source: projects/specs/trunk/e/elfutils/elfutils-vl.spec @ 10025

Revision 10025, 26.7 KB checked in by Takemikaduchi, 8 years ago (diff)

python,python3,thunderbird,wine: new upstream release
mesa: create compat32-mesa-dri-drivers subpackage
others: create compat32 subpackage

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define eu_version 0.161
4%define eu_release 2
5
6%global nocheck true
7
8Summary: A collection of utilities and DSOs to handle compiled objects
9Summary(ja): コンパイル済みオブジェクトを扱うためのユーティリティ集
10Name: elfutils
11Version: %{eu_version}
12Release: %{eu_release}%{?_dist_release}
13
14License: GPLv3+ and (GPLv2+ or LGPLv3+)
15Group: Development/Tools
16URL: https://fedorahosted.org/elfutils/
17
18Source: http://fedorahosted.org/releases/e/l/elfutils/%{name}-%{version}.tar.bz2
19
20#Patch1: elfutils-robustify.patch
21#Patch2: elfutils-portability.patch
22Patch1: elfutils-portability-%{version}.patch
23
24Patch2: elfutils-0.161-ar-long-name.patch
25# libdw: fix offset for sig8 lookup in dwarf_formref_die
26Patch3: elfutils-0.161-formref-type.patch
27# rhbz#1189928 - Consider sh_addralign 0 as 1
28Patch4: elfutils-0.161-addralign.patch
29
30##VINE##
31Patch10: elfutils-0.131-readelf_c.patch
32
33Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
34Requires: elfutils-libs-%{_arch} = %{version}-%{release}
35
36BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
37BuildRequires: bison >= 1.875
38BuildRequires: flex >= 2.5.4a
39BuildRequires: bzip2
40BuildRequires: bzip2-devel
41BuildRequires: zlib-devel
42BuildRequires: xz-devel
43BuildRequires: gettext
44BuildRequires: m4
45BuildRequires: gcc >= 3.4
46# Need <byteswap.h> that gives unsigned bswap_16 etc.
47BuildRequires: glibc-headers >= 2.3.4-11
48
49%define _gnu %{nil}
50%define _program_prefix eu-
51
52%description
53Elfutils is a collection of utilities, including ld (a linker),
54nm (for listing symbols from object files), size (for listing the
55section sizes of an object or archive file), strip (for discarding
56symbols), readelf (to see the raw ELF file structures), and elflint
57(to check for well-formed ELF files).
58
59
60%package libs
61Summary: Libraries to handle compiled objects
62Summary(ja): コンパイル済オブジェクトを扱うためのライブラリ
63License: GPLv2+ or LGPLv3+
64Group: System Environment/Libraries
65Provides: elfutils-libs-%{_arch} = %{version}-%{release}
66Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
67Conflicts: elfutils < %{version}-%{release}
68Conflicts: elfutils > %{version}-%{release}
69Conflicts: elfutils-devel < %{version}-%{release}
70Conflicts: elfutils-devel > %{version}-%{release}
71
72%description libs
73The elfutils-libs package contains libraries which implement DWARF, ELF,
74and machine-specific ELF handling.  These libraries are used by the programs
75in the elfutils package.  The elfutils-devel package enables building
76other programs using these libraries.
77
78
79%package devel
80Summary: Development libraries to handle compiled objects
81Summary(ja): コンパイル済オブジェクトを扱うための開発用ライブラリ
82License: GPLv2+ or LGPLv3+
83Group: Development/Libraries
84Provides: elfutils-devel-%{_arch} = %{version}-%{release}
85Requires: elfutils-libs-%{_arch} = %{version}-%{release}
86Requires: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
87Conflicts: elfutils-libelf-devel < %{version}-%{release}
88Conflicts: elfutils-libelf-devel > %{version}-%{release}
89
90%description devel
91The elfutils-devel package contains the libraries to create
92applications for handling compiled objects.  libebl provides some
93higher-level ELF access functionality.  libdw provides access to
94the DWARF debugging information.  libasm provides a programmable
95assembler interface.
96
97
98%package devel-static
99Summary: Static archives to handle compiled objects
100Summary(ja): コンパイル済オブジェクトを扱うための静的ライブラリ
101License: GPLv2+ or LGPLv3+
102Group: Development/Libraries
103Provides: elfutils-devel-static-%{_arch} = %{version}-%{release}
104Requires: elfutils-devel-%{_arch} = %{version}-%{release}
105Requires: elfutils-libelf-devel-static-%{_arch} = %{version}-%{release}
106Conflicts: elfutils-libelf-devel < %{version}-%{release}
107Conflicts: elfutils-libelf-devel > %{version}-%{release}
108
109%description devel-static
110The elfutils-devel-static package contains the static archives
111with the code to handle compiled objects.
112
113
114%package libelf
115Summary: Library to read and write ELF files
116Summary(ja): ELF ファイルを読み書きするためのライブラリ
117License: GPLv2+ or LGPLv3+
118Group: System Environment/Libraries
119Provides: libelf = %{version}-%{release}
120Obsoletes: libelf <= 0.8.2-2
121Provides: elfutils-libelf-%{_arch} = %{version}-%{release}
122Conflicts: elfutils < %{version}-%{release}
123Conflicts: elfutils > %{version}-%{release}
124Conflicts: elfutils-libs < %{version}-%{release}
125Conflicts: elfutils-libs > %{version}-%{release}
126Conflicts: elfutils-libelf-devel < %{version}-%{release}
127Conflicts: elfutils-libelf-devel > %{version}-%{release}
128
129%description libelf
130The elfutils-libelf package provides a DSO which allows reading and
131writing ELF files on a high level.  Third party programs depend on
132this package to read internals of ELF files.  The programs of the
133elfutils package use it also to generate new ELF files.
134
135
136%package libelf-devel
137Summary: Development support for libelf
138Summary(ja): libelf の開発用ライブラリ
139License: GPLv2+ or LGPLv3+
140Group: Development/Libraries
141Provides: libelf-devel = %{version}-%{release}
142Obsoletes: libelf-devel <= 0.8.2-2
143Provides: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
144Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
145Conflicts: libelf-devel < %{version}-%{release}
146
147%description libelf-devel
148The elfutils-libelf-devel package contains the libraries to create
149applications for handling compiled objects.  libelf allows you to
150access the internals of the ELF object file format, so you can see the
151different sections of an ELF file.
152
153
154%package libelf-devel-static
155Summary: Static archive of libelf
156Summary(ja): libelf の静的ライブラリ
157License: GPLv2+ or LGPLv3+
158Group: Development/Libraries
159Provides: elfutils-libelf-devel-static-%{_arch} = %{version}-%{release}
160Requires: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
161
162%description libelf-devel-static
163The elfutils-libelf-static package contains the static archive
164for libelf.
165
166
167# compat32
168%package -n compat32-%{name}-libelf
169Summary: Library to read and write ELF files
170Summary(ja): ELF ファイルを読み書きするためのライブラリ
171License: GPLv2+ or LGPLv3+
172Group: System Environment/Libraries
173Provides: compat32-libelf = %{version}-%{release}
174
175%description -n compat32-%{name}-libelf
176The elfutils-libelf package provides a DSO which allows reading and
177writing ELF files on a high level.  Third party programs depend on
178this package to read internals of ELF files.  The programs of the
179elfutils package use it also to generate new ELF files.
180
181%prep
182%setup -q
183#patch1 -p1 -b .robustify
184%patch1 -p1 -b .portability
185
186%patch2 -p1 -b .ar_long_name
187%patch3 -p1 -b .formref_type
188%patch4 -p1 -b .addralign
189
190%patch10 -p0 -b .readelf_c
191
192find . -name \*.sh ! -perm -0100 -print | xargs chmod +x
193
194
195%build
196# Remove -Wall from default flags.  The makefiles enable enough warnings
197# themselves, and they use -Werror.  Appending -Wall defeats the cases where
198# the makefiles disable some specific warnings for specific code.
199RPM_OPT_FLAGS=${RPM_OPT_FLAGS/-Wall/}
200
201%configure CFLAGS="$RPM_OPT_FLAGS -fexceptions"
202make -s %{?_smp_mflags}
203
204
205%install
206rm -rf ${RPM_BUILD_ROOT}
207make -s install DESTDIR=${RPM_BUILD_ROOT}
208
209chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/lib*.so*
210chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/elfutils/lib*.so*
211
212%find_lang %{name}
213
214# XXX Nuke unpackaged files
215{ cd ${RPM_BUILD_ROOT}
216  rm -f .%{_bindir}/eu-ld
217}
218
219
220
221%check
222make -s %{?_smp_mflags} check || (cat tests/test-suite.log; %{nocheck})
223
224
225%clean
226rm -rf ${RPM_BUILD_ROOT}
227
228
229%post libs -p /sbin/ldconfig
230
231%postun libs -p /sbin/ldconfig
232
233%post libelf -p /sbin/ldconfig
234
235%postun libelf -p /sbin/ldconfig
236
237%post -n compat32-%{name}-libelf -p /sbin/ldconfig
238
239%postun -n compat32-%{name}-libelf -p /sbin/ldconfig
240
241
242%files -f %{name}.lang
243%defattr(-,root,root)
244%doc README TODO
245%{_bindir}/eu-addr2line
246%{_bindir}/eu-ar
247%{_bindir}/eu-elfcmp
248%{_bindir}/eu-elflint
249%{_bindir}/eu-findtextrel
250%{_bindir}/eu-nm
251%{_bindir}/eu-objdump
252%{_bindir}/eu-ranlib
253%{_bindir}/eu-readelf
254%{_bindir}/eu-size
255%{_bindir}/eu-stack
256%{_bindir}/eu-strings
257%{_bindir}/eu-strip
258#%{_bindir}/eu-ld
259%{_bindir}/eu-unstrip
260%{_bindir}/eu-make-debug-archive
261
262
263%files libs
264%defattr(-,root,root)
265%{_libdir}/libasm-%{version}.so
266%{_libdir}/libasm.so.*
267%{_libdir}/libdw-%{version}.so
268%{_libdir}/libdw.so.*
269%dir %{_libdir}/elfutils
270%{_libdir}/elfutils/lib*.so
271
272
273%files devel
274%defattr(-,root,root)
275%{_includedir}/dwarf.h
276%dir %{_includedir}/elfutils
277%{_includedir}/elfutils/elf-knowledge.h
278%{_includedir}/elfutils/libasm.h
279%{_includedir}/elfutils/libebl.h
280%{_includedir}/elfutils/libdw.h
281%{_includedir}/elfutils/libdwelf.h
282%{_includedir}/elfutils/libdwfl.h
283%{_includedir}/elfutils/version.h
284%{_libdir}/libebl.a
285%{_libdir}/libasm.so
286%{_libdir}/libdw.so
287
288
289%files devel-static
290%defattr(-,root,root)
291%{_libdir}/libasm.a
292%{_libdir}/libdw.a
293
294
295%files libelf
296%defattr(-,root,root)
297%{_libdir}/libelf-%{version}.so
298%{_libdir}/libelf.so.*
299
300
301%files libelf-devel
302%defattr(-,root,root)
303%{_includedir}/libelf.h
304%{_includedir}/gelf.h
305%{_includedir}/nlist.h
306%{_libdir}/libelf.so
307
308
309%files libelf-devel-static
310%defattr(-,root,root)
311%{_libdir}/libelf.a
312
313%if %{build_compat32}
314%files -n compat32-%{name}-libelf
315%defattr(-,root,root)
316%{_libdir}/libelf-%{version}.so
317%{_libdir}/libelf.so.*
318%endif
319
320
321%changelog
322* Sat Feb 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.161-2
323- create compat32-elfutils-libelf subpackage
324
325* Fri Feb 20 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.161-1
326- update to 0.161
327- added Japanese summary
328
329* Mon Oct 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 0.157-1
330- update to 0.157
331
332* Wed Apr 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.152-2
333- add BR: zlib-devel, bzip2-devel, xz-devel, m4, gettext
334
335* Tue Apr 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.152-1
336- update to 0.152
337
338* Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.135-2
339- elfutils-libs: changed Group to System Environment/Libraries
340- elfutils-libelf: changed Group to System Environment/Libraries
341- elfutils-devel: changed Group to Development/Libraries
342- elfutils-devel-static: changed Group to Development/Libraries
343- elfutils-libelf-devel: changed Group to Development/Libraries
344- elfutils-libelf-devel-static: changed Group to Development/Libraries
345
346* Mon Sep 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.135-1
347- merged with Fedora 9 0.135-1
348
349  - Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 0.131-1vl5
350  - applied new versioning policy
351  - added elfutils-0.131-readelf_c.patch
352
353  - Thu Nov 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.131-0vl1
354  - new upstream release
355  - move libelf/libelf-devel obsoletes tag (<BTS:0568>)
356    - remove Obsoletes: libelf, libelf-devel from elfutils
357    - add Obsoletes: libelf to elfutils-libelf
358    - add Obsoletes: libelf-devel to elfutils-libelf-devel
359
360* Mon May 12 2008 Roland McGrath <roland@redhat.com> - 0.135-1
361- Update to 0.135
362  - libdwfl: bug fixes
363  - eu-strip: changed handling of ET_REL files wrt symbol tables and relocs
364
365* Wed Apr  9 2008 Roland McGrath <roland@redhat.com> - 0.134-1
366- Update to 0.134
367  - elflint: backend improvements for sparc, alpha (#204170)
368  - libdwfl, libelf: bug fixes (#439344, #438867, #438263, #438190)
369- Remove Conflicts: libelf-devel from elfutils-libelf-devel. (#435742)
370
371* Sun Mar  2 2008 Roland McGrath <roland@redhat.com> - 0.133-2
372- Update to 0.133
373  - readelf, elflint, libebl: SHT_GNU_ATTRIBUTE section handling (readelf -A)
374  - readelf: core note handling for NT_386_TLS, NT_PPC_SPE, Alpha NT_AUXV
375  - libdwfl: bug fixes and optimization in relocation handling
376  - elfcmp: bug fix for non-allocated section handling
377  - ld: implement newer features of binutils linker.
378- Install eu-objdump and libasm, now has limited disassembler support.
379
380* Mon Jan 21 2008 Roland McGrath <roland@redhat.com> - 0.132-3
381- Update to 0.132
382  - libelf: Use loff_t instead of off64_t in libelf.h header. (#377241)
383  - eu-readelf: Fix handling of ET_REL files in archives.
384  - libcpu: Implement x86 and x86-64 disassembler.
385  - libasm: Add interface for disassembler.
386  - all programs: add debugging of branch prediction.
387  - libelf: new function elf_scnshndx.
388
389* Sun Nov 11 2007 Roland McGrath <roland@redhat.com> - 0.131-1
390- Update to 0.131
391  - libdw: DW_FORM_ref_addr support; dwarf_formref entry point now deprecated;
392           bug fixes for oddly-formatted DWARF
393  - libdwfl: bug fixes in offline archive support, symbol table handling;
394             apply partial relocations for dwfl_module_address_section on ET_REL
395  - libebl: powerpc backend support for Altivec registers
396
397* Wed Oct 17 2007 Roland McGrath <roland@redhat.com> - 0.130-3
398- Fix ET_REL support.
399- Fix odd indentation in eu-readelf -x output.
400
401* Tue Oct 16 2007 Roland McGrath <roland@redhat.com> - 0.130-1
402- Update to 0.130
403  - eu-readelf -p option can take an argument like -x for one section
404  - eu-readelf --archive-index (or -c)
405  - eu-readelf -n improved output for core dumps
406  - eu-readelf: handle SHT_NOTE sections without requiring phdrs (#249467)
407  - eu-elflint: ditto
408  - eu-elflint: stricter checks on debug sections
409  - eu-unstrip: new options, --list (or -n), --relocate (or -R)
410  - libelf: new function elf_getdata_rawchunk, replaces gelf_rawchunk;
411            new functions gelf_getnote, gelf_getauxv, gelf_update_auxv
412  - libebl: backend improvements (#324031)
413  - libdwfl: build_id support, new functions for it
414  - libdwfl: dwfl_module_addrsym fixes (#268761, #268981)
415  - libdwfl offline archive support, new script eu-make-debug-archive
416
417* Mon Aug 20 2007 Roland McGrath <roland@redhat.com> - 0.129-2
418- Fix false-positive eu-elflint failure on ppc -mbss-plt binaries.
419
420* Tue Aug 14 2007 Roland McGrath <roland@redhat.com> - 0.129-1
421- Update to 0.129
422  - readelf: new options --hex-dump (or -x), --strings (or -p) (#250973)
423  - addr2line: new option --symbols (or -S)
424  - libdw: dwarf_getscopes fixes (#230235)
425  - libdwfl: dwfl_module_addrsym fixes (#249490)
426
427* Fri Jun  8 2007 Roland McGrath <roland@redhat.com> - 0.128-2
428- Update to 0.128
429  - new program: unstrip
430  - elfcmp: new option --hash-inexact
431- Replace Conflicts: with Provides/Requires using -arch
432
433* Wed Apr 18 2007 Roland McGrath <roland@redhat.com> - 0.127-1
434- Update to 0.127
435  - libdw: new function dwarf_getsrcdirs
436  - libdwfl: new functions dwfl_module_addrsym, dwfl_report_begin_add,
437             dwfl_module_address_section
438
439* Mon Feb  5 2007 Roland McGrath <roland@redhat.com> - 0.126-1
440- Update to 0.126
441  - New program eu-ar.
442  - libdw: fix missing dwarf_getelf (#227206)
443  - libdwfl: dwfl_module_addrname for st_size=0 symbols (#227167, #227231)
444- Resolves: RHBZ #227206, RHBZ #227167, RHBZ #227231
445
446* Wed Jan 10 2007 Roland McGrath <roland@redhat.com> - 0.125-3
447- Fix overeager warn_unused_result build failures.
448
449* Wed Jan 10 2007 Roland McGrath <roland@redhat.com> - 0.125-1
450- Update to 0.125
451  - elflint: Compare DT_GNU_HASH tests.
452  - move archives into -static RPMs
453  - libelf, elflint: better support for core file handling
454  - Really fix libdwfl sorting of modules with 64-bit addresses (#220817).
455- Resolves: RHBZ #220817, RHBZ #213792
456
457* Tue Oct 10 2006 Roland McGrath <roland@redhat.com> - 0.124-1
458- eu-strip -f: copy symtab into debuginfo file when relocs use it (#203000)
459- Update to 0.124
460  - libebl: fix ia64 reloc support (#206981)
461  - libebl: sparc backend support for return value location
462  - libebl, libdwfl: backend register name support extended with more info
463  - libelf, libdw: bug fixes for unaligned accesses on machines that care
464  - readelf, elflint: trivial bugs fixed
465
466* Mon Aug 14 2006 Roland McGrath <roland@redhat.com> 0.123-1
467- Update to 0.123
468  - libebl: Backend build fixes, thanks to Stepan Kasal.
469  - libebl: ia64 backend support for register names, return value location
470  - libdwfl: Handle truncated linux kernel module section names.
471  - libdwfl: Look for linux kernel vmlinux files with .debug suffix.
472  - elflint: Fix checks to permit --hash-style=gnu format.
473
474* Mon Jul 17 2006 Roland McGrath <roland@redhat.com> - 0.122-4
475- Fix warnings in elflint compilation.
476
477* Wed Jul 12 2006 Roland McGrath <roland@redhat.com> - 0.122-3
478- Update to 0.122
479  - Fix libdwfl sorting of modules with 64-bit addresses (#198225).
480  - libebl: add function to test for relative relocation
481  - elflint: fix and extend DT_RELCOUNT/DT_RELACOUNT checks
482  - elflint, readelf: add support for DT_GNU_HASH
483  - libelf: add elf_gnu_hash
484  - elflint, readelf: add support for 64-bit SysV-style hash tables
485  - libdwfl: new functions dwfl_module_getsymtab, dwfl_module_getsym.
486
487* Thu Jun 15 2006 Roland McGrath <roland@redhat.com> - 0.121-1
488- Update to 0.121
489  - libelf: bug fixes for rewriting existing files when using mmap (#187618).
490  - make all installed headers usable in C++ code (#193153).
491  - eu-readelf: better output format.
492  - eu-elflint: fix tests of dynamic section content.
493  - libdw, libdwfl: handle files without aranges info.
494
495* Thu May 25 2006 Jeremy Katz <katzj@redhat.com> - 0.120-3
496- rebuild to pick up -devel deps
497
498* Tue Apr  4 2006 Roland McGrath <roland@redhat.com> - 0.120-2
499- Update to 0.120
500  - License changed to GPL, with some exceptions for using
501    the libelf, libebl, libdw, and libdwfl library interfaces.
502    Red Hat elfutils is an included package of the Open Invention Network.
503  - dwarf.h updated for DWARF 3.0 final specification.
504  - libelf: Fix corruption in ELF_C_RDWR uses (#187618).
505  - libdwfl: New function dwfl_version; fixes for offline.
506
507* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.119-1.2.1
508- bump again for double-long bug on ppc(64)
509
510* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.119-1.2
511- rebuilt for new gcc4.1 snapshot and glibc changes
512
513* Fri Jan 13 2006 Roland McGrath <roland@redhat.com> - 0.119-1
514- update to 0.119
515
516* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
517- rebuilt
518
519* Sun Nov 27 2005 Roland McGrath <roland@redhat.com> - 0.118-1
520- update to 0.118
521  - elflint: more tests.
522  - libdwfl: New function dwfl_module_register_names.
523  - libebl: New backend hook for register names.
524- Make sure -fexceptions is always in CFLAGS.
525
526* Tue Nov 22 2005 Roland McGrath <roland@redhat.com> - 0.117-2
527- update to 0.117
528  - libdwfl: New function dwfl_module_return_value_location (#166118)
529  - libebl: Backend improvements for several CPUs
530
531* Mon Oct 31 2005 Roland McGrath <roland@redhat.com> - 0.116-1
532- update to 0.116
533  - libdw fixes, API changes and additions
534  - libdwfl fixes (#169672)
535  - eu-strip/libelf fix to preserve setuid/setgid permission bits (#167745)
536
537* Fri Sep  9 2005 Roland McGrath <roland@redhat.com> - 0.115-3
538- Update requires/conflicts for better biarch update behavior.
539
540* Mon Sep  5 2005 Roland McGrath <roland@redhat.com> - 0.115-2
541- update to 0.115
542  - New program eu-strings.
543  - libdw: New function dwarf_getscopes_die.
544  - libelf: speed-ups of non-mmap reading.
545  - Implement --enable-gcov option for configure.
546
547* Wed Aug 24 2005 Roland McGrath <roland@redhat.com> - 0.114-1
548- update to 0.114
549  - new program eu-ranlib
550  - libdw: new calls for inlines
551  - libdwfl: new calls for offline modules
552
553* Sat Aug 13 2005 Roland McGrath <roland@redhat.com> - 0.113-2
554- update to 0.113
555  - elflint: relax a bit.  Allow version definitions for defined symbols
556    against DSO versions also for symbols in nobits sections.
557    Allow .rodata section to have STRINGS and MERGE flag set.
558  - strip: add some more compatibility with binutils.
559  - libdwfl: bug fixes.
560- Separate libdw et al into elfutils-libs subpackage.
561
562* Sat Aug  6 2005 Roland McGrath <roland@redhat.com> - 0.112-1
563- update to 0.112
564  - elfcmp: some more relaxation.
565  - elflint: many more tests, especially regarding to symbol versioning.
566  - libelf: Add elfXX_offscn and gelf_offscn.
567  - libasm: asm_begin interface changes.
568  - libebl: Add three new interfaces to directly access machine, class,
569    and data encoding information.
570
571* Fri Jul 29 2005 Roland McGrath <roland@redhat.com> - 0.111-2
572- update portability patch
573
574* Thu Jul 28 2005 Roland McGrath <roland@redhat.com> - 0.111-1
575- update to 0.111
576  - libdwfl library now merged into libdw
577
578* Sun Jul 24 2005 Roland McGrath <roland@redhat.com> - 0.110-1
579- update to 0.110
580
581* Fri Jul 22 2005 Roland McGrath <roland@redhat.com> - 0.109-2
582- update to 0.109
583  - verify that libebl modules are from the same build
584  - new eu-elflint checks on copy relocations
585  - new program eu-elfcmp
586  - new experimental libdwfl library
587
588* Thu Jun  9 2005 Roland McGrath <roland@redhat.com> - 0.108-5
589- robustification of eu-strip and eu-readelf
590
591* Wed May 25 2005 Roland McGrath <roland@redhat.com> - 0.108-3
592- more robustification
593
594* Mon May 16 2005 Roland McGrath <roland@redhat.com> - 0.108-2
595- robustification
596
597* Mon May  9 2005 Roland McGrath <roland@redhat.com> - 0.108-1
598- update to 0.108
599  - merge strip fixes
600  - sort records in dwarf_getsrclines, fix dwarf_getsrc_die searching
601  - update elf.h from glibc
602
603* Sun May  8 2005 Roland McGrath <roland@redhat.com> - 0.107-2
604- fix strip -f byte-swapping bug
605
606* Sun May  8 2005 Roland McGrath <roland@redhat.com> - 0.107-1
607- update to 0.107
608  - readelf: improve DWARF output format
609  - elflint: -d option to support checking separate debuginfo files
610  - strip: fix ET_REL debuginfo files (#156341)
611
612* Mon Apr  4 2005 Roland McGrath <roland@redhat.com> - 0.106-3
613- fix some bugs in new code, reenable make check
614
615* Mon Apr  4 2005 Roland McGrath <roland@redhat.com> - 0.106-2
616- disable make check for most arches, for now
617
618* Mon Apr  4 2005 Roland McGrath <roland@redhat.com> - 0.106-1
619- update to 0.106
620
621* Mon Mar 28 2005 Roland McGrath <roland@redhat.com> - 0.104-2
622- update to 0.104
623
624* Wed Mar 23 2005 Jakub Jelinek <jakub@redhat.com> 0.103-2
625- update to 0.103
626
627* Wed Feb 16 2005 Jakub Jelinek <jakub@redhat.com> 0.101-2
628- update to 0.101.
629- use %%configure macro to get CFLAGS etc. right
630
631* Sat Feb  5 2005 Jeff Johnson <jbj@redhat.com> 0.99-2
632- upgrade to 0.99.
633
634* Sun Sep 26 2004 Jeff Johnson <jbj@redhat.com> 0.97-3
635- upgrade to 0.97.
636
637* Tue Aug 17 2004 Jakub Jelinek <jakub@redhat.com> 0.95-5
638- upgrade to 0.96.
639
640* Mon Jul  5 2004 Jakub Jelinek <jakub@redhat.com> 0.95-4
641- rebuilt with GCC 3.4.x, workaround VLA + alloca mixing
642  warning
643
644* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
645- rebuilt
646
647* Fri Apr  2 2004 Jeff Johnson <jbj@redhat.com> 0.95-2
648- upgrade to 0.95.
649
650* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
651- rebuilt
652
653* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
654- rebuilt
655
656* Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.94-1
657- upgrade to 0.94
658
659* Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.93-1
660- upgrade to 0.93
661
662* Thu Jan  8 2004 Jakub Jelinek <jakub@redhat.com> 0.92-1
663- full version
664- macroized spec file for GPL or OSL builds
665- include only libelf under GPL plus wrapper scripts
666
667* Wed Jan  7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-2
668- macroized spec file for GPL or OSL builds
669
670* Wed Jan  7 2004 Ulrich Drepper <drepper@redhat.com>
671- split elfutils-devel into two packages.
672
673* Wed Jan  7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-1
674- include only libelf under GPL plus wrapper scripts
675
676* Tue Dec 23 2003 Jeff Johnson <jbj@redhat.com> 0.89-3
677- readelf, not readline, in %%description (#111214).
678
679* Fri Sep 26 2003 Bill Nottingham <notting@redhat.com> 0.89-1
680- update to 0.89 (fix eu-strip)
681
682* Tue Sep 23 2003 Jakub Jelinek <jakub@redhat.com> 0.86-3
683- update to 0.86 (fix eu-strip on s390x/alpha)
684- libebl is an archive now; remove references to DSO
685
686* Mon Jul 14 2003 Jeff Johnson <jbj@redhat.com> 0.84-3
687- upgrade to 0.84 (readelf/elflint improvements, rawhide bugs fixed).
688
689* Fri Jul 11 2003 Jeff Johnson <jbj@redhat.com> 0.83-3
690- upgrade to 0.83 (fix invalid ELf handle on *.so strip, more).
691
692* Wed Jul  9 2003 Jeff Johnson <jbj@redhat.com> 0.82-3
693- upgrade to 0.82 (strip tests fixed on big-endian).
694
695* Tue Jul  8 2003 Jeff Johnson <jbj@redhat.com> 0.81-3
696- upgrade to 0.81 (strip excludes unused symtable entries, test borked).
697
698* Thu Jun 26 2003 Jeff Johnson <jbj@redhat.com> 0.80-3
699- upgrade to 0.80 (debugedit changes for kernel in progress).
700
701* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
702- rebuilt
703
704* Wed May 21 2003 Jeff Johnson <jbj@redhat.com> 0.79-2
705- upgrade to 0.79 (correct formats for size_t, more of libdw "works").
706
707* Mon May 19 2003 Jeff Johnson <jbj@redhat.com> 0.78-2
708- upgrade to 0.78 (libdwarf bugfix, libdw additions).
709
710* Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
711- debuginfo rebuild
712
713* Thu Feb 20 2003 Jeff Johnson <jbj@redhat.com> 0.76-2
714- use the correct way of identifying the section via the sh_info link.
715
716* Sat Feb 15 2003 Jakub Jelinek <jakub@redhat.com> 0.75-2
717- update to 0.75 (eu-strip -g fix)
718
719* Tue Feb 11 2003 Jakub Jelinek <jakub@redhat.com> 0.74-2
720- update to 0.74 (fix for writing with some non-dirty sections)
721
722* Thu Feb  6 2003 Jeff Johnson <jbj@redhat.com> 0.73-3
723- another -0.73 update (with sparc fixes).
724- do "make check" in %%check, not %%install, section.
725
726* Mon Jan 27 2003 Jeff Johnson <jbj@redhat.com> 0.73-2
727- update to 0.73 (with s390 fixes).
728
729* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
730- rebuilt
731
732* Wed Jan 22 2003 Jakub Jelinek <jakub@redhat.com> 0.72-4
733- fix arguments to gelf_getsymshndx and elf_getshstrndx
734- fix other warnings
735- reenable checks on s390x
736
737* Sat Jan 11 2003 Karsten Hopp <karsten@redhat.de> 0.72-3
738- temporarily disable checks on s390x, until someone has
739  time to look at it
740
741* Thu Dec 12 2002 Jakub Jelinek <jakub@redhat.com> 0.72-2
742- update to 0.72
743
744* Wed Dec 11 2002 Jakub Jelinek <jakub@redhat.com> 0.71-2
745- update to 0.71
746
747* Wed Dec 11 2002 Jeff Johnson <jbj@redhat.com> 0.69-4
748- update to 0.69.
749- add "make check" and segfault avoidance patch.
750- elfutils-libelf needs to run ldconfig.
751
752* Tue Dec 10 2002 Jeff Johnson <jbj@redhat.com> 0.68-2
753- update to 0.68.
754
755* Fri Dec  6 2002 Jeff Johnson <jbj@redhat.com> 0.67-2
756- update to 0.67.
757
758* Tue Dec  3 2002 Jeff Johnson <jbj@redhat.com> 0.65-2
759- update to 0.65.
760
761* Mon Dec  2 2002 Jeff Johnson <jbj@redhat.com> 0.64-2
762- update to 0.64.
763
764* Sun Dec 1 2002 Ulrich Drepper <drepper@redhat.com> 0.64
765- split packages further into elfutils-libelf
766
767* Sat Nov 30 2002 Jeff Johnson <jbj@redhat.com> 0.63-2
768- update to 0.63.
769
770* Fri Nov 29 2002 Ulrich Drepper <drepper@redhat.com> 0.62
771- Adjust for dropping libtool
772
773* Sun Nov 24 2002 Jeff Johnson <jbj@redhat.com> 0.59-2
774- update to 0.59
775
776* Thu Nov 14 2002 Jeff Johnson <jbj@redhat.com> 0.56-2
777- update to 0.56
778
779* Thu Nov  7 2002 Jeff Johnson <jbj@redhat.com> 0.54-2
780- update to 0.54
781
782* Sun Oct 27 2002 Jeff Johnson <jbj@redhat.com> 0.53-2
783- update to 0.53
784- drop x86_64 hack, ICE fixed in gcc-3.2-11.
785
786* Sat Oct 26 2002 Jeff Johnson <jbj@redhat.com> 0.52-3
787- get beehive to punch a rhpkg generated package.
788
789* Wed Oct 23 2002 Jeff Johnson <jbj@redhat.com> 0.52-2
790- build in 8.0.1.
791- x86_64: avoid gcc-3.2 ICE on x86_64 for now.
792
793* Tue Oct 22 2002 Ulrich Drepper <drepper@redhat.com> 0.52
794- Add libelf-devel to conflicts for elfutils-devel
795
796* Mon Oct 21 2002 Ulrich Drepper <drepper@redhat.com> 0.50
797- Split into runtime and devel package
798
799* Fri Oct 18 2002 Ulrich Drepper <drepper@redhat.com> 0.49
800- integrate into official sources
801
802* Wed Oct 16 2002 Jeff Johnson <jbj@redhat.com> 0.46-1
803- Swaddle.
Note: See TracBrowser for help on using the repository browser.