source: projects/specs/trunk/e/elfutils/elfutils-vl.spec @ 9365

Revision 9365, 25.7 KB checked in by inagaki, 9 years ago (diff)

2015-02-20 Ryoichi INAGAKI <ryo1@…>

  • eblook, gtranslator, rpmver: rebuilt
  • elfutils, freeglut: updated


Line 
1%define eu_version 0.161
2%define eu_release 1
3
4%global nocheck true
5
6Summary: A collection of utilities and DSOs to handle compiled objects
7Summary(ja): コンパイル済みオブジェクトを扱うためのユーティリティ集
8Name: elfutils
9Version: %{eu_version}
10Release: %{eu_release}%{?_dist_release}
11
12License: GPLv3+ and (GPLv2+ or LGPLv3+)
13Group: Development/Tools
14URL: https://fedorahosted.org/elfutils/
15
16Source: http://fedorahosted.org/releases/e/l/elfutils/%{name}-%{version}.tar.bz2
17
18#Patch1: elfutils-robustify.patch
19#Patch2: elfutils-portability.patch
20Patch1: elfutils-portability-%{version}.patch
21
22Patch2: elfutils-0.161-ar-long-name.patch
23# libdw: fix offset for sig8 lookup in dwarf_formref_die
24Patch3: elfutils-0.161-formref-type.patch
25# rhbz#1189928 - Consider sh_addralign 0 as 1
26Patch4: elfutils-0.161-addralign.patch
27
28##VINE##
29Patch10: elfutils-0.131-readelf_c.patch
30
31Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
32Requires: elfutils-libs-%{_arch} = %{version}-%{release}
33
34BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
35BuildRequires: bison >= 1.875
36BuildRequires: flex >= 2.5.4a
37BuildRequires: bzip2
38BuildRequires: bzip2-devel
39BuildRequires: zlib-devel
40BuildRequires: xz-devel
41BuildRequires: gettext
42BuildRequires: m4
43BuildRequires: gcc >= 3.4
44# Need <byteswap.h> that gives unsigned bswap_16 etc.
45BuildRequires: glibc-headers >= 2.3.4-11
46
47%define _gnu %{nil}
48%define _program_prefix eu-
49
50%description
51Elfutils is a collection of utilities, including ld (a linker),
52nm (for listing symbols from object files), size (for listing the
53section sizes of an object or archive file), strip (for discarding
54symbols), readelf (to see the raw ELF file structures), and elflint
55(to check for well-formed ELF files).
56
57
58%package libs
59Summary: Libraries to handle compiled objects
60Summary(ja): コンパイル済オブジェクトを扱うためのライブラリ
61License: GPLv2+ or LGPLv3+
62Group: System Environment/Libraries
63Provides: elfutils-libs-%{_arch} = %{version}-%{release}
64Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
65Conflicts: elfutils < %{version}-%{release}
66Conflicts: elfutils > %{version}-%{release}
67Conflicts: elfutils-devel < %{version}-%{release}
68Conflicts: elfutils-devel > %{version}-%{release}
69
70%description libs
71The elfutils-libs package contains libraries which implement DWARF, ELF,
72and machine-specific ELF handling.  These libraries are used by the programs
73in the elfutils package.  The elfutils-devel package enables building
74other programs using these libraries.
75
76
77%package devel
78Summary: Development libraries to handle compiled objects
79Summary(ja): コンパイル済オブジェクトを扱うための開発用ライブラリ
80License: GPLv2+ or LGPLv3+
81Group: Development/Libraries
82Provides: elfutils-devel-%{_arch} = %{version}-%{release}
83Requires: elfutils-libs-%{_arch} = %{version}-%{release}
84Requires: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
85Conflicts: elfutils-libelf-devel < %{version}-%{release}
86Conflicts: elfutils-libelf-devel > %{version}-%{release}
87
88%description devel
89The elfutils-devel package contains the libraries to create
90applications for handling compiled objects.  libebl provides some
91higher-level ELF access functionality.  libdw provides access to
92the DWARF debugging information.  libasm provides a programmable
93assembler interface.
94
95
96%package devel-static
97Summary: Static archives to handle compiled objects
98Summary(ja): コンパイル済オブジェクトを扱うための静的ライブラリ
99License: GPLv2+ or LGPLv3+
100Group: Development/Libraries
101Provides: elfutils-devel-static-%{_arch} = %{version}-%{release}
102Requires: elfutils-devel-%{_arch} = %{version}-%{release}
103Requires: elfutils-libelf-devel-static-%{_arch} = %{version}-%{release}
104Conflicts: elfutils-libelf-devel < %{version}-%{release}
105Conflicts: elfutils-libelf-devel > %{version}-%{release}
106
107%description devel-static
108The elfutils-devel-static package contains the static archives
109with the code to handle compiled objects.
110
111
112%package libelf
113Summary: Library to read and write ELF files
114Summary(ja): ELF ファイルを読み書きするためのライブラリ
115License: GPLv2+ or LGPLv3+
116Group: System Environment/Libraries
117Provides: libelf = %{version}-%{release}
118Obsoletes: libelf <= 0.8.2-2
119Provides: elfutils-libelf-%{_arch} = %{version}-%{release}
120Conflicts: elfutils < %{version}-%{release}
121Conflicts: elfutils > %{version}-%{release}
122Conflicts: elfutils-libs < %{version}-%{release}
123Conflicts: elfutils-libs > %{version}-%{release}
124Conflicts: elfutils-libelf-devel < %{version}-%{release}
125Conflicts: elfutils-libelf-devel > %{version}-%{release}
126
127%description libelf
128The elfutils-libelf package provides a DSO which allows reading and
129writing ELF files on a high level.  Third party programs depend on
130this package to read internals of ELF files.  The programs of the
131elfutils package use it also to generate new ELF files.
132
133
134%package libelf-devel
135Summary: Development support for libelf
136Summary(ja): libelf の開発用ライブラリ
137License: GPLv2+ or LGPLv3+
138Group: Development/Libraries
139Provides: libelf-devel = %{version}-%{release}
140Obsoletes: libelf-devel <= 0.8.2-2
141Provides: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
142Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
143Conflicts: libelf-devel < %{version}-%{release}
144
145%description libelf-devel
146The elfutils-libelf-devel package contains the libraries to create
147applications for handling compiled objects.  libelf allows you to
148access the internals of the ELF object file format, so you can see the
149different sections of an ELF file.
150
151
152%package libelf-devel-static
153Summary: Static archive of libelf
154Summary(ja): libelf の静的ライブラリ
155License: GPLv2+ or LGPLv3+
156Group: Development/Libraries
157Provides: elfutils-libelf-devel-static-%{_arch} = %{version}-%{release}
158Requires: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
159
160%description libelf-devel-static
161The elfutils-libelf-static package contains the static archive
162for libelf.
163
164
165%prep
166%setup -q
167#patch1 -p1 -b .robustify
168%patch1 -p1 -b .portability
169
170%patch2 -p1 -b .ar_long_name
171%patch3 -p1 -b .formref_type
172%patch4 -p1 -b .addralign
173
174%patch10 -p0 -b .readelf_c
175
176find . -name \*.sh ! -perm -0100 -print | xargs chmod +x
177
178
179%build
180# Remove -Wall from default flags.  The makefiles enable enough warnings
181# themselves, and they use -Werror.  Appending -Wall defeats the cases where
182# the makefiles disable some specific warnings for specific code.
183RPM_OPT_FLAGS=${RPM_OPT_FLAGS/-Wall/}
184
185%configure CFLAGS="$RPM_OPT_FLAGS -fexceptions"
186make -s %{?_smp_mflags}
187
188
189%install
190rm -rf ${RPM_BUILD_ROOT}
191make -s install DESTDIR=${RPM_BUILD_ROOT}
192
193chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/lib*.so*
194chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/elfutils/lib*.so*
195
196%find_lang %{name}
197
198# XXX Nuke unpackaged files
199{ cd ${RPM_BUILD_ROOT}
200  rm -f .%{_bindir}/eu-ld
201}
202
203
204
205%check
206make -s %{?_smp_mflags} check || (cat tests/test-suite.log; %{nocheck})
207
208
209%clean
210rm -rf ${RPM_BUILD_ROOT}
211
212
213%post libs -p /sbin/ldconfig
214
215%postun libs -p /sbin/ldconfig
216
217%post libelf -p /sbin/ldconfig
218
219%postun libelf -p /sbin/ldconfig
220
221
222%files -f %{name}.lang
223%defattr(-,root,root)
224%doc README TODO
225%{_bindir}/eu-addr2line
226%{_bindir}/eu-ar
227%{_bindir}/eu-elfcmp
228%{_bindir}/eu-elflint
229%{_bindir}/eu-findtextrel
230%{_bindir}/eu-nm
231%{_bindir}/eu-objdump
232%{_bindir}/eu-ranlib
233%{_bindir}/eu-readelf
234%{_bindir}/eu-size
235%{_bindir}/eu-stack
236%{_bindir}/eu-strings
237%{_bindir}/eu-strip
238#%{_bindir}/eu-ld
239%{_bindir}/eu-unstrip
240%{_bindir}/eu-make-debug-archive
241
242
243%files libs
244%defattr(-,root,root)
245%{_libdir}/libasm-%{version}.so
246%{_libdir}/libasm.so.*
247%{_libdir}/libdw-%{version}.so
248%{_libdir}/libdw.so.*
249%dir %{_libdir}/elfutils
250%{_libdir}/elfutils/lib*.so
251
252
253%files devel
254%defattr(-,root,root)
255%{_includedir}/dwarf.h
256%dir %{_includedir}/elfutils
257%{_includedir}/elfutils/elf-knowledge.h
258%{_includedir}/elfutils/libasm.h
259%{_includedir}/elfutils/libebl.h
260%{_includedir}/elfutils/libdw.h
261%{_includedir}/elfutils/libdwelf.h
262%{_includedir}/elfutils/libdwfl.h
263%{_includedir}/elfutils/version.h
264%{_libdir}/libebl.a
265%{_libdir}/libasm.so
266%{_libdir}/libdw.so
267
268
269%files devel-static
270%defattr(-,root,root)
271%{_libdir}/libasm.a
272%{_libdir}/libdw.a
273
274
275%files libelf
276%defattr(-,root,root)
277%{_libdir}/libelf-%{version}.so
278%{_libdir}/libelf.so.*
279
280
281%files libelf-devel
282%defattr(-,root,root)
283%{_includedir}/libelf.h
284%{_includedir}/gelf.h
285%{_includedir}/nlist.h
286%{_libdir}/libelf.so
287
288
289%files libelf-devel-static
290%defattr(-,root,root)
291%{_libdir}/libelf.a
292
293
294%changelog
295* Fri Feb 20 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.161-1
296- update to 0.161
297- added Japanese summary
298
299* Mon Oct 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 0.157-1
300- update to 0.157
301
302* Wed Apr 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.152-2
303- add BR: zlib-devel, bzip2-devel, xz-devel, m4, gettext
304
305* Tue Apr 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.152-1
306- update to 0.152
307
308* Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.135-2
309- elfutils-libs: changed Group to System Environment/Libraries
310- elfutils-libelf: changed Group to System Environment/Libraries
311- elfutils-devel: changed Group to Development/Libraries
312- elfutils-devel-static: changed Group to Development/Libraries
313- elfutils-libelf-devel: changed Group to Development/Libraries
314- elfutils-libelf-devel-static: changed Group to Development/Libraries
315
316* Mon Sep 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.135-1
317- merged with Fedora 9 0.135-1
318
319  - Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 0.131-1vl5
320  - applied new versioning policy
321  - added elfutils-0.131-readelf_c.patch
322
323  - Thu Nov 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.131-0vl1
324  - new upstream release
325  - move libelf/libelf-devel obsoletes tag (<BTS:0568>)
326    - remove Obsoletes: libelf, libelf-devel from elfutils
327    - add Obsoletes: libelf to elfutils-libelf
328    - add Obsoletes: libelf-devel to elfutils-libelf-devel
329
330* Mon May 12 2008 Roland McGrath <roland@redhat.com> - 0.135-1
331- Update to 0.135
332  - libdwfl: bug fixes
333  - eu-strip: changed handling of ET_REL files wrt symbol tables and relocs
334
335* Wed Apr  9 2008 Roland McGrath <roland@redhat.com> - 0.134-1
336- Update to 0.134
337  - elflint: backend improvements for sparc, alpha (#204170)
338  - libdwfl, libelf: bug fixes (#439344, #438867, #438263, #438190)
339- Remove Conflicts: libelf-devel from elfutils-libelf-devel. (#435742)
340
341* Sun Mar  2 2008 Roland McGrath <roland@redhat.com> - 0.133-2
342- Update to 0.133
343  - readelf, elflint, libebl: SHT_GNU_ATTRIBUTE section handling (readelf -A)
344  - readelf: core note handling for NT_386_TLS, NT_PPC_SPE, Alpha NT_AUXV
345  - libdwfl: bug fixes and optimization in relocation handling
346  - elfcmp: bug fix for non-allocated section handling
347  - ld: implement newer features of binutils linker.
348- Install eu-objdump and libasm, now has limited disassembler support.
349
350* Mon Jan 21 2008 Roland McGrath <roland@redhat.com> - 0.132-3
351- Update to 0.132
352  - libelf: Use loff_t instead of off64_t in libelf.h header. (#377241)
353  - eu-readelf: Fix handling of ET_REL files in archives.
354  - libcpu: Implement x86 and x86-64 disassembler.
355  - libasm: Add interface for disassembler.
356  - all programs: add debugging of branch prediction.
357  - libelf: new function elf_scnshndx.
358
359* Sun Nov 11 2007 Roland McGrath <roland@redhat.com> - 0.131-1
360- Update to 0.131
361  - libdw: DW_FORM_ref_addr support; dwarf_formref entry point now deprecated;
362           bug fixes for oddly-formatted DWARF
363  - libdwfl: bug fixes in offline archive support, symbol table handling;
364             apply partial relocations for dwfl_module_address_section on ET_REL
365  - libebl: powerpc backend support for Altivec registers
366
367* Wed Oct 17 2007 Roland McGrath <roland@redhat.com> - 0.130-3
368- Fix ET_REL support.
369- Fix odd indentation in eu-readelf -x output.
370
371* Tue Oct 16 2007 Roland McGrath <roland@redhat.com> - 0.130-1
372- Update to 0.130
373  - eu-readelf -p option can take an argument like -x for one section
374  - eu-readelf --archive-index (or -c)
375  - eu-readelf -n improved output for core dumps
376  - eu-readelf: handle SHT_NOTE sections without requiring phdrs (#249467)
377  - eu-elflint: ditto
378  - eu-elflint: stricter checks on debug sections
379  - eu-unstrip: new options, --list (or -n), --relocate (or -R)
380  - libelf: new function elf_getdata_rawchunk, replaces gelf_rawchunk;
381            new functions gelf_getnote, gelf_getauxv, gelf_update_auxv
382  - libebl: backend improvements (#324031)
383  - libdwfl: build_id support, new functions for it
384  - libdwfl: dwfl_module_addrsym fixes (#268761, #268981)
385  - libdwfl offline archive support, new script eu-make-debug-archive
386
387* Mon Aug 20 2007 Roland McGrath <roland@redhat.com> - 0.129-2
388- Fix false-positive eu-elflint failure on ppc -mbss-plt binaries.
389
390* Tue Aug 14 2007 Roland McGrath <roland@redhat.com> - 0.129-1
391- Update to 0.129
392  - readelf: new options --hex-dump (or -x), --strings (or -p) (#250973)
393  - addr2line: new option --symbols (or -S)
394  - libdw: dwarf_getscopes fixes (#230235)
395  - libdwfl: dwfl_module_addrsym fixes (#249490)
396
397* Fri Jun  8 2007 Roland McGrath <roland@redhat.com> - 0.128-2
398- Update to 0.128
399  - new program: unstrip
400  - elfcmp: new option --hash-inexact
401- Replace Conflicts: with Provides/Requires using -arch
402
403* Wed Apr 18 2007 Roland McGrath <roland@redhat.com> - 0.127-1
404- Update to 0.127
405  - libdw: new function dwarf_getsrcdirs
406  - libdwfl: new functions dwfl_module_addrsym, dwfl_report_begin_add,
407             dwfl_module_address_section
408
409* Mon Feb  5 2007 Roland McGrath <roland@redhat.com> - 0.126-1
410- Update to 0.126
411  - New program eu-ar.
412  - libdw: fix missing dwarf_getelf (#227206)
413  - libdwfl: dwfl_module_addrname for st_size=0 symbols (#227167, #227231)
414- Resolves: RHBZ #227206, RHBZ #227167, RHBZ #227231
415
416* Wed Jan 10 2007 Roland McGrath <roland@redhat.com> - 0.125-3
417- Fix overeager warn_unused_result build failures.
418
419* Wed Jan 10 2007 Roland McGrath <roland@redhat.com> - 0.125-1
420- Update to 0.125
421  - elflint: Compare DT_GNU_HASH tests.
422  - move archives into -static RPMs
423  - libelf, elflint: better support for core file handling
424  - Really fix libdwfl sorting of modules with 64-bit addresses (#220817).
425- Resolves: RHBZ #220817, RHBZ #213792
426
427* Tue Oct 10 2006 Roland McGrath <roland@redhat.com> - 0.124-1
428- eu-strip -f: copy symtab into debuginfo file when relocs use it (#203000)
429- Update to 0.124
430  - libebl: fix ia64 reloc support (#206981)
431  - libebl: sparc backend support for return value location
432  - libebl, libdwfl: backend register name support extended with more info
433  - libelf, libdw: bug fixes for unaligned accesses on machines that care
434  - readelf, elflint: trivial bugs fixed
435
436* Mon Aug 14 2006 Roland McGrath <roland@redhat.com> 0.123-1
437- Update to 0.123
438  - libebl: Backend build fixes, thanks to Stepan Kasal.
439  - libebl: ia64 backend support for register names, return value location
440  - libdwfl: Handle truncated linux kernel module section names.
441  - libdwfl: Look for linux kernel vmlinux files with .debug suffix.
442  - elflint: Fix checks to permit --hash-style=gnu format.
443
444* Mon Jul 17 2006 Roland McGrath <roland@redhat.com> - 0.122-4
445- Fix warnings in elflint compilation.
446
447* Wed Jul 12 2006 Roland McGrath <roland@redhat.com> - 0.122-3
448- Update to 0.122
449  - Fix libdwfl sorting of modules with 64-bit addresses (#198225).
450  - libebl: add function to test for relative relocation
451  - elflint: fix and extend DT_RELCOUNT/DT_RELACOUNT checks
452  - elflint, readelf: add support for DT_GNU_HASH
453  - libelf: add elf_gnu_hash
454  - elflint, readelf: add support for 64-bit SysV-style hash tables
455  - libdwfl: new functions dwfl_module_getsymtab, dwfl_module_getsym.
456
457* Thu Jun 15 2006 Roland McGrath <roland@redhat.com> - 0.121-1
458- Update to 0.121
459  - libelf: bug fixes for rewriting existing files when using mmap (#187618).
460  - make all installed headers usable in C++ code (#193153).
461  - eu-readelf: better output format.
462  - eu-elflint: fix tests of dynamic section content.
463  - libdw, libdwfl: handle files without aranges info.
464
465* Thu May 25 2006 Jeremy Katz <katzj@redhat.com> - 0.120-3
466- rebuild to pick up -devel deps
467
468* Tue Apr  4 2006 Roland McGrath <roland@redhat.com> - 0.120-2
469- Update to 0.120
470  - License changed to GPL, with some exceptions for using
471    the libelf, libebl, libdw, and libdwfl library interfaces.
472    Red Hat elfutils is an included package of the Open Invention Network.
473  - dwarf.h updated for DWARF 3.0 final specification.
474  - libelf: Fix corruption in ELF_C_RDWR uses (#187618).
475  - libdwfl: New function dwfl_version; fixes for offline.
476
477* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.119-1.2.1
478- bump again for double-long bug on ppc(64)
479
480* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.119-1.2
481- rebuilt for new gcc4.1 snapshot and glibc changes
482
483* Fri Jan 13 2006 Roland McGrath <roland@redhat.com> - 0.119-1
484- update to 0.119
485
486* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
487- rebuilt
488
489* Sun Nov 27 2005 Roland McGrath <roland@redhat.com> - 0.118-1
490- update to 0.118
491  - elflint: more tests.
492  - libdwfl: New function dwfl_module_register_names.
493  - libebl: New backend hook for register names.
494- Make sure -fexceptions is always in CFLAGS.
495
496* Tue Nov 22 2005 Roland McGrath <roland@redhat.com> - 0.117-2
497- update to 0.117
498  - libdwfl: New function dwfl_module_return_value_location (#166118)
499  - libebl: Backend improvements for several CPUs
500
501* Mon Oct 31 2005 Roland McGrath <roland@redhat.com> - 0.116-1
502- update to 0.116
503  - libdw fixes, API changes and additions
504  - libdwfl fixes (#169672)
505  - eu-strip/libelf fix to preserve setuid/setgid permission bits (#167745)
506
507* Fri Sep  9 2005 Roland McGrath <roland@redhat.com> - 0.115-3
508- Update requires/conflicts for better biarch update behavior.
509
510* Mon Sep  5 2005 Roland McGrath <roland@redhat.com> - 0.115-2
511- update to 0.115
512  - New program eu-strings.
513  - libdw: New function dwarf_getscopes_die.
514  - libelf: speed-ups of non-mmap reading.
515  - Implement --enable-gcov option for configure.
516
517* Wed Aug 24 2005 Roland McGrath <roland@redhat.com> - 0.114-1
518- update to 0.114
519  - new program eu-ranlib
520  - libdw: new calls for inlines
521  - libdwfl: new calls for offline modules
522
523* Sat Aug 13 2005 Roland McGrath <roland@redhat.com> - 0.113-2
524- update to 0.113
525  - elflint: relax a bit.  Allow version definitions for defined symbols
526    against DSO versions also for symbols in nobits sections.
527    Allow .rodata section to have STRINGS and MERGE flag set.
528  - strip: add some more compatibility with binutils.
529  - libdwfl: bug fixes.
530- Separate libdw et al into elfutils-libs subpackage.
531
532* Sat Aug  6 2005 Roland McGrath <roland@redhat.com> - 0.112-1
533- update to 0.112
534  - elfcmp: some more relaxation.
535  - elflint: many more tests, especially regarding to symbol versioning.
536  - libelf: Add elfXX_offscn and gelf_offscn.
537  - libasm: asm_begin interface changes.
538  - libebl: Add three new interfaces to directly access machine, class,
539    and data encoding information.
540
541* Fri Jul 29 2005 Roland McGrath <roland@redhat.com> - 0.111-2
542- update portability patch
543
544* Thu Jul 28 2005 Roland McGrath <roland@redhat.com> - 0.111-1
545- update to 0.111
546  - libdwfl library now merged into libdw
547
548* Sun Jul 24 2005 Roland McGrath <roland@redhat.com> - 0.110-1
549- update to 0.110
550
551* Fri Jul 22 2005 Roland McGrath <roland@redhat.com> - 0.109-2
552- update to 0.109
553  - verify that libebl modules are from the same build
554  - new eu-elflint checks on copy relocations
555  - new program eu-elfcmp
556  - new experimental libdwfl library
557
558* Thu Jun  9 2005 Roland McGrath <roland@redhat.com> - 0.108-5
559- robustification of eu-strip and eu-readelf
560
561* Wed May 25 2005 Roland McGrath <roland@redhat.com> - 0.108-3
562- more robustification
563
564* Mon May 16 2005 Roland McGrath <roland@redhat.com> - 0.108-2
565- robustification
566
567* Mon May  9 2005 Roland McGrath <roland@redhat.com> - 0.108-1
568- update to 0.108
569  - merge strip fixes
570  - sort records in dwarf_getsrclines, fix dwarf_getsrc_die searching
571  - update elf.h from glibc
572
573* Sun May  8 2005 Roland McGrath <roland@redhat.com> - 0.107-2
574- fix strip -f byte-swapping bug
575
576* Sun May  8 2005 Roland McGrath <roland@redhat.com> - 0.107-1
577- update to 0.107
578  - readelf: improve DWARF output format
579  - elflint: -d option to support checking separate debuginfo files
580  - strip: fix ET_REL debuginfo files (#156341)
581
582* Mon Apr  4 2005 Roland McGrath <roland@redhat.com> - 0.106-3
583- fix some bugs in new code, reenable make check
584
585* Mon Apr  4 2005 Roland McGrath <roland@redhat.com> - 0.106-2
586- disable make check for most arches, for now
587
588* Mon Apr  4 2005 Roland McGrath <roland@redhat.com> - 0.106-1
589- update to 0.106
590
591* Mon Mar 28 2005 Roland McGrath <roland@redhat.com> - 0.104-2
592- update to 0.104
593
594* Wed Mar 23 2005 Jakub Jelinek <jakub@redhat.com> 0.103-2
595- update to 0.103
596
597* Wed Feb 16 2005 Jakub Jelinek <jakub@redhat.com> 0.101-2
598- update to 0.101.
599- use %%configure macro to get CFLAGS etc. right
600
601* Sat Feb  5 2005 Jeff Johnson <jbj@redhat.com> 0.99-2
602- upgrade to 0.99.
603
604* Sun Sep 26 2004 Jeff Johnson <jbj@redhat.com> 0.97-3
605- upgrade to 0.97.
606
607* Tue Aug 17 2004 Jakub Jelinek <jakub@redhat.com> 0.95-5
608- upgrade to 0.96.
609
610* Mon Jul  5 2004 Jakub Jelinek <jakub@redhat.com> 0.95-4
611- rebuilt with GCC 3.4.x, workaround VLA + alloca mixing
612  warning
613
614* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
615- rebuilt
616
617* Fri Apr  2 2004 Jeff Johnson <jbj@redhat.com> 0.95-2
618- upgrade to 0.95.
619
620* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
621- rebuilt
622
623* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
624- rebuilt
625
626* Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.94-1
627- upgrade to 0.94
628
629* Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.93-1
630- upgrade to 0.93
631
632* Thu Jan  8 2004 Jakub Jelinek <jakub@redhat.com> 0.92-1
633- full version
634- macroized spec file for GPL or OSL builds
635- include only libelf under GPL plus wrapper scripts
636
637* Wed Jan  7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-2
638- macroized spec file for GPL or OSL builds
639
640* Wed Jan  7 2004 Ulrich Drepper <drepper@redhat.com>
641- split elfutils-devel into two packages.
642
643* Wed Jan  7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-1
644- include only libelf under GPL plus wrapper scripts
645
646* Tue Dec 23 2003 Jeff Johnson <jbj@redhat.com> 0.89-3
647- readelf, not readline, in %%description (#111214).
648
649* Fri Sep 26 2003 Bill Nottingham <notting@redhat.com> 0.89-1
650- update to 0.89 (fix eu-strip)
651
652* Tue Sep 23 2003 Jakub Jelinek <jakub@redhat.com> 0.86-3
653- update to 0.86 (fix eu-strip on s390x/alpha)
654- libebl is an archive now; remove references to DSO
655
656* Mon Jul 14 2003 Jeff Johnson <jbj@redhat.com> 0.84-3
657- upgrade to 0.84 (readelf/elflint improvements, rawhide bugs fixed).
658
659* Fri Jul 11 2003 Jeff Johnson <jbj@redhat.com> 0.83-3
660- upgrade to 0.83 (fix invalid ELf handle on *.so strip, more).
661
662* Wed Jul  9 2003 Jeff Johnson <jbj@redhat.com> 0.82-3
663- upgrade to 0.82 (strip tests fixed on big-endian).
664
665* Tue Jul  8 2003 Jeff Johnson <jbj@redhat.com> 0.81-3
666- upgrade to 0.81 (strip excludes unused symtable entries, test borked).
667
668* Thu Jun 26 2003 Jeff Johnson <jbj@redhat.com> 0.80-3
669- upgrade to 0.80 (debugedit changes for kernel in progress).
670
671* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
672- rebuilt
673
674* Wed May 21 2003 Jeff Johnson <jbj@redhat.com> 0.79-2
675- upgrade to 0.79 (correct formats for size_t, more of libdw "works").
676
677* Mon May 19 2003 Jeff Johnson <jbj@redhat.com> 0.78-2
678- upgrade to 0.78 (libdwarf bugfix, libdw additions).
679
680* Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
681- debuginfo rebuild
682
683* Thu Feb 20 2003 Jeff Johnson <jbj@redhat.com> 0.76-2
684- use the correct way of identifying the section via the sh_info link.
685
686* Sat Feb 15 2003 Jakub Jelinek <jakub@redhat.com> 0.75-2
687- update to 0.75 (eu-strip -g fix)
688
689* Tue Feb 11 2003 Jakub Jelinek <jakub@redhat.com> 0.74-2
690- update to 0.74 (fix for writing with some non-dirty sections)
691
692* Thu Feb  6 2003 Jeff Johnson <jbj@redhat.com> 0.73-3
693- another -0.73 update (with sparc fixes).
694- do "make check" in %%check, not %%install, section.
695
696* Mon Jan 27 2003 Jeff Johnson <jbj@redhat.com> 0.73-2
697- update to 0.73 (with s390 fixes).
698
699* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
700- rebuilt
701
702* Wed Jan 22 2003 Jakub Jelinek <jakub@redhat.com> 0.72-4
703- fix arguments to gelf_getsymshndx and elf_getshstrndx
704- fix other warnings
705- reenable checks on s390x
706
707* Sat Jan 11 2003 Karsten Hopp <karsten@redhat.de> 0.72-3
708- temporarily disable checks on s390x, until someone has
709  time to look at it
710
711* Thu Dec 12 2002 Jakub Jelinek <jakub@redhat.com> 0.72-2
712- update to 0.72
713
714* Wed Dec 11 2002 Jakub Jelinek <jakub@redhat.com> 0.71-2
715- update to 0.71
716
717* Wed Dec 11 2002 Jeff Johnson <jbj@redhat.com> 0.69-4
718- update to 0.69.
719- add "make check" and segfault avoidance patch.
720- elfutils-libelf needs to run ldconfig.
721
722* Tue Dec 10 2002 Jeff Johnson <jbj@redhat.com> 0.68-2
723- update to 0.68.
724
725* Fri Dec  6 2002 Jeff Johnson <jbj@redhat.com> 0.67-2
726- update to 0.67.
727
728* Tue Dec  3 2002 Jeff Johnson <jbj@redhat.com> 0.65-2
729- update to 0.65.
730
731* Mon Dec  2 2002 Jeff Johnson <jbj@redhat.com> 0.64-2
732- update to 0.64.
733
734* Sun Dec 1 2002 Ulrich Drepper <drepper@redhat.com> 0.64
735- split packages further into elfutils-libelf
736
737* Sat Nov 30 2002 Jeff Johnson <jbj@redhat.com> 0.63-2
738- update to 0.63.
739
740* Fri Nov 29 2002 Ulrich Drepper <drepper@redhat.com> 0.62
741- Adjust for dropping libtool
742
743* Sun Nov 24 2002 Jeff Johnson <jbj@redhat.com> 0.59-2
744- update to 0.59
745
746* Thu Nov 14 2002 Jeff Johnson <jbj@redhat.com> 0.56-2
747- update to 0.56
748
749* Thu Nov  7 2002 Jeff Johnson <jbj@redhat.com> 0.54-2
750- update to 0.54
751
752* Sun Oct 27 2002 Jeff Johnson <jbj@redhat.com> 0.53-2
753- update to 0.53
754- drop x86_64 hack, ICE fixed in gcc-3.2-11.
755
756* Sat Oct 26 2002 Jeff Johnson <jbj@redhat.com> 0.52-3
757- get beehive to punch a rhpkg generated package.
758
759* Wed Oct 23 2002 Jeff Johnson <jbj@redhat.com> 0.52-2
760- build in 8.0.1.
761- x86_64: avoid gcc-3.2 ICE on x86_64 for now.
762
763* Tue Oct 22 2002 Ulrich Drepper <drepper@redhat.com> 0.52
764- Add libelf-devel to conflicts for elfutils-devel
765
766* Mon Oct 21 2002 Ulrich Drepper <drepper@redhat.com> 0.50
767- Split into runtime and devel package
768
769* Fri Oct 18 2002 Ulrich Drepper <drepper@redhat.com> 0.49
770- integrate into official sources
771
772* Wed Oct 16 2002 Jeff Johnson <jbj@redhat.com> 0.46-1
773- Swaddle.
Note: See TracBrowser for help on using the repository browser.