source: projects/specs/trunk/d/dovecot/dovecot-vl.spec @ 820

Revision 820, 28.8 KB checked in by inagaki, 14 years ago (diff)

updated: dovecot, fuse, openobex, scim-bridge

Line 
1Summary: Dovecot Secure imap server
2Summary(ja): Dovecot セキュア IMAP サーバ
3Name: dovecot
4Version: 1.2.10
5Release: 2%{?_dist_release}
6License: MIT and LGPLv2 and BSD with advertising
7Group: System Environment/Daemons
8
9%define build_postgres 1
10%define build_mysql 1
11%define build_sqlite 1
12%define build_ldap 1
13
14%define build_sieve 1
15%define sieve_version 1.1.8
16%define sieve_name dovecot-sieve
17
18%define build_drac 1
19
20URL: http://www.dovecot.org/
21
22Source: http://www.dovecot.org/releases/1.1/%{name}-%{version}.tar.gz
23Source1: dovecot.init
24Source2: dovecot.pam
25Source3: maildir-migration.txt
26Source4: migrate-folders
27Source5: migrate-users
28Source6: perfect_maildir.pl
29Source7: dovecot-REDHAT-FAQ.txt
30Source8: http://dovecot.org/releases/sieve/%{sieve_name}-%{sieve_version}.tar.gz
31Source9: dovecot.sysconfig
32
33Source100: http://www.dovecot.org/patches/1.1/drac.c
34Source110: README.plugin-drac
35
36Patch1: dovecot-1.2-default-settings.patch
37Patch2: dovecot-1.0.beta2-mkcert-permissions.patch
38# local filesystem rules
39Patch3: dovecot-1.0.rc7-mkcert-paths.patch
40
41Packager: iwamoto
42Vendor: Project Vine
43Distribution: Vine Linux
44
45Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
46BuildRequires: openssl-devel, pam-devel, zlib-devel
47BuildRequires: bzip2-devel, libcap-devel
48BuildRequires: libtool autoconf automake, gettext-devel
49# Package includes an initscript service file,
50# needs to require initscripts package
51Requires: initscripts
52Requires(pre): /usr/sbin/useradd
53Requires(post): /sbin/chkconfig, /usr/sbin/useradd, /sbin/chkconfig
54Requires(preun): /usr/sbin/userdel, /usr/sbin/groupdel
55Requires(preun): /sbin/chkconfig, /sbin/service
56Requires(postun): /sbin/service
57
58%if %{build_postgres}
59BuildRequires: postgresql-devel
60%endif
61
62%if %{build_mysql}
63BuildRequires: mysql-devel
64%endif
65
66%if %{build_sqlite}
67BuildRequires: sqlite3-devel
68%endif
69
70%if %{build_ldap}
71BuildRequires: openldap-devel
72%endif
73
74%if %{build_drac}
75BuildRequires: dracd
76%endif
77
78%define docdir %{_docdir}/%{name}
79%define ssldir %{_sysconfdir}/pki/%{name}
80
81%description
82Dovecot is an IMAP server for Linux/UNIX-like systems, written with security
83primarily in mind.  It also contains a small POP3 server.  It supports mail
84in either of maildir or mbox formats.
85
86The SQL drivers and authentication plugins are in their subpackages.
87
88
89%if %{build_sieve}
90%package sieve
91Requires: %{name} = %{version}-%{release}
92Summary: CMU Sieve plugin for dovecot LDA
93Group: System Environment/Daemons
94License: MIT and LGPLv2+
95
96%description sieve
97This package provides the CMU Sieve plugin version %{sieve_version} for dovecot LDA.
98%endif
99
100%if %{build_postgres}
101%package pgsql
102Requires: %{name} = %{version}-%{release}
103Summary: Postgres SQL backend for dovecot
104Group: System Environment/Daemons
105%description pgsql
106This package provides the Postgres SQL backend for dovecot-auth etc.
107%endif
108
109%if %{build_mysql}
110%package mysql
111Requires: %{name} = %{version}-%{release}
112Summary: MySQL backend for dovecot
113Group: System Environment/Daemons
114%description mysql
115This package provides the MySQL backend for dovecot-auth etc.
116%endif
117
118%if %{build_sqlite}
119%package sqlite
120Requires: %{name} = %{version}-%{release}
121Summary: SQLite backend for dovecot
122Group: System Environment/Daemons
123%description sqlite
124This package provides the SQLite backend for dovecot-auth etc.
125%endif
126
127%if %{build_ldap}
128%package ldap
129Requires: %{name} = %{version}-%{release}
130Summary: LDAP auth plugin for dovecot
131Group: System Environment/Daemons
132%description ldap
133This package provides the LDAP auth plugin for dovecot-auth etc.
134%endif
135
136%if %{build_drac}
137%package drac
138Summary: Dovecot plugin module for support drac (POP before SMTP)
139Group: System Environment/Daemons
140Requires: %{name} = %{version}-%{release}
141Requires: dracd
142Obsoletes: %{name}-plugin-drac < %{version}-%{release}
143
144%description drac
145Dovecot plugin module for support drac (POP before SMTP)
146%endif
147
148%package devel
149Requires: %{name} = %{version}-%{release}
150Summary: Development files dor dovecot
151Group: Development/Libraries
152%description devel
153This package provides the development files for dovecot.
154
155
156%prep
157
158%setup -q
159
160cp %{SOURCE100} .
161cp %{SOURCE110} .
162
163%patch1 -p1 -b .default-settings
164%patch2 -p1 -b .mkcert-permissions
165%patch3 -p1 -b .mkcert-paths
166
167%if %{build_sieve}
168%setup -q -D -T -a 8
169%endif
170
171%build
172rm -f ./configure
173autoreconf -i -f
174%configure                           \
175    INSTALL_DATA="install -c -p -m644" \
176    --enable-header-install      \
177    --disable-static             \
178%if %{build_postgres}
179    --with-pgsql                 \
180%endif
181%if %{build_mysql}
182    --with-mysql                 \
183%endif
184%if %{build_sqlite}
185    --with-sqlite                \
186%endif
187    --with-sql=plugin            \
188    --with-sql-drivers           \
189    --with-ssl=openssl           \
190    --with-ssldir=%{ssldir}      \
191%if %{build_ldap}
192    --with-ldap=plugin
193%endif
194
195make %{?_smp_mflags}
196
197%if %{build_sieve}
198pushd %{sieve_name}-%{sieve_version}
199rm -f ./configure
200autoreconf -i -f
201%configure                           \
202    INSTALL_DATA="install -c -p -m644" \
203    --disable-static                 \
204    --with-dovecot=../
205
206make %{?_smp_mflags}
207popd
208%endif
209
210%if %{build_drac}
211%{__cc} -Wall -W -shared -fPIC -DHAVE_CONFIG_H \
212    -I. -I./src/lib \
213    drac.c -o drac.so -ldrac
214%endif
215
216%install
217rm -rf $RPM_BUILD_ROOT
218make install DESTDIR=$RPM_BUILD_ROOT
219rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}
220
221install -p -m 755 src/plugins/convert/convert-tool $RPM_BUILD_ROOT%{_libexecdir}/%{name}
222
223mkdir -p $RPM_BUILD_ROOT%{_initrddir}
224install -p -m 755 %{SOURCE1} $RPM_BUILD_ROOT%{_initrddir}/dovecot
225
226mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pam.d
227install -p -m 644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/dovecot
228
229mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
230install -p -m 600 %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/dovecot
231
232# generate ghost .pem file
233mkdir -p $RPM_BUILD_ROOT%{ssldir}/certs
234mkdir -p $RPM_BUILD_ROOT%{ssldir}/private
235touch $RPM_BUILD_ROOT%{ssldir}/certs/dovecot.pem
236chmod 600 $RPM_BUILD_ROOT%{ssldir}/certs/dovecot.pem
237touch $RPM_BUILD_ROOT%{ssldir}/private/dovecot.pem
238chmod 600 $RPM_BUILD_ROOT%{ssldir}/private/dovecot.pem
239
240mkdir -p $RPM_BUILD_ROOT/var/run/dovecot/login
241chmod 755 $RPM_BUILD_ROOT/var/run/dovecot
242chmod 700 $RPM_BUILD_ROOT/var/run/dovecot/login
243       
244# Install dovecot.conf and dovecot-openssl.cnf
245mkdir -p $RPM_BUILD_ROOT%{ssldir}
246install -p -m644 dovecot-example.conf $RPM_BUILD_ROOT%{_sysconfdir}/dovecot.conf
247rm -f $RPM_BUILD_ROOT%{_sysconfdir}/dovecot-*example.conf # dovecot seems to install this by itself
248install -p -m644 doc/dovecot-openssl.cnf $RPM_BUILD_ROOT%{ssldir}/dovecot-openssl.cnf
249
250# Install some of our own documentation
251install -p -m644 %{SOURCE7} $RPM_BUILD_ROOT%{docdir}/REDHAT-FAQ.txt
252
253# Install the licensing files into the documentation area
254install -p -m644 COPYING* $RPM_BUILD_ROOT%{docdir}
255
256mkdir -p $RPM_BUILD_ROOT%{docdir}/examples/
257install -p -m755 doc/mkcert.sh $RPM_BUILD_ROOT%{_libexecdir}/%{name}/mkcert.sh
258for f in `cd doc; echo *.conf`; do
259     install -p -m644 doc/$f $RPM_BUILD_ROOT%{docdir}/examples/$f;
260done
261
262install -p -m755 -d $RPM_BUILD_ROOT%{docdir}/UW-to-Dovecot-Migration
263for f in %{SOURCE3} %{SOURCE4} %{SOURCE5} %{SOURCE6}
264do
265    install -p -m644 $f $RPM_BUILD_ROOT%{docdir}/UW-to-Dovecot-Migration
266done
267
268mv $RPM_BUILD_ROOT%{docdir} $RPM_BUILD_ROOT%{docdir}-%{version}
269mkdir -p $RPM_BUILD_ROOT/var/lib/dovecot
270
271%if %{build_sieve}
272# dovecot-sieve
273pushd %{sieve_name}-%{sieve_version}
274make install DESTDIR=$RPM_BUILD_ROOT
275popd
276%endif
277
278%if %{build_drac}
279install -m 755 drac.so $RPM_BUILD_ROOT/%{_libdir}/dovecot/
280ln -s ../drac.so $RPM_BUILD_ROOT/%{_libdir}/dovecot/imap/
281ln -s ../drac.so $RPM_BUILD_ROOT/%{_libdir}/dovecot/pop3/
282%endif
283
284#remove the libtool archives
285find $RPM_BUILD_ROOT%{_libdir}/%{name}/ -name '*.la' | xargs rm -f
286
287#prepare the filelist
288(
289    find ${RPM_BUILD_ROOT}%{_libdir}/%{name} -type d | sed -e "s|^|%dir |";
290    find ${RPM_BUILD_ROOT}%{_libdir}/%{name} -! -type d | \
291        grep -v 'dovecot-config\|lib90_cmusieve_plugin\.so\|libdriver_.*\.so\|libauthdb_.*\.so\|libmech_.*\.so\|drac\.so';
292) | sed -e "s|$RPM_BUILD_ROOT||" >libs.filelist
293
294
295%clean
296rm -rf $RPM_BUILD_ROOT
297
298
299%pre
300getent group dovecot >/dev/null || groupadd -r dovecot
301getent passwd dovecot >/dev/null || \
302useradd -r -g dovecot -d /usr/libexec/dovecot -s /sbin/nologin -c "Dovecot IMAP server" dovecot
303exit 0
304
305%post
306/sbin/chkconfig --add %{name}
307# generate the ssl certificates
308if [ ! -f %{ssldir}/certs/%{name}.pem ]; then
309    SSLDIR=%{ssldir} OPENSSLCONFIG=%{ssldir}/dovecot-openssl.cnf \
310         %{_libexecdir}/%{name}/mkcert.sh &> /dev/null
311fi
312
313if ! test -f /var/run/dovecot/login/ssl-parameters.dat; then
314    dovecot --build-ssl-parameters &>/dev/null
315fi
316exit 0
317
318%preun
319if [ $1 = 0 ]; then
320    /sbin/service %{name} stop > /dev/null 2>&1 || :
321    /sbin/chkconfig --del %{name} || :
322fi
323
324%postun
325if [ "$1" -ge "1" ]; then
326    /sbin/service %{name} condrestart 2>/dev/null || :
327fi
328
329
330%files -f libs.filelist
331%defattr(-,root,root,-)
332%doc %{docdir}-%{version}
333%config(noreplace) %{_sysconfdir}/dovecot.conf
334%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/sysconfig/dovecot
335%{_initrddir}/dovecot
336%config(noreplace) %{_sysconfdir}/pam.d/dovecot
337%dir %{ssldir}
338%dir %{ssldir}/certs
339%dir %{ssldir}/private
340%config(noreplace) %{ssldir}/dovecot-openssl.cnf
341%attr(0600,root,root) %ghost %config(missingok,noreplace) %verify(not md5 size mtime) %{ssldir}/certs/dovecot.pem
342%attr(0600,root,root) %ghost %config(missingok,noreplace) %verify(not md5 size mtime) %{ssldir}/private/dovecot.pem
343%{_libexecdir}/%{name}
344%{_sbindir}/dovecot
345%{_sbindir}/dovecotpw
346%attr(0755,root,dovecot) %dir /var/run/dovecot
347%attr(0750,root,dovecot) %dir /var/run/dovecot/login
348# %attr(0755,root,dovecot) %{_libexecdir}/%{name}/mkcert.sh
349%attr(0750,dovecot,dovecot) %dir /var/lib/dovecot
350
351%if %{build_sieve}
352%files sieve
353%defattr(-,root,root,-)
354%{_libdir}/%{name}/lda/lib90_cmusieve_plugin.so
355%endif
356
357%if %{build_mysql}
358%files mysql
359%defattr(-,root,root,-)
360%{_libdir}/%{name}/sql/libdriver_mysql.so
361%{_libdir}/%{name}/auth/libdriver_mysql.so
362%{_libdir}/%{name}/dict/libdriver_mysql.so
363%endif
364
365%if %{build_postgres}
366%files pgsql
367%defattr(-,root,root,-)
368%{_libdir}/%{name}/sql/libdriver_pgsql.so
369%{_libdir}/%{name}/auth/libdriver_pgsql.so
370%{_libdir}/%{name}/dict/libdriver_pgsql.so
371%endif
372
373%if %{build_sqlite}
374%files sqlite
375%defattr(-,root,root,-)
376%{_libdir}/%{name}/sql/libdriver_sqlite.so
377%{_libdir}/%{name}/auth/libdriver_sqlite.so
378%{_libdir}/%{name}/dict/libdriver_sqlite.so
379%endif
380
381%if %{build_ldap}
382%files ldap
383%defattr(-,root,root,-)
384%{_libdir}/%{name}/auth/libauthdb_ldap.so
385%endif
386
387%if %{build_drac}
388%files drac
389%defattr(-,root,root)
390%{_libdir}/%{name}/drac.so
391%{_libdir}/%{name}/imap/drac.so
392%{_libdir}/%{name}/pop3/drac.so
393%doc README.plugin-drac
394%endif
395
396%files devel
397%defattr(-,root,root,-)
398%{_includedir}/%{name}
399%{_libdir}/%{name}/dovecot-config
400
401
402%changelog
403* Mon Jan 25 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.10-2
404- fix drac.so in libs.files
405
406* Mon Jan 25 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.10-1
407- new upstream release
408
409* Fri Jan  8 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.9-1
410- new upstream release
411- update to dovecot sieve 1.1.8
412
413* Thu Sep 17 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.3-2
414- update to dovecot sieve 1.1.7 to fix BoF
415- add BR: bzip2-devel, libcap-devel
416
417* Mon Aug 10 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.3-1
418- new upstream release
419
420* Wed Jul 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.2-1
421- new upstream release 
422
423* Sun Jul 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.1-1
424- new upstream release
425
426* Tue Jul  7 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.0-1
427- new upstream 1.2.x release
428- update Patch1 to fit new release
429- README.plugin-drac in UTF-8
430
431* Tue Jun  2 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.16-1
432- new upstream release
433
434* Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.15-3
435- rebuilt with MySQL-5.1.34.
436
437* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.15-2
438- add BuildRequires gettext-devel instead of gettext
439
440* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.15-1
441- new upstream release
442- update patch1 to fix new release
443
444* Mon Apr 27 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.14-1
445- new upstream release
446
447* Sun Mar 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.1.13-2
448- rebuilt with openldap-2.4.11
449
450* Sun Mar 22 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.13-1
451- new upstream release
452
453* Sat Feb 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.11-1
454- new upstream release
455
456* Sun Feb 01 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.10-1
457- new upstream release
458
459* Sun Jan 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.8-1
460- new upstream release
461
462* Sat Nov 01 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.6-1
463- new upstream release
464
465* Tue Oct 21 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.4-2
466- change BuildRequires sqlite-devel -> sqlite3-devel
467
468* Mon Oct 20 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.4-1
469- new upstream release
470
471* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.3-1
472- new upstream release
473
474* Sun Aug 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.2-1
475- new upstream release
476- split ldap plugin to subpackage
477- split sql plugins to subpackages
478- add -devel subpackage
479- update drac module, rename to -drac from -plugin-drac
480- add dovecot-sieve
481
482* Mon Mar 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.13-0vl2
483- build for VineSeed (0vl1 is for VinePlus 4.x)
484- new upstream release
485
486* Mon Jan 07 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.10-0vl2
487- build for VineSeed (0vl1 is for VinePlus 4.x)
488- new upstream release with security fix (CVE-2007-6598)
489- turn on daemon stop massage (Already start message is on)
490
491* Sat Dec 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.9-0vl1
492- new upstream source
493
494* Wed Nov 21 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.7-0vl4
495- updated %%install section to support lib64 architecture
496
497* Sun Nov 04 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.7-0vl3
498- rebuild for VineSeed (from VinePlus 4.x)
499
500  * Thu Sep 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.5-0vl1
501  - new upstream release
502  - rebuilt with postgresql-devel 8.2.5
503
504  * Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.3-0vl1
505  - new upstream release
506
507  * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl1
508  - new upstream release
509
510* Sat Nov 03 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.7-0vl2
511- add Require dracd tag in plugin-drac
512
513* Sat Nov 03 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.7-0vl1
514- new upstream release
515
516* Fri Oct 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.5-0vl4
517- fix drac plugin make method
518- change drac.so install method (use sym link)
519- add README.plugin-drac
520
521* Fri Oct 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.5-0vl3
522- add dovecot-openssl.cnf install to doc
523- daemon restart message turn on when package is upgraded
524
525* Tue Oct 09 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.5-0vl2
526- add drac.so (POP bedore SMTP) support
527
528* Mon Oct 08 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.5-0vl1
529- new upstream release
530- drop patch500 (it is included in new release)
531- move Mysql buildreq tag to "if build_mysql" section
532- add Requires: postgresql-libs and Requires: MySQL-shared in "if-endif"
533- add Requires: openldap
534
535* Wed Aug 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0-0.rc17.0vl2
536- add Patch500 to fix directory traversal vulnerability (CVE-2007-2231)
537  note that version 1.0.rc29 and up have been already fixed in upstream
538
539* Mon Jan 08 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0-0.rc17.0vl1
540- new upstream RC release
541
542* Sun Jan 07 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0-0.rc16.0vl1
543- new upstream RC release
544
545* Thu Dec 21 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0-0.rc15.0vl2
546- add Vendor/Distribution tag
547
548* Sun Dec 10 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0-0.rc15.0vl1
549- new upstream RC release
550- add BuildRequires: MySQL-shared, MySQL-devel
551- update patch100
552
553* Mon Oct 30 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0-0.rc7.1vl2
554- rebuilt with MySQL 5.0.27
555
556* Mon Aug 28 2006 IWAI, Masaharu <iwai@alib.jp> 1.0-0.rc7.1vl1
557- new upstream release
558- update default settings patch (Patch100)
559- build with openldap-2.3.24
560
561* Tue Aug  1 2006 IWAI, Masaharu <iwai@alib.jp> 1.0-0.rc2.1vl1
562- first release for Vine Linux
563
564* Mon Jul 17 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.rc2.1
565- reenable inotify and see what happens
566
567* Thu Jul 13 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.rc2
568- update to latest upstream release candidate
569- disable inotify for now, doesn't build -- this needs fixing though
570
571* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.0-0.beta8.2.1
572- rebuild
573
574* Thu Jun 08 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta8.2
575- put back pop3_uidl_format default that got lost
576  in the beta2->beta7 upgrade (would cause pop3 to not work
577  at all in many situations)
578
579* Thu May 04 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta8.1
580- upgrade to latest upstream beta release (beta8)
581- contains a security fix in mbox handling
582
583* Thu May 04 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta7.1
584- upgrade to latest upstream beta release
585- fixed BR 173048
586
587* Fri Mar 17 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.8
588- fix sqlite detection in upstream configure checks, second part
589  of #182240
590
591* Wed Mar  8 2006 Bill Nottingham <notting@redhat.com> - 1.0-0.beta2.7
592- fix scriplet noise some more
593
594* Mon Mar  6 2006 Jeremy Katz <katzj@redhat.com> - 1.0-0.beta2.6
595- fix scriptlet error (mitr, #184151)
596
597* Mon Feb 27 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.5
598- fix #182240 by looking in lib64 for libs first and then lib
599- fix comment #1 in #182240 by copying over the example config files
600  to documentation directory
601
602* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.0-0.beta2.4.1
603- bump again for double-long bug on ppc(64)
604
605* Thu Feb 09 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.4
606- enable inotify as it should work now (#179431)
607
608* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.0-0.beta2.3.1
609- rebuilt for new gcc4.1 snapshot and glibc changes
610
611* Thu Feb 02 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.3
612- change the compiled-in defaults and adjust the default's configfile
613  commented-out example settings to match compiled-in defaults,
614  instead of changing the defaults only in the configfile, as per #179432
615- fix #179574 by providing a default uidl_format for pop3
616- half-fix #179620 by having plaintext auth enabled by default... this
617  needs more thinking (which one we really want) and documentation
618  either way
619
620* Tue Jan 31 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.2
621- update URL in description
622- call dovecot --build-ssl-parameters in postinst as per #179430
623
624* Mon Jan 30 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.1
625- fix spec to work with BUILD_DIR != SOURCE_DIR
626- forward-port and split pam-nocred patch
627
628* Mon Jan 23 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2
629- new upstream version, hopefully fixes #173928, #163550
630- fix #168866, use install -p to install documentation
631
632* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
633- rebuilt
634
635* Sat Nov 12 2005 Tom Lane <tgl@redhat.com> - 0.99.14-10.fc5
636- Rebuild due to mysql update.
637
638* Wed Nov  9 2005 Tomas Mraz <tmraz@redhat.com> - 0.99.14-9.fc5
639- rebuilt with new openssl
640
641* Fri Sep 30 2005 Tomas Mraz <tmraz@redhat.com> - 0.99.14-8.fc5
642- use include instead of pam_stack in pam config
643
644* Wed Jul 27 2005 John Dennis <jdennis@redhat.com> - 0.99.14-7.fc5
645- fix bug #150888, log authenication failures with ip address
646
647* Fri Jul 22 2005 John Dennis <jdennis@redhat.com> - 0.99.14-6.fc5
648- fix bug #149673, add dummy PAM_TTY
649
650* Thu Apr 28 2005 John Dennis <jdennis@redhat.com> - 0.99.14-5.fc4
651- fix bug #156159 insecure location of restart flag file
652
653* Fri Apr 22 2005 John Dennis <jdennis@redhat.com> - 0.99.14-4.fc4
654- openssl moved its certs, CA, etc. from /usr/share/ssl to /etc/pki
655
656* Tue Apr 12 2005 Tom Lane <tgl@redhat.com> 0.99.14-3.fc4
657- Rebuild for Postgres 8.0.2 (new libpq major version).
658
659* Mon Mar  7 2005 John Dennis <jdennis@redhat.com> 0.99.14-2.fc4
660- bump rev for gcc4 build
661
662* Mon Feb 14 2005 John Dennis <jdennis@redhat.com> - 0.99.14-1.fc4
663- fix bug #147874, update to 0.99.14 release
664  v0.99.14 2005-02-11  Timo Sirainen <tss at iki.fi>
665  - Message address fields are now parsed differently, fixing some
666    issues with spaces. Affects only clients which use FETCH ENVELOPE
667    command.
668  - Message MIME parser was somewhat broken with missing MIME boundaries
669  - mbox: Don't allow X-UID headers in mails to override the UIDs we
670    would otherwise set. Too large values can break some clients and
671    cause other trouble.
672  - passwd-file userdb wasn't working
673  - PAM crashed with 64bit systems
674  - non-SSL inetd startup wasn't working
675  - If UID FETCH notices and skips an expunged message, don't return
676    a NO reply. It's not needed and only makes clients give error
677    messages.
678
679* Wed Feb  2 2005 John Dennis <jdennis@redhat.com> - 0.99.13-4.devel
680- fix bug #146198, clean up temp kerberos tickets
681
682* Mon Jan 17 2005 John Dennis <jdennis@redhat.com> 0.99.13-3.devel
683- fix bug #145214, force mbox_locks to fcntl only
684- fix bug #145241, remove prereq on postgres and mysql, allow rpm auto
685  dependency generator to pick up client lib dependency if needed.
686
687* Thu Jan 13 2005 John Dennis <jdennis@redhat.com> 0.99.13-2.devel
688- make postgres & mysql conditional build
689- remove execute bit on migration example scripts so rpm does not pull
690  in additional dependences on perl and perl modules that are not present
691  in dovecot proper.
692- add REDHAT-FAQ.txt to doc directory
693
694* Thu Jan  6 2005 John Dennis <jdennis@redhat.com> 0.99.13-1.devel
695- bring up to date with latest upstream, 0.99.13, bug #143707
696  also fix bug #14462, bad dovecot-uid macro name
697
698* Thu Jan  6 2005 John Dennis <jdennis@redhat.com> 0.99.11-10.devel
699- fix bug #133618, removed LITERAL+ capability from capability string
700
701* Wed Jan  5 2005 John Dennis <jdennis@redhat.com> 0.99.11-9.devel
702- fix bug #134325, stop dovecot during installation
703
704* Wed Jan  5 2005 John Dennis <jdennis@redhat.com> 0.99.11-8.devel
705- fix bug #129539, dovecot starts too early,
706  set chkconfig to 65 35 to match cyrus-imapd
707- also delete some old commented out code from SSL certificate creation
708
709* Thu Dec 23 2004 John Dennis <jdennis@redhat.com> 0.99.11-7.devel
710- add UW to Dovecot migration documentation and scripts, bug #139954
711  fix SSL documentation and scripts, add missing documentation, bug #139276
712
713* Thu Nov 15 2004 Warren Togami <wtogami@redhat.com> 0.99.11-2.FC4.1
714- rebuild against MySQL4
715
716* Thu Oct 21 2004 John Dennis <jdennis@redhat.com>
717- fix bug #136623
718  Change License field from GPL to LGPL to reflect actual license
719
720* Thu Sep 30 2004 John Dennis <jdennis@redhat.com> 0.99.11-1.FC3.3
721- fix bug #124786, listen to ipv6 as well as ipv4
722
723* Wed Sep  8 2004 John Dennis <jdennis@redhat.com> 0.99.11-1.FC3.1
724- bring up to latest upstream,
725  comments from Timo Sirainen <tss at iki.fi> on release v0.99.11 2004-09-04 
726  + 127.* and ::1 IP addresses are treated as secured with
727    disable_plaintext_auth = yes
728  + auth_debug setting for extra authentication debugging
729  + Some documentation and error message updates
730  + Create PID file in /var/run/dovecot/master.pid
731  + home setting is now optional in static userdb
732  + Added mail setting to static userdb
733  - After APPENDing to selected mailbox Dovecot didn't always notice the
734    new mail immediately which broke some clients
735  - THREAD and SORT commands crashed with some mails
736  - If APPENDed mail ended with CR character, Dovecot aborted the saving
737  - Output streams sometimes sent data duplicated and lost part of it.
738    This could have caused various strange problems, but looks like in
739    practise it rarely caused real problems.
740
741* Wed Aug  4 2004 John Dennis <jdennis@redhat.com>
742- change release field separator from comma to dot, bump build number
743
744* Mon Aug  2 2004 John Dennis <jdennis@redhat.com> 0.99.10.9-1,FC3,1
745- bring up to date with latest upstream, fixes include:
746- LDAP support compiles now with Solaris LDAP library
747- IMAP BODY and BODYSTRUCTURE replies were wrong for MIME parts which
748  didn't contain Content-Type header.
749- MySQL and PostgreSQL auth didn't reconnect if connection was lost
750  to SQL server
751- Linking fixes for dovecot-auth with some systems
752- Last fix for disconnecting client when downloading mail longer than
753  30 seconds actually made it never disconnect client. Now it works
754  properly: disconnect when client hasn't read _any_ data for 30
755  seconds.
756- MySQL compiling got broken in last release
757- More PostgreSQL reconnection fixing
758
759
760* Mon Jul 26 2004 John Dennis <jdennis@redhat.com> 0.99.10.7-1,FC3,1
761- enable postgres and mySQL in build
762- fix configure to look for mysql in alternate locations
763- nuke configure script in tar file, recreate from configure.in using autoconf
764
765- bring up to latest upstream, which included:
766- Added outlook-pop3-no-nuls workaround to fix Outlook hang in mails with NULs.
767- Config file lines can now contain quoted strings ("value ")
768- If client didn't finish downloading a single mail in 30 seconds,
769  Dovecot closed the connection. This was supposed to work so that
770  if client hasn't read data at all in 30 seconds, it's disconnected.
771- Maildir: LIST now doesn't skip symlinks
772
773
774* Wed Jun 30 2004 John Dennis <jdennis@redhat.com>
775- bump rev for build
776- change rev for FC3 build
777
778* Fri Jun 25 2004 John Dennis <jdennis@redhat.com> - 0.99.10.6-1
779- bring up to date with upstream,
780  recent change log comments from Timo Sirainen were:
781  SHA1 password support using OpenSSL crypto library
782  mail_extra_groups setting
783  maildir_stat_dirs setting
784  Added NAMESPACE capability and command
785  Autocreate missing maildirs (instead of crashing)
786  Fixed occational crash in maildir synchronization
787  Fixed occational assertion crash in ioloop.c
788  Fixed FreeBSD compiling issue
789  Fixed issues with 64bit Solaris binary
790
791* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
792- rebuilt
793
794* Thu May 27 2004 David Woodhouse <dwmw2@redhat.com> 0.99.10.5-1
795- Update to 0.99.10.5 to fix maildir segfaults (#123022)
796
797* Fri May 07 2004 Warren Togami <wtogami@redhat.com> 0.99.10.4-4
798- default auth config that is actually usable
799- Timo Sirainen (author) suggested functionality fixes
800  maildir, imap-fetch-body-section, customflags-fix
801
802* Mon Feb 23 2004 Tim Waugh <twaugh@redhat.com>
803- Use ':' instead of '.' as separator for chown.
804
805* Tue Feb 17 2004 Jeremy Katz <katzj@redhat.com> - 0.99.10.4-3
806- restart properly if it dies (#115594)
807
808* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
809- rebuilt
810
811* Mon Nov 24 2003 Jeremy Katz <katzj@redhat.com> 0.99.10.4-1
812- update to 0.99.10.4
813
814* Mon Oct  6 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-7
815- another patch from upstream to fix returning invalid data on partial
816  BODY[part] fetches
817- patch to avoid confusion of draft/deleted in indexes
818
819* Tue Sep 23 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-6
820- add some patches from upstream (#104288)
821
822* Thu Sep  4 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-5
823- fix startup with 2.6 with patch from upstream (#103801)
824
825* Tue Sep  2 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-4
826- fix assert in search code (#103383)
827
828* Tue Jul 22 2003 Nalin Dahyabhai <nalin@redhat.com> 0.99.10-3
829- rebuild
830
831* Thu Jul 17 2003 Bill Nottingham <notting@redhat.com> 0.99.10-2
832- don't run by default
833
834* Thu Jun 26 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-1
835- 0.99.10
836
837* Mon Jun 23 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-0.2
838- 0.99.10-rc2 (includes ssl detection fix)
839- a few tweaks from fedora
840  - noreplace the config file
841  - configure --with-ldap to get LDAP enabled
842
843* Mon Jun 23 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-0.1
844- 0.99.10-rc1
845- add fix for ssl detection
846- add zlib-devel to BuildRequires
847- change pam service name to dovecot
848- include pam config
849
850* Thu May  8 2003 Jeremy Katz <katzj@redhat.com> 0.99.9.1-1
851- update to 0.99.9.1
852- add patch from upstream to fix potential bug when fetching with
853  CR+LF linefeeds
854- tweak some things in the initscript and config file noticed by the
855  fedora folks
856
857* Sun Mar 16 2003 Jeremy Katz <katzj@redhat.com> 0.99.8.1-2
858- fix ssl dir
859- own /var/run/dovecot/login with the correct perms
860- fix chmod/chown in post
861
862* Fri Mar 14 2003 Jeremy Katz <katzj@redhat.com> 0.99.8.1-1
863- update to 0.99.8.1
864
865* Tue Mar 11 2003 Jeremy Katz <katzj@redhat.com> 0.99.8-2
866- add a patch to fix quoting problem from CVS
867
868* Mon Mar 10 2003 Jeremy Katz <katzj@redhat.com> 0.99.8-1
869- 0.99.8
870- add some buildrequires
871- fixup to build with openssl 0.9.7
872- now includes a pop3 daemon (off by default)
873- clean up description and %%preun
874- add dovecot user (uid/gid of 97)
875- add some buildrequires
876- move the ssl cert to %{_datadir}/ssl/certs
877- create a dummy ssl cert in %post
878- own /var/run/dovecot
879- make the config file a source so we get default mbox locks of fcntl
880
881* Sun Dec  1 2002 Seth Vidal <skvidal@phy.duke.edu>
882- 0.99.4 and fix startup so it starts imap-master not vsftpd :)
883
884* Tue Nov 26 2002 Seth Vidal <skvidal@phy.duke.edu>
885- first build
Note: See TracBrowser for help on using the repository browser.