source: projects/specs/trunk/d/dovecot/dovecot-vl.spec @ 521

Revision 521, 28.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Dovecot Secure imap server
2Summary(ja): Dovecot セキュア IMAP サーバ
3Name: dovecot
4Version: 1.2.3
5Release: 1%{?_dist_release}
6License: MIT and LGPLv2 and BSD with advertising
7Group: System Environment/Daemons
8
9%define build_postgres 1
10%define build_mysql 1
11%define build_sqlite 1
12%define build_ldap 1
13
14%define build_sieve 1
15%define sieve_version 1.1.6
16%define sieve_name dovecot-sieve
17
18%define build_drac 1
19
20URL: http://www.dovecot.org/
21
22Source: http://www.dovecot.org/releases/1.1/%{name}-%{version}.tar.gz
23Source1: dovecot.init
24Source2: dovecot.pam
25Source3: maildir-migration.txt
26Source4: migrate-folders
27Source5: migrate-users
28Source6: perfect_maildir.pl
29Source7: dovecot-REDHAT-FAQ.txt
30Source8: http://dovecot.org/releases/sieve/%{sieve_name}-%{sieve_version}.tar.gz
31Source9: dovecot.sysconfig
32
33Source100: http://www.dovecot.org/patches/1.1/drac.c
34Source110: README.plugin-drac
35
36Patch1: dovecot-1.2-default-settings.patch
37Patch2: dovecot-1.0.beta2-mkcert-permissions.patch
38# local filesystem rules
39Patch3: dovecot-1.0.rc7-mkcert-paths.patch
40
41Packager: iwamoto
42Vendor: Project Vine
43Distribution: Vine Linux
44
45Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
46BuildRequires: openssl-devel, pam-devel, zlib-devel
47BuildRequires: libtool autoconf automake, gettext-devel
48# Package includes an initscript service file,
49# needs to require initscripts package
50Requires: initscripts
51Requires(pre): /usr/sbin/useradd
52Requires(post): /sbin/chkconfig, /usr/sbin/useradd, /sbin/chkconfig
53Requires(preun): /usr/sbin/userdel, /usr/sbin/groupdel
54Requires(preun): /sbin/chkconfig, /sbin/service
55Requires(postun): /sbin/service
56
57%if %{build_postgres}
58BuildRequires: postgresql-devel
59%endif
60
61%if %{build_mysql}
62BuildRequires: mysql-devel
63%endif
64
65%if %{build_sqlite}
66BuildRequires: sqlite3-devel
67%endif
68
69%if %{build_ldap}
70BuildRequires: openldap-devel
71%endif
72
73%if %{build_drac}
74BuildRequires: dracd
75%endif
76
77%define docdir %{_docdir}/%{name}
78%define ssldir %{_sysconfdir}/pki/%{name}
79
80%description
81Dovecot is an IMAP server for Linux/UNIX-like systems, written with security
82primarily in mind.  It also contains a small POP3 server.  It supports mail
83in either of maildir or mbox formats.
84
85The SQL drivers and authentication plugins are in their subpackages.
86
87
88%if %{build_sieve}
89%package sieve
90Requires: %{name} = %{version}-%{release}
91Summary: CMU Sieve plugin for dovecot LDA
92Group: System Environment/Daemons
93License: MIT and LGPLv2+
94
95%description sieve
96This package provides the CMU Sieve plugin version %{sieve_version} for dovecot LDA.
97%endif
98
99%if %{build_postgres}
100%package pgsql
101Requires: %{name} = %{version}-%{release}
102Summary: Postgres SQL backend for dovecot
103Group: System Environment/Daemons
104%description pgsql
105This package provides the Postgres SQL backend for dovecot-auth etc.
106%endif
107
108%if %{build_mysql}
109%package mysql
110Requires: %{name} = %{version}-%{release}
111Summary: MySQL backend for dovecot
112Group: System Environment/Daemons
113%description mysql
114This package provides the MySQL backend for dovecot-auth etc.
115%endif
116
117%if %{build_sqlite}
118%package sqlite
119Requires: %{name} = %{version}-%{release}
120Summary: SQLite backend for dovecot
121Group: System Environment/Daemons
122%description sqlite
123This package provides the SQLite backend for dovecot-auth etc.
124%endif
125
126%if %{build_ldap}
127%package ldap
128Requires: %{name} = %{version}-%{release}
129Summary: LDAP auth plugin for dovecot
130Group: System Environment/Daemons
131%description ldap
132This package provides the LDAP auth plugin for dovecot-auth etc.
133%endif
134
135%if %{build_drac}
136%package drac
137Summary: Dovecot plugin module for support drac (POP before SMTP)
138Group: System Environment/Daemons
139Requires: %{name} = %{version}-%{release}
140Requires: dracd
141Obsoletes: %{name}-plugin-drac < %{version}-%{release}
142
143%description drac
144Dovecot plugin module for support drac (POP before SMTP)
145%endif
146
147%package devel
148Requires: %{name} = %{version}-%{release}
149Summary: Development files dor dovecot
150Group: Development/Libraries
151%description devel
152This package provides the development files for dovecot.
153
154
155%prep
156
157%setup -q
158
159cp %{SOURCE100} .
160cp %{SOURCE110} .
161
162%patch1 -p1 -b .default-settings
163%patch2 -p1 -b .mkcert-permissions
164%patch3 -p1 -b .mkcert-paths
165
166%if %{build_sieve}
167%setup -q -D -T -a 8
168%endif
169
170%build
171rm -f ./configure
172autoreconf -i -f
173%configure                           \
174    INSTALL_DATA="install -c -p -m644" \
175    --enable-header-install      \
176    --disable-static             \
177%if %{build_postgres}
178    --with-pgsql                 \
179%endif
180%if %{build_mysql}
181    --with-mysql                 \
182%endif
183%if %{build_sqlite}
184    --with-sqlite                \
185%endif
186    --with-sql=plugin            \
187    --with-sql-drivers           \
188    --with-ssl=openssl           \
189    --with-ssldir=%{ssldir}      \
190%if %{build_ldap}
191    --with-ldap=plugin
192%endif
193
194make %{?_smp_mflags}
195
196%if %{build_sieve}
197pushd %{sieve_name}-%{sieve_version}
198rm -f ./configure
199autoreconf -i -f
200%configure                           \
201    INSTALL_DATA="install -c -p -m644" \
202    --disable-static                 \
203    --with-dovecot=../
204
205make %{?_smp_mflags}
206popd
207%endif
208
209%if %{build_drac}
210%{__cc} -Wall -W -shared -fPIC -DHAVE_CONFIG_H \
211    -I. -I./src/lib \
212    drac.c -o drac.so -ldrac
213%endif
214
215%install
216rm -rf $RPM_BUILD_ROOT
217make install DESTDIR=$RPM_BUILD_ROOT
218rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}
219
220install -p -m 755 src/plugins/convert/convert-tool $RPM_BUILD_ROOT%{_libexecdir}/%{name}
221
222mkdir -p $RPM_BUILD_ROOT%{_initrddir}
223install -p -m 755 %{SOURCE1} $RPM_BUILD_ROOT%{_initrddir}/dovecot
224
225mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pam.d
226install -p -m 644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/dovecot
227
228mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
229install -p -m 600 %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/dovecot
230
231# generate ghost .pem file
232mkdir -p $RPM_BUILD_ROOT%{ssldir}/certs
233mkdir -p $RPM_BUILD_ROOT%{ssldir}/private
234touch $RPM_BUILD_ROOT%{ssldir}/certs/dovecot.pem
235chmod 600 $RPM_BUILD_ROOT%{ssldir}/certs/dovecot.pem
236touch $RPM_BUILD_ROOT%{ssldir}/private/dovecot.pem
237chmod 600 $RPM_BUILD_ROOT%{ssldir}/private/dovecot.pem
238
239mkdir -p $RPM_BUILD_ROOT/var/run/dovecot/login
240chmod 755 $RPM_BUILD_ROOT/var/run/dovecot
241chmod 700 $RPM_BUILD_ROOT/var/run/dovecot/login
242       
243# Install dovecot.conf and dovecot-openssl.cnf
244mkdir -p $RPM_BUILD_ROOT%{ssldir}
245install -p -m644 dovecot-example.conf $RPM_BUILD_ROOT%{_sysconfdir}/dovecot.conf
246rm -f $RPM_BUILD_ROOT%{_sysconfdir}/dovecot-*example.conf # dovecot seems to install this by itself
247install -p -m644 doc/dovecot-openssl.cnf $RPM_BUILD_ROOT%{ssldir}/dovecot-openssl.cnf
248
249# Install some of our own documentation
250install -p -m644 %{SOURCE7} $RPM_BUILD_ROOT%{docdir}/REDHAT-FAQ.txt
251
252# Install the licensing files into the documentation area
253install -p -m644 COPYING* $RPM_BUILD_ROOT%{docdir}
254
255mkdir -p $RPM_BUILD_ROOT%{docdir}/examples/
256install -p -m755 doc/mkcert.sh $RPM_BUILD_ROOT%{_libexecdir}/%{name}/mkcert.sh
257for f in `cd doc; echo *.conf`; do
258     install -p -m644 doc/$f $RPM_BUILD_ROOT%{docdir}/examples/$f;
259done
260
261install -p -m755 -d $RPM_BUILD_ROOT%{docdir}/UW-to-Dovecot-Migration
262for f in %{SOURCE3} %{SOURCE4} %{SOURCE5} %{SOURCE6}
263do
264    install -p -m644 $f $RPM_BUILD_ROOT%{docdir}/UW-to-Dovecot-Migration
265done
266
267mv $RPM_BUILD_ROOT%{docdir} $RPM_BUILD_ROOT%{docdir}-%{version}
268mkdir -p $RPM_BUILD_ROOT/var/lib/dovecot
269
270%if %{build_sieve}
271# dovecot-sieve
272pushd %{sieve_name}-%{sieve_version}
273make install DESTDIR=$RPM_BUILD_ROOT
274popd
275%endif
276
277%if %{build_drac}
278install -m 755 drac.so $RPM_BUILD_ROOT/%{_libdir}/dovecot/
279ln -s ../drac.so $RPM_BUILD_ROOT/%{_libdir}/dovecot/imap/
280ln -s ../drac.so $RPM_BUILD_ROOT/%{_libdir}/dovecot/pop3/
281%endif
282
283#remove the libtool archives
284find $RPM_BUILD_ROOT%{_libdir}/%{name}/ -name '*.la' | xargs rm -f
285
286#prepare the filelist
287(
288    find ${RPM_BUILD_ROOT}%{_libdir}/%{name} -type d | sed -e "s|^|%dir |";
289    find ${RPM_BUILD_ROOT}%{_libdir}/%{name} -! -type d | \
290        grep -v 'dovecot-config\|lib90_cmusieve_plugin\.so\|libdriver_.*\.so\|libauthdb_.*\.so\|libmech_.*\.so';
291) | sed -e "s|$RPM_BUILD_ROOT||" >libs.filelist
292
293
294%clean
295rm -rf $RPM_BUILD_ROOT
296
297
298%pre
299getent group dovecot >/dev/null || groupadd -r dovecot
300getent passwd dovecot >/dev/null || \
301useradd -r -g dovecot -d /usr/libexec/dovecot -s /sbin/nologin -c "Dovecot IMAP server" dovecot
302exit 0
303
304%post
305/sbin/chkconfig --add %{name}
306# generate the ssl certificates
307if [ ! -f %{ssldir}/certs/%{name}.pem ]; then
308    SSLDIR=%{ssldir} OPENSSLCONFIG=%{ssldir}/dovecot-openssl.cnf \
309         %{_libexecdir}/%{name}/mkcert.sh &> /dev/null
310fi
311
312if ! test -f /var/run/dovecot/login/ssl-parameters.dat; then
313    dovecot --build-ssl-parameters &>/dev/null
314fi
315exit 0
316
317%preun
318if [ $1 = 0 ]; then
319    /sbin/service %{name} stop > /dev/null 2>&1 || :
320    /sbin/chkconfig --del %{name} || :
321fi
322
323%postun
324if [ "$1" -ge "1" ]; then
325    /sbin/service %{name} condrestart 2>/dev/null || :
326fi
327
328
329%files -f libs.filelist
330%defattr(-,root,root,-)
331%doc %{docdir}-%{version}
332%config(noreplace) %{_sysconfdir}/dovecot.conf
333%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/sysconfig/dovecot
334%{_initrddir}/dovecot
335%config(noreplace) %{_sysconfdir}/pam.d/dovecot
336%dir %{ssldir}
337%dir %{ssldir}/certs
338%dir %{ssldir}/private
339%config(noreplace) %{ssldir}/dovecot-openssl.cnf
340%attr(0600,root,root) %ghost %config(missingok,noreplace) %verify(not md5 size mtime) %{ssldir}/certs/dovecot.pem
341%attr(0600,root,root) %ghost %config(missingok,noreplace) %verify(not md5 size mtime) %{ssldir}/private/dovecot.pem
342%{_libexecdir}/%{name}
343%{_sbindir}/dovecot
344%{_sbindir}/dovecotpw
345%attr(0755,root,dovecot) %dir /var/run/dovecot
346%attr(0750,root,dovecot) %dir /var/run/dovecot/login
347# %attr(0755,root,dovecot) %{_libexecdir}/%{name}/mkcert.sh
348%attr(0750,dovecot,dovecot) %dir /var/lib/dovecot
349
350%if %{build_sieve}
351%files sieve
352%defattr(-,root,root,-)
353%{_libdir}/%{name}/lda/lib90_cmusieve_plugin.so
354%endif
355
356%if %{build_mysql}
357%files mysql
358%defattr(-,root,root,-)
359%{_libdir}/%{name}/sql/libdriver_mysql.so
360%{_libdir}/%{name}/auth/libdriver_mysql.so
361%{_libdir}/%{name}/dict/libdriver_mysql.so
362%endif
363
364%if %{build_postgres}
365%files pgsql
366%defattr(-,root,root,-)
367%{_libdir}/%{name}/sql/libdriver_pgsql.so
368%{_libdir}/%{name}/auth/libdriver_pgsql.so
369%{_libdir}/%{name}/dict/libdriver_pgsql.so
370%endif
371
372%if %{build_sqlite}
373%files sqlite
374%defattr(-,root,root,-)
375%{_libdir}/%{name}/sql/libdriver_sqlite.so
376%{_libdir}/%{name}/auth/libdriver_sqlite.so
377%{_libdir}/%{name}/dict/libdriver_sqlite.so
378%endif
379
380%if %{build_ldap}
381%files ldap
382%defattr(-,root,root,-)
383%{_libdir}/%{name}/auth/libauthdb_ldap.so
384%endif
385
386%if %{build_drac}
387%files drac
388%defattr(-,root,root)
389%{_libdir}/%{name}/drac.so
390%{_libdir}/%{name}/imap/drac.so
391%{_libdir}/%{name}/pop3/drac.so
392%doc README.plugin-drac
393%endif
394
395%files devel
396%defattr(-,root,root,-)
397%{_includedir}/%{name}
398%{_libdir}/%{name}/dovecot-config
399
400
401%changelog
402* Mon Aug 10 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.3-1
403- new upstream release
404
405* Wed Jul 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.2-1
406- new upstream release 
407
408* Sun Jul 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.1-1
409- new upstream release
410
411* Tue Jul  7 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.0-1
412- new upstream 1.2.x release
413- update Patch1 to fit new release
414- README.plugin-drac in UTF-8
415
416* Tue Jun  2 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.16-1
417- new upstream release
418
419* Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.15-3
420- rebuilt with MySQL-5.1.34.
421
422* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.15-2
423- add BuildRequires gettext-devel instead of gettext
424
425* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.15-1
426- new upstream release
427- update patch1 to fix new release
428
429* Mon Apr 27 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.14-1
430- new upstream release
431
432* Sun Mar 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.1.13-2
433- rebuilt with openldap-2.4.11
434
435* Sun Mar 22 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.13-1
436- new upstream release
437
438* Sat Feb 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.11-1
439- new upstream release
440
441* Sun Feb 01 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.10-1
442- new upstream release
443
444* Sun Jan 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.8-1
445- new upstream release
446
447* Sat Nov 01 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.6-1
448- new upstream release
449
450* Tue Oct 21 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.4-2
451- change BuildRequires sqlite-devel -> sqlite3-devel
452
453* Mon Oct 20 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.4-1
454- new upstream release
455
456* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.3-1
457- new upstream release
458
459* Sun Aug 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.2-1
460- new upstream release
461- split ldap plugin to subpackage
462- split sql plugins to subpackages
463- add -devel subpackage
464- update drac module, rename to -drac from -plugin-drac
465- add dovecot-sieve
466
467* Mon Mar 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.13-0vl2
468- build for VineSeed (0vl1 is for VinePlus 4.x)
469- new upstream release
470
471* Mon Jan 07 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.10-0vl2
472- build for VineSeed (0vl1 is for VinePlus 4.x)
473- new upstream release with security fix (CVE-2007-6598)
474- turn on daemon stop massage (Already start message is on)
475
476* Sat Dec 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.9-0vl1
477- new upstream source
478
479* Wed Nov 21 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.7-0vl4
480- updated %%install section to support lib64 architecture
481
482* Sun Nov 04 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.7-0vl3
483- rebuild for VineSeed (from VinePlus 4.x)
484
485  * Thu Sep 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.5-0vl1
486  - new upstream release
487  - rebuilt with postgresql-devel 8.2.5
488
489  * Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.3-0vl1
490  - new upstream release
491
492  * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl1
493  - new upstream release
494
495* Sat Nov 03 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.7-0vl2
496- add Require dracd tag in plugin-drac
497
498* Sat Nov 03 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.7-0vl1
499- new upstream release
500
501* Fri Oct 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.5-0vl4
502- fix drac plugin make method
503- change drac.so install method (use sym link)
504- add README.plugin-drac
505
506* Fri Oct 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.5-0vl3
507- add dovecot-openssl.cnf install to doc
508- daemon restart message turn on when package is upgraded
509
510* Tue Oct 09 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.5-0vl2
511- add drac.so (POP bedore SMTP) support
512
513* Mon Oct 08 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.5-0vl1
514- new upstream release
515- drop patch500 (it is included in new release)
516- move Mysql buildreq tag to "if build_mysql" section
517- add Requires: postgresql-libs and Requires: MySQL-shared in "if-endif"
518- add Requires: openldap
519
520* Wed Aug 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0-0.rc17.0vl2
521- add Patch500 to fix directory traversal vulnerability (CVE-2007-2231)
522  note that version 1.0.rc29 and up have been already fixed in upstream
523
524* Mon Jan 08 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0-0.rc17.0vl1
525- new upstream RC release
526
527* Sun Jan 07 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0-0.rc16.0vl1
528- new upstream RC release
529
530* Thu Dec 21 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0-0.rc15.0vl2
531- add Vendor/Distribution tag
532
533* Sun Dec 10 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0-0.rc15.0vl1
534- new upstream RC release
535- add BuildRequires: MySQL-shared, MySQL-devel
536- update patch100
537
538* Mon Oct 30 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0-0.rc7.1vl2
539- rebuilt with MySQL 5.0.27
540
541* Mon Aug 28 2006 IWAI, Masaharu <iwai@alib.jp> 1.0-0.rc7.1vl1
542- new upstream release
543- update default settings patch (Patch100)
544- build with openldap-2.3.24
545
546* Tue Aug  1 2006 IWAI, Masaharu <iwai@alib.jp> 1.0-0.rc2.1vl1
547- first release for Vine Linux
548
549* Mon Jul 17 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.rc2.1
550- reenable inotify and see what happens
551
552* Thu Jul 13 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.rc2
553- update to latest upstream release candidate
554- disable inotify for now, doesn't build -- this needs fixing though
555
556* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.0-0.beta8.2.1
557- rebuild
558
559* Thu Jun 08 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta8.2
560- put back pop3_uidl_format default that got lost
561  in the beta2->beta7 upgrade (would cause pop3 to not work
562  at all in many situations)
563
564* Thu May 04 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta8.1
565- upgrade to latest upstream beta release (beta8)
566- contains a security fix in mbox handling
567
568* Thu May 04 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta7.1
569- upgrade to latest upstream beta release
570- fixed BR 173048
571
572* Fri Mar 17 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.8
573- fix sqlite detection in upstream configure checks, second part
574  of #182240
575
576* Wed Mar  8 2006 Bill Nottingham <notting@redhat.com> - 1.0-0.beta2.7
577- fix scriplet noise some more
578
579* Mon Mar  6 2006 Jeremy Katz <katzj@redhat.com> - 1.0-0.beta2.6
580- fix scriptlet error (mitr, #184151)
581
582* Mon Feb 27 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.5
583- fix #182240 by looking in lib64 for libs first and then lib
584- fix comment #1 in #182240 by copying over the example config files
585  to documentation directory
586
587* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.0-0.beta2.4.1
588- bump again for double-long bug on ppc(64)
589
590* Thu Feb 09 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.4
591- enable inotify as it should work now (#179431)
592
593* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.0-0.beta2.3.1
594- rebuilt for new gcc4.1 snapshot and glibc changes
595
596* Thu Feb 02 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.3
597- change the compiled-in defaults and adjust the default's configfile
598  commented-out example settings to match compiled-in defaults,
599  instead of changing the defaults only in the configfile, as per #179432
600- fix #179574 by providing a default uidl_format for pop3
601- half-fix #179620 by having plaintext auth enabled by default... this
602  needs more thinking (which one we really want) and documentation
603  either way
604
605* Tue Jan 31 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.2
606- update URL in description
607- call dovecot --build-ssl-parameters in postinst as per #179430
608
609* Mon Jan 30 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.1
610- fix spec to work with BUILD_DIR != SOURCE_DIR
611- forward-port and split pam-nocred patch
612
613* Mon Jan 23 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2
614- new upstream version, hopefully fixes #173928, #163550
615- fix #168866, use install -p to install documentation
616
617* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
618- rebuilt
619
620* Sat Nov 12 2005 Tom Lane <tgl@redhat.com> - 0.99.14-10.fc5
621- Rebuild due to mysql update.
622
623* Wed Nov  9 2005 Tomas Mraz <tmraz@redhat.com> - 0.99.14-9.fc5
624- rebuilt with new openssl
625
626* Fri Sep 30 2005 Tomas Mraz <tmraz@redhat.com> - 0.99.14-8.fc5
627- use include instead of pam_stack in pam config
628
629* Wed Jul 27 2005 John Dennis <jdennis@redhat.com> - 0.99.14-7.fc5
630- fix bug #150888, log authenication failures with ip address
631
632* Fri Jul 22 2005 John Dennis <jdennis@redhat.com> - 0.99.14-6.fc5
633- fix bug #149673, add dummy PAM_TTY
634
635* Thu Apr 28 2005 John Dennis <jdennis@redhat.com> - 0.99.14-5.fc4
636- fix bug #156159 insecure location of restart flag file
637
638* Fri Apr 22 2005 John Dennis <jdennis@redhat.com> - 0.99.14-4.fc4
639- openssl moved its certs, CA, etc. from /usr/share/ssl to /etc/pki
640
641* Tue Apr 12 2005 Tom Lane <tgl@redhat.com> 0.99.14-3.fc4
642- Rebuild for Postgres 8.0.2 (new libpq major version).
643
644* Mon Mar  7 2005 John Dennis <jdennis@redhat.com> 0.99.14-2.fc4
645- bump rev for gcc4 build
646
647* Mon Feb 14 2005 John Dennis <jdennis@redhat.com> - 0.99.14-1.fc4
648- fix bug #147874, update to 0.99.14 release
649  v0.99.14 2005-02-11  Timo Sirainen <tss at iki.fi>
650  - Message address fields are now parsed differently, fixing some
651    issues with spaces. Affects only clients which use FETCH ENVELOPE
652    command.
653  - Message MIME parser was somewhat broken with missing MIME boundaries
654  - mbox: Don't allow X-UID headers in mails to override the UIDs we
655    would otherwise set. Too large values can break some clients and
656    cause other trouble.
657  - passwd-file userdb wasn't working
658  - PAM crashed with 64bit systems
659  - non-SSL inetd startup wasn't working
660  - If UID FETCH notices and skips an expunged message, don't return
661    a NO reply. It's not needed and only makes clients give error
662    messages.
663
664* Wed Feb  2 2005 John Dennis <jdennis@redhat.com> - 0.99.13-4.devel
665- fix bug #146198, clean up temp kerberos tickets
666
667* Mon Jan 17 2005 John Dennis <jdennis@redhat.com> 0.99.13-3.devel
668- fix bug #145214, force mbox_locks to fcntl only
669- fix bug #145241, remove prereq on postgres and mysql, allow rpm auto
670  dependency generator to pick up client lib dependency if needed.
671
672* Thu Jan 13 2005 John Dennis <jdennis@redhat.com> 0.99.13-2.devel
673- make postgres & mysql conditional build
674- remove execute bit on migration example scripts so rpm does not pull
675  in additional dependences on perl and perl modules that are not present
676  in dovecot proper.
677- add REDHAT-FAQ.txt to doc directory
678
679* Thu Jan  6 2005 John Dennis <jdennis@redhat.com> 0.99.13-1.devel
680- bring up to date with latest upstream, 0.99.13, bug #143707
681  also fix bug #14462, bad dovecot-uid macro name
682
683* Thu Jan  6 2005 John Dennis <jdennis@redhat.com> 0.99.11-10.devel
684- fix bug #133618, removed LITERAL+ capability from capability string
685
686* Wed Jan  5 2005 John Dennis <jdennis@redhat.com> 0.99.11-9.devel
687- fix bug #134325, stop dovecot during installation
688
689* Wed Jan  5 2005 John Dennis <jdennis@redhat.com> 0.99.11-8.devel
690- fix bug #129539, dovecot starts too early,
691  set chkconfig to 65 35 to match cyrus-imapd
692- also delete some old commented out code from SSL certificate creation
693
694* Thu Dec 23 2004 John Dennis <jdennis@redhat.com> 0.99.11-7.devel
695- add UW to Dovecot migration documentation and scripts, bug #139954
696  fix SSL documentation and scripts, add missing documentation, bug #139276
697
698* Thu Nov 15 2004 Warren Togami <wtogami@redhat.com> 0.99.11-2.FC4.1
699- rebuild against MySQL4
700
701* Thu Oct 21 2004 John Dennis <jdennis@redhat.com>
702- fix bug #136623
703  Change License field from GPL to LGPL to reflect actual license
704
705* Thu Sep 30 2004 John Dennis <jdennis@redhat.com> 0.99.11-1.FC3.3
706- fix bug #124786, listen to ipv6 as well as ipv4
707
708* Wed Sep  8 2004 John Dennis <jdennis@redhat.com> 0.99.11-1.FC3.1
709- bring up to latest upstream,
710  comments from Timo Sirainen <tss at iki.fi> on release v0.99.11 2004-09-04 
711  + 127.* and ::1 IP addresses are treated as secured with
712    disable_plaintext_auth = yes
713  + auth_debug setting for extra authentication debugging
714  + Some documentation and error message updates
715  + Create PID file in /var/run/dovecot/master.pid
716  + home setting is now optional in static userdb
717  + Added mail setting to static userdb
718  - After APPENDing to selected mailbox Dovecot didn't always notice the
719    new mail immediately which broke some clients
720  - THREAD and SORT commands crashed with some mails
721  - If APPENDed mail ended with CR character, Dovecot aborted the saving
722  - Output streams sometimes sent data duplicated and lost part of it.
723    This could have caused various strange problems, but looks like in
724    practise it rarely caused real problems.
725
726* Wed Aug  4 2004 John Dennis <jdennis@redhat.com>
727- change release field separator from comma to dot, bump build number
728
729* Mon Aug  2 2004 John Dennis <jdennis@redhat.com> 0.99.10.9-1,FC3,1
730- bring up to date with latest upstream, fixes include:
731- LDAP support compiles now with Solaris LDAP library
732- IMAP BODY and BODYSTRUCTURE replies were wrong for MIME parts which
733  didn't contain Content-Type header.
734- MySQL and PostgreSQL auth didn't reconnect if connection was lost
735  to SQL server
736- Linking fixes for dovecot-auth with some systems
737- Last fix for disconnecting client when downloading mail longer than
738  30 seconds actually made it never disconnect client. Now it works
739  properly: disconnect when client hasn't read _any_ data for 30
740  seconds.
741- MySQL compiling got broken in last release
742- More PostgreSQL reconnection fixing
743
744
745* Mon Jul 26 2004 John Dennis <jdennis@redhat.com> 0.99.10.7-1,FC3,1
746- enable postgres and mySQL in build
747- fix configure to look for mysql in alternate locations
748- nuke configure script in tar file, recreate from configure.in using autoconf
749
750- bring up to latest upstream, which included:
751- Added outlook-pop3-no-nuls workaround to fix Outlook hang in mails with NULs.
752- Config file lines can now contain quoted strings ("value ")
753- If client didn't finish downloading a single mail in 30 seconds,
754  Dovecot closed the connection. This was supposed to work so that
755  if client hasn't read data at all in 30 seconds, it's disconnected.
756- Maildir: LIST now doesn't skip symlinks
757
758
759* Wed Jun 30 2004 John Dennis <jdennis@redhat.com>
760- bump rev for build
761- change rev for FC3 build
762
763* Fri Jun 25 2004 John Dennis <jdennis@redhat.com> - 0.99.10.6-1
764- bring up to date with upstream,
765  recent change log comments from Timo Sirainen were:
766  SHA1 password support using OpenSSL crypto library
767  mail_extra_groups setting
768  maildir_stat_dirs setting
769  Added NAMESPACE capability and command
770  Autocreate missing maildirs (instead of crashing)
771  Fixed occational crash in maildir synchronization
772  Fixed occational assertion crash in ioloop.c
773  Fixed FreeBSD compiling issue
774  Fixed issues with 64bit Solaris binary
775
776* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
777- rebuilt
778
779* Thu May 27 2004 David Woodhouse <dwmw2@redhat.com> 0.99.10.5-1
780- Update to 0.99.10.5 to fix maildir segfaults (#123022)
781
782* Fri May 07 2004 Warren Togami <wtogami@redhat.com> 0.99.10.4-4
783- default auth config that is actually usable
784- Timo Sirainen (author) suggested functionality fixes
785  maildir, imap-fetch-body-section, customflags-fix
786
787* Mon Feb 23 2004 Tim Waugh <twaugh@redhat.com>
788- Use ':' instead of '.' as separator for chown.
789
790* Tue Feb 17 2004 Jeremy Katz <katzj@redhat.com> - 0.99.10.4-3
791- restart properly if it dies (#115594)
792
793* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
794- rebuilt
795
796* Mon Nov 24 2003 Jeremy Katz <katzj@redhat.com> 0.99.10.4-1
797- update to 0.99.10.4
798
799* Mon Oct  6 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-7
800- another patch from upstream to fix returning invalid data on partial
801  BODY[part] fetches
802- patch to avoid confusion of draft/deleted in indexes
803
804* Tue Sep 23 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-6
805- add some patches from upstream (#104288)
806
807* Thu Sep  4 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-5
808- fix startup with 2.6 with patch from upstream (#103801)
809
810* Tue Sep  2 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-4
811- fix assert in search code (#103383)
812
813* Tue Jul 22 2003 Nalin Dahyabhai <nalin@redhat.com> 0.99.10-3
814- rebuild
815
816* Thu Jul 17 2003 Bill Nottingham <notting@redhat.com> 0.99.10-2
817- don't run by default
818
819* Thu Jun 26 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-1
820- 0.99.10
821
822* Mon Jun 23 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-0.2
823- 0.99.10-rc2 (includes ssl detection fix)
824- a few tweaks from fedora
825  - noreplace the config file
826  - configure --with-ldap to get LDAP enabled
827
828* Mon Jun 23 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-0.1
829- 0.99.10-rc1
830- add fix for ssl detection
831- add zlib-devel to BuildRequires
832- change pam service name to dovecot
833- include pam config
834
835* Thu May  8 2003 Jeremy Katz <katzj@redhat.com> 0.99.9.1-1
836- update to 0.99.9.1
837- add patch from upstream to fix potential bug when fetching with
838  CR+LF linefeeds
839- tweak some things in the initscript and config file noticed by the
840  fedora folks
841
842* Sun Mar 16 2003 Jeremy Katz <katzj@redhat.com> 0.99.8.1-2
843- fix ssl dir
844- own /var/run/dovecot/login with the correct perms
845- fix chmod/chown in post
846
847* Fri Mar 14 2003 Jeremy Katz <katzj@redhat.com> 0.99.8.1-1
848- update to 0.99.8.1
849
850* Tue Mar 11 2003 Jeremy Katz <katzj@redhat.com> 0.99.8-2
851- add a patch to fix quoting problem from CVS
852
853* Mon Mar 10 2003 Jeremy Katz <katzj@redhat.com> 0.99.8-1
854- 0.99.8
855- add some buildrequires
856- fixup to build with openssl 0.9.7
857- now includes a pop3 daemon (off by default)
858- clean up description and %%preun
859- add dovecot user (uid/gid of 97)
860- add some buildrequires
861- move the ssl cert to %{_datadir}/ssl/certs
862- create a dummy ssl cert in %post
863- own /var/run/dovecot
864- make the config file a source so we get default mbox locks of fcntl
865
866* Sun Dec  1 2002 Seth Vidal <skvidal@phy.duke.edu>
867- 0.99.4 and fix startup so it starts imap-master not vsftpd :)
868
869* Tue Nov 26 2002 Seth Vidal <skvidal@phy.duke.edu>
870- first build
Note: See TracBrowser for help on using the repository browser.