source: projects/specs/trunk/d/dovecot/dovecot-vl.spec @ 2487

Revision 2487, 28.9 KB checked in by Takemikaduchi, 13 years ago (diff)

rebuild with openssl-1.0.0c

Line 
1Summary: Dovecot Secure imap server
2Summary(ja): Dovecot セキュア IMAP サーバ
3Name: dovecot
4Version: 1.2.10
5Release: 3%{?_dist_release}
6License: MIT and LGPLv2 and BSD with advertising
7Group: System Environment/Daemons
8
9%define build_postgres 1
10%define build_mysql 1
11%define build_sqlite 1
12%define build_ldap 1
13
14%define build_sieve 1
15%define sieve_version 1.1.8
16%define sieve_name dovecot-sieve
17
18%define build_drac 1
19
20URL: http://www.dovecot.org/
21
22Source: http://www.dovecot.org/releases/1.1/%{name}-%{version}.tar.gz
23Source1: dovecot.init
24Source2: dovecot.pam
25Source3: maildir-migration.txt
26Source4: migrate-folders
27Source5: migrate-users
28Source6: perfect_maildir.pl
29Source7: dovecot-REDHAT-FAQ.txt
30Source8: http://dovecot.org/releases/sieve/%{sieve_name}-%{sieve_version}.tar.gz
31Source9: dovecot.sysconfig
32
33Source100: http://www.dovecot.org/patches/1.1/drac.c
34Source110: README.plugin-drac
35
36Patch1: dovecot-1.2-default-settings.patch
37Patch2: dovecot-1.0.beta2-mkcert-permissions.patch
38# local filesystem rules
39Patch3: dovecot-1.0.rc7-mkcert-paths.patch
40
41Packager: iwamoto
42Vendor: Project Vine
43Distribution: Vine Linux
44
45Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
46BuildRequires: openssl-devel, pam-devel, zlib-devel
47BuildRequires: bzip2-devel, libcap-devel
48BuildRequires: libtool autoconf automake, gettext-devel
49# Package includes an initscript service file,
50# needs to require initscripts package
51Requires: initscripts
52Requires(pre): /usr/sbin/useradd
53Requires(post): /sbin/chkconfig, /usr/sbin/useradd, /sbin/chkconfig
54Requires(preun): /usr/sbin/userdel, /usr/sbin/groupdel
55Requires(preun): /sbin/chkconfig, /sbin/service
56Requires(postun): /sbin/service
57
58%if %{build_postgres}
59BuildRequires: postgresql-devel
60%endif
61
62%if %{build_mysql}
63BuildRequires: mysql-devel
64%endif
65
66%if %{build_sqlite}
67BuildRequires: sqlite3-devel
68%endif
69
70%if %{build_ldap}
71BuildRequires: openldap-devel
72%endif
73
74%if %{build_drac}
75BuildRequires: dracd
76%endif
77
78%define docdir %{_docdir}/%{name}
79%define ssldir %{_sysconfdir}/pki/%{name}
80
81%description
82Dovecot is an IMAP server for Linux/UNIX-like systems, written with security
83primarily in mind.  It also contains a small POP3 server.  It supports mail
84in either of maildir or mbox formats.
85
86The SQL drivers and authentication plugins are in their subpackages.
87
88
89%if %{build_sieve}
90%package sieve
91Requires: %{name} = %{version}-%{release}
92Summary: CMU Sieve plugin for dovecot LDA
93Group: System Environment/Daemons
94License: MIT and LGPLv2+
95
96%description sieve
97This package provides the CMU Sieve plugin version %{sieve_version} for dovecot LDA.
98%endif
99
100%if %{build_postgres}
101%package pgsql
102Requires: %{name} = %{version}-%{release}
103Summary: Postgres SQL backend for dovecot
104Group: System Environment/Daemons
105%description pgsql
106This package provides the Postgres SQL backend for dovecot-auth etc.
107%endif
108
109%if %{build_mysql}
110%package mysql
111Requires: %{name} = %{version}-%{release}
112Summary: MySQL backend for dovecot
113Group: System Environment/Daemons
114%description mysql
115This package provides the MySQL backend for dovecot-auth etc.
116%endif
117
118%if %{build_sqlite}
119%package sqlite
120Requires: %{name} = %{version}-%{release}
121Summary: SQLite backend for dovecot
122Group: System Environment/Daemons
123%description sqlite
124This package provides the SQLite backend for dovecot-auth etc.
125%endif
126
127%if %{build_ldap}
128%package ldap
129Requires: %{name} = %{version}-%{release}
130Summary: LDAP auth plugin for dovecot
131Group: System Environment/Daemons
132%description ldap
133This package provides the LDAP auth plugin for dovecot-auth etc.
134%endif
135
136%if %{build_drac}
137%package drac
138Summary: Dovecot plugin module for support drac (POP before SMTP)
139Group: System Environment/Daemons
140Requires: %{name} = %{version}-%{release}
141Requires: dracd
142Obsoletes: %{name}-plugin-drac < %{version}-%{release}
143
144%description drac
145Dovecot plugin module for support drac (POP before SMTP)
146%endif
147
148%package devel
149Requires: %{name} = %{version}-%{release}
150Summary: Development files dor dovecot
151Group: Development/Libraries
152%description devel
153This package provides the development files for dovecot.
154
155
156%prep
157
158%setup -q
159
160cp %{SOURCE100} .
161cp %{SOURCE110} .
162
163%patch1 -p1 -b .default-settings
164%patch2 -p1 -b .mkcert-permissions
165%patch3 -p1 -b .mkcert-paths
166
167%if %{build_sieve}
168%setup -q -D -T -a 8
169%endif
170
171%build
172rm -f ./configure
173autoreconf -i -f
174%configure                           \
175    INSTALL_DATA="install -c -p -m644" \
176    --enable-header-install      \
177    --disable-static             \
178%if %{build_postgres}
179    --with-pgsql                 \
180%endif
181%if %{build_mysql}
182    --with-mysql                 \
183%endif
184%if %{build_sqlite}
185    --with-sqlite                \
186%endif
187    --with-sql=plugin            \
188    --with-sql-drivers           \
189    --with-ssl=openssl           \
190    --with-ssldir=%{ssldir}      \
191%if %{build_ldap}
192    --with-ldap=plugin
193%endif
194
195make %{?_smp_mflags}
196
197%if %{build_sieve}
198pushd %{sieve_name}-%{sieve_version}
199rm -f ./configure
200autoreconf -i -f
201%configure                           \
202    INSTALL_DATA="install -c -p -m644" \
203    --disable-static                 \
204    --with-dovecot=../
205
206make %{?_smp_mflags}
207popd
208%endif
209
210%if %{build_drac}
211%{__cc} -Wall -W -shared -fPIC -DHAVE_CONFIG_H \
212    -I. -I./src/lib \
213    drac.c -o drac.so -ldrac
214%endif
215
216%install
217rm -rf $RPM_BUILD_ROOT
218make install DESTDIR=$RPM_BUILD_ROOT
219rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}
220
221install -p -m 755 src/plugins/convert/convert-tool $RPM_BUILD_ROOT%{_libexecdir}/%{name}
222
223mkdir -p $RPM_BUILD_ROOT%{_initrddir}
224install -p -m 755 %{SOURCE1} $RPM_BUILD_ROOT%{_initrddir}/dovecot
225
226mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pam.d
227install -p -m 644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/dovecot
228
229mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
230install -p -m 600 %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/dovecot
231
232# generate ghost .pem file
233mkdir -p $RPM_BUILD_ROOT%{ssldir}/certs
234mkdir -p $RPM_BUILD_ROOT%{ssldir}/private
235touch $RPM_BUILD_ROOT%{ssldir}/certs/dovecot.pem
236chmod 600 $RPM_BUILD_ROOT%{ssldir}/certs/dovecot.pem
237touch $RPM_BUILD_ROOT%{ssldir}/private/dovecot.pem
238chmod 600 $RPM_BUILD_ROOT%{ssldir}/private/dovecot.pem
239
240mkdir -p $RPM_BUILD_ROOT/var/run/dovecot/login
241chmod 755 $RPM_BUILD_ROOT/var/run/dovecot
242chmod 700 $RPM_BUILD_ROOT/var/run/dovecot/login
243       
244# Install dovecot.conf and dovecot-openssl.cnf
245mkdir -p $RPM_BUILD_ROOT%{ssldir}
246install -p -m644 dovecot-example.conf $RPM_BUILD_ROOT%{_sysconfdir}/dovecot.conf
247rm -f $RPM_BUILD_ROOT%{_sysconfdir}/dovecot-*example.conf # dovecot seems to install this by itself
248install -p -m644 doc/dovecot-openssl.cnf $RPM_BUILD_ROOT%{ssldir}/dovecot-openssl.cnf
249
250# Install some of our own documentation
251install -p -m644 %{SOURCE7} $RPM_BUILD_ROOT%{docdir}/REDHAT-FAQ.txt
252
253# Install the licensing files into the documentation area
254install -p -m644 COPYING* $RPM_BUILD_ROOT%{docdir}
255
256mkdir -p $RPM_BUILD_ROOT%{docdir}/examples/
257install -p -m755 doc/mkcert.sh $RPM_BUILD_ROOT%{_libexecdir}/%{name}/mkcert.sh
258for f in `cd doc; echo *.conf`; do
259     install -p -m644 doc/$f $RPM_BUILD_ROOT%{docdir}/examples/$f;
260done
261
262install -p -m755 -d $RPM_BUILD_ROOT%{docdir}/UW-to-Dovecot-Migration
263for f in %{SOURCE3} %{SOURCE4} %{SOURCE5} %{SOURCE6}
264do
265    install -p -m644 $f $RPM_BUILD_ROOT%{docdir}/UW-to-Dovecot-Migration
266done
267
268mv $RPM_BUILD_ROOT%{docdir} $RPM_BUILD_ROOT%{docdir}-%{version}
269mkdir -p $RPM_BUILD_ROOT/var/lib/dovecot
270
271%if %{build_sieve}
272# dovecot-sieve
273pushd %{sieve_name}-%{sieve_version}
274make install DESTDIR=$RPM_BUILD_ROOT
275popd
276%endif
277
278%if %{build_drac}
279install -m 755 drac.so $RPM_BUILD_ROOT/%{_libdir}/dovecot/
280ln -s ../drac.so $RPM_BUILD_ROOT/%{_libdir}/dovecot/imap/
281ln -s ../drac.so $RPM_BUILD_ROOT/%{_libdir}/dovecot/pop3/
282%endif
283
284#remove the libtool archives
285find $RPM_BUILD_ROOT%{_libdir}/%{name}/ -name '*.la' | xargs rm -f
286
287#prepare the filelist
288(
289    find ${RPM_BUILD_ROOT}%{_libdir}/%{name} -type d | sed -e "s|^|%dir |";
290    find ${RPM_BUILD_ROOT}%{_libdir}/%{name} -! -type d | \
291        grep -v 'dovecot-config\|lib90_cmusieve_plugin\.so\|libdriver_.*\.so\|libauthdb_.*\.so\|libmech_.*\.so\|drac\.so';
292) | sed -e "s|$RPM_BUILD_ROOT||" >libs.filelist
293
294
295%clean
296rm -rf $RPM_BUILD_ROOT
297
298
299%pre
300getent group dovecot >/dev/null || groupadd -r dovecot
301getent passwd dovecot >/dev/null || \
302useradd -r -g dovecot -d /usr/libexec/dovecot -s /sbin/nologin -c "Dovecot IMAP server" dovecot
303exit 0
304
305%post
306/sbin/chkconfig --add %{name}
307# generate the ssl certificates
308if [ ! -f %{ssldir}/certs/%{name}.pem ]; then
309    SSLDIR=%{ssldir} OPENSSLCONFIG=%{ssldir}/dovecot-openssl.cnf \
310         %{_libexecdir}/%{name}/mkcert.sh &> /dev/null
311fi
312
313if ! test -f /var/run/dovecot/login/ssl-parameters.dat; then
314    dovecot --build-ssl-parameters &>/dev/null
315fi
316exit 0
317
318%preun
319if [ $1 = 0 ]; then
320    /sbin/service %{name} stop > /dev/null 2>&1 || :
321    /sbin/chkconfig --del %{name} || :
322fi
323
324%postun
325if [ "$1" -ge "1" ]; then
326    /sbin/service %{name} condrestart 2>/dev/null || :
327fi
328
329
330%files -f libs.filelist
331%defattr(-,root,root,-)
332%doc %{docdir}-%{version}
333%config(noreplace) %{_sysconfdir}/dovecot.conf
334%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/sysconfig/dovecot
335%{_initrddir}/dovecot
336%config(noreplace) %{_sysconfdir}/pam.d/dovecot
337%dir %{ssldir}
338%dir %{ssldir}/certs
339%dir %{ssldir}/private
340%config(noreplace) %{ssldir}/dovecot-openssl.cnf
341%attr(0600,root,root) %ghost %config(missingok,noreplace) %verify(not md5 size mtime) %{ssldir}/certs/dovecot.pem
342%attr(0600,root,root) %ghost %config(missingok,noreplace) %verify(not md5 size mtime) %{ssldir}/private/dovecot.pem
343%{_libexecdir}/%{name}
344%{_sbindir}/dovecot
345%{_sbindir}/dovecotpw
346%attr(0755,root,dovecot) %dir /var/run/dovecot
347%attr(0750,root,dovecot) %dir /var/run/dovecot/login
348# %attr(0755,root,dovecot) %{_libexecdir}/%{name}/mkcert.sh
349%attr(0750,dovecot,dovecot) %dir /var/lib/dovecot
350
351%if %{build_sieve}
352%files sieve
353%defattr(-,root,root,-)
354%{_libdir}/%{name}/lda/lib90_cmusieve_plugin.so
355%endif
356
357%if %{build_mysql}
358%files mysql
359%defattr(-,root,root,-)
360%{_libdir}/%{name}/sql/libdriver_mysql.so
361%{_libdir}/%{name}/auth/libdriver_mysql.so
362%{_libdir}/%{name}/dict/libdriver_mysql.so
363%endif
364
365%if %{build_postgres}
366%files pgsql
367%defattr(-,root,root,-)
368%{_libdir}/%{name}/sql/libdriver_pgsql.so
369%{_libdir}/%{name}/auth/libdriver_pgsql.so
370%{_libdir}/%{name}/dict/libdriver_pgsql.so
371%endif
372
373%if %{build_sqlite}
374%files sqlite
375%defattr(-,root,root,-)
376%{_libdir}/%{name}/sql/libdriver_sqlite.so
377%{_libdir}/%{name}/auth/libdriver_sqlite.so
378%{_libdir}/%{name}/dict/libdriver_sqlite.so
379%endif
380
381%if %{build_ldap}
382%files ldap
383%defattr(-,root,root,-)
384%{_libdir}/%{name}/auth/libauthdb_ldap.so
385%endif
386
387%if %{build_drac}
388%files drac
389%defattr(-,root,root)
390%{_libdir}/%{name}/drac.so
391%{_libdir}/%{name}/imap/drac.so
392%{_libdir}/%{name}/pop3/drac.so
393%doc README.plugin-drac
394%endif
395
396%files devel
397%defattr(-,root,root,-)
398%{_includedir}/%{name}
399%{_libdir}/%{name}/dovecot-config
400
401
402%changelog
403* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-3
404- rebuild with openssl-1.0.0c
405
406* Mon Jan 25 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.10-2
407- fix drac.so in libs.files
408
409* Mon Jan 25 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.10-1
410- new upstream release
411
412* Fri Jan  8 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.9-1
413- new upstream release
414- update to dovecot sieve 1.1.8
415
416* Thu Sep 17 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.3-2
417- update to dovecot sieve 1.1.7 to fix BoF
418- add BR: bzip2-devel, libcap-devel
419
420* Mon Aug 10 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.3-1
421- new upstream release
422
423* Wed Jul 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.2-1
424- new upstream release 
425
426* Sun Jul 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.1-1
427- new upstream release
428
429* Tue Jul  7 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.0-1
430- new upstream 1.2.x release
431- update Patch1 to fit new release
432- README.plugin-drac in UTF-8
433
434* Tue Jun  2 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.16-1
435- new upstream release
436
437* Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.15-3
438- rebuilt with MySQL-5.1.34.
439
440* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.15-2
441- add BuildRequires gettext-devel instead of gettext
442
443* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.15-1
444- new upstream release
445- update patch1 to fix new release
446
447* Mon Apr 27 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.14-1
448- new upstream release
449
450* Sun Mar 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.1.13-2
451- rebuilt with openldap-2.4.11
452
453* Sun Mar 22 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.13-1
454- new upstream release
455
456* Sat Feb 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.11-1
457- new upstream release
458
459* Sun Feb 01 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.10-1
460- new upstream release
461
462* Sun Jan 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.8-1
463- new upstream release
464
465* Sat Nov 01 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.6-1
466- new upstream release
467
468* Tue Oct 21 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.4-2
469- change BuildRequires sqlite-devel -> sqlite3-devel
470
471* Mon Oct 20 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.4-1
472- new upstream release
473
474* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.3-1
475- new upstream release
476
477* Sun Aug 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.2-1
478- new upstream release
479- split ldap plugin to subpackage
480- split sql plugins to subpackages
481- add -devel subpackage
482- update drac module, rename to -drac from -plugin-drac
483- add dovecot-sieve
484
485* Mon Mar 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.13-0vl2
486- build for VineSeed (0vl1 is for VinePlus 4.x)
487- new upstream release
488
489* Mon Jan 07 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.10-0vl2
490- build for VineSeed (0vl1 is for VinePlus 4.x)
491- new upstream release with security fix (CVE-2007-6598)
492- turn on daemon stop massage (Already start message is on)
493
494* Sat Dec 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.9-0vl1
495- new upstream source
496
497* Wed Nov 21 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.7-0vl4
498- updated %%install section to support lib64 architecture
499
500* Sun Nov 04 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.7-0vl3
501- rebuild for VineSeed (from VinePlus 4.x)
502
503  * Thu Sep 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.5-0vl1
504  - new upstream release
505  - rebuilt with postgresql-devel 8.2.5
506
507  * Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.3-0vl1
508  - new upstream release
509
510  * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl1
511  - new upstream release
512
513* Sat Nov 03 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.7-0vl2
514- add Require dracd tag in plugin-drac
515
516* Sat Nov 03 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.7-0vl1
517- new upstream release
518
519* Fri Oct 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.5-0vl4
520- fix drac plugin make method
521- change drac.so install method (use sym link)
522- add README.plugin-drac
523
524* Fri Oct 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.5-0vl3
525- add dovecot-openssl.cnf install to doc
526- daemon restart message turn on when package is upgraded
527
528* Tue Oct 09 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.5-0vl2
529- add drac.so (POP bedore SMTP) support
530
531* Mon Oct 08 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.5-0vl1
532- new upstream release
533- drop patch500 (it is included in new release)
534- move Mysql buildreq tag to "if build_mysql" section
535- add Requires: postgresql-libs and Requires: MySQL-shared in "if-endif"
536- add Requires: openldap
537
538* Wed Aug 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0-0.rc17.0vl2
539- add Patch500 to fix directory traversal vulnerability (CVE-2007-2231)
540  note that version 1.0.rc29 and up have been already fixed in upstream
541
542* Mon Jan 08 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0-0.rc17.0vl1
543- new upstream RC release
544
545* Sun Jan 07 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0-0.rc16.0vl1
546- new upstream RC release
547
548* Thu Dec 21 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0-0.rc15.0vl2
549- add Vendor/Distribution tag
550
551* Sun Dec 10 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0-0.rc15.0vl1
552- new upstream RC release
553- add BuildRequires: MySQL-shared, MySQL-devel
554- update patch100
555
556* Mon Oct 30 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0-0.rc7.1vl2
557- rebuilt with MySQL 5.0.27
558
559* Mon Aug 28 2006 IWAI, Masaharu <iwai@alib.jp> 1.0-0.rc7.1vl1
560- new upstream release
561- update default settings patch (Patch100)
562- build with openldap-2.3.24
563
564* Tue Aug  1 2006 IWAI, Masaharu <iwai@alib.jp> 1.0-0.rc2.1vl1
565- first release for Vine Linux
566
567* Mon Jul 17 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.rc2.1
568- reenable inotify and see what happens
569
570* Thu Jul 13 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.rc2
571- update to latest upstream release candidate
572- disable inotify for now, doesn't build -- this needs fixing though
573
574* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.0-0.beta8.2.1
575- rebuild
576
577* Thu Jun 08 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta8.2
578- put back pop3_uidl_format default that got lost
579  in the beta2->beta7 upgrade (would cause pop3 to not work
580  at all in many situations)
581
582* Thu May 04 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta8.1
583- upgrade to latest upstream beta release (beta8)
584- contains a security fix in mbox handling
585
586* Thu May 04 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta7.1
587- upgrade to latest upstream beta release
588- fixed BR 173048
589
590* Fri Mar 17 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.8
591- fix sqlite detection in upstream configure checks, second part
592  of #182240
593
594* Wed Mar  8 2006 Bill Nottingham <notting@redhat.com> - 1.0-0.beta2.7
595- fix scriplet noise some more
596
597* Mon Mar  6 2006 Jeremy Katz <katzj@redhat.com> - 1.0-0.beta2.6
598- fix scriptlet error (mitr, #184151)
599
600* Mon Feb 27 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.5
601- fix #182240 by looking in lib64 for libs first and then lib
602- fix comment #1 in #182240 by copying over the example config files
603  to documentation directory
604
605* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.0-0.beta2.4.1
606- bump again for double-long bug on ppc(64)
607
608* Thu Feb 09 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.4
609- enable inotify as it should work now (#179431)
610
611* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.0-0.beta2.3.1
612- rebuilt for new gcc4.1 snapshot and glibc changes
613
614* Thu Feb 02 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.3
615- change the compiled-in defaults and adjust the default's configfile
616  commented-out example settings to match compiled-in defaults,
617  instead of changing the defaults only in the configfile, as per #179432
618- fix #179574 by providing a default uidl_format for pop3
619- half-fix #179620 by having plaintext auth enabled by default... this
620  needs more thinking (which one we really want) and documentation
621  either way
622
623* Tue Jan 31 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.2
624- update URL in description
625- call dovecot --build-ssl-parameters in postinst as per #179430
626
627* Mon Jan 30 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.1
628- fix spec to work with BUILD_DIR != SOURCE_DIR
629- forward-port and split pam-nocred patch
630
631* Mon Jan 23 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2
632- new upstream version, hopefully fixes #173928, #163550
633- fix #168866, use install -p to install documentation
634
635* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
636- rebuilt
637
638* Sat Nov 12 2005 Tom Lane <tgl@redhat.com> - 0.99.14-10.fc5
639- Rebuild due to mysql update.
640
641* Wed Nov  9 2005 Tomas Mraz <tmraz@redhat.com> - 0.99.14-9.fc5
642- rebuilt with new openssl
643
644* Fri Sep 30 2005 Tomas Mraz <tmraz@redhat.com> - 0.99.14-8.fc5
645- use include instead of pam_stack in pam config
646
647* Wed Jul 27 2005 John Dennis <jdennis@redhat.com> - 0.99.14-7.fc5
648- fix bug #150888, log authenication failures with ip address
649
650* Fri Jul 22 2005 John Dennis <jdennis@redhat.com> - 0.99.14-6.fc5
651- fix bug #149673, add dummy PAM_TTY
652
653* Thu Apr 28 2005 John Dennis <jdennis@redhat.com> - 0.99.14-5.fc4
654- fix bug #156159 insecure location of restart flag file
655
656* Fri Apr 22 2005 John Dennis <jdennis@redhat.com> - 0.99.14-4.fc4
657- openssl moved its certs, CA, etc. from /usr/share/ssl to /etc/pki
658
659* Tue Apr 12 2005 Tom Lane <tgl@redhat.com> 0.99.14-3.fc4
660- Rebuild for Postgres 8.0.2 (new libpq major version).
661
662* Mon Mar  7 2005 John Dennis <jdennis@redhat.com> 0.99.14-2.fc4
663- bump rev for gcc4 build
664
665* Mon Feb 14 2005 John Dennis <jdennis@redhat.com> - 0.99.14-1.fc4
666- fix bug #147874, update to 0.99.14 release
667  v0.99.14 2005-02-11  Timo Sirainen <tss at iki.fi>
668  - Message address fields are now parsed differently, fixing some
669    issues with spaces. Affects only clients which use FETCH ENVELOPE
670    command.
671  - Message MIME parser was somewhat broken with missing MIME boundaries
672  - mbox: Don't allow X-UID headers in mails to override the UIDs we
673    would otherwise set. Too large values can break some clients and
674    cause other trouble.
675  - passwd-file userdb wasn't working
676  - PAM crashed with 64bit systems
677  - non-SSL inetd startup wasn't working
678  - If UID FETCH notices and skips an expunged message, don't return
679    a NO reply. It's not needed and only makes clients give error
680    messages.
681
682* Wed Feb  2 2005 John Dennis <jdennis@redhat.com> - 0.99.13-4.devel
683- fix bug #146198, clean up temp kerberos tickets
684
685* Mon Jan 17 2005 John Dennis <jdennis@redhat.com> 0.99.13-3.devel
686- fix bug #145214, force mbox_locks to fcntl only
687- fix bug #145241, remove prereq on postgres and mysql, allow rpm auto
688  dependency generator to pick up client lib dependency if needed.
689
690* Thu Jan 13 2005 John Dennis <jdennis@redhat.com> 0.99.13-2.devel
691- make postgres & mysql conditional build
692- remove execute bit on migration example scripts so rpm does not pull
693  in additional dependences on perl and perl modules that are not present
694  in dovecot proper.
695- add REDHAT-FAQ.txt to doc directory
696
697* Thu Jan  6 2005 John Dennis <jdennis@redhat.com> 0.99.13-1.devel
698- bring up to date with latest upstream, 0.99.13, bug #143707
699  also fix bug #14462, bad dovecot-uid macro name
700
701* Thu Jan  6 2005 John Dennis <jdennis@redhat.com> 0.99.11-10.devel
702- fix bug #133618, removed LITERAL+ capability from capability string
703
704* Wed Jan  5 2005 John Dennis <jdennis@redhat.com> 0.99.11-9.devel
705- fix bug #134325, stop dovecot during installation
706
707* Wed Jan  5 2005 John Dennis <jdennis@redhat.com> 0.99.11-8.devel
708- fix bug #129539, dovecot starts too early,
709  set chkconfig to 65 35 to match cyrus-imapd
710- also delete some old commented out code from SSL certificate creation
711
712* Thu Dec 23 2004 John Dennis <jdennis@redhat.com> 0.99.11-7.devel
713- add UW to Dovecot migration documentation and scripts, bug #139954
714  fix SSL documentation and scripts, add missing documentation, bug #139276
715
716* Thu Nov 15 2004 Warren Togami <wtogami@redhat.com> 0.99.11-2.FC4.1
717- rebuild against MySQL4
718
719* Thu Oct 21 2004 John Dennis <jdennis@redhat.com>
720- fix bug #136623
721  Change License field from GPL to LGPL to reflect actual license
722
723* Thu Sep 30 2004 John Dennis <jdennis@redhat.com> 0.99.11-1.FC3.3
724- fix bug #124786, listen to ipv6 as well as ipv4
725
726* Wed Sep  8 2004 John Dennis <jdennis@redhat.com> 0.99.11-1.FC3.1
727- bring up to latest upstream,
728  comments from Timo Sirainen <tss at iki.fi> on release v0.99.11 2004-09-04 
729  + 127.* and ::1 IP addresses are treated as secured with
730    disable_plaintext_auth = yes
731  + auth_debug setting for extra authentication debugging
732  + Some documentation and error message updates
733  + Create PID file in /var/run/dovecot/master.pid
734  + home setting is now optional in static userdb
735  + Added mail setting to static userdb
736  - After APPENDing to selected mailbox Dovecot didn't always notice the
737    new mail immediately which broke some clients
738  - THREAD and SORT commands crashed with some mails
739  - If APPENDed mail ended with CR character, Dovecot aborted the saving
740  - Output streams sometimes sent data duplicated and lost part of it.
741    This could have caused various strange problems, but looks like in
742    practise it rarely caused real problems.
743
744* Wed Aug  4 2004 John Dennis <jdennis@redhat.com>
745- change release field separator from comma to dot, bump build number
746
747* Mon Aug  2 2004 John Dennis <jdennis@redhat.com> 0.99.10.9-1,FC3,1
748- bring up to date with latest upstream, fixes include:
749- LDAP support compiles now with Solaris LDAP library
750- IMAP BODY and BODYSTRUCTURE replies were wrong for MIME parts which
751  didn't contain Content-Type header.
752- MySQL and PostgreSQL auth didn't reconnect if connection was lost
753  to SQL server
754- Linking fixes for dovecot-auth with some systems
755- Last fix for disconnecting client when downloading mail longer than
756  30 seconds actually made it never disconnect client. Now it works
757  properly: disconnect when client hasn't read _any_ data for 30
758  seconds.
759- MySQL compiling got broken in last release
760- More PostgreSQL reconnection fixing
761
762
763* Mon Jul 26 2004 John Dennis <jdennis@redhat.com> 0.99.10.7-1,FC3,1
764- enable postgres and mySQL in build
765- fix configure to look for mysql in alternate locations
766- nuke configure script in tar file, recreate from configure.in using autoconf
767
768- bring up to latest upstream, which included:
769- Added outlook-pop3-no-nuls workaround to fix Outlook hang in mails with NULs.
770- Config file lines can now contain quoted strings ("value ")
771- If client didn't finish downloading a single mail in 30 seconds,
772  Dovecot closed the connection. This was supposed to work so that
773  if client hasn't read data at all in 30 seconds, it's disconnected.
774- Maildir: LIST now doesn't skip symlinks
775
776
777* Wed Jun 30 2004 John Dennis <jdennis@redhat.com>
778- bump rev for build
779- change rev for FC3 build
780
781* Fri Jun 25 2004 John Dennis <jdennis@redhat.com> - 0.99.10.6-1
782- bring up to date with upstream,
783  recent change log comments from Timo Sirainen were:
784  SHA1 password support using OpenSSL crypto library
785  mail_extra_groups setting
786  maildir_stat_dirs setting
787  Added NAMESPACE capability and command
788  Autocreate missing maildirs (instead of crashing)
789  Fixed occational crash in maildir synchronization
790  Fixed occational assertion crash in ioloop.c
791  Fixed FreeBSD compiling issue
792  Fixed issues with 64bit Solaris binary
793
794* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
795- rebuilt
796
797* Thu May 27 2004 David Woodhouse <dwmw2@redhat.com> 0.99.10.5-1
798- Update to 0.99.10.5 to fix maildir segfaults (#123022)
799
800* Fri May 07 2004 Warren Togami <wtogami@redhat.com> 0.99.10.4-4
801- default auth config that is actually usable
802- Timo Sirainen (author) suggested functionality fixes
803  maildir, imap-fetch-body-section, customflags-fix
804
805* Mon Feb 23 2004 Tim Waugh <twaugh@redhat.com>
806- Use ':' instead of '.' as separator for chown.
807
808* Tue Feb 17 2004 Jeremy Katz <katzj@redhat.com> - 0.99.10.4-3
809- restart properly if it dies (#115594)
810
811* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
812- rebuilt
813
814* Mon Nov 24 2003 Jeremy Katz <katzj@redhat.com> 0.99.10.4-1
815- update to 0.99.10.4
816
817* Mon Oct  6 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-7
818- another patch from upstream to fix returning invalid data on partial
819  BODY[part] fetches
820- patch to avoid confusion of draft/deleted in indexes
821
822* Tue Sep 23 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-6
823- add some patches from upstream (#104288)
824
825* Thu Sep  4 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-5
826- fix startup with 2.6 with patch from upstream (#103801)
827
828* Tue Sep  2 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-4
829- fix assert in search code (#103383)
830
831* Tue Jul 22 2003 Nalin Dahyabhai <nalin@redhat.com> 0.99.10-3
832- rebuild
833
834* Thu Jul 17 2003 Bill Nottingham <notting@redhat.com> 0.99.10-2
835- don't run by default
836
837* Thu Jun 26 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-1
838- 0.99.10
839
840* Mon Jun 23 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-0.2
841- 0.99.10-rc2 (includes ssl detection fix)
842- a few tweaks from fedora
843  - noreplace the config file
844  - configure --with-ldap to get LDAP enabled
845
846* Mon Jun 23 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-0.1
847- 0.99.10-rc1
848- add fix for ssl detection
849- add zlib-devel to BuildRequires
850- change pam service name to dovecot
851- include pam config
852
853* Thu May  8 2003 Jeremy Katz <katzj@redhat.com> 0.99.9.1-1
854- update to 0.99.9.1
855- add patch from upstream to fix potential bug when fetching with
856  CR+LF linefeeds
857- tweak some things in the initscript and config file noticed by the
858  fedora folks
859
860* Sun Mar 16 2003 Jeremy Katz <katzj@redhat.com> 0.99.8.1-2
861- fix ssl dir
862- own /var/run/dovecot/login with the correct perms
863- fix chmod/chown in post
864
865* Fri Mar 14 2003 Jeremy Katz <katzj@redhat.com> 0.99.8.1-1
866- update to 0.99.8.1
867
868* Tue Mar 11 2003 Jeremy Katz <katzj@redhat.com> 0.99.8-2
869- add a patch to fix quoting problem from CVS
870
871* Mon Mar 10 2003 Jeremy Katz <katzj@redhat.com> 0.99.8-1
872- 0.99.8
873- add some buildrequires
874- fixup to build with openssl 0.9.7
875- now includes a pop3 daemon (off by default)
876- clean up description and %%preun
877- add dovecot user (uid/gid of 97)
878- add some buildrequires
879- move the ssl cert to %{_datadir}/ssl/certs
880- create a dummy ssl cert in %post
881- own /var/run/dovecot
882- make the config file a source so we get default mbox locks of fcntl
883
884* Sun Dec  1 2002 Seth Vidal <skvidal@phy.duke.edu>
885- 0.99.4 and fix startup so it starts imap-master not vsftpd :)
886
887* Tue Nov 26 2002 Seth Vidal <skvidal@phy.duke.edu>
888- first build
Note: See TracBrowser for help on using the repository browser.