source: projects/specs/trunk/c/curl/curl-vl.spec @ 9068

Revision 9068, 11.2 KB checked in by iwamoto, 10 years ago (diff)

curl: update to 7.39.0 with security fix

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
4Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
5Name: curl
6Version: 7.39.0
7Release: 1%{?_dist_release}
8
9License: MIT
10Group: Applications/Internet
11URL: http://curl.haxx.se/
12Source: http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
13
14# patch making libcurl multilib ready
15Patch101: 0101-curl-7.32.0-multilib.patch
16# prevent configure script from discarding -g in CFLAGS (#496778)
17Patch102: 0102-curl-7.32.0-debug.patch
18# make the curl tool link SSL libraries also used by src/tool_metalink.c
19Patch103: 0103-curl-7.32.0-metalink.patch
20# use localhost6 instead of ip6-localhost in the curl test-suite
21Patch104: 0104-curl-7.19.7-localhost6.patch
22# disable valgrind for certain test-cases (libssh2 problem)
23Patch106: 0106-curl-7.21.0-libssh2-valgrind.patch
24# work around valgrind bug (#678518)
25Patch107: 0107-curl-7.21.4-libidn-valgrind.patch
26# Fix character encoding of docs, which are of mixed encoding originally so
27# a simple iconv can't fix them
28Patch108: 0108-curl-7.32.0-utf8.patch
29
30BuildRoot: %{_tmppath}/%{name}-%{version}-root
31BuildRequires: openssl-devel libidn-devel zlib-devel
32BuildRequires: openldap-devel gnutls-devel
33BuildRequires: openssh-server
34BuildRequires: openssh-clients
35BuildRequires: pkgconfig
36%if "%{?_dist_release}" != "vl6"
37BuildRequires: libssh2-devel
38%endif
39Requires: ca-certificates
40
41Vendor: Project Vine
42Distribution: Vine Linux
43Packager: daisuke
44
45%description
46cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
47Dict servers, using any of the supported protocols. cURL is designed
48to work without user interaction or any kind of interactivity. cURL
49offers many useful capabilities, like proxy support, user
50authentication, FTP upload, HTTP post, and file transfer resume.
51
52%package devel
53Summary: Files needed for building applications with libcurl.
54Group: Development/Libraries
55Requires: %{name} = %{version}-%{release}
56Requires: openssl-devel libidn-devel zlib-devel
57
58%description devel
59cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
60Dict servers, using any of the supported protocols. The curl-devel
61package includes files needed for developing applications which can
62use cURL's capabilities internally.
63#'
64
65
66## to build compat32 for x86_64 architecture support
67%package -n compat32-%{name}
68Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
69Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
70Group: System Environment/Libraries
71
72%description -n compat32-%{name}
73cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
74Dict servers, using any of the supported protocols. cURL is designed
75to work without user interaction or any kind of interactivity. cURL
76offers many useful capabilities, like proxy support, user
77authentication, FTP upload, HTTP post, and file transfer resume.
78
79%package -n compat32-%{name}-devel
80Summary: Files needed for building applications with libcurl.
81Group: Development/Libraries
82
83%description -n compat32-%{name}-devel
84cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
85Dict servers, using any of the supported protocols. The curl-devel
86package includes files needed for developing applications which can
87use cURL's capabilities internally.
88#'
89
90%prep
91%setup -q
92
93# Fedora patches
94%patch101 -p1
95%patch102 -p1
96%patch103 -p1
97%patch104 -p1
98%patch106 -p1
99%patch107 -p1
100%patch108 -p1
101
102%build
103%configure \
104  --with-ssl=%{_prefix} \
105  --with-gnutls \
106  --with-libidn \
107  --enable-ipv6 \
108  --enable-threaded-resolver \
109  --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
110%if "%{?_dist_release}" != "vl6"
111  --with-libssh2 \
112%endif
113  --enable-ldaps \
114  --disable-static \
115  --enable-hidden-symbols
116
117make %{?_smp_mflags}
118
119%install
120rm -rf $RPM_BUILD_ROOT
121make DESTDIR=$RPM_BUILD_ROOT install
122
123rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
124
125%clean
126rm -rf $RPM_BUILD_ROOT
127
128%post -p /sbin/ldconfig
129
130%postun -p /sbin/ldconfig
131
132%files
133%defattr(-,root,root)
134%doc CHANGES COPYING README
135%doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
136%doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
137%doc docs/TheArtOfHttpScripting docs/TODO
138%{_bindir}/curl
139#{_datadir}/curl/*
140%{_libdir}/*.so.*
141%{_mandir}/man1/*.1*
142
143%files devel
144%defattr(-,root,root)
145%{_bindir}/curl-config
146%{_includedir}/curl
147%{_libdir}/*.so
148%{_libdir}/pkgconfig/*.pc
149%{_mandir}/man1/curl-config.1*
150%{_mandir}/man3/*
151%{_datadir}/aclocal/libcurl.m4
152
153
154## to build compat32 for x86_64 architecture support
155%if %{build_compat32}
156%files -n compat32-%{name}
157%defattr(-,root,root)
158%{_libdir}/*.so.*
159
160%files -n compat32-%{name}-devel
161%defattr(-,root,root)
162%{_libdir}/*.so
163%{_libdir}/pkgconfig/*.pc
164%endif
165
166%changelog
167* Sun Nov  9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.39.0-1
168- new upstream release with security fix
169
170* Sun Jan 19 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 7.34.0-1
171- new upstream release
172- add libcurl.m4 to -devel package
173
174* Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 7.32.0-1
175- new upstream release
176- import upstream/fedora patches
177- disable libssh2 on Vine Linux 6
178
179* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.1-1
180- new upstream reelase
181
182* Sun Oct 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.0-1
183- update to 7.28.0
184- add configure options
185  - --enable-ssh2, --enable-threaded-resolver, --enable-ldaps
186- add BR: libssh2-devel, openssh-clients, openssh-server, pkgconfig
187 
188- use ca-certificates package
189  - --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt
190  - R: ca-certificates
191
192* Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 7.24.0-1
193- new upstream release
194
195* Sun Jul  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-4
196- add patch100 for fix CVE-2011-2192 (gssapi)
197- add Vendor/Distri tags
198
199* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
200- rebuild with openssl-1.0.0c
201
202* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
203- rebuilt with rpm-4.8.1 for pkg-config
204
205* Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
206- new upstream release
207
208* Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
209- new upstream release with security fix
210
211* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
212- added compat32 subpackages
213
214* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
215- new upstream release
216- use "_smp_mflags" flag
217
218* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
219- rebuild with openldap-2.4.11
220- add BR: openldap-devel
221- remove static library
222
223* Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
224- new upstream release with security fix (CVE-2009-0037)
225
226* Sun Jul  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
227- new upstream release
228
229* Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
230- new upstream release
231
232* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
233- new upstream release
234
235* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
236- new upstream release
237
238* Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
239- new upstream release
240
241* Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
242- rebuilt with openssl-0.9.8e
243
244* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
245- new upstream release
246
247* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
248- new upstream release
249
250* Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
251- new upstream release
252- add pkgconfig file to devel package
253
254* Wed Dec  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
255- new upstream release
256
257* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
258- new upstream release
259
260* Fri Sep  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
261- new upstream release
262
263* Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
264- added libidn, zlib in Requires
265- added libidn-devel, zlib-devel in BuildPrereq
266- added zlib-devel in curl-devel's Requires
267
268* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
269- added openssl-devel, libidn-devel in curl-devel's Requires
270
271* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
272- new upstream release
273
274* Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
275- new upstream release
276- rebuild with openssl-0.9.7d
277
278* Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
279- upstream release
280
281* Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
282- add %%{_datadir}/curl/* to %%files section
283
284* Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
285- source upgrade
286
287* Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
288- source upgrade
289- add PreReq: ldconfig
290- add %%{_libdir}/*.la to %%files devel section
291
292* Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
293- build for VineSeed
294- add Requires: openssl
295
296* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
297- automated rebuild
298
299* Wed Jan  9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
300- 7.9.2
301
302* Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
303- include curl-config in curl-devel
304- update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
305
306* Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
307- added openssl-devel build req
308
309* Mon May 21 2001 Tim Powers <timp@redhat.com>
310- built for the distro
311
312* Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
313- upgrade to curl-7.7.2.
314- enable IPv6.
315
316* Fri Mar  2 2001 Tim Powers <timp@redhat.com>
317- rebuilt against openssl-0.9.6-1
318
319* Thu Jan  4 2001 Tim Powers <timp@redhat.com>
320- fixed mising ldconfigs
321- updated to 7.5.2, bug fixes
322
323* Mon Dec 11 2000 Tim Powers <timp@redhat.com>
324- updated to 7.5.1
325
326* Mon Nov  6 2000 Tim Powers <timp@redhat.com>
327- update to 7.4.1 to fix bug #20337, problems with curl -c
328- not using patch anymore, it's included in the new source. Keeping
329  for reference
330
331* Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
332- fix bogus req in -devel package
333
334* Fri Oct 20 2000 Tim Powers <timp@redhat.com>
335- devel package needed defattr so that root owns the files
336
337* Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
338- update to 7.3
339- apply vsprintf/vsnprintf patch from Colin Phipps via Debian
340
341* Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
342- enable SSL support
343- fix packager tag
344- move buildroot to %%{_tmppath}
345
346* Tue Aug 1 2000 Tim Powers <timp@redhat.com>
347- fixed vendor tag for bug #15028
348
349* Mon Jul 24 2000 Prospector <prospector@redhat.com>
350- rebuilt
351
352* Tue Jul 11 2000 Tim Powers <timp@redhat.com>
353- workaround alpha build problems with optimizations
354
355* Mon Jul 10 2000 Tim Powers <timp@redhat.com>
356- rebuilt
357
358* Mon Jun 5 2000 Tim Powers <timp@redhat.com>
359- put man pages in correct place
360- use %%makeinstall
361
362* Mon Apr 24 2000 Tim Powers <timp@redhat.com>
363- updated to 6.5.2
364
365* Wed Nov 3 1999 Tim Powers <timp@redhat.com>
366- updated sources to 6.2
367- gzip man page
368
369* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
370- changed group
371
372* Thu Aug 26 1999 Tim Powers <timp@redhat.com>
373- changelog started
374- general cleanups, changed prefix to /usr, added manpage to files section
375- including in Powertools
Note: See TracBrowser for help on using the repository browser.