source: projects/specs/trunk/c/curl/curl-vl.spec @ 9628

Revision 9628, 11.3 KB checked in by tomop, 9 years ago (diff)

curl-7.43.0-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
4Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
5Name: curl
6Version: 7.43.0
7Release: 1%{?_dist_release}
8
9License: MIT
10Group: Applications/Internet
11URL: http://curl.haxx.se/
12Source: http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
13
14# patch making libcurl multilib ready
15Patch101: 0101-curl-7.32.0-multilib.patch
16# prevent configure script from discarding -g in CFLAGS (#496778)
17Patch102: 0102-curl-7.32.0-debug.patch
18# make the curl tool link SSL libraries also used by src/tool_metalink.c
19Patch103: 0103-curl-7.32.0-metalink.patch
20# use localhost6 instead of ip6-localhost in the curl test-suite
21Patch104: 0104-curl-7.19.7-localhost6.patch
22# disable valgrind for certain test-cases (libssh2 problem)
23Patch106: 0106-curl-7.21.0-libssh2-valgrind.patch
24# work around valgrind bug (#678518)
25Patch107: 0107-curl-7.21.4-libidn-valgrind.patch
26# Fix character encoding of docs, which are of mixed encoding originally so
27
28BuildRoot: %{_tmppath}/%{name}-%{version}-root
29BuildRequires: openssl-devel libidn-devel zlib-devel
30BuildRequires: openldap-devel gnutls-devel
31BuildRequires: openssh-server
32BuildRequires: openssh-clients
33BuildRequires: pkgconfig
34%if "%{?_dist_release}" != "vl6"
35BuildRequires: libssh2-devel
36%endif
37Requires: ca-certificates
38
39Vendor: Project Vine
40Distribution: Vine Linux
41Packager: daisuke
42
43%description
44cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
45Dict servers, using any of the supported protocols. cURL is designed
46to work without user interaction or any kind of interactivity. cURL
47offers many useful capabilities, like proxy support, user
48authentication, FTP upload, HTTP post, and file transfer resume.
49
50%package devel
51Summary: Files needed for building applications with libcurl.
52Group: Development/Libraries
53Requires: %{name} = %{version}-%{release}
54Requires: openssl-devel libidn-devel zlib-devel
55
56%description devel
57cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
58Dict servers, using any of the supported protocols. The curl-devel
59package includes files needed for developing applications which can
60use cURL's capabilities internally.
61#'
62
63
64## to build compat32 for x86_64 architecture support
65%package -n compat32-%{name}
66Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
67Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
68Group: System Environment/Libraries
69
70%description -n compat32-%{name}
71cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
72Dict servers, using any of the supported protocols. cURL is designed
73to work without user interaction or any kind of interactivity. cURL
74offers many useful capabilities, like proxy support, user
75authentication, FTP upload, HTTP post, and file transfer resume.
76
77%package -n compat32-%{name}-devel
78Summary: Files needed for building applications with libcurl.
79Group: Development/Libraries
80
81%description -n compat32-%{name}-devel
82cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
83Dict servers, using any of the supported protocols. The curl-devel
84package includes files needed for developing applications which can
85use cURL's capabilities internally.
86#'
87
88%prep
89%setup -q
90
91# Fedora patches
92%patch101 -p1
93%patch102 -p1
94%patch103 -p1
95%patch104 -p1
96%patch106 -p1
97%patch107 -p1
98
99%build
100%configure \
101  --with-ssl=%{_prefix} \
102  --with-gnutls \
103  --with-libidn \
104  --enable-ipv6 \
105  --enable-threaded-resolver \
106  --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
107%if "%{?_dist_release}" != "vl6"
108  --with-libssh2 \
109%endif
110  --enable-ldaps \
111  --disable-static \
112  --enable-hidden-symbols
113
114make %{?_smp_mflags}
115
116%install
117rm -rf $RPM_BUILD_ROOT
118make DESTDIR=$RPM_BUILD_ROOT install
119
120rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
121
122%clean
123rm -rf $RPM_BUILD_ROOT
124
125%post -p /sbin/ldconfig
126
127%postun -p /sbin/ldconfig
128
129%files
130%defattr(-,root,root)
131%doc CHANGES COPYING README
132%doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
133%doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
134%doc docs/TheArtOfHttpScripting docs/TODO
135%{_bindir}/curl
136#{_datadir}/curl/*
137%{_libdir}/*.so.*
138%{_mandir}/man1/*.1*
139
140%files devel
141%defattr(-,root,root)
142%{_bindir}/curl-config
143%{_includedir}/curl
144%{_libdir}/*.so
145%{_libdir}/pkgconfig/*.pc
146%{_mandir}/man1/curl-config.1*
147%{_mandir}/man3/*
148%{_datadir}/aclocal/libcurl.m4
149
150
151## to build compat32 for x86_64 architecture support
152%if %{build_compat32}
153%files -n compat32-%{name}
154%defattr(-,root,root)
155%{_libdir}/*.so.*
156
157%files -n compat32-%{name}-devel
158%defattr(-,root,root)
159%{_libdir}/*.so
160%{_libdir}/pkgconfig/*.pc
161%endif
162
163%changelog
164* Fri Jun 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.43.0-1
165- new upstream release with security fix .
166- removed Patch108 (fixed in upstream).
167
168* Sun Nov  9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.39.0-1
169- new upstream release with security fix
170
171* Sun Jan 19 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 7.34.0-1
172- new upstream release
173- add libcurl.m4 to -devel package
174
175* Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 7.32.0-1
176- new upstream release
177- import upstream/fedora patches
178- disable libssh2 on Vine Linux 6
179
180* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.1-1
181- new upstream reelase
182
183* Sun Oct 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.0-1
184- update to 7.28.0
185- add configure options
186  - --enable-ssh2, --enable-threaded-resolver, --enable-ldaps
187- add BR: libssh2-devel, openssh-clients, openssh-server, pkgconfig
188 
189- use ca-certificates package
190  - --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt
191  - R: ca-certificates
192
193* Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 7.24.0-1
194- new upstream release
195
196* Sun Jul  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-4
197- add patch100 for fix CVE-2011-2192 (gssapi)
198- add Vendor/Distri tags
199
200* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
201- rebuild with openssl-1.0.0c
202
203* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
204- rebuilt with rpm-4.8.1 for pkg-config
205
206* Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
207- new upstream release
208
209* Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
210- new upstream release with security fix
211
212* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
213- added compat32 subpackages
214
215* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
216- new upstream release
217- use "_smp_mflags" flag
218
219* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
220- rebuild with openldap-2.4.11
221- add BR: openldap-devel
222- remove static library
223
224* Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
225- new upstream release with security fix (CVE-2009-0037)
226
227* Sun Jul  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
228- new upstream release
229
230* Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
231- new upstream release
232
233* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
234- new upstream release
235
236* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
237- new upstream release
238
239* Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
240- new upstream release
241
242* Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
243- rebuilt with openssl-0.9.8e
244
245* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
246- new upstream release
247
248* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
249- new upstream release
250
251* Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
252- new upstream release
253- add pkgconfig file to devel package
254
255* Wed Dec  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
256- new upstream release
257
258* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
259- new upstream release
260
261* Fri Sep  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
262- new upstream release
263
264* Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
265- added libidn, zlib in Requires
266- added libidn-devel, zlib-devel in BuildPrereq
267- added zlib-devel in curl-devel's Requires
268
269* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
270- added openssl-devel, libidn-devel in curl-devel's Requires
271
272* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
273- new upstream release
274
275* Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
276- new upstream release
277- rebuild with openssl-0.9.7d
278
279* Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
280- upstream release
281
282* Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
283- add %%{_datadir}/curl/* to %%files section
284
285* Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
286- source upgrade
287
288* Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
289- source upgrade
290- add PreReq: ldconfig
291- add %%{_libdir}/*.la to %%files devel section
292
293* Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
294- build for VineSeed
295- add Requires: openssl
296
297* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
298- automated rebuild
299
300* Wed Jan  9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
301- 7.9.2
302
303* Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
304- include curl-config in curl-devel
305- update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
306
307* Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
308- added openssl-devel build req
309
310* Mon May 21 2001 Tim Powers <timp@redhat.com>
311- built for the distro
312
313* Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
314- upgrade to curl-7.7.2.
315- enable IPv6.
316
317* Fri Mar  2 2001 Tim Powers <timp@redhat.com>
318- rebuilt against openssl-0.9.6-1
319
320* Thu Jan  4 2001 Tim Powers <timp@redhat.com>
321- fixed mising ldconfigs
322- updated to 7.5.2, bug fixes
323
324* Mon Dec 11 2000 Tim Powers <timp@redhat.com>
325- updated to 7.5.1
326
327* Mon Nov  6 2000 Tim Powers <timp@redhat.com>
328- update to 7.4.1 to fix bug #20337, problems with curl -c
329- not using patch anymore, it's included in the new source. Keeping
330  for reference
331
332* Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
333- fix bogus req in -devel package
334
335* Fri Oct 20 2000 Tim Powers <timp@redhat.com>
336- devel package needed defattr so that root owns the files
337
338* Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
339- update to 7.3
340- apply vsprintf/vsnprintf patch from Colin Phipps via Debian
341
342* Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
343- enable SSL support
344- fix packager tag
345- move buildroot to %%{_tmppath}
346
347* Tue Aug 1 2000 Tim Powers <timp@redhat.com>
348- fixed vendor tag for bug #15028
349
350* Mon Jul 24 2000 Prospector <prospector@redhat.com>
351- rebuilt
352
353* Tue Jul 11 2000 Tim Powers <timp@redhat.com>
354- workaround alpha build problems with optimizations
355
356* Mon Jul 10 2000 Tim Powers <timp@redhat.com>
357- rebuilt
358
359* Mon Jun 5 2000 Tim Powers <timp@redhat.com>
360- put man pages in correct place
361- use %%makeinstall
362
363* Mon Apr 24 2000 Tim Powers <timp@redhat.com>
364- updated to 6.5.2
365
366* Wed Nov 3 1999 Tim Powers <timp@redhat.com>
367- updated sources to 6.2
368- gzip man page
369
370* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
371- changed group
372
373* Thu Aug 26 1999 Tim Powers <timp@redhat.com>
374- changelog started
375- general cleanups, changed prefix to /usr, added manpage to files section
376- including in Powertools
Note: See TracBrowser for help on using the repository browser.