source: projects/specs/trunk/c/curl/curl-vl.spec @ 8211

Revision 8211, 11.1 KB checked in by daisuke, 10 years ago (diff)

curl: update to 7.34.0, add libcurl.m4 to devel package.

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
4Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
5Name: curl
6Version: 7.34.0
7Release: 1%{?_dist_release}
8
9License: MIT
10Group: Applications/Internet
11URL: http://curl.haxx.se/
12
13Source: http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
14
15# patch making libcurl multilib ready
16Patch101: 0101-curl-7.32.0-multilib.patch
17
18# prevent configure script from discarding -g in CFLAGS (#496778)
19Patch102: 0102-curl-7.32.0-debug.patch
20
21# make the curl tool link SSL libraries also used by src/tool_metalink.c
22Patch103: 0103-curl-7.32.0-metalink.patch
23
24# use localhost6 instead of ip6-localhost in the curl test-suite
25Patch104: 0104-curl-7.19.7-localhost6.patch
26
27# disable valgrind for certain test-cases (libssh2 problem)
28Patch106: 0106-curl-7.21.0-libssh2-valgrind.patch
29
30# work around valgrind bug (#678518)
31Patch107: 0107-curl-7.21.4-libidn-valgrind.patch
32
33# Fix character encoding of docs, which are of mixed encoding originally so
34# a simple iconv can't fix them
35Patch108: 0108-curl-7.32.0-utf8.patch
36
37
38BuildRoot: %{_tmppath}/%{name}-%{version}-root
39BuildRequires: openssl-devel libidn-devel zlib-devel
40BuildRequires: openldap-devel gnutls-devel
41BuildRequires: openssh-server
42BuildRequires: openssh-clients
43BuildRequires: pkgconfig
44%if "%{?_dist_release}" != "vl6"
45BuildRequires: libssh2-devel
46%endif
47Requires: ca-certificates
48
49Vendor: Project Vine
50Distribution: Vine Linux
51Packager: daisuke
52
53%description
54cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
55Dict servers, using any of the supported protocols. cURL is designed
56to work without user interaction or any kind of interactivity. cURL
57offers many useful capabilities, like proxy support, user
58authentication, FTP upload, HTTP post, and file transfer resume.
59
60%package devel
61Summary: Files needed for building applications with libcurl.
62Group: Development/Libraries
63Requires: %{name} = %{version}-%{release}
64Requires: openssl-devel libidn-devel zlib-devel
65
66%description devel
67cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
68Dict servers, using any of the supported protocols. The curl-devel
69package includes files needed for developing applications which can
70use cURL's capabilities internally.
71#'
72
73
74## to build compat32 for x86_64 architecture support
75%package -n compat32-%{name}
76Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
77Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
78Group: System Environment/Libraries
79
80%description -n compat32-%{name}
81cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
82Dict servers, using any of the supported protocols. cURL is designed
83to work without user interaction or any kind of interactivity. cURL
84offers many useful capabilities, like proxy support, user
85authentication, FTP upload, HTTP post, and file transfer resume.
86
87%package -n compat32-%{name}-devel
88Summary: Files needed for building applications with libcurl.
89Group: Development/Libraries
90
91%description -n compat32-%{name}-devel
92cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
93Dict servers, using any of the supported protocols. The curl-devel
94package includes files needed for developing applications which can
95use cURL's capabilities internally.
96#'
97
98%prep
99%setup -q
100
101# Fedora patches
102%patch101 -p1
103%patch102 -p1
104%patch103 -p1
105%patch104 -p1
106%patch106 -p1
107%patch107 -p1
108%patch108 -p1
109
110%build
111%configure \
112  --with-ssl=%{_prefix} \
113  --with-gnutls \
114  --with-libidn \
115  --enable-ipv6 \
116  --enable-threaded-resolver \
117  --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
118%if "%{?_dist_release}" != "vl6"
119  --with-libssh2 \
120%endif
121  --enable-ldaps \
122  --disable-static \
123  --enable-hidden-symbols
124
125make %{?_smp_mflags}
126
127%install
128rm -rf $RPM_BUILD_ROOT
129make DESTDIR=$RPM_BUILD_ROOT install
130
131rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
132
133%clean
134rm -rf $RPM_BUILD_ROOT
135
136%post -p /sbin/ldconfig
137
138%postun -p /sbin/ldconfig
139
140%files
141%defattr(-,root,root)
142%doc CHANGES COPYING README
143%doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
144%doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
145%doc docs/TheArtOfHttpScripting docs/TODO
146%{_bindir}/curl
147#{_datadir}/curl/*
148%{_libdir}/*.so.*
149%{_mandir}/man1/*.1*
150
151%files devel
152%defattr(-,root,root)
153%{_bindir}/curl-config
154%{_includedir}/curl
155%{_libdir}/*.so
156%{_libdir}/pkgconfig/*.pc
157%{_mandir}/man1/curl-config.1*
158%{_mandir}/man3/*
159%{_datadir}/aclocal/libcurl.m4
160
161
162## to build compat32 for x86_64 architecture support
163%if %{build_compat32}
164%files -n compat32-%{name}
165%defattr(-,root,root)
166%{_libdir}/*.so.*
167
168%files -n compat32-%{name}-devel
169%defattr(-,root,root)
170%{_libdir}/*.so
171%{_libdir}/pkgconfig/*.pc
172%endif
173
174%changelog
175* Sun Jan 19 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 7.34.0-1
176- new upstream release
177- add libcurl.m4 to -devel package
178
179* Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 7.32.0-1
180- new upstream release
181- import upstream/fedora patches
182- disable libssh2 on Vine Linux 6
183
184* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.1-1
185- new upstream reelase
186
187* Sun Oct 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.0-1
188- update to 7.28.0
189- add configure options
190  - --enable-ssh2, --enable-threaded-resolver, --enable-ldaps
191- add BR: libssh2-devel, openssh-clients, openssh-server, pkgconfig
192 
193- use ca-certificates package
194  - --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt
195  - R: ca-certificates
196
197* Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 7.24.0-1
198- new upstream release
199
200* Sun Jul  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-4
201- add patch100 for fix CVE-2011-2192 (gssapi)
202- add Vendor/Distri tags
203
204* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
205- rebuild with openssl-1.0.0c
206
207* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
208- rebuilt with rpm-4.8.1 for pkg-config
209
210* Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
211- new upstream release
212
213* Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
214- new upstream release with security fix
215
216* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
217- added compat32 subpackages
218
219* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
220- new upstream release
221- use "_smp_mflags" flag
222
223* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
224- rebuild with openldap-2.4.11
225- add BR: openldap-devel
226- remove static library
227
228* Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
229- new upstream release with security fix (CVE-2009-0037)
230
231* Sun Jul  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
232- new upstream release
233
234* Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
235- new upstream release
236
237* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
238- new upstream release
239
240* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
241- new upstream release
242
243* Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
244- new upstream release
245
246* Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
247- rebuilt with openssl-0.9.8e
248
249* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
250- new upstream release
251
252* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
253- new upstream release
254
255* Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
256- new upstream release
257- add pkgconfig file to devel package
258
259* Wed Dec  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
260- new upstream release
261
262* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
263- new upstream release
264
265* Fri Sep  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
266- new upstream release
267
268* Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
269- added libidn, zlib in Requires
270- added libidn-devel, zlib-devel in BuildPrereq
271- added zlib-devel in curl-devel's Requires
272
273* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
274- added openssl-devel, libidn-devel in curl-devel's Requires
275
276* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
277- new upstream release
278
279* Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
280- new upstream release
281- rebuild with openssl-0.9.7d
282
283* Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
284- upstream release
285
286* Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
287- add %%{_datadir}/curl/* to %%files section
288
289* Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
290- source upgrade
291
292* Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
293- source upgrade
294- add PreReq: ldconfig
295- add %%{_libdir}/*.la to %%files devel section
296
297* Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
298- build for VineSeed
299- add Requires: openssl
300
301* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
302- automated rebuild
303
304* Wed Jan  9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
305- 7.9.2
306
307* Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
308- include curl-config in curl-devel
309- update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
310
311* Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
312- added openssl-devel build req
313
314* Mon May 21 2001 Tim Powers <timp@redhat.com>
315- built for the distro
316
317* Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
318- upgrade to curl-7.7.2.
319- enable IPv6.
320
321* Fri Mar  2 2001 Tim Powers <timp@redhat.com>
322- rebuilt against openssl-0.9.6-1
323
324* Thu Jan  4 2001 Tim Powers <timp@redhat.com>
325- fixed mising ldconfigs
326- updated to 7.5.2, bug fixes
327
328* Mon Dec 11 2000 Tim Powers <timp@redhat.com>
329- updated to 7.5.1
330
331* Mon Nov  6 2000 Tim Powers <timp@redhat.com>
332- update to 7.4.1 to fix bug #20337, problems with curl -c
333- not using patch anymore, it's included in the new source. Keeping
334  for reference
335
336* Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
337- fix bogus req in -devel package
338
339* Fri Oct 20 2000 Tim Powers <timp@redhat.com>
340- devel package needed defattr so that root owns the files
341
342* Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
343- update to 7.3
344- apply vsprintf/vsnprintf patch from Colin Phipps via Debian
345
346* Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
347- enable SSL support
348- fix packager tag
349- move buildroot to %%{_tmppath}
350
351* Tue Aug 1 2000 Tim Powers <timp@redhat.com>
352- fixed vendor tag for bug #15028
353
354* Mon Jul 24 2000 Prospector <prospector@redhat.com>
355- rebuilt
356
357* Tue Jul 11 2000 Tim Powers <timp@redhat.com>
358- workaround alpha build problems with optimizations
359
360* Mon Jul 10 2000 Tim Powers <timp@redhat.com>
361- rebuilt
362
363* Mon Jun 5 2000 Tim Powers <timp@redhat.com>
364- put man pages in correct place
365- use %%makeinstall
366
367* Mon Apr 24 2000 Tim Powers <timp@redhat.com>
368- updated to 6.5.2
369
370* Wed Nov 3 1999 Tim Powers <timp@redhat.com>
371- updated sources to 6.2
372- gzip man page
373
374* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
375- changed group
376
377* Thu Aug 26 1999 Tim Powers <timp@redhat.com>
378- changelog started
379- general cleanups, changed prefix to /usr, added manpage to files section
380- including in Powertools
Note: See TracBrowser for help on using the repository browser.