source: projects/specs/trunk/c/curl/curl-vl.spec @ 7833

Revision 7833, 11.2 KB checked in by daisuke, 11 years ago (diff)

use ca-certificates

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
4Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
5Name: curl
6Version: 7.32.0
7Release: 1%{?_dist_release}
8
9License: MIT
10Group: Applications/Internet
11URL: http://curl.haxx.se/
12
13Source: http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
14
15# make sure that NSS is initialized prior to calling PK11_GenerateRandom()
16Patch1: 0001-curl-7.32.0-204126a5.patch
17
18# avoid delay if FTP is aborted in CURLOPT_HEADERFUNCTION callback (#1005686)
19Patch2: 0002-curl-7.32.0-c639d725.patch
20
21# patch making libcurl multilib ready
22Patch101: 0101-curl-7.32.0-multilib.patch
23
24# prevent configure script from discarding -g in CFLAGS (#496778)
25Patch102: 0102-curl-7.32.0-debug.patch
26
27# make the curl tool link SSL libraries also used by src/tool_metalink.c
28Patch103: 0103-curl-7.32.0-metalink.patch
29
30# use localhost6 instead of ip6-localhost in the curl test-suite
31Patch104: 0104-curl-7.19.7-localhost6.patch
32
33# disable valgrind for certain test-cases (libssh2 problem)
34Patch106: 0106-curl-7.21.0-libssh2-valgrind.patch
35
36# work around valgrind bug (#678518)
37Patch107: 0107-curl-7.21.4-libidn-valgrind.patch
38
39# Fix character encoding of docs, which are of mixed encoding originally so
40# a simple iconv can't fix them
41Patch108: 0108-curl-7.32.0-utf8.patch
42
43
44BuildRoot: %{_tmppath}/%{name}-%{version}-root
45BuildRequires: openssl-devel libidn-devel zlib-devel
46BuildRequires: openldap-devel gnutls-devel
47BuildRequires: openssh-server
48BuildRequires: openssh-clients
49BuildRequires: pkgconfig
50%if "%{?_dist_release}" != "vl6"
51BuildRequires: libssh2-devel
52%endif
53Requires: ca-certificates
54
55Vendor: Project Vine
56Distribution: Vine Linux
57Packager: daisuke
58
59%description
60cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
61Dict servers, using any of the supported protocols. cURL is designed
62to work without user interaction or any kind of interactivity. cURL
63offers many useful capabilities, like proxy support, user
64authentication, FTP upload, HTTP post, and file transfer resume.
65
66%package devel
67Summary: Files needed for building applications with libcurl.
68Group: Development/Libraries
69Requires: %{name} = %{version}-%{release}
70Requires: openssl-devel libidn-devel zlib-devel
71
72%description devel
73cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
74Dict servers, using any of the supported protocols. The curl-devel
75package includes files needed for developing applications which can
76use cURL's capabilities internally.
77#'
78
79
80## to build compat32 for x86_64 architecture support
81%package -n compat32-%{name}
82Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
83Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
84Group: System Environment/Libraries
85
86%description -n compat32-%{name}
87cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
88Dict servers, using any of the supported protocols. cURL is designed
89to work without user interaction or any kind of interactivity. cURL
90offers many useful capabilities, like proxy support, user
91authentication, FTP upload, HTTP post, and file transfer resume.
92
93%package -n compat32-%{name}-devel
94Summary: Files needed for building applications with libcurl.
95Group: Development/Libraries
96
97%description -n compat32-%{name}-devel
98cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
99Dict servers, using any of the supported protocols. The curl-devel
100package includes files needed for developing applications which can
101use cURL's capabilities internally.
102#'
103
104%prep
105%setup -q
106
107# upstream patches
108%patch1 -p1
109%patch2 -p1
110
111# Fedora patches
112%patch101 -p1
113%patch102 -p1
114%patch103 -p1
115%patch104 -p1
116%patch106 -p1
117%patch107 -p1
118%patch108 -p1
119
120%build
121%configure \
122  --with-ssl=%{_prefix} \
123  --with-gnutls \
124  --with-libidn \
125  --enable-ipv6 \
126  --enable-threaded-resolver \
127  --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
128%if "%{?_dist_release}" != "vl6"
129  --with-libssh2 \
130%endif
131  --enable-ldaps \
132  --disable-static
133
134make %{?_smp_mflags}
135
136%install
137rm -rf $RPM_BUILD_ROOT
138make DESTDIR=$RPM_BUILD_ROOT install
139
140rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
141
142%clean
143rm -rf $RPM_BUILD_ROOT
144
145%post -p /sbin/ldconfig
146
147%postun -p /sbin/ldconfig
148
149%files
150%defattr(-,root,root)
151%doc CHANGES COPYING README
152%doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
153%doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
154%doc docs/TheArtOfHttpScripting docs/TODO
155%{_bindir}/curl
156#{_datadir}/curl/*
157%{_libdir}/*.so.*
158%{_mandir}/man1/*.1*
159
160%files devel
161%defattr(-,root,root)
162%{_bindir}/curl-config
163%{_includedir}/curl
164%{_libdir}/*.so
165%{_libdir}/pkgconfig/*.pc
166%{_mandir}/man1/curl-config.1*
167%{_mandir}/man3/*
168
169
170## to build compat32 for x86_64 architecture support
171%if %{build_compat32}
172%files -n compat32-%{name}
173%defattr(-,root,root)
174%{_libdir}/*.so.*
175
176%files -n compat32-%{name}-devel
177%defattr(-,root,root)
178%{_libdir}/*.so
179%{_libdir}/pkgconfig/*.pc
180%endif
181
182%changelog
183* Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 7.32.0-1
184- new upstream release
185- import upstream/fedora patches
186- disable libssh2 on Vine Linux 6
187
188* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.1-1
189- new upstream reelase
190
191* Sun Oct 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.0-1
192- update to 7.28.0
193- add configure options
194  - --enable-ssh2, --enable-threaded-resolver, --enable-ldaps
195- add BR: libssh2-devel, openssh-clients, openssh-server, pkgconfig
196 
197- use ca-certificates package
198  - --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt
199  - R: ca-certificates
200
201* Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 7.24.0-1
202- new upstream release
203
204* Sun Jul  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-4
205- add patch100 for fix CVE-2011-2192 (gssapi)
206- add Vendor/Distri tags
207
208* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
209- rebuild with openssl-1.0.0c
210
211* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
212- rebuilt with rpm-4.8.1 for pkg-config
213
214* Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
215- new upstream release
216
217* Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
218- new upstream release with security fix
219
220* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
221- added compat32 subpackages
222
223* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
224- new upstream release
225- use "_smp_mflags" flag
226
227* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
228- rebuild with openldap-2.4.11
229- add BR: openldap-devel
230- remove static library
231
232* Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
233- new upstream release with security fix (CVE-2009-0037)
234
235* Sun Jul  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
236- new upstream release
237
238* Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
239- new upstream release
240
241* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
242- new upstream release
243
244* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
245- new upstream release
246
247* Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
248- new upstream release
249
250* Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
251- rebuilt with openssl-0.9.8e
252
253* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
254- new upstream release
255
256* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
257- new upstream release
258
259* Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
260- new upstream release
261- add pkgconfig file to devel package
262
263* Wed Dec  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
264- new upstream release
265
266* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
267- new upstream release
268
269* Fri Sep  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
270- new upstream release
271
272* Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
273- added libidn, zlib in Requires
274- added libidn-devel, zlib-devel in BuildPrereq
275- added zlib-devel in curl-devel's Requires
276
277* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
278- added openssl-devel, libidn-devel in curl-devel's Requires
279
280* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
281- new upstream release
282
283* Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
284- new upstream release
285- rebuild with openssl-0.9.7d
286
287* Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
288- upstream release
289
290* Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
291- add %%{_datadir}/curl/* to %%files section
292
293* Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
294- source upgrade
295
296* Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
297- source upgrade
298- add PreReq: ldconfig
299- add %%{_libdir}/*.la to %%files devel section
300
301* Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
302- build for VineSeed
303- add Requires: openssl
304
305* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
306- automated rebuild
307
308* Wed Jan  9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
309- 7.9.2
310
311* Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
312- include curl-config in curl-devel
313- update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
314
315* Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
316- added openssl-devel build req
317
318* Mon May 21 2001 Tim Powers <timp@redhat.com>
319- built for the distro
320
321* Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
322- upgrade to curl-7.7.2.
323- enable IPv6.
324
325* Fri Mar  2 2001 Tim Powers <timp@redhat.com>
326- rebuilt against openssl-0.9.6-1
327
328* Thu Jan  4 2001 Tim Powers <timp@redhat.com>
329- fixed mising ldconfigs
330- updated to 7.5.2, bug fixes
331
332* Mon Dec 11 2000 Tim Powers <timp@redhat.com>
333- updated to 7.5.1
334
335* Mon Nov  6 2000 Tim Powers <timp@redhat.com>
336- update to 7.4.1 to fix bug #20337, problems with curl -c
337- not using patch anymore, it's included in the new source. Keeping
338  for reference
339
340* Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
341- fix bogus req in -devel package
342
343* Fri Oct 20 2000 Tim Powers <timp@redhat.com>
344- devel package needed defattr so that root owns the files
345
346* Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
347- update to 7.3
348- apply vsprintf/vsnprintf patch from Colin Phipps via Debian
349
350* Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
351- enable SSL support
352- fix packager tag
353- move buildroot to %%{_tmppath}
354
355* Tue Aug 1 2000 Tim Powers <timp@redhat.com>
356- fixed vendor tag for bug #15028
357
358* Mon Jul 24 2000 Prospector <prospector@redhat.com>
359- rebuilt
360
361* Tue Jul 11 2000 Tim Powers <timp@redhat.com>
362- workaround alpha build problems with optimizations
363
364* Mon Jul 10 2000 Tim Powers <timp@redhat.com>
365- rebuilt
366
367* Mon Jun 5 2000 Tim Powers <timp@redhat.com>
368- put man pages in correct place
369- use %%makeinstall
370
371* Mon Apr 24 2000 Tim Powers <timp@redhat.com>
372- updated to 6.5.2
373
374* Wed Nov 3 1999 Tim Powers <timp@redhat.com>
375- updated sources to 6.2
376- gzip man page
377
378* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
379- changed group
380
381* Thu Aug 26 1999 Tim Powers <timp@redhat.com>
382- changelog started
383- general cleanups, changed prefix to /usr, added manpage to files section
384- including in Powertools
Note: See TracBrowser for help on using the repository browser.