source: projects/specs/trunk/c/curl/curl-vl.spec @ 7175

Revision 7175, 9.8 KB checked in by daisuke, 11 years ago (diff)

curl: update to 7.28.1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
4Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
5Name: curl
6Version: 7.28.1
7Release: 1%{?_dist_release}
8License: MIT/X
9Group: Applications/Internet
10Source: http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
11URL: http://curl.haxx.se/
12
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: openssl-devel libidn-devel zlib-devel
15BuildRequires: openldap-devel gnutls-devel
16BuildRequires: libssh2-devel
17BuildRequires: openssh-clients
18BuildRequires: openssh-server
19BuildRequires: pkgconfig
20Requires: ca-certificates
21
22Vendor: Project Vine
23Distribution: Vine Linux
24Packager: daisuke
25
26%description
27cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
28Dict servers, using any of the supported protocols. cURL is designed
29to work without user interaction or any kind of interactivity. cURL
30offers many useful capabilities, like proxy support, user
31authentication, FTP upload, HTTP post, and file transfer resume.
32
33%package devel
34Summary: Files needed for building applications with libcurl.
35Group: Development/Libraries
36Requires: %{name} = %{version}-%{release}
37Requires: openssl-devel libidn-devel zlib-devel
38
39%description devel
40cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
41Dict servers, using any of the supported protocols. The curl-devel
42package includes files needed for developing applications which can
43use cURL's capabilities internally.
44#'
45
46
47## to build compat32 for x86_64 architecture support
48%package -n compat32-%{name}
49Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
50Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
51Group: System Environment/Libraries
52
53%description -n compat32-%{name}
54cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
55Dict servers, using any of the supported protocols. cURL is designed
56to work without user interaction or any kind of interactivity. cURL
57offers many useful capabilities, like proxy support, user
58authentication, FTP upload, HTTP post, and file transfer resume.
59
60%package -n compat32-%{name}-devel
61Summary: Files needed for building applications with libcurl.
62Group: Development/Libraries
63
64%description -n compat32-%{name}-devel
65cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
66Dict servers, using any of the supported protocols. The curl-devel
67package includes files needed for developing applications which can
68use cURL's capabilities internally.
69#'
70
71%prep
72%setup -q
73
74%build
75%configure \
76  --with-ssl=%{_prefix} \
77  --with-gnutls \
78  --with-libidn \
79  --enable-ipv6 \
80  --enable-threaded-resolver \
81  --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
82  --with-libssh2 \
83  --enable-ldaps \
84  --disable-static
85
86make %{?_smp_mflags}
87
88%install
89rm -rf $RPM_BUILD_ROOT
90make DESTDIR=$RPM_BUILD_ROOT install
91
92rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
93
94%clean
95rm -rf $RPM_BUILD_ROOT
96
97%post -p /sbin/ldconfig
98
99%postun -p /sbin/ldconfig
100
101%files
102%defattr(-,root,root)
103%doc CHANGES COPYING README
104%doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
105%doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
106%doc docs/TheArtOfHttpScripting docs/TODO
107%{_bindir}/curl
108#{_datadir}/curl/*
109%{_libdir}/*.so.*
110%{_mandir}/man1/*.1*
111
112%files devel
113%defattr(-,root,root)
114%{_bindir}/curl-config
115%{_includedir}/curl
116%{_libdir}/*.so
117%{_libdir}/pkgconfig/*.pc
118%{_mandir}/man1/curl-config.1*
119%{_mandir}/man3/*
120
121
122## to build compat32 for x86_64 architecture support
123%if %{build_compat32}
124%files -n compat32-%{name}
125%defattr(-,root,root)
126%{_libdir}/*.so.*
127
128%files -n compat32-%{name}-devel
129%defattr(-,root,root)
130%{_libdir}/*.so
131%{_libdir}/pkgconfig/*.pc
132%endif
133
134%changelog
135* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.1-1
136- new upstream reelase
137
138* Sun Oct 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.0-1
139- update to 7.28.0
140- add configure options
141  - --enable-ssh2, --enable-threaded-resolver, --enable-ldaps
142- add BR: libssh2-devel, openssh-clients, openssh-server, pkgconfig
143 
144- use ca-certificates package
145  - --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt
146  - R: ca-certificates
147
148* Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 7.24.0-1
149- new upstream release
150
151* Sun Jul  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-4
152- add patch100 for fix CVE-2011-2192 (gssapi)
153- add Vendor/Distri tags
154
155* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
156- rebuild with openssl-1.0.0c
157
158* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
159- rebuilt with rpm-4.8.1 for pkg-config
160
161* Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
162- new upstream release
163
164* Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
165- new upstream release with security fix
166
167* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
168- added compat32 subpackages
169
170* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
171- new upstream release
172- use "_smp_mflags" flag
173
174* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
175- rebuild with openldap-2.4.11
176- add BR: openldap-devel
177- remove static library
178
179* Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
180- new upstream release with security fix (CVE-2009-0037)
181
182* Sun Jul  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
183- new upstream release
184
185* Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
186- new upstream release
187
188* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
189- new upstream release
190
191* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
192- new upstream release
193
194* Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
195- new upstream release
196
197* Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
198- rebuilt with openssl-0.9.8e
199
200* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
201- new upstream release
202
203* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
204- new upstream release
205
206* Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
207- new upstream release
208- add pkgconfig file to devel package
209
210* Wed Dec  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
211- new upstream release
212
213* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
214- new upstream release
215
216* Fri Sep  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
217- new upstream release
218
219* Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
220- added libidn, zlib in Requires
221- added libidn-devel, zlib-devel in BuildPrereq
222- added zlib-devel in curl-devel's Requires
223
224* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
225- added openssl-devel, libidn-devel in curl-devel's Requires
226
227* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
228- new upstream release
229
230* Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
231- new upstream release
232- rebuild with openssl-0.9.7d
233
234* Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
235- upstream release
236
237* Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
238- add %%{_datadir}/curl/* to %%files section
239
240* Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
241- source upgrade
242
243* Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
244- source upgrade
245- add PreReq: ldconfig
246- add %%{_libdir}/*.la to %%files devel section
247
248* Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
249- build for VineSeed
250- add Requires: openssl
251
252* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
253- automated rebuild
254
255* Wed Jan  9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
256- 7.9.2
257
258* Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
259- include curl-config in curl-devel
260- update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
261
262* Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
263- added openssl-devel build req
264
265* Mon May 21 2001 Tim Powers <timp@redhat.com>
266- built for the distro
267
268* Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
269- upgrade to curl-7.7.2.
270- enable IPv6.
271
272* Fri Mar  2 2001 Tim Powers <timp@redhat.com>
273- rebuilt against openssl-0.9.6-1
274
275* Thu Jan  4 2001 Tim Powers <timp@redhat.com>
276- fixed mising ldconfigs
277- updated to 7.5.2, bug fixes
278
279* Mon Dec 11 2000 Tim Powers <timp@redhat.com>
280- updated to 7.5.1
281
282* Mon Nov  6 2000 Tim Powers <timp@redhat.com>
283- update to 7.4.1 to fix bug #20337, problems with curl -c
284- not using patch anymore, it's included in the new source. Keeping
285  for reference
286
287* Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
288- fix bogus req in -devel package
289
290* Fri Oct 20 2000 Tim Powers <timp@redhat.com>
291- devel package needed defattr so that root owns the files
292
293* Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
294- update to 7.3
295- apply vsprintf/vsnprintf patch from Colin Phipps via Debian
296
297* Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
298- enable SSL support
299- fix packager tag
300- move buildroot to %%{_tmppath}
301
302* Tue Aug 1 2000 Tim Powers <timp@redhat.com>
303- fixed vendor tag for bug #15028
304
305* Mon Jul 24 2000 Prospector <prospector@redhat.com>
306- rebuilt
307
308* Tue Jul 11 2000 Tim Powers <timp@redhat.com>
309- workaround alpha build problems with optimizations
310
311* Mon Jul 10 2000 Tim Powers <timp@redhat.com>
312- rebuilt
313
314* Mon Jun 5 2000 Tim Powers <timp@redhat.com>
315- put man pages in correct place
316- use %%makeinstall
317
318* Mon Apr 24 2000 Tim Powers <timp@redhat.com>
319- updated to 6.5.2
320
321* Wed Nov 3 1999 Tim Powers <timp@redhat.com>
322- updated sources to 6.2
323- gzip man page
324
325* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
326- changed group
327
328* Thu Aug 26 1999 Tim Powers <timp@redhat.com>
329- changelog started
330- general cleanups, changed prefix to /usr, added manpage to files section
331- including in Powertools
Note: See TracBrowser for help on using the repository browser.