source: projects/specs/trunk/c/curl/curl-vl.spec @ 12322

Revision 12322, 14.0 KB checked in by tomop, 4 years ago (diff)

updated 13 packages

cpio-2.13-1

curl-7.68.0-1

e2fsprogs-1.45.5-1

firefox-68.5.0-1

flex-2.6.4-1

libarchive-3.4.2-1

libogg-1.3.4-1

libssh-0.9.3-1

libtasn1-4.16.0-1

libvorbis-1.3.6-1

nghttp2-1.40.0-1

thunderbird-68.5.0-1

vorbis-tools-1.4.0-5

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%if %{?_dist_release} != "vl6"
4%global with_http2 1
5%endif
6
7Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
8Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
9Name: curl
10Version: 7.68.0
11Release: 1%{?_dist_release}
12
13License: MIT
14Group: Applications/Internet
15URL: http://curl.haxx.se/
16Source: http://curl.haxx.se/download/%{name}-%{version}.tar.xz
17
18# avoid reporting spurious error in the HTTP2 framing layer (#1690971)
19Patch2:   0002-curl-7.65.3-h2-framing-layer-error.patch
20
21# patch making libcurl multilib ready
22Patch101: 0101-curl-7.32.0-multilib.patch
23
24# prevent configure script from discarding -g in CFLAGS (#496778)
25Patch102: 0102-curl-7.36.0-debug.patch
26
27# migrate tests/http_pipe.py to Python 3
28Patch103: 0103-curl-7.59.0-python3.patch
29
30# use localhost6 instead of ip6-localhost in the curl test-suite
31Patch104: 0104-curl-7.19.7-localhost6.patch
32
33# prevent valgrind from reporting false positives on x86_64
34Patch105: 0105-curl-7.63.0-lib1560-valgrind.patch
35
36BuildRoot: %{_tmppath}/%{name}-%{version}-root
37BuildRequires: openssl-devel
38BuildRequires: gnutls-devel
39BuildRequires: libidn-devel zlib-devel
40BuildRequires: openldap-devel
41BuildRequires: openssh-server
42BuildRequires: openssh-clients
43BuildRequires: pkgconfig
44%if "%{?_dist_release}" != "vl6"
45BuildRequires: libssh2-devel
46%endif
47%if 0%{?with_http2}
48BuildRequires: libnghttp2-devel
49%endif
50
51Requires: ca-certificates
52
53Vendor: Project Vine
54Distribution: Vine Linux
55Packager: daisuke
56
57%description
58cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
59Dict servers, using any of the supported protocols. cURL is designed
60to work without user interaction or any kind of interactivity. cURL
61offers many useful capabilities, like proxy support, user
62authentication, FTP upload, HTTP post, and file transfer resume.
63
64%package devel
65Summary: Files needed for building applications with libcurl.
66Group: Development/Libraries
67Requires: %{name} = %{version}-%{release}
68Requires: openssl-devel libidn-devel zlib-devel
69
70%description devel
71cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
72Dict servers, using any of the supported protocols. The curl-devel
73package includes files needed for developing applications which can
74use cURL's capabilities internally.
75#'
76
77
78## to build compat32 for x86_64 architecture support
79%package -n compat32-%{name}
80Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
81Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
82Group: System Environment/Libraries
83
84%description -n compat32-%{name}
85cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
86Dict servers, using any of the supported protocols. cURL is designed
87to work without user interaction or any kind of interactivity. cURL
88offers many useful capabilities, like proxy support, user
89authentication, FTP upload, HTTP post, and file transfer resume.
90
91%package -n compat32-%{name}-devel
92Summary: Files needed for building applications with libcurl.
93Group: Development/Libraries
94
95%description -n compat32-%{name}-devel
96cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
97Dict servers, using any of the supported protocols. The curl-devel
98package includes files needed for developing applications which can
99use cURL's capabilities internally.
100#'
101
102%prep
103%setup -q
104
105# upstream patches
106
107# Fedora patches
108%patch101 -p1
109%patch102 -p1
110#patch103 -p1
111%patch104 -p1
112%patch105 -p1
113
114# make tests/*.py use Python 3
115sed -e '1 s|^#!/.*python|&3|' -i tests/*.py
116
117# regenerate Makefile.in files
118aclocal -I m4
119automake
120
121# disable test 1112 (#565305), test 1455 (occasionally fails with 'bind failed
122# with errno 98: Address already in use' in Koji environment), and test 1801
123# <https://github.com/bagder/curl/commit/21e82bd6#commitcomment-12226582>
124# and test 1900, which is flaky and covers a deprecated feature of libcurl
125# <https://github.com/curl/curl/pull/2705>
126printf "1112\n1455\n1801\n1900\n" >> tests/data/DISABLED
127
128# disable test 1319 on ppc64 (server times out)
129%ifarch ppc64
130echo "1319" >> tests/data/DISABLED
131%endif
132
133# temporarily disable test 582 on s390x (client times out)
134%ifarch s390x
135echo "582" >> tests/data/DISABLED
136%endif
137
138# adapt test 323 for updated OpenSSL
139sed -e 's/^35$/35,52/' -i tests/data/test323
140
141%build
142%configure \
143  --with-ssl=%{_prefix} \
144  --with-libidn \
145  --enable-ipv6 \
146  --enable-threaded-resolver \
147  --with-ssl --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
148%if "%{?_dist_release}" != "vl6"
149  --with-libssh2 \
150%endif
151%if 0%{?with_http2}
152  --with-nghttp2 \
153%endif
154  --enable-ldaps \
155  --disable-static \
156  --enable-hidden-symbols
157
158make %{?_smp_mflags}
159
160%install
161rm -rf $RPM_BUILD_ROOT
162make DESTDIR=$RPM_BUILD_ROOT install
163
164rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
165
166%clean
167rm -rf $RPM_BUILD_ROOT
168
169%post -p /sbin/ldconfig
170
171%postun -p /sbin/ldconfig
172
173%files
174%defattr(-,root,root)
175%{!?_licensedir:%global license %%doc}
176%license COPYING
177%doc CHANGES README
178%doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
179%doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
180%doc docs/TheArtOfHttpScripting docs/TODO
181%{_bindir}/curl
182#{_datadir}/curl/*
183%{_libdir}/*.so.*
184%{_mandir}/man1/*.1*
185
186%files devel
187%defattr(-,root,root)
188%{_bindir}/curl-config
189%{_includedir}/curl
190%{_libdir}/*.so
191%{_libdir}/pkgconfig/*.pc
192%{_mandir}/man1/curl-config.1*
193%{_mandir}/man3/*
194%{_datadir}/aclocal/libcurl.m4
195
196
197## to build compat32 for x86_64 architecture support
198%if %{build_compat32}
199%files -n compat32-%{name}
200%defattr(-,root,root)
201%{_libdir}/*.so.*
202
203%files -n compat32-%{name}-devel
204%defattr(-,root,root)
205%{_libdir}/*.so
206%{_libdir}/pkgconfig/*.pc
207%endif
208
209%changelog
210* Sun Feb 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.68.0-1
211- new upstream release.
212
213* Sat Sep 21 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.66.0-1
214- new upstream release.
215- dropped Patch1 and 2: fixed in upstream.
216
217* Thu Aug 29 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.65.3-1
218- new upstream release.
219- updated patches.
220- imported Patch1, 2 and 105 from rawhide.
221
222* Sat Nov 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.62.0-1
223- new upstream release.
224- imported patches from rawhide.
225
226* Fri Apr 13 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.59.0-1
227- new upstream release.
228- imported Patch1 and 103 from rawhide.
229
230* Wed Feb  7 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.58.0-1
231- new upstream release with security fix
232- update patch101
233
234* Thu Jan 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.57.0-1
235- new upstream release.
236- updated Patch101-104.
237- dropped Patch107.
238
239* Mon May  1 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.54.0-1
240- new upstream release.
241
242* Thu Mar 16 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.53.1-1
243- new upstream release.
244
245* Wed Dec 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.51.0-1
246- new upstream release.
247
248* Fri Jul 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.50.0-1
249- new upstream release.
250- disabled HTTP/2 on Vine6.
251
252* Sat Jul 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-2
253- added HTTP/2 support.
254
255* Tue Jun 28 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-1
256- new upstream release with security fix.
257
258* Sat May 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.0-1
259- new upstream release.
260
261* Sat Mar 12 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.47.1-1
262- new upstream release
263- built with openssl 1.0.2g
264
265* Fri Jun 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.43.0-1
266- new upstream release with security fix .
267- removed Patch108 (fixed in upstream).
268
269* Sun Nov  9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.39.0-1
270- new upstream release with security fix
271
272* Sun Jan 19 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 7.34.0-1
273- new upstream release
274- add libcurl.m4 to -devel package
275
276* Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 7.32.0-1
277- new upstream release
278- import upstream/fedora patches
279- disable libssh2 on Vine Linux 6
280
281* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.1-1
282- new upstream reelase
283
284* Sun Oct 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.0-1
285- update to 7.28.0
286- add configure options
287  - --enable-ssh2, --enable-threaded-resolver, --enable-ldaps
288- add BR: libssh2-devel, openssh-clients, openssh-server, pkgconfig
289 
290- use ca-certificates package
291  - --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt
292  - R: ca-certificates
293
294* Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 7.24.0-1
295- new upstream release
296
297* Sun Jul  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-4
298- add patch100 for fix CVE-2011-2192 (gssapi)
299- add Vendor/Distri tags
300
301* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
302- rebuild with openssl-1.0.0c
303
304* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
305- rebuilt with rpm-4.8.1 for pkg-config
306
307* Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
308- new upstream release
309
310* Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
311- new upstream release with security fix
312
313* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
314- added compat32 subpackages
315
316* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
317- new upstream release
318- use "_smp_mflags" flag
319
320* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
321- rebuild with openldap-2.4.11
322- add BR: openldap-devel
323- remove static library
324
325* Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
326- new upstream release with security fix (CVE-2009-0037)
327
328* Sun Jul  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
329- new upstream release
330
331* Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
332- new upstream release
333
334* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
335- new upstream release
336
337* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
338- new upstream release
339
340* Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
341- new upstream release
342
343* Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
344- rebuilt with openssl-0.9.8e
345
346* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
347- new upstream release
348
349* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
350- new upstream release
351
352* Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
353- new upstream release
354- add pkgconfig file to devel package
355
356* Wed Dec  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
357- new upstream release
358
359* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
360- new upstream release
361
362* Fri Sep  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
363- new upstream release
364
365* Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
366- added libidn, zlib in Requires
367- added libidn-devel, zlib-devel in BuildPrereq
368- added zlib-devel in curl-devel's Requires
369
370* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
371- added openssl-devel, libidn-devel in curl-devel's Requires
372
373* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
374- new upstream release
375
376* Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
377- new upstream release
378- rebuild with openssl-0.9.7d
379
380* Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
381- upstream release
382
383* Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
384- add %%{_datadir}/curl/* to %%files section
385
386* Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
387- source upgrade
388
389* Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
390- source upgrade
391- add PreReq: ldconfig
392- add %%{_libdir}/*.la to %%files devel section
393
394* Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
395- build for VineSeed
396- add Requires: openssl
397
398* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
399- automated rebuild
400
401* Wed Jan  9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
402- 7.9.2
403
404* Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
405- include curl-config in curl-devel
406- update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
407
408* Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
409- added openssl-devel build req
410
411* Mon May 21 2001 Tim Powers <timp@redhat.com>
412- built for the distro
413
414* Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
415- upgrade to curl-7.7.2.
416- enable IPv6.
417
418* Fri Mar  2 2001 Tim Powers <timp@redhat.com>
419- rebuilt against openssl-0.9.6-1
420
421* Thu Jan  4 2001 Tim Powers <timp@redhat.com>
422- fixed mising ldconfigs
423- updated to 7.5.2, bug fixes
424
425* Mon Dec 11 2000 Tim Powers <timp@redhat.com>
426- updated to 7.5.1
427
428* Mon Nov  6 2000 Tim Powers <timp@redhat.com>
429- update to 7.4.1 to fix bug #20337, problems with curl -c
430- not using patch anymore, it's included in the new source. Keeping
431  for reference
432
433* Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
434- fix bogus req in -devel package
435
436* Fri Oct 20 2000 Tim Powers <timp@redhat.com>
437- devel package needed defattr so that root owns the files
438
439* Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
440- update to 7.3
441- apply vsprintf/vsnprintf patch from Colin Phipps via Debian
442
443* Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
444- enable SSL support
445- fix packager tag
446- move buildroot to %%{_tmppath}
447
448* Tue Aug 1 2000 Tim Powers <timp@redhat.com>
449- fixed vendor tag for bug #15028
450
451* Mon Jul 24 2000 Prospector <prospector@redhat.com>
452- rebuilt
453
454* Tue Jul 11 2000 Tim Powers <timp@redhat.com>
455- workaround alpha build problems with optimizations
456
457* Mon Jul 10 2000 Tim Powers <timp@redhat.com>
458- rebuilt
459
460* Mon Jun 5 2000 Tim Powers <timp@redhat.com>
461- put man pages in correct place
462- use %%makeinstall
463
464* Mon Apr 24 2000 Tim Powers <timp@redhat.com>
465- updated to 6.5.2
466
467* Wed Nov 3 1999 Tim Powers <timp@redhat.com>
468- updated sources to 6.2
469- gzip man page
470
471* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
472- changed group
473
474* Thu Aug 26 1999 Tim Powers <timp@redhat.com>
475- changelog started
476- general cleanups, changed prefix to /usr, added manpage to files section
477- including in Powertools
Note: See TracBrowser for help on using the repository browser.