source: projects/specs/trunk/c/curl/curl-vl.spec @ 11470

Revision 11470, 12.2 KB checked in by iwamoto, 6 years ago (diff)

curl: update to 7.58.0 with security fix

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%if %{?_dist_release} != "vl6"
4%global with_http2 1
5%endif
6
7Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
8Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
9Name: curl
10Version: 7.58.0
11Release: 1%{?_dist_release}
12
13License: MIT
14Group: Applications/Internet
15URL: http://curl.haxx.se/
16Source: http://curl.haxx.se/download/%{name}-%{version}.tar.xz
17
18# patch making libcurl multilib ready
19Patch101: 0101-curl-7.58.0-multilib.patch
20# prevent configure script from discarding -g in CFLAGS (#496778)
21Patch102: 0102-curl-7.36.0-debug.patch
22# use localhost6 instead of ip6-localhost in the curl test-suite
23Patch104: 0104-curl-7.19.7-localhost6.patch
24
25BuildRoot: %{_tmppath}/%{name}-%{version}-root
26BuildRequires: openssl-devel
27BuildRequires: gnutls-devel
28BuildRequires: libidn-devel zlib-devel
29BuildRequires: openldap-devel
30BuildRequires: openssh-server
31BuildRequires: openssh-clients
32BuildRequires: pkgconfig
33%if "%{?_dist_release}" != "vl6"
34BuildRequires: libssh2-devel
35%endif
36%if 0%{?with_http2}
37BuildRequires: libnghttp2-devel
38%endif
39
40Requires: ca-certificates
41
42Vendor: Project Vine
43Distribution: Vine Linux
44Packager: daisuke
45
46%description
47cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
48Dict servers, using any of the supported protocols. cURL is designed
49to work without user interaction or any kind of interactivity. cURL
50offers many useful capabilities, like proxy support, user
51authentication, FTP upload, HTTP post, and file transfer resume.
52
53%package devel
54Summary: Files needed for building applications with libcurl.
55Group: Development/Libraries
56Requires: %{name} = %{version}-%{release}
57Requires: openssl-devel libidn-devel zlib-devel
58
59%description devel
60cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
61Dict servers, using any of the supported protocols. The curl-devel
62package includes files needed for developing applications which can
63use cURL's capabilities internally.
64#'
65
66
67## to build compat32 for x86_64 architecture support
68%package -n compat32-%{name}
69Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
70Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
71Group: System Environment/Libraries
72
73%description -n compat32-%{name}
74cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
75Dict servers, using any of the supported protocols. cURL is designed
76to work without user interaction or any kind of interactivity. cURL
77offers many useful capabilities, like proxy support, user
78authentication, FTP upload, HTTP post, and file transfer resume.
79
80%package -n compat32-%{name}-devel
81Summary: Files needed for building applications with libcurl.
82Group: Development/Libraries
83
84%description -n compat32-%{name}-devel
85cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
86Dict servers, using any of the supported protocols. The curl-devel
87package includes files needed for developing applications which can
88use cURL's capabilities internally.
89#'
90
91%prep
92%setup -q
93
94# Fedora patches
95%patch101 -p1
96%patch102 -p1
97%patch104 -p1
98
99%build
100%configure \
101  --with-ssl=%{_prefix} \
102  --with-libidn \
103  --enable-ipv6 \
104  --enable-threaded-resolver \
105  --with-ssl --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
106%if "%{?_dist_release}" != "vl6"
107  --with-libssh2 \
108%endif
109%if 0%{?with_http2}
110  --with-nghttp2 \
111%endif
112  --enable-ldaps \
113  --disable-static \
114  --enable-hidden-symbols
115
116make %{?_smp_mflags}
117
118%install
119rm -rf $RPM_BUILD_ROOT
120make DESTDIR=$RPM_BUILD_ROOT install
121
122rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
123
124%clean
125rm -rf $RPM_BUILD_ROOT
126
127%post -p /sbin/ldconfig
128
129%postun -p /sbin/ldconfig
130
131%files
132%defattr(-,root,root)
133%{!?_licensedir:%global license %%doc}
134%license COPYING
135%doc CHANGES README
136%doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
137%doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
138%doc docs/TheArtOfHttpScripting docs/TODO
139%{_bindir}/curl
140#{_datadir}/curl/*
141%{_libdir}/*.so.*
142%{_mandir}/man1/*.1*
143
144%files devel
145%defattr(-,root,root)
146%{_bindir}/curl-config
147%{_includedir}/curl
148%{_libdir}/*.so
149%{_libdir}/pkgconfig/*.pc
150%{_mandir}/man1/curl-config.1*
151%{_mandir}/man3/*
152%{_datadir}/aclocal/libcurl.m4
153
154
155## to build compat32 for x86_64 architecture support
156%if %{build_compat32}
157%files -n compat32-%{name}
158%defattr(-,root,root)
159%{_libdir}/*.so.*
160
161%files -n compat32-%{name}-devel
162%defattr(-,root,root)
163%{_libdir}/*.so
164%{_libdir}/pkgconfig/*.pc
165%endif
166
167%changelog
168* Wed Feb  7 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.58.0-1
169- new upstream release with security fix
170- update patch101
171
172* Thu Jan 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.57.0-1
173- new upstream release.
174- updated Patch101-104.
175- dropped Patch107.
176
177* Mon May  1 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.54.0-1
178- new upstream release.
179
180* Thu Mar 16 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.53.1-1
181- new upstream release.
182
183* Wed Dec 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.51.0-1
184- new upstream release.
185
186* Fri Jul 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.50.0-1
187- new upstream release.
188- disabled HTTP/2 on Vine6.
189
190* Sat Jul 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-2
191- added HTTP/2 support.
192
193* Tue Jun 28 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-1
194- new upstream release with security fix.
195
196* Sat May 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.0-1
197- new upstream release.
198
199* Sat Mar 12 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.47.1-1
200- new upstream release
201- built with openssl 1.0.2g
202
203* Fri Jun 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.43.0-1
204- new upstream release with security fix .
205- removed Patch108 (fixed in upstream).
206
207* Sun Nov  9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.39.0-1
208- new upstream release with security fix
209
210* Sun Jan 19 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 7.34.0-1
211- new upstream release
212- add libcurl.m4 to -devel package
213
214* Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 7.32.0-1
215- new upstream release
216- import upstream/fedora patches
217- disable libssh2 on Vine Linux 6
218
219* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.1-1
220- new upstream reelase
221
222* Sun Oct 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.0-1
223- update to 7.28.0
224- add configure options
225  - --enable-ssh2, --enable-threaded-resolver, --enable-ldaps
226- add BR: libssh2-devel, openssh-clients, openssh-server, pkgconfig
227 
228- use ca-certificates package
229  - --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt
230  - R: ca-certificates
231
232* Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 7.24.0-1
233- new upstream release
234
235* Sun Jul  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-4
236- add patch100 for fix CVE-2011-2192 (gssapi)
237- add Vendor/Distri tags
238
239* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
240- rebuild with openssl-1.0.0c
241
242* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
243- rebuilt with rpm-4.8.1 for pkg-config
244
245* Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
246- new upstream release
247
248* Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
249- new upstream release with security fix
250
251* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
252- added compat32 subpackages
253
254* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
255- new upstream release
256- use "_smp_mflags" flag
257
258* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
259- rebuild with openldap-2.4.11
260- add BR: openldap-devel
261- remove static library
262
263* Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
264- new upstream release with security fix (CVE-2009-0037)
265
266* Sun Jul  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
267- new upstream release
268
269* Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
270- new upstream release
271
272* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
273- new upstream release
274
275* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
276- new upstream release
277
278* Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
279- new upstream release
280
281* Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
282- rebuilt with openssl-0.9.8e
283
284* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
285- new upstream release
286
287* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
288- new upstream release
289
290* Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
291- new upstream release
292- add pkgconfig file to devel package
293
294* Wed Dec  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
295- new upstream release
296
297* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
298- new upstream release
299
300* Fri Sep  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
301- new upstream release
302
303* Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
304- added libidn, zlib in Requires
305- added libidn-devel, zlib-devel in BuildPrereq
306- added zlib-devel in curl-devel's Requires
307
308* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
309- added openssl-devel, libidn-devel in curl-devel's Requires
310
311* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
312- new upstream release
313
314* Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
315- new upstream release
316- rebuild with openssl-0.9.7d
317
318* Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
319- upstream release
320
321* Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
322- add %%{_datadir}/curl/* to %%files section
323
324* Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
325- source upgrade
326
327* Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
328- source upgrade
329- add PreReq: ldconfig
330- add %%{_libdir}/*.la to %%files devel section
331
332* Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
333- build for VineSeed
334- add Requires: openssl
335
336* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
337- automated rebuild
338
339* Wed Jan  9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
340- 7.9.2
341
342* Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
343- include curl-config in curl-devel
344- update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
345
346* Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
347- added openssl-devel build req
348
349* Mon May 21 2001 Tim Powers <timp@redhat.com>
350- built for the distro
351
352* Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
353- upgrade to curl-7.7.2.
354- enable IPv6.
355
356* Fri Mar  2 2001 Tim Powers <timp@redhat.com>
357- rebuilt against openssl-0.9.6-1
358
359* Thu Jan  4 2001 Tim Powers <timp@redhat.com>
360- fixed mising ldconfigs
361- updated to 7.5.2, bug fixes
362
363* Mon Dec 11 2000 Tim Powers <timp@redhat.com>
364- updated to 7.5.1
365
366* Mon Nov  6 2000 Tim Powers <timp@redhat.com>
367- update to 7.4.1 to fix bug #20337, problems with curl -c
368- not using patch anymore, it's included in the new source. Keeping
369  for reference
370
371* Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
372- fix bogus req in -devel package
373
374* Fri Oct 20 2000 Tim Powers <timp@redhat.com>
375- devel package needed defattr so that root owns the files
376
377* Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
378- update to 7.3
379- apply vsprintf/vsnprintf patch from Colin Phipps via Debian
380
381* Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
382- enable SSL support
383- fix packager tag
384- move buildroot to %%{_tmppath}
385
386* Tue Aug 1 2000 Tim Powers <timp@redhat.com>
387- fixed vendor tag for bug #15028
388
389* Mon Jul 24 2000 Prospector <prospector@redhat.com>
390- rebuilt
391
392* Tue Jul 11 2000 Tim Powers <timp@redhat.com>
393- workaround alpha build problems with optimizations
394
395* Mon Jul 10 2000 Tim Powers <timp@redhat.com>
396- rebuilt
397
398* Mon Jun 5 2000 Tim Powers <timp@redhat.com>
399- put man pages in correct place
400- use %%makeinstall
401
402* Mon Apr 24 2000 Tim Powers <timp@redhat.com>
403- updated to 6.5.2
404
405* Wed Nov 3 1999 Tim Powers <timp@redhat.com>
406- updated sources to 6.2
407- gzip man page
408
409* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
410- changed group
411
412* Thu Aug 26 1999 Tim Powers <timp@redhat.com>
413- changelog started
414- general cleanups, changed prefix to /usr, added manpage to files section
415- including in Powertools
Note: See TracBrowser for help on using the repository browser.