source: projects/specs/trunk/c/curl/curl-vl.spec @ 11316

Revision 11316, 12.0 KB checked in by tomop, 6 years ago (diff)

curl-7.57.0-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%if %{?_dist_release} != "vl6"
4%global with_http2 1
5%endif
6
7Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
8Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
9Name: curl
10Version: 7.57.0
11Release: 1%{?_dist_release}
12
13License: MIT
14Group: Applications/Internet
15URL: http://curl.haxx.se/
16Source: http://curl.haxx.se/download/%{name}-%{version}.tar.xz
17
18# patch making libcurl multilib ready
19Patch101: 0101-curl-7.32.0-multilib.patch
20# prevent configure script from discarding -g in CFLAGS (#496778)
21Patch102: 0102-curl-7.36.0-debug.patch
22# use localhost6 instead of ip6-localhost in the curl test-suite
23Patch104: 0104-curl-7.19.7-localhost6.patch
24
25BuildRoot: %{_tmppath}/%{name}-%{version}-root
26BuildRequires: openssl-devel
27BuildRequires: gnutls-devel
28BuildRequires: libidn-devel zlib-devel
29BuildRequires: openldap-devel
30BuildRequires: openssh-server
31BuildRequires: openssh-clients
32BuildRequires: pkgconfig
33%if "%{?_dist_release}" != "vl6"
34BuildRequires: libssh2-devel
35%endif
36%if 0%{?with_http2}
37BuildRequires: libnghttp2-devel
38%endif
39
40Requires: ca-certificates
41
42Vendor: Project Vine
43Distribution: Vine Linux
44Packager: daisuke
45
46%description
47cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
48Dict servers, using any of the supported protocols. cURL is designed
49to work without user interaction or any kind of interactivity. cURL
50offers many useful capabilities, like proxy support, user
51authentication, FTP upload, HTTP post, and file transfer resume.
52
53%package devel
54Summary: Files needed for building applications with libcurl.
55Group: Development/Libraries
56Requires: %{name} = %{version}-%{release}
57Requires: openssl-devel libidn-devel zlib-devel
58
59%description devel
60cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
61Dict servers, using any of the supported protocols. The curl-devel
62package includes files needed for developing applications which can
63use cURL's capabilities internally.
64#'
65
66
67## to build compat32 for x86_64 architecture support
68%package -n compat32-%{name}
69Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
70Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
71Group: System Environment/Libraries
72
73%description -n compat32-%{name}
74cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
75Dict servers, using any of the supported protocols. cURL is designed
76to work without user interaction or any kind of interactivity. cURL
77offers many useful capabilities, like proxy support, user
78authentication, FTP upload, HTTP post, and file transfer resume.
79
80%package -n compat32-%{name}-devel
81Summary: Files needed for building applications with libcurl.
82Group: Development/Libraries
83
84%description -n compat32-%{name}-devel
85cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
86Dict servers, using any of the supported protocols. The curl-devel
87package includes files needed for developing applications which can
88use cURL's capabilities internally.
89#'
90
91%prep
92%setup -q
93
94# Fedora patches
95%patch101 -p1
96%patch102 -p1
97%patch104 -p1
98
99%build
100%configure \
101  --with-ssl=%{_prefix} \
102  --with-libidn \
103  --enable-ipv6 \
104  --enable-threaded-resolver \
105  --with-ssl --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
106%if "%{?_dist_release}" != "vl6"
107  --with-libssh2 \
108%endif
109%if 0%{?with_http2}
110  --with-nghttp2 \
111%endif
112  --enable-ldaps \
113  --disable-static \
114  --enable-hidden-symbols
115
116make %{?_smp_mflags}
117
118%install
119rm -rf $RPM_BUILD_ROOT
120make DESTDIR=$RPM_BUILD_ROOT install
121
122rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
123
124%clean
125rm -rf $RPM_BUILD_ROOT
126
127%post -p /sbin/ldconfig
128
129%postun -p /sbin/ldconfig
130
131%files
132%defattr(-,root,root)
133%{!?_licensedir:%global license %%doc}
134%license COPYING
135%doc CHANGES README
136%doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
137%doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
138%doc docs/TheArtOfHttpScripting docs/TODO
139%{_bindir}/curl
140#{_datadir}/curl/*
141%{_libdir}/*.so.*
142%{_mandir}/man1/*.1*
143
144%files devel
145%defattr(-,root,root)
146%{_bindir}/curl-config
147%{_includedir}/curl
148%{_libdir}/*.so
149%{_libdir}/pkgconfig/*.pc
150%{_mandir}/man1/curl-config.1*
151%{_mandir}/man3/*
152%{_datadir}/aclocal/libcurl.m4
153
154
155## to build compat32 for x86_64 architecture support
156%if %{build_compat32}
157%files -n compat32-%{name}
158%defattr(-,root,root)
159%{_libdir}/*.so.*
160
161%files -n compat32-%{name}-devel
162%defattr(-,root,root)
163%{_libdir}/*.so
164%{_libdir}/pkgconfig/*.pc
165%endif
166
167%changelog
168* Thu Jan 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.57.0-1
169- new upstream release.
170- updated Patch101-104.
171- dropped Patch107.
172
173* Mon May  1 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.54.0-1
174- new upstream release.
175
176* Thu Mar 16 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.53.1-1
177- new upstream release.
178
179* Wed Dec 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.51.0-1
180- new upstream release.
181
182* Fri Jul 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.50.0-1
183- new upstream release.
184- disabled HTTP/2 on Vine6.
185
186* Sat Jul 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-2
187- added HTTP/2 support.
188
189* Tue Jun 28 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-1
190- new upstream release with security fix.
191
192* Sat May 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.0-1
193- new upstream release.
194
195* Sat Mar 12 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.47.1-1
196- new upstream release
197- built with openssl 1.0.2g
198
199* Fri Jun 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.43.0-1
200- new upstream release with security fix .
201- removed Patch108 (fixed in upstream).
202
203* Sun Nov  9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.39.0-1
204- new upstream release with security fix
205
206* Sun Jan 19 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 7.34.0-1
207- new upstream release
208- add libcurl.m4 to -devel package
209
210* Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 7.32.0-1
211- new upstream release
212- import upstream/fedora patches
213- disable libssh2 on Vine Linux 6
214
215* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.1-1
216- new upstream reelase
217
218* Sun Oct 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.0-1
219- update to 7.28.0
220- add configure options
221  - --enable-ssh2, --enable-threaded-resolver, --enable-ldaps
222- add BR: libssh2-devel, openssh-clients, openssh-server, pkgconfig
223 
224- use ca-certificates package
225  - --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt
226  - R: ca-certificates
227
228* Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 7.24.0-1
229- new upstream release
230
231* Sun Jul  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-4
232- add patch100 for fix CVE-2011-2192 (gssapi)
233- add Vendor/Distri tags
234
235* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
236- rebuild with openssl-1.0.0c
237
238* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
239- rebuilt with rpm-4.8.1 for pkg-config
240
241* Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
242- new upstream release
243
244* Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
245- new upstream release with security fix
246
247* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
248- added compat32 subpackages
249
250* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
251- new upstream release
252- use "_smp_mflags" flag
253
254* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
255- rebuild with openldap-2.4.11
256- add BR: openldap-devel
257- remove static library
258
259* Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
260- new upstream release with security fix (CVE-2009-0037)
261
262* Sun Jul  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
263- new upstream release
264
265* Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
266- new upstream release
267
268* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
269- new upstream release
270
271* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
272- new upstream release
273
274* Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
275- new upstream release
276
277* Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
278- rebuilt with openssl-0.9.8e
279
280* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
281- new upstream release
282
283* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
284- new upstream release
285
286* Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
287- new upstream release
288- add pkgconfig file to devel package
289
290* Wed Dec  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
291- new upstream release
292
293* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
294- new upstream release
295
296* Fri Sep  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
297- new upstream release
298
299* Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
300- added libidn, zlib in Requires
301- added libidn-devel, zlib-devel in BuildPrereq
302- added zlib-devel in curl-devel's Requires
303
304* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
305- added openssl-devel, libidn-devel in curl-devel's Requires
306
307* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
308- new upstream release
309
310* Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
311- new upstream release
312- rebuild with openssl-0.9.7d
313
314* Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
315- upstream release
316
317* Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
318- add %%{_datadir}/curl/* to %%files section
319
320* Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
321- source upgrade
322
323* Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
324- source upgrade
325- add PreReq: ldconfig
326- add %%{_libdir}/*.la to %%files devel section
327
328* Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
329- build for VineSeed
330- add Requires: openssl
331
332* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
333- automated rebuild
334
335* Wed Jan  9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
336- 7.9.2
337
338* Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
339- include curl-config in curl-devel
340- update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
341
342* Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
343- added openssl-devel build req
344
345* Mon May 21 2001 Tim Powers <timp@redhat.com>
346- built for the distro
347
348* Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
349- upgrade to curl-7.7.2.
350- enable IPv6.
351
352* Fri Mar  2 2001 Tim Powers <timp@redhat.com>
353- rebuilt against openssl-0.9.6-1
354
355* Thu Jan  4 2001 Tim Powers <timp@redhat.com>
356- fixed mising ldconfigs
357- updated to 7.5.2, bug fixes
358
359* Mon Dec 11 2000 Tim Powers <timp@redhat.com>
360- updated to 7.5.1
361
362* Mon Nov  6 2000 Tim Powers <timp@redhat.com>
363- update to 7.4.1 to fix bug #20337, problems with curl -c
364- not using patch anymore, it's included in the new source. Keeping
365  for reference
366
367* Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
368- fix bogus req in -devel package
369
370* Fri Oct 20 2000 Tim Powers <timp@redhat.com>
371- devel package needed defattr so that root owns the files
372
373* Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
374- update to 7.3
375- apply vsprintf/vsnprintf patch from Colin Phipps via Debian
376
377* Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
378- enable SSL support
379- fix packager tag
380- move buildroot to %%{_tmppath}
381
382* Tue Aug 1 2000 Tim Powers <timp@redhat.com>
383- fixed vendor tag for bug #15028
384
385* Mon Jul 24 2000 Prospector <prospector@redhat.com>
386- rebuilt
387
388* Tue Jul 11 2000 Tim Powers <timp@redhat.com>
389- workaround alpha build problems with optimizations
390
391* Mon Jul 10 2000 Tim Powers <timp@redhat.com>
392- rebuilt
393
394* Mon Jun 5 2000 Tim Powers <timp@redhat.com>
395- put man pages in correct place
396- use %%makeinstall
397
398* Mon Apr 24 2000 Tim Powers <timp@redhat.com>
399- updated to 6.5.2
400
401* Wed Nov 3 1999 Tim Powers <timp@redhat.com>
402- updated sources to 6.2
403- gzip man page
404
405* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
406- changed group
407
408* Thu Aug 26 1999 Tim Powers <timp@redhat.com>
409- changelog started
410- general cleanups, changed prefix to /usr, added manpage to files section
411- including in Powertools
Note: See TracBrowser for help on using the repository browser.