source: projects/specs/trunk/c/curl/curl-vl.spec @ 11062

Revision 11062, 12.0 KB checked in by tomop, 7 years ago (diff)

curl-7.54.0-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%if %{?_dist_release} != "vl6"
4%global with_http2 1
5%endif
6
7Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
8Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
9Name: curl
10Version: 7.54.0
11Release: 1%{?_dist_release}
12
13License: MIT
14Group: Applications/Internet
15URL: http://curl.haxx.se/
16Source: http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
17
18# patch making libcurl multilib ready
19Patch101: 0101-curl-7.32.0-multilib.patch
20# prevent configure script from discarding -g in CFLAGS (#496778)
21Patch102: 0102-curl-7.36.0-debug.patch
22# use localhost6 instead of ip6-localhost in the curl test-suite
23Patch104: 0104-curl-7.19.7-localhost6.patch
24# work around valgrind bug (#678518)
25Patch107: 0107-curl-7.21.4-libidn-valgrind.patch
26
27BuildRoot: %{_tmppath}/%{name}-%{version}-root
28BuildRequires: openssl-devel libidn-devel zlib-devel
29BuildRequires: openldap-devel gnutls-devel
30BuildRequires: openssh-server
31BuildRequires: openssh-clients
32BuildRequires: pkgconfig
33%if "%{?_dist_release}" != "vl6"
34BuildRequires: libssh2-devel
35%endif
36%if 0%{?with_http2}
37BuildRequires: libnghttp2-devel
38%endif
39
40Requires: ca-certificates
41
42Vendor: Project Vine
43Distribution: Vine Linux
44Packager: daisuke
45
46%description
47cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
48Dict servers, using any of the supported protocols. cURL is designed
49to work without user interaction or any kind of interactivity. cURL
50offers many useful capabilities, like proxy support, user
51authentication, FTP upload, HTTP post, and file transfer resume.
52
53%package devel
54Summary: Files needed for building applications with libcurl.
55Group: Development/Libraries
56Requires: %{name} = %{version}-%{release}
57Requires: openssl-devel libidn-devel zlib-devel
58
59%description devel
60cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
61Dict servers, using any of the supported protocols. The curl-devel
62package includes files needed for developing applications which can
63use cURL's capabilities internally.
64#'
65
66
67## to build compat32 for x86_64 architecture support
68%package -n compat32-%{name}
69Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
70Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
71Group: System Environment/Libraries
72
73%description -n compat32-%{name}
74cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
75Dict servers, using any of the supported protocols. cURL is designed
76to work without user interaction or any kind of interactivity. cURL
77offers many useful capabilities, like proxy support, user
78authentication, FTP upload, HTTP post, and file transfer resume.
79
80%package -n compat32-%{name}-devel
81Summary: Files needed for building applications with libcurl.
82Group: Development/Libraries
83
84%description -n compat32-%{name}-devel
85cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
86Dict servers, using any of the supported protocols. The curl-devel
87package includes files needed for developing applications which can
88use cURL's capabilities internally.
89#'
90
91%prep
92%setup -q
93
94# Fedora patches
95%patch101 -p1
96%patch102 -p1
97%patch104 -p1
98%patch107 -p1
99
100%build
101%configure \
102  --with-ssl=%{_prefix} \
103  --with-gnutls \
104  --with-libidn \
105  --enable-ipv6 \
106  --enable-threaded-resolver \
107  --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
108%if "%{?_dist_release}" != "vl6"
109  --with-libssh2 \
110%endif
111%if 0%{?with_http2}
112  --with-nghttp2 \
113%endif
114  --enable-ldaps \
115  --disable-static \
116  --enable-hidden-symbols
117
118make %{?_smp_mflags}
119
120%install
121rm -rf $RPM_BUILD_ROOT
122make DESTDIR=$RPM_BUILD_ROOT install
123
124rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
125
126%clean
127rm -rf $RPM_BUILD_ROOT
128
129%post -p /sbin/ldconfig
130
131%postun -p /sbin/ldconfig
132
133%files
134%defattr(-,root,root)
135%{!?_licensedir:%global license %%doc}
136%license COPYING
137%doc CHANGES README
138%doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
139%doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
140%doc docs/TheArtOfHttpScripting docs/TODO
141%{_bindir}/curl
142#{_datadir}/curl/*
143%{_libdir}/*.so.*
144%{_mandir}/man1/*.1*
145
146%files devel
147%defattr(-,root,root)
148%{_bindir}/curl-config
149%{_includedir}/curl
150%{_libdir}/*.so
151%{_libdir}/pkgconfig/*.pc
152%{_mandir}/man1/curl-config.1*
153%{_mandir}/man3/*
154%{_datadir}/aclocal/libcurl.m4
155
156
157## to build compat32 for x86_64 architecture support
158%if %{build_compat32}
159%files -n compat32-%{name}
160%defattr(-,root,root)
161%{_libdir}/*.so.*
162
163%files -n compat32-%{name}-devel
164%defattr(-,root,root)
165%{_libdir}/*.so
166%{_libdir}/pkgconfig/*.pc
167%endif
168
169%changelog
170* Mon May  1 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.54.0-1
171- new upstream release.
172
173* Thu Mar 16 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.53.1-1
174- new upstream release.
175
176* Wed Dec 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.51.0-1
177- new upstream release.
178
179* Fri Jul 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.50.0-1
180- new upstream release.
181- disabled HTTP/2 on Vine6.
182
183* Sat Jul 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-2
184- added HTTP/2 support.
185
186* Tue Jun 28 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-1
187- new upstream release with security fix.
188
189* Sat May 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.0-1
190- new upstream release.
191
192* Sat Mar 12 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.47.1-1
193- new upstream release
194- built with openssl 1.0.2g
195
196* Fri Jun 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.43.0-1
197- new upstream release with security fix .
198- removed Patch108 (fixed in upstream).
199
200* Sun Nov  9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.39.0-1
201- new upstream release with security fix
202
203* Sun Jan 19 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 7.34.0-1
204- new upstream release
205- add libcurl.m4 to -devel package
206
207* Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 7.32.0-1
208- new upstream release
209- import upstream/fedora patches
210- disable libssh2 on Vine Linux 6
211
212* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.1-1
213- new upstream reelase
214
215* Sun Oct 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.0-1
216- update to 7.28.0
217- add configure options
218  - --enable-ssh2, --enable-threaded-resolver, --enable-ldaps
219- add BR: libssh2-devel, openssh-clients, openssh-server, pkgconfig
220 
221- use ca-certificates package
222  - --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt
223  - R: ca-certificates
224
225* Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 7.24.0-1
226- new upstream release
227
228* Sun Jul  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-4
229- add patch100 for fix CVE-2011-2192 (gssapi)
230- add Vendor/Distri tags
231
232* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
233- rebuild with openssl-1.0.0c
234
235* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
236- rebuilt with rpm-4.8.1 for pkg-config
237
238* Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
239- new upstream release
240
241* Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
242- new upstream release with security fix
243
244* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
245- added compat32 subpackages
246
247* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
248- new upstream release
249- use "_smp_mflags" flag
250
251* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
252- rebuild with openldap-2.4.11
253- add BR: openldap-devel
254- remove static library
255
256* Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
257- new upstream release with security fix (CVE-2009-0037)
258
259* Sun Jul  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
260- new upstream release
261
262* Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
263- new upstream release
264
265* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
266- new upstream release
267
268* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
269- new upstream release
270
271* Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
272- new upstream release
273
274* Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
275- rebuilt with openssl-0.9.8e
276
277* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
278- new upstream release
279
280* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
281- new upstream release
282
283* Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
284- new upstream release
285- add pkgconfig file to devel package
286
287* Wed Dec  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
288- new upstream release
289
290* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
291- new upstream release
292
293* Fri Sep  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
294- new upstream release
295
296* Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
297- added libidn, zlib in Requires
298- added libidn-devel, zlib-devel in BuildPrereq
299- added zlib-devel in curl-devel's Requires
300
301* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
302- added openssl-devel, libidn-devel in curl-devel's Requires
303
304* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
305- new upstream release
306
307* Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
308- new upstream release
309- rebuild with openssl-0.9.7d
310
311* Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
312- upstream release
313
314* Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
315- add %%{_datadir}/curl/* to %%files section
316
317* Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
318- source upgrade
319
320* Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
321- source upgrade
322- add PreReq: ldconfig
323- add %%{_libdir}/*.la to %%files devel section
324
325* Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
326- build for VineSeed
327- add Requires: openssl
328
329* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
330- automated rebuild
331
332* Wed Jan  9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
333- 7.9.2
334
335* Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
336- include curl-config in curl-devel
337- update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
338
339* Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
340- added openssl-devel build req
341
342* Mon May 21 2001 Tim Powers <timp@redhat.com>
343- built for the distro
344
345* Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
346- upgrade to curl-7.7.2.
347- enable IPv6.
348
349* Fri Mar  2 2001 Tim Powers <timp@redhat.com>
350- rebuilt against openssl-0.9.6-1
351
352* Thu Jan  4 2001 Tim Powers <timp@redhat.com>
353- fixed mising ldconfigs
354- updated to 7.5.2, bug fixes
355
356* Mon Dec 11 2000 Tim Powers <timp@redhat.com>
357- updated to 7.5.1
358
359* Mon Nov  6 2000 Tim Powers <timp@redhat.com>
360- update to 7.4.1 to fix bug #20337, problems with curl -c
361- not using patch anymore, it's included in the new source. Keeping
362  for reference
363
364* Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
365- fix bogus req in -devel package
366
367* Fri Oct 20 2000 Tim Powers <timp@redhat.com>
368- devel package needed defattr so that root owns the files
369
370* Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
371- update to 7.3
372- apply vsprintf/vsnprintf patch from Colin Phipps via Debian
373
374* Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
375- enable SSL support
376- fix packager tag
377- move buildroot to %%{_tmppath}
378
379* Tue Aug 1 2000 Tim Powers <timp@redhat.com>
380- fixed vendor tag for bug #15028
381
382* Mon Jul 24 2000 Prospector <prospector@redhat.com>
383- rebuilt
384
385* Tue Jul 11 2000 Tim Powers <timp@redhat.com>
386- workaround alpha build problems with optimizations
387
388* Mon Jul 10 2000 Tim Powers <timp@redhat.com>
389- rebuilt
390
391* Mon Jun 5 2000 Tim Powers <timp@redhat.com>
392- put man pages in correct place
393- use %%makeinstall
394
395* Mon Apr 24 2000 Tim Powers <timp@redhat.com>
396- updated to 6.5.2
397
398* Wed Nov 3 1999 Tim Powers <timp@redhat.com>
399- updated sources to 6.2
400- gzip man page
401
402* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
403- changed group
404
405* Thu Aug 26 1999 Tim Powers <timp@redhat.com>
406- changelog started
407- general cleanups, changed prefix to /usr, added manpage to files section
408- including in Powertools
Note: See TracBrowser for help on using the repository browser.