source: projects/specs/trunk/c/curl/curl-vl.spec @ 12513

Revision 12513, 14.4 KB checked in by tomop, 3 years ago (diff)

updated 9 packages

curl-7.74.0-1

freerdp-2.2.0-1

golang-1.15.6-1

jasper-2.0.23-1

libssh-0.9.5-1

nghttp2-1.42.0-1

nodejs-14.15.1-1

pulseaudio-14.0-1

samba-4.13.3-1

RevLine 
[521]1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
[10740]3%if %{?_dist_release} != "vl6"
4%global with_http2 1
5%endif
6
[521]7Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
8Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
9Name: curl
[12513]10Version: 7.74.0
[10740]11Release: 1%{?_dist_release}
[12507]12Group: internet
[12415]13Vendor: Project Vine
14Distribution: Vine Linux
15Packager: daisuke
[7833]16
17License: MIT
[12424]18URL: https://curl.haxx.se/
19Source: https://curl.haxx.se/download/%{name}-%{version}.tar.xz
[7833]20
[12131]21# avoid reporting spurious error in the HTTP2 framing layer (#1690971)
22Patch2:   0002-curl-7.65.3-h2-framing-layer-error.patch
23
[11840]24# patch making libcurl multilib ready
[12507]25Patch101: 0101-curl-7.73.0-multilib.patch
[11725]26
[7833]27# prevent configure script from discarding -g in CFLAGS (#496778)
[10071]28Patch102: 0102-curl-7.36.0-debug.patch
[11840]29
[11725]30# migrate tests/http_pipe.py to Python 3
31Patch103: 0103-curl-7.59.0-python3.patch
[11840]32
[7833]33# use localhost6 instead of ip6-localhost in the curl test-suite
[12507]34Patch104: 0104-curl-7.73.0-localhost6.patch
[7833]35
[12131]36# prevent valgrind from reporting false positives on x86_64
37Patch105: 0105-curl-7.63.0-lib1560-valgrind.patch
38
[521]39BuildRoot: %{_tmppath}/%{name}-%{version}-root
[11316]40BuildRequires: openssl-devel
41BuildRequires: gnutls-devel
42BuildRequires: libidn-devel zlib-devel
43BuildRequires: openldap-devel
[7833]44BuildRequires: openssh-server
[7033]45BuildRequires: openssh-clients
46BuildRequires: pkgconfig
[7833]47%if "%{?_dist_release}" != "vl6"
48BuildRequires: libssh2-devel
49%endif
[10740]50%if 0%{?with_http2}
51BuildRequires: libnghttp2-devel
52%endif
53
[7033]54Requires: ca-certificates
[521]55
56%description
57cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
58Dict servers, using any of the supported protocols. cURL is designed
59to work without user interaction or any kind of interactivity. cURL
60offers many useful capabilities, like proxy support, user
61authentication, FTP upload, HTTP post, and file transfer resume.
62
[12507]63
[521]64%package devel
[890]65Summary: Files needed for building applications with libcurl.
[12507]66Group: programming
[521]67Requires: %{name} = %{version}-%{release}
68Requires: openssl-devel libidn-devel zlib-devel
69
70%description devel
71cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
72Dict servers, using any of the supported protocols. The curl-devel
73package includes files needed for developing applications which can
74use cURL's capabilities internally.
75#'
76
77
78## to build compat32 for x86_64 architecture support
79%package -n compat32-%{name}
80Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
81Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
[12507]82Group: system
[521]83
84%description -n compat32-%{name}
85cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
86Dict servers, using any of the supported protocols. cURL is designed
87to work without user interaction or any kind of interactivity. cURL
88offers many useful capabilities, like proxy support, user
89authentication, FTP upload, HTTP post, and file transfer resume.
90
[12507]91
[521]92%package -n compat32-%{name}-devel
93Summary: Files needed for building applications with libcurl.
[12507]94Group: programming
[521]95
96%description -n compat32-%{name}-devel
97cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
98Dict servers, using any of the supported protocols. The curl-devel
99package includes files needed for developing applications which can
100use cURL's capabilities internally.
101#'
102
[12507]103
104%debug_package
105
106
[521]107%prep
108%setup -q
109
[11725]110# upstream patches
111
[7833]112# Fedora patches
113%patch101 -p1
114%patch102 -p1
[11840]115#patch103 -p1
[7833]116%patch104 -p1
[12131]117%patch105 -p1
[7833]118
[11725]119# make tests/*.py use Python 3
120sed -e '1 s|^#!/.*python|&3|' -i tests/*.py
121
[11840]122# regenerate Makefile.in files
123aclocal -I m4
124automake
125
126# disable test 1112 (#565305), test 1455 (occasionally fails with 'bind failed
127# with errno 98: Address already in use' in Koji environment), and test 1801
[11725]128# <https://github.com/bagder/curl/commit/21e82bd6#commitcomment-12226582>
[11840]129# and test 1900, which is flaky and covers a deprecated feature of libcurl
130# <https://github.com/curl/curl/pull/2705>
131printf "1112\n1455\n1801\n1900\n" >> tests/data/DISABLED
[11725]132
[11840]133# disable test 1319 on ppc64 (server times out)
134%ifarch ppc64
135echo "1319" >> tests/data/DISABLED
136%endif
137
138# temporarily disable test 582 on s390x (client times out)
139%ifarch s390x
140echo "582" >> tests/data/DISABLED
141%endif
142
143# adapt test 323 for updated OpenSSL
144sed -e 's/^35$/35,52/' -i tests/data/test323
145
[12507]146
[521]147%build
[7033]148%configure \
149  --with-ssl=%{_prefix} \
150  --with-libidn \
151  --enable-ipv6 \
152  --enable-threaded-resolver \
[11316]153  --with-ssl --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
[7833]154%if "%{?_dist_release}" != "vl6"
[7033]155  --with-libssh2 \
[7833]156%endif
[10740]157%if 0%{?with_http2}
158  --with-nghttp2 \
159%endif
[7033]160  --enable-ldaps \
[8211]161  --disable-static \
162  --enable-hidden-symbols
[7033]163
[521]164make %{?_smp_mflags}
165
[12507]166
[521]167%install
168rm -rf $RPM_BUILD_ROOT
169make DESTDIR=$RPM_BUILD_ROOT install
170
171rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
172
[12507]173
[521]174%clean
175rm -rf $RPM_BUILD_ROOT
176
177%post -p /sbin/ldconfig
178%postun -p /sbin/ldconfig
179
[12507]180
[521]181%files
182%defattr(-,root,root)
[10740]183%{!?_licensedir:%global license %%doc}
[10632]184%license COPYING
185%doc CHANGES README
[521]186%doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
187%doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
188%doc docs/TheArtOfHttpScripting docs/TODO
189%{_bindir}/curl
190#{_datadir}/curl/*
191%{_libdir}/*.so.*
[7033]192%{_mandir}/man1/*.1*
[521]193
194%files devel
195%defattr(-,root,root)
196%{_bindir}/curl-config
197%{_includedir}/curl
198%{_libdir}/*.so
199%{_libdir}/pkgconfig/*.pc
200%{_mandir}/man1/curl-config.1*
201%{_mandir}/man3/*
[8211]202%{_datadir}/aclocal/libcurl.m4
[521]203
204
205## to build compat32 for x86_64 architecture support
206%if %{build_compat32}
207%files -n compat32-%{name}
208%defattr(-,root,root)
209%{_libdir}/*.so.*
210
211%files -n compat32-%{name}-devel
212%defattr(-,root,root)
213%{_libdir}/*.so
214%endif
215
[12507]216
[521]217%changelog
[12513]218* Wed Dec 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.74.0-1
219- new upstream release.
220
[12507]221* Tue Nov 03 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.73.0-1
222- new upstream release.
223- updated Patch0101 and Patch0104.
224
[12424]225* Fri Jul 10 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.71.1-1
226- new upstream release.
227
[12415]228* Tue Jun 09 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.70.0-1
229- new upstream release.
230
[12322]231* Sun Feb 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.68.0-1
232- new upstream release.
233
[12223]234* Sat Sep 21 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.66.0-1
235- new upstream release.
236- dropped Patch1 and 2: fixed in upstream.
237
[12131]238* Thu Aug 29 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.65.3-1
239- new upstream release.
240- updated patches.
241- imported Patch1, 2 and 105 from rawhide.
242
[11840]243* Sat Nov 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.62.0-1
244- new upstream release.
245- imported patches from rawhide.
246
[11725]247* Fri Apr 13 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.59.0-1
248- new upstream release.
249- imported Patch1 and 103 from rawhide.
250
[11470]251* Wed Feb  7 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.58.0-1
252- new upstream release with security fix
253- update patch101
254
[11316]255* Thu Jan 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.57.0-1
256- new upstream release.
257- updated Patch101-104.
258- dropped Patch107.
259
[11062]260* Mon May  1 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.54.0-1
261- new upstream release.
262
[10933]263* Thu Mar 16 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.53.1-1
264- new upstream release.
265
[10847]266* Wed Dec 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.51.0-1
267- new upstream release.
268
[10740]269* Fri Jul 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.50.0-1
270- new upstream release.
271- disabled HTTP/2 on Vine6.
272
[10632]273* Sat Jul 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-2
274- added HTTP/2 support.
275
[10418]276* Tue Jun 28 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-1
277- new upstream release with security fix.
278
[10302]279* Sat May 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.0-1
280- new upstream release.
281
[10071]282* Sat Mar 12 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.47.1-1
283- new upstream release
284- built with openssl 1.0.2g
285
[9628]286* Fri Jun 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.43.0-1
287- new upstream release with security fix .
288- removed Patch108 (fixed in upstream).
289
[9068]290* Sun Nov  9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.39.0-1
291- new upstream release with security fix
292
[8211]293* Sun Jan 19 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 7.34.0-1
294- new upstream release
295- add libcurl.m4 to -devel package
296
[7833]297* Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 7.32.0-1
298- new upstream release
299- import upstream/fedora patches
300- disable libssh2 on Vine Linux 6
301
[7175]302* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.1-1
303- new upstream reelase
304
[7033]305* Sun Oct 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.0-1
306- update to 7.28.0
307- add configure options
308  - --enable-ssh2, --enable-threaded-resolver, --enable-ldaps
309- add BR: libssh2-devel, openssh-clients, openssh-server, pkgconfig
310 
311- use ca-certificates package
312  - --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt
313  - R: ca-certificates
314
[5734]315* Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 7.24.0-1
316- new upstream release
317
[4261]318* Sun Jul  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-4
319- add patch100 for fix CVE-2011-2192 (gssapi)
320- add Vendor/Distri tags
321
[2487]322* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
323- rebuild with openssl-1.0.0c
324
[1919]325* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
326- rebuilt with rpm-4.8.1 for pkg-config
327
[890]328* Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
329- new upstream release
330
[521]331* Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
332- new upstream release with security fix
333
334* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
335- added compat32 subpackages
336
337* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
338- new upstream release
339- use "_smp_mflags" flag
340
341* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
342- rebuild with openldap-2.4.11
343- add BR: openldap-devel
344- remove static library
345
346* Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
347- new upstream release with security fix (CVE-2009-0037)
348
349* Sun Jul  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
350- new upstream release
351
352* Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
353- new upstream release
354
355* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
356- new upstream release
357
358* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
359- new upstream release
360
361* Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
362- new upstream release
363
364* Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
365- rebuilt with openssl-0.9.8e
366
367* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
368- new upstream release
369
370* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
371- new upstream release
372
373* Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
374- new upstream release
375- add pkgconfig file to devel package
376
377* Wed Dec  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
378- new upstream release
379
380* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
381- new upstream release
382
383* Fri Sep  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
384- new upstream release
385
386* Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
387- added libidn, zlib in Requires
388- added libidn-devel, zlib-devel in BuildPrereq
389- added zlib-devel in curl-devel's Requires
390
391* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
392- added openssl-devel, libidn-devel in curl-devel's Requires
393
394* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
395- new upstream release
396
397* Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
398- new upstream release
399- rebuild with openssl-0.9.7d
400
401* Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
402- upstream release
403
404* Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
405- add %%{_datadir}/curl/* to %%files section
406
407* Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
408- source upgrade
409
410* Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
411- source upgrade
412- add PreReq: ldconfig
413- add %%{_libdir}/*.la to %%files devel section
414
415* Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
416- build for VineSeed
417- add Requires: openssl
418
419* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
420- automated rebuild
421
422* Wed Jan  9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
423- 7.9.2
424
425* Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
426- include curl-config in curl-devel
427- update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
428
429* Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
430- added openssl-devel build req
431
432* Mon May 21 2001 Tim Powers <timp@redhat.com>
433- built for the distro
434
435* Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
436- upgrade to curl-7.7.2.
437- enable IPv6.
438
439* Fri Mar  2 2001 Tim Powers <timp@redhat.com>
440- rebuilt against openssl-0.9.6-1
441
442* Thu Jan  4 2001 Tim Powers <timp@redhat.com>
443- fixed mising ldconfigs
444- updated to 7.5.2, bug fixes
445
446* Mon Dec 11 2000 Tim Powers <timp@redhat.com>
447- updated to 7.5.1
448
449* Mon Nov  6 2000 Tim Powers <timp@redhat.com>
450- update to 7.4.1 to fix bug #20337, problems with curl -c
451- not using patch anymore, it's included in the new source. Keeping
452  for reference
453
454* Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
455- fix bogus req in -devel package
456
457* Fri Oct 20 2000 Tim Powers <timp@redhat.com>
458- devel package needed defattr so that root owns the files
459
460* Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
461- update to 7.3
462- apply vsprintf/vsnprintf patch from Colin Phipps via Debian
463
464* Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
465- enable SSL support
466- fix packager tag
467- move buildroot to %%{_tmppath}
468
469* Tue Aug 1 2000 Tim Powers <timp@redhat.com>
470- fixed vendor tag for bug #15028
471
472* Mon Jul 24 2000 Prospector <prospector@redhat.com>
473- rebuilt
474
475* Tue Jul 11 2000 Tim Powers <timp@redhat.com>
476- workaround alpha build problems with optimizations
477
478* Mon Jul 10 2000 Tim Powers <timp@redhat.com>
479- rebuilt
480
481* Mon Jun 5 2000 Tim Powers <timp@redhat.com>
482- put man pages in correct place
483- use %%makeinstall
484
485* Mon Apr 24 2000 Tim Powers <timp@redhat.com>
486- updated to 6.5.2
487
488* Wed Nov 3 1999 Tim Powers <timp@redhat.com>
489- updated sources to 6.2
490- gzip man page
491
492* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
493- changed group
494
495* Thu Aug 26 1999 Tim Powers <timp@redhat.com>
496- changelog started
497- general cleanups, changed prefix to /usr, added manpage to files section
498- including in Powertools
Note: See TracBrowser for help on using the repository browser.