source: projects/specs/trunk/c/courier-authlib/courier-authlib-vl.spec @ 8747

Revision 8747, 8.2 KB checked in by tomop, 10 years ago (diff)

courier-authlib-0.66.1-2

Line 
1Summary: Courier authentication library.
2Summary(ja): Courier 認証ライブラリ
3Name: courier-authlib
4Version: 0.66.1
5Release: 2%{?_dist_release}
6License: GPL
7Group: System Environment/Daemons
8URL: http://www.courier-mta.org
9Source0: %{name}-%{version}.tar.bz2
10BuildRoot: %{_tmppath}/%{name}-%{version}-root
11BuildRequires: libtool
12BuildRequires: libtool-ltdl-devel
13BuildRequires: openldap-devel
14BuildRequires: libmysqlclient-devel zlib-devel
15BuildRequires: libpq-devel
16BuildRequires: gdbm-devel
17BuildRequires: pam-devel
18BuildRequires: expect
19
20Requires(post): /sbin/chkconfig
21Requires(preun): /sbin/chkconfig
22
23Vendor: Project Vine
24Distribution: Vine Linux
25Packager: tomop
26
27%description
28The Courier authentication library provides authentication services for
29other Courier applications.
30
31%description -l ja
32Courier 認証ライブラリは他の Courier アプリケーションへ認証サービスを
33提供します。
34
35
36%package devel
37Summary: Development libraries for the Courier authentication library.
38Summary(ja): Courier 認証ライブラリの開発ライブラリ
39Group: Development/Libraries
40Requires: courier-authlib = %{version}-%{release}
41
42%description devel
43This package contains the development libraries and files needed to compile
44Courier packages that use this authentication library.  Install this
45package in order to build the rest of the Courier packages.  After they are
46built and installed this package can be removed.  Files in this package
47are not needed at runtime.
48
49%description -l ja devel
50認証ライブラリを必要とする Courier パッケージのコンパイルに必要な開発
51ライブラリです。他の Courier パッケージを作成するならインストールして
52ください。作成したパッケージのインストール後は不要ですので削除しても構
53いません。このパッケージに含まれるファイルは実行時には必要ありません。
54
55
56%package ldap
57Summary: LDAP support for the Courier authentication library.
58Summary(ja): Courier 認証ライブラリの LDAP サポート
59Group: System Environment/Daemons
60Requires: courier-authlib = %{version}-%{release}
61Requires: openldap
62
63%description ldap
64This package installs LDAP support for the Courier authentication library.
65Install this package in order to be able to authenticate using LDAP.
66
67%description -l ja ldap
68Courier 認証ライブラリの LDAP サポートパッケージです。LDAP を使った認証を
69行なう場合にインストールしてください。
70
71
72%package pgsql
73Summary: PostgreSQL support for the Courier authentication library.
74Summary(ja): Courier 認証ライブラリの PostgreSQL サポート
75Group: System Environment/Daemons
76Requires: courier-authlib = %{version}-%{release}
77
78%description pgsql
79This package installs PostgreSQL support for the Courier authentication
80library.
81Install this package in order to be able to authenticate using PostgreSQL.
82
83%description -l ja pgsql
84Courier 認証ライブラリの PostgreSQL サポートパッケージです。PostgreSQL を
85使った認証を行なう場合にインストールしてください。
86
87
88%package mysql
89Summary: MySQL support for the Courier authentication library.
90Summary(ja): Courier 認証ライブラリの MySQL サポート
91Group: System Environment/Daemons
92Requires: courier-authlib = %{version}-%{release}
93
94%description mysql
95This package installs MySQL support for the Courier authentication library.
96Install this package in order to be able to authenticate using MySQL.
97
98%description -l ja mysql
99Courier 認証ライブラリの MySQL サポートパッケージです。MySQL を使った認証を
100行なう場合にインストールしてください。
101
102%prep
103%setup -q
104
105%build
106#%configure --without-authldap --without-authpgsql
107%configure
108make
109
110%install
111rm -rf %{buildroot}
112make install DESTDIR=%{buildroot}
113rm -f %{buildroot}/%{_libdir}/%{name}/*.a
114install -m 555 sysconftool %{buildroot}/%{_libexecdir}/%{name}
115install -m 555 authmigrate %{buildroot}/%{_libexecdir}/%{name}
116
117#./courierauthconfig --configfiles >configtmp
118#. configtmp
119
120./authmksock %{buildroot}/%{_localstatedir}/spool/authdaemon/socket || exit 1
121touch %{buildroot}/%{_localstatedir}/spool/authdaemon/pid.lock || exit 1
122touch %{buildroot}/%{_localstatedir}/spool/authdaemon/pid || exit 1
123chmod 777 %{buildroot}/%{_localstatedir}/spool/authdaemon/socket || exit 1
124
125mkdir -p %{buildroot}/%{_initdir}
126install -m 555 courier-authlib.sysvinit %{buildroot}/%{_initdir}/courier-authlib
127
128%post
129%{_libexecdir}/%{name}/authmigrate >/dev/null
130%{_libexecdir}/%{name}/sysconftool %{_sysconfdir}/authlib/*.dist >/dev/null
131
132/sbin/chkconfig --del courier-authlib
133/sbin/chkconfig --add courier-authlib
134
135%preun
136if test -x %{_sbindir}/authdaemond
137then
138        %{_sbindir}/authdaemond >/dev/null 2>&1 || /bin/true
139fi
140
141if test "$1" = "0"
142then
143        /sbin/chkconfig --del courier-authlib
144fi
145
146%clean
147rm -rf %{buildroot}
148
149%files
150%defattr(-,root,root)
151%doc README README*html README.authmysql.myownquery README.ldap
152%doc NEWS COPYING* AUTHORS ChangeLog authldap.schema
153/etc/rc.d/init.d/*
154%ghost %attr(600,root,root) %{_localstatedir}/spool/authdaemon/pid.lock
155%ghost %attr(644,root,root) %{_localstatedir}/spool/authdaemon/pid
156%ghost %attr(-,root,root) %{_localstatedir}/spool/authdaemon/socket
157%{_mandir}/man1/*
158%{_mandir}/man8/*
159%defattr(-,daemon,daemon)
160%dir %{_sysconfdir}/authlib
161%{_sysconfdir}/authlib/authdaemonrc.dist
162%{_libexecdir}/%{name}
163%dir %{_libdir}/%{name}
164%{_libdir}/%{name}/libauthcustom*
165%{_libdir}/%{name}/libauthpam*
166%{_libdir}/%{name}/libauthpipe*
167%{_libdir}/%{name}/libauthuser*
168%{_libdir}/%{name}/libcourierauth*
169%dir %attr(750,daemon,daemon) %{_localstatedir}/spool/authdaemon
170%{_sbindir}/*
171
172%files devel
173%defattr(-,root,root)
174%{_bindir}/courierauthconfig
175%{_includedir}/*
176%{_mandir}/man3/*
177%doc authlib.html auth_*.html
178
179%files ldap
180%defattr(-,root,root)
181%{_sysconfdir}/authlib/authldaprc.dist
182%{_libdir}/%{name}/libauthldap*
183
184%files pgsql
185%defattr(-,root,root)
186%{_sysconfdir}/authlib/authpgsqlrc.dist
187%{_libdir}/%{name}/libauthpgsql*
188
189%files mysql
190%defattr(-,root,root)
191%{_sysconfdir}/authlib/authmysqlrc.dist
192%{_libdir}/%{name}/libauthmysql*
193
194
195%changelog
196* Sun Jul 6 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.66.1-2
197- rebuilt with current environment.
198- replaced BR:MySQL-devel to BR:libmysqlclient-devel.
199- replaced BR:postgresql-devel to BR:libpq-devel.
200- dropped R:postgresql-libs (detected by autoreq).
201- dropped R:postgresql.
202
203* Sat Jan  4 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 0.66.1-1
204- update to 0.66.1
205- drop APOP patch (Patch0)
206- add BuildRequires: libtool-ltdl-devel
207
208* Sun Apr 03 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.63.0-2
209- Rebuilt with new toolchain.
210
211* Sun Feb 07 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.63.0-1
212- new upstream release.
213- replaced "BuildPreReq:" with "BuilldRequires:".
214
215* Sun Nov 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.62.4-1
216- new upstream release.
217- removed "Requires: MySQL-shared".
218- updated APOP patch.
219
220* Thu May 21 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.59.3-2
221- rebuilt with MySQL-shared-5.1.34.
222
223* Sat Jul 05 2008 Shu KONNO <owa@bg.wakwak.com> 0.59.3-1vl5
224- applied new versioning policy, and spec in utf-8
225- rebuilt with postgresql-8.3.3
226
227* Sun Jan 27 2008 Shu KONNO <owa@bg.wakwak.com> 0.59.3-0vl3
228- rebuilt
229
230* Tue Jan 08 2008 Shu KONNO <owa@bg.wakwak.com> 0.59.3-0vl2
231- rebuilt with postgresql-8.2.6
232
233* Thu Sep 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.59.3-0vl1
234- new upstream release
235- rebuilt with postgresql 8.2.5
236
237* Sat Nov 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.56-0vl4
238- rebuilt with MySQL 5.0.27
239- included /usr/lib/courier-authlib/libauthpipe.*
240
241* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.56-0vl3
242- rebuilt with openldap-2.3.27-0vl1
243
244* Sun May 22 2005 UECHI Yasumasa <uechi@potaway.net> 0.56-0vl2
245- new upstream release
246
247* Mon Mar 28 2005 UECHI Yasumasa <uechi@potaway.net> 0.55-0vl4
248- add ldap, postgresql, mysql packages
249
250* Thu Mar 17 2005 UECHI Yasumasa <uechi@potaway.net> 0.55-0vl1
251- new upstream release
252
253* Thu Feb 17 2005 UECHI Yasumasa <uechi@potaway.net> 0.54-0vl1
254- new upstream release
255
256* Wed Jan 12 2005 UECHI Yasumasa <uechi@potaway.net> 0.53-0vl1
257- new upstream release
258
259* Wed Jan 12 2005 UECHI Yasumasa <uechi@potaway.net> 0.52-0vl1
260- simplify a spec for Vine
261- add apop patch
262
263* Sun Oct  3 2004 Mr. Sam <sam@email-scan.com> - 0.50-1
264- Initial build.
Note: See TracBrowser for help on using the repository browser.