source: projects/specs/trunk/c/courier-authlib/courier-authlib-vl.spec @ 11085

Revision 11085, 9.1 KB checked in by iwaim, 7 years ago (diff)

courier-authlib 0.67.0-1

Line 
1Summary: Courier authentication library.
2Summary(ja): Courier 認証ライブラリ
3Name: courier-authlib
4Version: 0.67.0
5Release: 1%{?_dist_release}
6License: GPLv3
7Group: System Environment/Daemons
8URL: http://www.courier-mta.org
9Source0: %{name}-%{version}.tar.bz2
10BuildRoot: %{_tmppath}/%{name}-%{version}-root
11BuildRequires: libtool
12BuildRequires: libtool-ltdl-devel
13BuildRequires: zlib-devel
14BuildRequires: gdbm-devel
15BuildRequires: pam-devel
16BuildRequires: expect
17BuildRequires: courier-unicode-devel > 1.2
18
19Requires(post): /sbin/chkconfig
20Requires(preun): /sbin/chkconfig
21
22Patch0: courier-authlib-0.67.0_configure.patch
23
24Vendor: Project Vine
25Distribution: Vine Linux
26Packager: tomop, iwaim
27
28%description
29The Courier authentication library provides authentication services for
30other Courier applications.
31
32%description -l ja
33Courier 認証ライブラリは他の Courier アプリケーションへ認証サービスを
34提供します。
35
36
37%package devel
38Summary: Development libraries for the Courier authentication library.
39Summary(ja): Courier 認証ライブラリの開発ライブラリ
40Group: Development/Libraries
41Requires: courier-authlib = %{version}-%{release}
42
43%description devel
44This package contains the development libraries and files needed to compile
45Courier packages that use this authentication library.  Install this
46package in order to build the rest of the Courier packages.  After they are
47built and installed this package can be removed.  Files in this package
48are not needed at runtime.
49
50%description -l ja devel
51認証ライブラリを必要とする Courier パッケージのコンパイルに必要な開発
52ライブラリです。他の Courier パッケージを作成するならインストールして
53ください。作成したパッケージのインストール後は不要ですので削除しても構
54いません。このパッケージに含まれるファイルは実行時には必要ありません。
55
56
57%package ldap
58Summary: LDAP support for the Courier authentication library.
59Summary(ja): Courier 認証ライブラリの LDAP サポート
60Group: System Environment/Daemons
61Requires: courier-authlib = %{version}-%{release}
62Requires: openldap
63BuildRequires: openldap-devel
64
65%description ldap
66This package installs LDAP support for the Courier authentication library.
67Install this package in order to be able to authenticate using LDAP.
68
69%description -l ja ldap
70Courier 認証ライブラリの LDAP サポートパッケージです。LDAP を使った認証を
71行なう場合にインストールしてください。
72
73
74%package pgsql
75Summary: PostgreSQL support for the Courier authentication library.
76Summary(ja): Courier 認証ライブラリの PostgreSQL サポート
77Group: System Environment/Daemons
78Requires: courier-authlib = %{version}-%{release}
79%if "%{?_dist_release}" == "vl6"
80BuildRequires: postgresql-devel
81%else
82BuildRequires: libpq-devel
83%endif
84
85%description pgsql
86This package installs PostgreSQL support for the Courier authentication
87library.
88Install this package in order to be able to authenticate using PostgreSQL.
89
90%description -l ja pgsql
91Courier 認証ライブラリの PostgreSQL サポートパッケージです。PostgreSQL を
92使った認証を行なう場合にインストールしてください。
93
94
95%package mysql
96Summary: MySQL support for the Courier authentication library.
97Summary(ja): Courier 認証ライブラリの MySQL サポート
98Group: System Environment/Daemons
99Requires: courier-authlib = %{version}-%{release}
100%if "%{?_dist_release}" == "vl6"
101BuildRequires: MySQL-devel
102%else
103BuildRequires: libmysqlclient-devel
104%endif
105
106%description mysql
107This package installs MySQL support for the Courier authentication library.
108Install this package in order to be able to authenticate using MySQL.
109
110%description -l ja mysql
111Courier 認証ライブラリの MySQL サポートパッケージです。MySQL を使った認証を
112行なう場合にインストールしてください。
113
114%prep
115%setup -q
116%patch0 -p1
117
118%build
119#%configure --without-authldap --without-authpgsql
120%configure
121make
122
123%install
124rm -rf %{buildroot}
125make install DESTDIR=%{buildroot}
126rm -f %{buildroot}/%{_libdir}/%{name}/*.a
127install -m 555 sysconftool %{buildroot}/%{_libexecdir}/%{name}
128install -m 555 authmigrate %{buildroot}/%{_libexecdir}/%{name}
129
130#./courierauthconfig --configfiles >configtmp
131#. configtmp
132
133./authmksock %{buildroot}/%{_localstatedir}/spool/authdaemon/socket || exit 1
134touch %{buildroot}/%{_localstatedir}/spool/authdaemon/pid.lock || exit 1
135touch %{buildroot}/%{_localstatedir}/spool/authdaemon/pid || exit 1
136chmod 777 %{buildroot}/%{_localstatedir}/spool/authdaemon/socket || exit 1
137
138mkdir -p %{buildroot}/%{_initdir}
139install -m 555 courier-authlib.sysvinit %{buildroot}/%{_initdir}/courier-authlib
140
141%post
142%{_libexecdir}/%{name}/authmigrate >/dev/null
143%{_libexecdir}/%{name}/sysconftool %{_sysconfdir}/authlib/*.dist >/dev/null
144
145/sbin/chkconfig --del courier-authlib
146/sbin/chkconfig --add courier-authlib
147
148%preun
149if test -x %{_sbindir}/authdaemond
150then
151        %{_sbindir}/authdaemond >/dev/null 2>&1 || /bin/true
152fi
153
154if test "$1" = "0"
155then
156        /sbin/chkconfig --del courier-authlib
157fi
158
159%clean
160rm -rf %{buildroot}
161
162%files
163%defattr(-,root,root)
164%doc README README*html README.authmysql.myownquery README.ldap
165%doc NEWS COPYING* AUTHORS ChangeLog authldap.schema
166/etc/rc.d/init.d/*
167%ghost %attr(600,root,root) %{_localstatedir}/spool/authdaemon/pid.lock
168%ghost %attr(644,root,root) %{_localstatedir}/spool/authdaemon/pid
169%ghost %attr(-,root,root) %{_localstatedir}/spool/authdaemon/socket
170%{_mandir}/man1/*
171%{_mandir}/man8/*
172%defattr(-,daemon,daemon)
173%dir %{_sysconfdir}/authlib
174%{_sysconfdir}/authlib/authdaemonrc.dist
175%{_libexecdir}/%{name}
176%dir %{_libdir}/%{name}
177%{_libdir}/%{name}/libauthcustom*
178%{_libdir}/%{name}/libauthpam*
179%{_libdir}/%{name}/libauthpipe*
180%{_libdir}/%{name}/libauthuser*
181%{_libdir}/%{name}/libcourierauth*
182%dir %attr(750,daemon,daemon) %{_localstatedir}/spool/authdaemon
183%{_sbindir}/*
184
185%files devel
186%defattr(-,root,root)
187%{_bindir}/courierauthconfig
188%{_includedir}/*
189%{_mandir}/man3/*
190%doc authlib.html auth_*.html
191
192%files ldap
193%defattr(-,root,root)
194%{_sysconfdir}/authlib/authldaprc.dist
195%{_libdir}/%{name}/libauthldap*
196
197%files pgsql
198%defattr(-,root,root)
199%{_sysconfdir}/authlib/authpgsqlrc.dist
200%{_libdir}/%{name}/libauthpgsql*
201
202%files mysql
203%defattr(-,root,root)
204%{_sysconfdir}/authlib/authmysqlrc.dist
205%{_libdir}/%{name}/libauthmysql*
206
207
208%changelog
209* Mon Jan 30 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 0.67.0-1
210- update to 0.67.0
211- add CXXFLAGS patch (Patch0)
212
213* Thu Jan  5 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 0.66.4-4
214- fix typo for VineSeed
215
216* Thu Jan  5 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 0.66.4-3
217- build for Vine Linux 6
218
219* Fri May  6 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 0.66.4-2
220- build with openssl 1.0.2 for courier-authlib-mysql
221
222* Tue Dec 29 2015 IWAI, Masaharu <iwaim.sub@gmail.com> 0.66.4-1
223- update to 0.66.4
224- add BuildRequires: courier-unicode-devel > 1.2
225- update License tag
226- add Packager: iwaim
227
228* Sun Jul 6 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.66.1-2
229- rebuilt with current environment.
230- replaced BR:MySQL-devel to BR:libmysqlclient-devel.
231- replaced BR:postgresql-devel to BR:libpq-devel.
232- dropped R:postgresql-libs (detected by autoreq).
233- dropped R:postgresql.
234
235* Sat Jan  4 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 0.66.1-1
236- update to 0.66.1
237- drop APOP patch (Patch0)
238- add BuildRequires: libtool-ltdl-devel
239
240* Sun Apr 03 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.63.0-2
241- Rebuilt with new toolchain.
242
243* Sun Feb 07 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.63.0-1
244- new upstream release.
245- replaced "BuildPreReq:" with "BuilldRequires:".
246
247* Sun Nov 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.62.4-1
248- new upstream release.
249- removed "Requires: MySQL-shared".
250- updated APOP patch.
251
252* Thu May 21 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.59.3-2
253- rebuilt with MySQL-shared-5.1.34.
254
255* Sat Jul 05 2008 Shu KONNO <owa@bg.wakwak.com> 0.59.3-1vl5
256- applied new versioning policy, and spec in utf-8
257- rebuilt with postgresql-8.3.3
258
259* Sun Jan 27 2008 Shu KONNO <owa@bg.wakwak.com> 0.59.3-0vl3
260- rebuilt
261
262* Tue Jan 08 2008 Shu KONNO <owa@bg.wakwak.com> 0.59.3-0vl2
263- rebuilt with postgresql-8.2.6
264
265* Thu Sep 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.59.3-0vl1
266- new upstream release
267- rebuilt with postgresql 8.2.5
268
269* Sat Nov 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.56-0vl4
270- rebuilt with MySQL 5.0.27
271- included /usr/lib/courier-authlib/libauthpipe.*
272
273* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.56-0vl3
274- rebuilt with openldap-2.3.27-0vl1
275
276* Sun May 22 2005 UECHI Yasumasa <uechi@potaway.net> 0.56-0vl2
277- new upstream release
278
279* Mon Mar 28 2005 UECHI Yasumasa <uechi@potaway.net> 0.55-0vl4
280- add ldap, postgresql, mysql packages
281
282* Thu Mar 17 2005 UECHI Yasumasa <uechi@potaway.net> 0.55-0vl1
283- new upstream release
284
285* Thu Feb 17 2005 UECHI Yasumasa <uechi@potaway.net> 0.54-0vl1
286- new upstream release
287
288* Wed Jan 12 2005 UECHI Yasumasa <uechi@potaway.net> 0.53-0vl1
289- new upstream release
290
291* Wed Jan 12 2005 UECHI Yasumasa <uechi@potaway.net> 0.52-0vl1
292- simplify a spec for Vine
293- add apop patch
294
295* Sun Oct  3 2004 Mr. Sam <sam@email-scan.com> - 0.50-1
296- Initial build.
Note: See TracBrowser for help on using the repository browser.