source: projects/specs/trunk/c/courier-authlib/courier-authlib-vl.spec @ 8135

Revision 8135, 8.0 KB checked in by iwaim, 10 years ago (diff)

courier-authlib 0.66.1-1

Line 
1Summary: Courier authentication library.
2Summary(ja): Courier 認証ライブラリ
3Name: courier-authlib
4Version: 0.66.1
5Release: 1%{?_dist_release}
6License: GPL
7Group: System Environment/Daemons
8URL: http://www.courier-mta.org
9Source0: %{name}-%{version}.tar.bz2
10BuildRoot: %{_tmppath}/%{name}-%{version}-root
11BuildRequires: libtool
12BuildRequires: libtool-ltdl-devel
13BuildRequires: openldap-devel
14BuildRequires: MySQL-devel zlib-devel
15BuildRequires: postgresql-devel
16BuildRequires: gdbm-devel
17BuildRequires: pam-devel
18BuildRequires: expect
19
20Requires(post): /sbin/chkconfig
21Requires(preun): /sbin/chkconfig
22
23Vendor: Project Vine
24Distribution: Vine Linux
25Packager: tomop
26
27%description
28The Courier authentication library provides authentication services for
29other Courier applications.
30
31%description -l ja
32Courier 認証ライブラリは他の Courier アプリケーションへ認証サービスを
33提供します。
34
35
36%package devel
37Summary: Development libraries for the Courier authentication library.
38Summary(ja): Courier 認証ライブラリの開発ライブラリ
39Group: Development/Libraries
40Requires: courier-authlib = %{version}-%{release}
41
42%description devel
43This package contains the development libraries and files needed to compile
44Courier packages that use this authentication library.  Install this
45package in order to build the rest of the Courier packages.  After they are
46built and installed this package can be removed.  Files in this package
47are not needed at runtime.
48
49%description -l ja devel
50認証ライブラリを必要とする Courier パッケージのコンパイルに必要な開発
51ライブラリです。他の Courier パッケージを作成するならインストールして
52ください。作成したパッケージのインストール後は不要ですので削除しても構
53いません。このパッケージに含まれるファイルは実行時には必要ありません。
54
55
56%package ldap
57Summary: LDAP support for the Courier authentication library.
58Summary(ja): Courier 認証ライブラリの LDAP サポート
59Group: System Environment/Daemons
60Requires: courier-authlib = %{version}-%{release}
61Requires: openldap
62
63%description ldap
64This package installs LDAP support for the Courier authentication library.
65Install this package in order to be able to authenticate using LDAP.
66
67%description -l ja ldap
68Courier 認証ライブラリの LDAP サポートパッケージです。LDAP を使った認証を
69行なう場合にインストールしてください。
70
71
72%package pgsql
73Summary: PostgreSQL support for the Courier authentication library.
74Summary(ja): Courier 認証ライブラリの PostgreSQL サポート
75Group: System Environment/Daemons
76Requires: courier-authlib = %{version}-%{release}
77Requires: postgresql-libs, postgresql
78
79%description pgsql
80This package installs PostgreSQL support for the Courier authentication
81library.
82Install this package in order to be able to authenticate using PostgreSQL.
83
84%description -l ja pgsql
85Courier 認証ライブラリの PostgreSQL サポートパッケージです。PostgreSQL を
86使った認証を行なう場合にインストールしてください。
87
88
89%package mysql
90Summary: MySQL support for the Courier authentication library.
91Summary(ja): Courier 認証ライブラリの MySQL サポート
92Group: System Environment/Daemons
93Requires: courier-authlib = %{version}-%{release}
94
95%description mysql
96This package installs MySQL support for the Courier authentication library.
97Install this package in order to be able to authenticate using MySQL.
98
99%description -l ja mysql
100Courier 認証ライブラリの MySQL サポートパッケージです。MySQL を使った認証を
101行なう場合にインストールしてください。
102
103%prep
104%setup -q
105
106%build
107#%configure --without-authldap --without-authpgsql
108%configure
109make
110
111%install
112rm -rf %{buildroot}
113make install DESTDIR=%{buildroot}
114rm -f %{buildroot}/%{_libdir}/%{name}/*.a
115install -m 555 sysconftool %{buildroot}/%{_libexecdir}/%{name}
116install -m 555 authmigrate %{buildroot}/%{_libexecdir}/%{name}
117
118#./courierauthconfig --configfiles >configtmp
119#. configtmp
120
121./authmksock %{buildroot}/%{_localstatedir}/spool/authdaemon/socket || exit 1
122touch %{buildroot}/%{_localstatedir}/spool/authdaemon/pid.lock || exit 1
123touch %{buildroot}/%{_localstatedir}/spool/authdaemon/pid || exit 1
124chmod 777 %{buildroot}/%{_localstatedir}/spool/authdaemon/socket || exit 1
125
126mkdir -p %{buildroot}/%{_initdir}
127install -m 555 courier-authlib.sysvinit %{buildroot}/%{_initdir}/courier-authlib
128
129%post
130%{_libexecdir}/%{name}/authmigrate >/dev/null
131%{_libexecdir}/%{name}/sysconftool %{_sysconfdir}/authlib/*.dist >/dev/null
132
133/sbin/chkconfig --del courier-authlib
134/sbin/chkconfig --add courier-authlib
135
136%preun
137if test -x %{_sbindir}/authdaemond
138then
139        %{_sbindir}/authdaemond >/dev/null 2>&1 || /bin/true
140fi
141
142if test "$1" = "0"
143then
144        /sbin/chkconfig --del courier-authlib
145fi
146
147%clean
148rm -rf %{buildroot}
149
150%files
151%defattr(-,root,root)
152%doc README README*html README.authmysql.myownquery README.ldap
153%doc NEWS COPYING* AUTHORS ChangeLog authldap.schema
154/etc/rc.d/init.d/*
155%ghost %attr(600,root,root) %{_localstatedir}/spool/authdaemon/pid.lock
156%ghost %attr(644,root,root) %{_localstatedir}/spool/authdaemon/pid
157%ghost %attr(-,root,root) %{_localstatedir}/spool/authdaemon/socket
158%{_mandir}/man1/*
159%{_mandir}/man8/*
160%defattr(-,daemon,daemon)
161%dir %{_sysconfdir}/authlib
162%{_sysconfdir}/authlib/authdaemonrc.dist
163%{_libexecdir}/%{name}
164%dir %{_libdir}/%{name}
165%{_libdir}/%{name}/libauthcustom*
166%{_libdir}/%{name}/libauthpam*
167%{_libdir}/%{name}/libauthpipe*
168%{_libdir}/%{name}/libauthuser*
169%{_libdir}/%{name}/libcourierauth*
170%dir %attr(750,daemon,daemon) %{_localstatedir}/spool/authdaemon
171%{_sbindir}/*
172
173%files devel
174%defattr(-,root,root)
175%{_bindir}/courierauthconfig
176%{_includedir}/*
177%{_mandir}/man3/*
178%doc authlib.html auth_*.html
179
180%files ldap
181%defattr(-,root,root)
182%{_sysconfdir}/authlib/authldaprc.dist
183%{_libdir}/%{name}/libauthldap*
184
185%files pgsql
186%defattr(-,root,root)
187%{_sysconfdir}/authlib/authpgsqlrc.dist
188%{_libdir}/%{name}/libauthpgsql*
189
190%files mysql
191%defattr(-,root,root)
192%{_sysconfdir}/authlib/authmysqlrc.dist
193%{_libdir}/%{name}/libauthmysql*
194
195
196%changelog
197* Sat Jan  4 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 0.66.1-1
198- update to 0.66.1
199- drop APOP patch (Patch0)
200- add BuildRequires: libtool-ltdl-devel
201
202* Sun Apr 03 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.63.0-2
203- Rebuilt with new toolchain.
204
205* Sun Feb 07 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.63.0-1
206- new upstream release.
207- replaced "BuildPreReq:" with "BuilldRequires:".
208
209* Sun Nov 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.62.4-1
210- new upstream release.
211- removed "Requires: MySQL-shared".
212- updated APOP patch.
213
214* Thu May 21 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.59.3-2
215- rebuilt with MySQL-shared-5.1.34.
216
217* Sat Jul 05 2008 Shu KONNO <owa@bg.wakwak.com> 0.59.3-1vl5
218- applied new versioning policy, and spec in utf-8
219- rebuilt with postgresql-8.3.3
220
221* Sun Jan 27 2008 Shu KONNO <owa@bg.wakwak.com> 0.59.3-0vl3
222- rebuilt
223
224* Tue Jan 08 2008 Shu KONNO <owa@bg.wakwak.com> 0.59.3-0vl2
225- rebuilt with postgresql-8.2.6
226
227* Thu Sep 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.59.3-0vl1
228- new upstream release
229- rebuilt with postgresql 8.2.5
230
231* Sat Nov 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.56-0vl4
232- rebuilt with MySQL 5.0.27
233- included /usr/lib/courier-authlib/libauthpipe.*
234
235* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.56-0vl3
236- rebuilt with openldap-2.3.27-0vl1
237
238* Sun May 22 2005 UECHI Yasumasa <uechi@potaway.net> 0.56-0vl2
239- new upstream release
240
241* Mon Mar 28 2005 UECHI Yasumasa <uechi@potaway.net> 0.55-0vl4
242- add ldap, postgresql, mysql packages
243
244* Thu Mar 17 2005 UECHI Yasumasa <uechi@potaway.net> 0.55-0vl1
245- new upstream release
246
247* Thu Feb 17 2005 UECHI Yasumasa <uechi@potaway.net> 0.54-0vl1
248- new upstream release
249
250* Wed Jan 12 2005 UECHI Yasumasa <uechi@potaway.net> 0.53-0vl1
251- new upstream release
252
253* Wed Jan 12 2005 UECHI Yasumasa <uechi@potaway.net> 0.52-0vl1
254- simplify a spec for Vine
255- add apop patch
256
257* Sun Oct  3 2004 Mr. Sam <sam@email-scan.com> - 0.50-1
258- Initial build.
Note: See TracBrowser for help on using the repository browser.