source: projects/specs/trunk/c/compiz/compiz-vl.spec @ 8949

Revision 8949, 30.1 KB checked in by Takemikaduchi, 10 years ago (diff)

cmemo,compiz: rebuild
others: new upstream release

Line 
1# build with kde4
2%bcond_with kde
3
4%define         dialogversion   0.7.18
5%define         kde_dialogversion 0.0.5
6
7%define         core_plugins    blur clone commands cube dbus decoration fade ini inotify minimize move obs place png regex resize rotate scale screenshot switcher video water wobbly zoom fs
8
9%define         gnome_plugins   annotate gconf glib svg gnomecompat
10
11# List of plugins passed to ./configure.  The order is important
12
13%define         plugins         core,glib,gconf,dbus,png,svg,video,screenshot,decoration,clone,place,fade,minimize,move,resize,switcher,scale,wall
14
15Summary:        OpenGL window and compositing manager
16Summary(ja):    OpenGL ウィンドウ・コンポジットマネージャ
17Name:           compiz
18URL:            http://www.go-compiz.org
19License:        X11/MIT/GPL
20Group:          User Interface/Desktops
21Version:        0.8.8
22Release:        6%{?_dist_release}
23
24BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
25
26# libdrm is not available on these arches
27ExcludeArch:    s390 s390x ppc64
28
29Requires:       xorg-x11-server-Xorg
30Requires:       mesa-libGL
31
32Requires(post): desktop-file-utils
33
34BuildRequires:  mesa-libGLU-devel
35BuildRequires:  libdrm-devel
36BuildRequires:  libwnck-devel
37BuildRequires:  libX11-devel
38BuildRequires:  libXcomposite-devel
39BuildRequires:  libXdamage-devel
40BuildRequires:  libXext-devel
41BuildRequires:  libXfixes-devel
42BuildRequires:  libXmu-devel
43BuildRequires:  libXrandr-devel
44BuildRequires:  libXrender-devel
45BuildRequires:  libXt-devel
46BuildRequires:  libSM-devel
47
48BuildRequires:  GConf2-devel
49BuildRequires:  control-center-devel
50BuildRequires:  dbus-devel
51BuildRequires:  dbus-glib-devel
52BuildRequires:  fuse-devel
53BuildRequires:  gnome-desktop-devel >= 2.30.0
54BuildRequires:  libglade2-devel
55BuildRequires:  librsvg2-devel
56BuildRequires:  libxslt-devel
57BuildRequires:  metacity-devel
58
59BuildRequires:  desktop-file-utils
60BuildRequires:  intltool >= 0.35
61BuildRequires:  gettext
62
63%if %{with kde}
64BuildRequires:  kdebase-workspace-devel
65BUildRequires:  dbus-qt-devel
66%endif
67Conflicts:      control-center < 2.32.1-2
68
69# Make sure that former beryl users still have bling
70Obsoletes:      beryl-core
71
72Source0:        http://releases.compiz.org/%{version}/%{name}-%{version}.tar.bz2
73Source1:        desktop-effects-%{dialogversion}.tar.bz2
74Source2:        kde-desktop-effects-%{kde_dialogversion}.tar.bz2
75
76# Sources from fedora
77#Source11:      compiz-gtk
78#Source12:      compiz-gtk.desktop
79#Source13:      compiz-gnome.desktop
80#Source14:      compiz-gnome.session
81
82# Patches from fedora
83Patch102: desktop-effects-0.7.17-wall-plugin.patch
84Patch103: composite-cube-logo.patch
85Patch111: gconf-core-plugin-loopfix.patch
86
87# Make sure configuration plugins never get unloaded
88Patch123: compiz-0.7.8-pin-initial-plugins.patch
89
90# Patches from ubuntu
91Patch1140: 014-fix-gtk-window-decorator-no-argb-crash.patch
92Patch1150: 015_optional-fbo.patch
93Patch1160: 016_call_glxwaitx_before_drawing.patch
94Patch1170: 017_always_unredirect_screensaver_on_nvidia.patch
95Patch1200: 020_disable_gdk_gtk_disable_deprecated.patch
96Patch1490: 049-damage-report-non-empty.patch
97Patch1600: 060_move_checks_to_compiz.patch
98
99# Patches from upstream
100Patch2000: compiz-0.8.6-replace-gdk_draw_drawable-with-cairo-equiv.patch
101Patch2010: compiz-0.8.6-fix-pixmap-size-calculation.patch
102
103# Vine default options
104Patch3000: compiz-0.8.6-vine-default.patch
105
106Vendor: Project Vine
107Distribution: Vine Linux
108
109%description
110Compiz is one of the first OpenGL-accelerated compositing window
111managers for the X Window System. The integration allows it to perform
112compositing effects in window management, such as a minimization
113effect and a cube workspace.  Compiz is an OpenGL compositing manager
114that use Compiz use EXT_texture_from_pixmap OpenGL extension for
115binding redirected top-level windows to texture objects.
116
117%package devel
118Summary: Development packages for compiz
119Summary(ja): compiz の開発パッケージ
120Group: Development/Libraries
121Requires: compiz = %{version}-%{release}
122Requires: pkgconfig
123Requires: libXcomposite-devel libXfixes-devel libXdamage-devel libXrandr-devel
124Requires: libXinerama-devel libICE-devel libSM-devel libxml2-devel
125Requires: libxslt-devel startup-notification-devel
126
127%description devel
128The compiz-devel package includes the header files,
129and developer docs for the compiz package.
130
131Install compiz-devel if you want to develop plugins for the compiz
132windows and compositing manager.
133
134%package gnome
135Summary: Compiz gnome integration bits
136Summary(ja): Compiz gnome integration bits
137Group: User Interface/Desktops
138Requires: gnome-session
139Requires: metacity
140Requires: libwnck
141Requires: glx-utils
142Requires: %{name} = %{version}
143Requires(pre): GConf2
144Requires(post): GConf2
145Requires(preun): GConf2
146Obsoletes: compiz < 0.5.2-8
147Obsoletes: beryl-gnome
148
149%description gnome
150The compiz-gnome package contains gtk-window-decorator,
151and other gnome integration related stuff.
152
153%if %{with kde}
154%package kde
155Summary: Compiz kde integration bits
156Summary(ja): Compiz kde integration bits
157Group: User Interface/Desktops
158Requires: %{name} = %{version}
159Requires: compiz-manager
160Obsoletes: beryl-kde
161
162%description kde
163The compiz-kde package contains kde-window-decorator,
164and other kde integration related stuff.
165%endif
166
167%prep
168%setup -q -T -b1 -n desktop-effects-%{dialogversion}
169#%setup -q -T -b2 -n kde-desktop-effects-%{kde_dialogversion}
170%setup -q
171
172pushd ../desktop-effects-%{dialogversion}
173%patch102 -p1 -b .wall-plugin
174popd
175
176%patch103 -p1 -b .composite-cube-logo
177%patch111 -p1 -b .gconf-core-loop
178
179## %patch123 -p1 -b .initial-plugins
180
181# ubuntu patch
182%patch1140 -p1 -b .fix-gtk-window-decorator-no-argb-crash
183%patch1150 -p1 -b .disable-fbo
184%patch1160 -p1 -b .call_glxwaitx_before_drawing
185%patch1170 -p1 -b .always_unredirect_screensaver_on_nvidia
186%patch1200 -p1 -b .disable_gdk_gtk_disable_deprecated
187%patch1490 -p1 -b .damage-report-non-empty
188%patch1600 -p1 -b .move-check-to-compiz
189
190# upstream patch
191#%patch2000 -p1 -b .replace-gdk_draw_drawable-with-cairo-equiv
192#%patch2010 -p1 -b .fix-pixmap-size-calculation
193
194# vine patch
195%patch3000 -p1 -b .vine-default
196
197%build
198rm -rf $RPM_BUILD_ROOT
199
200CPPFLAGS="$CPPFLAGS -I$RPM_BUILD_ROOT%{_includedir}"
201export CPPFLAGS
202
203#needed to find kde4 libs
204#LDFLAGS="$LDFLAGS -L%{_libdir}/kde4/devel"
205#export LDFLAGS
206
207#libtoolize
208autoreconf -if
209%configure                                      \
210%{?with_kde: --enable-kde4 }                    \
211%{!?with_kde: --disable-kde4 }                  \
212        --disable-kde                           \
213        --enable-gconf                          \
214        --enable-dbus                           \
215        --enable-place                          \
216        --enable-librsvg                        \
217        --enable-gtk                            \
218        --enable-metacity                       \
219        --enable-gnome                          \
220        --with-default-plugins=%{plugins}       \
221        --enable-gnome-keybindings           
222
223
224make LIBTOOL=/usr/bin/libtool %{?_smp_mflags} imagedir=%{_datadir}/pixmaps
225
226# desktop-effects
227cd ../desktop-effects-%{dialogversion}
228%configure
229
230
231%install
232rm -rf $RPM_BUILD_ROOT
233export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
234make LIBTOOL=/usr/bin/libtool DESTDIR=$RPM_BUILD_ROOT install || exit 1
235unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
236
237echo INSTALLING DESKTOP EFFECTS
238pushd ../desktop-effects-%{dialogversion}
239make LIBTOOL=/usr/bin/libtool LIBS=-lX11 DESTDIR=$RPM_BUILD_ROOT install || exit 1
240#desktop-file-install --vendor vine --delete-original      \
241#  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
242#  $RPM_BUILD_ROOT%{_datadir}/applications/desktop-effects.desktop
243rm -f $RPM_BUILD_ROOT%{_datadir}/applications/desktop-effects.desktop
244popd
245
246%if %{with kde}
247# kde-desktop-effects
248echo INSTALLING KDE DESKTOP EFFECTS
249pushd ../kde-desktop-effects-%{kde_dialogversion}
250cp -a kde-desktop-effects.sh $RPM_BUILD_ROOT/%{_bindir}/
251mkdir -p $RPM_BUILD_ROOT/%{_docdir}/compiz-kde-%{version}
252cp -a ChangeLog COPYING README $RPM_BUILD_ROOT/%{_docdir}/compiz-kde-%{version}
253
254iconlist="16 24 32 36 48 96"
255for i in $iconlist; do
256 mkdir -p $RPM_BUILD_ROOT/%{_datadir}/icons/hicolor/$i\x$i/apps/
257 cp -p ../desktop-effects-%{dialogversion}/desktop-effects$i.png $RPM_BUILD_ROOT/%{_datadir}/icons/hicolor/$i\x$i/apps/kde-desktop-effects.png
258done
259
260desktop-file-install --vendor=""           \
261  --dir=%{buildroot}%{_datadir}/applications/kde       \
262  kde-desktop-effects.desktop
263popd
264%endif
265
266%if !%{with kde}
267rm -f $RPM_BUILD_ROOT%{_datadir}/compiz/kconfig.xml
268%endif
269
270
271#install -m 0755 %{SOURCE11} $RPM_BUILD_ROOT%{_bindir}
272#desktop-file-install --vendor="" \
273#  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
274#  %{SOURCE12}
275# set up an X session
276#mkdir -p $RPM_BUILD_ROOT%{_datadir}/xsessions
277#install %{SOURCE13} $RPM_BUILD_ROOT%{_datadir}/xsessions
278#mkdir -p $RPM_BUILD_ROOT%{_datadir}/gnome-session/sessions
279#install %{SOURCE14} $RPM_BUILD_ROOT%{_datadir}/gnome-session/sessions
280
281
282find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
283find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} ';'
284
285
286%find_lang compiz
287%find_lang desktop-effects
288
289cat compiz.lang > core-files.txt
290cat desktop-effects.lang > gnome-files.txt
291
292for f in %{core_plugins}; do
293  echo %{_libdir}/compiz/lib$f.so
294  echo %{_datadir}/compiz/$f.xml
295done >> core-files.txt
296
297for f in %{gnome_plugins}; do
298  echo %{_libdir}/compiz/lib$f.so
299  echo %{_datadir}/compiz/$f.xml
300done >> gnome-files.txt
301
302
303%post -p /sbin/ldconfig
304
305%postun -p /sbin/ldconfig
306
307%post gnome
308update-desktop-database -q %{_datadir}/applications
309
310export GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source`
311for f in %{core_plugins} %{gnome_plugins} core; do
312  echo %{_sysconfdir}/gconf/schemas/compiz-${f}.schemas; done \
313  | xargs gconftool-2 --makefile-install-rule >& /dev/null || :
314
315gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/gwd.schemas >& /dev/null || :
316
317touch --no-create %{_datadir}/icons/hicolor
318if [ -x /usr/bin/gtk-update-icon-cache ]; then
319        /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
320fi
321
322
323%pre gnome
324if [ "$1" -gt 1 ]; then
325  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
326  for f in %{core_plugins} %{gnome_plugins} core; do
327    echo %{_sysconfdir}/gconf/schemas/compiz-${f}.schemas; done \
328    | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null || :
329
330  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gwd.schemas >& /dev/null || :
331fi
332
333
334%preun gnome
335if [ "$1" -eq 0 ]; then
336  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
337  for f in %{core_plugins} %{gnome_plugins} core; do
338    echo %{_sysconfdir}/gconf/schemas/compiz-${f}.schemas; done \
339    | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null || :
340
341  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gwd.schemas >& /dev/null || :
342fi
343
344
345%postun gnome
346touch --no-create %{_datadir}/icons/hicolor
347if [ -x /usr/bin/gtk-update-icon-cache ]; then
348        /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
349fi
350
351%if %{with kde}
352%post kde
353update-desktop-database -q %{_datadir}/applications/kde
354touch --no-create %{_datadir}/icons/hicolor
355
356%postun kde
357touch --no-create %{_datadir}/icons/hicolor
358%endif
359
360%clean
361rm -rf $RPM_BUILD_ROOT
362
363
364%files -f core-files.txt
365%defattr(-, root, root)
366%doc AUTHORS ChangeLog COPYING* README TODO
367%{_bindir}/compiz
368%{_libdir}/libdecoration.so.*
369%dir %{_libdir}/compiz
370%dir %{_datadir}/compiz
371%{_datadir}/compiz/*.png
372%{_datadir}/compiz/core.xml
373
374
375%files gnome -f gnome-files.txt
376%defattr(-, root, root)
377#%{_bindir}/compiz-gtk
378%{_bindir}/gtk-window-decorator
379%{_bindir}/desktop-effects
380#%{_datadir}/applications/compiz-gtk.desktop
381%{_datadir}/compiz/desktop-effects.glade
382%{_datadir}/icons/hicolor/16x16/apps/desktop-effects.png
383%{_datadir}/icons/hicolor/24x24/apps/desktop-effects.png
384%{_datadir}/icons/hicolor/32x32/apps/desktop-effects.png
385%{_datadir}/icons/hicolor/36x36/apps/desktop-effects.png
386%{_datadir}/icons/hicolor/48x48/apps/desktop-effects.png
387%{_datadir}/icons/hicolor/96x96/apps/desktop-effects.png
388#%{_datadir}/xsessions/compiz-gnome.desktop
389#%{_datadir}/gnome-session/sessions/compiz-gnome.session
390%{_sysconfdir}/gconf/schemas/*.schemas
391
392%if %{with kde}
393%files kde
394%defattr(-, root, root)
395%{_bindir}/kde4-window-decorator
396%{_docdir}/compiz-kde-%{version}
397%{_bindir}/kde-desktop-effects.sh
398%{_datadir}/applications/kde/kde-desktop-effects.desktop
399%{_datadir}/icons/hicolor/*/apps/kde-desktop-effects.png
400%{_datadir}/compiz/kconfig.xml
401%endif
402
403%files devel
404%defattr(-, root, root)
405%{_libdir}/pkgconfig/compiz.pc
406%{_libdir}/pkgconfig/libdecoration.pc
407%{_libdir}/pkgconfig/compiz-cube.pc
408%{_libdir}/pkgconfig/compiz-gconf.pc
409%{_libdir}/pkgconfig/compiz-scale.pc
410%{_datadir}/compiz/schemas.xslt
411%{_includedir}/compiz
412%{_libdir}/libdecoration.so
413
414
415%changelog
416* Sun Sep 14 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.8-6
417- rebuild with VineSeed environment
418
419* Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.8-5
420- rebuild with VineSeed environment
421
422* Sun Sep 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.8-4
423- remove follow files
424    Source11 (compiz-gtk)
425    Source12 (compiz-gtk.desktop)
426    Source13 (compiz-gnome.desktop)
427    Source14 (compiz-gnome.session)
428
429* Mon Mar 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.8-3
430- remove SandyBridge chipset from blacklist
431- add BR: dbus-glib-devel
432
433* Sun Aug 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.8-2
434- add Source files from Fedora
435    Source11 (compiz-gtk)
436    Source12 (compiz-gtk.desktop)
437    Source13 (compiz-gnome.desktop)
438    Source14 (compiz-gnome.session)
439
440* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.8-1
441- new upstream release
442- add BuildRequires: libxslt-devel, libglade2-devel
443- drop Patch2000,2010
444
445* Sat Apr 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.6-5
446- add Patch3000
447  - disable Sync to vblank
448  - increase drop-shadow radius
449  - set default decorator to gtk-window-decorator
450  - change default daces in cube plugin
451  - use "smart" placement mode
452
453* Sun Mar 13 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.6-4
454- drop compiz-gtk
455  - add Conflicts: control-center < 2.32.1-2
456
457* Sat Mar 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.6-3
458- rebuild with mesa-7.10.1
459- add cherry picked ubuntu patch
460  - Patch1150: add --no-fbo option
461  - Patch1200: disable GDK|GTK_DISABLE_DEPRECATED
462  - Patch1160: call glxwaitx before drawing
463  - Patch1170: always unredirect screensaver on nvidia
464  - Patch1490: damage report non empty
465  - Patch1600: move check to compiz
466- add upstream patch
467  - Patch2000: replace gdk_draw_drawable with cairo equivalents
468  - Patch2010: fix pixmap size calculation
469
470* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.6-2
471- rebuild with rpm-4.8.1 for pkg-config file
472
473* Sat Apr 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.6-1
474- new upstream release (build on GNOME-2.30)
475- drop Patch123, Patch300
476
477* Sat Nov 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-4
478- rebuild with mesa-7.6
479- add Patch300 to build with gconf-2.28
480
481* Thu Jun 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-3
482- disable glib plugin in compiz-gtk
483- use direct rendering on virtualbox video adaptor.
484
485* Tue May 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-2
486- add Requires: glx-utils to compiz-gnome
487
488* Mon May 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-1
489- new upstream release
490
491* Sun May 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-8
492- re-enable metacity decoration on gtk-window-decorator
493  - BR: metacity-devel instead of metacity
494
495* Fri May 01 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.7.8-7
496- fix pre/post scripts for speeding up gconf schema installation
497
498* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-6
499- add ccp compiz option to compiz-gtk
500
501* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-5
502- remove desktop-effect.desktop
503  - we use gnome-appearance-properties integrated version.
504
505* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-4
506- add Patch121,122 from upstream fix.
507- add Patch123: make sure configuration plugins never get unloaded
508- add Patch124: memleak fix from upstream
509- add Patch125: make the terminal keybind work
510- add Patch120,126,127 for kde42
511- add Patch128: gwd fix from upstream
512
513* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-3
514- rebuild with gnome-desktop-2.26.0
515
516* Wed Oct 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-2
517- add compiz-gtk scripts and desktop file from fedora
518
519* Thu Oct 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-1
520- new upstream release
521
522* Wed Jun 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.6-2
523- rebuild with gnome-desktop-2.24.0
524
525* Wed Jun 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.6-1
526- new upstream release
527
528* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.4-1
529- new upstream release
530
531* Sat May 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.2-1
532- initial build for Vine Linux
533
534* Thu Mar 27 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.7.2-3
535- Fix gconf plugin loop RH #438794, patch based on
536  older one from Guillaume Seguin
537- Add core to default plugin list
538
539* Wed Mar 26 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.7.2-2
540- Reword kde-desktop-effects messages to mention Compiz by name (#438883)
541
542* Mon Mar 24 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.7.2-1
543- Update to 0.7.2
544
545* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.6.2-7
546- Autorebuild for GCC 4.3
547
548* Thu Jan 17 2008 Kristian H淡gsberg <krh@redhat.com> - 0.6.2-6
549- Update to desktop-effects version 0.7.17 which include more
550  translations and move desktop-effects translations to compiz-gnome.
551- Fix spelling in beryl-core obsoletes.
552
553* Mon Jan 07 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.6.2-5
554- Update buildrequires (kwd uses the kde3 api)
555
556* Tue Nov  6 2007 Stepan Kasal <skasal@redhat.com> - 0.6.2-4
557- Fix a typo in description of the main package.
558- All descriptions should end with a dot (unlike the summary line)
559
560* Thu Oct 25 2007 Sebastian Vahl <fedora@deadbabylon.de> - 0.6.2-3
561- Include kde-desktop-effects in kde subpackage
562
563* Tue Oct 23 2007 Adel Gadllah <adel.gadllah@gmail.com> - 0.6.2-2
564- Obsolete berly-core
565
566* Mon Oct 22 2007 Warren Togami <wtogami@redhat.com> - 0.6.2-1
567- 0.6.2
568
569* Fri Oct 12 2007 Kristian H淡gsberg <krh@redhat.com> - 0.6.0-2
570- Disable scale corner initiate and install a GNOME key config entry.
571
572* Wed Oct 10 2007 Warren Togami <wtogami@redhat.com> - 0.6.0-1
573- 0.6.0 final
574- always-restack-windows-on-map
575
576* Tue Oct  9 2007 Warren Togami <wtogami@redhat.com> - 0.5.2-14
577- Make compiz behave with gnome-terminal (#304051)
578
579* Fri Oct  5 2007 Matthias Clasen <mclasen@redhat.com> - 0.5.2-13
580- Also install gwd.schemas (#319621)
581
582* Thu Sep 20 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-12
583- Update to more recent 0.6 branch snapshot (fixes #253575).
584
585* Fri Sep 14 2007 Warren Togami <wtogami@redhat.com> - 0.5.2-11
586- compiz-gnome: install core schema so it actually works
587- remove unnecessary gconf stuff from %%install
588
589* Tue Aug 28 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-9
590- Make compiz-gnome Obsolete the older compiz package so yum/anaconda
591  will pull it in (thans to Adel Gadllah).
592
593* Wed Aug 22 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-8
594- Bump to desktop-effects 0.7.7 to avoid kill decorator when popping
595  up dialog.
596- Fix broken gconf install and uninstall rules.
597- Pick up shadowman logo for RHEL builds (#232398).
598
599* Tue Aug 21 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-7.0ec3ec
600- Add more-sm-junk.patch so we set SM restart style to
601  SmRestartIfRunning on exit (#247163, #245971).
602- Add Requires to compiz-devel (#253407).
603- Update to desktop-effects 0.7.6, which terminates decorator when
604  switching to metacity or on compiz failure (#215247, #215032).
605
606* Fri Aug 17 2007 Adel Gadllah <adel.gadllah@gmail.com> 0.5.2-6.0ec3ec
607- Split into gnome and kde subpackages
608- Minor cleanups
609
610* Wed Aug 15 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-5.0ec3ec
611- Reorder plugin list to avoid 'place' getting removed on startup.
612- Add run-command-key.patch to put the run command key in the GNOME
613  keyboard shortcut dialog (#213576).
614- Drop a bunch of obsolete patches.
615- Bump mesa-libGL and X server requires to fix TFP bugs for
616  power-of-two textures (#251935).
617- Rebase fedora-logo and composite-cube-logo patch.
618
619* Tue Aug 14 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-4.0ec3ec
620- Build with desktop-effects so we don't pick up metacity work spaces.
621  Fixes #250568.
622
623* Tue Aug 14 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-3.0ec3ec
624- Build git snapshot from fedora branch at
625  git://people.freedesktop.org/~krh/compiz, brances from 0.6 upstream
626  branch.
627- Fixes #237486.
628
629* Fri Aug 10 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-3
630- Require desktop-effects 0.7.3 and gnome-session 2.19.6-5 which pass
631  'glib' on the command line too.
632
633* Fri Aug 10 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-2
634- Move xml meta data files to main package.
635
636* Thu Aug  9 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-1
637- Update to 0.5.2.
638- Require at least gnome-session 2.19.6-2 so gnome-wm starts compiz
639  with LIBGL_ALWAYS_INDIRECT set.
640
641* Wed Jun 27 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.0-1
642- Update to 0.5.0
643
644* Tue Jun  5 2007 Matthias Clasen <mclasen@redhat.com> - 0.4.0-1
645- Update to 0.4.0
646
647* Mon Jun  4 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.6-10
648- Rebuild against new libwnck
649
650* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.6-9
651- Don't install INSTALL
652
653* Mon Apr 16 2007 Kristian H淡gsberg <krh@hinata.boston.redhat.com> - 0.3.6-8
654- Update metacity build requires to metacity-devel.
655
656* Wed Apr  4 2007 Kristian H淡gsberg <krh@hinata.boston.redhat.com> - 0.3.6-7
657- Fix typo in ./configure option.
658
659* Wed Apr  4 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-6
660- Add place and clone plugins to default plugin list.
661
662* Wed Mar 28 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-5
663- Update URL (#208214).
664- Require at least metacity 2.18 (#232831).
665- Add close-session.patch to deregister from SM when replaced (#229113).
666
667* Tue Mar 27 2007 Kristian H淡gsberg <krh@redhat.com> 0.3.6-4
668- Explicitly disable KDE parts (#234128).
669
670* Mon Mar 26 2007 Matthias Clasen <mclasen@redhat.com> 0.3.6-3
671- Fix some directory ownership issues (#233825)
672- Small spec cleanups
673
674* Tue Feb  6 2007 Kristian H淡gsberg <krh@redhat.com> 0.3.6
675- Require gnome-session > 2.16 so it starts gtk-window-decorator.
676- Update to desktop-effects 0.7.1 that doesn't refuse to work with Xinerama.
677
678* Tue Jan 16 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-1
679- Update to 0.3.6, update patches.
680- Drop autotool build requires.
681- Drop glfinish.patch, cow.patch, resize-offset.patch and icon-menu-patch.
682- Add libdecoration.so
683- Update to desktop-effects-0.7.0, which spawns the right decorator
684  and plays nicely with unknown plugins.
685
686* Sat Nov 25 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.4-2
687- Update the fedora logo patch (#217224)
688
689* Thu Nov 23 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.4-1
690- Update to 0.3.4
691
692* Wed Nov 15 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.2-2
693- Use cow by default, bug 208044
694
695* Fri Nov 10 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
696- Update to 0.3.2
697- Drop upstreamed patches
698- Work with new metacity theme api
699
700* Mon Oct 2 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.32.20060818git.fc6
701- Install the .desktop file with desktop-file-install. Add X-Red-Hat-Base to make it appear in "Preferences", rather than "More Preferences".
702
703* Sat Sep 30 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.31.20060818git.fc6
704- Add buildrequires on intltool
705
706* Sat Sep 30 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.31.20060818git.fc6
707- Build
708
709* Fri Sep 29 2006 Soren Sandmann <sandmann@redhat.com>
710- Update to desktop-effects-0.6.163, which has translation enabled. (Bug 208257)
711
712* Thu Sep 28 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.30.20060817git.fc6
713- Add patch to terminate keyboard moves when a mouse buttons is pressed. (Bug 207792).
714
715* Thu Sep 28 2006 Soren Sandmann <sandmann@redhat.com>
716- Change default plugin list to not include the plane plugin. (Bug 208448).
717- Change default keybinding for shrink to be Pause (Bug 206187).
718
719* Wed Sep 27 2006 Soren Sandmann <sandmann@redhat.com>
720- Add patch to show a menu when the window icon is clicked. (Bug 201629).
721
722* Tue Sep 26 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.29.20060817git.fc6
723- Add restart.patch to make compiz ask the session manager to restart it
724  if it crashes (bug 200280).
725
726* Mon Sep 25 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.28.20060817git.fc6
727- Change plane.patch to not do cyclical window movement in dimensions
728  where the desktop has size 1 (bug 207263).
729
730* Thu Sep 21 2006 Soren Sandmann <sandmann@redhat.com>
731- Add patch to fix resizing smaller than minimum size (resize-offset.patch, bug 201623).
732
733* Tue Sep 19 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.27.20060817git.fc6
734- Change .plane patch to
735  (a) not set the background color to pink in the plane plugin.
736  (b) allow workspaces with horizontal sizes less then 4.
737
738* Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.26.20060817git.fc6
739- Change plane patch to correctly initialize the screen size to the
740  defaults (bug 206088).
741
742* Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com>
743- Run update-desktop-database and gtk-update-icon-cache in post. Add icons
744  to list of packaged files. Also bump to 0.6.137 of dialog (which just makes
745  directories before attempting to install to them).
746
747* Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com>
748- Upgrade to 0.6.107 of the desktop-effects dialog box. Only change is
749  that the new version has icons.
750
751* Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
752- Add patch to fix mispositioning of window decorator event windows (bug 201624)
753
754* Fri Sep 15 2006 Soren Sandmann <sandamnn@redhat.com>
755- Upgrade to version 0.6.83 of desktop-effects. (bug 206500)
756
757* Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
758- Add patch to only accept button 1 for close/minimize/maximize (bug 201628)
759
760* Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
761- Add patch to fix thumbnail sorting (bug 201605)
762
763* Thu Sep 14 2006 Soren Sandmann <sandmann@redhat.com>
764- Add patch to fix double clicking (bug 201783).
765
766* Tue Sep 12 2006 Soren Sandmann <sandmann@redhat.com>
767- Don't attempt to move the viewport when dx = dy = 0.(last bit of 206088).
768
769* Tue Sep 12 2006 Soren Sandmann <sandamnn@redhat.com>
770- Fix plane.patch to draw correctly when no timeout is running. (206088).
771
772* Wed Sep  6 2006 Kristian H淡gsberg <krh@redhat.com>
773- Update fbconfig-depth-fix.patch to also skip fbconfigs without
774  corresponding visuals.
775
776* Tue Sep 5 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.25.20060817git.fc6
777- Make number of vertical size configurable
778
779* Tue Sep 5 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.24.20060817git.fc6
780- Fix vertical viewport support in the plane patch.
781
782* Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.23.20060817git.fc6
783- Upgrade to 0.6.61 of the dialog
784
785* Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
786- Add libtool to BuildRequires
787
788* Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
789- Add automake and autoconf to BuildRequires
790
791* Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
792- Add a patch to put viewports on a plane.
793
794* Wed Aug 30 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.21.20060817git.fc6
795- Drop gl-include-inferiors.patch now that compiz uses COW and the X
796  server evicts offscreen pixmaps automatically on
797  GLX_EXT_texture_from_pixmap usage.
798
799* Tue Aug 29 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.20.20060817git.fc6
800- Add cow.patch to make compiz use the composite overlay window.
801
802* Fri Aug 25 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.19-20060817git.fc6
803- Rebase to desktop-effects 0.6.41
804
805* Fri Aug 25 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.18.20060817git.fc6
806- Rebase to desktop-effects 0.6.19 and drop
807  desktop-effects-0.6.1-delete-session.patch
808
809* Tue Aug 22 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.17.20060817git.fc6
810- Add patch from upstream to also use sync protocol for override
811  redirect windows (sync-override-redirect-windows.patch).
812
813* Thu Aug 17 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.16.20060817git.fc6
814- Rebase to latest upstream changes which has the rest of the bindings
815  rewrite.  Add resize-move-keybindings.patch to make move and resize
816  bindings work like metacity.
817- Add back scale plugin.
818
819* Thu Aug 10 2006 Ray Strode <rstrode@redhat.com> 0.0.13-0.15.20060721git.fc5.aiglx
820- Add Requires: gnome-session 2.15.90-2.fc6 (bug 201473)
821- unlink session file on changing wms (bug 201473)
822
823* Thu Aug  3 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.14.20060721git.fc5.aiglx
824- Add Requires: gnome-session 2.15.4-3
825
826* Thu Aug  3 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.13.20060721git.fc5.aiglx
827- New version of dialog box. Macro the version number.
828
829* Wed Aug  2 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.13.20060721git.fc5.aiglx
830- Add 'desktop effects' dialog box.
831
832* Mon Jul 31 2006 Kristian H淡gsberg <krh@redhat.com> 0.0.13-0.12.20060721git.fc5.aiglx
833- Add libwnck requires.
834
835* Wed Jul 26 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.11.20060721git.fc5.aiglx
836- Bump and build for fc5 AIGLX repo.
837
838* Wed Jul 26 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.12.20060721git
839- Fix gconf hooks.
840
841* Tue Jul 25 2006 Kristian H淡gsberg <krh@redhat.com>
842- Require system-logos instead.
843
844* Mon Jul 24 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.10.20060721git
845- Bump version to work around tagging weirdness.
846
847* Mon Jul 24 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.9.20060721git
848- Add devel package and require redhat-logos instead of fedora-logos (#199757).
849
850* Fri Jul 21 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.8.20060720git
851- Add workaround for AIGLX throttling problem.
852
853* Thu Jul 20 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.7.20060720git
854- Drop scale plugin from snapshot.
855
856* Tue Jul 18 2006 Matthias Clasen <mclasen@redhat.com> - 0.0.13-0.6.20060717git
857- Don't build on s390
858
859* Mon Jul 17 2006 Matthias Clasen <mclasen@redhat.com> - 0.0.13-0.5.20060717git
860- Do some changes forced upon us by package review
861
862* Thu Jul 13 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-5.1
863- Use sane numbering scheme.
864
865* Fri Jul  7 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-4
866- Drop the fullscreen hardcode patch and require X server that has
867  GLX_MESA_copy_sub_buffer.
868
869* Tue Jun 27 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-3
870- Unbreak --replace.
871
872* Thu Jun 15 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-2
873- Add Requires, fix start-compiz.sh.
874
875* Wed Jun 14 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-1
876- Spec file for compiz, borrowing bits and pieces from Alphonse Van
877  Assches spec file (#192432).
Note: See TracBrowser for help on using the repository browser.