source: projects/specs/trunk/c/compiz/compiz-vl.spec @ 9586

Revision 9586, 29.2 KB checked in by Takemikaduchi, 9 years ago (diff)

compiz: change BR & R: marco
task-compiz: add compiz-mate
yelp: add R

Line 
1# build with kde4
2%bcond_with kde
3
4%define         dialogversion   0.7.18
5%define         kde_dialogversion 0.0.5
6
7%define         core_plugins    blur clone commands cube dbus decoration fade ini inotify minimize move obs place png regex resize rotate scale screenshot switcher video water wobbly zoom fs
8
9%define         mate_plugins    annotate glib svg gnomecompat
10
11# List of plugins passed to ./configure.  The order is important
12
13%define         plugins         core,glib,dbus,png,svg,video,screenshot,decoration,clone,place,fade,minimize,move,resize,switcher,scale,wall
14
15Summary:        OpenGL window and compositing manager
16Summary(ja):    OpenGL ウィンドウ・コンポジットマネージャ
17Name:           compiz
18URL:            http://www.go-compiz.org
19License:        X11/MIT/GPL
20Group:          User Interface/Desktops
21Version:        0.8.8
22Release:        7%{?_dist_release}
23
24BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
25
26# libdrm is not available on these arches
27ExcludeArch:    s390 s390x ppc64
28
29Requires:       xorg-x11-server-Xorg
30Requires:       mesa-libGL
31
32Requires(post): desktop-file-utils
33
34BuildRequires:  mesa-libGLU-devel
35BuildRequires:  libdrm-devel
36BuildRequires:  libwnck-devel
37BuildRequires:  libX11-devel
38BuildRequires:  libXcomposite-devel
39BuildRequires:  libXdamage-devel
40BuildRequires:  libXext-devel
41BuildRequires:  libXfixes-devel
42BuildRequires:  libXmu-devel
43BuildRequires:  libXrandr-devel
44BuildRequires:  libXrender-devel
45BuildRequires:  libXt-devel
46BuildRequires:  libSM-devel
47
48BuildRequires:  dbus-devel
49BuildRequires:  dbus-glib-devel
50BuildRequires:  fuse-devel
51BuildRequires:  gnome-desktop-devel >= 2.30.0
52BuildRequires:  libglade2-devel
53BuildRequires:  librsvg2-devel
54BuildRequires:  libxslt-devel
55BuildRequires:  marco-devel
56BuildRequires:  mate-control-center-devel
57
58BuildRequires:  desktop-file-utils
59BuildRequires:  intltool >= 0.35
60BuildRequires:  gettext
61
62%if %{with kde}
63BuildRequires:  kdebase-workspace-devel
64BUildRequires:  dbus-qt-devel
65%endif
66Conflicts:      control-center < 2.32.1-2
67
68# Make sure that former beryl users still have bling
69Obsoletes:      beryl-core
70
71Obsoletes:  %{name}-gnome < 0.8.8-7
72
73Source0:        http://releases.compiz.org/%{version}/%{name}-%{version}.tar.bz2
74Source1:        desktop-effects-%{dialogversion}.tar.bz2
75Source2:        kde-desktop-effects-%{kde_dialogversion}.tar.bz2
76
77# Sources from fedora
78#Source11:      compiz-gtk
79#Source12:      compiz-gtk.desktop
80#Source13:      compiz-gnome.desktop
81#Source14:      compiz-gnome.session
82
83# Patches from fedora
84Patch102: desktop-effects-0.7.17-wall-plugin.patch
85Patch103: composite-cube-logo.patch
86Patch111: gconf-core-plugin-loopfix.patch
87
88# Make sure configuration plugins never get unloaded
89Patch123: compiz-0.7.8-pin-initial-plugins.patch
90
91# Patches from ubuntu
92Patch1140: 014-fix-gtk-window-decorator-no-argb-crash.patch
93Patch1150: 015_optional-fbo.patch
94Patch1160: 016_call_glxwaitx_before_drawing.patch
95Patch1170: 017_always_unredirect_screensaver_on_nvidia.patch
96Patch1200: 020_disable_gdk_gtk_disable_deprecated.patch
97Patch1490: 049-damage-report-non-empty.patch
98Patch1600: 060_move_checks_to_compiz.patch
99
100# Patches from upstream
101Patch2000: compiz-0.8.6-replace-gdk_draw_drawable-with-cairo-equiv.patch
102Patch2010: compiz-0.8.6-fix-pixmap-size-calculation.patch
103
104# Vine default options
105Patch3000: compiz-0.8.6-vine-default.patch
106Patch3001: compiz-mate.patch
107
108Vendor: Project Vine
109Distribution: Vine Linux
110
111%description
112Compiz is one of the first OpenGL-accelerated compositing window
113managers for the X Window System. The integration allows it to perform
114compositing effects in window management, such as a minimization
115effect and a cube workspace.  Compiz is an OpenGL compositing manager
116that use Compiz use EXT_texture_from_pixmap OpenGL extension for
117binding redirected top-level windows to texture objects.
118
119%package devel
120Summary: Development packages for compiz
121Summary(ja): compiz の開発パッケージ
122Group: Development/Libraries
123Requires: compiz = %{version}-%{release}
124Requires: pkgconfig
125Requires: libXcomposite-devel libXfixes-devel libXdamage-devel libXrandr-devel
126Requires: libXinerama-devel libICE-devel libSM-devel libxml2-devel
127Requires: libxslt-devel startup-notification-devel
128
129%description devel
130The compiz-devel package includes the header files,
131and developer docs for the compiz package.
132
133Install compiz-devel if you want to develop plugins for the compiz
134windows and compositing manager.
135
136%package mate
137Summary: Compiz mate integration bits
138Summary(ja): Compiz mate integration bits
139Group: User Interface/Desktops
140Requires: mate-session-manager
141Requires: marco
142Requires: libwnck
143Requires: glx-utils
144Requires: %{name} = %{version}
145
146%description mate
147The compiz-mate package contains gtk-window-decorator,
148and other mate integration related stuff.
149
150%if %{with kde}
151%package kde
152Summary: Compiz kde integration bits
153Summary(ja): Compiz kde integration bits
154Group: User Interface/Desktops
155Requires: %{name} = %{version}
156Requires: compiz-manager
157Obsoletes: beryl-kde
158
159%description kde
160The compiz-kde package contains kde-window-decorator,
161and other kde integration related stuff.
162%endif
163
164%prep
165%setup -q -T -b1 -n desktop-effects-%{dialogversion}
166#%setup -q -T -b2 -n kde-desktop-effects-%{kde_dialogversion}
167%setup -q
168
169pushd ../desktop-effects-%{dialogversion}
170%patch102 -p1 -b .wall-plugin
171popd
172
173%patch103 -p1 -b .composite-cube-logo
174%patch111 -p1 -b .gconf-core-loop
175
176## %patch123 -p1 -b .initial-plugins
177
178# ubuntu patch
179%patch1140 -p1 -b .fix-gtk-window-decorator-no-argb-crash
180%patch1150 -p1 -b .disable-fbo
181%patch1160 -p1 -b .call_glxwaitx_before_drawing
182%patch1170 -p1 -b .always_unredirect_screensaver_on_nvidia
183%patch1200 -p1 -b .disable_gdk_gtk_disable_deprecated
184%patch1490 -p1 -b .damage-report-non-empty
185%patch1600 -p1 -b .move-check-to-compiz
186
187# upstream patch
188#%patch2000 -p1 -b .replace-gdk_draw_drawable-with-cairo-equiv
189#%patch2010 -p1 -b .fix-pixmap-size-calculation
190
191# vine patch
192%patch3000 -p1 -b .vine-default
193%patch3001 -p1 -b .mate
194
195%build
196rm -rf $RPM_BUILD_ROOT
197
198CPPFLAGS="$CPPFLAGS -I$RPM_BUILD_ROOT%{_includedir}"
199export CPPFLAGS
200
201#needed to find kde4 libs
202#LDFLAGS="$LDFLAGS -L%{_libdir}/kde4/devel"
203#export LDFLAGS
204
205#libtoolize
206autoreconf -if
207%configure                                      \
208%{?with_kde: --enable-kde4 }                    \
209%{!?with_kde: --disable-kde4 }                  \
210        --disable-kde                           \
211        --disable-gconf                         \
212        --enable-dbus                           \
213        --enable-librsvg                        \
214        --enable-gtk                            \
215        --enable-marco                          \
216        --enable-mate                           \
217        --with-default-plugins=%{plugins}       \
218        --enable-gnome-keybindings           
219
220
221make LIBTOOL=/usr/bin/libtool %{?_smp_mflags} imagedir=%{_datadir}/pixmaps
222
223# desktop-effects
224cd ../desktop-effects-%{dialogversion}
225%configure
226
227
228%install
229rm -rf $RPM_BUILD_ROOT
230make LIBTOOL=/usr/bin/libtool DESTDIR=$RPM_BUILD_ROOT install || exit 1
231
232echo INSTALLING DESKTOP EFFECTS
233pushd ../desktop-effects-%{dialogversion}
234make LIBTOOL=/usr/bin/libtool LIBS=-lX11 DESTDIR=$RPM_BUILD_ROOT install || exit 1
235#desktop-file-install --vendor vine --delete-original      \
236#  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
237#  $RPM_BUILD_ROOT%{_datadir}/applications/desktop-effects.desktop
238rm -f $RPM_BUILD_ROOT%{_datadir}/applications/desktop-effects.desktop
239popd
240
241%if %{with kde}
242# kde-desktop-effects
243echo INSTALLING KDE DESKTOP EFFECTS
244pushd ../kde-desktop-effects-%{kde_dialogversion}
245cp -a kde-desktop-effects.sh $RPM_BUILD_ROOT/%{_bindir}/
246mkdir -p $RPM_BUILD_ROOT/%{_docdir}/compiz-kde-%{version}
247cp -a ChangeLog COPYING README $RPM_BUILD_ROOT/%{_docdir}/compiz-kde-%{version}
248
249iconlist="16 24 32 36 48 96"
250for i in $iconlist; do
251 mkdir -p $RPM_BUILD_ROOT/%{_datadir}/icons/hicolor/$i\x$i/apps/
252 cp -p ../desktop-effects-%{dialogversion}/desktop-effects$i.png $RPM_BUILD_ROOT/%{_datadir}/icons/hicolor/$i\x$i/apps/kde-desktop-effects.png
253done
254
255desktop-file-install --vendor=""           \
256  --dir=%{buildroot}%{_datadir}/applications/kde       \
257  kde-desktop-effects.desktop
258popd
259%endif
260
261%if !%{with kde}
262rm -f $RPM_BUILD_ROOT%{_datadir}/compiz/kconfig.xml
263%endif
264
265
266#install -m 0755 %{SOURCE11} $RPM_BUILD_ROOT%{_bindir}
267#desktop-file-install --vendor="" \
268#  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
269#  %{SOURCE12}
270# set up an X session
271#mkdir -p $RPM_BUILD_ROOT%{_datadir}/xsessions
272#install %{SOURCE13} $RPM_BUILD_ROOT%{_datadir}/xsessions
273#mkdir -p $RPM_BUILD_ROOT%{_datadir}/gnome-session/sessions
274#install %{SOURCE14} $RPM_BUILD_ROOT%{_datadir}/gnome-session/sessions
275
276
277find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
278find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} ';'
279
280
281%find_lang compiz
282%find_lang desktop-effects
283
284cat compiz.lang > core-files.txt
285cat desktop-effects.lang > mate-files.txt
286
287for f in %{core_plugins}; do
288  echo %{_libdir}/compiz/lib$f.so
289  echo %{_datadir}/compiz/$f.xml
290done >> core-files.txt
291
292for f in %{mate_plugins}; do
293  echo %{_libdir}/compiz/lib$f.so
294  echo %{_datadir}/compiz/$f.xml
295done >> mate-files.txt
296
297rm -f $RPM_BUILD_ROOT%{_datadir}/applications/compiz.desktop
298rm -f $RPM_BUILD_ROOT%{_datadir}/compiz/gconf.xml
299
300
301%post -p /sbin/ldconfig
302
303%postun -p /sbin/ldconfig
304
305%post mate
306update-desktop-database -q %{_datadir}/applications
307touch --no-create %{_datadir}/icons/hicolor
308if [ -x /usr/bin/gtk-update-icon-cache ]; then
309        /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
310fi
311
312%postun mate
313update-desktop-database -q %{_datadir}/applications
314touch --no-create %{_datadir}/icons/hicolor
315if [ -x /usr/bin/gtk-update-icon-cache ]; then
316        /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
317fi
318
319%if %{with kde}
320%post kde
321update-desktop-database -q %{_datadir}/applications/kde
322touch --no-create %{_datadir}/icons/hicolor
323
324%postun kde
325touch --no-create %{_datadir}/icons/hicolor
326%endif
327
328%clean
329rm -rf $RPM_BUILD_ROOT
330
331
332%files -f core-files.txt
333%defattr(-, root, root)
334%doc AUTHORS ChangeLog COPYING* README TODO
335%{_bindir}/compiz
336%{_libdir}/libdecoration.so.*
337%dir %{_libdir}/compiz
338%dir %{_datadir}/compiz
339%{_datadir}/compiz/*.png
340%{_datadir}/compiz/core.xml
341
342%files mate -f mate-files.txt
343%defattr(-, root, root)
344%{_bindir}/gtk-window-decorator
345%{_bindir}/desktop-effects
346%{_libdir}/window-manager-settings/libcompiz.so
347%{_datadir}/compiz/desktop-effects.glade
348%{_datadir}/icons/hicolor/16x16/apps/desktop-effects.png
349%{_datadir}/icons/hicolor/24x24/apps/desktop-effects.png
350%{_datadir}/icons/hicolor/32x32/apps/desktop-effects.png
351%{_datadir}/icons/hicolor/36x36/apps/desktop-effects.png
352%{_datadir}/icons/hicolor/48x48/apps/desktop-effects.png
353%{_datadir}/icons/hicolor/96x96/apps/desktop-effects.png
354%{_datadir}/mate/wm-properties/compiz-wm.desktop
355%{_datadir}/mate-control-center/keybindings/50-compiz-desktop-key.xml
356%{_datadir}/mate-control-center/keybindings/50-compiz-key.xml
357
358%if %{with kde}
359%files kde
360%defattr(-, root, root)
361%{_bindir}/kde4-window-decorator
362%{_docdir}/compiz-kde-%{version}
363%{_bindir}/kde-desktop-effects.sh
364%{_datadir}/applications/kde/kde-desktop-effects.desktop
365%{_datadir}/icons/hicolor/*/apps/kde-desktop-effects.png
366%{_datadir}/compiz/kconfig.xml
367%endif
368
369%files devel
370%defattr(-, root, root)
371%{_libdir}/pkgconfig/compiz.pc
372%{_libdir}/pkgconfig/libdecoration.pc
373%{_libdir}/pkgconfig/compiz-cube.pc
374%{_libdir}/pkgconfig/compiz-scale.pc
375%{_includedir}/compiz
376%{_libdir}/libdecoration.so
377
378
379%changelog
380* Sun Jun 07 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.8-7
381- add Patch3001 (compiz-mate.patch)
382- add BuildRequires: marco-devel, mate-control-center-devel
383- remove BuildRequires: GConf2-devel, control-center-devel, metacity-devel
384- create %%{name}-mate subpackage
385- remove %%{name}-gnome subpackage
386
387* Sun Sep 14 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.8-6
388- rebuild with VineSeed environment
389
390* Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.8-5
391- rebuild with VineSeed environment
392
393* Sun Sep 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.8-4
394- remove follow files
395    Source11 (compiz-gtk)
396    Source12 (compiz-gtk.desktop)
397    Source13 (compiz-gnome.desktop)
398    Source14 (compiz-gnome.session)
399
400* Mon Mar 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.8-3
401- remove SandyBridge chipset from blacklist
402- add BR: dbus-glib-devel
403
404* Sun Aug 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.8-2
405- add Source files from Fedora
406    Source11 (compiz-gtk)
407    Source12 (compiz-gtk.desktop)
408    Source13 (compiz-gnome.desktop)
409    Source14 (compiz-gnome.session)
410
411* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.8-1
412- new upstream release
413- add BuildRequires: libxslt-devel, libglade2-devel
414- drop Patch2000,2010
415
416* Sat Apr 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.6-5
417- add Patch3000
418  - disable Sync to vblank
419  - increase drop-shadow radius
420  - set default decorator to gtk-window-decorator
421  - change default daces in cube plugin
422  - use "smart" placement mode
423
424* Sun Mar 13 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.6-4
425- drop compiz-gtk
426  - add Conflicts: control-center < 2.32.1-2
427
428* Sat Mar 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.6-3
429- rebuild with mesa-7.10.1
430- add cherry picked ubuntu patch
431  - Patch1150: add --no-fbo option
432  - Patch1200: disable GDK|GTK_DISABLE_DEPRECATED
433  - Patch1160: call glxwaitx before drawing
434  - Patch1170: always unredirect screensaver on nvidia
435  - Patch1490: damage report non empty
436  - Patch1600: move check to compiz
437- add upstream patch
438  - Patch2000: replace gdk_draw_drawable with cairo equivalents
439  - Patch2010: fix pixmap size calculation
440
441* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.6-2
442- rebuild with rpm-4.8.1 for pkg-config file
443
444* Sat Apr 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.6-1
445- new upstream release (build on GNOME-2.30)
446- drop Patch123, Patch300
447
448* Sat Nov 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-4
449- rebuild with mesa-7.6
450- add Patch300 to build with gconf-2.28
451
452* Thu Jun 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-3
453- disable glib plugin in compiz-gtk
454- use direct rendering on virtualbox video adaptor.
455
456* Tue May 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-2
457- add Requires: glx-utils to compiz-gnome
458
459* Mon May 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-1
460- new upstream release
461
462* Sun May 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-8
463- re-enable metacity decoration on gtk-window-decorator
464  - BR: metacity-devel instead of metacity
465
466* Fri May 01 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.7.8-7
467- fix pre/post scripts for speeding up gconf schema installation
468
469* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-6
470- add ccp compiz option to compiz-gtk
471
472* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-5
473- remove desktop-effect.desktop
474  - we use gnome-appearance-properties integrated version.
475
476* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-4
477- add Patch121,122 from upstream fix.
478- add Patch123: make sure configuration plugins never get unloaded
479- add Patch124: memleak fix from upstream
480- add Patch125: make the terminal keybind work
481- add Patch120,126,127 for kde42
482- add Patch128: gwd fix from upstream
483
484* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-3
485- rebuild with gnome-desktop-2.26.0
486
487* Wed Oct 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-2
488- add compiz-gtk scripts and desktop file from fedora
489
490* Thu Oct 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-1
491- new upstream release
492
493* Wed Jun 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.6-2
494- rebuild with gnome-desktop-2.24.0
495
496* Wed Jun 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.6-1
497- new upstream release
498
499* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.4-1
500- new upstream release
501
502* Sat May 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.2-1
503- initial build for Vine Linux
504
505* Thu Mar 27 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.7.2-3
506- Fix gconf plugin loop RH #438794, patch based on
507  older one from Guillaume Seguin
508- Add core to default plugin list
509
510* Wed Mar 26 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.7.2-2
511- Reword kde-desktop-effects messages to mention Compiz by name (#438883)
512
513* Mon Mar 24 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.7.2-1
514- Update to 0.7.2
515
516* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.6.2-7
517- Autorebuild for GCC 4.3
518
519* Thu Jan 17 2008 Kristian H淡gsberg <krh@redhat.com> - 0.6.2-6
520- Update to desktop-effects version 0.7.17 which include more
521  translations and move desktop-effects translations to compiz-gnome.
522- Fix spelling in beryl-core obsoletes.
523
524* Mon Jan 07 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.6.2-5
525- Update buildrequires (kwd uses the kde3 api)
526
527* Tue Nov  6 2007 Stepan Kasal <skasal@redhat.com> - 0.6.2-4
528- Fix a typo in description of the main package.
529- All descriptions should end with a dot (unlike the summary line)
530
531* Thu Oct 25 2007 Sebastian Vahl <fedora@deadbabylon.de> - 0.6.2-3
532- Include kde-desktop-effects in kde subpackage
533
534* Tue Oct 23 2007 Adel Gadllah <adel.gadllah@gmail.com> - 0.6.2-2
535- Obsolete berly-core
536
537* Mon Oct 22 2007 Warren Togami <wtogami@redhat.com> - 0.6.2-1
538- 0.6.2
539
540* Fri Oct 12 2007 Kristian H淡gsberg <krh@redhat.com> - 0.6.0-2
541- Disable scale corner initiate and install a GNOME key config entry.
542
543* Wed Oct 10 2007 Warren Togami <wtogami@redhat.com> - 0.6.0-1
544- 0.6.0 final
545- always-restack-windows-on-map
546
547* Tue Oct  9 2007 Warren Togami <wtogami@redhat.com> - 0.5.2-14
548- Make compiz behave with gnome-terminal (#304051)
549
550* Fri Oct  5 2007 Matthias Clasen <mclasen@redhat.com> - 0.5.2-13
551- Also install gwd.schemas (#319621)
552
553* Thu Sep 20 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-12
554- Update to more recent 0.6 branch snapshot (fixes #253575).
555
556* Fri Sep 14 2007 Warren Togami <wtogami@redhat.com> - 0.5.2-11
557- compiz-gnome: install core schema so it actually works
558- remove unnecessary gconf stuff from %%install
559
560* Tue Aug 28 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-9
561- Make compiz-gnome Obsolete the older compiz package so yum/anaconda
562  will pull it in (thans to Adel Gadllah).
563
564* Wed Aug 22 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-8
565- Bump to desktop-effects 0.7.7 to avoid kill decorator when popping
566  up dialog.
567- Fix broken gconf install and uninstall rules.
568- Pick up shadowman logo for RHEL builds (#232398).
569
570* Tue Aug 21 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-7.0ec3ec
571- Add more-sm-junk.patch so we set SM restart style to
572  SmRestartIfRunning on exit (#247163, #245971).
573- Add Requires to compiz-devel (#253407).
574- Update to desktop-effects 0.7.6, which terminates decorator when
575  switching to metacity or on compiz failure (#215247, #215032).
576
577* Fri Aug 17 2007 Adel Gadllah <adel.gadllah@gmail.com> 0.5.2-6.0ec3ec
578- Split into gnome and kde subpackages
579- Minor cleanups
580
581* Wed Aug 15 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-5.0ec3ec
582- Reorder plugin list to avoid 'place' getting removed on startup.
583- Add run-command-key.patch to put the run command key in the GNOME
584  keyboard shortcut dialog (#213576).
585- Drop a bunch of obsolete patches.
586- Bump mesa-libGL and X server requires to fix TFP bugs for
587  power-of-two textures (#251935).
588- Rebase fedora-logo and composite-cube-logo patch.
589
590* Tue Aug 14 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-4.0ec3ec
591- Build with desktop-effects so we don't pick up metacity work spaces.
592  Fixes #250568.
593
594* Tue Aug 14 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-3.0ec3ec
595- Build git snapshot from fedora branch at
596  git://people.freedesktop.org/~krh/compiz, brances from 0.6 upstream
597  branch.
598- Fixes #237486.
599
600* Fri Aug 10 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-3
601- Require desktop-effects 0.7.3 and gnome-session 2.19.6-5 which pass
602  'glib' on the command line too.
603
604* Fri Aug 10 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-2
605- Move xml meta data files to main package.
606
607* Thu Aug  9 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-1
608- Update to 0.5.2.
609- Require at least gnome-session 2.19.6-2 so gnome-wm starts compiz
610  with LIBGL_ALWAYS_INDIRECT set.
611
612* Wed Jun 27 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.0-1
613- Update to 0.5.0
614
615* Tue Jun  5 2007 Matthias Clasen <mclasen@redhat.com> - 0.4.0-1
616- Update to 0.4.0
617
618* Mon Jun  4 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.6-10
619- Rebuild against new libwnck
620
621* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.6-9
622- Don't install INSTALL
623
624* Mon Apr 16 2007 Kristian H淡gsberg <krh@hinata.boston.redhat.com> - 0.3.6-8
625- Update metacity build requires to metacity-devel.
626
627* Wed Apr  4 2007 Kristian H淡gsberg <krh@hinata.boston.redhat.com> - 0.3.6-7
628- Fix typo in ./configure option.
629
630* Wed Apr  4 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-6
631- Add place and clone plugins to default plugin list.
632
633* Wed Mar 28 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-5
634- Update URL (#208214).
635- Require at least metacity 2.18 (#232831).
636- Add close-session.patch to deregister from SM when replaced (#229113).
637
638* Tue Mar 27 2007 Kristian H淡gsberg <krh@redhat.com> 0.3.6-4
639- Explicitly disable KDE parts (#234128).
640
641* Mon Mar 26 2007 Matthias Clasen <mclasen@redhat.com> 0.3.6-3
642- Fix some directory ownership issues (#233825)
643- Small spec cleanups
644
645* Tue Feb  6 2007 Kristian H淡gsberg <krh@redhat.com> 0.3.6
646- Require gnome-session > 2.16 so it starts gtk-window-decorator.
647- Update to desktop-effects 0.7.1 that doesn't refuse to work with Xinerama.
648
649* Tue Jan 16 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-1
650- Update to 0.3.6, update patches.
651- Drop autotool build requires.
652- Drop glfinish.patch, cow.patch, resize-offset.patch and icon-menu-patch.
653- Add libdecoration.so
654- Update to desktop-effects-0.7.0, which spawns the right decorator
655  and plays nicely with unknown plugins.
656
657* Sat Nov 25 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.4-2
658- Update the fedora logo patch (#217224)
659
660* Thu Nov 23 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.4-1
661- Update to 0.3.4
662
663* Wed Nov 15 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.2-2
664- Use cow by default, bug 208044
665
666* Fri Nov 10 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
667- Update to 0.3.2
668- Drop upstreamed patches
669- Work with new metacity theme api
670
671* Mon Oct 2 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.32.20060818git.fc6
672- Install the .desktop file with desktop-file-install. Add X-Red-Hat-Base to make it appear in "Preferences", rather than "More Preferences".
673
674* Sat Sep 30 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.31.20060818git.fc6
675- Add buildrequires on intltool
676
677* Sat Sep 30 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.31.20060818git.fc6
678- Build
679
680* Fri Sep 29 2006 Soren Sandmann <sandmann@redhat.com>
681- Update to desktop-effects-0.6.163, which has translation enabled. (Bug 208257)
682
683* Thu Sep 28 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.30.20060817git.fc6
684- Add patch to terminate keyboard moves when a mouse buttons is pressed. (Bug 207792).
685
686* Thu Sep 28 2006 Soren Sandmann <sandmann@redhat.com>
687- Change default plugin list to not include the plane plugin. (Bug 208448).
688- Change default keybinding for shrink to be Pause (Bug 206187).
689
690* Wed Sep 27 2006 Soren Sandmann <sandmann@redhat.com>
691- Add patch to show a menu when the window icon is clicked. (Bug 201629).
692
693* Tue Sep 26 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.29.20060817git.fc6
694- Add restart.patch to make compiz ask the session manager to restart it
695  if it crashes (bug 200280).
696
697* Mon Sep 25 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.28.20060817git.fc6
698- Change plane.patch to not do cyclical window movement in dimensions
699  where the desktop has size 1 (bug 207263).
700
701* Thu Sep 21 2006 Soren Sandmann <sandmann@redhat.com>
702- Add patch to fix resizing smaller than minimum size (resize-offset.patch, bug 201623).
703
704* Tue Sep 19 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.27.20060817git.fc6
705- Change .plane patch to
706  (a) not set the background color to pink in the plane plugin.
707  (b) allow workspaces with horizontal sizes less then 4.
708
709* Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.26.20060817git.fc6
710- Change plane patch to correctly initialize the screen size to the
711  defaults (bug 206088).
712
713* Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com>
714- Run update-desktop-database and gtk-update-icon-cache in post. Add icons
715  to list of packaged files. Also bump to 0.6.137 of dialog (which just makes
716  directories before attempting to install to them).
717
718* Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com>
719- Upgrade to 0.6.107 of the desktop-effects dialog box. Only change is
720  that the new version has icons.
721
722* Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
723- Add patch to fix mispositioning of window decorator event windows (bug 201624)
724
725* Fri Sep 15 2006 Soren Sandmann <sandamnn@redhat.com>
726- Upgrade to version 0.6.83 of desktop-effects. (bug 206500)
727
728* Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
729- Add patch to only accept button 1 for close/minimize/maximize (bug 201628)
730
731* Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
732- Add patch to fix thumbnail sorting (bug 201605)
733
734* Thu Sep 14 2006 Soren Sandmann <sandmann@redhat.com>
735- Add patch to fix double clicking (bug 201783).
736
737* Tue Sep 12 2006 Soren Sandmann <sandmann@redhat.com>
738- Don't attempt to move the viewport when dx = dy = 0.(last bit of 206088).
739
740* Tue Sep 12 2006 Soren Sandmann <sandamnn@redhat.com>
741- Fix plane.patch to draw correctly when no timeout is running. (206088).
742
743* Wed Sep  6 2006 Kristian H淡gsberg <krh@redhat.com>
744- Update fbconfig-depth-fix.patch to also skip fbconfigs without
745  corresponding visuals.
746
747* Tue Sep 5 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.25.20060817git.fc6
748- Make number of vertical size configurable
749
750* Tue Sep 5 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.24.20060817git.fc6
751- Fix vertical viewport support in the plane patch.
752
753* Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.23.20060817git.fc6
754- Upgrade to 0.6.61 of the dialog
755
756* Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
757- Add libtool to BuildRequires
758
759* Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
760- Add automake and autoconf to BuildRequires
761
762* Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
763- Add a patch to put viewports on a plane.
764
765* Wed Aug 30 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.21.20060817git.fc6
766- Drop gl-include-inferiors.patch now that compiz uses COW and the X
767  server evicts offscreen pixmaps automatically on
768  GLX_EXT_texture_from_pixmap usage.
769
770* Tue Aug 29 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.20.20060817git.fc6
771- Add cow.patch to make compiz use the composite overlay window.
772
773* Fri Aug 25 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.19-20060817git.fc6
774- Rebase to desktop-effects 0.6.41
775
776* Fri Aug 25 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.18.20060817git.fc6
777- Rebase to desktop-effects 0.6.19 and drop
778  desktop-effects-0.6.1-delete-session.patch
779
780* Tue Aug 22 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.17.20060817git.fc6
781- Add patch from upstream to also use sync protocol for override
782  redirect windows (sync-override-redirect-windows.patch).
783
784* Thu Aug 17 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.16.20060817git.fc6
785- Rebase to latest upstream changes which has the rest of the bindings
786  rewrite.  Add resize-move-keybindings.patch to make move and resize
787  bindings work like metacity.
788- Add back scale plugin.
789
790* Thu Aug 10 2006 Ray Strode <rstrode@redhat.com> 0.0.13-0.15.20060721git.fc5.aiglx
791- Add Requires: gnome-session 2.15.90-2.fc6 (bug 201473)
792- unlink session file on changing wms (bug 201473)
793
794* Thu Aug  3 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.14.20060721git.fc5.aiglx
795- Add Requires: gnome-session 2.15.4-3
796
797* Thu Aug  3 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.13.20060721git.fc5.aiglx
798- New version of dialog box. Macro the version number.
799
800* Wed Aug  2 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.13.20060721git.fc5.aiglx
801- Add 'desktop effects' dialog box.
802
803* Mon Jul 31 2006 Kristian H淡gsberg <krh@redhat.com> 0.0.13-0.12.20060721git.fc5.aiglx
804- Add libwnck requires.
805
806* Wed Jul 26 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.11.20060721git.fc5.aiglx
807- Bump and build for fc5 AIGLX repo.
808
809* Wed Jul 26 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.12.20060721git
810- Fix gconf hooks.
811
812* Tue Jul 25 2006 Kristian H淡gsberg <krh@redhat.com>
813- Require system-logos instead.
814
815* Mon Jul 24 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.10.20060721git
816- Bump version to work around tagging weirdness.
817
818* Mon Jul 24 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.9.20060721git
819- Add devel package and require redhat-logos instead of fedora-logos (#199757).
820
821* Fri Jul 21 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.8.20060720git
822- Add workaround for AIGLX throttling problem.
823
824* Thu Jul 20 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.7.20060720git
825- Drop scale plugin from snapshot.
826
827* Tue Jul 18 2006 Matthias Clasen <mclasen@redhat.com> - 0.0.13-0.6.20060717git
828- Don't build on s390
829
830* Mon Jul 17 2006 Matthias Clasen <mclasen@redhat.com> - 0.0.13-0.5.20060717git
831- Do some changes forced upon us by package review
832
833* Thu Jul 13 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-5.1
834- Use sane numbering scheme.
835
836* Fri Jul  7 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-4
837- Drop the fullscreen hardcode patch and require X server that has
838  GLX_MESA_copy_sub_buffer.
839
840* Tue Jun 27 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-3
841- Unbreak --replace.
842
843* Thu Jun 15 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-2
844- Add Requires, fix start-compiz.sh.
845
846* Wed Jun 14 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-1
847- Spec file for compiz, borrowing bits and pieces from Alphonse Van
848  Assches spec file (#192432).
Note: See TracBrowser for help on using the repository browser.