source: projects/specs/trunk/c/compiz/compiz-vl.spec @ 5837

Revision 5837, 29.9 KB checked in by daisuke, 12 years ago (diff)

compiz:

  • remove SandyBridge? chipset from blacklist
  • add BR: dbus-glib-devel
Line 
1# build with kde4
2%bcond_with kde
3
4%define         dialogversion   0.7.18
5%define         kde_dialogversion 0.0.5
6
7%define         core_plugins    blur clone commands cube dbus decoration fade ini inotify minimize move obs place png regex resize rotate scale screenshot switcher video water wobbly zoom fs
8
9%define         gnome_plugins   annotate gconf glib svg gnomecompat
10
11# List of plugins passed to ./configure.  The order is important
12
13%define         plugins         core,glib,gconf,dbus,png,svg,video,screenshot,decoration,clone,place,fade,minimize,move,resize,switcher,scale,wall
14
15Summary:        OpenGL window and compositing manager
16Summary(ja):    OpenGL ウィンドウ・コンポジットマネージャ
17Name:           compiz
18URL:            http://www.go-compiz.org
19License:        X11/MIT/GPL
20Group:          User Interface/Desktops
21Version:        0.8.8
22Release:        3%{?_dist_release}
23
24BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
25
26# libdrm is not available on these arches
27ExcludeArch:    s390 s390x ppc64
28
29Requires:       xorg-x11-server-Xorg
30Requires:       mesa-libGL
31
32Requires(post): desktop-file-utils
33
34BuildRequires:  mesa-libGLU-devel
35BuildRequires:  libdrm-devel
36BuildRequires:  libwnck-devel
37BuildRequires:  libX11-devel
38BuildRequires:  libXcomposite-devel
39BuildRequires:  libXdamage-devel
40BuildRequires:  libXext-devel
41BuildRequires:  libXfixes-devel
42BuildRequires:  libXmu-devel
43BuildRequires:  libXrandr-devel
44BuildRequires:  libXrender-devel
45BuildRequires:  libXt-devel
46BuildRequires:  libSM-devel
47
48BuildRequires:  GConf2-devel
49BuildRequires:  control-center-devel
50BuildRequires:  dbus-devel
51BuildRequires:  dbus-glib-devel
52BuildRequires:  fuse-devel
53BuildRequires:  gnome-desktop-devel >= 2.30.0
54BuildRequires:  libglade2-devel
55BuildRequires:  librsvg2-devel
56BuildRequires:  libxslt-devel
57BuildRequires:  metacity-devel
58
59BuildRequires:  desktop-file-utils
60BuildRequires:  intltool >= 0.35
61BuildRequires:  gettext
62
63%if %{with kde}
64BuildRequires:  kdebase-workspace-devel
65BUildRequires:  dbus-qt-devel
66%endif
67Conflicts:      control-center < 2.32.1-2
68
69# Make sure that former beryl users still have bling
70Obsoletes:      beryl-core
71
72Source0:        http://releases.compiz.org/%{version}/%{name}-%{version}.tar.bz2
73Source1:        desktop-effects-%{dialogversion}.tar.bz2
74Source2:        kde-desktop-effects-%{kde_dialogversion}.tar.bz2
75
76# Sources from fedora
77Source11:       compiz-gtk
78Source12:       compiz-gtk.desktop
79Source13:       compiz-gnome.desktop
80Source14:       compiz-gnome.session
81
82# Patches from fedora
83Patch102: desktop-effects-0.7.17-wall-plugin.patch
84Patch103: composite-cube-logo.patch
85Patch111: gconf-core-plugin-loopfix.patch
86
87# Make sure configuration plugins never get unloaded
88Patch123: compiz-0.7.8-pin-initial-plugins.patch
89
90# Patches from ubuntu
91Patch1140: 014-fix-gtk-window-decorator-no-argb-crash.patch
92Patch1150: 015_optional-fbo.patch
93Patch1160: 016_call_glxwaitx_before_drawing.patch
94Patch1170: 017_always_unredirect_screensaver_on_nvidia.patch
95Patch1200: 020_disable_gdk_gtk_disable_deprecated.patch
96Patch1490: 049-damage-report-non-empty.patch
97Patch1600: 060_move_checks_to_compiz.patch
98
99# Patches from upstream
100Patch2000: compiz-0.8.6-replace-gdk_draw_drawable-with-cairo-equiv.patch
101Patch2010: compiz-0.8.6-fix-pixmap-size-calculation.patch
102
103# Vine default options
104Patch3000: compiz-0.8.6-vine-default.patch
105
106Vendor: Project Vine
107Distribution: Vine Linux
108
109%description
110Compiz is one of the first OpenGL-accelerated compositing window
111managers for the X Window System. The integration allows it to perform
112compositing effects in window management, such as a minimization
113effect and a cube workspace.  Compiz is an OpenGL compositing manager
114that use Compiz use EXT_texture_from_pixmap OpenGL extension for
115binding redirected top-level windows to texture objects.
116
117%package devel
118Summary: Development packages for compiz
119Summary(ja): compiz の開発パッケージ
120Group: Development/Libraries
121Requires: compiz = %{version}-%{release}
122Requires: pkgconfig
123Requires: libXcomposite-devel libXfixes-devel libXdamage-devel libXrandr-devel
124Requires: libXinerama-devel libICE-devel libSM-devel libxml2-devel
125Requires: libxslt-devel startup-notification-devel
126
127%description devel
128The compiz-devel package includes the header files,
129and developer docs for the compiz package.
130
131Install compiz-devel if you want to develop plugins for the compiz
132windows and compositing manager.
133
134%package gnome
135Summary: Compiz gnome integration bits
136Summary(ja): Compiz gnome integration bits
137Group: User Interface/Desktops
138Requires: gnome-session
139Requires: metacity
140Requires: libwnck
141Requires: glx-utils
142Requires: %{name} = %{version}
143Requires(pre): GConf2
144Requires(post): GConf2
145Requires(preun): GConf2
146Obsoletes: compiz < 0.5.2-8
147Obsoletes: beryl-gnome
148
149%description gnome
150The compiz-gnome package contains gtk-window-decorator,
151and other gnome integration related stuff.
152
153%if %{with kde}
154%package kde
155Summary: Compiz kde integration bits
156Summary(ja): Compiz kde integration bits
157Group: User Interface/Desktops
158Requires: %{name} = %{version}
159Requires: compiz-manager
160Obsoletes: beryl-kde
161
162%description kde
163The compiz-kde package contains kde-window-decorator,
164and other kde integration related stuff.
165%endif
166
167%prep
168%setup -q -T -b1 -n desktop-effects-%{dialogversion}
169#%setup -q -T -b2 -n kde-desktop-effects-%{kde_dialogversion}
170%setup -q
171
172pushd ../desktop-effects-%{dialogversion}
173%patch102 -p1 -b .wall-plugin
174popd
175
176%patch103 -p1 -b .composite-cube-logo
177%patch111 -p1 -b .gconf-core-loop
178
179## %patch123 -p1 -b .initial-plugins
180
181# ubuntu patch
182%patch1140 -p1 -b .fix-gtk-window-decorator-no-argb-crash
183%patch1150 -p1 -b .disable-fbo
184%patch1160 -p1 -b .call_glxwaitx_before_drawing
185%patch1170 -p1 -b .always_unredirect_screensaver_on_nvidia
186%patch1200 -p1 -b .disable_gdk_gtk_disable_deprecated
187%patch1490 -p1 -b .damage-report-non-empty
188%patch1600 -p1 -b .move-check-to-compiz
189
190# upstream patch
191#%patch2000 -p1 -b .replace-gdk_draw_drawable-with-cairo-equiv
192#%patch2010 -p1 -b .fix-pixmap-size-calculation
193
194# vine patch
195%patch3000 -p1 -b .vine-default
196
197%build
198rm -rf $RPM_BUILD_ROOT
199
200CPPFLAGS="$CPPFLAGS -I$RPM_BUILD_ROOT%{_includedir}"
201export CPPFLAGS
202
203#needed to find kde4 libs
204#LDFLAGS="$LDFLAGS -L%{_libdir}/kde4/devel"
205#export LDFLAGS
206
207libtoolize
208autoreconf
209%configure                                      \
210%{?with_kde: --enable-kde4 }                    \
211%{!?with_kde: --disable-kde4 }                  \
212        --disable-kde                           \
213        --enable-gconf                          \
214        --enable-dbus                           \
215        --enable-place                          \
216        --enable-librsvg                        \
217        --enable-gtk                            \
218        --enable-metacity                       \
219        --enable-gnome                          \
220        --with-default-plugins=%{plugins}       \
221        --enable-gnome-keybindings           
222
223
224make LIBTOOL=/usr/bin/libtool %{?_smp_mflags} imagedir=%{_datadir}/pixmaps
225
226# desktop-effects
227cd ../desktop-effects-%{dialogversion}
228%configure
229
230
231%install
232rm -rf $RPM_BUILD_ROOT
233export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
234make LIBTOOL=/usr/bin/libtool DESTDIR=$RPM_BUILD_ROOT install || exit 1
235unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
236
237echo INSTALLING DESKTOP EFFECTS
238pushd ../desktop-effects-%{dialogversion}
239make LIBTOOL=/usr/bin/libtool LIBS=-lX11 DESTDIR=$RPM_BUILD_ROOT install || exit 1
240#desktop-file-install --vendor vine --delete-original      \
241#  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
242#  $RPM_BUILD_ROOT%{_datadir}/applications/desktop-effects.desktop
243rm -f $RPM_BUILD_ROOT%{_datadir}/applications/desktop-effects.desktop
244popd
245
246%if %{with kde}
247# kde-desktop-effects
248echo INSTALLING KDE DESKTOP EFFECTS
249pushd ../kde-desktop-effects-%{kde_dialogversion}
250cp -a kde-desktop-effects.sh $RPM_BUILD_ROOT/%{_bindir}/
251mkdir -p $RPM_BUILD_ROOT/%{_docdir}/compiz-kde-%{version}
252cp -a ChangeLog COPYING README $RPM_BUILD_ROOT/%{_docdir}/compiz-kde-%{version}
253
254iconlist="16 24 32 36 48 96"
255for i in $iconlist; do
256 mkdir -p $RPM_BUILD_ROOT/%{_datadir}/icons/hicolor/$i\x$i/apps/
257 cp -p ../desktop-effects-%{dialogversion}/desktop-effects$i.png $RPM_BUILD_ROOT/%{_datadir}/icons/hicolor/$i\x$i/apps/kde-desktop-effects.png
258done
259
260desktop-file-install --vendor=""           \
261  --dir=%{buildroot}%{_datadir}/applications/kde       \
262  kde-desktop-effects.desktop
263popd
264%endif
265
266%if !%{with kde}
267rm -f $RPM_BUILD_ROOT%{_datadir}/compiz/kconfig.xml
268%endif
269
270
271install -m 0755 %{SOURCE11} $RPM_BUILD_ROOT%{_bindir}
272desktop-file-install --vendor="" \
273  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
274  %{SOURCE12}
275# set up an X session
276mkdir -p $RPM_BUILD_ROOT%{_datadir}/xsessions
277install %{SOURCE13} $RPM_BUILD_ROOT%{_datadir}/xsessions
278mkdir -p $RPM_BUILD_ROOT%{_datadir}/gnome-session/sessions
279install %{SOURCE14} $RPM_BUILD_ROOT%{_datadir}/gnome-session/sessions
280
281
282find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
283find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} ';'
284
285
286%find_lang compiz
287%find_lang desktop-effects
288
289cat compiz.lang > core-files.txt
290cat desktop-effects.lang > gnome-files.txt
291
292for f in %{core_plugins}; do
293  echo %{_libdir}/compiz/lib$f.so
294  echo %{_datadir}/compiz/$f.xml
295done >> core-files.txt
296
297for f in %{gnome_plugins}; do
298  echo %{_libdir}/compiz/lib$f.so
299  echo %{_datadir}/compiz/$f.xml
300done >> gnome-files.txt
301
302
303%post -p /sbin/ldconfig
304
305%postun -p /sbin/ldconfig
306
307%post gnome
308update-desktop-database -q %{_datadir}/applications
309
310export GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source`
311for f in %{core_plugins} %{gnome_plugins} core; do
312  echo %{_sysconfdir}/gconf/schemas/compiz-${f}.schemas; done \
313  | xargs gconftool-2 --makefile-install-rule >& /dev/null || :
314
315gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/gwd.schemas >& /dev/null || :
316
317touch --no-create %{_datadir}/icons/hicolor
318if [ -x /usr/bin/gtk-update-icon-cache ]; then
319        /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
320fi
321
322
323%pre gnome
324if [ "$1" -gt 1 ]; then
325  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
326  for f in %{core_plugins} %{gnome_plugins} core; do
327    echo %{_sysconfdir}/gconf/schemas/compiz-${f}.schemas; done \
328    | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null || :
329
330  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gwd.schemas >& /dev/null || :
331fi
332
333
334%preun gnome
335if [ "$1" -eq 0 ]; then
336  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
337  for f in %{core_plugins} %{gnome_plugins} core; do
338    echo %{_sysconfdir}/gconf/schemas/compiz-${f}.schemas; done \
339    | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null || :
340
341  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gwd.schemas >& /dev/null || :
342fi
343
344
345%postun gnome
346touch --no-create %{_datadir}/icons/hicolor
347if [ -x /usr/bin/gtk-update-icon-cache ]; then
348        /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
349fi
350
351%if %{with kde}
352%post kde
353update-desktop-database -q %{_datadir}/applications/kde
354touch --no-create %{_datadir}/icons/hicolor
355
356%postun kde
357touch --no-create %{_datadir}/icons/hicolor
358%endif
359
360%clean
361rm -rf $RPM_BUILD_ROOT
362
363
364%files -f core-files.txt
365%defattr(-, root, root)
366%doc AUTHORS ChangeLog COPYING* README TODO
367%{_bindir}/compiz
368%{_libdir}/libdecoration.so.*
369%dir %{_libdir}/compiz
370%dir %{_datadir}/compiz
371%{_datadir}/compiz/*.png
372%{_datadir}/compiz/core.xml
373
374
375%files gnome -f gnome-files.txt
376%defattr(-, root, root)
377%{_bindir}/compiz-gtk
378%{_bindir}/gtk-window-decorator
379%{_bindir}/desktop-effects
380#%{_libdir}/window-manager-settings/libcompiz.so
381#%{_datadir}/gnome/wm-properties/compiz-wm.desktop
382#%{_datadir}/applications/compiz.desktop
383#%{_datadir}/gnome-control-center/keybindings/50-compiz-desktop-key.xml
384#%{_datadir}/gnome-control-center/keybindings/50-compiz-key.xml
385%{_datadir}/applications/compiz-gtk.desktop
386%{_datadir}/compiz/desktop-effects.glade
387%{_datadir}/icons/hicolor/16x16/apps/desktop-effects.png
388%{_datadir}/icons/hicolor/24x24/apps/desktop-effects.png
389%{_datadir}/icons/hicolor/32x32/apps/desktop-effects.png
390%{_datadir}/icons/hicolor/36x36/apps/desktop-effects.png
391%{_datadir}/icons/hicolor/48x48/apps/desktop-effects.png
392%{_datadir}/icons/hicolor/96x96/apps/desktop-effects.png
393%{_datadir}/xsessions/compiz-gnome.desktop
394%{_datadir}/gnome-session/sessions/compiz-gnome.session
395%{_sysconfdir}/gconf/schemas/*.schemas
396
397%if %{with kde}
398%files kde
399%defattr(-, root, root)
400%{_bindir}/kde4-window-decorator
401%{_docdir}/compiz-kde-%{version}
402%{_bindir}/kde-desktop-effects.sh
403%{_datadir}/applications/kde/kde-desktop-effects.desktop
404%{_datadir}/icons/hicolor/*/apps/kde-desktop-effects.png
405%{_datadir}/compiz/kconfig.xml
406%endif
407
408%files devel
409%defattr(-, root, root)
410%{_libdir}/pkgconfig/compiz.pc
411%{_libdir}/pkgconfig/libdecoration.pc
412%{_libdir}/pkgconfig/compiz-cube.pc
413%{_libdir}/pkgconfig/compiz-gconf.pc
414%{_libdir}/pkgconfig/compiz-scale.pc
415%{_datadir}/compiz/schemas.xslt
416%{_includedir}/compiz
417%{_libdir}/libdecoration.so
418
419
420%changelog
421* Mon Mar 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.8-3
422- remove SandyBridge chipset from blacklist
423- add BR: dbus-glib-devel
424
425* Sun Aug 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.8-2
426- add Source files from Fedora
427    Source11 (compiz-gtk)
428    Source12 (compiz-gtk.desktop)
429    Source13 (compiz-gnome.desktop)
430    Source14 (compiz-gnome.session)
431
432* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.8-1
433- new upstream release
434- add BuildRequires: libxslt-devel, libglade2-devel
435- drop Patch2000,2010
436
437* Sat Apr 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.6-5
438- add Patch3000
439  - disable Sync to vblank
440  - increase drop-shadow radius
441  - set default decorator to gtk-window-decorator
442  - change default daces in cube plugin
443  - use "smart" placement mode
444
445* Sun Mar 13 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.6-4
446- drop compiz-gtk
447  - add Conflicts: control-center < 2.32.1-2
448
449* Sat Mar 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.6-3
450- rebuild with mesa-7.10.1
451- add cherry picked ubuntu patch
452  - Patch1150: add --no-fbo option
453  - Patch1200: disable GDK|GTK_DISABLE_DEPRECATED
454  - Patch1160: call glxwaitx before drawing
455  - Patch1170: always unredirect screensaver on nvidia
456  - Patch1490: damage report non empty
457  - Patch1600: move check to compiz
458- add upstream patch
459  - Patch2000: replace gdk_draw_drawable with cairo equivalents
460  - Patch2010: fix pixmap size calculation
461
462* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.6-2
463- rebuild with rpm-4.8.1 for pkg-config file
464
465* Sat Apr 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.6-1
466- new upstream release (build on GNOME-2.30)
467- drop Patch123, Patch300
468
469* Sat Nov 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-4
470- rebuild with mesa-7.6
471- add Patch300 to build with gconf-2.28
472
473* Thu Jun 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-3
474- disable glib plugin in compiz-gtk
475- use direct rendering on virtualbox video adaptor.
476
477* Tue May 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-2
478- add Requires: glx-utils to compiz-gnome
479
480* Mon May 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-1
481- new upstream release
482
483* Sun May 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-8
484- re-enable metacity decoration on gtk-window-decorator
485  - BR: metacity-devel instead of metacity
486
487* Fri May 01 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.7.8-7
488- fix pre/post scripts for speeding up gconf schema installation
489
490* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-6
491- add ccp compiz option to compiz-gtk
492
493* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-5
494- remove desktop-effect.desktop
495  - we use gnome-appearance-properties integrated version.
496
497* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-4
498- add Patch121,122 from upstream fix.
499- add Patch123: make sure configuration plugins never get unloaded
500- add Patch124: memleak fix from upstream
501- add Patch125: make the terminal keybind work
502- add Patch120,126,127 for kde42
503- add Patch128: gwd fix from upstream
504
505* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-3
506- rebuild with gnome-desktop-2.26.0
507
508* Wed Oct 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-2
509- add compiz-gtk scripts and desktop file from fedora
510
511* Thu Oct 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-1
512- new upstream release
513
514* Wed Jun 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.6-2
515- rebuild with gnome-desktop-2.24.0
516
517* Wed Jun 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.6-1
518- new upstream release
519
520* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.4-1
521- new upstream release
522
523* Sat May 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.2-1
524- initial build for Vine Linux
525
526* Thu Mar 27 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.7.2-3
527- Fix gconf plugin loop RH #438794, patch based on
528  older one from Guillaume Seguin
529- Add core to default plugin list
530
531* Wed Mar 26 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.7.2-2
532- Reword kde-desktop-effects messages to mention Compiz by name (#438883)
533
534* Mon Mar 24 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.7.2-1
535- Update to 0.7.2
536
537* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.6.2-7
538- Autorebuild for GCC 4.3
539
540* Thu Jan 17 2008 Kristian H淡gsberg <krh@redhat.com> - 0.6.2-6
541- Update to desktop-effects version 0.7.17 which include more
542  translations and move desktop-effects translations to compiz-gnome.
543- Fix spelling in beryl-core obsoletes.
544
545* Mon Jan 07 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.6.2-5
546- Update buildrequires (kwd uses the kde3 api)
547
548* Tue Nov  6 2007 Stepan Kasal <skasal@redhat.com> - 0.6.2-4
549- Fix a typo in description of the main package.
550- All descriptions should end with a dot (unlike the summary line)
551
552* Thu Oct 25 2007 Sebastian Vahl <fedora@deadbabylon.de> - 0.6.2-3
553- Include kde-desktop-effects in kde subpackage
554
555* Tue Oct 23 2007 Adel Gadllah <adel.gadllah@gmail.com> - 0.6.2-2
556- Obsolete berly-core
557
558* Mon Oct 22 2007 Warren Togami <wtogami@redhat.com> - 0.6.2-1
559- 0.6.2
560
561* Fri Oct 12 2007 Kristian H淡gsberg <krh@redhat.com> - 0.6.0-2
562- Disable scale corner initiate and install a GNOME key config entry.
563
564* Wed Oct 10 2007 Warren Togami <wtogami@redhat.com> - 0.6.0-1
565- 0.6.0 final
566- always-restack-windows-on-map
567
568* Tue Oct  9 2007 Warren Togami <wtogami@redhat.com> - 0.5.2-14
569- Make compiz behave with gnome-terminal (#304051)
570
571* Fri Oct  5 2007 Matthias Clasen <mclasen@redhat.com> - 0.5.2-13
572- Also install gwd.schemas (#319621)
573
574* Thu Sep 20 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-12
575- Update to more recent 0.6 branch snapshot (fixes #253575).
576
577* Fri Sep 14 2007 Warren Togami <wtogami@redhat.com> - 0.5.2-11
578- compiz-gnome: install core schema so it actually works
579- remove unnecessary gconf stuff from %%install
580
581* Tue Aug 28 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-9
582- Make compiz-gnome Obsolete the older compiz package so yum/anaconda
583  will pull it in (thans to Adel Gadllah).
584
585* Wed Aug 22 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-8
586- Bump to desktop-effects 0.7.7 to avoid kill decorator when popping
587  up dialog.
588- Fix broken gconf install and uninstall rules.
589- Pick up shadowman logo for RHEL builds (#232398).
590
591* Tue Aug 21 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-7.0ec3ec
592- Add more-sm-junk.patch so we set SM restart style to
593  SmRestartIfRunning on exit (#247163, #245971).
594- Add Requires to compiz-devel (#253407).
595- Update to desktop-effects 0.7.6, which terminates decorator when
596  switching to metacity or on compiz failure (#215247, #215032).
597
598* Fri Aug 17 2007 Adel Gadllah <adel.gadllah@gmail.com> 0.5.2-6.0ec3ec
599- Split into gnome and kde subpackages
600- Minor cleanups
601
602* Wed Aug 15 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-5.0ec3ec
603- Reorder plugin list to avoid 'place' getting removed on startup.
604- Add run-command-key.patch to put the run command key in the GNOME
605  keyboard shortcut dialog (#213576).
606- Drop a bunch of obsolete patches.
607- Bump mesa-libGL and X server requires to fix TFP bugs for
608  power-of-two textures (#251935).
609- Rebase fedora-logo and composite-cube-logo patch.
610
611* Tue Aug 14 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-4.0ec3ec
612- Build with desktop-effects so we don't pick up metacity work spaces.
613  Fixes #250568.
614
615* Tue Aug 14 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-3.0ec3ec
616- Build git snapshot from fedora branch at
617  git://people.freedesktop.org/~krh/compiz, brances from 0.6 upstream
618  branch.
619- Fixes #237486.
620
621* Fri Aug 10 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-3
622- Require desktop-effects 0.7.3 and gnome-session 2.19.6-5 which pass
623  'glib' on the command line too.
624
625* Fri Aug 10 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-2
626- Move xml meta data files to main package.
627
628* Thu Aug  9 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-1
629- Update to 0.5.2.
630- Require at least gnome-session 2.19.6-2 so gnome-wm starts compiz
631  with LIBGL_ALWAYS_INDIRECT set.
632
633* Wed Jun 27 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.0-1
634- Update to 0.5.0
635
636* Tue Jun  5 2007 Matthias Clasen <mclasen@redhat.com> - 0.4.0-1
637- Update to 0.4.0
638
639* Mon Jun  4 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.6-10
640- Rebuild against new libwnck
641
642* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.6-9
643- Don't install INSTALL
644
645* Mon Apr 16 2007 Kristian H淡gsberg <krh@hinata.boston.redhat.com> - 0.3.6-8
646- Update metacity build requires to metacity-devel.
647
648* Wed Apr  4 2007 Kristian H淡gsberg <krh@hinata.boston.redhat.com> - 0.3.6-7
649- Fix typo in ./configure option.
650
651* Wed Apr  4 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-6
652- Add place and clone plugins to default plugin list.
653
654* Wed Mar 28 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-5
655- Update URL (#208214).
656- Require at least metacity 2.18 (#232831).
657- Add close-session.patch to deregister from SM when replaced (#229113).
658
659* Tue Mar 27 2007 Kristian H淡gsberg <krh@redhat.com> 0.3.6-4
660- Explicitly disable KDE parts (#234128).
661
662* Mon Mar 26 2007 Matthias Clasen <mclasen@redhat.com> 0.3.6-3
663- Fix some directory ownership issues (#233825)
664- Small spec cleanups
665
666* Tue Feb  6 2007 Kristian H淡gsberg <krh@redhat.com> 0.3.6
667- Require gnome-session > 2.16 so it starts gtk-window-decorator.
668- Update to desktop-effects 0.7.1 that doesn't refuse to work with Xinerama.
669
670* Tue Jan 16 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-1
671- Update to 0.3.6, update patches.
672- Drop autotool build requires.
673- Drop glfinish.patch, cow.patch, resize-offset.patch and icon-menu-patch.
674- Add libdecoration.so
675- Update to desktop-effects-0.7.0, which spawns the right decorator
676  and plays nicely with unknown plugins.
677
678* Sat Nov 25 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.4-2
679- Update the fedora logo patch (#217224)
680
681* Thu Nov 23 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.4-1
682- Update to 0.3.4
683
684* Wed Nov 15 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.2-2
685- Use cow by default, bug 208044
686
687* Fri Nov 10 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
688- Update to 0.3.2
689- Drop upstreamed patches
690- Work with new metacity theme api
691
692* Mon Oct 2 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.32.20060818git.fc6
693- Install the .desktop file with desktop-file-install. Add X-Red-Hat-Base to make it appear in "Preferences", rather than "More Preferences".
694
695* Sat Sep 30 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.31.20060818git.fc6
696- Add buildrequires on intltool
697
698* Sat Sep 30 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.31.20060818git.fc6
699- Build
700
701* Fri Sep 29 2006 Soren Sandmann <sandmann@redhat.com>
702- Update to desktop-effects-0.6.163, which has translation enabled. (Bug 208257)
703
704* Thu Sep 28 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.30.20060817git.fc6
705- Add patch to terminate keyboard moves when a mouse buttons is pressed. (Bug 207792).
706
707* Thu Sep 28 2006 Soren Sandmann <sandmann@redhat.com>
708- Change default plugin list to not include the plane plugin. (Bug 208448).
709- Change default keybinding for shrink to be Pause (Bug 206187).
710
711* Wed Sep 27 2006 Soren Sandmann <sandmann@redhat.com>
712- Add patch to show a menu when the window icon is clicked. (Bug 201629).
713
714* Tue Sep 26 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.29.20060817git.fc6
715- Add restart.patch to make compiz ask the session manager to restart it
716  if it crashes (bug 200280).
717
718* Mon Sep 25 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.28.20060817git.fc6
719- Change plane.patch to not do cyclical window movement in dimensions
720  where the desktop has size 1 (bug 207263).
721
722* Thu Sep 21 2006 Soren Sandmann <sandmann@redhat.com>
723- Add patch to fix resizing smaller than minimum size (resize-offset.patch, bug 201623).
724
725* Tue Sep 19 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.27.20060817git.fc6
726- Change .plane patch to
727  (a) not set the background color to pink in the plane plugin.
728  (b) allow workspaces with horizontal sizes less then 4.
729
730* Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.26.20060817git.fc6
731- Change plane patch to correctly initialize the screen size to the
732  defaults (bug 206088).
733
734* Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com>
735- Run update-desktop-database and gtk-update-icon-cache in post. Add icons
736  to list of packaged files. Also bump to 0.6.137 of dialog (which just makes
737  directories before attempting to install to them).
738
739* Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com>
740- Upgrade to 0.6.107 of the desktop-effects dialog box. Only change is
741  that the new version has icons.
742
743* Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
744- Add patch to fix mispositioning of window decorator event windows (bug 201624)
745
746* Fri Sep 15 2006 Soren Sandmann <sandamnn@redhat.com>
747- Upgrade to version 0.6.83 of desktop-effects. (bug 206500)
748
749* Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
750- Add patch to only accept button 1 for close/minimize/maximize (bug 201628)
751
752* Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
753- Add patch to fix thumbnail sorting (bug 201605)
754
755* Thu Sep 14 2006 Soren Sandmann <sandmann@redhat.com>
756- Add patch to fix double clicking (bug 201783).
757
758* Tue Sep 12 2006 Soren Sandmann <sandmann@redhat.com>
759- Don't attempt to move the viewport when dx = dy = 0.(last bit of 206088).
760
761* Tue Sep 12 2006 Soren Sandmann <sandamnn@redhat.com>
762- Fix plane.patch to draw correctly when no timeout is running. (206088).
763
764* Wed Sep  6 2006 Kristian H淡gsberg <krh@redhat.com>
765- Update fbconfig-depth-fix.patch to also skip fbconfigs without
766  corresponding visuals.
767
768* Tue Sep 5 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.25.20060817git.fc6
769- Make number of vertical size configurable
770
771* Tue Sep 5 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.24.20060817git.fc6
772- Fix vertical viewport support in the plane patch.
773
774* Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.23.20060817git.fc6
775- Upgrade to 0.6.61 of the dialog
776
777* Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
778- Add libtool to BuildRequires
779
780* Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
781- Add automake and autoconf to BuildRequires
782
783* Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
784- Add a patch to put viewports on a plane.
785
786* Wed Aug 30 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.21.20060817git.fc6
787- Drop gl-include-inferiors.patch now that compiz uses COW and the X
788  server evicts offscreen pixmaps automatically on
789  GLX_EXT_texture_from_pixmap usage.
790
791* Tue Aug 29 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.20.20060817git.fc6
792- Add cow.patch to make compiz use the composite overlay window.
793
794* Fri Aug 25 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.19-20060817git.fc6
795- Rebase to desktop-effects 0.6.41
796
797* Fri Aug 25 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.18.20060817git.fc6
798- Rebase to desktop-effects 0.6.19 and drop
799  desktop-effects-0.6.1-delete-session.patch
800
801* Tue Aug 22 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.17.20060817git.fc6
802- Add patch from upstream to also use sync protocol for override
803  redirect windows (sync-override-redirect-windows.patch).
804
805* Thu Aug 17 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.16.20060817git.fc6
806- Rebase to latest upstream changes which has the rest of the bindings
807  rewrite.  Add resize-move-keybindings.patch to make move and resize
808  bindings work like metacity.
809- Add back scale plugin.
810
811* Thu Aug 10 2006 Ray Strode <rstrode@redhat.com> 0.0.13-0.15.20060721git.fc5.aiglx
812- Add Requires: gnome-session 2.15.90-2.fc6 (bug 201473)
813- unlink session file on changing wms (bug 201473)
814
815* Thu Aug  3 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.14.20060721git.fc5.aiglx
816- Add Requires: gnome-session 2.15.4-3
817
818* Wed Aug  3 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.13.20060721git.fc5.aiglx
819- New version of dialog box. Macro the version number.
820
821* Wed Aug  2 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.13.20060721git.fc5.aiglx
822- Add 'desktop effects' dialog box.
823
824* Mon Jul 31 2006 Kristian H淡gsberg <krh@redhat.com> 0.0.13-0.12.20060721git.fc5.aiglx
825- Add libwnck requires.
826
827* Wed Jul 26 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.11.20060721git.fc5.aiglx
828- Bump and build for fc5 AIGLX repo.
829
830* Wed Jul 26 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.12.20060721git
831- Fix gconf hooks.
832
833* Tue Jul 25 2006 Kristian H淡gsberg <krh@redhat.com>
834- Require system-logos instead.
835
836* Mon Jul 24 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.10.20060721git
837- Bump version to work around tagging weirdness.
838
839* Mon Jul 24 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.9.20060721git
840- Add devel package and require redhat-logos instead of fedora-logos (#199757).
841
842* Fri Jul 21 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.8.20060720git
843- Add workaround for AIGLX throttling problem.
844
845* Thu Jul 20 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.7.20060720git
846- Drop scale plugin from snapshot.
847
848* Tue Jul 18 2006 Matthias Clasen <mclasen@redhat.com> - 0.0.13-0.6.20060717git
849- Don't build on s390
850
851* Mon Jul 17 2006 Matthias Clasen <mclasen@redhat.com> - 0.0.13-0.5.20060717git
852- Do some changes forced upon us by package review
853
854* Thu Jul 13 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-5.1
855- Use sane numbering scheme.
856
857* Fri Jul  7 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-4
858- Drop the fullscreen hardcode patch and require X server that has
859  GLX_MESA_copy_sub_buffer.
860
861* Tue Jun 27 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-3
862- Unbreak --replace.
863
864* Thu Jun 15 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-2
865- Add Requires, fix start-compiz.sh.
866
867* Wed Jun 14 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-1
868- Spec file for compiz, borrowing bits and pieces from Alphonse Van
869  Assches spec file (#192432).
Note: See TracBrowser for help on using the repository browser.