source: projects/specs/trunk/c/compiz/compiz-vl.spec @ 4677

Revision 4677, 29.7 KB checked in by Takemikaduchi, 13 years ago (diff)

compiz,task-compiz,xorg-x11-drv-wacom: fix package, others: new upstream release

Line 
1# build with kde4
2%bcond_with kde
3
4%define         dialogversion   0.7.18
5%define         kde_dialogversion 0.0.5
6
7%define         core_plugins    blur clone commands cube dbus decoration fade ini inotify minimize move obs place png regex resize rotate scale screenshot switcher video water wobbly zoom fs
8
9%define         gnome_plugins   annotate gconf glib svg gnomecompat
10
11# List of plugins passed to ./configure.  The order is important
12
13%define         plugins         core,glib,gconf,dbus,png,svg,video,screenshot,decoration,clone,place,fade,minimize,move,resize,switcher,scale,wall
14
15Summary:        OpenGL window and compositing manager
16Summary(ja):    OpenGL ウィンドウ・コンポジットマネージャ
17Name:           compiz
18URL:            http://www.go-compiz.org
19License:        X11/MIT/GPL
20Group:          User Interface/Desktops
21Version:        0.8.8
22Release:        2%{?_dist_release}
23
24BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
25
26# libdrm is not available on these arches
27ExcludeArch:    s390 s390x ppc64
28
29Requires:       xorg-x11-server-Xorg
30Requires:       mesa-libGL
31
32Requires(post): desktop-file-utils
33
34BuildRequires:  mesa-libGLU-devel
35BuildRequires:  libdrm-devel
36BuildRequires:  libwnck-devel
37BuildRequires:  libX11-devel
38BuildRequires:  libXcomposite-devel
39BuildRequires:  libXdamage-devel
40BuildRequires:  libXext-devel
41BuildRequires:  libXfixes-devel
42BuildRequires:  libXmu-devel
43BuildRequires:  libXrandr-devel
44BuildRequires:  libXrender-devel
45BuildRequires:  libXt-devel
46BuildRequires:  libSM-devel
47
48BuildRequires:  GConf2-devel
49BuildRequires:  control-center-devel
50BuildRequires:  dbus-devel
51BuildRequires:  fuse-devel
52BuildRequires:  gnome-desktop-devel >= 2.30.0
53BuildRequires:  libglade2-devel
54BuildRequires:  librsvg2-devel
55BuildRequires:  libxslt-devel
56BuildRequires:  metacity-devel
57
58BuildRequires:  desktop-file-utils
59BuildRequires:  intltool >= 0.35
60BuildRequires:  gettext
61
62%if %{with kde}
63BuildRequires:  kdebase-workspace-devel
64BUildRequires:  dbus-qt-devel
65%endif
66Conflicts:      control-center < 2.32.1-2
67
68# Make sure that former beryl users still have bling
69Obsoletes:      beryl-core
70
71Source0:        http://releases.compiz.org/%{version}/%{name}-%{version}.tar.bz2
72Source1:        desktop-effects-%{dialogversion}.tar.bz2
73Source2:        kde-desktop-effects-%{kde_dialogversion}.tar.bz2
74
75# Sources from fedora
76Source11:       compiz-gtk
77Source12:       compiz-gtk.desktop
78Source13:       compiz-gnome.desktop
79Source14:       compiz-gnome.session
80
81# Patches from fedora
82Patch102: desktop-effects-0.7.17-wall-plugin.patch
83Patch103: composite-cube-logo.patch
84Patch111: gconf-core-plugin-loopfix.patch
85
86# Make sure configuration plugins never get unloaded
87Patch123: compiz-0.7.8-pin-initial-plugins.patch
88
89# Patches from ubuntu
90Patch1140: 014-fix-gtk-window-decorator-no-argb-crash.patch
91Patch1150: 015_optional-fbo.patch
92Patch1160: 016_call_glxwaitx_before_drawing.patch
93Patch1170: 017_always_unredirect_screensaver_on_nvidia.patch
94Patch1200: 020_disable_gdk_gtk_disable_deprecated.patch
95Patch1490: 049-damage-report-non-empty.patch
96Patch1600: 060_move_checks_to_compiz.patch
97
98# Patches from upstream
99Patch2000: compiz-0.8.6-replace-gdk_draw_drawable-with-cairo-equiv.patch
100Patch2010: compiz-0.8.6-fix-pixmap-size-calculation.patch
101
102# Vine default options
103Patch3000: compiz-0.8.6-vine-default.patch
104
105Vendor: Project Vine
106Distribution: Vine Linux
107
108%description
109Compiz is one of the first OpenGL-accelerated compositing window
110managers for the X Window System. The integration allows it to perform
111compositing effects in window management, such as a minimization
112effect and a cube workspace.  Compiz is an OpenGL compositing manager
113that use Compiz use EXT_texture_from_pixmap OpenGL extension for
114binding redirected top-level windows to texture objects.
115
116%package devel
117Summary: Development packages for compiz
118Summary(ja): compiz の開発パッケージ
119Group: Development/Libraries
120Requires: compiz = %{version}-%{release}
121Requires: pkgconfig
122Requires: libXcomposite-devel libXfixes-devel libXdamage-devel libXrandr-devel
123Requires: libXinerama-devel libICE-devel libSM-devel libxml2-devel
124Requires: libxslt-devel startup-notification-devel
125
126%description devel
127The compiz-devel package includes the header files,
128and developer docs for the compiz package.
129
130Install compiz-devel if you want to develop plugins for the compiz
131windows and compositing manager.
132
133%package gnome
134Summary: Compiz gnome integration bits
135Summary(ja): Compiz gnome integration bits
136Group: User Interface/Desktops
137Requires: gnome-session
138Requires: metacity
139Requires: libwnck
140Requires: glx-utils
141Requires: %{name} = %{version}
142Requires(pre): GConf2
143Requires(post): GConf2
144Requires(preun): GConf2
145Obsoletes: compiz < 0.5.2-8
146Obsoletes: beryl-gnome
147
148%description gnome
149The compiz-gnome package contains gtk-window-decorator,
150and other gnome integration related stuff.
151
152%if %{with kde}
153%package kde
154Summary: Compiz kde integration bits
155Summary(ja): Compiz kde integration bits
156Group: User Interface/Desktops
157Requires: %{name} = %{version}
158Requires: compiz-manager
159Obsoletes: beryl-kde
160
161%description kde
162The compiz-kde package contains kde-window-decorator,
163and other kde integration related stuff.
164%endif
165
166%prep
167%setup -q -T -b1 -n desktop-effects-%{dialogversion}
168#%setup -q -T -b2 -n kde-desktop-effects-%{kde_dialogversion}
169%setup -q
170
171pushd ../desktop-effects-%{dialogversion}
172%patch102 -p1 -b .wall-plugin
173popd
174
175%patch103 -p1 -b .composite-cube-logo
176%patch111 -p1 -b .gconf-core-loop
177
178## %patch123 -p1 -b .initial-plugins
179
180# ubuntu patch
181%patch1140 -p1 -b .fix-gtk-window-decorator-no-argb-crash
182%patch1150 -p1 -b .disable-fbo
183%patch1160 -p1 -b .call_glxwaitx_before_drawing
184%patch1170 -p1 -b .always_unredirect_screensaver_on_nvidia
185%patch1200 -p1 -b .disable_gdk_gtk_disable_deprecated
186%patch1490 -p1 -b .damage-report-non-empty
187%patch1600 -p1 -b .move-check-to-compiz
188
189# upstream patch
190#%patch2000 -p1 -b .replace-gdk_draw_drawable-with-cairo-equiv
191#%patch2010 -p1 -b .fix-pixmap-size-calculation
192
193# vine patch
194%patch3000 -p1 -b .vine-default
195
196%build
197rm -rf $RPM_BUILD_ROOT
198
199CPPFLAGS="$CPPFLAGS -I$RPM_BUILD_ROOT%{_includedir}"
200export CPPFLAGS
201
202#needed to find kde4 libs
203#LDFLAGS="$LDFLAGS -L%{_libdir}/kde4/devel"
204#export LDFLAGS
205
206libtoolize
207autoreconf
208%configure                                      \
209%{?with_kde: --enable-kde4 }                    \
210%{!?with_kde: --disable-kde4 }                  \
211        --disable-kde                           \
212        --enable-gconf                          \
213        --enable-dbus                           \
214        --enable-place                          \
215        --enable-librsvg                        \
216        --enable-gtk                            \
217        --enable-metacity                       \
218        --enable-gnome                          \
219        --with-default-plugins=%{plugins}       \
220        --enable-gnome-keybindings           
221
222
223make LIBTOOL=/usr/bin/libtool %{?_smp_mflags} imagedir=%{_datadir}/pixmaps
224
225# desktop-effects
226cd ../desktop-effects-%{dialogversion}
227%configure
228
229
230%install
231rm -rf $RPM_BUILD_ROOT
232export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
233make LIBTOOL=/usr/bin/libtool DESTDIR=$RPM_BUILD_ROOT install || exit 1
234unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
235
236echo INSTALLING DESKTOP EFFECTS
237pushd ../desktop-effects-%{dialogversion}
238make LIBTOOL=/usr/bin/libtool DESTDIR=$RPM_BUILD_ROOT install || exit 1
239#desktop-file-install --vendor vine --delete-original      \
240#  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
241#  $RPM_BUILD_ROOT%{_datadir}/applications/desktop-effects.desktop
242rm -f $RPM_BUILD_ROOT%{_datadir}/applications/desktop-effects.desktop
243popd
244
245%if %{with kde}
246# kde-desktop-effects
247echo INSTALLING KDE DESKTOP EFFECTS
248pushd ../kde-desktop-effects-%{kde_dialogversion}
249cp -a kde-desktop-effects.sh $RPM_BUILD_ROOT/%{_bindir}/
250mkdir -p $RPM_BUILD_ROOT/%{_docdir}/compiz-kde-%{version}
251cp -a ChangeLog COPYING README $RPM_BUILD_ROOT/%{_docdir}/compiz-kde-%{version}
252
253iconlist="16 24 32 36 48 96"
254for i in $iconlist; do
255 mkdir -p $RPM_BUILD_ROOT/%{_datadir}/icons/hicolor/$i\x$i/apps/
256 cp -p ../desktop-effects-%{dialogversion}/desktop-effects$i.png $RPM_BUILD_ROOT/%{_datadir}/icons/hicolor/$i\x$i/apps/kde-desktop-effects.png
257done
258
259desktop-file-install --vendor=""           \
260  --dir=%{buildroot}%{_datadir}/applications/kde       \
261  kde-desktop-effects.desktop
262popd
263%endif
264
265%if !%{with kde}
266rm -f $RPM_BUILD_ROOT%{_datadir}/compiz/kconfig.xml
267%endif
268
269
270install -m 0755 %{SOURCE11} $RPM_BUILD_ROOT%{_bindir}
271desktop-file-install --vendor="" \
272  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
273  %{SOURCE12}
274# set up an X session
275mkdir -p $RPM_BUILD_ROOT%{_datadir}/xsessions
276install %{SOURCE13} $RPM_BUILD_ROOT%{_datadir}/xsessions
277mkdir -p $RPM_BUILD_ROOT%{_datadir}/gnome-session/sessions
278install %{SOURCE14} $RPM_BUILD_ROOT%{_datadir}/gnome-session/sessions
279
280
281find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
282find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} ';'
283
284
285%find_lang compiz
286%find_lang desktop-effects
287
288cat compiz.lang > core-files.txt
289cat desktop-effects.lang > gnome-files.txt
290
291for f in %{core_plugins}; do
292  echo %{_libdir}/compiz/lib$f.so
293  echo %{_datadir}/compiz/$f.xml
294done >> core-files.txt
295
296for f in %{gnome_plugins}; do
297  echo %{_libdir}/compiz/lib$f.so
298  echo %{_datadir}/compiz/$f.xml
299done >> gnome-files.txt
300
301
302%post -p /sbin/ldconfig
303
304%postun -p /sbin/ldconfig
305
306%post gnome
307update-desktop-database -q %{_datadir}/applications
308
309export GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source`
310for f in %{core_plugins} %{gnome_plugins} core; do
311  echo %{_sysconfdir}/gconf/schemas/compiz-${f}.schemas; done \
312  | xargs gconftool-2 --makefile-install-rule >& /dev/null || :
313
314gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/gwd.schemas >& /dev/null || :
315
316touch --no-create %{_datadir}/icons/hicolor
317if [ -x /usr/bin/gtk-update-icon-cache ]; then
318        /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
319fi
320
321
322%pre gnome
323if [ "$1" -gt 1 ]; then
324  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
325  for f in %{core_plugins} %{gnome_plugins} core; do
326    echo %{_sysconfdir}/gconf/schemas/compiz-${f}.schemas; done \
327    | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null || :
328
329  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gwd.schemas >& /dev/null || :
330fi
331
332
333%preun gnome
334if [ "$1" -eq 0 ]; then
335  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
336  for f in %{core_plugins} %{gnome_plugins} core; do
337    echo %{_sysconfdir}/gconf/schemas/compiz-${f}.schemas; done \
338    | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null || :
339
340  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gwd.schemas >& /dev/null || :
341fi
342
343
344%postun gnome
345touch --no-create %{_datadir}/icons/hicolor
346if [ -x /usr/bin/gtk-update-icon-cache ]; then
347        /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
348fi
349
350%if %{with kde}
351%post kde
352update-desktop-database -q %{_datadir}/applications/kde
353touch --no-create %{_datadir}/icons/hicolor
354
355%postun kde
356touch --no-create %{_datadir}/icons/hicolor
357%endif
358
359%clean
360rm -rf $RPM_BUILD_ROOT
361
362
363%files -f core-files.txt
364%defattr(-, root, root)
365%doc AUTHORS ChangeLog COPYING* README TODO
366%{_bindir}/compiz
367%{_libdir}/libdecoration.so.*
368%dir %{_libdir}/compiz
369%dir %{_datadir}/compiz
370%{_datadir}/compiz/*.png
371%{_datadir}/compiz/core.xml
372
373
374%files gnome -f gnome-files.txt
375%defattr(-, root, root)
376%{_bindir}/compiz-gtk
377%{_bindir}/gtk-window-decorator
378%{_bindir}/desktop-effects
379#%{_libdir}/window-manager-settings/libcompiz.so
380#%{_datadir}/gnome/wm-properties/compiz-wm.desktop
381#%{_datadir}/applications/compiz.desktop
382#%{_datadir}/gnome-control-center/keybindings/50-compiz-desktop-key.xml
383#%{_datadir}/gnome-control-center/keybindings/50-compiz-key.xml
384%{_datadir}/applications/compiz-gtk.desktop
385%{_datadir}/compiz/desktop-effects.glade
386%{_datadir}/icons/hicolor/16x16/apps/desktop-effects.png
387%{_datadir}/icons/hicolor/24x24/apps/desktop-effects.png
388%{_datadir}/icons/hicolor/32x32/apps/desktop-effects.png
389%{_datadir}/icons/hicolor/36x36/apps/desktop-effects.png
390%{_datadir}/icons/hicolor/48x48/apps/desktop-effects.png
391%{_datadir}/icons/hicolor/96x96/apps/desktop-effects.png
392%{_datadir}/xsessions/compiz-gnome.desktop
393%{_datadir}/gnome-session/sessions/compiz-gnome.session
394%{_sysconfdir}/gconf/schemas/*.schemas
395
396%if %{with kde}
397%files kde
398%defattr(-, root, root)
399%{_bindir}/kde4-window-decorator
400%{_docdir}/compiz-kde-%{version}
401%{_bindir}/kde-desktop-effects.sh
402%{_datadir}/applications/kde/kde-desktop-effects.desktop
403%{_datadir}/icons/hicolor/*/apps/kde-desktop-effects.png
404%{_datadir}/compiz/kconfig.xml
405%endif
406
407%files devel
408%defattr(-, root, root)
409%{_libdir}/pkgconfig/compiz.pc
410%{_libdir}/pkgconfig/libdecoration.pc
411%{_libdir}/pkgconfig/compiz-cube.pc
412%{_libdir}/pkgconfig/compiz-gconf.pc
413%{_libdir}/pkgconfig/compiz-scale.pc
414%{_datadir}/compiz/schemas.xslt
415%{_includedir}/compiz
416%{_libdir}/libdecoration.so
417
418
419%changelog
420* Sun Aug 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.8-2
421- add Source files from Fedora
422    Source11 (compiz-gtk)
423    Source12 (compiz-gtk.desktop)
424    Source13 (compiz-gnome.desktop)
425    Source14 (compiz-gnome.session)
426
427* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.8-1
428- new upstream release
429- add BuildRequires: libxslt-devel, libglade2-devel
430- drop Patch2000,2010
431
432* Sat Apr 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.6-5
433- add Patch3000
434  - disable Sync to vblank
435  - increase drop-shadow radius
436  - set default decorator to gtk-window-decorator
437  - change default daces in cube plugin
438  - use "smart" placement mode
439
440* Sun Mar 13 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.6-4
441- drop compiz-gtk
442  - add Conflicts: control-center < 2.32.1-2
443
444* Sat Mar 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.6-3
445- rebuild with mesa-7.10.1
446- add cherry picked ubuntu patch
447  - Patch1150: add --no-fbo option
448  - Patch1200: disable GDK|GTK_DISABLE_DEPRECATED
449  - Patch1160: call glxwaitx before drawing
450  - Patch1170: always unredirect screensaver on nvidia
451  - Patch1490: damage report non empty
452  - Patch1600: move check to compiz
453- add upstream patch
454  - Patch2000: replace gdk_draw_drawable with cairo equivalents
455  - Patch2010: fix pixmap size calculation
456
457* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.6-2
458- rebuild with rpm-4.8.1 for pkg-config file
459
460* Sat Apr 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.6-1
461- new upstream release (build on GNOME-2.30)
462- drop Patch123, Patch300
463
464* Sat Nov 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-4
465- rebuild with mesa-7.6
466- add Patch300 to build with gconf-2.28
467
468* Thu Jun 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-3
469- disable glib plugin in compiz-gtk
470- use direct rendering on virtualbox video adaptor.
471
472* Tue May 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-2
473- add Requires: glx-utils to compiz-gnome
474
475* Mon May 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-1
476- new upstream release
477
478* Sun May 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-8
479- re-enable metacity decoration on gtk-window-decorator
480  - BR: metacity-devel instead of metacity
481
482* Fri May 01 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.7.8-7
483- fix pre/post scripts for speeding up gconf schema installation
484
485* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-6
486- add ccp compiz option to compiz-gtk
487
488* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-5
489- remove desktop-effect.desktop
490  - we use gnome-appearance-properties integrated version.
491
492* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-4
493- add Patch121,122 from upstream fix.
494- add Patch123: make sure configuration plugins never get unloaded
495- add Patch124: memleak fix from upstream
496- add Patch125: make the terminal keybind work
497- add Patch120,126,127 for kde42
498- add Patch128: gwd fix from upstream
499
500* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-3
501- rebuild with gnome-desktop-2.26.0
502
503* Wed Oct 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-2
504- add compiz-gtk scripts and desktop file from fedora
505
506* Thu Oct 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-1
507- new upstream release
508
509* Wed Jun 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.6-2
510- rebuild with gnome-desktop-2.24.0
511
512* Wed Jun 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.6-1
513- new upstream release
514
515* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.4-1
516- new upstream release
517
518* Sat May 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.2-1
519- initial build for Vine Linux
520
521* Thu Mar 27 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.7.2-3
522- Fix gconf plugin loop RH #438794, patch based on
523  older one from Guillaume Seguin
524- Add core to default plugin list
525
526* Wed Mar 26 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.7.2-2
527- Reword kde-desktop-effects messages to mention Compiz by name (#438883)
528
529* Mon Mar 24 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.7.2-1
530- Update to 0.7.2
531
532* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.6.2-7
533- Autorebuild for GCC 4.3
534
535* Thu Jan 17 2008 Kristian H淡gsberg <krh@redhat.com> - 0.6.2-6
536- Update to desktop-effects version 0.7.17 which include more
537  translations and move desktop-effects translations to compiz-gnome.
538- Fix spelling in beryl-core obsoletes.
539
540* Mon Jan 07 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.6.2-5
541- Update buildrequires (kwd uses the kde3 api)
542
543* Tue Nov  6 2007 Stepan Kasal <skasal@redhat.com> - 0.6.2-4
544- Fix a typo in description of the main package.
545- All descriptions should end with a dot (unlike the summary line)
546
547* Thu Oct 25 2007 Sebastian Vahl <fedora@deadbabylon.de> - 0.6.2-3
548- Include kde-desktop-effects in kde subpackage
549
550* Tue Oct 23 2007 Adel Gadllah <adel.gadllah@gmail.com> - 0.6.2-2
551- Obsolete berly-core
552
553* Mon Oct 22 2007 Warren Togami <wtogami@redhat.com> - 0.6.2-1
554- 0.6.2
555
556* Fri Oct 12 2007 Kristian H淡gsberg <krh@redhat.com> - 0.6.0-2
557- Disable scale corner initiate and install a GNOME key config entry.
558
559* Wed Oct 10 2007 Warren Togami <wtogami@redhat.com> - 0.6.0-1
560- 0.6.0 final
561- always-restack-windows-on-map
562
563* Tue Oct  9 2007 Warren Togami <wtogami@redhat.com> - 0.5.2-14
564- Make compiz behave with gnome-terminal (#304051)
565
566* Fri Oct  5 2007 Matthias Clasen <mclasen@redhat.com> - 0.5.2-13
567- Also install gwd.schemas (#319621)
568
569* Thu Sep 20 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-12
570- Update to more recent 0.6 branch snapshot (fixes #253575).
571
572* Fri Sep 14 2007 Warren Togami <wtogami@redhat.com> - 0.5.2-11
573- compiz-gnome: install core schema so it actually works
574- remove unnecessary gconf stuff from %%install
575
576* Tue Aug 28 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-9
577- Make compiz-gnome Obsolete the older compiz package so yum/anaconda
578  will pull it in (thans to Adel Gadllah).
579
580* Wed Aug 22 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-8
581- Bump to desktop-effects 0.7.7 to avoid kill decorator when popping
582  up dialog.
583- Fix broken gconf install and uninstall rules.
584- Pick up shadowman logo for RHEL builds (#232398).
585
586* Tue Aug 21 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-7.0ec3ec
587- Add more-sm-junk.patch so we set SM restart style to
588  SmRestartIfRunning on exit (#247163, #245971).
589- Add Requires to compiz-devel (#253407).
590- Update to desktop-effects 0.7.6, which terminates decorator when
591  switching to metacity or on compiz failure (#215247, #215032).
592
593* Fri Aug 17 2007 Adel Gadllah <adel.gadllah@gmail.com> 0.5.2-6.0ec3ec
594- Split into gnome and kde subpackages
595- Minor cleanups
596
597* Wed Aug 15 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-5.0ec3ec
598- Reorder plugin list to avoid 'place' getting removed on startup.
599- Add run-command-key.patch to put the run command key in the GNOME
600  keyboard shortcut dialog (#213576).
601- Drop a bunch of obsolete patches.
602- Bump mesa-libGL and X server requires to fix TFP bugs for
603  power-of-two textures (#251935).
604- Rebase fedora-logo and composite-cube-logo patch.
605
606* Tue Aug 14 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-4.0ec3ec
607- Build with desktop-effects so we don't pick up metacity work spaces.
608  Fixes #250568.
609
610* Tue Aug 14 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-3.0ec3ec
611- Build git snapshot from fedora branch at
612  git://people.freedesktop.org/~krh/compiz, brances from 0.6 upstream
613  branch.
614- Fixes #237486.
615
616* Fri Aug 10 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-3
617- Require desktop-effects 0.7.3 and gnome-session 2.19.6-5 which pass
618  'glib' on the command line too.
619
620* Fri Aug 10 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-2
621- Move xml meta data files to main package.
622
623* Thu Aug  9 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-1
624- Update to 0.5.2.
625- Require at least gnome-session 2.19.6-2 so gnome-wm starts compiz
626  with LIBGL_ALWAYS_INDIRECT set.
627
628* Wed Jun 27 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.0-1
629- Update to 0.5.0
630
631* Tue Jun  5 2007 Matthias Clasen <mclasen@redhat.com> - 0.4.0-1
632- Update to 0.4.0
633
634* Mon Jun  4 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.6-10
635- Rebuild against new libwnck
636
637* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.6-9
638- Don't install INSTALL
639
640* Mon Apr 16 2007 Kristian H淡gsberg <krh@hinata.boston.redhat.com> - 0.3.6-8
641- Update metacity build requires to metacity-devel.
642
643* Wed Apr  4 2007 Kristian H淡gsberg <krh@hinata.boston.redhat.com> - 0.3.6-7
644- Fix typo in ./configure option.
645
646* Wed Apr  4 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-6
647- Add place and clone plugins to default plugin list.
648
649* Wed Mar 28 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-5
650- Update URL (#208214).
651- Require at least metacity 2.18 (#232831).
652- Add close-session.patch to deregister from SM when replaced (#229113).
653
654* Tue Mar 27 2007 Kristian H淡gsberg <krh@redhat.com> 0.3.6-4
655- Explicitly disable KDE parts (#234128).
656
657* Mon Mar 26 2007 Matthias Clasen <mclasen@redhat.com> 0.3.6-3
658- Fix some directory ownership issues (#233825)
659- Small spec cleanups
660
661* Tue Feb  6 2007 Kristian H淡gsberg <krh@redhat.com> 0.3.6
662- Require gnome-session > 2.16 so it starts gtk-window-decorator.
663- Update to desktop-effects 0.7.1 that doesn't refuse to work with Xinerama.
664
665* Tue Jan 16 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-1
666- Update to 0.3.6, update patches.
667- Drop autotool build requires.
668- Drop glfinish.patch, cow.patch, resize-offset.patch and icon-menu-patch.
669- Add libdecoration.so
670- Update to desktop-effects-0.7.0, which spawns the right decorator
671  and plays nicely with unknown plugins.
672
673* Sat Nov 25 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.4-2
674- Update the fedora logo patch (#217224)
675
676* Thu Nov 23 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.4-1
677- Update to 0.3.4
678
679* Wed Nov 15 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.2-2
680- Use cow by default, bug 208044
681
682* Fri Nov 10 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
683- Update to 0.3.2
684- Drop upstreamed patches
685- Work with new metacity theme api
686
687* Mon Oct 2 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.32.20060818git.fc6
688- Install the .desktop file with desktop-file-install. Add X-Red-Hat-Base to make it appear in "Preferences", rather than "More Preferences".
689
690* Sat Sep 30 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.31.20060818git.fc6
691- Add buildrequires on intltool
692
693* Sat Sep 30 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.31.20060818git.fc6
694- Build
695
696* Fri Sep 29 2006 Soren Sandmann <sandmann@redhat.com>
697- Update to desktop-effects-0.6.163, which has translation enabled. (Bug 208257)
698
699* Thu Sep 28 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.30.20060817git.fc6
700- Add patch to terminate keyboard moves when a mouse buttons is pressed. (Bug 207792).
701
702* Thu Sep 28 2006 Soren Sandmann <sandmann@redhat.com>
703- Change default plugin list to not include the plane plugin. (Bug 208448).
704- Change default keybinding for shrink to be Pause (Bug 206187).
705
706* Wed Sep 27 2006 Soren Sandmann <sandmann@redhat.com>
707- Add patch to show a menu when the window icon is clicked. (Bug 201629).
708
709* Tue Sep 26 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.29.20060817git.fc6
710- Add restart.patch to make compiz ask the session manager to restart it
711  if it crashes (bug 200280).
712
713* Mon Sep 25 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.28.20060817git.fc6
714- Change plane.patch to not do cyclical window movement in dimensions
715  where the desktop has size 1 (bug 207263).
716
717* Thu Sep 21 2006 Soren Sandmann <sandmann@redhat.com>
718- Add patch to fix resizing smaller than minimum size (resize-offset.patch, bug 201623).
719
720* Tue Sep 19 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.27.20060817git.fc6
721- Change .plane patch to
722  (a) not set the background color to pink in the plane plugin.
723  (b) allow workspaces with horizontal sizes less then 4.
724
725* Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.26.20060817git.fc6
726- Change plane patch to correctly initialize the screen size to the
727  defaults (bug 206088).
728
729* Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com>
730- Run update-desktop-database and gtk-update-icon-cache in post. Add icons
731  to list of packaged files. Also bump to 0.6.137 of dialog (which just makes
732  directories before attempting to install to them).
733
734* Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com>
735- Upgrade to 0.6.107 of the desktop-effects dialog box. Only change is
736  that the new version has icons.
737
738* Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
739- Add patch to fix mispositioning of window decorator event windows (bug 201624)
740
741* Fri Sep 15 2006 Soren Sandmann <sandamnn@redhat.com>
742- Upgrade to version 0.6.83 of desktop-effects. (bug 206500)
743
744* Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
745- Add patch to only accept button 1 for close/minimize/maximize (bug 201628)
746
747* Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
748- Add patch to fix thumbnail sorting (bug 201605)
749
750* Thu Sep 14 2006 Soren Sandmann <sandmann@redhat.com>
751- Add patch to fix double clicking (bug 201783).
752
753* Tue Sep 12 2006 Soren Sandmann <sandmann@redhat.com>
754- Don't attempt to move the viewport when dx = dy = 0.(last bit of 206088).
755
756* Tue Sep 12 2006 Soren Sandmann <sandamnn@redhat.com>
757- Fix plane.patch to draw correctly when no timeout is running. (206088).
758
759* Wed Sep  6 2006 Kristian H淡gsberg <krh@redhat.com>
760- Update fbconfig-depth-fix.patch to also skip fbconfigs without
761  corresponding visuals.
762
763* Tue Sep 5 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.25.20060817git.fc6
764- Make number of vertical size configurable
765
766* Tue Sep 5 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.24.20060817git.fc6
767- Fix vertical viewport support in the plane patch.
768
769* Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.23.20060817git.fc6
770- Upgrade to 0.6.61 of the dialog
771
772* Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
773- Add libtool to BuildRequires
774
775* Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
776- Add automake and autoconf to BuildRequires
777
778* Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
779- Add a patch to put viewports on a plane.
780
781* Wed Aug 30 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.21.20060817git.fc6
782- Drop gl-include-inferiors.patch now that compiz uses COW and the X
783  server evicts offscreen pixmaps automatically on
784  GLX_EXT_texture_from_pixmap usage.
785
786* Tue Aug 29 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.20.20060817git.fc6
787- Add cow.patch to make compiz use the composite overlay window.
788
789* Fri Aug 25 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.19-20060817git.fc6
790- Rebase to desktop-effects 0.6.41
791
792* Fri Aug 25 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.18.20060817git.fc6
793- Rebase to desktop-effects 0.6.19 and drop
794  desktop-effects-0.6.1-delete-session.patch
795
796* Tue Aug 22 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.17.20060817git.fc6
797- Add patch from upstream to also use sync protocol for override
798  redirect windows (sync-override-redirect-windows.patch).
799
800* Thu Aug 17 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.16.20060817git.fc6
801- Rebase to latest upstream changes which has the rest of the bindings
802  rewrite.  Add resize-move-keybindings.patch to make move and resize
803  bindings work like metacity.
804- Add back scale plugin.
805
806* Thu Aug 10 2006 Ray Strode <rstrode@redhat.com> 0.0.13-0.15.20060721git.fc5.aiglx
807- Add Requires: gnome-session 2.15.90-2.fc6 (bug 201473)
808- unlink session file on changing wms (bug 201473)
809
810* Thu Aug  3 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.14.20060721git.fc5.aiglx
811- Add Requires: gnome-session 2.15.4-3
812
813* Wed Aug  3 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.13.20060721git.fc5.aiglx
814- New version of dialog box. Macro the version number.
815
816* Wed Aug  2 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.13.20060721git.fc5.aiglx
817- Add 'desktop effects' dialog box.
818
819* Mon Jul 31 2006 Kristian H淡gsberg <krh@redhat.com> 0.0.13-0.12.20060721git.fc5.aiglx
820- Add libwnck requires.
821
822* Wed Jul 26 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.11.20060721git.fc5.aiglx
823- Bump and build for fc5 AIGLX repo.
824
825* Wed Jul 26 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.12.20060721git
826- Fix gconf hooks.
827
828* Tue Jul 25 2006 Kristian H淡gsberg <krh@redhat.com>
829- Require system-logos instead.
830
831* Mon Jul 24 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.10.20060721git
832- Bump version to work around tagging weirdness.
833
834* Mon Jul 24 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.9.20060721git
835- Add devel package and require redhat-logos instead of fedora-logos (#199757).
836
837* Fri Jul 21 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.8.20060720git
838- Add workaround for AIGLX throttling problem.
839
840* Thu Jul 20 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.7.20060720git
841- Drop scale plugin from snapshot.
842
843* Tue Jul 18 2006 Matthias Clasen <mclasen@redhat.com> - 0.0.13-0.6.20060717git
844- Don't build on s390
845
846* Mon Jul 17 2006 Matthias Clasen <mclasen@redhat.com> - 0.0.13-0.5.20060717git
847- Do some changes forced upon us by package review
848
849* Thu Jul 13 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-5.1
850- Use sane numbering scheme.
851
852* Fri Jul  7 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-4
853- Drop the fullscreen hardcode patch and require X server that has
854  GLX_MESA_copy_sub_buffer.
855
856* Tue Jun 27 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-3
857- Unbreak --replace.
858
859* Thu Jun 15 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-2
860- Add Requires, fix start-compiz.sh.
861
862* Wed Jun 14 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-1
863- Spec file for compiz, borrowing bits and pieces from Alphonse Van
864  Assches spec file (#192432).
Note: See TracBrowser for help on using the repository browser.