source: projects/specs/trunk/c/compiz/compiz-vl.spec @ 2997

Revision 2997, 28.2 KB checked in by daisuke, 13 years ago (diff)

compiz:

  • rebuild with mesa-7.10.1
  • add cherry picked ubuntu patch
    • Patch1150: add --no-fbo option
    • Patch1200: disable GDK|GTK_DISABLE_DEPRECATED (to build with newer glib)
    • Patch1160: call glxwaitx before drawing
    • Patch1170: always unredirect screensaver on nvidia
    • Patch1490: damage report non empty
    • Patch1600: move check to compiz
  • add upstream patch
    • Patch2000: replace gdk_draw_drawable with cairo equivalents
    • Patch2010: fix pixmap size calculation


Line 
1# build with kde4
2%bcond_with kde
3
4%define         dialogversion   0.7.18
5%define         kde_dialogversion 0.0.5
6
7%define         core_plugins    blur clone commands cube dbus decoration fade ini inotify minimize move obs place png regex resize rotate scale screenshot switcher video water wobbly zoom fs
8
9%define         gnome_plugins   annotate gconf glib svg gnomecompat
10
11# List of plugins passed to ./configure.  The order is important
12
13%define         plugins         core,glib,gconf,dbus,png,svg,video,screenshot,decoration,clone,place,fade,minimize,move,resize,switcher,scale,wall
14
15Summary:        OpenGL window and compositing manager
16Summary(ja):    OpenGL ウィンドウ・コンポジットマネージャ
17Name:           compiz
18URL:            http://www.go-compiz.org
19License:        X11/MIT/GPL
20Group:          User Interface/Desktops
21Version:        0.8.6
22Release:        3%{?_dist_release}
23
24BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
25
26# libdrm is not available on these arches
27ExcludeArch:    s390 s390x ppc64
28
29Requires:       xorg-x11-server-Xorg
30Requires:       mesa-libGL
31
32Requires(post): desktop-file-utils
33
34BuildRequires:  libX11-devel, libdrm-devel, libwnck-devel
35BuildRequires:  libXfixes-devel, libXrandr-devel, libXrender-devel
36BuildRequires:  libXcomposite-devel, libXdamage-devel, libXext-devel
37BuildRequires:  libXt-devel, libXmu-devel, libICE-devel, libSM-devel
38BuildRequires:  control-center-devel, GConf2-devel
39BuildRequires:  gnome-desktop-devel >= 2.30.0
40BuildRequires:  metacity-devel
41BuildRequires:  desktop-file-utils
42BuildRequires:  intltool >= 0.35
43BuildRequires:  gettext
44BuildRequires:  dbus-devel
45BuildRequires:  librsvg2-devel
46BuildRequires:  mesa-libGLU-devel
47BuildRequires:  fuse-devel
48%if %{with kde}
49BuildRequires:  kdebase-workspace-devel
50BUildRequires:  dbus-qt-devel
51%endif
52
53Source0:        http://releases.compiz.org/%{version}/%{name}-%{version}.tar.bz2
54Source1:        desktop-effects-%{dialogversion}.tar.bz2
55Source2:        kde-desktop-effects-%{kde_dialogversion}.tar.bz2
56
57Source3:        compiz-gtk
58Source4:        compiz-gtk.desktop
59
60# Make sure that former beryl users still have bling
61Obsoletes: beryl-core
62
63# Patches from fedora
64Patch102: desktop-effects-0.7.17-wall-plugin.patch
65Patch103: composite-cube-logo.patch
66Patch111: gconf-core-plugin-loopfix.patch
67
68# Make sure configuration plugins never get unloaded
69Patch123: compiz-0.7.8-pin-initial-plugins.patch
70
71# Patches from ubuntu
72Patch1140: 014-fix-gtk-window-decorator-no-argb-crash.patch
73Patch1150: 015_optional-fbo.patch
74Patch1160: 016_call_glxwaitx_before_drawing.patch
75Patch1170: 017_always_unredirect_screensaver_on_nvidia.patch
76Patch1200: 020_disable_gdk_gtk_disable_deprecated.patch
77Patch1490: 049-damage-report-non-empty.patch
78Patch1600: 060_move_checks_to_compiz.patch
79
80# Patches from upstream
81Patch2000: compiz-0.8.6-replace-gdk_draw_drawable-with-cairo-equiv.patch
82Patch2010: compiz-0.8.6-fix-pixmap-size-calculation.patch
83
84%description
85Compiz is one of the first OpenGL-accelerated compositing window
86managers for the X Window System. The integration allows it to perform
87compositing effects in window management, such as a minimization
88effect and a cube workspace.  Compiz is an OpenGL compositing manager
89that use Compiz use EXT_texture_from_pixmap OpenGL extension for
90binding redirected top-level windows to texture objects.
91
92%package devel
93Summary: Development packages for compiz
94Summary(ja): compiz の開発パッケージ
95Group: Development/Libraries
96Requires: compiz = %{version}-%{release}
97Requires: pkgconfig
98Requires: libXcomposite-devel libXfixes-devel libXdamage-devel libXrandr-devel
99Requires: libXinerama-devel libICE-devel libSM-devel libxml2-devel
100Requires: libxslt-devel startup-notification-devel
101
102%description devel
103The compiz-devel package includes the header files,
104and developer docs for the compiz package.
105
106Install compiz-devel if you want to develop plugins for the compiz
107windows and compositing manager.
108
109%package gnome
110Summary: Compiz gnome integration bits
111Summary(ja): Compiz gnome integration bits
112Group: User Interface/Desktops
113Requires: gnome-session
114Requires: metacity
115Requires: libwnck
116Requires: glx-utils
117Requires: %{name} = %{version}
118Requires(pre): GConf2
119Requires(post): GConf2
120Requires(preun): GConf2
121Obsoletes: compiz < 0.5.2-8
122Obsoletes: beryl-gnome
123
124%description gnome
125The compiz-gnome package contains gtk-window-decorator,
126and other gnome integration related stuff.
127
128%if %{with kde}
129%package kde
130Summary: Compiz kde integration bits
131Summary(ja): Compiz kde integration bits
132Group: User Interface/Desktops
133Requires: %{name} = %{version}
134Requires: compiz-manager
135Obsoletes: beryl-kde
136
137%description kde
138The compiz-kde package contains kde-window-decorator,
139and other kde integration related stuff.
140%endif
141
142%prep
143%setup -q -T -b1 -n desktop-effects-%{dialogversion}
144#%setup -q -T -b2 -n kde-desktop-effects-%{kde_dialogversion}
145%setup -q
146
147pushd ../desktop-effects-%{dialogversion}
148%patch102 -p1 -b .wall-plugin
149popd
150
151%patch103 -p1 -b .composite-cube-logo
152%patch111 -p1 -b .gconf-core-loop
153
154## %patch123 -p1 -b .initial-plugins
155
156# ubuntu patch
157%patch1140 -p1 -b .fix-gtk-window-decorator-no-argb-crash
158%patch1150 -p1 -b .disable-fbo
159%patch1160 -p1 -b .call_glxwaitx_before_drawing
160%patch1170 -p1 -b .always_unredirect_screensaver_on_nvidia
161%patch1200 -p1 -b .disable_gdk_gtk_disable_deprecated
162%patch1490 -p1 -b .damage-report-non-empty
163%patch1600 -p1 -b .move-check-to-compiz
164
165# upstream patch
166%patch2000 -p1 -b .replace-gdk_draw_drawable-with-cairo-equiv
167%patch2010 -p1 -b .fix-pixmap-size-calculation
168%build
169rm -rf $RPM_BUILD_ROOT
170
171CPPFLAGS="$CPPFLAGS -I$RPM_BUILD_ROOT%{_includedir}"
172export CPPFLAGS
173
174#needed to find kde4 libs
175#LDFLAGS="$LDFLAGS -L%{_libdir}/kde4/devel"
176#export LDFLAGS
177
178libtoolize
179autoreconf
180%configure                                      \
181%{?with_kde: --enable-kde4 }                    \
182%{!?with_kde: --disable-kde4 }                  \
183        --disable-kde                           \
184        --enable-gconf                          \
185        --enable-dbus                           \
186        --enable-place                          \
187        --enable-librsvg                        \
188        --enable-gtk                            \
189        --enable-metacity                       \
190        --enable-gnome                          \
191        --with-default-plugins=%{plugins}       \
192        --enable-gnome-keybindings           
193
194
195make %{?_smp_mflags} imagedir=%{_datadir}/pixmaps
196
197# desktop-effects
198cd ../desktop-effects-%{dialogversion}
199%configure
200
201
202%install
203rm -rf $RPM_BUILD_ROOT
204export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
205make DESTDIR=$RPM_BUILD_ROOT install || exit 1
206unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
207
208echo INSTALLING DESKTOP EFFECTS
209pushd ../desktop-effects-%{dialogversion}
210make DESTDIR=$RPM_BUILD_ROOT install || exit 1
211#desktop-file-install --vendor vine --delete-original      \
212#  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
213#  $RPM_BUILD_ROOT%{_datadir}/applications/desktop-effects.desktop
214rm -f $RPM_BUILD_ROOT%{_datadir}/applications/desktop-effects.desktop
215popd
216
217# install compiz-gtk/compiz-gtk.desktop
218install %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}
219
220desktop-file-install --vendor="" \
221  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
222  %{SOURCE4}
223   
224
225%if %{with kde}
226# kde-desktop-effects
227echo INSTALLING KDE DESKTOP EFFECTS
228pushd ../kde-desktop-effects-%{kde_dialogversion}
229cp -a kde-desktop-effects.sh $RPM_BUILD_ROOT/%{_bindir}/
230mkdir -p $RPM_BUILD_ROOT/%{_docdir}/compiz-kde-%{version}
231cp -a ChangeLog COPYING README $RPM_BUILD_ROOT/%{_docdir}/compiz-kde-%{version}
232
233iconlist="16 24 32 36 48 96"
234for i in $iconlist; do
235 mkdir -p $RPM_BUILD_ROOT/%{_datadir}/icons/hicolor/$i\x$i/apps/
236 cp -p ../desktop-effects-%{dialogversion}/desktop-effects$i.png $RPM_BUILD_ROOT/%{_datadir}/icons/hicolor/$i\x$i/apps/kde-desktop-effects.png
237done
238
239desktop-file-install --vendor=""           \
240  --dir=%{buildroot}%{_datadir}/applications/kde       \
241  kde-desktop-effects.desktop
242popd
243%endif
244
245%if !%{with kde}
246rm -f $RPM_BUILD_ROOT%{_datadir}/compiz/kconfig.xml
247%endif
248
249
250find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
251find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} ';'
252
253
254%find_lang compiz
255%find_lang desktop-effects
256
257cat compiz.lang > core-files.txt
258cat desktop-effects.lang > gnome-files.txt
259
260for f in %{core_plugins}; do
261  echo %{_libdir}/compiz/lib$f.so
262  echo %{_datadir}/compiz/$f.xml
263done >> core-files.txt
264
265for f in %{gnome_plugins}; do
266  echo %{_libdir}/compiz/lib$f.so
267  echo %{_datadir}/compiz/$f.xml
268done >> gnome-files.txt
269
270
271%post -p /sbin/ldconfig
272
273%postun -p /sbin/ldconfig
274
275%post gnome
276update-desktop-database -q %{_datadir}/applications
277
278export GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source`
279for f in %{core_plugins} %{gnome_plugins} core; do
280  echo %{_sysconfdir}/gconf/schemas/compiz-${f}.schemas; done \
281  | xargs gconftool-2 --makefile-install-rule >& /dev/null || :
282
283gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/gwd.schemas >& /dev/null || :
284
285touch --no-create %{_datadir}/icons/hicolor
286if [ -x /usr/bin/gtk-update-icon-cache ]; then
287        /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
288fi
289
290
291%pre gnome
292if [ "$1" -gt 1 ]; then
293  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
294  for f in %{core_plugins} %{gnome_plugins} core; do
295    echo %{_sysconfdir}/gconf/schemas/compiz-${f}.schemas; done \
296    | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null || :
297
298  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gwd.schemas >& /dev/null || :
299fi
300
301
302%preun gnome
303if [ "$1" -eq 0 ]; then
304  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
305  for f in %{core_plugins} %{gnome_plugins} core; do
306    echo %{_sysconfdir}/gconf/schemas/compiz-${f}.schemas; done \
307    | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null || :
308
309  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gwd.schemas >& /dev/null || :
310fi
311
312
313%postun gnome
314touch --no-create %{_datadir}/icons/hicolor
315if [ -x /usr/bin/gtk-update-icon-cache ]; then
316        /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
317fi
318
319%if %{with kde}
320%post kde
321update-desktop-database -q %{_datadir}/applications/kde
322touch --no-create %{_datadir}/icons/hicolor
323
324%postun kde
325touch --no-create %{_datadir}/icons/hicolor
326%endif
327
328%clean
329rm -rf $RPM_BUILD_ROOT
330
331
332%files -f core-files.txt
333%defattr(-, root, root)
334%doc AUTHORS ChangeLog COPYING* README TODO
335%{_bindir}/compiz
336%{_libdir}/libdecoration.so.*
337%dir %{_libdir}/compiz
338%dir %{_datadir}/compiz
339%{_datadir}/compiz/*.png
340%{_datadir}/compiz/core.xml
341
342
343%files gnome -f gnome-files.txt
344%defattr(-, root, root)
345%{_bindir}/gtk-window-decorator
346%{_bindir}/compiz-gtk
347%{_bindir}/desktop-effects
348%{_libdir}/window-manager-settings/libcompiz.so
349%{_datadir}/gnome/wm-properties/compiz-wm.desktop
350%{_datadir}/applications/compiz.desktop
351%{_datadir}/gnome-control-center/keybindings/50-compiz-desktop-key.xml
352%{_datadir}/gnome-control-center/keybindings/50-compiz-key.xml
353%{_datadir}/compiz/desktop-effects.glade
354%{_datadir}/applications/compiz-gtk.desktop
355#{_datadir}/applications/vine-desktop-effects.desktop
356%{_datadir}/icons/hicolor/16x16/apps/desktop-effects.png
357%{_datadir}/icons/hicolor/24x24/apps/desktop-effects.png
358%{_datadir}/icons/hicolor/32x32/apps/desktop-effects.png
359%{_datadir}/icons/hicolor/36x36/apps/desktop-effects.png
360%{_datadir}/icons/hicolor/48x48/apps/desktop-effects.png
361%{_datadir}/icons/hicolor/96x96/apps/desktop-effects.png
362%{_sysconfdir}/gconf/schemas/*.schemas
363
364%if %{with kde}
365%files kde
366%defattr(-, root, root)
367%{_bindir}/kde4-window-decorator
368%{_docdir}/compiz-kde-%{version}
369%{_bindir}/kde-desktop-effects.sh
370%{_datadir}/applications/kde/kde-desktop-effects.desktop
371%{_datadir}/icons/hicolor/*/apps/kde-desktop-effects.png
372%{_datadir}/compiz/kconfig.xml
373%endif
374
375%files devel
376%defattr(-, root, root)
377%{_libdir}/pkgconfig/compiz.pc
378%{_libdir}/pkgconfig/libdecoration.pc
379%{_libdir}/pkgconfig/compiz-cube.pc
380%{_libdir}/pkgconfig/compiz-gconf.pc
381%{_libdir}/pkgconfig/compiz-scale.pc
382%{_datadir}/compiz/schemas.xslt
383%{_includedir}/compiz
384%{_libdir}/libdecoration.so
385
386
387%changelog
388* Sat Mar 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.6-3
389- rebuild with mesa-7.10.1
390- add cherry picked ubuntu patch
391  - Patch1150: add --no-fbo option
392  - Patch1200: disable GDK|GTK_DISABLE_DEPRECATED
393  - Patch1160: call glxwaitx before drawing
394  - Patch1170: always unredirect screensaver on nvidia
395  - Patch1490: damage report non empty
396  - Patch1600: move check to compiz
397- add upstream patch
398  - Patch2000: replace gdk_draw_drawable with cairo equivalents
399  - Patch2010: fix pixmap size calculation
400
401* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.6-2
402- rebuild with rpm-4.8.1 for pkg-config file
403
404* Sat Apr 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.6-1
405- new upstream release (build on GNOME-2.30)
406- drop Patch123, Patch300
407
408* Sat Nov 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-4
409- rebuild with mesa-7.6
410- add Patch300 to build with gconf-2.28
411
412* Thu Jun 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-3
413- disable glib plugin in compiz-gtk
414- use direct rendering on virtualbox video adaptor.
415
416* Tue May 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-2
417- add Requires: glx-utils to compiz-gnome
418
419* Mon May 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-1
420- new upstream release
421
422* Sun May 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-8
423- re-enable metacity decoration on gtk-window-decorator
424  - BR: metacity-devel instead of metacity
425
426* Fri May 01 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.7.8-7
427- fix pre/post scripts for speeding up gconf schema installation
428
429* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-6
430- add ccp compiz option to compiz-gtk
431
432* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-5
433- remove desktop-effect.desktop
434  - we use gnome-appearance-properties integrated version.
435
436* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-4
437- add Patch121,122 from upstream fix.
438- add Patch123: make sure configuration plugins never get unloaded
439- add Patch124: memleak fix from upstream
440- add Patch125: make the terminal keybind work
441- add Patch120,126,127 for kde42
442- add Patch128: gwd fix from upstream
443
444* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-3
445- rebuild with gnome-desktop-2.26.0
446
447* Wed Oct 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-2
448- add compiz-gtk scripts and desktop file from fedora
449
450* Thu Oct 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-1
451- new upstream release
452
453* Wed Jun 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.6-2
454- rebuild with gnome-desktop-2.24.0
455
456* Wed Jun 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.6-1
457- new upstream release
458
459* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.4-1
460- new upstream release
461
462* Sat May 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.2-1
463- initial build for Vine Linux
464
465* Thu Mar 27 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.7.2-3
466- Fix gconf plugin loop RH #438794, patch based on
467  older one from Guillaume Seguin
468- Add core to default plugin list
469
470* Wed Mar 26 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.7.2-2
471- Reword kde-desktop-effects messages to mention Compiz by name (#438883)
472
473* Mon Mar 24 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.7.2-1
474- Update to 0.7.2
475
476* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.6.2-7
477- Autorebuild for GCC 4.3
478
479* Thu Jan 17 2008 Kristian H淡gsberg <krh@redhat.com> - 0.6.2-6
480- Update to desktop-effects version 0.7.17 which include more
481  translations and move desktop-effects translations to compiz-gnome.
482- Fix spelling in beryl-core obsoletes.
483
484* Mon Jan 07 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.6.2-5
485- Update buildrequires (kwd uses the kde3 api)
486
487* Tue Nov  6 2007 Stepan Kasal <skasal@redhat.com> - 0.6.2-4
488- Fix a typo in description of the main package.
489- All descriptions should end with a dot (unlike the summary line)
490
491* Thu Oct 25 2007 Sebastian Vahl <fedora@deadbabylon.de> - 0.6.2-3
492- Include kde-desktop-effects in kde subpackage
493
494* Tue Oct 23 2007 Adel Gadllah <adel.gadllah@gmail.com> - 0.6.2-2
495- Obsolete berly-core
496
497* Mon Oct 22 2007 Warren Togami <wtogami@redhat.com> - 0.6.2-1
498- 0.6.2
499
500* Fri Oct 12 2007 Kristian H淡gsberg <krh@redhat.com> - 0.6.0-2
501- Disable scale corner initiate and install a GNOME key config entry.
502
503* Wed Oct 10 2007 Warren Togami <wtogami@redhat.com> - 0.6.0-1
504- 0.6.0 final
505- always-restack-windows-on-map
506
507* Tue Oct  9 2007 Warren Togami <wtogami@redhat.com> - 0.5.2-14
508- Make compiz behave with gnome-terminal (#304051)
509
510* Fri Oct  5 2007 Matthias Clasen <mclasen@redhat.com> - 0.5.2-13
511- Also install gwd.schemas (#319621)
512
513* Thu Sep 20 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-12
514- Update to more recent 0.6 branch snapshot (fixes #253575).
515
516* Fri Sep 14 2007 Warren Togami <wtogami@redhat.com> - 0.5.2-11
517- compiz-gnome: install core schema so it actually works
518- remove unnecessary gconf stuff from %%install
519
520* Tue Aug 28 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-9
521- Make compiz-gnome Obsolete the older compiz package so yum/anaconda
522  will pull it in (thans to Adel Gadllah).
523
524* Wed Aug 22 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-8
525- Bump to desktop-effects 0.7.7 to avoid kill decorator when popping
526  up dialog.
527- Fix broken gconf install and uninstall rules.
528- Pick up shadowman logo for RHEL builds (#232398).
529
530* Tue Aug 21 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-7.0ec3ec
531- Add more-sm-junk.patch so we set SM restart style to
532  SmRestartIfRunning on exit (#247163, #245971).
533- Add Requires to compiz-devel (#253407).
534- Update to desktop-effects 0.7.6, which terminates decorator when
535  switching to metacity or on compiz failure (#215247, #215032).
536
537* Fri Aug 17 2007 Adel Gadllah <adel.gadllah@gmail.com> 0.5.2-6.0ec3ec
538- Split into gnome and kde subpackages
539- Minor cleanups
540
541* Wed Aug 15 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-5.0ec3ec
542- Reorder plugin list to avoid 'place' getting removed on startup.
543- Add run-command-key.patch to put the run command key in the GNOME
544  keyboard shortcut dialog (#213576).
545- Drop a bunch of obsolete patches.
546- Bump mesa-libGL and X server requires to fix TFP bugs for
547  power-of-two textures (#251935).
548- Rebase fedora-logo and composite-cube-logo patch.
549
550* Tue Aug 14 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-4.0ec3ec
551- Build with desktop-effects so we don't pick up metacity work spaces.
552  Fixes #250568.
553
554* Tue Aug 14 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-3.0ec3ec
555- Build git snapshot from fedora branch at
556  git://people.freedesktop.org/~krh/compiz, brances from 0.6 upstream
557  branch.
558- Fixes #237486.
559
560* Fri Aug 10 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-3
561- Require desktop-effects 0.7.3 and gnome-session 2.19.6-5 which pass
562  'glib' on the command line too.
563
564* Fri Aug 10 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-2
565- Move xml meta data files to main package.
566
567* Thu Aug  9 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-1
568- Update to 0.5.2.
569- Require at least gnome-session 2.19.6-2 so gnome-wm starts compiz
570  with LIBGL_ALWAYS_INDIRECT set.
571
572* Wed Jun 27 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.0-1
573- Update to 0.5.0
574
575* Tue Jun  5 2007 Matthias Clasen <mclasen@redhat.com> - 0.4.0-1
576- Update to 0.4.0
577
578* Mon Jun  4 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.6-10
579- Rebuild against new libwnck
580
581* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.6-9
582- Don't install INSTALL
583
584* Mon Apr 16 2007 Kristian H淡gsberg <krh@hinata.boston.redhat.com> - 0.3.6-8
585- Update metacity build requires to metacity-devel.
586
587* Wed Apr  4 2007 Kristian H淡gsberg <krh@hinata.boston.redhat.com> - 0.3.6-7
588- Fix typo in ./configure option.
589
590* Wed Apr  4 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-6
591- Add place and clone plugins to default plugin list.
592
593* Wed Mar 28 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-5
594- Update URL (#208214).
595- Require at least metacity 2.18 (#232831).
596- Add close-session.patch to deregister from SM when replaced (#229113).
597
598* Tue Mar 27 2007 Kristian H淡gsberg <krh@redhat.com> 0.3.6-4
599- Explicitly disable KDE parts (#234128).
600
601* Mon Mar 26 2007 Matthias Clasen <mclasen@redhat.com> 0.3.6-3
602- Fix some directory ownership issues (#233825)
603- Small spec cleanups
604
605* Tue Feb  6 2007 Kristian H淡gsberg <krh@redhat.com> 0.3.6
606- Require gnome-session > 2.16 so it starts gtk-window-decorator.
607- Update to desktop-effects 0.7.1 that doesn't refuse to work with Xinerama.
608
609* Tue Jan 16 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-1
610- Update to 0.3.6, update patches.
611- Drop autotool build requires.
612- Drop glfinish.patch, cow.patch, resize-offset.patch and icon-menu-patch.
613- Add libdecoration.so
614- Update to desktop-effects-0.7.0, which spawns the right decorator
615  and plays nicely with unknown plugins.
616
617* Sat Nov 25 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.4-2
618- Update the fedora logo patch (#217224)
619
620* Thu Nov 23 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.4-1
621- Update to 0.3.4
622
623* Wed Nov 15 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.2-2
624- Use cow by default, bug 208044
625
626* Fri Nov 10 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
627- Update to 0.3.2
628- Drop upstreamed patches
629- Work with new metacity theme api
630
631* Mon Oct 2 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.32.20060818git.fc6
632- Install the .desktop file with desktop-file-install. Add X-Red-Hat-Base to make it appear in "Preferences", rather than "More Preferences".
633
634* Sat Sep 30 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.31.20060818git.fc6
635- Add buildrequires on intltool
636
637* Sat Sep 30 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.31.20060818git.fc6
638- Build
639
640* Fri Sep 29 2006 Soren Sandmann <sandmann@redhat.com>
641- Update to desktop-effects-0.6.163, which has translation enabled. (Bug 208257)
642
643* Thu Sep 28 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.30.20060817git.fc6
644- Add patch to terminate keyboard moves when a mouse buttons is pressed. (Bug 207792).
645
646* Thu Sep 28 2006 Soren Sandmann <sandmann@redhat.com>
647- Change default plugin list to not include the plane plugin. (Bug 208448).
648- Change default keybinding for shrink to be Pause (Bug 206187).
649
650* Wed Sep 27 2006 Soren Sandmann <sandmann@redhat.com>
651- Add patch to show a menu when the window icon is clicked. (Bug 201629).
652
653* Tue Sep 26 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.29.20060817git.fc6
654- Add restart.patch to make compiz ask the session manager to restart it
655  if it crashes (bug 200280).
656
657* Mon Sep 25 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.28.20060817git.fc6
658- Change plane.patch to not do cyclical window movement in dimensions
659  where the desktop has size 1 (bug 207263).
660
661* Thu Sep 21 2006 Soren Sandmann <sandmann@redhat.com>
662- Add patch to fix resizing smaller than minimum size (resize-offset.patch, bug 201623).
663
664* Tue Sep 19 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.27.20060817git.fc6
665- Change .plane patch to
666  (a) not set the background color to pink in the plane plugin.
667  (b) allow workspaces with horizontal sizes less then 4.
668
669* Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.26.20060817git.fc6
670- Change plane patch to correctly initialize the screen size to the
671  defaults (bug 206088).
672
673* Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com>
674- Run update-desktop-database and gtk-update-icon-cache in post. Add icons
675  to list of packaged files. Also bump to 0.6.137 of dialog (which just makes
676  directories before attempting to install to them).
677
678* Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com>
679- Upgrade to 0.6.107 of the desktop-effects dialog box. Only change is
680  that the new version has icons.
681
682* Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
683- Add patch to fix mispositioning of window decorator event windows (bug 201624)
684
685* Fri Sep 15 2006 Soren Sandmann <sandamnn@redhat.com>
686- Upgrade to version 0.6.83 of desktop-effects. (bug 206500)
687
688* Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
689- Add patch to only accept button 1 for close/minimize/maximize (bug 201628)
690
691* Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
692- Add patch to fix thumbnail sorting (bug 201605)
693
694* Thu Sep 14 2006 Soren Sandmann <sandmann@redhat.com>
695- Add patch to fix double clicking (bug 201783).
696
697* Tue Sep 12 2006 Soren Sandmann <sandmann@redhat.com>
698- Don't attempt to move the viewport when dx = dy = 0.(last bit of 206088).
699
700* Tue Sep 12 2006 Soren Sandmann <sandamnn@redhat.com>
701- Fix plane.patch to draw correctly when no timeout is running. (206088).
702
703* Wed Sep  6 2006 Kristian H淡gsberg <krh@redhat.com>
704- Update fbconfig-depth-fix.patch to also skip fbconfigs without
705  corresponding visuals.
706
707* Tue Sep 5 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.25.20060817git.fc6
708- Make number of vertical size configurable
709
710* Tue Sep 5 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.24.20060817git.fc6
711- Fix vertical viewport support in the plane patch.
712
713* Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.23.20060817git.fc6
714- Upgrade to 0.6.61 of the dialog
715
716* Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
717- Add libtool to BuildRequires
718
719* Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
720- Add automake and autoconf to BuildRequires
721
722* Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
723- Add a patch to put viewports on a plane.
724
725* Wed Aug 30 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.21.20060817git.fc6
726- Drop gl-include-inferiors.patch now that compiz uses COW and the X
727  server evicts offscreen pixmaps automatically on
728  GLX_EXT_texture_from_pixmap usage.
729
730* Tue Aug 29 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.20.20060817git.fc6
731- Add cow.patch to make compiz use the composite overlay window.
732
733* Fri Aug 25 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.19-20060817git.fc6
734- Rebase to desktop-effects 0.6.41
735
736* Fri Aug 25 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.18.20060817git.fc6
737- Rebase to desktop-effects 0.6.19 and drop
738  desktop-effects-0.6.1-delete-session.patch
739
740* Tue Aug 22 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.17.20060817git.fc6
741- Add patch from upstream to also use sync protocol for override
742  redirect windows (sync-override-redirect-windows.patch).
743
744* Thu Aug 17 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.16.20060817git.fc6
745- Rebase to latest upstream changes which has the rest of the bindings
746  rewrite.  Add resize-move-keybindings.patch to make move and resize
747  bindings work like metacity.
748- Add back scale plugin.
749
750* Thu Aug 10 2006 Ray Strode <rstrode@redhat.com> 0.0.13-0.15.20060721git.fc5.aiglx
751- Add Requires: gnome-session 2.15.90-2.fc6 (bug 201473)
752- unlink session file on changing wms (bug 201473)
753
754* Thu Aug  3 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.14.20060721git.fc5.aiglx
755- Add Requires: gnome-session 2.15.4-3
756
757* Wed Aug  3 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.13.20060721git.fc5.aiglx
758- New version of dialog box. Macro the version number.
759
760* Wed Aug  2 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.13.20060721git.fc5.aiglx
761- Add 'desktop effects' dialog box.
762
763* Mon Jul 31 2006 Kristian H淡gsberg <krh@redhat.com> 0.0.13-0.12.20060721git.fc5.aiglx
764- Add libwnck requires.
765
766* Wed Jul 26 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.11.20060721git.fc5.aiglx
767- Bump and build for fc5 AIGLX repo.
768
769* Wed Jul 26 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.12.20060721git
770- Fix gconf hooks.
771
772* Tue Jul 25 2006 Kristian H淡gsberg <krh@redhat.com>
773- Require system-logos instead.
774
775* Mon Jul 24 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.10.20060721git
776- Bump version to work around tagging weirdness.
777
778* Mon Jul 24 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.9.20060721git
779- Add devel package and require redhat-logos instead of fedora-logos (#199757).
780
781* Fri Jul 21 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.8.20060720git
782- Add workaround for AIGLX throttling problem.
783
784* Thu Jul 20 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.7.20060720git
785- Drop scale plugin from snapshot.
786
787* Tue Jul 18 2006 Matthias Clasen <mclasen@redhat.com> - 0.0.13-0.6.20060717git
788- Don't build on s390
789
790* Mon Jul 17 2006 Matthias Clasen <mclasen@redhat.com> - 0.0.13-0.5.20060717git
791- Do some changes forced upon us by package review
792
793* Thu Jul 13 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-5.1
794- Use sane numbering scheme.
795
796* Fri Jul  7 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-4
797- Drop the fullscreen hardcode patch and require X server that has
798  GLX_MESA_copy_sub_buffer.
799
800* Tue Jun 27 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-3
801- Unbreak --replace.
802
803* Thu Jun 15 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-2
804- Add Requires, fix start-compiz.sh.
805
806* Wed Jun 14 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-1
807- Spec file for compiz, borrowing bits and pieces from Alphonse Van
808  Assches spec file (#192432).
Note: See TracBrowser for help on using the repository browser.