source: projects/specs/trunk/c/cmake/cmake-vl.spec @ 1643

Revision 1643, 4.6 KB checked in by Takemikaduchi, 14 years ago (diff)

add BuildRequires?

Line 
1# Set to bcond_with or use --without gui to disable qt4 gui build
2%bcond_without gui
3
4Name: cmake
5Summary: Cross-platform make system
6Summary(ja): クロスプラットフォームな Make システム
7Version: 2.8.2
8Release: 3%{?_dist_release}
9
10Group: Development/Tools
11License: BSD
12URL: http://www.cmake.org/
13
14Source0: http://www.cmake.org/files/v2.8/%{name}-%{version}.tar.gz
15Source1: macros.cmake
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18
19BuildRequires: ncurses-devel
20%if %{with gui}
21BuildRequires: qt4-devel, desktop-file-utils
22%define qt_gui --qt-gui
23%endif
24
25Vendor: Project Vine
26Distribution: Vine Linux
27
28%description
29CMake is used to control the software compilation process using simple
30platform and compiler independent configuration files. CMake generates
31native makefiles and workspaces that can be used in the compiler
32environment of your choice. CMake is quite sophisticated: it is possible
33to support complex environments requiring system configuration, pre-processor
34generation, code generation, and template instantiation.
35
36%package        gui
37Summary:        Qt GUI for %{name}
38Group:          Development/Tools
39Requires:       %{name} = %{version}-%{release}
40Requires(post): desktop-file-utils, shared-mime-info
41Requires(postun): desktop-file-utils, shared-mime-info
42
43%description    gui
44The %{name}-gui package contains the Qt based GUI for CMake.
45
46
47%prep
48%setup -q
49# Fixup permissions
50find -name \*.h -o -name \*.cxx -print0 | xargs -0 chmod -x
51
52%build
53./bootstrap --prefix=%{_prefix} --datadir=/share/%{name} \
54    --mandir=/share/man --with-system-libs %{?qt_gui}
55make VERBOSE=1 %{?_smp_mflags}
56
57%install
58rm -rf $RPM_BUILD_ROOT
59make install DESTDIR=$RPM_BUILD_ROOT
60
61find $RPM_BUILD_ROOT/%{_datadir}/%{name}/Modules -type f | xargs chmod -x
62rm -rf $RPM_BUILD_ROOT/usr/doc
63
64# RPM macros
65install -p -m0644 -D %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
66sed -i -e "s|@@CMAKE_VERSION@@|%{version}|" $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
67touch -r %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
68
69%if %{with gui}
70# Desktop file
71desktop-file-install --delete-original \
72  --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
73  $RPM_BUILD_ROOT/%{_datadir}/applications/CMake.desktop
74%endif
75
76
77%clean
78rm -rf $RPM_BUILD_ROOT
79
80%if %{with gui}
81%post gui
82update-desktop-database &> /dev/null || :
83update-mime-database %{_datadir}/mime &> /dev/null || :
84
85%postun gui
86update-desktop-database &> /dev/null || :
87update-mime-database %{_datadir}/mime &> /dev/null || :
88%endif
89
90
91%files
92%defattr(-,root,root)
93%doc CMakeLogo.gif ChangeLog.* Copyright.txt
94%doc Docs/*
95%doc Example/
96%config(noreplace) %{_sysconfdir}/rpm/macros.cmake
97%{_bindir}/ccmake
98%{_bindir}/cmake
99%{_bindir}/cpack
100%{_bindir}/ctest
101%{_datadir}/%{name}/
102%{_mandir}/man1/*
103
104%if %{with gui}
105%files gui
106%defattr(-,root,root,-)
107%{_bindir}/cmake-gui
108%{_datadir}/applications/CMake.desktop
109%{_datadir}/mime/packages/cmakecache.xml
110%{_datadir}/pixmaps/CMakeSetup32.png
111%endif
112
113
114%changelog
115* Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.2-3
116- add BuildRequires: ncurses-devel
117
118* Sun Aug 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-2
119- generate gui package
120- renamed module directory
121
122* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-1
123- new upstream release
124
125* Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-3
126- rebuilt with new toolchain
127
128* Sun Aug 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.4-2
129- imported RPM macros from Fedora (cmake-2.6.4-3.fc12)
130
131* Tue Aug 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.4-1
132- new upstream release
133- added Vendor/Distribution tag
134
135* Wed Mar 25 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.3-1
136- new upstream release
137
138* Tue Oct 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.2-1
139- new upstream release
140
141* Sat Mar 29 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.8-1
142- new upstream release
143
144* Wed Aug 15 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.7-0vl1
145- new upstream release
146
147* Mon May 14 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.6-0vl1
148- new upstream release
149- drop Patch100
150- use bootstrap script instead of configure
151- delete caches from %%doc
152
153* Sat May 12 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.3-0vl2
154- rebuilt with new toolchain
155
156* Tue Oct 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.3-0vl1
157- new upstream release
158- delete duped docs
159
160* Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.3-0vl2
161- added Patch100 (especially for ppc to solve ppc/powerpc issue)
162
163* Mon Feb 06 2006 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.2.3-0vl1
164- source version up
165
166* Sun Mar 20 2005 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.0.5-0vl1
167- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.