source: projects/specs/trunk/c/cmake/cmake-vl.spec @ 1777

Revision 1777, 4.9 KB checked in by inagaki, 14 years ago (diff)

update: cmake, digikam

RevLine 
[1640]1# Set to bcond_with or use --without gui to disable qt4 gui build
2%bcond_without gui
3
[1442]4Name: cmake
[521]5Summary: Cross-platform make system
[1640]6Summary(ja): クロスプラットフォームな Make システム
[1442]7Version: 2.8.2
[1777]8Release: 4%{?_dist_release}
[521]9
10Group: Development/Tools
[1640]11License: BSD
[521]12URL: http://www.cmake.org/
13
[1442]14Source0: http://www.cmake.org/files/v2.8/%{name}-%{version}.tar.gz
15Source1: macros.cmake
16
[521]17BuildRoot: %{_tmppath}/%{name}-%{version}-root
[1777]18BuildRequires: curl-devel
19BuildRequires: expat-devel
[1643]20BuildRequires: ncurses-devel
[1777]21BuildRequires: zlib-devel
[1640]22%if %{with gui}
23BuildRequires: qt4-devel, desktop-file-utils
24%define qt_gui --qt-gui
[1777]25%else
26%define qt_gui --no-qt-gui
[1640]27%endif
[521]28
29Vendor: Project Vine
30Distribution: Vine Linux
31
32%description
33CMake is used to control the software compilation process using simple
34platform and compiler independent configuration files. CMake generates
35native makefiles and workspaces that can be used in the compiler
36environment of your choice. CMake is quite sophisticated: it is possible
37to support complex environments requiring system configuration, pre-processor
38generation, code generation, and template instantiation.
39
[1640]40%package        gui
41Summary:        Qt GUI for %{name}
42Group:          Development/Tools
43Requires:       %{name} = %{version}-%{release}
44Requires(post): desktop-file-utils, shared-mime-info
45Requires(postun): desktop-file-utils, shared-mime-info
46
47%description    gui
48The %{name}-gui package contains the Qt based GUI for CMake.
49
50
[521]51%prep
52%setup -q
[1640]53# Fixup permissions
54find -name \*.h -o -name \*.cxx -print0 | xargs -0 chmod -x
[521]55
56%build
[1777]57./bootstrap \
58    --prefix=%{_prefix} \
59    --datadir=/share/%{name} \
60    --mandir=/share/man \
61    --system-libs \
62    %{?qt_gui}
63
[1640]64make VERBOSE=1 %{?_smp_mflags}
[521]65
66%install
67rm -rf $RPM_BUILD_ROOT
[1640]68make install DESTDIR=$RPM_BUILD_ROOT
[521]69
[1640]70find $RPM_BUILD_ROOT/%{_datadir}/%{name}/Modules -type f | xargs chmod -x
[521]71rm -rf $RPM_BUILD_ROOT/usr/doc
72
73# RPM macros
74install -p -m0644 -D %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
75sed -i -e "s|@@CMAKE_VERSION@@|%{version}|" $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
76touch -r %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
77
[1640]78%if %{with gui}
79# Desktop file
80desktop-file-install --delete-original \
81  --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
82  $RPM_BUILD_ROOT/%{_datadir}/applications/CMake.desktop
83%endif
84
85
[521]86%clean
87rm -rf $RPM_BUILD_ROOT
88
[1640]89%if %{with gui}
90%post gui
91update-desktop-database &> /dev/null || :
92update-mime-database %{_datadir}/mime &> /dev/null || :
93
94%postun gui
95update-desktop-database &> /dev/null || :
96update-mime-database %{_datadir}/mime &> /dev/null || :
97%endif
98
99
[521]100%files
101%defattr(-,root,root)
102%doc CMakeLogo.gif ChangeLog.* Copyright.txt
103%doc Docs/*
104%doc Example/
105%config(noreplace) %{_sysconfdir}/rpm/macros.cmake
[1640]106%{_bindir}/ccmake
107%{_bindir}/cmake
108%{_bindir}/cpack
109%{_bindir}/ctest
110%{_datadir}/%{name}/
[521]111%{_mandir}/man1/*
112
[1640]113%if %{with gui}
114%files gui
115%defattr(-,root,root,-)
116%{_bindir}/cmake-gui
117%{_datadir}/applications/CMake.desktop
118%{_datadir}/mime/packages/cmakecache.xml
119%{_datadir}/pixmaps/CMakeSetup32.png
120%endif
121
122
[521]123%changelog
[1777]124* Sun Sep  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-4
125- fixed typo (not --with-system-libs, but --system-libs)
126- added BR: curl-devel, expat-devel, zlib-devel
127
[1643]128* Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.2-3
129- add BuildRequires: ncurses-devel
130
[1640]131* Sun Aug 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-2
132- generate gui package
133- renamed module directory
134
[1442]135* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-1
136- new upstream release
137
[521]138* Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-3
139- rebuilt with new toolchain
140
141* Sun Aug 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.4-2
142- imported RPM macros from Fedora (cmake-2.6.4-3.fc12)
143
144* Tue Aug 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.4-1
145- new upstream release
146- added Vendor/Distribution tag
147
148* Wed Mar 25 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.3-1
149- new upstream release
150
151* Tue Oct 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.2-1
152- new upstream release
153
154* Sat Mar 29 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.8-1
155- new upstream release
156
157* Wed Aug 15 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.7-0vl1
158- new upstream release
159
160* Mon May 14 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.6-0vl1
161- new upstream release
162- drop Patch100
163- use bootstrap script instead of configure
164- delete caches from %%doc
165
166* Sat May 12 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.3-0vl2
167- rebuilt with new toolchain
168
169* Tue Oct 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.3-0vl1
170- new upstream release
171- delete duped docs
172
173* Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.3-0vl2
174- added Patch100 (especially for ppc to solve ppc/powerpc issue)
175
176* Mon Feb 06 2006 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.2.3-0vl1
177- source version up
178
179* Sun Mar 20 2005 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.0.5-0vl1
180- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.