source: projects/specs/trunk/c/chromium/chromium-vl.spec @ 1570

Revision 1570, 20.7 KB checked in by munepi, 14 years ago (diff)

updated chromium

Line 
1# Thanks to malcolmlewis for help with this script
2# Thanks to Tom "spot" Callaway for much of the patchwork
3# Thanks to jhaygood for most of the icu patch
4
5# norootforbuild
6
7%if %{?_dist_release} == "vl6"
8%define with_system_icu 1
9%endif
10
11%define svn_rev 56023
12
13Name:           chromium
14Summary:        Google's opens source browser project
15Summary(ja):    Googleのオープンソースウェブブラウザ
16#'
17Version:        6.0.493.0
18Release:        1%{?_dist_release}
19License:        BSD
20Group:          Applications/Internet
21Source0:        %{name}.%{version}.svn%{svn_rev}.tar.lzma
22## The following are included for source reasons only
23# Custom build tools for chromium, hammer is a fancy front-end for scons
24Source1:        http://src.chromium.org/svn/trunk/tools/depot_tools.tar.gz
25%{?nosrc:NoSource: 0}
26%{?nosrc:NoSource: 1}
27# Script used to create the tar.lzma archive from the daily tarball downloadable at http://build.chromium.org/buildbot/archives/
28Source2:        repack_chromium_archive.sh
29# Script used to create the tar.lzma archive from a checked out source
30#Source3:        pack_chromium_source.sh
31Source3:        pack_chromium_source-vine.sh
32#Source10:       chromium.desktop
33Source10:       chromium-vine.desktop
34# Patch template which adds vendor to user agent
35##!!Source20:       chromium-vendor.patch.in
36Source20:       chromium-vendor-vine.patch.in
37##!!Source30:       master_preferences
38Source30:       master_preferences.vine
39#Source31:       default_bookmarks.html
40#Source31:       default_bookmarks.html.vine
41# icu-4.2.1 contained in chromium.5.0.353.0.svn41449 (for Vine Linux 5.X)
42Source100:      icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2
43Provides:       chromium-browser = %{version}
44#Obsoletes:      chromium-browser < %{version}
45
46## Start Patches
47# Many changes to the gyp system so we can use system libraries
48# My first ever patch set.  I hope I did well.
49Patch3:         chromium-gyp-system-icu.patch
50Patch4:         chromium-no-sqlite-debug.patch
51Patch5:         chromium-gyp-system-04-nss-nspr.patch
52Patch7:         chromium-codechanges-nss-nspr.patch
53Patch8:         chromium-codechanges-zlib.patch
54#Patch9:         chromium-drop-sse.patch
55Patch10:        chromium-fix-wrapper.patch
56Patch12:        chromium-no-test-sources.patch
57Patch13:        chromium-no-courgette.patch
58Patch14:        chromium-master-prefs-path.patch
59#Patch15:        chromium-media-probe.patch
60Patch16:        chromium-icu-code-changes.patch
61Patch17:        chromium-system-glew.patch
62Patch18:        chromium-system-expat.patch
63Patch19:        chromium-system-zlib.patch
64Patch20:        chromium-noffmpeg.patch
65Patch21:        chromium-system-old-ffmpeg-way.patch
66Patch23:        chromium-disable-mmx.patch
67#Patch24:       chromium-fix-yuv_row_posix-shared.patch
68Patch25:        tcmalloc-factory.patch
69
70# Vine
71
72
73BuildRequires:  gcc gcc-c++
74%if %{?_dist_release} == "vl5"
75BuildRequires:  libstdc++34 libstdc++34-devel
76%elseif %{?_dist_release} == "vl6"
77BuildRequires:  libstdc++ libstdc++-devel
78%endif
79BuildRequires:  libevent
80##!!BuildRequires:  pkg-config
81BuildRequires:  python
82##!!BuildRequires:  python-xml
83BuildRequires:  python-pyxml
84BuildRequires:  perl bison flex gperf
85##!!BuildRequires:  wdiff
86##!!BuildRequires:  update-desktop-files
87BuildRequires:  desktop-file-utils
88BuildRequires:  lzma
89##!!BuildRequires:  mozilla-nss-devel
90BuildRequires:  nss-devel
91##!!BuildRequires:  alsa-devel
92BuildRequires:  alsa-lib-devel
93BuildRequires:  gtk2-devel
94BuildRequires:  glib2-devel
95BuildRequires:  cairo-devel >= 1.6
96##!!BuildRequires:  mozilla-nspr-devel
97BuildRequires:  nspr-devel
98##!!BuildRequires:  gconf2-devel
99BuildRequires:  GConf2-devel
100BuildRequires:  freetype2-devel
101##!!BuildRequires:  dbus-1-devel
102BuildRequires:  dbus-devel
103BuildRequires:  libxslt-devel
104BuildRequires:  libxml2-devel
105BuildRequires:  libjpeg-devel
106BuildRequires:  zlib-devel
107##!!BuildRequires:  libbz2-devel
108BuildRequires:  bzip2-devel
109BuildRequires:  cups-devel
110%if %{?_dist_release} == "vl6"
111BuildRequires:  fdupes
112%endif
113##!!BuildRequires:  libexpat-devel
114BuildRequires:  expat-devel
115BuildRequires:  libpng-devel
116BuildRequires:  sqlite3-devel
117BuildRequires:  gnutls-devel
118%if %{?_dist_release} == "vl5"
119BuildRequires:  gnome-keyring-devel
120%elseif %{?_dist_release} == "vl6"
121BuildRequires:  libgnome-keyring-devel
122%endif
123BuildRequires:  glew-devel
124##!!BuildRequires:  Mesa-devel
125BuildRequires:  mesa-libGLU-devel
126
127%{?with_system_icu:BuildRequires:  libicu-devel >= 4.0}
128BuildRequires:  libevent-devel
129
130##Vine Linux
131BuildRequires:  libXScrnSaver-devel
132#BuildRequires:  gle-devel
133#BuildRequires:  webkit-gtk-devel
134#BuildRequires:  scons
135%ifarch x86_64
136Requires:  nspluginwrapper
137%endif
138
139##!!Requires:       alsa
140Requires:       alsa-lib
141# shouldn't be required to name all dependencies
142# Requires:       mozilla-nss mozilla-nspr gtk2 glib2 cairo >= 1.6 freetype2 dbus-1 alsa v8 >= 1.3.15
143## Recommends the ffmpeg libraries (available from packman)
144#Recommends:     libavcodec52 libavformat52 libavutil50
145
146BuildRoot:      %{_tmppath}/%{name}-%{version}-root
147
148%description
149Chromium is the open-source project behind Google Chrome.
150We invite you to join us in our effort to help build a safer, faster,
151and more stable way for all Internet users to experience the web,
152and to create a powerful platform for developing a new generation of
153web applications.
154
155%description -l ja
156Chromium は Google Chrome の後方にあるオープンソースプロジェクトです。
157私たちは、ウェブを体験しているすべてのインターネットユーザに対して
158より安全で、より速くて、より安定した方法を築き上げるのを助けるために、
159ウェブアプリケーションの新しい世代を発展させるように
160強力なプラットホームを作成するために、
161私たちの取り組みで私たちに加わるようにあなたを誘います。
162
163
164%prep
165[ -d %{name} ] && %__rm -rf %{name}
166lzma -cd %{SOURCE0} | tar xf -
167%setup -D -T -n %{name}
168
169# use static libicu
170%if %{?_dist_release} == "vl5"
171cd src/third_party || exit 1
172    %__rm -rf icu || exit 1
173    tar jxvf %{SOURCE100} || exit 1
174    %__mv icu-4.2.1-chromium.5.0.353.0.svn41449 icu || exit 1
175cd - || exit 1
176%endif
177
178# use system libicu only if >= 4.0
179%{?with_system_icu:%patch3 -p1}
180
181%patch4 -p1
182%patch5 -p1
183%patch7 -p1
184%patch8 -p1
185#%patch9 -p1
186%patch10 -p1
187%patch12 -p1
188%patch13 -p1
189%patch14 -p1
190#%patch15 -p0
191%{?with_system_icu:%patch16 -p1}
192%patch17 -p1
193%patch18 -p1
194%patch19 -p1
195%patch20 -p1
196%patch21 -p1
197%patch25 -p1
198%ifarch %ix86
199%patch23 -p1
200%endif
201#%patch24 -p1
202
203
204# apply vendor patch after substitution
205%__sed "s:RPM_VERSION:%{version}-%{release}:" %{SOURCE20} | patch -p0
206
207%build
208## create make files
209
210PARSED_OPT_FLAGS=`echo \'$RPM_OPT_FLAGS -DUSE_SYSTEM_LIBEVENT -fPIC -fno-ipa-cp -fno-strict-aliasing \' | %__sed "s/ /',/g" | %__sed "s/',/', '/g"`
211for i in src/build/common.gypi; do
212        %__sed -i "s|'-march=pentium4',||g" $i
213        %__sed -i "s|'-msse2',||g" $i
214        %__sed -i "s|'-mfpmath=sse',||g" $i
215        %__sed -i "s|'-O<(debug_optimize)',||g" $i
216        %__sed -i "s|'-m32',||g" $i
217        %__sed -i "s|'-fno-exceptions',|$PARSED_OPT_FLAGS|g" $i
218        %__sed -i "s|'-Werror'|'-Wno-error'|g" $i
219done
220# '
221
222pushd src
223
224./build/gyp_chromium -f make build/all.gyp \
225    -Duse_system_ffmpeg=1 \
226    -Duse_system_zlib=1 \
227    -Duse_system_libpng=1 \
228    -Duse_system_bzip2=1 \
229    -Duse_system_libbz2=1 \
230    -Duse_system_libjpeg=1 \
231    -Duse_system_libxml=1 \
232    -Duse_system_libxslt=1 \
233    -Duse_system_libevent=1 \
234    -Dproprietary_codecs=1 \
235    -Dlinux_fpic=1 \
236    %{?with_system_icu:-Duse_system_icu=1} \
237    %{!?with_system_icu:-Duse_system_icu=0} \
238    %ifarch %{ix86}
239        -Dtarget_arch=ia32 \
240         -Ddisable_sse2=1 \
241    %endif
242    %ifarch x86_64
243        -Dtarget_arch=x64 \
244    %endif
245    %if %{?_dist_release} == "vl6"
246        -Dno_strict_aliasing=1 -Dgcc_version=44 \
247    %endif
248    -Drelease_extra_cflags=-fPIC \
249    ;
250
251#make -r %{?jobs:-j%jobs} chrome BUILDTYPE=Release
252#%__make -r -j5 chrome BUILDTYPE=Release
253%__make %{?_smp_mflags} chrome BUILDTYPE=Release
254
255popd
256
257%install
258%{__rm} -rf %{buildroot}
259
260## Create install directories
261%{__mkdir_p} %{buildroot}%{_libdir}/%{name}
262%{__mkdir_p} %{buildroot}%{_bindir}
263%{__mkdir_p} %{buildroot}%{_datadir}/applications
264%{__mkdir_p} %{buildroot}%{_datadir}/pixmaps
265%{__mkdir_p} %{buildroot}%{_mandir}/man1
266%{__mkdir_p} %{buildroot}%{_sysconfdir}/%{name}
267
268# chromium 'make' deposits us back at the top level build directory
269pushd src/out/Release
270ls -l
271
272# clean somechromium-codechanges-zlib.patch
273# clean debug junk
274%{__rm} -rf obj/ mksnapshot obj.target obj.host
275find ./ -type f -name '*.d' | while read i; do %__rm -f $i; done
276# clean NaCl stuff...  maybe NaCl will be in its own package in the future.
277%{__rm} -f ncdecode_table ncdecode_tablegen
278# clean other temporary binaries used in the compilation of chromium
279%{__rm} -f protoc xdg-settings
280
281%{__cp} -rf * %{buildroot}%{_libdir}/%{name}/
282
283# Man page
284[ ! -f %{name}.1 ] && %{__mv} chrome.1 %{name}.1
285%__install -m 0644 %{name}.1 %{buildroot}%{_mandir}/man1
286
287# Add startup file with plugins enabled
288%{__cat} > %{buildroot}%{_bindir}/%{name} <<EOF
289#!/bin/bash
290%{_libdir}/%{name}/chrome-wrapper --enable-plugins --enable-user-scripts --enable-extensions --enable-sync --enable-geolocation --enable-webgl "\$@"
291EOF
292
293# # link to browser plugin path.  Plugin patch doesn't work. Why?
294# %{__mkdir_p} %{buildroot}%{_libdir}/browser-plugins
295# pushd %{buildroot}%{_libdir}/%{name}
296# %{__ln_s} %{_libdir}/browser-plugins plugins
297# popd
298pushd %{buildroot}%{_libdir}/%{name}
299%ifarch x86_64
300%{__ln_s} %{_libdir}/mozilla/plugins-wrapped plugins
301%else
302%{__ln_s} %{_libdir}/mozilla/plugins plugins
303%endif
304
305#touch %{buildroot}%{_libdir}/libavcodec.so.52
306#%{__ln_s} %{_libdir}/libavcodec.so.52 libavcodec.so.52
307#touch %{buildroot}%{_libdir}/libavformat.so.52
308#%{__ln_s} %{_libdir}/libavformat.so.52 libavformat.so.52
309#touch %{buildroot}%{_libdir}/libavutil.so.50
310#%{__ln_s} %{_libdir}/libavutil.so.50 libavutil.so.50
311popd
312
313# Install desktop-related files
314%__install -m 0644 %{SOURCE10} %{buildroot}%{_datadir}/applications/%{name}.desktop
315%__install -m 0644 product_logo_48.png %{buildroot}%{_datadir}/pixmaps/%{name}.png
316desktop-file-install --vendor Vine                      \
317        --dir $RPM_BUILD_ROOT%{_datadir}/applications   \
318        --delete-original                               \
319        --mode 644                                      \
320        $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop
321
322# Install the master_preferences file
323#%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}
324%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}/$(basename %{SOURCE30} .vine)
325
326## install o3d plugin
327#pushd src/o3d/build/out/Release
328#%{__cp} -rf * %{buildroot}%{_libdir}/browser-plugins
329
330%clean
331%{__rm} -rf %{buildroot}
332
333
334%files
335%defattr(-,root,root)
336%doc src/AUTHORS src/LICENSE
337%dir %{_libdir}/%{name}
338%attr(0755,root,root) %{_bindir}/%{name}
339%{_mandir}/man1/*
340%{_datadir}/applications/*%{name}.desktop
341%{_datadir}/pixmaps/%{name}.png
342%{_libdir}/%{name}/*
343%config %{_sysconfdir}/%{name}
344#%{_libdir}/browser-plugins/*
345#%exclude %{_libdir}/libavcodec.so.52
346#%exclude %{_libdir}/libavutil.so.50
347#%exclude %{_libdir}/libavformat.so.52
348
349%changelog
350* Sat Aug 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.493.0-1
351- updated to snapshot 6.0.493
352- used with_system_icu (for vl6)
353  - added BuildRequires: libicu-devel
354
355* Thu Jul 22 2010 IWAI, Masaharu <iwai@alib.jp> 6.0.454.0-2vl5
356- build for Vine Linux 5.x
357  - add BuildRequires: gnome-keyring-devel
358
359* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.454.0-1
360- updated to snapshot 6.0.454
361- added BuildRequires:
362  - sqlite3-devel
363  - gnutls-devel
364  - libgnome-keyring-devel
365
366* Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.431.0-1
367- updated to snapshot 6.0.431.0 r49253
368- added BuildRequires: cups-devel
369
370* Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.405.0-1
371- updated to snapshot 6.0.405.0 r47263
372
373* Fri Apr 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-2
374- unused with_system_icu (for vl6)
375  - used icu-4.2.1-chromium.5.0.353.0.svn41449 (for vl6)
376
377* Wed Apr 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-1
378- updated to snapshot 5.0.378.0 r44472
379  - used with_system_icu (for vl6)
380  - added icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2 (for vl5)
381
382* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.372.0-1
383- updated to snapshot 5.0.372.0 r43947
384- added BuildRequires: glew-devel
385- changed Group tag to Applications/Internet
386- added Summary(ja) and %%description -l ja
387
388* Mon Apr 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.365.0-1
389- updated to snapshot 5.0.365.0 r42966
390- merged 5.0.353.0-4vl5
391 * Fri Apr  2 2010 IWAI, Masaharu <iwai@alib.jp> 5.0.353.0-4vl5
392 - build on Vine Linux 5.1
393   - add BuildRequires: libstdc++34 libstdc++34-devel for Vine5
394
395* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.364.0-1
396- updated to snapshot 5.0.364.0 r42779
397
398* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.359.0-1
399- updated to snapshot 5.0.359.0 r42116
400- dropped chromium-20100122-ubuntu-html5-video-mimetypes.patch
401
402* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-4
403- fixed master_preferences.vine, little
404
405* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-3
406- fixed to install master_preferences
407- dropped chromium-5.0.353-no-ffmpeg-vine.patch
408
409* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-2
410- applied chromium-5.0.353-no-ffmpeg-vine.patch
411
412* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-1
413- updated to snapshot 5.0.353.0 r41449
414  * Wed Mar 10 2010 bgmerrell@novell.com
415  - Add master_preferences source file and install it to /etc/chromium.
416  - Create a new patch (chromium-master-prefs-path.patch) which tells
417    chromium to look in /etc/chromium for the master_preferences file
418    (instead of looking in the default directory, which is the same
419    directory as the 'chrome' binary).
420
421* Sun Feb 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.335.0-1
422- updated to snapshot 5.0.335.0 r39556
423
424* Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-2
425- applied chromium-20100122-ubuntu-html5-video-mimetypes.patch from Gentoo
426
427* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-1
428- updated to snapshot 5.0.330.0 r39074
429
430* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-5
431- use_system_ffmpeg
432
433* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-4
434- added Requires:  nspluginwrapper
435- fixed a symbolic link of plugins directory with nspluginwrapper
436
437* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-3
438- replaced %%{SOUECE20} to chromium-vendor-vine.patch.in
439
440* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-2
441- added BuildRequires: mesa-libGLU-devel
442- added BuildRequires: libstdc++34 libstdc++34-devel for vl5
443
444* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-1
445- built based on chromium-5.0.329.0-167.1.src.rpm of OpenSuse
446
447  * Sun Nov 29 2009 - tittiatcoke@gmail.com - 4.0.260.0
448  - Update to 4.0.260
449  * Fri Nov 27 2009 - tittiatcoke@gmail.com - 4.0.259.0
450  - Update to 4.0.259
451  * Thu Nov 26 2009 - tittiatcoke@gmail.com - 4.0.258.0
452  - Update to 4.0.258
453  * Tue Nov 24 2009 - tittatcoke@gmai.com - 4.0.257.0
454  - In order to complete prevent the wrong v8 version to be used, the Chromium build has been
455    changed to having an built-in v8
456  * Tue Nov 24 2009 - dbuck@example.com - 4.0.257.0
457  - Re-base patches.  Fixed a few patch errors.  Rename some patches to better correspond with function.  Removed some patches.
458  - Minor SPEC changes.  I changed the v8 requirement to be exact, instead of greater than a specific version.
459  * Sat Oct 24 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.223.5
460  - don't create desktop files in wrapper, fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
461  * Tue Oct 20 2009 - Raymond Wooninck >tittiatcoke@gmail.com> - 4.0.223.5
462  - update to newer svn snapshot
463    + Obsoletes fwrite patch (included upstream)
464  * Fri Oct 16 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.223.2
465  - update to newer svn snapshot
466    + Requires newer version of v8
467  * Thu Oct 15 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.222.6
468  - do not force SSE on x86 (drop-sse.patch)
469  * Tue Oct 13 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.222.6
470  - Update to newer svn snapshot
471  - Fixed spec file in order to build
472  - Included patch to build with system zlib
473  * Mon Oct 12 2009 - Pavol Rusnak <prusnak@suse.cz> 4.0.222.2
474  - package renamed to chromium
475  - cleaned up spec file
476  * Tue Oct 6 2009 - dbuck <dbuck@example.com> - 4.0.222.2
477  - v8 is now built as a separate package, and is required
478  - included many patches to use system libraries: v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
479  * Sun Oct 1 2009 - dbuck <dbuck@example.com> - 4.0.221.1
480  - included a newer DEP than is in svn, native_client@823.  So things should compile cleanly now
481  * Sun Aug 31 2009 - dbuck <dbuck@example.com> - 4.0.204.0
482  - initial build
483
484#% changelog
485* Sun Jan 24 2010 prusnak@suse.cz
486- added vendor to user agent (chromium-vendor.patch.in)
487* Sun Nov 29 2009 prusnak@suse.cz
488- added --enable-sync to wrapper to enable bookmark sync
489* Fri Nov 13 2009 tittiatcoke@gmail.com
490- update to 247.0 svn 31928
491* Fri Oct 30 2009 tittiatcoke@gmail.com
492- update to 229.0 svn 30454
493  + Fix regression where popups and app frames lost their titlebars.
494  + Makes it so that when a folder is open on the bookmark bar
495    and the mouse moves over another folder, the menu for that
496    folder is shown.
497  + Lazily create the find bar.
498  + Polish to the gmail checker sample.
499  * New, crisper icons that are exactly 19x19
500  * Add a loading animation at the beginning before Gmail
501    responds.
502  * Fix a bug where we sometimes don't update the UI after a
503    logout/login cycle.
504  + Refactor widget methods to support desktop notifications,
505    including GTK stubs.
506  + Find-in-page should not ding while deleting characters.
507  + Add SSL wrapper for linux and mac.  This allows notifier to
508    use chrome's SSL layer instead of OpenSSL.
509  + Add three of the six extensions to PAC that Internet Explorer supports.
510  + WebSocket support in chromium. (Run with --enable-web-sockets
511    enables WebSocket features.)
512  + Do not allow GTK File Chooser dialogs to return directories.
513  + Fix the notifier SSL layer to make notifications work for
514    Linux Bookmark sync.
515  + linux: don't override mouse selection behavior in omnibox
516* Sun Oct 25 2009 tittiatcoke@gmail.com
517- Update to 224.4 svn 30027
518  + First cut at new page and browser action docs based
519    on new API. Deleted old stuff.
520  + Add suppression for new memory leak caused by WebKit merge 49830:49844
521  + Cleanup: change PIDs to base::ProcessId (or pid_t, as appropriate)
522  + Minimize dependency of user scripts
523  + Fixup the flip_framer eof-handling semantics now that we have
524    the FIN bit in place
525  + app depends on x11 because of active_window_watcher_x
526  + Adding two images for the new Extension managment UI
527  + Removing hard-coded Chrome Frame output path
528  + Rearrange clipboard code
529  + Fix crash bug when attempting to download a url with unsupported scheme,
530    e.g. 'data:', by 'Alt + Click'
531  + GTK: Change text for extension download UI
532  + Ignore invalid urls on command line
533  + Make dropped tabs animate from where they were dropped.
534  + Make room for the full width of the tab placeholder.
535  + Make tab dragging as smooth as glass.
536  + Remove an annoying NOTIMPLEMNETED
537  + Extensions: guarantee removal of BROWSER_WINDOW_READY registration
538  + If we're in the middle of a drag, don't allow the user to middle
539    click to close or right click for the context menu
540  + "Fix" a NOTIMPLEMENTED on Linux by using the default password store
541  + Remove +x bit from files that shouldn't have it
542  + Fold first 3 channels of multichannel instead of 5.  Use fixed point
543  + Adding new image needed for the managment UI
544  + Fix a race bug where content scripts would not apply to the first page load
545  + Make escape remove a bookmark if it's just been added (but not if it already existed)
546  + Fix bubbles deactivating the opaque frame
547  + Allow ESC to cancel ALT+SHIFT+T in Toolbar
548  + ake all pepper plugins default to windowless and transparent
549  + Add styles for printing
550  + Implement the new extension management UI
551  + Add support for to automation interface load install and load extensions
552  + GTK: theme the info bar border
553  + Update V8 to version 1.3.16.1
554  + Introduce WebSecurityPolicy for security related methods
555  + New button scheme...borders are separate from the inner contents so
556    that they can be highlighted / depressed independently
557  + When opening Chrome maximized with an application window already
558    running, the Chrome window was not activated
559  + Fix compatibility problems with FileZilla FTP Server
560  + Remove the extension shelf on Linux
561  + Fix the proxy host and port string to start with http:// if it does not already
562  + Enable HTML5 databases for all extension renderer processes
Note: See TracBrowser for help on using the repository browser.