source: projects/specs/trunk/c/chromium/chromium-vl.spec @ 1419

Revision 1419, 20.8 KB checked in by iwaim, 14 years ago (diff)

chromium 6.0.454.0-2vl5

Line 
1# Thanks to malcolmlewis for help with this script
2# Thanks to Tom "spot" Callaway for much of the patchwork
3# Thanks to jhaygood for most of the icu patch
4
5# norootforbuild
6
7%if %{?_dist_release} == "vl6"
8#% define with_system_icu 1
9%endif
10
11%define svn_rev 51404
12
13Name:           chromium
14Summary:        Google's opens source browser project
15Summary(ja):    Googleのオープンソースウェブブラウザ
16#'
17Version:        6.0.454.0
18Release:        2%{?_dist_release}
19License:        BSD
20Group:          Applications/Internet
21Source0:        %{name}.%{version}.svn%{svn_rev}.tar.lzma
22## The following are included for source reasons only
23# Custom build tools for chromium, hammer is a fancy front-end for scons
24Source1:        http://src.chromium.org/svn/trunk/tools/depot_tools.tar.gz
25%{?nosrc:NoSource: 0}
26%{?nosrc:NoSource: 1}
27# Script used to create the tar.lzma archive from the daily tarball downloadable at http://build.chromium.org/buildbot/archives/
28Source2:        repack_chromium_archive.sh
29# Script used to create the tar.lzma archive from a checked out source
30#Source3:        pack_chromium_source.sh
31Source3:        pack_chromium_source-vine.sh
32#Source10:       chromium.desktop
33Source10:       chromium-vine.desktop
34# Patch template which adds vendor to user agent
35##!!Source20:       chromium-vendor.patch.in
36Source20:       chromium-vendor-vine.patch.in
37##!!Source30:       master_preferences
38Source30:       master_preferences.vine
39#Source31:       default_bookmarks.html
40#Source31:       default_bookmarks.html.vine
41# icu-4.2.1 contained in chromium.5.0.353.0.svn41449 (for Vine Linux 5.X)
42Source100:      icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2
43Provides:       chromium-browser = %{version}
44#Obsoletes:      chromium-browser < %{version}
45
46## Start Patches
47# Many changes to the gyp system so we can use system libraries
48# My first ever patch set.  I hope I did well.
49Patch3:         chromium-gyp-system-icu.patch
50Patch4:         chromium-no-sqlite-debug.patch
51Patch5:         chromium-gyp-system-04-nss-nspr.patch
52Patch7:         chromium-codechanges-nss-nspr.patch
53Patch8:         chromium-codechanges-zlib.patch
54#Patch9:         chromium-drop-sse.patch
55Patch10:        chromium-fix-wrapper.patch
56Patch12:        chromium-no-test-sources.patch
57Patch13:        chromium-no-courgette.patch
58Patch14:        chromium-master-prefs-path.patch
59#Patch15:        chromium-media-probe.patch
60Patch16:        chromium-icu-code-changes.patch
61Patch17:        chromium-system-glew.patch
62Patch18:        chromium-system-expat.patch
63Patch19:        chromium-system-zlib.patch
64Patch20:        chromium-noffmpeg.patch
65Patch21:        chromium-system-old-ffmpeg-way.patch
66Patch23:        chromium-disable-mmx.patch
67Patch24:        chromium-fix-yuv_row_posix-shared.patch
68Patch25:        tcmalloc-factory.patch
69
70# Vine
71#Patch40:       chromium-5.0.353-no-ffmpeg-vine.patch
72
73## Gentoo patches
74# Allow use of MP3/MPEG-4 audio/video tags with our system ffmpeg
75#Patch50: http://sources.gentoo.org/viewcvs.py/*checkout*/gentoo-x86/www-client/chromium/files/chromium-20100122-ubuntu-html5-video-mimetypes.patch
76
77BuildRequires:  gcc gcc-c++
78%if %{?_dist_release} == "vl5"
79BuildRequires:  libstdc++34 libstdc++34-devel
80%elseif %{?_dist_release} == "vl6"
81BuildRequires:  libstdc++ libstdc++-devel
82%endif
83BuildRequires:  libevent
84##!!BuildRequires:  pkg-config
85BuildRequires:  python
86##!!BuildRequires:  python-xml
87BuildRequires:  python-pyxml
88BuildRequires:  perl bison flex gperf
89##!!BuildRequires:  wdiff
90##!!BuildRequires:  update-desktop-files
91BuildRequires:  desktop-file-utils
92BuildRequires:  lzma
93##!!BuildRequires:  mozilla-nss-devel
94BuildRequires:  nss-devel
95##!!BuildRequires:  alsa-devel
96BuildRequires:  alsa-lib-devel
97BuildRequires:  gtk2-devel
98BuildRequires:  glib2-devel
99BuildRequires:  cairo-devel >= 1.6
100##!!BuildRequires:  mozilla-nspr-devel
101BuildRequires:  nspr-devel
102##!!BuildRequires:  gconf2-devel
103BuildRequires:  GConf2-devel
104BuildRequires:  freetype2-devel
105##!!BuildRequires:  dbus-1-devel
106BuildRequires:  dbus-devel
107BuildRequires:  libxslt-devel
108BuildRequires:  libxml2-devel
109BuildRequires:  libjpeg-devel
110BuildRequires:  zlib-devel
111##!!BuildRequires:  libbz2-devel
112BuildRequires:  bzip2-devel
113BuildRequires:  cups-devel
114%if %{?_dist_release} == "vl6"
115BuildRequires:  fdupes
116%endif
117##!!BuildRequires:  libexpat-devel
118BuildRequires:  expat-devel
119BuildRequires:  libpng-devel
120BuildRequires:  sqlite3-devel
121BuildRequires:  gnutls-devel
122%if %{?_dist_release} == "vl5"
123BuildRequires:  gnome-keyring-devel
124%elseif %{?_dist_release} == "vl6"
125BuildRequires:  libgnome-keyring-devel
126%endif
127BuildRequires:  glew-devel
128##!!BuildRequires:  Mesa-devel
129BuildRequires:  mesa-libGLU-devel
130
131%{?with_system_icu:BuildRequires:  libicu-devel >= 4.0}
132BuildRequires:  libevent-devel
133
134##Vine Linux
135BuildRequires:  libXScrnSaver-devel
136#BuildRequires:  gle-devel
137#BuildRequires:  webkit-gtk-devel
138#BuildRequires:  scons
139%ifarch x86_64
140Requires:  nspluginwrapper
141%endif
142
143##!!Requires:       alsa
144Requires:       alsa-lib
145# shouldn't be required to name all dependencies
146# Requires:       mozilla-nss mozilla-nspr gtk2 glib2 cairo >= 1.6 freetype2 dbus-1 alsa v8 >= 1.3.15
147## Recommends the ffmpeg libraries (available from packman)
148#Recommends:     libavcodec52 libavformat52 libavutil50
149
150BuildRoot:      %{_tmppath}/%{name}-%{version}-root
151
152%description
153Chromium is the open-source project behind Google Chrome.
154We invite you to join us in our effort to help build a safer, faster,
155and more stable way for all Internet users to experience the web,
156and to create a powerful platform for developing a new generation of
157web applications.
158
159%description -l ja
160Chromium は Google Chrome の後方にあるオープンソースプロジェクトです。
161私たちは、ウェブを体験しているすべてのインターネットユーザに対して
162より安全で、より速くて、より安定した方法を築き上げるのを助けるために、
163ウェブアプリケーションの新しい世代を発展させるように
164強力なプラットホームを作成するために、
165私たちの取り組みで私たちに加わるようにあなたを誘います。
166
167
168%prep
169[ -d %{name} ] && %__rm -rf %{name}
170lzma -cd %{SOURCE0} | tar xf -
171%setup -D -T -n %{name}
172
173# use static libicu
174#%if %{?_dist_release} == "vl5"
175cd src/third_party || exit 1
176    %__rm -rf icu || exit 1
177    tar jxvf %{SOURCE100} || exit 1
178    %__mv icu-4.2.1-chromium.5.0.353.0.svn41449 icu || exit 1
179cd - || exit 1
180#%endif
181
182# use system libicu only if >= 4.0
183%{?with_system_icu:%patch3 -p1}
184
185%patch4 -p1
186%patch5 -p1
187%patch7 -p1
188%patch8 -p1
189#%patch9 -p1
190%patch10 -p1
191#%patch11 -p1
192%patch12 -p1
193%patch13 -p1
194%patch14 -p1
195#%patch15 -p0
196%{?with_system_icu:%patch16 -p1}
197%patch17 -p1
198%patch18 -p1
199%patch19 -p1
200%patch20 -p1
201%patch21 -p1
202#%patch22 -p1
203%patch25 -p1
204%ifarch %ix86
205%patch23 -p1
206%endif
207%patch24 -p1
208
209
210# apply vendor patch after substitution
211%__sed "s:RPM_VERSION:%{version}-%{release}:" %{SOURCE20} | patch -p0
212
213%build
214## create make files
215
216PARSED_OPT_FLAGS=`echo \'$RPM_OPT_FLAGS -DUSE_SYSTEM_LIBEVENT -fPIC -fno-strict-aliasing \' | %__sed "s/ /',/g" | %__sed "s/',/', '/g"`
217for i in src/build/common.gypi; do
218        %__sed -i "s|'-march=pentium4',||g" $i
219        %__sed -i "s|'-msse2',||g" $i
220        %__sed -i "s|'-mfpmath=sse',||g" $i
221        %__sed -i "s|'-O<(debug_optimize)',||g" $i
222        %__sed -i "s|'-m32',||g" $i
223        %__sed -i "s|'-fno-exceptions',|$PARSED_OPT_FLAGS|g" $i
224        %__sed -i "s|'-Werror'|'-Wno-error'|g" $i
225done
226# '
227
228pushd src
229
230./build/gyp_chromium -f make build/all.gyp \
231    -Duse_system_ffmpeg=1 \
232    -Duse_system_zlib=1 \
233    -Duse_system_libpng=1 \
234    -Duse_system_bzip2=1 \
235    -Duse_system_libbz2=1 \
236    -Duse_system_libjpeg=1 \
237    -Duse_system_libxml=1 \
238    -Duse_system_libxslt=1 \
239    -Duse_system_libevent=1 \
240    -Dproprietary_codecs=1 \
241    -Dlinux_fpic=1 \
242    %{?with_system_icu:-Duse_system_icu=1} \
243    %{!?with_system_icu:-Duse_system_icu=0} \
244    %ifarch %{ix86}
245        -Dtarget_arch=ia32 \
246         -Ddisable_sse2=1 \
247    %endif
248    %ifarch x86_64
249        -Dtarget_arch=x64 \
250    %endif
251    %if %{?_dist_release} == "vl6"
252        -Dno_strict_aliasing=1 -Dgcc_version=44 \
253    %endif
254    -Drelease_extra_cflags=-fPIC \
255    ;
256
257#make -r %{?jobs:-j%jobs} chrome BUILDTYPE=Release
258#%__make -r -j5 chrome BUILDTYPE=Release
259%__make %{?_smp_mflags} chrome BUILDTYPE=Release
260
261popd
262
263%install
264%{__rm} -rf %{buildroot}
265
266## Create install directories
267%{__mkdir_p} %{buildroot}%{_libdir}/%{name}
268%{__mkdir_p} %{buildroot}%{_bindir}
269%{__mkdir_p} %{buildroot}%{_datadir}/applications
270%{__mkdir_p} %{buildroot}%{_datadir}/pixmaps
271%{__mkdir_p} %{buildroot}%{_mandir}/man1
272%{__mkdir_p} %{buildroot}%{_sysconfdir}/%{name}
273
274# chromium 'make' deposits us back at the top level build directory
275pushd src/out/Release
276ls -l
277
278# clean somechromium-codechanges-zlib.patch
279# clean debug junk
280%{__rm} -rf obj/ mksnapshot obj.target obj.host
281find ./ -type f -name '*.d' | while read i; do %__rm -f $i; done
282# clean NaCl stuff...  maybe NaCl will be in its own package in the future.
283%{__rm} -f ncdecode_table ncdecode_tablegen
284# clean other temporary binaries used in the compilation of chromium
285%{__rm} -f protoc xdg-settings
286
287%{__cp} -rf * %{buildroot}%{_libdir}/%{name}/
288
289# Man page
290[ ! -f %{name}.1 ] && %{__mv} chrome.1 %{name}.1
291%__install -m 0644 %{name}.1 %{buildroot}%{_mandir}/man1
292
293# Add startup file with plugins enabled
294%{__cat} > %{buildroot}%{_bindir}/%{name} <<EOF
295#!/bin/bash
296%{_libdir}/%{name}/chrome-wrapper --enable-plugins --enable-user-scripts --enable-extensions --enable-sync --enable-geolocation --enable-webgl "\$@"
297EOF
298
299# # link to browser plugin path.  Plugin patch doesn't work. Why?
300# %{__mkdir_p} %{buildroot}%{_libdir}/browser-plugins
301# pushd %{buildroot}%{_libdir}/%{name}
302# %{__ln_s} %{_libdir}/browser-plugins plugins
303# popd
304pushd %{buildroot}%{_libdir}/%{name}
305%ifarch x86_64
306%{__ln_s} %{_libdir}/mozilla/plugins-wrapped plugins
307%else
308%{__ln_s} %{_libdir}/mozilla/plugins plugins
309%endif
310
311#touch %{buildroot}%{_libdir}/libavcodec.so.52
312#%{__ln_s} %{_libdir}/libavcodec.so.52 libavcodec.so.52
313#touch %{buildroot}%{_libdir}/libavformat.so.52
314#%{__ln_s} %{_libdir}/libavformat.so.52 libavformat.so.52
315#touch %{buildroot}%{_libdir}/libavutil.so.50
316#%{__ln_s} %{_libdir}/libavutil.so.50 libavutil.so.50
317popd
318
319# Install desktop-related files
320%__install -m 0644 %{SOURCE10} %{buildroot}%{_datadir}/applications/%{name}.desktop
321%__install -m 0644 product_logo_48.png %{buildroot}%{_datadir}/pixmaps/%{name}.png
322desktop-file-install --vendor Vine                      \
323        --dir $RPM_BUILD_ROOT%{_datadir}/applications   \
324        --delete-original                               \
325        --mode 644                                      \
326        $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop
327
328# Install the master_preferences file
329#%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}
330%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}/$(basename %{SOURCE30} .vine)
331
332## install o3d plugin
333#pushd src/o3d/build/out/Release
334#%{__cp} -rf * %{buildroot}%{_libdir}/browser-plugins
335
336%clean
337%{__rm} -rf %{buildroot}
338
339
340%files
341%defattr(-,root,root)
342%doc src/AUTHORS src/LICENSE
343%dir %{_libdir}/%{name}
344%attr(0755,root,root) %{_bindir}/%{name}
345%{_mandir}/man1/*
346%{_datadir}/applications/*%{name}.desktop
347%{_datadir}/pixmaps/%{name}.png
348%{_libdir}/%{name}/*
349%config %{_sysconfdir}/%{name}
350#%{_libdir}/browser-plugins/*
351#%exclude %{_libdir}/libavcodec.so.52
352#%exclude %{_libdir}/libavutil.so.50
353#%exclude %{_libdir}/libavformat.so.52
354
355%changelog
356* Thu Jul 22 2010 IWAI, Masaharu <iwai@alib.jp> 6.0.454.0-2vl5
357- build for Vine Linux 5.x
358  - add BuildRequires: gnome-keyring-devel
359
360* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.454.0-1
361- updated to snapshot 6.0.454
362- added BuildRequires:
363  - sqlite3-devel
364  - gnutls-devel
365  - libgnome-keyring-devel
366
367* Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.431.0-1
368- updated to snapshot 6.0.431.0 r49253
369- added BuildRequires: cups-devel
370
371* Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.405.0-1
372- updated to snapshot 6.0.405.0 r47263
373
374* Fri Apr 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-2
375- unused with_system_icu (for vl6)
376  - used icu-4.2.1-chromium.5.0.353.0.svn41449 (for vl6)
377
378* Wed Apr 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-1
379- updated to snapshot 5.0.378.0 r44472
380  - used with_system_icu (for vl6)
381  - added icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2 (for vl5)
382
383* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.372.0-1
384- updated to snapshot 5.0.372.0 r43947
385- added BuildRequires: glew-devel
386- changed Group tag to Applications/Internet
387- added Summary(ja) and %%description -l ja
388
389* Mon Apr 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.365.0-1
390- updated to snapshot 5.0.365.0 r42966
391- merged 5.0.353.0-4vl5
392 * Fri Apr  2 2010 IWAI, Masaharu <iwai@alib.jp> 5.0.353.0-4vl5
393 - build on Vine Linux 5.1
394   - add BuildRequires: libstdc++34 libstdc++34-devel for Vine5
395
396* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.364.0-1
397- updated to snapshot 5.0.364.0 r42779
398
399* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.359.0-1
400- updated to snapshot 5.0.359.0 r42116
401- dropped chromium-20100122-ubuntu-html5-video-mimetypes.patch
402
403* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-4
404- fixed master_preferences.vine, little
405
406* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-3
407- fixed to install master_preferences
408- dropped chromium-5.0.353-no-ffmpeg-vine.patch
409
410* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-2
411- applied chromium-5.0.353-no-ffmpeg-vine.patch
412
413* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-1
414- updated to snapshot 5.0.353.0 r41449
415  * Wed Mar 10 2010 bgmerrell@novell.com
416  - Add master_preferences source file and install it to /etc/chromium.
417  - Create a new patch (chromium-master-prefs-path.patch) which tells
418    chromium to look in /etc/chromium for the master_preferences file
419    (instead of looking in the default directory, which is the same
420    directory as the 'chrome' binary).
421
422* Sun Feb 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.335.0-1
423- updated to snapshot 5.0.335.0 r39556
424
425* Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-2
426- applied chromium-20100122-ubuntu-html5-video-mimetypes.patch from Gentoo
427
428* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-1
429- updated to snapshot 5.0.330.0 r39074
430
431* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-5
432- use_system_ffmpeg
433
434* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-4
435- added Requires:  nspluginwrapper
436- fixed a symbolic link of plugins directory with nspluginwrapper
437
438* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-3
439- replaced %%{SOUECE20} to chromium-vendor-vine.patch.in
440
441* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-2
442- added BuildRequires: mesa-libGLU-devel
443- added BuildRequires: libstdc++34 libstdc++34-devel for vl5
444
445* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-1
446- built based on chromium-5.0.329.0-167.1.src.rpm of OpenSuse
447
448  * Sun Nov 29 2009 - tittiatcoke@gmail.com - 4.0.260.0
449  - Update to 4.0.260
450  * Fri Nov 27 2009 - tittiatcoke@gmail.com - 4.0.259.0
451  - Update to 4.0.259
452  * Thu Nov 26 2009 - tittiatcoke@gmail.com - 4.0.258.0
453  - Update to 4.0.258
454  * Tue Nov 24 2009 - tittatcoke@gmai.com - 4.0.257.0
455  - In order to complete prevent the wrong v8 version to be used, the Chromium build has been
456    changed to having an built-in v8
457  * Tue Nov 24 2009 - dbuck@example.com - 4.0.257.0
458  - Re-base patches.  Fixed a few patch errors.  Rename some patches to better correspond with function.  Removed some patches.
459  - Minor SPEC changes.  I changed the v8 requirement to be exact, instead of greater than a specific version.
460  * Sat Oct 24 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.223.5
461  - don't create desktop files in wrapper, fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
462  * Tue Oct 20 2009 - Raymond Wooninck >tittiatcoke@gmail.com> - 4.0.223.5
463  - update to newer svn snapshot
464    + Obsoletes fwrite patch (included upstream)
465  * Fri Oct 16 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.223.2
466  - update to newer svn snapshot
467    + Requires newer version of v8
468  * Thu Oct 15 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.222.6
469  - do not force SSE on x86 (drop-sse.patch)
470  * Tue Oct 13 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.222.6
471  - Update to newer svn snapshot
472  - Fixed spec file in order to build
473  - Included patch to build with system zlib
474  * Mon Oct 12 2009 - Pavol Rusnak <prusnak@suse.cz> 4.0.222.2
475  - package renamed to chromium
476  - cleaned up spec file
477  * Tue Oct 6 2009 - dbuck <dbuck@example.com> - 4.0.222.2
478  - v8 is now built as a separate package, and is required
479  - included many patches to use system libraries: v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
480  * Sun Oct 1 2009 - dbuck <dbuck@example.com> - 4.0.221.1
481  - included a newer DEP than is in svn, native_client@823.  So things should compile cleanly now
482  * Sun Aug 31 2009 - dbuck <dbuck@example.com> - 4.0.204.0
483  - initial build
484
485#% changelog
486* Sun Jan 24 2010 prusnak@suse.cz
487- added vendor to user agent (chromium-vendor.patch.in)
488* Sun Nov 29 2009 prusnak@suse.cz
489- added --enable-sync to wrapper to enable bookmark sync
490* Fri Nov 13 2009 tittiatcoke@gmail.com
491- update to 247.0 svn 31928
492* Fri Oct 30 2009 tittiatcoke@gmail.com
493- update to 229.0 svn 30454
494  + Fix regression where popups and app frames lost their titlebars.
495  + Makes it so that when a folder is open on the bookmark bar
496    and the mouse moves over another folder, the menu for that
497    folder is shown.
498  + Lazily create the find bar.
499  + Polish to the gmail checker sample.
500  * New, crisper icons that are exactly 19x19
501  * Add a loading animation at the beginning before Gmail
502    responds.
503  * Fix a bug where we sometimes don't update the UI after a
504    logout/login cycle.
505  + Refactor widget methods to support desktop notifications,
506    including GTK stubs.
507  + Find-in-page should not ding while deleting characters.
508  + Add SSL wrapper for linux and mac.  This allows notifier to
509    use chrome's SSL layer instead of OpenSSL.
510  + Add three of the six extensions to PAC that Internet Explorer supports.
511  + WebSocket support in chromium. (Run with --enable-web-sockets
512    enables WebSocket features.)
513  + Do not allow GTK File Chooser dialogs to return directories.
514  + Fix the notifier SSL layer to make notifications work for
515    Linux Bookmark sync.
516  + linux: don't override mouse selection behavior in omnibox
517* Sun Oct 25 2009 tittiatcoke@gmail.com
518- Update to 224.4 svn 30027
519  + First cut at new page and browser action docs based
520    on new API. Deleted old stuff.
521  + Add suppression for new memory leak caused by WebKit merge 49830:49844
522  + Cleanup: change PIDs to base::ProcessId (or pid_t, as appropriate)
523  + Minimize dependency of user scripts
524  + Fixup the flip_framer eof-handling semantics now that we have
525    the FIN bit in place
526  + app depends on x11 because of active_window_watcher_x
527  + Adding two images for the new Extension managment UI
528  + Removing hard-coded Chrome Frame output path
529  + Rearrange clipboard code
530  + Fix crash bug when attempting to download a url with unsupported scheme,
531    e.g. 'data:', by 'Alt + Click'
532  + GTK: Change text for extension download UI
533  + Ignore invalid urls on command line
534  + Make dropped tabs animate from where they were dropped.
535  + Make room for the full width of the tab placeholder.
536  + Make tab dragging as smooth as glass.
537  + Remove an annoying NOTIMPLEMNETED
538  + Extensions: guarantee removal of BROWSER_WINDOW_READY registration
539  + If we're in the middle of a drag, don't allow the user to middle
540    click to close or right click for the context menu
541  + "Fix" a NOTIMPLEMENTED on Linux by using the default password store
542  + Remove +x bit from files that shouldn't have it
543  + Fold first 3 channels of multichannel instead of 5.  Use fixed point
544  + Adding new image needed for the managment UI
545  + Fix a race bug where content scripts would not apply to the first page load
546  + Make escape remove a bookmark if it's just been added (but not if it already existed)
547  + Fix bubbles deactivating the opaque frame
548  + Allow ESC to cancel ALT+SHIFT+T in Toolbar
549  + ake all pepper plugins default to windowless and transparent
550  + Add styles for printing
551  + Implement the new extension management UI
552  + Add support for to automation interface load install and load extensions
553  + GTK: theme the info bar border
554  + Update V8 to version 1.3.16.1
555  + Introduce WebSecurityPolicy for security related methods
556  + New button scheme...borders are separate from the inner contents so
557    that they can be highlighted / depressed independently
558  + When opening Chrome maximized with an application window already
559    running, the Chrome window was not activated
560  + Fix compatibility problems with FileZilla FTP Server
561  + Remove the extension shelf on Linux
562  + Fix the proxy host and port string to start with http:// if it does not already
563  + Enable HTML5 databases for all extension renderer processes
Note: See TracBrowser for help on using the repository browser.