source: projects/specs/trunk/c/chromium/chromium-vl.spec @ 1707

Revision 1707, 20.9 KB checked in by munepi, 14 years ago (diff)

update chromium

Line 
1# Thanks to malcolmlewis for help with this script
2# Thanks to Tom "spot" Callaway for much of the patchwork
3# Thanks to jhaygood for most of the icu patch
4
5# norootforbuild
6
7%if %{?_dist_release} == "vl6"
8%define with_system_icu 1
9%endif
10
11%define svn_rev 57638
12
13Name:           chromium
14Summary:        Google's opens source browser project
15Summary(ja):    Googleのオープンソースウェブブラウザ
16#'
17Version:        7.0.507.0
18Release:        1%{?_dist_release}
19License:        BSD
20Group:          Applications/Internet
21Source0:        %{name}.%{version}.svn%{svn_rev}.tar.lzma
22## The following are included for source reasons only
23# Custom build tools for chromium, hammer is a fancy front-end for scons
24Source1:        http://src.chromium.org/svn/trunk/tools/depot_tools.tar.gz
25# Script used to create the tar.lzma archive from the daily tarball downloadable at http://build.chromium.org/buildbot/archives/
26Source2:        repack_chromium_archive.sh
27# Script used to create the tar.lzma archive from a checked out source
28#Source3:        pack_chromium_source.sh
29Source3:        pack_chromium_source-vine.sh
30#Source10:       chromium.desktop
31Source10:       chromium-vine.desktop
32# Patch template which adds vendor to user agent
33##!!Source20:       chromium-vendor.patch.in
34Source20:       chromium-vendor-vine.patch.in
35##!!Source30:       master_preferences
36Source30:       master_preferences.vine
37#Source31:       default_bookmarks.html
38#Source31:       default_bookmarks.html.vine
39# icu-4.2.1 contained in chromium.5.0.353.0.svn41449 (for Vine Linux 5.X)
40Source100:      icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2
41
42%{?nosrc:NoSource: 0}
43%{?nosrc:NoSource: 1}
44%{?nosrc:NoSource: 100}
45
46Provides:       chromium-browser = %{version}
47#Obsoletes:      chromium-browser < %{version}
48
49## Start Patches
50# Many changes to the gyp system so we can use system libraries
51# My first ever patch set.  I hope I did well.
52Patch3:         chromium-gyp-system-icu.patch
53Patch4:         chromium-no-sqlite-debug.patch
54Patch5:         chromium-gyp-system-04-nss-nspr.patch
55Patch7:         chromium-codechanges-nss-nspr.patch
56Patch8:         chromium-codechanges-zlib.patch
57#Patch9:         chromium-drop-sse.patch
58Patch10:        chromium-fix-wrapper.patch
59Patch12:        chromium-no-test-sources.patch
60Patch13:        chromium-no-courgette.patch
61Patch14:        chromium-master-prefs-path.patch
62#Patch15:        chromium-media-probe.patch
63#Patch16:        chromium-icu-code-changes.patch
64Patch17:        chromium-system-glew.patch
65Patch18:        chromium-system-expat.patch
66Patch19:        chromium-system-zlib.patch
67Patch20:        chromium-noffmpeg.patch
68Patch21:        chromium-system-old-ffmpeg-way.patch
69Patch23:        chromium-disable-mmx.patch
70#Patch24:       chromium-fix-yuv_row_posix-shared.patch
71Patch25:        tcmalloc-factory.patch
72
73# Vine
74
75
76BuildRequires:  gcc gcc-c++
77%if %{?_dist_release} == "vl5"
78BuildRequires:  libstdc++34 libstdc++34-devel
79%elseif %{?_dist_release} == "vl6"
80BuildRequires:  libstdc++ libstdc++-devel
81%endif
82BuildRequires:  libevent
83##!!BuildRequires:  pkg-config
84BuildRequires:  python
85##!!BuildRequires:  python-xml
86BuildRequires:  python-pyxml
87BuildRequires:  perl bison flex gperf
88##!!BuildRequires:  wdiff
89##!!BuildRequires:  update-desktop-files
90BuildRequires:  desktop-file-utils
91BuildRequires:  lzma
92##!!BuildRequires:  mozilla-nss-devel
93BuildRequires:  nss-devel
94##!!BuildRequires:  alsa-devel
95BuildRequires:  alsa-lib-devel
96BuildRequires:  gtk2-devel
97BuildRequires:  glib2-devel
98BuildRequires:  cairo-devel >= 1.6
99##!!BuildRequires:  mozilla-nspr-devel
100BuildRequires:  nspr-devel
101##!!BuildRequires:  gconf2-devel
102BuildRequires:  GConf2-devel
103BuildRequires:  freetype2-devel
104##!!BuildRequires:  dbus-1-devel
105BuildRequires:  dbus-devel
106BuildRequires:  libxslt-devel
107BuildRequires:  libxml2-devel
108BuildRequires:  libjpeg-devel
109BuildRequires:  zlib-devel
110##!!BuildRequires:  libbz2-devel
111BuildRequires:  bzip2-devel
112BuildRequires:  cups-devel
113%if %{?_dist_release} == "vl6"
114BuildRequires:  fdupes
115%endif
116##!!BuildRequires:  libexpat-devel
117BuildRequires:  expat-devel
118BuildRequires:  libpng-devel
119BuildRequires:  sqlite3-devel
120BuildRequires:  gnutls-devel
121%if %{?_dist_release} == "vl5"
122BuildRequires:  gnome-keyring-devel
123%elseif %{?_dist_release} == "vl6"
124BuildRequires:  libgnome-keyring-devel
125%endif
126BuildRequires:  glew-devel
127##!!BuildRequires:  Mesa-devel
128BuildRequires:  mesa-libGLU-devel
129
130%{?with_system_icu:BuildRequires:  libicu-devel >= 4.0}
131BuildRequires:  libevent-devel
132
133##Vine Linux
134BuildRequires:  libXScrnSaver-devel
135#BuildRequires:  gle-devel
136#BuildRequires:  webkit-gtk-devel
137#BuildRequires:  scons
138%ifarch x86_64
139Requires:  nspluginwrapper
140%endif
141
142##!!Requires:       alsa
143Requires:       alsa-lib
144# shouldn't be required to name all dependencies
145# Requires:       mozilla-nss mozilla-nspr gtk2 glib2 cairo >= 1.6 freetype2 dbus-1 alsa v8 >= 1.3.15
146## Recommends the ffmpeg libraries (available from packman)
147#Recommends:     libavcodec52 libavformat52 libavutil50
148
149BuildRoot:      %{_tmppath}/%{name}-%{version}-root
150
151%description
152Chromium is the open-source project behind Google Chrome.
153We invite you to join us in our effort to help build a safer, faster,
154and more stable way for all Internet users to experience the web,
155and to create a powerful platform for developing a new generation of
156web applications.
157
158%description -l ja
159Chromium は Google Chrome の後方にあるオープンソースプロジェクトです。
160私たちは、ウェブを体験しているすべてのインターネットユーザに対して
161より安全で、より速くて、より安定した方法を築き上げるのを助けるために、
162ウェブアプリケーションの新しい世代を発展させるように
163強力なプラットホームを作成するために、
164私たちの取り組みで私たちに加わるようにあなたを誘います。
165
166
167%prep
168[ -d %{name} ] && %__rm -rf %{name}
169lzma -cd %{SOURCE0} | tar xf -
170%setup -D -T -n %{name}
171
172# use static libicu
173%if %{?_dist_release} == "vl5"
174cd src/third_party || exit 1
175    %__rm -rf icu || exit 1
176    tar jxvf %{SOURCE100} || exit 1
177    %__mv icu-4.2.1-chromium.5.0.353.0.svn41449 icu || exit 1
178cd - || exit 1
179%endif
180
181# use system libicu only if >= 4.0
182%{?with_system_icu:%patch3 -p1}
183
184%patch4 -p1
185%patch5 -p1
186%patch7 -p1
187%patch8 -p1
188#%patch9 -p1
189%patch10 -p1
190%patch12 -p1
191%patch13 -p1
192%patch14 -p1
193#%patch15 -p0
194#%{?with_system_icu:%patch16 -p1}
195%patch17 -p1
196%patch18 -p1
197%patch19 -p1
198%patch20 -p1
199%patch21 -p1
200%patch25 -p1
201%ifarch %ix86
202%patch23 -p1
203%endif
204#%patch24 -p1
205
206
207# apply vendor patch after substitution
208%__sed "s:RPM_VERSION:%{version}-%{release}:" %{SOURCE20} | patch -p0
209
210%build
211## create make files
212
213PARSED_OPT_FLAGS=`echo \'$RPM_OPT_FLAGS -DUSE_SYSTEM_LIBEVENT -fPIC -fno-ipa-cp -fno-strict-aliasing \' | %__sed "s/ /',/g" | %__sed "s/',/', '/g"`
214for i in src/build/common.gypi; do
215        %__sed -i "s|'-march=pentium4',||g" $i
216        %__sed -i "s|'-msse2',||g" $i
217        %__sed -i "s|'-mfpmath=sse',||g" $i
218        %__sed -i "s|'-O<(debug_optimize)',||g" $i
219        %__sed -i "s|'-m32',||g" $i
220        %__sed -i "s|'-fno-exceptions',|$PARSED_OPT_FLAGS|g" $i
221        %__sed -i "s|'-Werror'|'-Wno-error'|g" $i
222done
223# '
224
225pushd src
226
227./build/gyp_chromium -f make build/all.gyp \
228    -Duse_system_ffmpeg=1 \
229    -Duse_system_zlib=1 \
230    -Duse_system_libpng=1 \
231    -Duse_system_bzip2=1 \
232    -Duse_system_libbz2=1 \
233    -Duse_system_libjpeg=1 \
234    -Duse_system_libxml=1 \
235    -Duse_system_libxslt=1 \
236    -Duse_system_libevent=1 \
237    -Dproprietary_codecs=1 \
238    -Dlinux_fpic=1 \
239    %{?with_system_icu:-Duse_system_icu=1} \
240    %{!?with_system_icu:-Duse_system_icu=0} \
241    %ifarch %{ix86}
242        -Dtarget_arch=ia32 \
243         -Ddisable_sse2=1 \
244    %endif
245    %ifarch x86_64
246        -Dtarget_arch=x64 \
247    %endif
248    %if %{?_dist_release} == "vl6"
249        -Dno_strict_aliasing=1 -Dgcc_version=44 \
250    %endif
251    -Drelease_extra_cflags=-fPIC \
252    ;
253
254#make -r %{?jobs:-j%jobs} chrome BUILDTYPE=Release
255#%__make -r -j5 chrome BUILDTYPE=Release
256%__make %{?_smp_mflags} chrome BUILDTYPE=Release
257
258popd
259
260%install
261%{__rm} -rf %{buildroot}
262
263## Create install directories
264%{__mkdir_p} %{buildroot}%{_libdir}/%{name}
265%{__mkdir_p} %{buildroot}%{_bindir}
266%{__mkdir_p} %{buildroot}%{_datadir}/applications
267%{__mkdir_p} %{buildroot}%{_datadir}/pixmaps
268%{__mkdir_p} %{buildroot}%{_mandir}/man1
269%{__mkdir_p} %{buildroot}%{_sysconfdir}/%{name}
270
271# chromium 'make' deposits us back at the top level build directory
272pushd src/out/Release
273ls -l
274
275# clean somechromium-codechanges-zlib.patch
276# clean debug junk
277%{__rm} -rf obj/ mksnapshot obj.target obj.host
278find ./ -type f -name '*.d' | while read i; do %__rm -f $i; done
279# clean NaCl stuff...  maybe NaCl will be in its own package in the future.
280%{__rm} -f ncdecode_table ncdecode_tablegen
281# clean other temporary binaries used in the compilation of chromium
282%{__rm} -f protoc xdg-settings
283
284%{__cp} -rf * %{buildroot}%{_libdir}/%{name}/
285
286# Man page
287[ ! -f %{name}.1 ] && %{__mv} chrome.1 %{name}.1
288%__install -m 0644 %{name}.1 %{buildroot}%{_mandir}/man1
289
290# Add startup file with plugins enabled
291%{__cat} > %{buildroot}%{_bindir}/%{name} <<EOF
292#!/bin/bash
293%{_libdir}/%{name}/chrome-wrapper --enable-plugins --enable-user-scripts --enable-extensions --enable-sync --enable-geolocation --enable-webgl --enable-nacl "\$@"
294EOF
295
296# # link to browser plugin path.  Plugin patch doesn't work. Why?
297# %{__mkdir_p} %{buildroot}%{_libdir}/browser-plugins
298# pushd %{buildroot}%{_libdir}/%{name}
299# %{__ln_s} %{_libdir}/browser-plugins plugins
300# popd
301pushd %{buildroot}%{_libdir}/%{name}
302%ifarch x86_64
303%{__ln_s} %{_libdir}/mozilla/plugins-wrapped plugins
304%else
305%{__ln_s} %{_libdir}/mozilla/plugins plugins
306%endif
307
308## support ffmpeg libs
309touch %{buildroot}%{_libdir}/libavcodec.so.52
310%{__ln_s} %{_libdir}/libavcodec.so.52 libavcodec.so.52
311touch %{buildroot}%{_libdir}/libavformat.so.52
312%{__ln_s} %{_libdir}/libavformat.so.52 libavformat.so.52
313touch %{buildroot}%{_libdir}/libavutil.so.50
314%{__ln_s} %{_libdir}/libavutil.so.50 libavutil.so.50
315popd
316
317# Install desktop-related files
318%__install -m 0644 %{SOURCE10} %{buildroot}%{_datadir}/applications/%{name}.desktop
319%__install -m 0644 product_logo_48.png %{buildroot}%{_datadir}/pixmaps/%{name}.png
320desktop-file-install --vendor Vine                      \
321        --dir $RPM_BUILD_ROOT%{_datadir}/applications   \
322        --delete-original                               \
323        --mode 644                                      \
324        $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop
325
326# Install the master_preferences file
327#%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}
328%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}/$(basename %{SOURCE30} .vine)
329
330## install o3d plugin
331#pushd src/o3d/build/out/Release
332#%{__cp} -rf * %{buildroot}%{_libdir}/browser-plugins
333
334%clean
335%{__rm} -rf %{buildroot}
336
337
338%files
339%defattr(-,root,root)
340%doc src/AUTHORS src/LICENSE
341%dir %{_libdir}/%{name}
342%attr(0755,root,root) %{_bindir}/%{name}
343%{_mandir}/man1/*
344%{_datadir}/applications/*%{name}.desktop
345%{_datadir}/pixmaps/%{name}.png
346%{_libdir}/%{name}/*
347%config %{_sysconfdir}/%{name}
348#%{_libdir}/browser-plugins/*
349%exclude %{_libdir}/libavcodec.so.52
350%exclude %{_libdir}/libavutil.so.50
351%exclude %{_libdir}/libavformat.so.52
352
353%changelog
354* Sat Aug 28 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.507.0-1
355- updated to snapshot 7.0.507
356
357* Wed Aug 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.498.0-1
358- updated to snapshot 7.0.498
359
360* Sat Aug 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.493.0-1
361- updated to snapshot 6.0.493
362- used with_system_icu (for vl6)
363  - added BuildRequires: libicu-devel
364
365* Thu Jul 22 2010 IWAI, Masaharu <iwai@alib.jp> 6.0.454.0-2vl5
366- build for Vine Linux 5.x
367  - add BuildRequires: gnome-keyring-devel
368
369* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.454.0-1
370- updated to snapshot 6.0.454
371- added BuildRequires:
372  - sqlite3-devel
373  - gnutls-devel
374  - libgnome-keyring-devel
375
376* Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.431.0-1
377- updated to snapshot 6.0.431.0 r49253
378- added BuildRequires: cups-devel
379
380* Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.405.0-1
381- updated to snapshot 6.0.405.0 r47263
382
383* Fri Apr 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-2
384- unused with_system_icu (for vl6)
385  - used icu-4.2.1-chromium.5.0.353.0.svn41449 (for vl6)
386
387* Wed Apr 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-1
388- updated to snapshot 5.0.378.0 r44472
389  - used with_system_icu (for vl6)
390  - added icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2 (for vl5)
391
392* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.372.0-1
393- updated to snapshot 5.0.372.0 r43947
394- added BuildRequires: glew-devel
395- changed Group tag to Applications/Internet
396- added Summary(ja) and %%description -l ja
397
398* Mon Apr 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.365.0-1
399- updated to snapshot 5.0.365.0 r42966
400- merged 5.0.353.0-4vl5
401 * Fri Apr  2 2010 IWAI, Masaharu <iwai@alib.jp> 5.0.353.0-4vl5
402 - build on Vine Linux 5.1
403   - add BuildRequires: libstdc++34 libstdc++34-devel for Vine5
404
405* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.364.0-1
406- updated to snapshot 5.0.364.0 r42779
407
408* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.359.0-1
409- updated to snapshot 5.0.359.0 r42116
410- dropped chromium-20100122-ubuntu-html5-video-mimetypes.patch
411
412* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-4
413- fixed master_preferences.vine, little
414
415* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-3
416- fixed to install master_preferences
417- dropped chromium-5.0.353-no-ffmpeg-vine.patch
418
419* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-2
420- applied chromium-5.0.353-no-ffmpeg-vine.patch
421
422* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-1
423- updated to snapshot 5.0.353.0 r41449
424  * Wed Mar 10 2010 bgmerrell@novell.com
425  - Add master_preferences source file and install it to /etc/chromium.
426  - Create a new patch (chromium-master-prefs-path.patch) which tells
427    chromium to look in /etc/chromium for the master_preferences file
428    (instead of looking in the default directory, which is the same
429    directory as the 'chrome' binary).
430
431* Sun Feb 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.335.0-1
432- updated to snapshot 5.0.335.0 r39556
433
434* Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-2
435- applied chromium-20100122-ubuntu-html5-video-mimetypes.patch from Gentoo
436
437* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-1
438- updated to snapshot 5.0.330.0 r39074
439
440* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-5
441- use_system_ffmpeg
442
443* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-4
444- added Requires:  nspluginwrapper
445- fixed a symbolic link of plugins directory with nspluginwrapper
446
447* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-3
448- replaced %%{SOUECE20} to chromium-vendor-vine.patch.in
449
450* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-2
451- added BuildRequires: mesa-libGLU-devel
452- added BuildRequires: libstdc++34 libstdc++34-devel for vl5
453
454* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-1
455- built based on chromium-5.0.329.0-167.1.src.rpm of OpenSuse
456
457  * Sun Nov 29 2009 - tittiatcoke@gmail.com - 4.0.260.0
458  - Update to 4.0.260
459  * Fri Nov 27 2009 - tittiatcoke@gmail.com - 4.0.259.0
460  - Update to 4.0.259
461  * Thu Nov 26 2009 - tittiatcoke@gmail.com - 4.0.258.0
462  - Update to 4.0.258
463  * Tue Nov 24 2009 - tittatcoke@gmai.com - 4.0.257.0
464  - In order to complete prevent the wrong v8 version to be used, the Chromium build has been
465    changed to having an built-in v8
466  * Tue Nov 24 2009 - dbuck@example.com - 4.0.257.0
467  - Re-base patches.  Fixed a few patch errors.  Rename some patches to better correspond with function.  Removed some patches.
468  - Minor SPEC changes.  I changed the v8 requirement to be exact, instead of greater than a specific version.
469  * Sat Oct 24 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.223.5
470  - don't create desktop files in wrapper, fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
471  * Tue Oct 20 2009 - Raymond Wooninck >tittiatcoke@gmail.com> - 4.0.223.5
472  - update to newer svn snapshot
473    + Obsoletes fwrite patch (included upstream)
474  * Fri Oct 16 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.223.2
475  - update to newer svn snapshot
476    + Requires newer version of v8
477  * Thu Oct 15 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.222.6
478  - do not force SSE on x86 (drop-sse.patch)
479  * Tue Oct 13 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.222.6
480  - Update to newer svn snapshot
481  - Fixed spec file in order to build
482  - Included patch to build with system zlib
483  * Mon Oct 12 2009 - Pavol Rusnak <prusnak@suse.cz> 4.0.222.2
484  - package renamed to chromium
485  - cleaned up spec file
486  * Tue Oct 6 2009 - dbuck <dbuck@example.com> - 4.0.222.2
487  - v8 is now built as a separate package, and is required
488  - included many patches to use system libraries: v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
489  * Sun Oct 1 2009 - dbuck <dbuck@example.com> - 4.0.221.1
490  - included a newer DEP than is in svn, native_client@823.  So things should compile cleanly now
491  * Sun Aug 31 2009 - dbuck <dbuck@example.com> - 4.0.204.0
492  - initial build
493
494#% changelog
495* Sun Jan 24 2010 prusnak@suse.cz
496- added vendor to user agent (chromium-vendor.patch.in)
497* Sun Nov 29 2009 prusnak@suse.cz
498- added --enable-sync to wrapper to enable bookmark sync
499* Fri Nov 13 2009 tittiatcoke@gmail.com
500- update to 247.0 svn 31928
501* Fri Oct 30 2009 tittiatcoke@gmail.com
502- update to 229.0 svn 30454
503  + Fix regression where popups and app frames lost their titlebars.
504  + Makes it so that when a folder is open on the bookmark bar
505    and the mouse moves over another folder, the menu for that
506    folder is shown.
507  + Lazily create the find bar.
508  + Polish to the gmail checker sample.
509  * New, crisper icons that are exactly 19x19
510  * Add a loading animation at the beginning before Gmail
511    responds.
512  * Fix a bug where we sometimes don't update the UI after a
513    logout/login cycle.
514  + Refactor widget methods to support desktop notifications,
515    including GTK stubs.
516  + Find-in-page should not ding while deleting characters.
517  + Add SSL wrapper for linux and mac.  This allows notifier to
518    use chrome's SSL layer instead of OpenSSL.
519  + Add three of the six extensions to PAC that Internet Explorer supports.
520  + WebSocket support in chromium. (Run with --enable-web-sockets
521    enables WebSocket features.)
522  + Do not allow GTK File Chooser dialogs to return directories.
523  + Fix the notifier SSL layer to make notifications work for
524    Linux Bookmark sync.
525  + linux: don't override mouse selection behavior in omnibox
526* Sun Oct 25 2009 tittiatcoke@gmail.com
527- Update to 224.4 svn 30027
528  + First cut at new page and browser action docs based
529    on new API. Deleted old stuff.
530  + Add suppression for new memory leak caused by WebKit merge 49830:49844
531  + Cleanup: change PIDs to base::ProcessId (or pid_t, as appropriate)
532  + Minimize dependency of user scripts
533  + Fixup the flip_framer eof-handling semantics now that we have
534    the FIN bit in place
535  + app depends on x11 because of active_window_watcher_x
536  + Adding two images for the new Extension managment UI
537  + Removing hard-coded Chrome Frame output path
538  + Rearrange clipboard code
539  + Fix crash bug when attempting to download a url with unsupported scheme,
540    e.g. 'data:', by 'Alt + Click'
541  + GTK: Change text for extension download UI
542  + Ignore invalid urls on command line
543  + Make dropped tabs animate from where they were dropped.
544  + Make room for the full width of the tab placeholder.
545  + Make tab dragging as smooth as glass.
546  + Remove an annoying NOTIMPLEMNETED
547  + Extensions: guarantee removal of BROWSER_WINDOW_READY registration
548  + If we're in the middle of a drag, don't allow the user to middle
549    click to close or right click for the context menu
550  + "Fix" a NOTIMPLEMENTED on Linux by using the default password store
551  + Remove +x bit from files that shouldn't have it
552  + Fold first 3 channels of multichannel instead of 5.  Use fixed point
553  + Adding new image needed for the managment UI
554  + Fix a race bug where content scripts would not apply to the first page load
555  + Make escape remove a bookmark if it's just been added (but not if it already existed)
556  + Fix bubbles deactivating the opaque frame
557  + Allow ESC to cancel ALT+SHIFT+T in Toolbar
558  + ake all pepper plugins default to windowless and transparent
559  + Add styles for printing
560  + Implement the new extension management UI
561  + Add support for to automation interface load install and load extensions
562  + GTK: theme the info bar border
563  + Update V8 to version 1.3.16.1
564  + Introduce WebSecurityPolicy for security related methods
565  + New button scheme...borders are separate from the inner contents so
566    that they can be highlighted / depressed independently
567  + When opening Chrome maximized with an application window already
568    running, the Chrome window was not activated
569  + Fix compatibility problems with FileZilla FTP Server
570  + Remove the extension shelf on Linux
571  + Fix the proxy host and port string to start with http:// if it does not already
572  + Enable HTML5 databases for all extension renderer processes
Note: See TracBrowser for help on using the repository browser.