source: projects/specs/trunk/b/bzr/bzr-vl.spec @ 7322

Revision 7322, 9.7 KB checked in by iwaim, 11 years ago (diff)

bzr 2.5.1-1

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3# All package versioning is found here:
4# the actual version is composed from these below, including leading 0 for release candidates
5#   bzrmajor:  main bzr version
6#   Version: bzr version, add subrelease version here
7#   bzrrc: release candidate version, if any, line starts with % for rc, # for stable releas (no %).
8
9%define bzrmajor 2.5
10%define bzrminor 1
11
12Name:           bzr
13Version:        %{bzrmajor}%{?bzrminor:.}%{?bzrminor}
14Release:        1%{?_dist_release}
15Summary:        Friendly distributed version control system
16Summary(ja):    bzr - 分散型バージョン管理システム
17
18Group:          Development/Tools
19License:        GPLv2+
20URL:            http://www.bazaar-vcs.org/
21Source0:        https://launchpad.net/%{name}/%{bzrmajor}/%{version}/+download/%{name}-%{version}.tar.gz
22Source1:        https://launchpad.net/%{name}/%{bzrmajor}/%{version}/+download/%{name}-%{version}.tar.gz.sig
23BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
24
25BuildRequires:  python-devel zlib-devel
26# We're using an old version of Pyrex, use the pregenerated C files instead
27# of rebuilding
28#BuildRequires: Pyrex
29Requires:   python-paramiko
30# Workaround Bug #230223 otherwise this would be a soft dependency
31Requires:   python-pycurl
32
33Vendor: Project Vine
34Distribution: Vine Linux
35
36%description
37Bazaar is a distributed revision control system that is powerful, friendly,
38and scalable.  It is the successor of Baz-1.x which, in turn, was
39a user-friendly reimplementation of GNU Arch.
40
41
42%prep
43%setup -q -n %{name}-%{version}
44
45sed -i '1{/#![[:space:]]*\/usr\/bin\/\(python\|env\)/d}' bzrlib/_patiencediff_py.py
46sed -i '1{/#![[:space:]]*\/usr\/bin\/\(python\|env\)/d}' bzrlib/weave.py
47
48%build
49CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py build
50
51chmod a-x contrib/bash/bzrbashprompt.sh
52
53%install
54rm -rf $RPM_BUILD_ROOT
55%{__python} setup.py install --skip-build --install-data %{_datadir} --root $RPM_BUILD_ROOT
56chmod 0644 contrib/bzr_access
57chmod 0644 contrib/bzr_ssh_path_limiter
58chmod 0755 $RPM_BUILD_ROOT%{python_sitearch}/bzrlib/*.so
59
60install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/
61install -m 0644 contrib/bash/bzr $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/
62rm contrib/bash/bzr
63
64# This is included in %doc, remove redundancy here
65#rm -rf $RPM_BUILD_ROOT%{python_sitearch}/bzrlib/doc/
66
67# Use independently packaged python-elementtree instead
68rm -rf $RPM_BUILD_ROOT%{python_sitearch}/bzrlib/util/elementtree/
69
70%{find_lang} %{name}
71
72%clean
73rm -rf $RPM_BUILD_ROOT
74
75
76%files -f %{name}.lang
77%defattr(-,root,root,-)
78%doc NEWS README TODO COPYING.txt doc/  contrib/
79%{_bindir}/bzr
80%{_mandir}/man1/*
81%{python_sitearch}/bzrlib/
82%{python_sitearch}/*.egg-info
83%{_sysconfdir}/bash_completion.d/
84
85%changelog
86* Thu Jan  3 2013 IWAI, Masaharu <iwai@alib.jp> 2.5.1-1
87- new upstream release
88- add .mo files
89
90* Mon May 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
91- new upstream release
92
93* Thu Mar 31 2011 IWAI, Masaharu <iwai@alib.jp> 2.3.1-1
94- new upstream release
95- add Vendor and Distribution tags
96
97* Sun Dec 12 2010 IWAI, Masaharu <iwai@alib.jp> 2.2.2-1
98- new upstream release
99
100* Mon Apr 19 2010 Shu KONNO <owa@bg.wakwak.com> 1.17-2
101- rebuilt with python-2.6
102
103* Thu Aug  6 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.17-1
104- initial build for VineSeed
105
106* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.17-2
107- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
108
109* Mon Jul 20 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.17-1
110- Upgade to 1.17
111
112* Mon Jul 13 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.17-0.1
113- Update to 1.17rc1
114
115* Fri Jun 26 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.16.1-1
116- Update to 1.16.1
117
118* Thu Jun 18 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.16-1
119- Update to 1.16
120
121* Wed Jun 10 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.15.1-1
122- Update to 1.15.1
123
124* Sat May 23 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.15-2
125- Update to 1.15final
126
127* Sat May 16 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.15-0.1
128- Update to 1.15rc1
129
130* Sat May 02 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.14.1-1
131- Update to 1.14.1
132
133* Wed Apr 29 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.14-1
134- Update to 1.14
135
136* Mon Apr 20 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.14-0.3.rc2
137- Update to 1.14rc2
138
139* Sat Apr 11 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.14-0.2.rc1
140- Correct build dependencies
141
142* Thu Apr 09 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.14-0.1.rc1
143- Update to 1.14rc1
144
145* Tue Mar 24 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.13.1-1
146- Update to 1.13.1
147
148* Mon Mar 16 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.13-1
149- Update to 1.13
150
151* Tue Mar 10 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.13-0.1.rc1
152- Update to 1.13rc1
153
154* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.12-2
155- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
156
157* Fri Feb 13 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.12-1
158- Update to 1.12
159
160* Tue Feb 10 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.12-0.1.rc1
161- Update to 1.12rc1
162
163* Mon Jan 19 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.11-1
164- Update to 1.11
165
166* Wed Dec 10 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.10-1
167- Update to 1.10
168
169* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.9-2
170- Rebuild for Python 2.6
171
172* Thu Nov 13 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.9-1
173- Update to 1.9
174
175* Thu Sep 25 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.7-1
176- 1.7 Final
177
178* Wed Sep 3 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.7-0.1.rc2
179- 1.7rc2
180- Remove executable permission from a %%doc file
181
182* Wed Sep 3 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.6.1-0.1.rc2
183- New upstream bugfix release.
184
185* Thu May 21 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.5-2
186- Upload tarball.
187
188* Wed May 21 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.5-1
189- Update to 1.5.
190
191* Thu May 15 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.4-2
192- Workaround upstream Bug# 230223 by Requiring python-pycurl.
193
194* Mon May 5 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.4-1
195- Update to 1.4.
196
197* Sun Apr 27 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.3.1-1
198- Paramiko/sftp backport from 1.4.0. bz#444325
199- Update to 1.3.1 final.
200
201* Sat Apr 4 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.3.1-0.1.rc1
202- Update to 1.3.1rc1 to fix a bug when you have a pack based remote repo and
203  knit based local branch.
204
205* Wed Mar 26 2008 Warren Togami <wtogami@redhat.com> - 1.3-1
206- Update to 1.3.
207
208* Mon Feb 25 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.2-1
209- Update to 1.2.
210
211* Fri Feb 8 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.1-2
212- Rebuild for new gcc.
213
214* Mon Jan 21 2008 Toshio Kuratomi <a.badger@gmail.com> - 1.1-1
215- Upstream 1.1 bugfix and performance enhancement release.
216- Enable bash completion script from the contrib directory.
217
218* Thu Dec 13 2007 Toshio Kuratomi <a.badger@gmail.com> - 1.0-1
219- Update to 1.0 final.
220
221* Tue Dec 11 2007 Toshio Kuratomi <a.badger@gmail.com> - 1.0-0.1.rc3
222- Update to 1.0rc3
223- The new rawhide python package generates egg-info files.
224
225* Fri Nov 30 2007 Toshio Kuratomi <a.badger@gmail.com> - 1.0-0.1.rc2
226- Update to 1.0rc2
227
228* Tue Aug 28 2007 Toshio Kuratomi <a.badger@gmail.com> - 0.91-1
229- Update to 0.91.
230  + Fixes some issues with using tag-enabled branches.
231
232* Tue Aug 28 2007 Toshio Kuratomi <a.badger@gmail.com> - 0.90-1
233- Update to 0.90
234
235* Mon Aug 27 2007 Toshio Kuratomi <a.badger@gmail.com> - 0.90-0.1.rc1
236- Update to 0.90rc1.
237- 0.90 contains some pyrex code to speed things up.  bzr is now arch specific.
238- Update license tag.
239
240* Wed Jul 25 2007 Warren Togami <wtogami@redhat.com> - 0.18-1
241- Update to 0.18.
242
243* Tue Jun 26 2007 Warren Togami <wtogami@redhat.com>  - 0.17-2
244- Update to 0.17.
245
246* Tue May 08 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.16-1
247- Update to 0.16.
248
249* Thu Mar 22 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.15-1
250- Update to 0.15.
251- Simplify the %%files list.
252
253* Tue Jan 23 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.14-1
254- Update to 0.14
255
256* Sun Dec 10 2006 Toshio Kuratomi <toshio@tiki-lounge.com> 0.13-2
257- Conditionalize the python-elementtree requires as python2.5 in FC7 includes
258  elementtree
259
260* Wed Dec 6 2006 Toshio Kuratomi <toshio@tiki-lounge.com> 0.13-1
261- Update to 0.13
262
263* Thu Oct 30 2006 Toshio Kuratomi <toshio@tiki-lounge.com> 0.12-1
264- Update to 0.12
265
266* Thu Oct 08 2006 Toshio Kuratomi <toshio@tiki-lounge.com> 0.11-1
267- Update to 0.11
268- New download location.
269
270* Sun Sep 17 2006 Warren Togami <wtogami@redhat.com> 0.10-1
271- 0.10
272
273* Fri Aug 11 2006 Shahms E. King <shahms@shahms.com> 0.9-1
274- Update to new upstream
275
276* Fri Aug 11 2006 Shahms E. King <shahms@shahms.com> 0.8.2-3
277- Include, don't ghost .pyo files per new guidelines
278
279* Mon Jun 26 2006 Shahms E. King <shahms@shahms.com> 0.8.2-2
280- Require python-paramiko for sftp support
281
282* Tue May 23 2006 Shahms E. King <shahms@shahms.com> 0.8.2-1
283- Update to new upstream version
284- Fix dist tag
285
286* Wed May 10 2006 Shahms E. King <shahms@shahms.com> 0.8-1
287- Update to new upstream version
288- Update bzr-sys-etree.patch for changes
289
290* Mon Feb 13 2006 Shahms E. King <shahms@shahms.com> 0.7-3
291- Add python-elementtree to BuildRequires
292
293* Mon Feb 13 2006 Shahms E. King <shahms@shahms.com> 0.7-2
294- Add dist tag
295
296* Fri Feb 10 2006 Shahms E. King <shahms@shahms.com> 0.7-1
297- Update to 0.7
298
299* Thu Jan 26 2006 Shahms E. King <shahms@shahms.com> 0.6.2-2
300- Fix system library patch
301
302* Wed Dec 07 2005 Shahms E. King <shahms@shahms.com> 0.6.2-1
303- Initial package
Note: See TracBrowser for help on using the repository browser.