source: projects/specs/trunk/b/bzr/bzr-vl.spec @ 11097

Revision 11097, 9.9 KB checked in by iwaim, 7 years ago (diff)

bzr 2.7.0-1

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3# All package versioning is found here:
4# the actual version is composed from these below, including leading 0 for release candidates
5#   bzrmajor:  main bzr version
6#   Version: bzr version, add subrelease version here
7#   bzrrc: release candidate version, if any, line starts with % for rc, # for stable releas (no %).
8
9%define bzrmajor 2.7
10%define bzrminor 0
11
12Name:           bzr
13Version:        %{bzrmajor}%{?bzrminor:.}%{?bzrminor}
14Release:        1%{?_dist_release}
15Summary:        Friendly distributed version control system
16Summary(ja):    bzr - 分散型バージョン管理システム
17
18Group:          Development/Tools
19License:        GPLv2+
20URL:            http://www.bazaar-vcs.org/
21Source0:        https://launchpad.net/%{name}/%{bzrmajor}/%{version}/+download/%{name}-%{version}.tar.gz
22Source1:        https://launchpad.net/%{name}/%{bzrmajor}/%{version}/+download/%{name}-%{version}.tar.gz.sig
23BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
24
25BuildRequires:  python-devel zlib-devel
26# We're using an old version of Pyrex, use the pregenerated C files instead
27# of rebuilding
28#BuildRequires: Pyrex
29Requires:   python-paramiko
30# Workaround Bug #230223 otherwise this would be a soft dependency
31Requires:   python-pycurl
32
33Vendor: Project Vine
34Distribution: Vine Linux
35Packager: iwaim
36
37%description
38Bazaar is a distributed revision control system that is powerful, friendly,
39and scalable.  It is the successor of Baz-1.x which, in turn, was
40a user-friendly reimplementation of GNU Arch.
41
42
43%prep
44%setup -q -n %{name}-%{version}
45
46sed -i '1{/#![[:space:]]*\/usr\/bin\/\(python\|env\)/d}' bzrlib/_patiencediff_py.py
47sed -i '1{/#![[:space:]]*\/usr\/bin\/\(python\|env\)/d}' bzrlib/weave.py
48
49%build
50CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py build
51
52chmod a-x contrib/bash/bzrbashprompt.sh
53
54%install
55rm -rf $RPM_BUILD_ROOT
56%{__python} setup.py install --skip-build --install-data %{_datadir} --root $RPM_BUILD_ROOT
57chmod 0644 contrib/bzr_access
58chmod 0644 contrib/bzr_ssh_path_limiter
59chmod 0755 $RPM_BUILD_ROOT%{python_sitearch}/bzrlib/*.so
60
61install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/
62install -m 0644 contrib/bash/bzr $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/
63rm contrib/bash/bzr
64
65# This is included in %doc, remove redundancy here
66#rm -rf $RPM_BUILD_ROOT%{python_sitearch}/bzrlib/doc/
67
68# Use independently packaged python-elementtree instead
69rm -rf $RPM_BUILD_ROOT%{python_sitearch}/bzrlib/util/elementtree/
70
71%{find_lang} %{name}
72
73%clean
74rm -rf $RPM_BUILD_ROOT
75
76
77%files -f %{name}.lang
78%defattr(-,root,root,-)
79%doc NEWS README TODO COPYING.txt doc/  contrib/
80%{_bindir}/bzr
81%{_mandir}/man1/*
82%{python_sitearch}/bzrlib/
83%{python_sitearch}/*.egg-info
84%{_sysconfdir}/bash_completion.d/
85
86%changelog
87* Sat Feb 25 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2.7.0-1
88- update to 2.7.0
89
90* Mon Dec 30 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 2.6.0-1
91- update to 2.6.0
92- add Packager tag
93
94* Thu Jan  3 2013 IWAI, Masaharu <iwai@alib.jp> 2.5.1-1
95- new upstream release
96- add .mo files
97
98* Mon May 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
99- new upstream release
100
101* Thu Mar 31 2011 IWAI, Masaharu <iwai@alib.jp> 2.3.1-1
102- new upstream release
103- add Vendor and Distribution tags
104
105* Sun Dec 12 2010 IWAI, Masaharu <iwai@alib.jp> 2.2.2-1
106- new upstream release
107
108* Mon Apr 19 2010 Shu KONNO <owa@bg.wakwak.com> 1.17-2
109- rebuilt with python-2.6
110
111* Thu Aug  6 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.17-1
112- initial build for VineSeed
113
114* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.17-2
115- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
116
117* Mon Jul 20 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.17-1
118- Upgade to 1.17
119
120* Mon Jul 13 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.17-0.1
121- Update to 1.17rc1
122
123* Fri Jun 26 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.16.1-1
124- Update to 1.16.1
125
126* Thu Jun 18 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.16-1
127- Update to 1.16
128
129* Wed Jun 10 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.15.1-1
130- Update to 1.15.1
131
132* Sat May 23 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.15-2
133- Update to 1.15final
134
135* Sat May 16 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.15-0.1
136- Update to 1.15rc1
137
138* Sat May 02 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.14.1-1
139- Update to 1.14.1
140
141* Wed Apr 29 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.14-1
142- Update to 1.14
143
144* Mon Apr 20 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.14-0.3.rc2
145- Update to 1.14rc2
146
147* Sat Apr 11 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.14-0.2.rc1
148- Correct build dependencies
149
150* Thu Apr 09 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.14-0.1.rc1
151- Update to 1.14rc1
152
153* Tue Mar 24 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.13.1-1
154- Update to 1.13.1
155
156* Mon Mar 16 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.13-1
157- Update to 1.13
158
159* Tue Mar 10 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.13-0.1.rc1
160- Update to 1.13rc1
161
162* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.12-2
163- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
164
165* Fri Feb 13 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.12-1
166- Update to 1.12
167
168* Tue Feb 10 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.12-0.1.rc1
169- Update to 1.12rc1
170
171* Mon Jan 19 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.11-1
172- Update to 1.11
173
174* Wed Dec 10 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.10-1
175- Update to 1.10
176
177* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.9-2
178- Rebuild for Python 2.6
179
180* Thu Nov 13 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.9-1
181- Update to 1.9
182
183* Thu Sep 25 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.7-1
184- 1.7 Final
185
186* Wed Sep 3 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.7-0.1.rc2
187- 1.7rc2
188- Remove executable permission from a %%doc file
189
190* Wed Sep 3 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.6.1-0.1.rc2
191- New upstream bugfix release.
192
193* Thu May 21 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.5-2
194- Upload tarball.
195
196* Wed May 21 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.5-1
197- Update to 1.5.
198
199* Thu May 15 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.4-2
200- Workaround upstream Bug# 230223 by Requiring python-pycurl.
201
202* Mon May 5 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.4-1
203- Update to 1.4.
204
205* Sun Apr 27 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.3.1-1
206- Paramiko/sftp backport from 1.4.0. bz#444325
207- Update to 1.3.1 final.
208
209* Sat Apr 4 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.3.1-0.1.rc1
210- Update to 1.3.1rc1 to fix a bug when you have a pack based remote repo and
211  knit based local branch.
212
213* Wed Mar 26 2008 Warren Togami <wtogami@redhat.com> - 1.3-1
214- Update to 1.3.
215
216* Mon Feb 25 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.2-1
217- Update to 1.2.
218
219* Fri Feb 8 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.1-2
220- Rebuild for new gcc.
221
222* Mon Jan 21 2008 Toshio Kuratomi <a.badger@gmail.com> - 1.1-1
223- Upstream 1.1 bugfix and performance enhancement release.
224- Enable bash completion script from the contrib directory.
225
226* Thu Dec 13 2007 Toshio Kuratomi <a.badger@gmail.com> - 1.0-1
227- Update to 1.0 final.
228
229* Tue Dec 11 2007 Toshio Kuratomi <a.badger@gmail.com> - 1.0-0.1.rc3
230- Update to 1.0rc3
231- The new rawhide python package generates egg-info files.
232
233* Fri Nov 30 2007 Toshio Kuratomi <a.badger@gmail.com> - 1.0-0.1.rc2
234- Update to 1.0rc2
235
236* Tue Aug 28 2007 Toshio Kuratomi <a.badger@gmail.com> - 0.91-1
237- Update to 0.91.
238  + Fixes some issues with using tag-enabled branches.
239
240* Tue Aug 28 2007 Toshio Kuratomi <a.badger@gmail.com> - 0.90-1
241- Update to 0.90
242
243* Mon Aug 27 2007 Toshio Kuratomi <a.badger@gmail.com> - 0.90-0.1.rc1
244- Update to 0.90rc1.
245- 0.90 contains some pyrex code to speed things up.  bzr is now arch specific.
246- Update license tag.
247
248* Wed Jul 25 2007 Warren Togami <wtogami@redhat.com> - 0.18-1
249- Update to 0.18.
250
251* Tue Jun 26 2007 Warren Togami <wtogami@redhat.com>  - 0.17-2
252- Update to 0.17.
253
254* Tue May 08 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.16-1
255- Update to 0.16.
256
257* Thu Mar 22 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.15-1
258- Update to 0.15.
259- Simplify the %%files list.
260
261* Tue Jan 23 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.14-1
262- Update to 0.14
263
264* Sun Dec 10 2006 Toshio Kuratomi <toshio@tiki-lounge.com> 0.13-2
265- Conditionalize the python-elementtree requires as python2.5 in FC7 includes
266  elementtree
267
268* Wed Dec 6 2006 Toshio Kuratomi <toshio@tiki-lounge.com> 0.13-1
269- Update to 0.13
270
271* Thu Oct 30 2006 Toshio Kuratomi <toshio@tiki-lounge.com> 0.12-1
272- Update to 0.12
273
274* Thu Oct 08 2006 Toshio Kuratomi <toshio@tiki-lounge.com> 0.11-1
275- Update to 0.11
276- New download location.
277
278* Sun Sep 17 2006 Warren Togami <wtogami@redhat.com> 0.10-1
279- 0.10
280
281* Fri Aug 11 2006 Shahms E. King <shahms@shahms.com> 0.9-1
282- Update to new upstream
283
284* Fri Aug 11 2006 Shahms E. King <shahms@shahms.com> 0.8.2-3
285- Include, don't ghost .pyo files per new guidelines
286
287* Mon Jun 26 2006 Shahms E. King <shahms@shahms.com> 0.8.2-2
288- Require python-paramiko for sftp support
289
290* Tue May 23 2006 Shahms E. King <shahms@shahms.com> 0.8.2-1
291- Update to new upstream version
292- Fix dist tag
293
294* Wed May 10 2006 Shahms E. King <shahms@shahms.com> 0.8-1
295- Update to new upstream version
296- Update bzr-sys-etree.patch for changes
297
298* Mon Feb 13 2006 Shahms E. King <shahms@shahms.com> 0.7-3
299- Add python-elementtree to BuildRequires
300
301* Mon Feb 13 2006 Shahms E. King <shahms@shahms.com> 0.7-2
302- Add dist tag
303
304* Fri Feb 10 2006 Shahms E. King <shahms@shahms.com> 0.7-1
305- Update to 0.7
306
307* Thu Jan 26 2006 Shahms E. King <shahms@shahms.com> 0.6.2-2
308- Fix system library patch
309
310* Wed Dec 07 2005 Shahms E. King <shahms@shahms.com> 0.6.2-1
311- Initial package
Note: See TracBrowser for help on using the repository browser.