source: projects/specs/trunk/b/bzr/bzr-vl.spec @ 6251

Revision 6251, 9.7 KB checked in by daisuke, 12 years ago (diff)

update to 2.5.0

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3# All package versioning is found here:
4# the actual version is composed from these below, including leading 0 for release candidates
5#   bzrmajor:  main bzr version
6#   Version: bzr version, add subrelease version here
7#   bzrrc: release candidate version, if any, line starts with % for rc, # for stable releas (no %).
8#   release: rpm subrelease (0.N for rc candidates, N for stable releases)
9%define bzrmajor 2.5.0
10
11# Magics to get the dots in Release string correct per the above
12%define subrelease %{?bzrrc:.}%{?bzrrc}
13
14Name:           bzr
15Version:        %{bzrmajor}
16Release:        1%{?_dist_release}
17Summary:        Friendly distributed version control system
18Summary(ja):    bzr - 分散型バージョン管理システム
19
20Group:          Development/Tools
21License:        GPLv2+
22URL:            http://www.bazaar-vcs.org/
23Source0:        https://launchpad.net/%{name}/%{bzrmajor}/%{version}/+download/%{name}-%{version}.tar.gz
24Source1:        https://launchpad.net/%{name}/%{bzrmajor}/%{version}/+download/%{name}-%{version}.tar.gz.sig
25BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
26
27BuildRequires:  python-devel zlib-devel
28# We're using an old version of Pyrex, use the pregenerated C files instead
29# of rebuilding
30#BuildRequires: Pyrex
31Requires:   python-paramiko
32# Workaround Bug #230223 otherwise this would be a soft dependency
33Requires:   python-pycurl
34
35Vendor: Project Vine
36Distribution: Vine Linux
37
38%description
39Bazaar is a distributed revision control system that is powerful, friendly,
40and scalable.  It is the successor of Baz-1.x which, in turn, was
41a user-friendly reimplementation of GNU Arch.
42
43
44%prep
45%setup -q -n %{name}-%{version}
46
47sed -i '1{/#![[:space:]]*\/usr\/bin\/\(python\|env\)/d}' bzrlib/_patiencediff_py.py
48sed -i '1{/#![[:space:]]*\/usr\/bin\/\(python\|env\)/d}' bzrlib/weave.py
49
50%build
51CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py build
52
53chmod a-x contrib/bash/bzrbashprompt.sh
54
55%install
56rm -rf $RPM_BUILD_ROOT
57%{__python} setup.py install --skip-build --install-data %{_datadir} --root $RPM_BUILD_ROOT
58chmod 0644 contrib/bzr_access
59chmod 0644 contrib/bzr_ssh_path_limiter
60chmod 0755 $RPM_BUILD_ROOT%{python_sitearch}/bzrlib/*.so
61
62install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/
63install -m 0644 contrib/bash/bzr $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/
64rm contrib/bash/bzr
65
66# This is included in %doc, remove redundancy here
67#rm -rf $RPM_BUILD_ROOT%{python_sitearch}/bzrlib/doc/
68
69# Use independently packaged python-elementtree instead
70rm -rf $RPM_BUILD_ROOT%{python_sitearch}/bzrlib/util/elementtree/
71
72%clean
73rm -rf $RPM_BUILD_ROOT
74
75
76%files
77%defattr(-,root,root,-)
78%doc NEWS README TODO COPYING.txt doc/  contrib/
79%{_bindir}/bzr
80%{_mandir}/man1/*
81%{python_sitearch}/bzrlib/
82%{python_sitearch}/*.egg-info
83%{_sysconfdir}/bash_completion.d/
84
85%changelog
86* Mon May 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
87- new upstream release
88
89* Thu Mar 31 2011 IWAI, Masaharu <iwai@alib.jp> 2.3.1-1
90- new upstream release
91- add Vendor and Distribution tags
92
93* Sun Dec 12 2010 IWAI, Masaharu <iwai@alib.jp> 2.2.2-1
94- new upstream release
95
96* Mon Apr 19 2010 Shu KONNO <owa@bg.wakwak.com> 1.17-2
97- rebuilt with python-2.6
98
99* Thu Aug  6 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.17-1
100- initial build for VineSeed
101
102* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.17-2
103- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
104
105* Mon Jul 20 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.17-1
106- Upgade to 1.17
107
108* Mon Jul 13 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.17-0.1
109- Update to 1.17rc1
110
111* Fri Jun 26 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.16.1-1
112- Update to 1.16.1
113
114* Thu Jun 18 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.16-1
115- Update to 1.16
116
117* Wed Jun 10 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.15.1-1
118- Update to 1.15.1
119
120* Sat May 23 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.15-2
121- Update to 1.15final
122
123* Sat May 16 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.15-0.1
124- Update to 1.15rc1
125
126* Sat May 02 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.14.1-1
127- Update to 1.14.1
128
129* Wed Apr 29 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.14-1
130- Update to 1.14
131
132* Mon Apr 20 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.14-0.3.rc2
133- Update to 1.14rc2
134
135* Sat Apr 11 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.14-0.2.rc1
136- Correct build dependencies
137
138* Thu Apr 09 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.14-0.1.rc1
139- Update to 1.14rc1
140
141* Tue Mar 24 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.13.1-1
142- Update to 1.13.1
143
144* Mon Mar 16 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.13-1
145- Update to 1.13
146
147* Tue Mar 10 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.13-0.1.rc1
148- Update to 1.13rc1
149
150* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.12-2
151- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
152
153* Fri Feb 13 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.12-1
154- Update to 1.12
155
156* Tue Feb 10 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.12-0.1.rc1
157- Update to 1.12rc1
158
159* Mon Jan 19 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.11-1
160- Update to 1.11
161
162* Wed Dec 10 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.10-1
163- Update to 1.10
164
165* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.9-2
166- Rebuild for Python 2.6
167
168* Thu Nov 13 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.9-1
169- Update to 1.9
170
171* Thu Sep 25 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.7-1
172- 1.7 Final
173
174* Wed Sep 3 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.7-0.1.rc2
175- 1.7rc2
176- Remove executable permission from a %%doc file
177
178* Wed Sep 3 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.6.1-0.1.rc2
179- New upstream bugfix release.
180
181* Thu May 21 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.5-2
182- Upload tarball.
183
184* Wed May 21 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.5-1
185- Update to 1.5.
186
187* Thu May 15 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.4-2
188- Workaround upstream Bug# 230223 by Requiring python-pycurl.
189
190* Mon May 5 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.4-1
191- Update to 1.4.
192
193* Sun Apr 27 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.3.1-1
194- Paramiko/sftp backport from 1.4.0. bz#444325
195- Update to 1.3.1 final.
196
197* Sat Apr 4 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.3.1-0.1.rc1
198- Update to 1.3.1rc1 to fix a bug when you have a pack based remote repo and
199  knit based local branch.
200
201* Wed Mar 26 2008 Warren Togami <wtogami@redhat.com> - 1.3-1
202- Update to 1.3.
203
204* Mon Feb 25 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.2-1
205- Update to 1.2.
206
207* Fri Feb 8 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.1-2
208- Rebuild for new gcc.
209
210* Mon Jan 21 2008 Toshio Kuratomi <a.badger@gmail.com> - 1.1-1
211- Upstream 1.1 bugfix and performance enhancement release.
212- Enable bash completion script from the contrib directory.
213
214* Thu Dec 13 2007 Toshio Kuratomi <a.badger@gmail.com> - 1.0-1
215- Update to 1.0 final.
216
217* Tue Dec 11 2007 Toshio Kuratomi <a.badger@gmail.com> - 1.0-0.1.rc3
218- Update to 1.0rc3
219- The new rawhide python package generates egg-info files.
220
221* Fri Nov 30 2007 Toshio Kuratomi <a.badger@gmail.com> - 1.0-0.1.rc2
222- Update to 1.0rc2
223
224* Tue Aug 28 2007 Toshio Kuratomi <a.badger@gmail.com> - 0.91-1
225- Update to 0.91.
226  + Fixes some issues with using tag-enabled branches.
227
228* Tue Aug 28 2007 Toshio Kuratomi <a.badger@gmail.com> - 0.90-1
229- Update to 0.90
230
231* Mon Aug 27 2007 Toshio Kuratomi <a.badger@gmail.com> - 0.90-0.1.rc1
232- Update to 0.90rc1.
233- 0.90 contains some pyrex code to speed things up.  bzr is now arch specific.
234- Update license tag.
235
236* Wed Jul 25 2007 Warren Togami <wtogami@redhat.com> - 0.18-1
237- Update to 0.18.
238
239* Tue Jun 26 2007 Warren Togami <wtogami@redhat.com>  - 0.17-2
240- Update to 0.17.
241
242* Tue May 08 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.16-1
243- Update to 0.16.
244
245* Thu Mar 22 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.15-1
246- Update to 0.15.
247- Simplify the %%files list.
248
249* Tue Jan 23 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.14-1
250- Update to 0.14
251
252* Sun Dec 10 2006 Toshio Kuratomi <toshio@tiki-lounge.com> 0.13-2
253- Conditionalize the python-elementtree requires as python2.5 in FC7 includes
254  elementtree
255
256* Wed Dec 6 2006 Toshio Kuratomi <toshio@tiki-lounge.com> 0.13-1
257- Update to 0.13
258
259* Thu Oct 30 2006 Toshio Kuratomi <toshio@tiki-lounge.com> 0.12-1
260- Update to 0.12
261
262* Thu Oct 08 2006 Toshio Kuratomi <toshio@tiki-lounge.com> 0.11-1
263- Update to 0.11
264- New download location.
265
266* Sun Sep 17 2006 Warren Togami <wtogami@redhat.com> 0.10-1
267- 0.10
268
269* Fri Aug 11 2006 Shahms E. King <shahms@shahms.com> 0.9-1
270- Update to new upstream
271
272* Fri Aug 11 2006 Shahms E. King <shahms@shahms.com> 0.8.2-3
273- Include, don't ghost .pyo files per new guidelines
274
275* Mon Jun 26 2006 Shahms E. King <shahms@shahms.com> 0.8.2-2
276- Require python-paramiko for sftp support
277
278* Tue May 23 2006 Shahms E. King <shahms@shahms.com> 0.8.2-1
279- Update to new upstream version
280- Fix dist tag
281
282* Wed May 10 2006 Shahms E. King <shahms@shahms.com> 0.8-1
283- Update to new upstream version
284- Update bzr-sys-etree.patch for changes
285
286* Mon Feb 13 2006 Shahms E. King <shahms@shahms.com> 0.7-3
287- Add python-elementtree to BuildRequires
288
289* Mon Feb 13 2006 Shahms E. King <shahms@shahms.com> 0.7-2
290- Add dist tag
291
292* Fri Feb 10 2006 Shahms E. King <shahms@shahms.com> 0.7-1
293- Update to 0.7
294
295* Thu Jan 26 2006 Shahms E. King <shahms@shahms.com> 0.6.2-2
296- Fix system library patch
297
298* Wed Dec 07 2005 Shahms E. King <shahms@shahms.com> 0.6.2-1
299- Initial package
Note: See TracBrowser for help on using the repository browser.