source: projects/specs/trunk/b/bind/bind-vl.spec @ 6036

Revision 6036, 19.8 KB checked in by daisuke, 12 years ago (diff)

9.6.ESV.R5.P1-2

Line 
1%define _localstatedir /var
2
3%define pversion 9.6.ESV.R5.P1
4%define sversion 9.6-ESV-R5-P1
5%define bind_epoch 1
6
7%define bind_uid  25
8%define bind_gid  25
9
10Summary: A DNS (Domain Name System) server.
11Summary(ja): DNS (Domain Name System) サーバ
12Name: bind
13Version: %{pversion}
14Release: 2%{?_dist_release}
15License: distributable
16Group: System Environment/Daemons
17Source: ftp://ftp.isc.org/isc/bind9/%{version}/%{name}-%{sversion}.tar.gz
18Source1: bind-manpages.tar.bz2
19Source2: named.sysconfig
20Source3: named.init
21Source4: named.logrotate
22Source5: keygen.c
23Url: http://www.isc.org/bind.html
24Patch1: bind-9.3.3rc2-rndckey.patch
25Patch2: bind-9.6-nonexec.patch
26Patch10: bind-9.6-install-missing-header.patch
27Buildroot: %{_tmppath}/%{name}-%{version}-root
28BuildRequires: openssl-devel glibc-devel libtool
29BuildRequires: libxml2-devel libcap-devel
30Requires(pre): chkconfig, sh-utils, textutils, fileutils, shadow-utils, perl, sed
31Requires(pre): bind-utils = %{bind_epoch}:%{version}-%{release}
32Requires: bind-libs = %{bind_epoch}:%{version}-%{release}
33Conflicts: bind9 <= 9.2.1-0vl5, bind-current
34Obsoletes: bind9 <= 9.2.1-0vl5
35epoch: %{bind_epoch}
36
37Vendor: Project Vine
38Distribution: Vine Linux
39
40%description
41BIND (Berkeley Internet Name Domain) is an implementation of the DNS
42(Domain Name System) protocols. BIND includes a DNS server (named),
43which resolves host names to IP addresses, and a resolver library
44(routines for applications to use when interfacing with DNS).  A DNS
45server allows clients to name resources or objects and share the
46information with other network machines.  The named DNS server can be
47used on workstations as a caching name server, but is generally only
48needed on one machine for an entire network.  Note that the
49configuration files for making BIND act as a simple caching nameserver
50are included in the caching-nameserver package. 
51
52Install the bind package if you need a DNS server for your network.  If
53you want bind to act a caching name server, you will also need to install
54the caching-nameserver package.
55
56
57%package libs
58Summary: Libraries used by various DNS packages
59Group: System Environment/Libraries
60Conflicts: bind-current-libs
61
62%description libs
63Contains libraries used by both the bind server package as well as the utils packages.
64
65
66%package utils
67Summary: Utilities for querying DNS name servers.
68Summary(ja): DNS ネームサーバに問い合わせをするユーティリティ
69Group: Applications/System
70Requires: bind-libs = %{bind_epoch}:%{version}-%{release}
71Conflicts: bind9-utils <= 9.2.1-0vl5, bind-current-utils
72Obsoletes: bind9-utils <= 9.2.1-0vl5
73
74
75%description utils
76Bind-utils contains a collection of utilities for querying DNS (Domain
77Name Service) name servers to find out information about Internet hosts.
78These tools will provide you with the IP addresses for given host names,
79as well as other information about registered domains and network
80addresses.
81
82You should install bind-utils if you need to get information from DNS name
83servers.
84
85
86%package devel
87Summary: Include files and libraries needed for bind DNS development.
88Summary(ja): bind DNS 開発に必要なインクルードファイルとライブラリ
89Group: Development/Libraries
90Requires: bind = %{bind_epoch}:%{version}-%{release}
91Requires: bind-libs = %{bind_epoch}:%{version}-%{release}
92Conflicts: bind9-devel <= 9.2.1-0vl5, bind-current-devel
93Obsoletes: bind9-devel <= 9.2.1-0vl5
94
95
96%description devel
97The bind-devel package contains all the include files and the
98library required for DNS (Domain Name Service) development for
99BIND versions 9.x.x.
100
101You should install bind-devel if you want to develop bind DNS
102applications. If you install bind-devel, you'll also need to install
103bind.
104#'
105
106%prep
107%setup -n bind-%{sversion} -q
108%patch1 -p1 -b .key
109%patch2 -p1 -b .nonexec
110%patch10 -p1 -b .install-missin-header
111
112%build
113libtoolize --copy --force
114aclocal
115autoconf
116%configure --with-libtool --with-openssl=/usr --enable-threads
117make %{?_smp_mflags}
118
119%install
120rm -rf $RPM_BUILD_ROOT
121mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/{rc.d/init.d,logrotate.d}
122mkdir -p ${RPM_BUILD_ROOT}/usr/{bin,lib,sbin,include}
123mkdir -p ${RPM_BUILD_ROOT}/var/named
124mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/{man1,man5,man8}
125mkdir -p ${RPM_BUILD_ROOT}/var/run/named
126
127make DESTDIR=$RPM_BUILD_ROOT install
128install -c -m 640 bin/rndc/rndc.conf $RPM_BUILD_ROOT/etc
129install -c -m 755 contrib/named-bootconf/named-bootconf.sh $RPM_BUILD_ROOT/usr/sbin/named-bootconf
130install -c -m 755 %SOURCE3 $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/named
131install -c -m 644 %SOURCE4 $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/named
132touch $RPM_BUILD_ROOT%{_sysconfdir}/rndc.key
133gcc $RPM_OPT_FLAGS -o $RPM_BUILD_ROOT/usr/sbin/dns-keygen %{SOURCE5}
134cd $RPM_BUILD_ROOT%{_mandir}
135tar xjf %{SOURCE1}
136# newer version is contained in source
137rm -f man5/named.conf.5.gz
138mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
139cp %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/named
140
141
142%pre
143if [ "$1" -eq 1 ]; then
144  /usr/sbin/groupadd -g %{bind_gid} -f -r named >/dev/null 2>&1 || :;
145  /usr/sbin/useradd  -u %{bind_uid} -r -N -M -g named -s /sbin/nologin -d /var/named -c Named named >/dev/null 2>&1 || :;
146fi;
147:;
148
149%post
150/sbin/ldconfig
151/sbin/chkconfig --add named
152if [ "$1" -eq 1 ]; then
153  if [ ! -e /etc/rndc.key ]; then
154    /usr/sbin/rndc-confgen -a > /dev/null 2>&1
155  fi
156  [ -x /sbin/restorecon ] && /sbin/restorecon /etc/rndc.* /etc/named.* >/dev/null 2>&1 ;
157  # rndc.key has to have correct perms and ownership, CVE-2007-6283
158  [ -e /etc/rndc.key ] && chown root:named /etc/rndc.key
159  [ -e /etc/rndc.key ] && chmod 0640 /etc/rndc.key
160
161  # Check DNSSEC settings if this is a fresh install
162  if [ -r /etc/sysconfig/dnssec ]; then
163    . /etc/sysconfig/dnssec
164    [ -x /usr/sbin/dnssec-configure ] && \
165      dnssec-configure -b --norestart --dnssec="$DNSSEC" --dlv="$DLV" > \
166        /dev/null 2>&1
167  fi;
168fi
169:;
170
171%preun
172if [ "$1" -eq 0 ]; then
173   /sbin/service named stop >/dev/null 2>&1 || :
174   /sbin/chkconfig --del named ||:
175fi
176exit 0
177
178
179%postun
180if [ "$1" -ge 1 ]; then
181        %{_sysconfdir}/rc.d/init.d/named condrestart >/dev/null 2>&1 || :
182fi
183/sbin/ldconfig
184
185%triggerpostun -- bind < 8.2.2_P5-15
186/sbin/chkconfig --add named
187/sbin/ldconfig
188
189%clean
190rm -rf ${RPM_BUILD_ROOT} ${RPM_BUILD_DIR}/%{name}-%{version}
191
192
193%post libs -p /sbin/ldconfig
194
195%postun libs -p /sbin/ldconfig
196
197
198%files
199%defattr(-,root,root)
200%doc CHANGES README
201%doc doc/arm doc/draft doc/rfc doc/misc
202%config(noreplace) %{_sysconfdir}/logrotate.d/named
203%config %{_sysconfdir}/rc.d/init.d/named
204%config(noreplace) %{_sysconfdir}/sysconfig/named
205%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.conf
206%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.key
207
208%{_sbindir}/dnssec*
209%{_sbindir}/lwresd
210%{_sbindir}/named
211%{_sbindir}/named-bootconf
212%{_sbindir}/named-check*
213%{_sbindir}/named-compilezone
214%{_sbindir}/rndc*
215%{_sbindir}/dns-keygen
216
217#%{_libdir}/libbind9.so.*
218#%{_libdir}/libisccc.so.*
219#%{_libdir}/libisccfg.so.*
220
221%{_mandir}/man5/resolv.conf.5*
222%{_mandir}/man5/named.conf.5*
223%{_mandir}/man5/rndc.conf.5*
224%{_mandir}/man8/rndc.8*
225%{_mandir}/man8/named.8*
226%{_mandir}/man8/lwresd.8*
227%{_mandir}/man8/dnssec*.8*
228%{_mandir}/man8/named-checkconf.8*
229%{_mandir}/man8/named-checkzone.8*
230%{_mandir}/man8/named-compilezone.8*
231%{_mandir}/man8/rndc-confgen.8*
232
233%attr(-,named,named) %dir %{_var}/named
234%attr(-,named,named) %dir %{_var}/run/named
235     
236
237%files libs
238%defattr(-,root,root)
239%{_libdir}/*.so.*
240
241%files utils
242%defattr(-,root,root)
243%{_bindir}/dig
244%{_bindir}/host
245%{_bindir}/nslookup
246%{_bindir}/nsupdate
247#%{_libdir}/libdns.so.*
248#%{_libdir}/libisc.so.*
249#%{_libdir}/liblwres.so.*
250%{_mandir}/man1/host.1*
251%{_mandir}/man1/nsupdate.1*
252%{_mandir}/man1/dig.1*
253%{_mandir}/man5/resolver.5*
254%{_mandir}/man1/nslookup.1*
255%{_mandir}/man8/nslookup.8*
256
257
258%files devel
259%defattr(-,root,root)
260%{_libdir}/*.so
261%{_libdir}/*.la
262%{_libdir}/*.a
263%{_includedir}/*
264%{_mandir}/man3/*
265%{_mandir}/man1/isc-config.sh.1*
266%{_bindir}/isc-config.sh
267
268%changelog
269* Fri Apr 06 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.ESV.R5.P1-2
270- add patch2 to install libraries as exec
271- add patch10 to install missing header (isc/hmacsha.h)
272
273* Fri Nov 18 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R5.P1-1
274- new upstream release with security fix (CVE-2011-4313)
275
276* Wed Jul  6 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R4.P3-1
277- new upstream release with security fix (CVE-2011-2464)
278- use hoge(pre) tags instead of old hogepre tags
279
280* Sat May 28 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R4.P1-1
281- new upstream release with security fix (CVE-2011-1910)
282
283* Thu Mar 31 2011 IWAI, Masaharu <iwai@alib.jp> 9.6.ESV.R4-1
284- new upstream release
285
286* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.6.ESV.R2-4
287- rebuild with openssl-1.0.0c
288
289* Fri Jan 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.6.ESV.R2-3
290- rebuild package
291
292* Sun Oct 24 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R2-2
293- change spec filename bind9-vl -> bind-vl
294
295* Thu Oct  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R2-1
296- new upstream ESV release
297- add BR: libxml2-devel libcap-devel
298
299* Wed Aug 18 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R1-2
300- add Conflicts bind-current
301
302* Tue Aug 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R1-1
303- new upstream ESV release
304- add epoch 1 to upgrade from exist bind package
305
306* Thu Jan 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-2
307- add man1/isc-config.sh.1 into devel file list
308
309* Wed Jan 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-1
310- new upstream release with security fix (CVE-2009-4022, 2010-0097) 
311
312* Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P2-1
313- new upstream release with security fix (CVE-2009-4022)
314
315* Wed Jul 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P1-1
316- new upstream release with security fix
317
318* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.1-1
319- new upstream release
320- clean up %%post/%%pre scriptlet
321  - create named user and group in %%pre
322  - don't remove named user/group in %%preun
323  - use rndc-confgen to create rndc.key
324
325* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.0P1-1
326- new upstream release
327- drop patch0 and patch14, merged in upstream
328
329* Sat Jan 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.5.1P1-1
330- new upstream release with security fix
331
332* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 9.5.0P1-1
333- new upstream release with security fix
334- new versioning policy
335
336* Sun Sep 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1P1-0vl1
337- new upstream release with security fix
338
339* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1-0vl1
340- new upstream release
341- build with new openssl/toolchain
342
343* Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.4-0vl1
344- new upstream release with security fix
345
346* Fri Nov 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2P2-0vl1
347- new upstream release
348
349* Fri Sep 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl2
350- add Prereq sed
351
352* Wed Sep 06 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl1
353- new upstream release for security fix (CVE-2006-4095,4096)
354
355* Wed Feb 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 9.3.2-0vl3
356- separate -libs package
357- remove old named.conf.5.gz
358  - newer version is contained in source
359
360* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl2
361- add bsdcompat patch (Patch4)
362- add fix_h_errno patch from FC
363  - h_errno not being accessed / set correctly in libbind
364
365* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl1
366- new upstream release
367
368* Sun Nov  7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 9.2.4-0vl2
369- added PreReq to bind-utils (see: [VineSeed:09555])
370
371* Thu Oct 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.4-0vl1
372- new upstream release
373
374* Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl3
375- fix /etc/init.d/named to use rndc
376
377* Tue Nov 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl2
378- rebuild to remove unneeded dependancy
379
380* Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl1
381- new upstream release
382
383* Tue Mar  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.2-0vl1
384- new upstream release
385
386* Thu Nov 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl7
387- fix dependancies.
388
389* Wed Nov 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl6
390- add obsoletes: and conflicts: to bind9, bind9-utils, bind9-devel <= 9.2.1-0vl5
391- change package name to bind for VineSeed.
392- use more macros.
393
394* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl5
395- fixed some macros
396- add conflicts: to bind-* in bind9-devel and bind9-utils
397- add provides: bind = %%{version}
398
399* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl4
400- use %%configure macros
401
402* Sat Oct 19 2002 Michihide Hotta <hotta@net-newbie.com> 9.2.1-0vl3
403- fixed inconsistent dependency
404
405* Wed Aug 14 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl2
406- updated to 9.2.2rc1
407
408* Thu May 02 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl0
409- updated to bind9(9.2.1), test packages ;)
410        -- based on Rawhide's bind-9.2.0-8
411        -- changed name bind9
412        -- added Conflicts: bind
413
414* Sun Feb 03 2002 Toru Sagami <sagami@vinelinux.org> 8.3.1-0vl1
415- release 8.3.1 includes security fixes
416
417* Mon Jan 14 2002 Toru Sagami <sagami@vinelinux.org> 8.3.0-0vl1
418- Upgraded to current stable release 8.3.0
419
420* Mon Oct  8 2001 <zn@mbf.nifty.com>
421- 8.2.5-0vl0: Upgraded to new upstream version.
422
423* Thu May 24 2001 <sagami@vinelinux.org>
424- 8.2.4-0vl1: eliminate CVS related files from %%doc
425
426* Thu May 17 2001 <sagami@vinelinux.org>
427- 8.2.4-0vl0
428
429* Fri Feb 02 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
430- 8.2.3-1vl2
431- built on VineSeed
432
433* Tue Jan 30 2001 KAJIKI Yoshihiro <kajiki@ylug.org>
434- add doc/old
435- build for Vine 2.1
436
437* Sat Jan 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
438- 8.2.3, fixes several security problems
439
440* Tue Nov 14 2000 Bill Nottingham <notting@redhat.com>
441- static libraries may be used in shared objects. Build with -fPIC on ia64
442
443* Fri Nov 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
444- 8.2.2-P7 (fixes Bug #20546)
445
446* Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
447- condrestart fixes
448
449* Tue Jul 18 2000 Nalin Dahyabhai <nalin@redhat.com>
450- change the init script to take condrestart, not cond-restart
451- add sh-utils, /bin/cat, perl, /bin/chmod, /usr/sbin/useradd as prereqs for
452  the %pre and %post scripts
453
454* Sun Jul 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
455- Don't prereq /etc/init.d
456
457* Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
458- move initscript back
459
460* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
461- automatic rebuild
462
463* Sun Jul  9 2000 Florian La Roche <Florian.LaRoche@redhat.de>
464- add "exit 0" for uninstall case
465
466* Fri Jul  7 2000 Florian La Roche <Florian.LaRoche@redhat.de>
467- add prereq init.d and cleanup install section
468
469* Fri Jun 30 2000 Trond Eivind Glomsr <teg@redhat.com>
470- fix the init script
471
472* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
473- make libbind.a and nslookup.help readable again by setting INSTALL_LIB to ""
474
475* Mon Jun 26 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
476- Fix up the initscript (Bug #13033)
477- Fix build with current glibc (Bug #12755)
478- /etc/rc.d/init.d -> /etc/init.d
479- use %%{_mandir} rather than /usr/share/man
480
481* Mon Jun 19 2000 Bill Nottingham <notting@redhat.com>
482- fix conflict with man-pages
483- remove compatibilty chkconfig links
484- initscript munging
485
486* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
487- modify logrotate setup to use PID file
488- temporarily disable optimization by unsetting $RPM_OPT_FLAGS at build-time
489- actually bump the release this time
490
491* Sun Jun  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
492- FHS compliance
493
494* Mon Apr 17 2000 Nalin Dahyabhai <nalin@redhat.com>
495- clean up restart patch
496
497* Mon Apr 10 2000 Nalin Dahyabhai <nalin@redhat.com>
498- provide /var/named (fix for bugs #9847, #10205)
499- preserve args when restarted via ndc(8) (bug #10227)
500- make resolv.conf(5) a link to resolver(5) (bug #10245)
501- fix SYSTYPE bug in all makefiles
502- move creation of named user from %%post into %%pre
503
504* Mon Feb 28 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
505- Fix TTL (patch from ISC, Bug #9820)
506
507* Wed Feb 16 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
508- fix typo in spec (it's %post, without a leading blank) introduced in -6
509- change SYSTYPE to linux
510
511* Sat Feb 11 2000 Bill Nottingham <notting@redhat.com>
512- pick a standard < 100 uid/gid for named
513
514* Thu Feb 04 2000 Elliot Lee <sopwith@redhat.com>
515- Pass named a '-u named' parameter by default, and add/remove user.
516
517* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
518- fix host mx bug (Bug #9021)
519
520* Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
521- rebuild to fix dependencies
522- man pages are compressed
523
524* Wed Jan 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
525- It's /usr/bin/killall, not /usr/sbin/killall (Bug #8063)
526
527* Mon Jan 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
528- Fix up location of named-bootconf.pl and make it executable
529  (Bug #8028)
530- bind-devel requires bind
531
532* Mon Nov 15 1999 Bernhard Rosenkraenzer <bero@redhat.com>
533- update to 8.2.2-P5
534
535* Wed Nov 10 1999 Bill Nottingham <notting@redhat.com>
536- update to 8.2.2-P3
537
538* Tue Oct 12 1999 Cristian Gafton <gafton@redhat.com>
539- add patch to stop a cache only server from complaining about lame servers
540  on every request.
541
542* Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
543- use real stop and start in named.init for restart, not ndc restart, it has
544  problems when named has changed during a package update... (# 4890)
545
546* Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
547- chkconfig --del in %preun, not %postun
548
549* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
550- initscript munging
551
552* Mon Jul 26 1999 Bill Nottingham <notting@redhat.com>
553- fix installed chkconfig links to match init file
554
555* Sat Jul  3 1999 Jeff Johnson <jbj@redhat.com>
556- conflict with new (in man-1.24) man pages (#3876,#3877).
557
558* Tue Jun 29 1999 Bill Nottingham <notting@redhat.com>
559- fix named.logrotate (wrong %SOURCE)
560
561* Fri Jun 25 1999 Jeff Johnson <jbj@redhat.com>
562- update to 8.2.1.
563- add named.logrotate (#3571).
564- hack around egcs-1.1.2 -m486 bug (#3413, #3485).
565- vet file list.
566
567* Fri Jun 18 1999 Bill Nottingham <notting@redhat.com>
568- don't run by default
569
570* Sun May 30 1999 Jeff Johnson <jbj@redhat.com>
571- nslookup fixes (#2463).
572- missing files (#3152).
573
574* Sat May  1 1999 Stepan Kasal <kasal@math.cas.cz>
575- nslookup patched:
576  to count numRecords properly
577  to fix subsequent calls to ls -d
578  to parse "view" and "finger" commands properly
579  the view hack updated for bind-8 (using sed)
580
581* Wed Mar 31 1999 Bill Nottingham <notting@redhat.com>
582- add ISC patch
583- add quick hack to make host not crash
584- add more docs
585
586* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
587- add probing information in the init file to keep linuxconf happy
588- dont strip libbind
589
590* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
591- auto rebuild in the new build environment (release 3)
592
593* Wed Mar 17 1999 Preston Brown <pbrown@redhat.com>
594- removed 'done' output at named shutdown.
595
596* Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
597- version 8.2
598
599* Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com>
600- patch to use the __FDS_BITS macro
601- build for glibc 2.1
602
603* Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
604- change named.restart to /usr/sbin/ndc restart
605
606* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
607- install man pages correctly.
608- change K10named to K45named.
609
610* Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
611- don't start if /etc/named.conf doesn't exist.
612
613* Sat Aug  8 1998 Jeff Johnson <jbj@redhat.com>
614- autmagically create /etc/named.conf from /etc/named.boot in %post
615- remove echo in %post
616
617* Wed Jun 10 1998 Jeff Johnson <jbj@redhat.com>
618- merge in 5.1 mods
619
620* Sun Apr 12 1998 Manuel J. Galan <manolow@step.es>
621- Several essential modifications to build and install correctly.
622- Modified 'ndc' to avoid deprecated use of '-'
623
624* Mon Dec 22 1997 Scott Lampert <fortunato@heavymetal.org>
625- Used buildroot
626- patched bin/named/ns_udp.c to use <libelf/nlist.h> for include
627  on Redhat 5.0 instead of <nlist.h>
628
Note: See TracBrowser for help on using the repository browser.