source: projects/specs/trunk/b/bind/bind-vl.spec @ 12554

Revision 12554, 25.0 KB checked in by tomop, 3 years ago (diff)

updated 3 packages

bind-9.11.28-1

jasper-2.0.25-1

python3-3.8.8-2

Line 
1%bcond_with systemd
2
3%bcond_with python
4%define python_executable %{__python}
5
6%define _localstatedir /var
7%define _unpackaged_files_terminate_build 1
8
9%define sname bind
10%define pname bind
11# example: 9.9.13.P1
12%define pversion 9.11.28
13# example: 9.9.13-P1
14%define sversion 9.11.28
15%define bind_epoch 1
16# fixed <BTS:VineLinux:1139>
17%define old_bind_version 1:9.9.2p2-1vl7
18
19%define bind_uid  25
20%define bind_gid  25
21
22%bcond_with readline
23
24Summary: A DNS (Domain Name System) server.
25Summary(ja): DNS (Domain Name System) サーバ
26Name: %{pname}
27Epoch: %{bind_epoch}
28Version: %{pversion}
29Release: 1%{?_dist_release}%{?with_systemd:.systemd}
30Group: servers
31Vendor: Project Vine
32Distribution: Vine Linux
33Packager: daisuke
34
35License: ISC and BSD and Public Domain
36URL: http://www.isc.org/bind.html
37Source: https://downloads.isc.org/isc/bind9/%{sversion}/bind-%{sversion}.tar.gz
38Source1: bind-manpages.tar.bz2
39Source2: named.sysconfig
40Source3: named.init
41Source4: named.logrotate
42Source5: keygen.c
43Source100: named.service
44Source101: named-setup-rndc.service
45Source102: named.sysconfig.systemd
46Source103: bind.tmpfiles.d
47Source104: named.conf
48
49Patch1: bind-9.11.5-rndckey.patch
50
51BuildRoot: %{_tmppath}/%{name}-%{version}-root
52%if %{with python}
53BuildRequires: python
54BuildRequires: python-rpm-macros
55BuildRequires: python-ply
56%endif
57BuildRequires: openssl-devel glibc-devel libtool
58BuildRequires: libxml2-devel
59BuildRequires: libcap-devel
60%if %{with readline}
61BuildRequires: readline-devel
62%endif
63Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
64Requires(pre): %{pname}-utils = %{bind_epoch}:%{version}-%{release}
65Requires(pre): shadow-utils
66Requires(post): %{pname}-utils = %{bind_epoch}:%{version}-%{release}
67Requires(post): coreutils
68%if %{with systemd}
69%{?systemd_requires}
70%else
71Requires(post): chkconfig
72Requires(preun): chkconfig
73%endif
74Conflicts: bind9 <= 9.2.1-0vl5, bind-current
75Obsoletes: bind9 <= 9.2.1-0vl5
76Obsoletes: bind-current < 1:9.9.4-1
77
78%description
79BIND (Berkeley Internet Name Domain) is an implementation of the DNS
80(Domain Name System) protocols. BIND includes a DNS server (named),
81which resolves host names to IP addresses, and a resolver library
82(routines for applications to use when interfacing with DNS).  A DNS
83server allows clients to name resources or objects and share the
84information with other network machines.  The named DNS server can be
85used on workstations as a caching name server, but is generally only
86needed on one machine for an entire network.  Note that the
87configuration files for making BIND act as a simple caching nameserver
88are included in the caching-nameserver package. 
89
90Install the bind package if you need a DNS server for your network.  If
91you want bind to act a caching name server, you will also need to install
92the caching-nameserver package.
93
94
95%package libs
96Summary: Libraries used by various DNS packages
97Summary(ja): さまざまな DNS パッケージで使用されるライブラリ
98Group: system
99Obsoletes: bind-current-libs <= %{old_bind_version}
100
101%description libs
102Contains libraries used by both the bind server package as well as the utils packages.
103
104
105%package utils
106Summary: Utilities for querying DNS name servers.
107Summary(ja): DNS ネームサーバに問い合わせをするユーティリティ
108Group: admin-tools
109Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
110Conflicts: bind9-utils <= 9.2.1-0vl5
111Conflicts: bind-current-utils
112Obsoletes: bind9-utils <= 9.2.1-0vl5
113Obsoletes: bind-current-utils <= %{old_bind_version}
114
115%description utils
116Bind-utils contains a collection of utilities for querying DNS (Domain
117Name Service) name servers to find out information about Internet hosts.
118These tools will provide you with the IP addresses for given host names,
119as well as other information about registered domains and network
120addresses.
121
122You should install bind-utils if you need to get information from DNS name
123servers.
124
125
126%package devel
127Summary: Include files and libraries needed for bind DNS development.
128Summary(ja): bind DNS 開発に必要なインクルードファイルとライブラリ
129Group: programming
130Requires: %{pname} = %{bind_epoch}:%{version}-%{release}
131Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
132Conflicts: bind9-devel <= 9.2.1-0vl5
133Conflicts: bind-current-devel
134Obsoletes: bind9-devel <= 9.2.1-0vl5
135Obsoletes: bind-current-devel <= %{old_bind_version}
136
137%description devel
138The bind-devel package contains all the include files and the
139library required for DNS (Domain Name Service) development for
140BIND versions 9.x.x.
141
142You should install bind-devel if you want to develop bind DNS
143applications. If you install bind-devel, you'll also need to install
144bind.
145#'
146
147
148%debug_package
149
150
151%prep
152%setup -n bind-%{sversion} -q
153%patch1 -p1 -b .key
154perl -pi -e 's/^(SUBDIRS =.+)dlzexternal(.+)$/\1\2/' bin/tests/system/Makefile.in
155
156
157%build
158libtoolize --copy --force
159aclocal
160autoconf
161%configure \
162  --with-libtool \
163  --with-openssl=/usr \
164%if %{without readline}
165    --without-readline \
166%endif
167  --disable-openssl-version-ceck \
168  --enable-threads \
169  --enable-ipv6 \
170  --with-pic \
171  --with-dlz-dlopen \
172%if %{with python}
173  --with-python=%{python_executable} \
174%else
175  --with-python=no \
176%endif
177  --enable-filter-aaaa \
178  --enable-fixed-rrset
179make %{?_smp_mflags}
180
181
182%install
183rm -rf %{buildroot}
184mkdir -p %{buildroot}%{_sysconfdir}/{logrotate.d,sysconfig}
185mkdir -p %{buildroot}/usr/{bin,lib,sbin,include}
186mkdir -p %{buildroot}/var/named/data
187mkdir -p %{buildroot}%{_mandir}/{man1,man5,man8}
188mkdir -p %{buildroot}/var/run/named
189
190make DESTDIR=%{buildroot} install
191install -c -m 640 bin/rndc/rndc.conf %{buildroot}/etc
192install -c -m 644 %SOURCE4 %{buildroot}%{_sysconfdir}/logrotate.d/named
193touch %{buildroot}%{_sysconfdir}/rndc.key
194gcc %{optflags} -o %{buildroot}/usr/sbin/dns-keygen %{SOURCE5}
195cd %{buildroot}%{_mandir}
196tar xjf %{SOURCE1}
197# newer version is contained in source
198rm -f man5/named.conf.5.gz
199
200install -m 644 %{SOURCE104} %{buildroot}%{_sysconfdir}/named.conf
201
202%if %{with systemd}
203# Systemd unit files
204mkdir -p %{buildroot}%{_unitdir}
205install -m 644 %{SOURCE100} %{buildroot}%{_unitdir}
206install -m 644 %{SOURCE101} %{buildroot}%{_unitdir}
207install -m 644 %{SOURCE102} %{buildroot}%{_sysconfdir}/sysconfig/named
208mkdir -p %{buildroot}%{_tmpfilesdir}
209install -m 644 %{SOURCE103} %{buildroot}%{_tmpfilesdir}/named.conf
210%else
211mkdir -p %{buildroot}%{_sysconfdir}/rc.d/init.d
212install -c -m 755 %SOURCE3 %{buildroot}%{_sysconfdir}/rc.d/init.d/named
213cp %{SOURCE2} %{buildroot}%{_sysconfdir}/sysconfig/named
214%endif
215
216chmod +x %{buildroot}%{_libdir}/*.so.*
217
218rm -f %{buildroot}%{_libdir}/*.la
219
220%clean
221rm -rf %{buildroot} ${RPM_BUILD_DIR}/%{name}-%{version}
222
223
224%pre
225if [ "$1" -eq 1 ]; then
226  /usr/sbin/groupadd -g %{bind_gid} -f -r named >/dev/null 2>&1 || :;
227  /usr/sbin/useradd  -u %{bind_uid} -r -N -M -g named -s /sbin/nologin -d /var/named -c Named named >/dev/null 2>&1 || :;
228fi;
229:;
230
231%post
232/sbin/ldconfig
233if [ "$1" -eq 1 ]; then
234  if [ ! -e /etc/rndc.key ]; then
235    /usr/sbin/rndc-confgen -a > /dev/null 2>&1
236  fi
237  [ -x /sbin/restorecon ] && /sbin/restorecon /etc/rndc.* /etc/named.* >/dev/null 2>&1 ;
238  # rndc.key has to have correct perms and ownership, CVE-2007-6283
239  [ -e /etc/rndc.key ] && chown root:named /etc/rndc.key
240  [ -e /etc/rndc.key ] && chmod 0640 /etc/rndc.key
241
242  # Check DNSSEC settings if this is a fresh install
243  if [ -r /etc/sysconfig/dnssec ]; then
244    . /etc/sysconfig/dnssec
245    [ -x /usr/sbin/dnssec-configure ] && \
246      dnssec-configure -b --norestart --dnssec="$DNSSEC" --dlv="$DLV" > \
247        /dev/null 2>&1
248  fi;
249fi
250%if %{with systemd}
251%systemd_post named.service
252%else
253if [ "$1" -eq 1 ]; then
254  /sbin/chkconfig --add named
255fi
256%endif
257:;
258
259%preun
260%if %{with systemd}
261# Package removal, not upgrade
262%systemd_preun named.service
263%else
264if [ "$1" -eq 0 -o -x /sbin/systemctl ]; then
265   /sbin/service named stop >/dev/null 2>&1 || :
266   /sbin/chkconfig --del named ||:
267fi
268%endif
269exit 0
270
271%postun
272/sbin/ldconfig
273%if %{with systemd}
274# Package upgrade, not uninstall
275%systemd_postun_with_restart named.service
276%else
277if [ "$1" -ge 1 ]; then
278        %{_sysconfdir}/rc.d/init.d/named condrestart >/dev/null 2>&1 || :
279fi
280%endif
281exit 0
282
283%triggerpostun -- bind < 8.2.2_P5-15
284/sbin/chkconfig --add named
285/sbin/ldconfig
286
287%triggerpostun -- bind-current < 1:9.9.4-1
288/sbin/chkconfig --add named
289/sbin/ldconfig
290
291%ldconfig_scriptlets libs
292
293
294%files
295%defattr(-,root,root)
296%license COPYRIGHT
297%doc CHANGES README*
298%doc doc/arm doc/misc
299%config(noreplace) %{_sysconfdir}/named.conf
300%config(noreplace) %{_sysconfdir}/logrotate.d/named
301%if %{with systemd}
302%{_unitdir}/named.service
303%{_unitdir}/named-setup-rndc.service
304%{_tmpfilesdir}/named.conf
305%else
306%config %{_sysconfdir}/rc.d/init.d/named
307%attr(-,named,named) %dir %{_var}/run/named
308%endif
309%config(noreplace) %{_sysconfdir}/sysconfig/named
310%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.conf
311%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.key
312%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/bind.keys
313
314%attr(-,named,named) %dir %{_var}/named
315%attr(-,named,named) %dir %{_var}/named/data
316
317%{_sbindir}/dnssec*
318%{_sbindir}/lwresd
319%{_sbindir}/named
320%{_sbindir}/named-check*
321%{_sbindir}/named-compilezone
322%{_sbindir}/rndc*
323%{_sbindir}/dns-keygen
324%{_bindir}/arpaname
325%{_sbindir}/ddns-confgen
326%{_sbindir}/genrandom
327%{_sbindir}/isc-hmac-fixup
328%{_sbindir}/named-journalprint
329%{_sbindir}/nsec3hash
330%{_sbindir}/tsig-keygen
331
332%if %{with python}
333%{python_sitelib}/*
334%endif
335
336%{_mandir}/man1/arpaname.1*
337%{_mandir}/man5/resolv.conf.5*
338%{_mandir}/man5/named.conf.5*
339%{_mandir}/man5/rndc.conf.5*
340%{_mandir}/man8/rndc.8*
341%{_mandir}/man8/named.8*
342%{_mandir}/man8/lwresd.8*
343%{_mandir}/man8/dnssec*.8*
344%{_mandir}/man8/named-checkconf.8*
345%{_mandir}/man8/named-checkzone.8*
346%{_mandir}/man8/named-compilezone.8*
347%{_mandir}/man8/rndc-confgen.8*
348%{_mandir}/man8/ddns-confgen.8*
349%{_mandir}/man8/genrandom.8*
350%{_mandir}/man8/isc-hmac-fixup.8*
351%{_mandir}/man8/named-journalprint.8*
352%{_mandir}/man8/nsec3hash.8*
353%{_mandir}/man8/tsig-keygen.8*
354
355%files libs
356%defattr(-,root,root)
357%{_libdir}/*.so.*
358
359%files utils
360%defattr(-,root,root)
361%{_bindir}/delv
362%{_bindir}/dig
363%{_bindir}/host
364%{_bindir}/mdig
365%{_bindir}/named-rrchecker
366%{_bindir}/nslookup
367%{_bindir}/nsupdate
368%{_mandir}/man1/delv.1*
369%{_mandir}/man1/dig.1*
370%{_mandir}/man1/host.1*
371%{_mandir}/man1/mdig.1*
372%{_mandir}/man1/named-rrchecker.1*
373%{_mandir}/man1/nslookup.1*
374%{_mandir}/man1/nsupdate.1*
375%{_mandir}/man5/resolver.5*
376%{_mandir}/man8/nslookup.8*
377
378%files devel
379%defattr(-,root,root)
380%{_libdir}/*.so
381%{_libdir}/*.a
382%{_includedir}/*
383%{_mandir}/man3/*
384%{_mandir}/man1/bind9-config.1*
385%{_mandir}/man1/isc-config.sh.1*
386%{_bindir}/bind9-config
387%{_bindir}/isc-config.sh
388
389%changelog
390* Sat Feb 27 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.11.28-1
391- updated to 9.11.28.
392
393* Thu Sep 03 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.11.22-1
394- updated to 9.11.22.
395
396* Fri Jul 10 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.11.20-2
397- added systemd support (disabled as default).
398
399* Thu Jul 02 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.11.20-1
400- updated to 9.11.20.
401
402* Sat Nov 02 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.11.12-1
403- updated to 9.11.12.
404
405* Wed Oct 02 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.11.11-1
406- updated to 9.11.11.
407
408* Sun Dec 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.11.5-1
409- updated to 9.11.5 (new ESV).
410- updated Patch1.
411
412* Thu Nov 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.9.13.P1-1
413- updated to 9.9.13.P1.
414- updated Patch1.
415
416* Thu Apr 13 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 9.9.9.P8-1
417- update to 9.9.9.P8
418
419* Sun Feb 19 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 9.9.9.P6-1
420- new upstream release.
421
422* Thu Nov 03 2016 Daisuke SUZUKI <daisuke@vinelinux.org> 9.9.9.P4-1
423- new upstream release.
424
425* Mon Aug 1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.9.9.P2-1
426- new upstream release.
427
428* Mon Mar 14 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.8.P4-1
429- new upstream release with secrity fix (CVE-2016-1285,1286)
430- built with openssl 1.0.2g
431
432* Wed Jan 20 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.8.P3-1
433- new upstream release with secrity fix (CVE-2015-4620) 
434
435* Thu Jul  9 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.7.P1-1
436- new upstream release with secrity fix (CVE-2015-4620)
437
438* Mon Mar 23 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 9.9.6.P2-2
439- rebuilt without readline to avoid GPL infection
440
441* Fri Feb 27 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 9.9.6.P2-1
442- new upstream release with secrity fix (CVE-2015-1349)
443- added BR: readline-devel
444
445* Fri Feb  6 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 9.9.6.P1-3
446- new upstream release with secrity fix (CVE-2014-8500) 
447- used "3" as release number because of being newer than Vine Linux/6 updates
448
449* Tue Oct 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 9.9.4-1
450- update to 9.9.4(ESV)
451
452* Thu Mar 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 9.9.2p2-1
453- update to 9.9.2-P2
454- remove .la
455- remove Conflicts/Obsoletes from libs subpackage.
456- add configure options
457  --enable-ipv6 --with-pic --enable-filter-aaaa --enable-fixed-rrset
458
459* Tue Dec 18 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.8.4p1-1
460- new upstream release.
461- added an option "--with-dlz-dlopen".
462
463* Tue May 31 2011 IWAI, Masaharu <iwai@alib.jp> 9.8.0p2-2
464- Obosoletes: bind.* < 1:9.6.ESV.R1
465 - fixed <BTS:VineLinux:1139>
466
467* Sun May 29 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.8.0p2-1
468- new upstream release with security fix (CVE-2011-1910)
469
470* Tue May 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.8.0p1-2
471- add BuildRequires: libxml2-devel, libcap-devel
472
473* Mon May  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.8.0p1-1
474- new upstream release with security fix (CVE-2011-1907)
475- fix changelog typo
476
477* Sat Apr 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 9.8.0-2
478- Obosoletes: bind.* < 1:9.6.ESV.R1
479
480* Thu Apr 07 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 9.8.0-1
481- update to 9.8.0
482- remove Provides: bind.* = %%{bind_epoch}:%{version}-%{release}
483
484* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.7.2P2-3
485- rebuild with openssl-1.0.0c
486
487* Sun Oct 24 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.7.2P2-2
488- fix Req: in bind package
489
490* Wed Oct 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.7.2P2-1
491- change package name bind -> bind-current
492- add epoch 1
493- new upstream release
494
495* Sat Jul 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 9.7.1P2-1
496- new upstream release
497
498* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 9.6.1P3-4
499- rebuilt with gcc-4.4.3-3 on ppc
500
501* Sat Feb  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 9.6.1P3-3
502- rebuilt with new toolchains (for VineSeed)
503- s/BuildPrereq/BuildRequires/
504
505* Thu Jan 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-2
506- add man1/isc-config.sh.1 into devel file list
507
508* Wed Jan 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-1
509- new upstream release with security fix (CVE-2009-4022, 2010-0097) 
510
511* Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P2-1
512- new upstream release with security fix (CVE-2009-4022)
513
514* Wed Jul 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P1-1
515- new upstream release with security fix
516
517* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.1-1
518- new upstream release
519- clean up %%post/%%pre scriptlet
520  - create named user and group in %%pre
521  - don't remove named user/group in %%preun
522  - use rndc-confgen to create rndc.key
523
524* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.0P1-1
525- new upstream release
526- drop patch0 and patch14, merged in upstream
527
528* Sun Jan 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.5.1P1-1
529- new upstream release with security fix
530
531* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 9.5.0P1-1
532- new upstream release with security fix
533- new versioning policy
534
535* Sun Sep 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1P1-0vl1
536- new upstream release with security fix
537
538* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1-0vl1
539- new upstream release
540- build with new openssl/toolchain
541
542* Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.4-0vl1
543- new upstream release with security fix
544
545* Fri Nov 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2P2-0vl1
546- new upstream release
547
548* Fri Sep 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl2
549- add Prereq sed
550
551* Wed Sep 06 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl1
552- new upstream release for security fix (CVE-2006-4095,4096)
553
554* Wed Feb 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 9.3.2-0vl3
555- separate -libs package
556- remove old named.conf.5.gz
557  - newer version is contained in source
558
559* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl2
560- add bsdcompat patch (Patch4)
561- add fix_h_errno patch from FC
562  - h_errno not being accessed / set correctly in libbind
563
564* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl1
565- new upstream release
566
567* Sun Nov  7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 9.2.4-0vl2
568- added PreReq to bind-utils (see: [VineSeed:09555])
569
570* Thu Oct 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.4-0vl1
571- new upstream release
572
573* Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl3
574- fix /etc/init.d/named to use rndc
575
576* Tue Nov 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl2
577- rebuild to remove unneeded dependancy
578
579* Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl1
580- new upstream release
581
582* Tue Mar  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.2-0vl1
583- new upstream release
584
585* Thu Nov 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl7
586- fix dependancies.
587
588* Wed Nov 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl6
589- add obsoletes: and conflicts: to bind9, bind9-utils, bind9-devel <= 9.2.1-0vl5
590- change package name to bind for VineSeed.
591- use more macros.
592
593* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl5
594- fixed some macros
595- add conflicts: to bind-* in bind9-devel and bind9-utils
596- add provides: bind = %%{version}
597
598* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl4
599- use %%configure macros
600
601* Sat Oct 19 2002 Michihide Hotta <hotta@net-newbie.com> 9.2.1-0vl3
602- fixed inconsistent dependency
603
604* Wed Aug 14 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl2
605- updated to 9.2.2rc1
606
607* Thu May 02 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl0
608- updated to bind9(9.2.1), test packages ;)
609        -- based on Rawhide's bind-9.2.0-8
610        -- changed name bind9
611        -- added Conflicts: bind
612
613* Sun Feb 03 2002 Toru Sagami <sagami@vinelinux.org> 8.3.1-0vl1
614- release 8.3.1 includes security fixes
615
616* Mon Jan 14 2002 Toru Sagami <sagami@vinelinux.org> 8.3.0-0vl1
617- Upgraded to current stable release 8.3.0
618
619* Mon Oct  8 2001 <zn@mbf.nifty.com>
620- 8.2.5-0vl0: Upgraded to new upstream version.
621
622* Thu May 24 2001 <sagami@vinelinux.org>
623- 8.2.4-0vl1: eliminate CVS related files from %%doc
624
625* Thu May 17 2001 <sagami@vinelinux.org>
626- 8.2.4-0vl0
627
628* Fri Feb 02 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
629- 8.2.3-1vl2
630- built on VineSeed
631
632* Tue Jan 30 2001 KAJIKI Yoshihiro <kajiki@ylug.org>
633- add doc/old
634- build for Vine 2.1
635
636* Sat Jan 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
637- 8.2.3, fixes several security problems
638
639* Tue Nov 14 2000 Bill Nottingham <notting@redhat.com>
640- static libraries may be used in shared objects. Build with -fPIC on ia64
641
642* Fri Nov 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
643- 8.2.2-P7 (fixes Bug #20546)
644
645* Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
646- condrestart fixes
647
648* Tue Jul 18 2000 Nalin Dahyabhai <nalin@redhat.com>
649- change the init script to take condrestart, not cond-restart
650- add sh-utils, /bin/cat, perl, /bin/chmod, /usr/sbin/useradd as prereqs for
651  the %pre and %post scripts
652
653* Sun Jul 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
654- Don't prereq /etc/init.d
655
656* Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
657- move initscript back
658
659* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
660- automatic rebuild
661
662* Sun Jul  9 2000 Florian La Roche <Florian.LaRoche@redhat.de>
663- add "exit 0" for uninstall case
664
665* Fri Jul  7 2000 Florian La Roche <Florian.LaRoche@redhat.de>
666- add prereq init.d and cleanup install section
667
668* Fri Jun 30 2000 Trond Eivind Glomsr <teg@redhat.com>
669- fix the init script
670
671* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
672- make libbind.a and nslookup.help readable again by setting INSTALL_LIB to ""
673
674* Mon Jun 26 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
675- Fix up the initscript (Bug #13033)
676- Fix build with current glibc (Bug #12755)
677- /etc/rc.d/init.d -> /etc/init.d
678- use %%{_mandir} rather than /usr/share/man
679
680* Mon Jun 19 2000 Bill Nottingham <notting@redhat.com>
681- fix conflict with man-pages
682- remove compatibilty chkconfig links
683- initscript munging
684
685* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
686- modify logrotate setup to use PID file
687- temporarily disable optimization by unsetting $RPM_OPT_FLAGS at build-time
688- actually bump the release this time
689
690* Sun Jun  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
691- FHS compliance
692
693* Mon Apr 17 2000 Nalin Dahyabhai <nalin@redhat.com>
694- clean up restart patch
695
696* Mon Apr 10 2000 Nalin Dahyabhai <nalin@redhat.com>
697- provide /var/named (fix for bugs #9847, #10205)
698- preserve args when restarted via ndc(8) (bug #10227)
699- make resolv.conf(5) a link to resolver(5) (bug #10245)
700- fix SYSTYPE bug in all makefiles
701- move creation of named user from %%post into %%pre
702
703* Mon Feb 28 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
704- Fix TTL (patch from ISC, Bug #9820)
705
706* Wed Feb 16 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
707- fix typo in spec (it's %post, without a leading blank) introduced in -6
708- change SYSTYPE to linux
709
710* Fri Feb 11 2000 Bill Nottingham <notting@redhat.com>
711- pick a standard < 100 uid/gid for named
712
713* Fri Feb 04 2000 Elliot Lee <sopwith@redhat.com>
714- Pass named a '-u named' parameter by default, and add/remove user.
715
716* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
717- fix host mx bug (Bug #9021)
718
719* Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
720- rebuild to fix dependencies
721- man pages are compressed
722
723* Wed Jan 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
724- It's /usr/bin/killall, not /usr/sbin/killall (Bug #8063)
725
726* Mon Jan 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
727- Fix up location of named-bootconf.pl and make it executable
728  (Bug #8028)
729- bind-devel requires bind
730
731* Mon Nov 15 1999 Bernhard Rosenkraenzer <bero@redhat.com>
732- update to 8.2.2-P5
733
734* Wed Nov 10 1999 Bill Nottingham <notting@redhat.com>
735- update to 8.2.2-P3
736
737* Tue Oct 12 1999 Cristian Gafton <gafton@redhat.com>
738- add patch to stop a cache only server from complaining about lame servers
739  on every request.
740
741* Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
742- use real stop and start in named.init for restart, not ndc restart, it has
743  problems when named has changed during a package update... (# 4890)
744
745* Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
746- chkconfig --del in %preun, not %postun
747
748* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
749- initscript munging
750
751* Mon Jul 26 1999 Bill Nottingham <notting@redhat.com>
752- fix installed chkconfig links to match init file
753
754* Sat Jul  3 1999 Jeff Johnson <jbj@redhat.com>
755- conflict with new (in man-1.24) man pages (#3876,#3877).
756
757* Tue Jun 29 1999 Bill Nottingham <notting@redhat.com>
758- fix named.logrotate (wrong %SOURCE)
759
760* Fri Jun 25 1999 Jeff Johnson <jbj@redhat.com>
761- update to 8.2.1.
762- add named.logrotate (#3571).
763- hack around egcs-1.1.2 -m486 bug (#3413, #3485).
764- vet file list.
765
766* Fri Jun 18 1999 Bill Nottingham <notting@redhat.com>
767- don't run by default
768
769* Sun May 30 1999 Jeff Johnson <jbj@redhat.com>
770- nslookup fixes (#2463).
771- missing files (#3152).
772
773* Sat May  1 1999 Stepan Kasal <kasal@math.cas.cz>
774- nslookup patched:
775  to count numRecords properly
776  to fix subsequent calls to ls -d
777  to parse "view" and "finger" commands properly
778  the view hack updated for bind-8 (using sed)
779
780* Wed Mar 31 1999 Bill Nottingham <notting@redhat.com>
781- add ISC patch
782- add quick hack to make host not crash
783- add more docs
784
785* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
786- add probing information in the init file to keep linuxconf happy
787- dont strip libbind
788
789* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
790- auto rebuild in the new build environment (release 3)
791
792* Wed Mar 17 1999 Preston Brown <pbrown@redhat.com>
793- removed 'done' output at named shutdown.
794
795* Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
796- version 8.2
797
798* Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com>
799- patch to use the __FDS_BITS macro
800- build for glibc 2.1
801
802* Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
803- change named.restart to /usr/sbin/ndc restart
804
805* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
806- install man pages correctly.
807- change K10named to K45named.
808
809* Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
810- don't start if /etc/named.conf doesn't exist.
811
812* Sat Aug  8 1998 Jeff Johnson <jbj@redhat.com>
813- autmagically create /etc/named.conf from /etc/named.boot in %post
814- remove echo in %post
815
816* Wed Jun 10 1998 Jeff Johnson <jbj@redhat.com>
817- merge in 5.1 mods
818
819* Sun Apr 12 1998 Manuel J. Galan <manolow@step.es>
820- Several essential modifications to build and install correctly.
821- Modified 'ndc' to avoid deprecated use of '-'
822
823* Mon Dec 22 1997 Scott Lampert <fortunato@heavymetal.org>
824- Used buildroot
825- patched bin/named/ns_udp.c to use <libelf/nlist.h> for include
826  on Redhat 5.0 instead of <nlist.h>
827
Note: See TracBrowser for help on using the repository browser.