source: projects/specs/trunk/b/bind/bind-vl.spec @ 6632

Revision 6632, 19.7 KB checked in by daisuke, 12 years ago (diff)

update to 9.6-ESV-R7-P2

Line 
1%define _localstatedir /var
2
3%define pversion 9.6.ESV.R7.P2
4%define sversion 9.6-ESV-R7-P2
5%define bind_epoch 1
6
7%define bind_uid  25
8%define bind_gid  25
9
10Summary: A DNS (Domain Name System) server.
11Summary(ja): DNS (Domain Name System) サーバ
12Name: bind
13Version: %{pversion}
14Release: 1%{?_dist_release}
15License: distributable
16Group: System Environment/Daemons
17Source: ftp://ftp.isc.org/isc/bind9/%{version}/%{name}-%{sversion}.tar.gz
18Source1: bind-manpages.tar.bz2
19Source2: named.sysconfig
20Source3: named.init
21Source4: named.logrotate
22Source5: keygen.c
23Url: http://www.isc.org/bind.html
24Patch1: bind-9.3.3rc2-rndckey.patch
25Buildroot: %{_tmppath}/%{name}-%{version}-root
26BuildRequires: openssl-devel glibc-devel libtool
27BuildRequires: libxml2-devel libcap-devel
28Requires(pre): chkconfig, sh-utils, textutils, fileutils, shadow-utils, perl, sed
29Requires(pre): bind-utils = %{bind_epoch}:%{version}-%{release}
30Requires: bind-libs = %{bind_epoch}:%{version}-%{release}
31Conflicts: bind9 <= 9.2.1-0vl5, bind-current
32Obsoletes: bind9 <= 9.2.1-0vl5
33epoch: %{bind_epoch}
34
35Vendor: Project Vine
36Distribution: Vine Linux
37
38%description
39BIND (Berkeley Internet Name Domain) is an implementation of the DNS
40(Domain Name System) protocols. BIND includes a DNS server (named),
41which resolves host names to IP addresses, and a resolver library
42(routines for applications to use when interfacing with DNS).  A DNS
43server allows clients to name resources or objects and share the
44information with other network machines.  The named DNS server can be
45used on workstations as a caching name server, but is generally only
46needed on one machine for an entire network.  Note that the
47configuration files for making BIND act as a simple caching nameserver
48are included in the caching-nameserver package. 
49
50Install the bind package if you need a DNS server for your network.  If
51you want bind to act a caching name server, you will also need to install
52the caching-nameserver package.
53
54
55%package libs
56Summary: Libraries used by various DNS packages
57Group: System Environment/Libraries
58Conflicts: bind-current-libs
59
60%description libs
61Contains libraries used by both the bind server package as well as the utils packages.
62
63
64%package utils
65Summary: Utilities for querying DNS name servers.
66Summary(ja): DNS ネームサーバに問い合わせをするユーティリティ
67Group: Applications/System
68Requires: bind-libs = %{bind_epoch}:%{version}-%{release}
69Conflicts: bind9-utils <= 9.2.1-0vl5, bind-current-utils
70Obsoletes: bind9-utils <= 9.2.1-0vl5
71
72
73%description utils
74Bind-utils contains a collection of utilities for querying DNS (Domain
75Name Service) name servers to find out information about Internet hosts.
76These tools will provide you with the IP addresses for given host names,
77as well as other information about registered domains and network
78addresses.
79
80You should install bind-utils if you need to get information from DNS name
81servers.
82
83
84%package devel
85Summary: Include files and libraries needed for bind DNS development.
86Summary(ja): bind DNS 開発に必要なインクルードファイルとライブラリ
87Group: Development/Libraries
88Requires: bind = %{bind_epoch}:%{version}-%{release}
89Requires: bind-libs = %{bind_epoch}:%{version}-%{release}
90Conflicts: bind9-devel <= 9.2.1-0vl5, bind-current-devel
91Obsoletes: bind9-devel <= 9.2.1-0vl5
92
93
94%description devel
95The bind-devel package contains all the include files and the
96library required for DNS (Domain Name Service) development for
97BIND versions 9.x.x.
98
99You should install bind-devel if you want to develop bind DNS
100applications. If you install bind-devel, you'll also need to install
101bind.
102#'
103
104%prep
105%setup -n bind-%{sversion} -q
106%patch1 -p1 -b .key
107
108%build
109libtoolize --copy --force
110aclocal
111autoconf
112%configure --with-libtool --with-openssl=/usr --enable-threads
113make %{?_smp_mflags}
114
115%install
116rm -rf $RPM_BUILD_ROOT
117mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/{rc.d/init.d,logrotate.d}
118mkdir -p ${RPM_BUILD_ROOT}/usr/{bin,lib,sbin,include}
119mkdir -p ${RPM_BUILD_ROOT}/var/named
120mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/{man1,man5,man8}
121mkdir -p ${RPM_BUILD_ROOT}/var/run/named
122
123make DESTDIR=$RPM_BUILD_ROOT install
124install -c -m 640 bin/rndc/rndc.conf $RPM_BUILD_ROOT/etc
125install -c -m 755 contrib/named-bootconf/named-bootconf.sh $RPM_BUILD_ROOT/usr/sbin/named-bootconf
126install -c -m 755 %SOURCE3 $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/named
127install -c -m 644 %SOURCE4 $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/named
128touch $RPM_BUILD_ROOT%{_sysconfdir}/rndc.key
129gcc $RPM_OPT_FLAGS -o $RPM_BUILD_ROOT/usr/sbin/dns-keygen %{SOURCE5}
130cd $RPM_BUILD_ROOT%{_mandir}
131tar xjf %{SOURCE1}
132# newer version is contained in source
133rm -f man5/named.conf.5.gz
134mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
135cp %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/named
136
137
138%pre
139if [ "$1" -eq 1 ]; then
140  /usr/sbin/groupadd -g %{bind_gid} -f -r named >/dev/null 2>&1 || :;
141  /usr/sbin/useradd  -u %{bind_uid} -r -N -M -g named -s /sbin/nologin -d /var/named -c Named named >/dev/null 2>&1 || :;
142fi;
143:;
144
145%post
146/sbin/ldconfig
147/sbin/chkconfig --add named
148if [ "$1" -eq 1 ]; then
149  if [ ! -e /etc/rndc.key ]; then
150    /usr/sbin/rndc-confgen -a > /dev/null 2>&1
151  fi
152  [ -x /sbin/restorecon ] && /sbin/restorecon /etc/rndc.* /etc/named.* >/dev/null 2>&1 ;
153  # rndc.key has to have correct perms and ownership, CVE-2007-6283
154  [ -e /etc/rndc.key ] && chown root:named /etc/rndc.key
155  [ -e /etc/rndc.key ] && chmod 0640 /etc/rndc.key
156
157  # Check DNSSEC settings if this is a fresh install
158  if [ -r /etc/sysconfig/dnssec ]; then
159    . /etc/sysconfig/dnssec
160    [ -x /usr/sbin/dnssec-configure ] && \
161      dnssec-configure -b --norestart --dnssec="$DNSSEC" --dlv="$DLV" > \
162        /dev/null 2>&1
163  fi;
164fi
165:;
166
167%preun
168if [ "$1" -eq 0 ]; then
169   /sbin/service named stop >/dev/null 2>&1 || :
170   /sbin/chkconfig --del named ||:
171fi
172exit 0
173
174
175%postun
176if [ "$1" -ge 1 ]; then
177        %{_sysconfdir}/rc.d/init.d/named condrestart >/dev/null 2>&1 || :
178fi
179/sbin/ldconfig
180
181%triggerpostun -- bind < 8.2.2_P5-15
182/sbin/chkconfig --add named
183/sbin/ldconfig
184
185%clean
186rm -rf ${RPM_BUILD_ROOT} ${RPM_BUILD_DIR}/%{name}-%{version}
187
188
189%post libs -p /sbin/ldconfig
190
191%postun libs -p /sbin/ldconfig
192
193
194%files
195%defattr(-,root,root)
196%doc CHANGES README
197%doc doc/arm doc/draft doc/rfc doc/misc
198%config(noreplace) %{_sysconfdir}/logrotate.d/named
199%config %{_sysconfdir}/rc.d/init.d/named
200%config(noreplace) %{_sysconfdir}/sysconfig/named
201%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.conf
202%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.key
203
204%{_sbindir}/dnssec*
205%{_sbindir}/lwresd
206%{_sbindir}/named
207%{_sbindir}/named-bootconf
208%{_sbindir}/named-check*
209%{_sbindir}/named-compilezone
210%{_sbindir}/rndc*
211%{_sbindir}/dns-keygen
212
213#%{_libdir}/libbind9.so.*
214#%{_libdir}/libisccc.so.*
215#%{_libdir}/libisccfg.so.*
216
217%{_mandir}/man5/resolv.conf.5*
218%{_mandir}/man5/named.conf.5*
219%{_mandir}/man5/rndc.conf.5*
220%{_mandir}/man8/rndc.8*
221%{_mandir}/man8/named.8*
222%{_mandir}/man8/lwresd.8*
223%{_mandir}/man8/dnssec*.8*
224%{_mandir}/man8/named-checkconf.8*
225%{_mandir}/man8/named-checkzone.8*
226%{_mandir}/man8/named-compilezone.8*
227%{_mandir}/man8/rndc-confgen.8*
228
229%attr(-,named,named) %dir %{_var}/named
230%attr(-,named,named) %dir %{_var}/run/named
231     
232
233%files libs
234%defattr(-,root,root)
235%{_libdir}/*.so.*
236
237%files utils
238%defattr(-,root,root)
239%{_bindir}/dig
240%{_bindir}/host
241%{_bindir}/nslookup
242%{_bindir}/nsupdate
243#%{_libdir}/libdns.so.*
244#%{_libdir}/libisc.so.*
245#%{_libdir}/liblwres.so.*
246%{_mandir}/man1/host.1*
247%{_mandir}/man1/nsupdate.1*
248%{_mandir}/man1/dig.1*
249%{_mandir}/man5/resolver.5*
250%{_mandir}/man1/nslookup.1*
251%{_mandir}/man8/nslookup.8*
252
253
254%files devel
255%defattr(-,root,root)
256%{_libdir}/*.so
257%{_libdir}/*.la
258%{_libdir}/*.a
259%{_includedir}/*
260%{_mandir}/man3/*
261%{_mandir}/man1/isc-config.sh.1*
262%{_bindir}/isc-config.sh
263
264%changelog
265* Wed Jul 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.ESV.R7.P2-1
266- new upstream release with secrity fix (CVE-2012-3817)
267
268* Tue Jun  5 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R7.P1-1
269- new upstream release with security fix (CVE-2012-1667)
270
271* Fri Nov 18 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R5.P1-1
272- new upstream release with security fix (CVE-2011-4313)
273
274* Wed Jul  6 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R4.P3-1
275- new upstream release with security fix (CVE-2011-2464)
276- use hoge(pre) tags instead of old hogepre tags
277
278* Sat May 28 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R4.P1-1
279- new upstream release with security fix (CVE-2011-1910)
280
281* Thu Mar 31 2011 IWAI, Masaharu <iwai@alib.jp> 9.6.ESV.R4-1
282- new upstream release
283
284* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.6.ESV.R2-4
285- rebuild with openssl-1.0.0c
286
287* Fri Jan 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.6.ESV.R2-3
288- rebuild package
289
290* Sun Oct 24 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R2-2
291- change spec filename bind9-vl -> bind-vl
292
293* Thu Oct  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R2-1
294- new upstream ESV release
295- add BR: libxml2-devel libcap-devel
296
297* Wed Aug 18 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R1-2
298- add Conflicts bind-current
299
300* Tue Aug 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R1-1
301- new upstream ESV release
302- add epoch 1 to upgrade from exist bind package
303
304* Thu Jan 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-2
305- add man1/isc-config.sh.1 into devel file list
306
307* Wed Jan 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-1
308- new upstream release with security fix (CVE-2009-4022, 2010-0097) 
309
310* Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P2-1
311- new upstream release with security fix (CVE-2009-4022)
312
313* Wed Jul 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P1-1
314- new upstream release with security fix
315
316* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.1-1
317- new upstream release
318- clean up %%post/%%pre scriptlet
319  - create named user and group in %%pre
320  - don't remove named user/group in %%preun
321  - use rndc-confgen to create rndc.key
322
323* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.0P1-1
324- new upstream release
325- drop patch0 and patch14, merged in upstream
326
327* Sat Jan 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.5.1P1-1
328- new upstream release with security fix
329
330* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 9.5.0P1-1
331- new upstream release with security fix
332- new versioning policy
333
334* Sun Sep 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1P1-0vl1
335- new upstream release with security fix
336
337* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1-0vl1
338- new upstream release
339- build with new openssl/toolchain
340
341* Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.4-0vl1
342- new upstream release with security fix
343
344* Fri Nov 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2P2-0vl1
345- new upstream release
346
347* Fri Sep 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl2
348- add Prereq sed
349
350* Wed Sep 06 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl1
351- new upstream release for security fix (CVE-2006-4095,4096)
352
353* Wed Feb 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 9.3.2-0vl3
354- separate -libs package
355- remove old named.conf.5.gz
356  - newer version is contained in source
357
358* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl2
359- add bsdcompat patch (Patch4)
360- add fix_h_errno patch from FC
361  - h_errno not being accessed / set correctly in libbind
362
363* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl1
364- new upstream release
365
366* Sun Nov  7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 9.2.4-0vl2
367- added PreReq to bind-utils (see: [VineSeed:09555])
368
369* Thu Oct 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.4-0vl1
370- new upstream release
371
372* Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl3
373- fix /etc/init.d/named to use rndc
374
375* Tue Nov 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl2
376- rebuild to remove unneeded dependancy
377
378* Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl1
379- new upstream release
380
381* Tue Mar  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.2-0vl1
382- new upstream release
383
384* Thu Nov 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl7
385- fix dependancies.
386
387* Wed Nov 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl6
388- add obsoletes: and conflicts: to bind9, bind9-utils, bind9-devel <= 9.2.1-0vl5
389- change package name to bind for VineSeed.
390- use more macros.
391
392* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl5
393- fixed some macros
394- add conflicts: to bind-* in bind9-devel and bind9-utils
395- add provides: bind = %%{version}
396
397* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl4
398- use %%configure macros
399
400* Sat Oct 19 2002 Michihide Hotta <hotta@net-newbie.com> 9.2.1-0vl3
401- fixed inconsistent dependency
402
403* Wed Aug 14 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl2
404- updated to 9.2.2rc1
405
406* Thu May 02 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl0
407- updated to bind9(9.2.1), test packages ;)
408        -- based on Rawhide's bind-9.2.0-8
409        -- changed name bind9
410        -- added Conflicts: bind
411
412* Sun Feb 03 2002 Toru Sagami <sagami@vinelinux.org> 8.3.1-0vl1
413- release 8.3.1 includes security fixes
414
415* Mon Jan 14 2002 Toru Sagami <sagami@vinelinux.org> 8.3.0-0vl1
416- Upgraded to current stable release 8.3.0
417
418* Mon Oct  8 2001 <zn@mbf.nifty.com>
419- 8.2.5-0vl0: Upgraded to new upstream version.
420
421* Thu May 24 2001 <sagami@vinelinux.org>
422- 8.2.4-0vl1: eliminate CVS related files from %%doc
423
424* Thu May 17 2001 <sagami@vinelinux.org>
425- 8.2.4-0vl0
426
427* Fri Feb 02 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
428- 8.2.3-1vl2
429- built on VineSeed
430
431* Tue Jan 30 2001 KAJIKI Yoshihiro <kajiki@ylug.org>
432- add doc/old
433- build for Vine 2.1
434
435* Sat Jan 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
436- 8.2.3, fixes several security problems
437
438* Tue Nov 14 2000 Bill Nottingham <notting@redhat.com>
439- static libraries may be used in shared objects. Build with -fPIC on ia64
440
441* Fri Nov 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
442- 8.2.2-P7 (fixes Bug #20546)
443
444* Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
445- condrestart fixes
446
447* Tue Jul 18 2000 Nalin Dahyabhai <nalin@redhat.com>
448- change the init script to take condrestart, not cond-restart
449- add sh-utils, /bin/cat, perl, /bin/chmod, /usr/sbin/useradd as prereqs for
450  the %pre and %post scripts
451
452* Sun Jul 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
453- Don't prereq /etc/init.d
454
455* Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
456- move initscript back
457
458* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
459- automatic rebuild
460
461* Sun Jul  9 2000 Florian La Roche <Florian.LaRoche@redhat.de>
462- add "exit 0" for uninstall case
463
464* Fri Jul  7 2000 Florian La Roche <Florian.LaRoche@redhat.de>
465- add prereq init.d and cleanup install section
466
467* Fri Jun 30 2000 Trond Eivind Glomsr <teg@redhat.com>
468- fix the init script
469
470* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
471- make libbind.a and nslookup.help readable again by setting INSTALL_LIB to ""
472
473* Mon Jun 26 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
474- Fix up the initscript (Bug #13033)
475- Fix build with current glibc (Bug #12755)
476- /etc/rc.d/init.d -> /etc/init.d
477- use %%{_mandir} rather than /usr/share/man
478
479* Mon Jun 19 2000 Bill Nottingham <notting@redhat.com>
480- fix conflict with man-pages
481- remove compatibilty chkconfig links
482- initscript munging
483
484* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
485- modify logrotate setup to use PID file
486- temporarily disable optimization by unsetting $RPM_OPT_FLAGS at build-time
487- actually bump the release this time
488
489* Sun Jun  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
490- FHS compliance
491
492* Mon Apr 17 2000 Nalin Dahyabhai <nalin@redhat.com>
493- clean up restart patch
494
495* Mon Apr 10 2000 Nalin Dahyabhai <nalin@redhat.com>
496- provide /var/named (fix for bugs #9847, #10205)
497- preserve args when restarted via ndc(8) (bug #10227)
498- make resolv.conf(5) a link to resolver(5) (bug #10245)
499- fix SYSTYPE bug in all makefiles
500- move creation of named user from %%post into %%pre
501
502* Mon Feb 28 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
503- Fix TTL (patch from ISC, Bug #9820)
504
505* Wed Feb 16 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
506- fix typo in spec (it's %post, without a leading blank) introduced in -6
507- change SYSTYPE to linux
508
509* Sat Feb 11 2000 Bill Nottingham <notting@redhat.com>
510- pick a standard < 100 uid/gid for named
511
512* Thu Feb 04 2000 Elliot Lee <sopwith@redhat.com>
513- Pass named a '-u named' parameter by default, and add/remove user.
514
515* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
516- fix host mx bug (Bug #9021)
517
518* Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
519- rebuild to fix dependencies
520- man pages are compressed
521
522* Wed Jan 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
523- It's /usr/bin/killall, not /usr/sbin/killall (Bug #8063)
524
525* Mon Jan 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
526- Fix up location of named-bootconf.pl and make it executable
527  (Bug #8028)
528- bind-devel requires bind
529
530* Mon Nov 15 1999 Bernhard Rosenkraenzer <bero@redhat.com>
531- update to 8.2.2-P5
532
533* Wed Nov 10 1999 Bill Nottingham <notting@redhat.com>
534- update to 8.2.2-P3
535
536* Tue Oct 12 1999 Cristian Gafton <gafton@redhat.com>
537- add patch to stop a cache only server from complaining about lame servers
538  on every request.
539
540* Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
541- use real stop and start in named.init for restart, not ndc restart, it has
542  problems when named has changed during a package update... (# 4890)
543
544* Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
545- chkconfig --del in %preun, not %postun
546
547* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
548- initscript munging
549
550* Mon Jul 26 1999 Bill Nottingham <notting@redhat.com>
551- fix installed chkconfig links to match init file
552
553* Sat Jul  3 1999 Jeff Johnson <jbj@redhat.com>
554- conflict with new (in man-1.24) man pages (#3876,#3877).
555
556* Tue Jun 29 1999 Bill Nottingham <notting@redhat.com>
557- fix named.logrotate (wrong %SOURCE)
558
559* Fri Jun 25 1999 Jeff Johnson <jbj@redhat.com>
560- update to 8.2.1.
561- add named.logrotate (#3571).
562- hack around egcs-1.1.2 -m486 bug (#3413, #3485).
563- vet file list.
564
565* Fri Jun 18 1999 Bill Nottingham <notting@redhat.com>
566- don't run by default
567
568* Sun May 30 1999 Jeff Johnson <jbj@redhat.com>
569- nslookup fixes (#2463).
570- missing files (#3152).
571
572* Sat May  1 1999 Stepan Kasal <kasal@math.cas.cz>
573- nslookup patched:
574  to count numRecords properly
575  to fix subsequent calls to ls -d
576  to parse "view" and "finger" commands properly
577  the view hack updated for bind-8 (using sed)
578
579* Wed Mar 31 1999 Bill Nottingham <notting@redhat.com>
580- add ISC patch
581- add quick hack to make host not crash
582- add more docs
583
584* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
585- add probing information in the init file to keep linuxconf happy
586- dont strip libbind
587
588* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
589- auto rebuild in the new build environment (release 3)
590
591* Wed Mar 17 1999 Preston Brown <pbrown@redhat.com>
592- removed 'done' output at named shutdown.
593
594* Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
595- version 8.2
596
597* Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com>
598- patch to use the __FDS_BITS macro
599- build for glibc 2.1
600
601* Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
602- change named.restart to /usr/sbin/ndc restart
603
604* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
605- install man pages correctly.
606- change K10named to K45named.
607
608* Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
609- don't start if /etc/named.conf doesn't exist.
610
611* Sat Aug  8 1998 Jeff Johnson <jbj@redhat.com>
612- autmagically create /etc/named.conf from /etc/named.boot in %post
613- remove echo in %post
614
615* Wed Jun 10 1998 Jeff Johnson <jbj@redhat.com>
616- merge in 5.1 mods
617
618* Sun Apr 12 1998 Manuel J. Galan <manolow@step.es>
619- Several essential modifications to build and install correctly.
620- Modified 'ndc' to avoid deprecated use of '-'
621
622* Mon Dec 22 1997 Scott Lampert <fortunato@heavymetal.org>
623- Used buildroot
624- patched bin/named/ns_udp.c to use <libelf/nlist.h> for include
625  on Redhat 5.0 instead of <nlist.h>
626
Note: See TracBrowser for help on using the repository browser.