source: projects/specs/trunk/b/bind/bind-vl.spec @ 6634

Revision 6634, 19.7 KB checked in by daisuke, 12 years ago (diff)

fix permissions, remove .la

Line 
1%define _localstatedir /var
2
3%define pversion 9.6.ESV.R7.P2
4%define sversion 9.6-ESV-R7-P2
5%define bind_epoch 1
6
7%define bind_uid  25
8%define bind_gid  25
9
10Summary: A DNS (Domain Name System) server.
11Summary(ja): DNS (Domain Name System) サーバ
12Name: bind
13Version: %{pversion}
14Release: 1%{?_dist_release}
15License: distributable
16Group: System Environment/Daemons
17Source: ftp://ftp.isc.org/isc/bind9/%{version}/%{name}-%{sversion}.tar.gz
18Source1: bind-manpages.tar.bz2
19Source2: named.sysconfig
20Source3: named.init
21Source4: named.logrotate
22Source5: keygen.c
23Url: http://www.isc.org/bind.html
24Patch1: bind-9.3.3rc2-rndckey.patch
25Buildroot: %{_tmppath}/%{name}-%{version}-root
26BuildRequires: openssl-devel glibc-devel libtool
27BuildRequires: libxml2-devel libcap-devel
28Requires(pre): chkconfig, sh-utils, textutils, fileutils, shadow-utils, perl, sed
29Requires(pre): bind-utils = %{bind_epoch}:%{version}-%{release}
30Requires: bind-libs = %{bind_epoch}:%{version}-%{release}
31Conflicts: bind9 <= 9.2.1-0vl5, bind-current
32Obsoletes: bind9 <= 9.2.1-0vl5
33epoch: %{bind_epoch}
34
35Vendor: Project Vine
36Distribution: Vine Linux
37
38%description
39BIND (Berkeley Internet Name Domain) is an implementation of the DNS
40(Domain Name System) protocols. BIND includes a DNS server (named),
41which resolves host names to IP addresses, and a resolver library
42(routines for applications to use when interfacing with DNS).  A DNS
43server allows clients to name resources or objects and share the
44information with other network machines.  The named DNS server can be
45used on workstations as a caching name server, but is generally only
46needed on one machine for an entire network.  Note that the
47configuration files for making BIND act as a simple caching nameserver
48are included in the caching-nameserver package. 
49
50Install the bind package if you need a DNS server for your network.  If
51you want bind to act a caching name server, you will also need to install
52the caching-nameserver package.
53
54
55%package libs
56Summary: Libraries used by various DNS packages
57Group: System Environment/Libraries
58Conflicts: bind-current-libs
59
60%description libs
61Contains libraries used by both the bind server package as well as the utils packages.
62
63
64%package utils
65Summary: Utilities for querying DNS name servers.
66Summary(ja): DNS ネームサーバに問い合わせをするユーティリティ
67Group: Applications/System
68Requires: bind-libs = %{bind_epoch}:%{version}-%{release}
69Conflicts: bind9-utils <= 9.2.1-0vl5, bind-current-utils
70Obsoletes: bind9-utils <= 9.2.1-0vl5
71
72
73%description utils
74Bind-utils contains a collection of utilities for querying DNS (Domain
75Name Service) name servers to find out information about Internet hosts.
76These tools will provide you with the IP addresses for given host names,
77as well as other information about registered domains and network
78addresses.
79
80You should install bind-utils if you need to get information from DNS name
81servers.
82
83
84%package devel
85Summary: Include files and libraries needed for bind DNS development.
86Summary(ja): bind DNS 開発に必要なインクルードファイルとライブラリ
87Group: Development/Libraries
88Requires: bind = %{bind_epoch}:%{version}-%{release}
89Requires: bind-libs = %{bind_epoch}:%{version}-%{release}
90Conflicts: bind9-devel <= 9.2.1-0vl5, bind-current-devel
91Obsoletes: bind9-devel <= 9.2.1-0vl5
92
93
94%description devel
95The bind-devel package contains all the include files and the
96library required for DNS (Domain Name Service) development for
97BIND versions 9.x.x.
98
99You should install bind-devel if you want to develop bind DNS
100applications. If you install bind-devel, you'll also need to install
101bind.
102#'
103
104%prep
105%setup -n bind-%{sversion} -q
106%patch1 -p1 -b .key
107
108%build
109libtoolize --copy --force
110aclocal
111autoconf
112%configure --with-libtool --with-openssl=/usr --enable-threads
113make %{?_smp_mflags}
114
115%install
116rm -rf $RPM_BUILD_ROOT
117mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/{rc.d/init.d,logrotate.d}
118mkdir -p ${RPM_BUILD_ROOT}/usr/{bin,lib,sbin,include}
119mkdir -p ${RPM_BUILD_ROOT}/var/named
120mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/{man1,man5,man8}
121mkdir -p ${RPM_BUILD_ROOT}/var/run/named
122
123make DESTDIR=$RPM_BUILD_ROOT install
124install -c -m 640 bin/rndc/rndc.conf $RPM_BUILD_ROOT/etc
125install -c -m 755 contrib/named-bootconf/named-bootconf.sh $RPM_BUILD_ROOT/usr/sbin/named-bootconf
126install -c -m 755 %SOURCE3 $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/named
127install -c -m 644 %SOURCE4 $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/named
128touch $RPM_BUILD_ROOT%{_sysconfdir}/rndc.key
129gcc $RPM_OPT_FLAGS -o $RPM_BUILD_ROOT/usr/sbin/dns-keygen %{SOURCE5}
130cd $RPM_BUILD_ROOT%{_mandir}
131tar xjf %{SOURCE1}
132# newer version is contained in source
133rm -f man5/named.conf.5.gz
134mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
135cp %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/named
136
137# fix permissions
138chmod 0755 $RPM_BUILD_ROOT%{_libdir}/lib*.so.*
139
140%pre
141if [ "$1" -eq 1 ]; then
142  /usr/sbin/groupadd -g %{bind_gid} -f -r named >/dev/null 2>&1 || :;
143  /usr/sbin/useradd  -u %{bind_uid} -r -N -M -g named -s /sbin/nologin -d /var/named -c Named named >/dev/null 2>&1 || :;
144fi;
145:;
146
147%post
148/sbin/ldconfig
149/sbin/chkconfig --add named
150if [ "$1" -eq 1 ]; then
151  if [ ! -e /etc/rndc.key ]; then
152    /usr/sbin/rndc-confgen -a > /dev/null 2>&1
153  fi
154  [ -x /sbin/restorecon ] && /sbin/restorecon /etc/rndc.* /etc/named.* >/dev/null 2>&1 ;
155  # rndc.key has to have correct perms and ownership, CVE-2007-6283
156  [ -e /etc/rndc.key ] && chown root:named /etc/rndc.key
157  [ -e /etc/rndc.key ] && chmod 0640 /etc/rndc.key
158
159  # Check DNSSEC settings if this is a fresh install
160  if [ -r /etc/sysconfig/dnssec ]; then
161    . /etc/sysconfig/dnssec
162    [ -x /usr/sbin/dnssec-configure ] && \
163      dnssec-configure -b --norestart --dnssec="$DNSSEC" --dlv="$DLV" > \
164        /dev/null 2>&1
165  fi;
166fi
167:;
168
169%preun
170if [ "$1" -eq 0 ]; then
171   /sbin/service named stop >/dev/null 2>&1 || :
172   /sbin/chkconfig --del named ||:
173fi
174exit 0
175
176
177%postun
178if [ "$1" -ge 1 ]; then
179        %{_sysconfdir}/rc.d/init.d/named condrestart >/dev/null 2>&1 || :
180fi
181/sbin/ldconfig
182
183%triggerpostun -- bind < 8.2.2_P5-15
184/sbin/chkconfig --add named
185/sbin/ldconfig
186
187%clean
188rm -rf ${RPM_BUILD_ROOT} ${RPM_BUILD_DIR}/%{name}-%{version}
189
190
191%post libs -p /sbin/ldconfig
192
193%postun libs -p /sbin/ldconfig
194
195
196%files
197%defattr(-,root,root)
198%doc CHANGES README
199%doc doc/arm doc/draft doc/rfc doc/misc
200%config(noreplace) %{_sysconfdir}/logrotate.d/named
201%config %{_sysconfdir}/rc.d/init.d/named
202%config(noreplace) %{_sysconfdir}/sysconfig/named
203%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.conf
204%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.key
205
206%{_sbindir}/dnssec*
207%{_sbindir}/lwresd
208%{_sbindir}/named
209%{_sbindir}/named-bootconf
210%{_sbindir}/named-check*
211%{_sbindir}/named-compilezone
212%{_sbindir}/rndc*
213%{_sbindir}/dns-keygen
214
215%{_mandir}/man5/resolv.conf.5*
216%{_mandir}/man5/named.conf.5*
217%{_mandir}/man5/rndc.conf.5*
218%{_mandir}/man8/rndc.8*
219%{_mandir}/man8/named.8*
220%{_mandir}/man8/lwresd.8*
221%{_mandir}/man8/dnssec*.8*
222%{_mandir}/man8/named-checkconf.8*
223%{_mandir}/man8/named-checkzone.8*
224%{_mandir}/man8/named-compilezone.8*
225%{_mandir}/man8/rndc-confgen.8*
226
227%attr(-,named,named) %dir %{_var}/named
228%attr(-,named,named) %dir %{_var}/run/named
229     
230
231%files libs
232%defattr(-,root,root)
233%{_libdir}/*.so.*
234
235%files utils
236%defattr(-,root,root)
237%{_bindir}/dig
238%{_bindir}/host
239%{_bindir}/nslookup
240%{_bindir}/nsupdate
241%{_mandir}/man1/host.1*
242%{_mandir}/man1/nsupdate.1*
243%{_mandir}/man1/dig.1*
244%{_mandir}/man5/resolver.5*
245%{_mandir}/man1/nslookup.1*
246%{_mandir}/man8/nslookup.8*
247
248
249%files devel
250%defattr(-,root,root)
251%{_libdir}/*.so
252%{_libdir}/*.a
253%{_includedir}/*
254%{_mandir}/man3/*
255%{_mandir}/man1/isc-config.sh.1*
256%{_bindir}/isc-config.sh
257
258%changelog
259* Wed Jul 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.ESV.R7.P2-1
260- new upstream release with secrity fix (CVE-2012-3817)
261- fix permission of shared libs
262- remove .la
263
264* Tue Jun  5 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R7.P1-1
265- new upstream release with security fix (CVE-2012-1667)
266
267* Fri Nov 18 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R5.P1-1
268- new upstream release with security fix (CVE-2011-4313)
269
270* Wed Jul  6 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R4.P3-1
271- new upstream release with security fix (CVE-2011-2464)
272- use hoge(pre) tags instead of old hogepre tags
273
274* Sat May 28 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R4.P1-1
275- new upstream release with security fix (CVE-2011-1910)
276
277* Thu Mar 31 2011 IWAI, Masaharu <iwai@alib.jp> 9.6.ESV.R4-1
278- new upstream release
279
280* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.6.ESV.R2-4
281- rebuild with openssl-1.0.0c
282
283* Fri Jan 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.6.ESV.R2-3
284- rebuild package
285
286* Sun Oct 24 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R2-2
287- change spec filename bind9-vl -> bind-vl
288
289* Thu Oct  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R2-1
290- new upstream ESV release
291- add BR: libxml2-devel libcap-devel
292
293* Wed Aug 18 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R1-2
294- add Conflicts bind-current
295
296* Tue Aug 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R1-1
297- new upstream ESV release
298- add epoch 1 to upgrade from exist bind package
299
300* Thu Jan 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-2
301- add man1/isc-config.sh.1 into devel file list
302
303* Wed Jan 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-1
304- new upstream release with security fix (CVE-2009-4022, 2010-0097) 
305
306* Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P2-1
307- new upstream release with security fix (CVE-2009-4022)
308
309* Wed Jul 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P1-1
310- new upstream release with security fix
311
312* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.1-1
313- new upstream release
314- clean up %%post/%%pre scriptlet
315  - create named user and group in %%pre
316  - don't remove named user/group in %%preun
317  - use rndc-confgen to create rndc.key
318
319* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.0P1-1
320- new upstream release
321- drop patch0 and patch14, merged in upstream
322
323* Sat Jan 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.5.1P1-1
324- new upstream release with security fix
325
326* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 9.5.0P1-1
327- new upstream release with security fix
328- new versioning policy
329
330* Sun Sep 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1P1-0vl1
331- new upstream release with security fix
332
333* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1-0vl1
334- new upstream release
335- build with new openssl/toolchain
336
337* Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.4-0vl1
338- new upstream release with security fix
339
340* Fri Nov 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2P2-0vl1
341- new upstream release
342
343* Fri Sep 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl2
344- add Prereq sed
345
346* Wed Sep 06 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl1
347- new upstream release for security fix (CVE-2006-4095,4096)
348
349* Wed Feb 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 9.3.2-0vl3
350- separate -libs package
351- remove old named.conf.5.gz
352  - newer version is contained in source
353
354* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl2
355- add bsdcompat patch (Patch4)
356- add fix_h_errno patch from FC
357  - h_errno not being accessed / set correctly in libbind
358
359* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl1
360- new upstream release
361
362* Sun Nov  7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 9.2.4-0vl2
363- added PreReq to bind-utils (see: [VineSeed:09555])
364
365* Thu Oct 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.4-0vl1
366- new upstream release
367
368* Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl3
369- fix /etc/init.d/named to use rndc
370
371* Tue Nov 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl2
372- rebuild to remove unneeded dependancy
373
374* Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl1
375- new upstream release
376
377* Tue Mar  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.2-0vl1
378- new upstream release
379
380* Thu Nov 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl7
381- fix dependancies.
382
383* Wed Nov 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl6
384- add obsoletes: and conflicts: to bind9, bind9-utils, bind9-devel <= 9.2.1-0vl5
385- change package name to bind for VineSeed.
386- use more macros.
387
388* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl5
389- fixed some macros
390- add conflicts: to bind-* in bind9-devel and bind9-utils
391- add provides: bind = %%{version}
392
393* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl4
394- use %%configure macros
395
396* Sat Oct 19 2002 Michihide Hotta <hotta@net-newbie.com> 9.2.1-0vl3
397- fixed inconsistent dependency
398
399* Wed Aug 14 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl2
400- updated to 9.2.2rc1
401
402* Thu May 02 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl0
403- updated to bind9(9.2.1), test packages ;)
404        -- based on Rawhide's bind-9.2.0-8
405        -- changed name bind9
406        -- added Conflicts: bind
407
408* Sun Feb 03 2002 Toru Sagami <sagami@vinelinux.org> 8.3.1-0vl1
409- release 8.3.1 includes security fixes
410
411* Mon Jan 14 2002 Toru Sagami <sagami@vinelinux.org> 8.3.0-0vl1
412- Upgraded to current stable release 8.3.0
413
414* Mon Oct  8 2001 <zn@mbf.nifty.com>
415- 8.2.5-0vl0: Upgraded to new upstream version.
416
417* Thu May 24 2001 <sagami@vinelinux.org>
418- 8.2.4-0vl1: eliminate CVS related files from %%doc
419
420* Thu May 17 2001 <sagami@vinelinux.org>
421- 8.2.4-0vl0
422
423* Fri Feb 02 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
424- 8.2.3-1vl2
425- built on VineSeed
426
427* Tue Jan 30 2001 KAJIKI Yoshihiro <kajiki@ylug.org>
428- add doc/old
429- build for Vine 2.1
430
431* Sat Jan 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
432- 8.2.3, fixes several security problems
433
434* Tue Nov 14 2000 Bill Nottingham <notting@redhat.com>
435- static libraries may be used in shared objects. Build with -fPIC on ia64
436
437* Fri Nov 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
438- 8.2.2-P7 (fixes Bug #20546)
439
440* Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
441- condrestart fixes
442
443* Tue Jul 18 2000 Nalin Dahyabhai <nalin@redhat.com>
444- change the init script to take condrestart, not cond-restart
445- add sh-utils, /bin/cat, perl, /bin/chmod, /usr/sbin/useradd as prereqs for
446  the %pre and %post scripts
447
448* Sun Jul 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
449- Don't prereq /etc/init.d
450
451* Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
452- move initscript back
453
454* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
455- automatic rebuild
456
457* Sun Jul  9 2000 Florian La Roche <Florian.LaRoche@redhat.de>
458- add "exit 0" for uninstall case
459
460* Fri Jul  7 2000 Florian La Roche <Florian.LaRoche@redhat.de>
461- add prereq init.d and cleanup install section
462
463* Fri Jun 30 2000 Trond Eivind Glomsr <teg@redhat.com>
464- fix the init script
465
466* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
467- make libbind.a and nslookup.help readable again by setting INSTALL_LIB to ""
468
469* Mon Jun 26 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
470- Fix up the initscript (Bug #13033)
471- Fix build with current glibc (Bug #12755)
472- /etc/rc.d/init.d -> /etc/init.d
473- use %%{_mandir} rather than /usr/share/man
474
475* Mon Jun 19 2000 Bill Nottingham <notting@redhat.com>
476- fix conflict with man-pages
477- remove compatibilty chkconfig links
478- initscript munging
479
480* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
481- modify logrotate setup to use PID file
482- temporarily disable optimization by unsetting $RPM_OPT_FLAGS at build-time
483- actually bump the release this time
484
485* Sun Jun  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
486- FHS compliance
487
488* Mon Apr 17 2000 Nalin Dahyabhai <nalin@redhat.com>
489- clean up restart patch
490
491* Mon Apr 10 2000 Nalin Dahyabhai <nalin@redhat.com>
492- provide /var/named (fix for bugs #9847, #10205)
493- preserve args when restarted via ndc(8) (bug #10227)
494- make resolv.conf(5) a link to resolver(5) (bug #10245)
495- fix SYSTYPE bug in all makefiles
496- move creation of named user from %%post into %%pre
497
498* Mon Feb 28 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
499- Fix TTL (patch from ISC, Bug #9820)
500
501* Wed Feb 16 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
502- fix typo in spec (it's %post, without a leading blank) introduced in -6
503- change SYSTYPE to linux
504
505* Sat Feb 11 2000 Bill Nottingham <notting@redhat.com>
506- pick a standard < 100 uid/gid for named
507
508* Thu Feb 04 2000 Elliot Lee <sopwith@redhat.com>
509- Pass named a '-u named' parameter by default, and add/remove user.
510
511* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
512- fix host mx bug (Bug #9021)
513
514* Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
515- rebuild to fix dependencies
516- man pages are compressed
517
518* Wed Jan 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
519- It's /usr/bin/killall, not /usr/sbin/killall (Bug #8063)
520
521* Mon Jan 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
522- Fix up location of named-bootconf.pl and make it executable
523  (Bug #8028)
524- bind-devel requires bind
525
526* Mon Nov 15 1999 Bernhard Rosenkraenzer <bero@redhat.com>
527- update to 8.2.2-P5
528
529* Wed Nov 10 1999 Bill Nottingham <notting@redhat.com>
530- update to 8.2.2-P3
531
532* Tue Oct 12 1999 Cristian Gafton <gafton@redhat.com>
533- add patch to stop a cache only server from complaining about lame servers
534  on every request.
535
536* Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
537- use real stop and start in named.init for restart, not ndc restart, it has
538  problems when named has changed during a package update... (# 4890)
539
540* Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
541- chkconfig --del in %preun, not %postun
542
543* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
544- initscript munging
545
546* Mon Jul 26 1999 Bill Nottingham <notting@redhat.com>
547- fix installed chkconfig links to match init file
548
549* Sat Jul  3 1999 Jeff Johnson <jbj@redhat.com>
550- conflict with new (in man-1.24) man pages (#3876,#3877).
551
552* Tue Jun 29 1999 Bill Nottingham <notting@redhat.com>
553- fix named.logrotate (wrong %SOURCE)
554
555* Fri Jun 25 1999 Jeff Johnson <jbj@redhat.com>
556- update to 8.2.1.
557- add named.logrotate (#3571).
558- hack around egcs-1.1.2 -m486 bug (#3413, #3485).
559- vet file list.
560
561* Fri Jun 18 1999 Bill Nottingham <notting@redhat.com>
562- don't run by default
563
564* Sun May 30 1999 Jeff Johnson <jbj@redhat.com>
565- nslookup fixes (#2463).
566- missing files (#3152).
567
568* Sat May  1 1999 Stepan Kasal <kasal@math.cas.cz>
569- nslookup patched:
570  to count numRecords properly
571  to fix subsequent calls to ls -d
572  to parse "view" and "finger" commands properly
573  the view hack updated for bind-8 (using sed)
574
575* Wed Mar 31 1999 Bill Nottingham <notting@redhat.com>
576- add ISC patch
577- add quick hack to make host not crash
578- add more docs
579
580* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
581- add probing information in the init file to keep linuxconf happy
582- dont strip libbind
583
584* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
585- auto rebuild in the new build environment (release 3)
586
587* Wed Mar 17 1999 Preston Brown <pbrown@redhat.com>
588- removed 'done' output at named shutdown.
589
590* Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
591- version 8.2
592
593* Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com>
594- patch to use the __FDS_BITS macro
595- build for glibc 2.1
596
597* Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
598- change named.restart to /usr/sbin/ndc restart
599
600* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
601- install man pages correctly.
602- change K10named to K45named.
603
604* Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
605- don't start if /etc/named.conf doesn't exist.
606
607* Sat Aug  8 1998 Jeff Johnson <jbj@redhat.com>
608- autmagically create /etc/named.conf from /etc/named.boot in %post
609- remove echo in %post
610
611* Wed Jun 10 1998 Jeff Johnson <jbj@redhat.com>
612- merge in 5.1 mods
613
614* Sun Apr 12 1998 Manuel J. Galan <manolow@step.es>
615- Several essential modifications to build and install correctly.
616- Modified 'ndc' to avoid deprecated use of '-'
617
618* Mon Dec 22 1997 Scott Lampert <fortunato@heavymetal.org>
619- Used buildroot
620- patched bin/named/ns_udp.c to use <libelf/nlist.h> for include
621  on Redhat 5.0 instead of <nlist.h>
622
Note: See TracBrowser for help on using the repository browser.