source: projects/specs/trunk/b/bash/bash-vl.spec @ 8989

Revision 8989, 18.3 KB checked in by tomop, 10 years ago (diff)

bash-4.3.29-1

Line 
1%define bashversion 4.3
2%define patchlevel 29
3
4Summary:      The GNU Bourne Again shell (bash).
5Summary(ja):  GNU Bourne Again シェル (bash).
6
7Name:         bash
8Version:      %{bashversion}.%{patchlevel}
9Release:      1%{?_dist_release}
10
11Group:        System Environment/Shells
12License:      GPLv3+
13
14Vendor:       Project Vine
15Distribution: Vine Linux
16Packager:     daisuke
17
18Source0:      ftp://ftp.gnu.org/pub/gnu/bash/bash-%{bashversion}.tar.gz
19Source10:     bashrc-vine
20
21# Official upstream patches
22Patch1: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-001
23Patch2: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-002
24Patch3: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-003
25Patch4: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-004
26Patch5: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-005
27Patch6: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-006
28Patch7: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-007
29Patch8: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-008
30Patch9: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-009
31Patch10: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-010
32Patch11: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-011
33Patch12: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-012
34Patch13: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-013
35Patch14: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-014
36Patch15: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-015
37Patch16: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-016
38Patch17: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-017
39Patch18: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-018
40Patch19: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-019
41Patch20: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-020
42Patch21: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-021
43Patch22: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-022
44Patch23: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-023
45Patch24: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-024
46Patch25: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-025
47Patch26: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-026
48Patch27: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-027
49Patch28: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-028
50Patch29: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-029
51
52# Other patches
53Patch101: bash-2.02-security.patch
54Patch102: bash-2.03-paths.patch
55Patch103: bash-2.03-profile.patch
56Patch104: bash-2.05a-interpreter.patch
57Patch105: bash-2.05b-debuginfo.patch
58Patch106: bash-2.05b-manso.patch
59Patch107: bash-2.05b-pgrp_sync.patch
60Patch108: bash-2.05b-readline-oom.patch
61Patch109: bash-2.05b-xcc.patch
62Patch110: bash-3.2-audit.patch
63Patch111: bash-3.2-ssh_source_bash.patch
64Patch112: bash-bashbug.patch
65Patch113: bash-infotags.patch
66Patch114: bash-requires.patch
67Patch115: bash-setlocale.patch
68Patch116: bash-tty-tests.patch
69
70# 484809, check if interp section is NOBITS
71Patch117: bash-4.0-nobits.patch
72
73# Do the same CFLAGS in generated Makefile in examples
74Patch118: bash-4.1-examples.patch
75
76# Builtins like echo and printf won't report errors
77# when output does not succeed due to EPIPE
78Patch119: bash-4.1-broken_pipe.patch
79
80# Enable system-wide .bash_logout for login shells
81Patch120: bash-4.2-rc2-logout.patch
82
83# Static analyzis shows some issues in bash-2.05a-interpreter.patch
84Patch121: bash-4.2-coverity.patch
85
86# Don't call malloc in signal handler
87Patch122: bash-4.1-defer-sigchld-trap.patch
88
89# 799958, updated info about trap
90Patch123: bash-4.2-manpage_trap.patch
91
92# https://www.securecoding.cert.org/confluence/display/seccode/INT32-C.+Ensure+that+operations+on+signed+integers+do+not+result+in+overflow
93Patch125: bash-4.2-size_type.patch
94
95Buildroot:    %{_tmppath}/%{name}-%{version}-root
96BuildRequires: texinfo, bison, ncurses-devel, autoconf, gettext
97Obsoletes:    bash <= 1.14.7
98Obsoletes:    bash2
99
100
101%description
102Bash is a GNU project sh-compatible shell or command language
103interpreter. Bash (Bourne Again shell) incorporates useful features
104from the Korn shell (ksh) and the C shell (csh). Most sh scripts
105can be run by bash without modification.
106
107Bash offers several improvements over sh, including command line
108editing, unlimited size command history, job control, shell
109functions and aliases, indexed arrays of unlimited size and
110integer arithmetic in any base from two to 64. Bash is ultimately
111intended to conform to the IEEE POSIX P1003.2/ISO 9945.2 Shell and
112Tools standard.
113
114
115%package doc
116Summary:  Documentation for the GNU Bourne Again shell (bash).
117Summary:  GNU Bourne Again シェル向けドキュメント
118Group:    Applications/Documentation
119Requires: %{name} = %{version}-%{release}
120
121Obsoletes: bash2-doc
122
123%description doc
124This is a separate documentation package for the GNU Bourne
125Again shell.
126
127
128%prep
129%setup -q -n %{name}-%{bashversion}
130
131# Official upstream patches
132%patch1 -p0 -b .001
133%patch2 -p0 -b .002
134%patch3 -p0 -b .003
135%patch4 -p0 -b .004
136%patch5 -p0 -b .005
137%patch6 -p0 -b .006
138%patch7 -p0 -b .007
139%patch8 -p0 -b .008
140%patch9 -p0 -b .009
141%patch10 -p0 -b .010
142%patch11 -p0 -b .011
143%patch12 -p0 -b .012
144%patch13 -p0 -b .013
145%patch14 -p0 -b .014
146%patch15 -p0 -b .015
147%patch16 -p0 -b .016
148%patch17 -p0 -b .017
149%patch18 -p0 -b .018
150%patch19 -p0 -b .019
151%patch20 -p0 -b .020
152%patch21 -p0 -b .021
153%patch22 -p0 -b .022
154%patch23 -p0 -b .023
155%patch24 -p0 -b .024
156%patch25 -p0 -b .025
157%patch26 -p0 -b .026
158%patch27 -p0 -b .027
159%patch28 -p0 -b .028
160%patch29 -p0 -b .029
161
162# Other patches
163%patch101 -p1 -b .security
164%patch102 -p1 -b .paths
165%patch103 -p1 -b .profile
166%patch104 -p1 -b .interpreter
167%patch105 -p1 -b .debuginfo
168%patch106 -p1 -b .manso
169%patch107 -p1 -b .pgrp_sync
170%patch108 -p1 -b .readline_oom
171%patch109 -p1 -b .xcc
172%patch110 -p1 -b .audit
173%patch111 -p1 -b .ssh_source_bash
174%patch112 -p1 -b .bashbug
175%patch113 -p1 -b .infotags
176%patch114 -p1 -b .requires
177%patch115 -p1 -b .setlocale
178%patch116 -p1 -b .tty_tests
179%patch117 -p1 -b .nobits
180%patch118 -p1 -b .examples
181%patch119 -p1 -b .broken_pipe
182%patch120 -p1 -b .logout
183%patch121 -p1 -b .coverity
184%patch122 -p1 -b .defer_sigchld_trap
185%patch123 -p1
186%patch125 -p1 -b .size_type
187
188echo %{version} > _distribution
189echo %{release} |sed 's/vl.*//' > _patchlevel
190
191
192%build
193%configure --with-bash-malloc=no
194make CPPFLAGS="-D_GNU_SOURCE -DRECYCLES_PIDS `getconf LFS_CFLAGS`"
195
196%install
197rm -rf %{buildroot}
198
199# Fix bug #83776
200perl -pi -e 's,bashref\.info,bash.info,' doc/bashref.info
201
202make DESTDIR=$RPM_BUILD_ROOT install
203
204pushd $RPM_BUILD_ROOT
205 mkdir ./bin
206 mv ./usr/bin/bash ./bin/bash
207 ln -s bash ./bin/sh
208 rm -f .%{_infodir}/dir
209popd
210
211ln -s bash.1 %{buildroot}%{_mandir}/man1/sh.1
212
213# make manpages for bash builtins as per suggestion in DOC/README
214pushd doc
215sed -e '
216/^\.SH NAME/, /\\- bash built-in commands, see \\fBbash\\fR(1)$/{
217/^\.SH NAME/d
218s/^bash, //
219s/\\- bash built-in commands, see \\fBbash\\fR(1)$//
220s/,//g
221b
222}
223d
224' builtins.1 > man.pages
225for i in echo pwd test kill; do
226  perl -pi -e "s,$i,,g" man.pages
227  perl -pi -e "s,  , ,g" man.pages
228done
229
230install -c -m 644 builtins.1 %{buildroot}%{_mandir}/man1/builtins.1
231
232for i in `cat man.pages` ; do
233  echo .so man1/builtins.1 > %{buildroot}%{_mandir}/man1/$i.1
234  chmod 0644 ${RPM_BUILD_ROOT}%{_mandir}/man1/$i.1
235done
236
237mkdir -p $RPM_BUILD_ROOT/etc/profile.d/
238install -m 644 %{SOURCE10} $RPM_BUILD_ROOT/etc/bashrc
239
240# Not for printf, false and true (conflict with coreutils)
241rm -f $RPM_BUILD_ROOT%{_mandir}/man1/printf.1
242rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/true.1
243rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/false.1
244
245popd
246
247%find_lang %{name}
248
249rm -rf $RPM_BUILD_ROOT/%{_docdir}/bash
250
251%clean
252rm -rf %{buildroot}
253
254# ***** bash doesn't use install-info. It's always listed in %{_infodir}/dir
255# to prevent prereq loops
256
257# post is in lua so that we can run it without any external deps.  Helps
258# for bootstrapping a new install.
259# Jesse Keating 2009-01-29 (code from Ignacio Vazquez-Abrams)
260%post -p <lua>
261bashfound = false;
262shfound = false;
263 
264f = io.open("/etc/shells", "r");
265if f == nil
266then
267  f = io.open("/etc/shells", "w");
268else
269  repeat
270    t = f:read();
271    if t == "/bin/bash"
272    then
273      bashfound = true;
274    end
275    if t == "/bin/sh"
276    then
277      shfound = true;
278    end
279  until t == nil;
280end
281f:close()
282 
283f = io.open("/etc/shells", "a");
284if not bashfound
285then
286  f:write("/bin/bash\n")
287end
288if not shfound
289then
290  f:write("/bin/sh\n")
291end
292f:close()
293
294%files -f %{name}.lang
295%defattr(-,root,root)
296%doc CHANGES COPYING
297%doc examples
298%config(noreplace) /etc/bashrc
299/bin/bash
300/bin/sh
301%{_infodir}/bash.info*
302%{_mandir}/*/*
303%{_mandir}/*/..1*
304%{_bindir}/bashbug
305
306
307%files doc
308%defattr(-,root,root)
309%doc COMPAT NEWS NOTES POSIX RBASH
310%doc examples/functions/ examples/misc/
311%doc examples/scripts.noah/ examples/scripts.v2/ examples/scripts/
312%doc examples/startup-files/ examples/complete/ examples/loadables/
313%doc doc/*.ps doc/*.0 doc/*.html doc/article.txt
314%doc doc/FAQ doc/INTRO doc/article.ms doc/README
315
316
317%changelog
318* Fri Oct 3 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.29-1
319- updated to 4.3 patch level 29
320- removed patch1000 (included in 4.3.26).
321
322* Thu Sep 25 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.25-2
323- added patch1000 to fix CVE-2014-7169.
324
325* Thu Sep 25 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.25-1
326- updated to 4.3 patch level 25
327
328* Tue Jun 10 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3.18-1
329- update to 4.3 patch level 18
330
331* Wed May 14 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3.11-1
332- update to 4.3 patch level 11
333
334* Mon Mar 18 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.45-1
335- update to 4.2 patch level 45
336- import some patch from fedora package (122-127)
337  - patch122: Don't call malloc in signal handler
338  - patch123: #799958, updated info about trap
339  - patch124: #695656, block the signal and unblock it after the
340    new handler is installed
341  - patch125: Use unsigned type for size
342    https://www.securecoding.cert.org/confluence/display/seccode/INT32-C.+Ensure+that+operations+on+signed+integers+do+not+result+in+overflow
343  - patch126: #903833, Fix missing close(), fixes fd leaks
344
345* Sat Oct  6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.2.37-2
346- remove postun lua script because bash will be never uninstalled
347
348* Mon Sep 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.37-1
349- update to 4.2 patch level 37
350
351* Fri Feb 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.20-1
352- update to 4.2 patch level 20
353
354* Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.8-1
355- update to 4.2 patch level 8
356- use lua script in post/postun
357- update patches from fedora
358
359* Fri Sep 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1-1
360- update to 4.1 patch level 7
361
362* Fri Mar  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-9
363- check if /bin/grep exists on %%post script
364
365* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-8
366- rebuilt with gcc-4.4.3-3 on ppc
367
368* Tue Feb  2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-7
369- rebuilt with new toolchain
370
371* Fri Dec  4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-6
372- revert changes on 3.2-5 (avoid a nasty dependency loop on bootstrapping)
373
374* Fri Dec  4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-5
375- add Requires(post): grep
376
377* Sat Oct 24 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-4
378- remove obsolete /bin/bash2 entry from /etc/shells
379
380* Mon Apr 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-3
381- add Requires(post): ncurses (should be added by find-requires..)
382
383* Sun Mar 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-2
384- add upstream patch (from 040 to 048)
385- build against ncurses-devel (libtinfo)
386- spec in utf-8
387
388* Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2-1vl5
389- added upstream patch (from 026 to 039)
390- added Japanese summary
391- applied new versioning policy
392
393* Fri Jan 18 2008 Shu KONNO <owa@bg.wakwak.com> 3.2-0vl2
394- rebuilt with libtermcap-devel
395
396* Fri Oct 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-0vl1
397- new upstream release
398- add upstream patch (from 001 to 025)
399- remove Provides: bash2
400
401* Wed May 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.05b-0vl4
402- rebuilt with new toolchain
403
404* Mon Sep 11 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.05b-0vl3
405- change doc Group to Applications/Documentation. <BTS:VineLinux:163>
406- quote CPPFLAGS to avoid configure error. <BTS:VineLinux:173>
407
408* Mon Jun 28 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.05b-0vl2
409- Don't read /etc/profile.d/*.sh in /etc/bashrc; done in /etc/profile
410
411* Wed Mar 10 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.05b-0vl1
412- update to 2.05b
413- rebuild with new toolchains
414- add make check
415- add %postun script based on Fedora development
416- README file moved doc package
417- update Patch5 and Patch8 from Fedora development
418- change Patch6
419- remove Patch2 and Patch100 (bash-2.05b supports multibyte string)
420- add Patch11--39 from Fedora development 2.05b-36
421  * Tim Waugh <twaugh@redhat.com>
422  - Fix parameter expansion in multibyte locales (bug #112657).
423  - Speed up UTF-8 command-line redrawing in the common case (bug #102353,
424    bug #110777).
425  - Apply upstream patches (bug #109269 among others).
426  - Fix bash.info (bug #83776).
427  - Add bash205b-007 patch to fix bug #106876.
428  - Avoid crashing on multibyte input when locale is set incorrectly
429    (bug #74266).
430  - LFS support (bug #103627).
431  - Fix completion display when multibyte or control characters are to be
432    shown (bug #90201).
433  - Fix a warning message (bug #79629).
434  - Don't build with AFS support (bug #86514).
435  - Don't explicitly strip binaries (bug #85995).
436  - Really fix bug #83331 for good.
437  - Fix builtins.1.
438  - Actually apply the patch (bug #83331).
439  - Fix history/UTF-8 bug (bug #83331).
440  - More tab-completion fixing (bug #72512).
441  - Force pgrp synchronization (bug #81653).
442  - Prevent prompt overwriting output (bug #74383).
443  - Fix '-rbash' (bug #78455).
444  - Add readline-init patch (bug #74925).
445  - Add the (4) patches from ftp.gnu.org (bug #75888, bug #72512).
446  - Ship '.' man page, which doesn't get picked up by glob.
447  - Locale shell variables fix (bug #74701).
448  * Elliot Lee <sopwith@redhat.com>
449  - (patch26) Don't call 'size' in makefile. Pointless, and interferes with
450    cross compiles.
451
452* Wed Oct  9 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.05-0vl1
453- update to 2.05
454- add README.jpatch to %doc
455- remove patch4 (bash2): revert command name in man pages to "bash"
456  - fix perl command to remove man pages conflict with sh-utils
457- remove section of config.h.in from patch0 to prevent remake of configure
458- change patch9: define in config-top.h to avoid conflict with patch100
459- remove patches 7, 10 & 101
460
461* Mon Apr  8 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.04-1vl14
462- made a link for man sh
463
464* Thu Nov 15 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.04-1vl13
465- added missing %%post and %%triggerpostun section
466
467* Sun Jul 15 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
468- 2.04-1vl12
469- now bash2 is finally bash
470
471* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.04-1vl11
472- build for Playstation2
473
474* Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
475- 2.04-1vl10
476- Provides: bash = %%{version}
477
478* Thu Jun 07 2001 Satoshi MACHINO  <machino@vinelinux.org> 2.04-1vl9
479- added Provides: bash
480
481* Thu Jun 07 2001 Satoshi MACHINO  <machino@vinelinux.org> 2.04-1vl8
482- Obsoletes: bash
483- changed Copyright to License
484
485* Fri Dec 29 2000 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
486- 2.04-1vl7
487- deleted: /etc/profile.d/alias.sh (which we have in /etc/skel/.bashrc)
488- corrected: bashrc-vine -> bashrc
489
490* Sat Dec 16 2000 Satoshi MACHINO  <machino@vinelinux.org> 2.04-1vl6
491- combined bash-1.x and bash-2.x packages
492- added some patches from bash-2.04-13mdk
493
494* Sun Dec 10 2000 Jun Nishii <jun@vinelinux.org> 2.04-1vl5
495- fix spec macros
496- added tests
497
498* Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl5
499- build with gcc-2.95.3
500- partially used rpmmacros
501
502* Fri Sep  8 2000 Jun Nishii <jun@vinelinux.org>
503- minor bug fix in spec file
504
505* Sun Aug 27 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
506- 2.04-1vl3
507- modified %install and %files section to handle compressed man page(s)
508
509* Thu Mar 23 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
510- added pcomplete patch to fix complete if the candidate list is NULL.
511
512* Wed Mar 22 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
513- updated to 2.04
514
515* Tue Sep 14 1999 Dale Lovelace <dale@redhat.com>
516- Remove annoying ^H's from documentation
517
518* Fri Jul 16 1999 Ken Estes <kestes@staff.mail.com>
519- patch to detect what executables are required by a script.
520
521* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
522- auto rebuild in the new build environment (release 4)
523
524* Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
525- strip binaries.
526- include bash-doc correctly.
527
528* Thu Mar 18 1999 Preston Brown <pbrown@redhat.com>
529- fixed post/postun /etc/shells work.
530
531* Thu Mar 18 1999 Cristian Gafton <gafton@redhat.com>
532- updated again text in the spec file
533
534* Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
535- updated text in spec file.
536- update to 2.03.
537
538* Fri Feb 12 1999 Cristian Gafton <gafton@redhat.com>
539- build it as bash2 instead of bash
540
541* Tue Feb  9 1999 Bill Nottingham <notting@redhat.com>
542- set 'NON_INTERACTIVE_LOGIN_SHELLS' so profile gets read
543
544* Thu Jan 14 1999 Jeff Johnson <jbj@redhat.com>
545- rename man pages in bash-doc to avoid packaging conflicts (#606).
546
547* Wed Dec 02 1998 Cristian Gafton <gafton@redhat.com>
548- patch for the arm
549- use $RPM_ARCH-redhat-linux as the build target
550
551* Tue Oct  6 1998 Bill Nottingham <notting@redhat.com>
552- rewrite %pre, axe %postun (to avoid prereq loops)
553
554* Wed Aug 19 1998 Jeff Johnson <jbj@redhat.com>
555- resurrect for RH 6.0.
556
557* Sun Jul 26 1998 Jeff Johnson <jbj@redhat.com>
558- update to 2.02.1
559
560* Thu Jun 11 1998 Jeff Johnson <jbj@redhat.com>
561- Package for 5.2.
562
563* Mon Apr 20 1998 Ian Macdonald <ianmacd@xs4all.nl>
564- added POSIX.NOTES doc file
565- some extraneous doc files removed
566- minor .spec file changes
567
568* Sun Apr 19 1998 Ian Macdonald <ianmacd@xs4all.nl>
569- upgraded to version 2.02
570- Alpha, MIPS & Sparc patches removed due to lack of test platforms
571- glibc & signal patches no longer required
572- added documentation subpackage (doc)
573
574* Fri Nov 07 1997 Donnie Barnes <djb@redhat.com>
575- added signal handling patch from Dean Gaudet <dgaudet@arctic.org> that
576  is based on a change made in bash 2.0.  Should fix some early exit
577  problems with suspends and fg.
578
579* Mon Oct 20 1997 Donnie Barnes <djb@redhat.com>
580- added %clean
581
582* Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
583- added comment explaining why install-info isn't used
584- added mips patch
585
586* Fri Oct 17 1997 Donnie Barnes <djb@redhat.com>
587- added BuildRoot
588
589* Tue Jun 03 1997 Erik Troan <ewt@redhat.com>
590- built against glibc
Note: See TracBrowser for help on using the repository browser.