source: projects/specs/trunk/b/bash/bash-vl.spec @ 8970

Revision 8970, 18.0 KB checked in by tomop, 10 years ago (diff)

bash-4.3.25-2

Line 
1%define bashversion 4.3
2%define patchlevel 25
3
4Summary:      The GNU Bourne Again shell (bash).
5Summary(ja):  GNU Bourne Again シェル (bash).
6
7Name:         bash
8Version:      %{bashversion}.%{patchlevel}
9Release:      2%{?_dist_release}
10
11Group:        System Environment/Shells
12License:      GPLv3+
13
14Vendor:       Project Vine
15Distribution: Vine Linux
16Packager:     daisuke
17
18Source0:      ftp://ftp.gnu.org/pub/gnu/bash/bash-%{bashversion}.tar.gz
19Source10:     bashrc-vine
20
21# Official upstream patches
22Patch1: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-001
23Patch2: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-002
24Patch3: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-003
25Patch4: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-004
26Patch5: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-005
27Patch6: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-006
28Patch7: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-007
29Patch8: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-008
30Patch9: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-009
31Patch10: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-010
32Patch11: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-011
33Patch12: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-012
34Patch13: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-013
35Patch14: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-014
36Patch15: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-015
37Patch16: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-016
38Patch17: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-017
39Patch18: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-018
40Patch19: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-019
41Patch20: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-020
42Patch21: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-021
43Patch22: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-022
44Patch23: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-023
45Patch24: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-024
46Patch25: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-025
47
48# Other patches
49Patch101: bash-2.02-security.patch
50Patch102: bash-2.03-paths.patch
51Patch103: bash-2.03-profile.patch
52Patch104: bash-2.05a-interpreter.patch
53Patch105: bash-2.05b-debuginfo.patch
54Patch106: bash-2.05b-manso.patch
55Patch107: bash-2.05b-pgrp_sync.patch
56Patch108: bash-2.05b-readline-oom.patch
57Patch109: bash-2.05b-xcc.patch
58Patch110: bash-3.2-audit.patch
59Patch111: bash-3.2-ssh_source_bash.patch
60Patch112: bash-bashbug.patch
61Patch113: bash-infotags.patch
62Patch114: bash-requires.patch
63Patch115: bash-setlocale.patch
64Patch116: bash-tty-tests.patch
65
66# 484809, check if interp section is NOBITS
67Patch117: bash-4.0-nobits.patch
68
69# Do the same CFLAGS in generated Makefile in examples
70Patch118: bash-4.1-examples.patch
71
72# Builtins like echo and printf won't report errors
73# when output does not succeed due to EPIPE
74Patch119: bash-4.1-broken_pipe.patch
75
76# Enable system-wide .bash_logout for login shells
77Patch120: bash-4.2-rc2-logout.patch
78
79# Static analyzis shows some issues in bash-2.05a-interpreter.patch
80Patch121: bash-4.2-coverity.patch
81
82# Don't call malloc in signal handler
83Patch122: bash-4.1-defer-sigchld-trap.patch
84
85# 799958, updated info about trap
86Patch123: bash-4.2-manpage_trap.patch
87
88# https://www.securecoding.cert.org/confluence/display/seccode/INT32-C.+Ensure+that+operations+on+signed+integers+do+not+result+in+overflow
89Patch125: bash-4.2-size_type.patch
90
91# CVE-2014-7169
92#  http://www.openwall.com/lists/oss-security/2014/09/25/10
93Patch1000: bash-eol-pushback.patch
94
95Buildroot:    %{_tmppath}/%{name}-%{version}-root
96BuildRequires: texinfo, bison, ncurses-devel, autoconf, gettext
97Obsoletes:    bash <= 1.14.7
98Obsoletes:    bash2
99
100
101%description
102Bash is a GNU project sh-compatible shell or command language
103interpreter. Bash (Bourne Again shell) incorporates useful features
104from the Korn shell (ksh) and the C shell (csh). Most sh scripts
105can be run by bash without modification.
106
107Bash offers several improvements over sh, including command line
108editing, unlimited size command history, job control, shell
109functions and aliases, indexed arrays of unlimited size and
110integer arithmetic in any base from two to 64. Bash is ultimately
111intended to conform to the IEEE POSIX P1003.2/ISO 9945.2 Shell and
112Tools standard.
113
114
115%package doc
116Summary:  Documentation for the GNU Bourne Again shell (bash).
117Summary:  GNU Bourne Again シェル向けドキュメント
118Group:    Applications/Documentation
119Requires: %{name} = %{version}-%{release}
120
121Obsoletes: bash2-doc
122
123%description doc
124This is a separate documentation package for the GNU Bourne
125Again shell.
126
127
128%prep
129%setup -q -n %{name}-%{bashversion}
130
131# Official upstream patches
132%patch1 -p0 -b .001
133%patch2 -p0 -b .002
134%patch3 -p0 -b .003
135%patch4 -p0 -b .004
136%patch5 -p0 -b .005
137%patch6 -p0 -b .006
138%patch7 -p0 -b .007
139%patch8 -p0 -b .008
140%patch9 -p0 -b .009
141%patch10 -p0 -b .010
142%patch11 -p0 -b .011
143%patch12 -p0 -b .012
144%patch13 -p0 -b .013
145%patch14 -p0 -b .014
146%patch15 -p0 -b .015
147%patch16 -p0 -b .016
148%patch17 -p0 -b .017
149%patch18 -p0 -b .018
150%patch19 -p0 -b .019
151%patch20 -p0 -b .020
152%patch21 -p0 -b .021
153%patch22 -p0 -b .022
154%patch23 -p0 -b .023
155%patch24 -p0 -b .024
156%patch25 -p0 -b .025
157
158# Other patches
159%patch101 -p1 -b .security
160%patch102 -p1 -b .paths
161%patch103 -p1 -b .profile
162%patch104 -p1 -b .interpreter
163%patch105 -p1 -b .debuginfo
164%patch106 -p1 -b .manso
165%patch107 -p1 -b .pgrp_sync
166%patch108 -p1 -b .readline_oom
167%patch109 -p1 -b .xcc
168%patch110 -p1 -b .audit
169%patch111 -p1 -b .ssh_source_bash
170%patch112 -p1 -b .bashbug
171%patch113 -p1 -b .infotags
172%patch114 -p1 -b .requires
173%patch115 -p1 -b .setlocale
174%patch116 -p1 -b .tty_tests
175%patch117 -p1 -b .nobits
176%patch118 -p1 -b .examples
177%patch119 -p1 -b .broken_pipe
178%patch120 -p1 -b .logout
179%patch121 -p1 -b .coverity
180%patch122 -p1 -b .defer_sigchld_trap
181%patch123 -p1
182%patch125 -p1 -b .size_type
183
184%patch1000 -p0 -b .CVE-2014-7169
185
186echo %{version} > _distribution
187echo %{release} |sed 's/vl.*//' > _patchlevel
188
189
190%build
191%configure --with-bash-malloc=no
192make CPPFLAGS="-D_GNU_SOURCE -DRECYCLES_PIDS `getconf LFS_CFLAGS`"
193
194%install
195rm -rf %{buildroot}
196
197# Fix bug #83776
198perl -pi -e 's,bashref\.info,bash.info,' doc/bashref.info
199
200make DESTDIR=$RPM_BUILD_ROOT install
201
202pushd $RPM_BUILD_ROOT
203 mkdir ./bin
204 mv ./usr/bin/bash ./bin/bash
205 ln -s bash ./bin/sh
206 rm -f .%{_infodir}/dir
207popd
208
209ln -s bash.1 %{buildroot}%{_mandir}/man1/sh.1
210
211# make manpages for bash builtins as per suggestion in DOC/README
212pushd doc
213sed -e '
214/^\.SH NAME/, /\\- bash built-in commands, see \\fBbash\\fR(1)$/{
215/^\.SH NAME/d
216s/^bash, //
217s/\\- bash built-in commands, see \\fBbash\\fR(1)$//
218s/,//g
219b
220}
221d
222' builtins.1 > man.pages
223for i in echo pwd test kill; do
224  perl -pi -e "s,$i,,g" man.pages
225  perl -pi -e "s,  , ,g" man.pages
226done
227
228install -c -m 644 builtins.1 %{buildroot}%{_mandir}/man1/builtins.1
229
230for i in `cat man.pages` ; do
231  echo .so man1/builtins.1 > %{buildroot}%{_mandir}/man1/$i.1
232  chmod 0644 ${RPM_BUILD_ROOT}%{_mandir}/man1/$i.1
233done
234
235mkdir -p $RPM_BUILD_ROOT/etc/profile.d/
236install -m 644 %{SOURCE10} $RPM_BUILD_ROOT/etc/bashrc
237
238# Not for printf, false and true (conflict with coreutils)
239rm -f $RPM_BUILD_ROOT%{_mandir}/man1/printf.1
240rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/true.1
241rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/false.1
242
243popd
244
245%find_lang %{name}
246
247rm -rf $RPM_BUILD_ROOT/%{_docdir}/bash
248
249%clean
250rm -rf %{buildroot}
251
252# ***** bash doesn't use install-info. It's always listed in %{_infodir}/dir
253# to prevent prereq loops
254
255# post is in lua so that we can run it without any external deps.  Helps
256# for bootstrapping a new install.
257# Jesse Keating 2009-01-29 (code from Ignacio Vazquez-Abrams)
258%post -p <lua>
259bashfound = false;
260shfound = false;
261 
262f = io.open("/etc/shells", "r");
263if f == nil
264then
265  f = io.open("/etc/shells", "w");
266else
267  repeat
268    t = f:read();
269    if t == "/bin/bash"
270    then
271      bashfound = true;
272    end
273    if t == "/bin/sh"
274    then
275      shfound = true;
276    end
277  until t == nil;
278end
279f:close()
280 
281f = io.open("/etc/shells", "a");
282if not bashfound
283then
284  f:write("/bin/bash\n")
285end
286if not shfound
287then
288  f:write("/bin/sh\n")
289end
290f:close()
291
292%files -f %{name}.lang
293%defattr(-,root,root)
294%doc CHANGES COPYING
295%doc examples
296%config(noreplace) /etc/bashrc
297/bin/bash
298/bin/sh
299%{_infodir}/bash.info*
300%{_mandir}/*/*
301%{_mandir}/*/..1*
302%{_bindir}/bashbug
303
304
305%files doc
306%defattr(-,root,root)
307%doc COMPAT NEWS NOTES POSIX RBASH
308%doc examples/functions/ examples/misc/
309%doc examples/scripts.noah/ examples/scripts.v2/ examples/scripts/
310%doc examples/startup-files/ examples/complete/ examples/loadables/
311%doc doc/*.ps doc/*.0 doc/*.html doc/article.txt
312%doc doc/FAQ doc/INTRO doc/article.ms doc/README
313
314
315%changelog
316* Thu Sep 25 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.25-2
317- added patch1000 to fix CVE-2014-7169.
318
319* Thu Sep 25 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.25-1
320- updated to 4.3 patch level 25
321
322* Tue Jun 10 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3.18-1
323- update to 4.3 patch level 18
324
325* Wed May 14 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3.11-1
326- update to 4.3 patch level 11
327
328* Mon Mar 18 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.45-1
329- update to 4.2 patch level 45
330- import some patch from fedora package (122-127)
331  - patch122: Don't call malloc in signal handler
332  - patch123: #799958, updated info about trap
333  - patch124: #695656, block the signal and unblock it after the
334    new handler is installed
335  - patch125: Use unsigned type for size
336    https://www.securecoding.cert.org/confluence/display/seccode/INT32-C.+Ensure+that+operations+on+signed+integers+do+not+result+in+overflow
337  - patch126: #903833, Fix missing close(), fixes fd leaks
338
339* Sat Oct  6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.2.37-2
340- remove postun lua script because bash will be never uninstalled
341
342* Mon Sep 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.37-1
343- update to 4.2 patch level 37
344
345* Fri Feb 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.20-1
346- update to 4.2 patch level 20
347
348* Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.8-1
349- update to 4.2 patch level 8
350- use lua script in post/postun
351- update patches from fedora
352
353* Fri Sep 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1-1
354- update to 4.1 patch level 7
355
356* Fri Mar  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-9
357- check if /bin/grep exists on %%post script
358
359* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-8
360- rebuilt with gcc-4.4.3-3 on ppc
361
362* Tue Feb  2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-7
363- rebuilt with new toolchain
364
365* Fri Dec  4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-6
366- revert changes on 3.2-5 (avoid a nasty dependency loop on bootstrapping)
367
368* Fri Dec  4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-5
369- add Requires(post): grep
370
371* Sat Oct 24 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-4
372- remove obsolete /bin/bash2 entry from /etc/shells
373
374* Mon Apr 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-3
375- add Requires(post): ncurses (should be added by find-requires..)
376
377* Sun Mar 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-2
378- add upstream patch (from 040 to 048)
379- build against ncurses-devel (libtinfo)
380- spec in utf-8
381
382* Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2-1vl5
383- added upstream patch (from 026 to 039)
384- added Japanese summary
385- applied new versioning policy
386
387* Fri Jan 18 2008 Shu KONNO <owa@bg.wakwak.com> 3.2-0vl2
388- rebuilt with libtermcap-devel
389
390* Fri Oct 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-0vl1
391- new upstream release
392- add upstream patch (from 001 to 025)
393- remove Provides: bash2
394
395* Wed May 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.05b-0vl4
396- rebuilt with new toolchain
397
398* Mon Sep 11 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.05b-0vl3
399- change doc Group to Applications/Documentation. <BTS:VineLinux:163>
400- quote CPPFLAGS to avoid configure error. <BTS:VineLinux:173>
401
402* Mon Jun 28 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.05b-0vl2
403- Don't read /etc/profile.d/*.sh in /etc/bashrc; done in /etc/profile
404
405* Wed Mar 10 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.05b-0vl1
406- update to 2.05b
407- rebuild with new toolchains
408- add make check
409- add %postun script based on Fedora development
410- README file moved doc package
411- update Patch5 and Patch8 from Fedora development
412- change Patch6
413- remove Patch2 and Patch100 (bash-2.05b supports multibyte string)
414- add Patch11--39 from Fedora development 2.05b-36
415  * Tim Waugh <twaugh@redhat.com>
416  - Fix parameter expansion in multibyte locales (bug #112657).
417  - Speed up UTF-8 command-line redrawing in the common case (bug #102353,
418    bug #110777).
419  - Apply upstream patches (bug #109269 among others).
420  - Fix bash.info (bug #83776).
421  - Add bash205b-007 patch to fix bug #106876.
422  - Avoid crashing on multibyte input when locale is set incorrectly
423    (bug #74266).
424  - LFS support (bug #103627).
425  - Fix completion display when multibyte or control characters are to be
426    shown (bug #90201).
427  - Fix a warning message (bug #79629).
428  - Don't build with AFS support (bug #86514).
429  - Don't explicitly strip binaries (bug #85995).
430  - Really fix bug #83331 for good.
431  - Fix builtins.1.
432  - Actually apply the patch (bug #83331).
433  - Fix history/UTF-8 bug (bug #83331).
434  - More tab-completion fixing (bug #72512).
435  - Force pgrp synchronization (bug #81653).
436  - Prevent prompt overwriting output (bug #74383).
437  - Fix '-rbash' (bug #78455).
438  - Add readline-init patch (bug #74925).
439  - Add the (4) patches from ftp.gnu.org (bug #75888, bug #72512).
440  - Ship '.' man page, which doesn't get picked up by glob.
441  - Locale shell variables fix (bug #74701).
442  * Elliot Lee <sopwith@redhat.com>
443  - (patch26) Don't call 'size' in makefile. Pointless, and interferes with
444    cross compiles.
445
446* Wed Oct  9 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.05-0vl1
447- update to 2.05
448- add README.jpatch to %doc
449- remove patch4 (bash2): revert command name in man pages to "bash"
450  - fix perl command to remove man pages conflict with sh-utils
451- remove section of config.h.in from patch0 to prevent remake of configure
452- change patch9: define in config-top.h to avoid conflict with patch100
453- remove patches 7, 10 & 101
454
455* Mon Apr  8 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.04-1vl14
456- made a link for man sh
457
458* Thu Nov 15 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.04-1vl13
459- added missing %%post and %%triggerpostun section
460
461* Sun Jul 15 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
462- 2.04-1vl12
463- now bash2 is finally bash
464
465* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.04-1vl11
466- build for Playstation2
467
468* Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
469- 2.04-1vl10
470- Provides: bash = %%{version}
471
472* Thu Jun 07 2001 Satoshi MACHINO  <machino@vinelinux.org> 2.04-1vl9
473- added Provides: bash
474
475* Thu Jun 07 2001 Satoshi MACHINO  <machino@vinelinux.org> 2.04-1vl8
476- Obsoletes: bash
477- changed Copyright to License
478
479* Fri Dec 29 2000 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
480- 2.04-1vl7
481- deleted: /etc/profile.d/alias.sh (which we have in /etc/skel/.bashrc)
482- corrected: bashrc-vine -> bashrc
483
484* Sat Dec 16 2000 Satoshi MACHINO  <machino@vinelinux.org> 2.04-1vl6
485- combined bash-1.x and bash-2.x packages
486- added some patches from bash-2.04-13mdk
487
488* Sun Dec 10 2000 Jun Nishii <jun@vinelinux.org> 2.04-1vl5
489- fix spec macros
490- added tests
491
492* Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl5
493- build with gcc-2.95.3
494- partially used rpmmacros
495
496* Fri Sep  8 2000 Jun Nishii <jun@vinelinux.org>
497- minor bug fix in spec file
498
499* Sun Aug 27 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
500- 2.04-1vl3
501- modified %install and %files section to handle compressed man page(s)
502
503* Thu Mar 23 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
504- added pcomplete patch to fix complete if the candidate list is NULL.
505
506* Wed Mar 22 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
507- updated to 2.04
508
509* Tue Sep 14 1999 Dale Lovelace <dale@redhat.com>
510- Remove annoying ^H's from documentation
511
512* Fri Jul 16 1999 Ken Estes <kestes@staff.mail.com>
513- patch to detect what executables are required by a script.
514
515* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
516- auto rebuild in the new build environment (release 4)
517
518* Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
519- strip binaries.
520- include bash-doc correctly.
521
522* Thu Mar 18 1999 Preston Brown <pbrown@redhat.com>
523- fixed post/postun /etc/shells work.
524
525* Thu Mar 18 1999 Cristian Gafton <gafton@redhat.com>
526- updated again text in the spec file
527
528* Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
529- updated text in spec file.
530- update to 2.03.
531
532* Fri Feb 12 1999 Cristian Gafton <gafton@redhat.com>
533- build it as bash2 instead of bash
534
535* Tue Feb  9 1999 Bill Nottingham <notting@redhat.com>
536- set 'NON_INTERACTIVE_LOGIN_SHELLS' so profile gets read
537
538* Thu Jan 14 1999 Jeff Johnson <jbj@redhat.com>
539- rename man pages in bash-doc to avoid packaging conflicts (#606).
540
541* Wed Dec 02 1998 Cristian Gafton <gafton@redhat.com>
542- patch for the arm
543- use $RPM_ARCH-redhat-linux as the build target
544
545* Tue Oct  6 1998 Bill Nottingham <notting@redhat.com>
546- rewrite %pre, axe %postun (to avoid prereq loops)
547
548* Wed Aug 19 1998 Jeff Johnson <jbj@redhat.com>
549- resurrect for RH 6.0.
550
551* Sun Jul 26 1998 Jeff Johnson <jbj@redhat.com>
552- update to 2.02.1
553
554* Thu Jun 11 1998 Jeff Johnson <jbj@redhat.com>
555- Package for 5.2.
556
557* Mon Apr 20 1998 Ian Macdonald <ianmacd@xs4all.nl>
558- added POSIX.NOTES doc file
559- some extraneous doc files removed
560- minor .spec file changes
561
562* Sun Apr 19 1998 Ian Macdonald <ianmacd@xs4all.nl>
563- upgraded to version 2.02
564- Alpha, MIPS & Sparc patches removed due to lack of test platforms
565- glibc & signal patches no longer required
566- added documentation subpackage (doc)
567
568* Fri Nov 07 1997 Donnie Barnes <djb@redhat.com>
569- added signal handling patch from Dean Gaudet <dgaudet@arctic.org> that
570  is based on a change made in bash 2.0.  Should fix some early exit
571  problems with suspends and fg.
572
573* Mon Oct 20 1997 Donnie Barnes <djb@redhat.com>
574- added %clean
575
576* Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
577- added comment explaining why install-info isn't used
578- added mips patch
579
580* Fri Oct 17 1997 Donnie Barnes <djb@redhat.com>
581- added BuildRoot
582
583* Tue Jun 03 1997 Erik Troan <ewt@redhat.com>
584- built against glibc
Note: See TracBrowser for help on using the repository browser.