source: projects/specs/trunk/b/bash/bash-vl.spec @ 12490

Revision 12490, 18.8 KB checked in by tomop, 4 years ago (diff)

updated 3 packages

bash-5.0.18-1

bison-3.7.2-1

readline-8.0.4-1

Line 
1%define bashversion 5.0
2%define patchlevel 18
3
4Summary:      The GNU Bourne Again shell (bash).
5Summary(ja):  GNU Bourne Again シェル (bash).
6Name:         bash
7Version:      %{bashversion}.%{patchlevel}
8Release:      1%{?_dist_release}
9Group:        system
10Vendor:       Project Vine
11Distribution: Vine Linux
12Packager:     daisuke
13
14License:      GPLv3+
15Source0:      http://ftp.gnu.org/pub/gnu/bash/bash-%{bashversion}.tar.gz
16Source10:     bashrc-vine
17
18# Official upstream patches
19Patch1: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-001
20Patch2: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-002
21Patch3: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-003
22Patch4: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-004
23Patch5: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-005
24Patch6: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-006
25Patch7: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-007
26Patch8: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-008
27Patch9: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-009
28Patch10: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-010
29Patch11: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-011
30Patch12: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-012
31Patch13: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-013
32Patch14: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-014
33Patch15: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-015
34Patch16: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-016
35Patch17: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-017
36Patch18: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-018
37
38# Other patches
39#Patch101: bash-2.02-security.patch
40Patch102: bash-2.03-paths.patch
41Patch103: bash-2.03-profile.patch
42Patch104: bash-2.05a-interpreter.patch
43Patch105: bash-2.05b-debuginfo.patch
44#Patch106: bash-2.05b-manso.patch
45Patch107: bash-2.05b-pgrp_sync.patch
46#Patch108: bash-2.05b-readline-oom.patch
47#Patch109: bash-2.05b-xcc.patch
48Patch110: bash-3.2-audit.patch
49Patch111: bash-3.2-ssh_source_bash.patch
50#Patch112: bash-bashbug.patch
51Patch113: bash-infotags.patch
52Patch114: bash-requires.patch
53Patch115: bash-setlocale.patch
54Patch116: bash-tty-tests.patch
55
56# 484809, check if interp section is NOBITS
57Patch117: bash-4.0-nobits.patch
58
59# Do the same CFLAGS in generated Makefile in examples
60Patch118: bash-4.1-examples.patch
61
62# Builtins like echo and printf won't report errors
63# when output does not succeed due to EPIPE
64Patch119: bash-4.1-broken_pipe.patch
65
66# Enable system-wide .bash_logout for login shells
67Patch120: bash-4.2-rc2-logout.patch
68
69# Static analyzis shows some issues in bash-2.05a-interpreter.patch
70Patch121: bash-4.2-coverity.patch
71
72# Don't call malloc in signal handler
73#Patch122: bash-4.1-defer-sigchld-trap.patch
74
75# 799958, updated info about trap
76Patch123: bash-4.2-manpage_trap.patch
77
78# https://www.securecoding.cert.org/confluence/display/seccode/INT32-C.+Ensure+that+operations+on+signed+integers+do+not+result+in+overflow
79Patch125: bash-4.2-size_type.patch
80
81# 1112710 - mention ulimit -c and -f POSIX block size
82Patch128: bash-4.3-man-ulimit.patch
83
84# A series of patches emitted by upstream since 4.3-18
85#Patch134: bash-4.3-pathexp-globignore-delim.patch
86
87# 1102815 - fix double echoes in vi visual mode
88Patch135: bash-4.3-noecho.patch
89
90# 1182278 - bash crashes on `select' if REPLY is readonly
91#Patch137: bash-4.3-select-readonly.patch
92
93#1241533,1224855 - bash leaks memory when LC_ALL set
94Patch138: bash-4.3-memleak-lc_all.patch
95
96#1245233 - old memleak reappeared, taken from upstream
97#Patch139: bash-4.3-old-memleak.patch
98
99# bash-4.4 builds loadable builtin examples by default
100# this patch disables it
101Patch140: bash-4.4-no-loadable-builtins.patch
102
103
104Buildroot:    %{_tmppath}/%{name}-%{version}-root
105BuildRequires: texinfo, bison, ncurses-devel, autoconf, gettext
106Obsoletes:    bash <= 1.14.7
107Obsoletes:    bash2
108
109%description
110Bash is a GNU project sh-compatible shell or command language
111interpreter. Bash (Bourne Again shell) incorporates useful features
112from the Korn shell (ksh) and the C shell (csh). Most sh scripts
113can be run by bash without modification.
114
115Bash offers several improvements over sh, including command line
116editing, unlimited size command history, job control, shell
117functions and aliases, indexed arrays of unlimited size and
118integer arithmetic in any base from two to 64. Bash is ultimately
119intended to conform to the IEEE POSIX P1003.2/ISO 9945.2 Shell and
120Tools standard.
121
122
123%package doc
124Summary:  Documentation for the GNU Bourne Again shell (bash).
125Summary(ja):  GNU Bourne Again シェル向けドキュメント
126Group:    documentation
127Requires: %{name} = %{version}-%{release}
128
129Obsoletes: bash2-doc
130
131%description doc
132This is a separate documentation package for the GNU Bourne
133Again shell.
134
135
136%debug_package
137
138
139%prep
140%setup -q -n %{name}-%{bashversion}
141
142# Official upstream patches
143%patch1 -p0 -b .001
144%patch2 -p0 -b .002
145%patch3 -p0 -b .003
146%patch4 -p0 -b .004
147%patch5 -p0 -b .005
148%patch6 -p0 -b .006
149%patch7 -p0 -b .007
150%patch8 -p0 -b .008
151%patch9 -p0 -b .009
152%patch10 -p0 -b .010
153%patch11 -p0 -b .011
154%patch12 -p0 -b .012
155%patch13 -p0 -b .013
156%patch14 -p0 -b .014
157%patch15 -p0 -b .015
158%patch16 -p0 -b .016
159%patch17 -p0 -b .017
160%patch18 -p0 -b .018
161
162# Other patches
163%patch102 -p1 -b .paths
164%patch103 -p1 -b .profile
165%patch104 -p1 -b .interpreter
166%patch105 -p1 -b .debuginfo
167%patch107 -p1 -b .pgrp_sync
168%patch110 -p1 -b .audit
169%patch111 -p1 -b .ssh_source_bash
170%patch113 -p1 -b .infotags
171%patch114 -p1 -b .requires
172%patch115 -p1 -b .setlocale
173%patch116 -p1 -b .tty_tests
174%patch117 -p1 -b .nobits
175%patch118 -p1 -b .examples
176%patch119 -p1 -b .broken_pipe
177%patch120 -p1 -b .logout
178%patch121 -p1 -b .coverity
179%patch123 -p1
180%patch125 -p1 -b .size_type
181%patch128 -p1 -b .ulimit
182%patch135 -p1 -b .noecho
183%patch138 -p1 -b .lc_all
184%patch140 -p1 -b .no_loadable_builtin
185
186echo %{version} > _distribution
187echo %{release} |sed 's/vl.*//' > _patchlevel
188
189
190%build
191%configure --with-bash-malloc=no
192make CPPFLAGS="-D_GNU_SOURCE -DRECYCLES_PIDS `getconf LFS_CFLAGS`"
193
194%install
195rm -rf %{buildroot}
196
197# Fix bug #83776
198perl -pi -e 's,bashref\.info,bash.info,' doc/bashref.info
199
200make DESTDIR=$RPM_BUILD_ROOT install
201
202pushd $RPM_BUILD_ROOT
203 mkdir ./bin
204 mv ./usr/bin/bash ./bin/bash
205 ln -s bash ./bin/sh
206 rm -f .%{_infodir}/dir
207popd
208
209ln -s bash.1 %{buildroot}%{_mandir}/man1/sh.1
210
211# make manpages for bash builtins as per suggestion in DOC/README
212pushd doc
213sed -e '
214/^\.SH NAME/, /\\- bash built-in commands, see \\fBbash\\fR(1)$/{
215/^\.SH NAME/d
216s/^bash, //
217s/\\- bash built-in commands, see \\fBbash\\fR(1)$//
218s/,//g
219b
220}
221d
222' builtins.1 > man.pages
223for i in echo pwd test kill; do
224  perl -pi -e "s,$i,,g" man.pages
225  perl -pi -e "s,  , ,g" man.pages
226done
227
228install -c -m 644 builtins.1 %{buildroot}%{_mandir}/man1/builtins.1
229
230for i in `cat man.pages` ; do
231  echo .so man1/builtins.1 > %{buildroot}%{_mandir}/man1/$i.1
232  chmod 0644 ${RPM_BUILD_ROOT}%{_mandir}/man1/$i.1
233done
234
235mkdir -p $RPM_BUILD_ROOT/etc/profile.d/
236install -m 644 %{SOURCE10} $RPM_BUILD_ROOT/etc/bashrc
237
238# Not for printf, false and true (conflict with coreutils)
239rm -f $RPM_BUILD_ROOT%{_mandir}/man1/printf.1
240rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/true.1
241rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/false.1
242
243popd
244
245%find_lang %{name}
246
247rm -rf $RPM_BUILD_ROOT/%{_docdir}/bash
248
249%clean
250rm -rf %{buildroot}
251
252# ***** bash doesn't use install-info. It's always listed in %{_infodir}/dir
253# to prevent prereq loops
254
255# post is in lua so that we can run it without any external deps.  Helps
256# for bootstrapping a new install.
257# Jesse Keating 2009-01-29 (code from Ignacio Vazquez-Abrams)
258%post -p <lua>
259bashfound = false;
260shfound = false;
261 
262f = io.open("/etc/shells", "r");
263if f == nil
264then
265  f = io.open("/etc/shells", "w");
266else
267  repeat
268    t = f:read();
269    if t == "/bin/bash"
270    then
271      bashfound = true;
272    end
273    if t == "/bin/sh"
274    then
275      shfound = true;
276    end
277  until t == nil;
278end
279f:close()
280 
281f = io.open("/etc/shells", "a");
282if not bashfound
283then
284  f:write("/bin/bash\n")
285end
286if not shfound
287then
288  f:write("/bin/sh\n")
289end
290f:close()
291
292%files -f %{name}.lang
293%defattr(-,root,root)
294%license COPYING
295%doc CHANGES
296%doc examples
297%config(noreplace) /etc/bashrc
298/bin/bash
299/bin/sh
300%{_infodir}/bash.info*
301%{_mandir}/*/*
302%{_mandir}/*/..1*
303%{_bindir}/bashbug
304
305
306%files doc
307%defattr(-,root,root)
308%doc COMPAT NEWS NOTES POSIX RBASH
309%doc examples/functions/ examples/misc/
310%doc examples/scripts*/
311%doc examples/startup-files/ examples/complete/ examples/loadables/
312%doc doc/*.ps doc/*.0 doc/*.html doc/article.txt
313%doc doc/FAQ doc/INTRO doc/article.ms doc/README
314
315
316%changelog
317* Sat Sep 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.18-1
318- updated to 5.0 patch level 18.
319
320* Sat Feb 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.16-1
321- updated to 5.0 patch level 16.
322
323* Thu Sep 12 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.11-1
324- updated to 5.0 patch level 11.
325
326* Thu Aug 29 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.9-1
327- updated to 5.0 patch level 9.
328- dropped Patch101, 106, 108, 109, 112, 122, 134, 137 and 139.
329- imported Patch140 from rawhide.
330
331* Tue Jul  5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.46-1
332- updated to 4.3 patch level 46.
333
334* Sat Sep 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.42-1
335- updated to 4.3 patch level 42.
336- imported patch 128-139 from RawHide.
337
338* Fri Oct  3 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.29-1
339- updated to 4.3 patch level 29.
340- removed patch1000 (included in 4.3.26).
341
342* Thu Sep 25 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.25-2
343- added patch1000 to fix CVE-2014-7169.
344
345* Thu Sep 25 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.25-1
346- updated to 4.3 patch level 25.
347
348* Tue Jun 10 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3.18-1
349- update to 4.3 patch level 18
350
351* Wed May 14 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3.11-1
352- update to 4.3 patch level 11
353
354* Mon Mar 18 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.45-1
355- update to 4.2 patch level 45
356- import some patch from fedora package (122-127)
357  - patch122: Don't call malloc in signal handler
358  - patch123: #799958, updated info about trap
359  - patch124: #695656, block the signal and unblock it after the
360    new handler is installed
361  - patch125: Use unsigned type for size
362    https://www.securecoding.cert.org/confluence/display/seccode/INT32-C.+Ensure+that+operations+on+signed+integers+do+not+result+in+overflow
363  - patch126: #903833, Fix missing close(), fixes fd leaks
364
365* Sat Oct  6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.2.37-2
366- remove postun lua script because bash will be never uninstalled
367
368* Mon Sep 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.37-1
369- update to 4.2 patch level 37
370
371* Fri Feb 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.20-1
372- update to 4.2 patch level 20
373
374* Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.8-1
375- update to 4.2 patch level 8
376- use lua script in post/postun
377- update patches from fedora
378
379* Fri Sep 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1-1
380- update to 4.1 patch level 7
381
382* Fri Mar  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-9
383- check if /bin/grep exists on %%post script
384
385* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-8
386- rebuilt with gcc-4.4.3-3 on ppc
387
388* Tue Feb  2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-7
389- rebuilt with new toolchain
390
391* Fri Dec  4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-6
392- revert changes on 3.2-5 (avoid a nasty dependency loop on bootstrapping)
393
394* Fri Dec  4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-5
395- add Requires(post): grep
396
397* Sat Oct 24 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-4
398- remove obsolete /bin/bash2 entry from /etc/shells
399
400* Mon Apr 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-3
401- add Requires(post): ncurses (should be added by find-requires..)
402
403* Sun Mar 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-2
404- add upstream patch (from 040 to 048)
405- build against ncurses-devel (libtinfo)
406- spec in utf-8
407
408* Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2-1vl5
409- added upstream patch (from 026 to 039)
410- added Japanese summary
411- applied new versioning policy
412
413* Fri Jan 18 2008 Shu KONNO <owa@bg.wakwak.com> 3.2-0vl2
414- rebuilt with libtermcap-devel
415
416* Fri Oct 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-0vl1
417- new upstream release
418- add upstream patch (from 001 to 025)
419- remove Provides: bash2
420
421* Wed May 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.05b-0vl4
422- rebuilt with new toolchain
423
424* Mon Sep 11 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.05b-0vl3
425- change doc Group to Applications/Documentation. <BTS:VineLinux:163>
426- quote CPPFLAGS to avoid configure error. <BTS:VineLinux:173>
427
428* Mon Jun 28 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.05b-0vl2
429- Don't read /etc/profile.d/*.sh in /etc/bashrc; done in /etc/profile
430
431* Wed Mar 10 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.05b-0vl1
432- update to 2.05b
433- rebuild with new toolchains
434- add make check
435- add %postun script based on Fedora development
436- README file moved doc package
437- update Patch5 and Patch8 from Fedora development
438- change Patch6
439- remove Patch2 and Patch100 (bash-2.05b supports multibyte string)
440- add Patch11--39 from Fedora development 2.05b-36
441  * Tim Waugh <twaugh@redhat.com>
442  - Fix parameter expansion in multibyte locales (bug #112657).
443  - Speed up UTF-8 command-line redrawing in the common case (bug #102353,
444    bug #110777).
445  - Apply upstream patches (bug #109269 among others).
446  - Fix bash.info (bug #83776).
447  - Add bash205b-007 patch to fix bug #106876.
448  - Avoid crashing on multibyte input when locale is set incorrectly
449    (bug #74266).
450  - LFS support (bug #103627).
451  - Fix completion display when multibyte or control characters are to be
452    shown (bug #90201).
453  - Fix a warning message (bug #79629).
454  - Don't build with AFS support (bug #86514).
455  - Don't explicitly strip binaries (bug #85995).
456  - Really fix bug #83331 for good.
457  - Fix builtins.1.
458  - Actually apply the patch (bug #83331).
459  - Fix history/UTF-8 bug (bug #83331).
460  - More tab-completion fixing (bug #72512).
461  - Force pgrp synchronization (bug #81653).
462  - Prevent prompt overwriting output (bug #74383).
463  - Fix '-rbash' (bug #78455).
464  - Add readline-init patch (bug #74925).
465  - Add the (4) patches from ftp.gnu.org (bug #75888, bug #72512).
466  - Ship '.' man page, which doesn't get picked up by glob.
467  - Locale shell variables fix (bug #74701).
468  * Elliot Lee <sopwith@redhat.com>
469  - (patch26) Don't call 'size' in makefile. Pointless, and interferes with
470    cross compiles.
471
472* Wed Oct  9 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.05-0vl1
473- update to 2.05
474- add README.jpatch to %doc
475- remove patch4 (bash2): revert command name in man pages to "bash"
476  - fix perl command to remove man pages conflict with sh-utils
477- remove section of config.h.in from patch0 to prevent remake of configure
478- change patch9: define in config-top.h to avoid conflict with patch100
479- remove patches 7, 10 & 101
480
481* Mon Apr  8 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.04-1vl14
482- made a link for man sh
483
484* Thu Nov 15 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.04-1vl13
485- added missing %%post and %%triggerpostun section
486
487* Sun Jul 15 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
488- 2.04-1vl12
489- now bash2 is finally bash
490
491* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.04-1vl11
492- build for Playstation2
493
494* Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
495- 2.04-1vl10
496- Provides: bash = %%{version}
497
498* Thu Jun 07 2001 Satoshi MACHINO  <machino@vinelinux.org> 2.04-1vl9
499- added Provides: bash
500
501* Thu Jun 07 2001 Satoshi MACHINO  <machino@vinelinux.org> 2.04-1vl8
502- Obsoletes: bash
503- changed Copyright to License
504
505* Fri Dec 29 2000 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
506- 2.04-1vl7
507- deleted: /etc/profile.d/alias.sh (which we have in /etc/skel/.bashrc)
508- corrected: bashrc-vine -> bashrc
509
510* Sat Dec 16 2000 Satoshi MACHINO  <machino@vinelinux.org> 2.04-1vl6
511- combined bash-1.x and bash-2.x packages
512- added some patches from bash-2.04-13mdk
513
514* Sun Dec 10 2000 Jun Nishii <jun@vinelinux.org> 2.04-1vl5
515- fix spec macros
516- added tests
517
518* Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl5
519- build with gcc-2.95.3
520- partially used rpmmacros
521
522* Fri Sep  8 2000 Jun Nishii <jun@vinelinux.org>
523- minor bug fix in spec file
524
525* Sun Aug 27 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
526- 2.04-1vl3
527- modified %install and %files section to handle compressed man page(s)
528
529* Thu Mar 23 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
530- added pcomplete patch to fix complete if the candidate list is NULL.
531
532* Wed Mar 22 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
533- updated to 2.04
534
535* Tue Sep 14 1999 Dale Lovelace <dale@redhat.com>
536- Remove annoying ^H's from documentation
537
538* Fri Jul 16 1999 Ken Estes <kestes@staff.mail.com>
539- patch to detect what executables are required by a script.
540
541* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
542- auto rebuild in the new build environment (release 4)
543
544* Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
545- strip binaries.
546- include bash-doc correctly.
547
548* Thu Mar 18 1999 Preston Brown <pbrown@redhat.com>
549- fixed post/postun /etc/shells work.
550
551* Thu Mar 18 1999 Cristian Gafton <gafton@redhat.com>
552- updated again text in the spec file
553
554* Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
555- updated text in spec file.
556- update to 2.03.
557
558* Fri Feb 12 1999 Cristian Gafton <gafton@redhat.com>
559- build it as bash2 instead of bash
560
561* Tue Feb  9 1999 Bill Nottingham <notting@redhat.com>
562- set 'NON_INTERACTIVE_LOGIN_SHELLS' so profile gets read
563
564* Thu Jan 14 1999 Jeff Johnson <jbj@redhat.com>
565- rename man pages in bash-doc to avoid packaging conflicts (#606).
566
567* Wed Dec 02 1998 Cristian Gafton <gafton@redhat.com>
568- patch for the arm
569- use $RPM_ARCH-redhat-linux as the build target
570
571* Tue Oct  6 1998 Bill Nottingham <notting@redhat.com>
572- rewrite %pre, axe %postun (to avoid prereq loops)
573
574* Wed Aug 19 1998 Jeff Johnson <jbj@redhat.com>
575- resurrect for RH 6.0.
576
577* Sun Jul 26 1998 Jeff Johnson <jbj@redhat.com>
578- update to 2.02.1
579
580* Thu Jun 11 1998 Jeff Johnson <jbj@redhat.com>
581- Package for 5.2.
582
583* Mon Apr 20 1998 Ian Macdonald <ianmacd@xs4all.nl>
584- added POSIX.NOTES doc file
585- some extraneous doc files removed
586- minor .spec file changes
587
588* Sun Apr 19 1998 Ian Macdonald <ianmacd@xs4all.nl>
589- upgraded to version 2.02
590- Alpha, MIPS & Sparc patches removed due to lack of test platforms
591- glibc & signal patches no longer required
592- added documentation subpackage (doc)
593
594* Fri Nov 07 1997 Donnie Barnes <djb@redhat.com>
595- added signal handling patch from Dean Gaudet <dgaudet@arctic.org> that
596  is based on a change made in bash 2.0.  Should fix some early exit
597  problems with suspends and fg.
598
599* Mon Oct 20 1997 Donnie Barnes <djb@redhat.com>
600- added %clean
601
602* Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
603- added comment explaining why install-info isn't used
604- added mips patch
605
606* Fri Oct 17 1997 Donnie Barnes <djb@redhat.com>
607- added BuildRoot
608
609* Tue Jun 03 1997 Erik Troan <ewt@redhat.com>
610- built against glibc
Note: See TracBrowser for help on using the repository browser.