source: projects/specs/trunk/b/bash/bash-vl.spec @ 8968

Revision 8968, 17.8 KB checked in by tomop, 10 years ago (diff)

bash-4.3.25-1

Line 
1%define bashversion 4.3
2%define patchlevel 25
3
4Summary:      The GNU Bourne Again shell (bash).
5Summary(ja):  GNU Bourne Again シェル (bash).
6
7Name:         bash
8Version:      %{bashversion}.%{patchlevel}
9Release:      1%{?_dist_release}
10
11Group:        System Environment/Shells
12License:      GPLv3+
13
14Vendor:       Project Vine
15Distribution: Vine Linux
16Packager:     daisuke
17
18Source0:      ftp://ftp.gnu.org/pub/gnu/bash/bash-%{bashversion}.tar.gz
19Source10:     bashrc-vine
20
21# Official upstream patches
22Patch1: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-001
23Patch2: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-002
24Patch3: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-003
25Patch4: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-004
26Patch5: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-005
27Patch6: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-006
28Patch7: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-007
29Patch8: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-008
30Patch9: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-009
31Patch10: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-010
32Patch11: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-011
33Patch12: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-012
34Patch13: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-013
35Patch14: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-014
36Patch15: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-015
37Patch16: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-016
38Patch17: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-017
39Patch18: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-018
40Patch19: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-019
41Patch20: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-020
42Patch21: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-021
43Patch22: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-022
44Patch23: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-023
45Patch24: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-024
46Patch25: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-025
47
48# Other patches
49Patch101: bash-2.02-security.patch
50Patch102: bash-2.03-paths.patch
51Patch103: bash-2.03-profile.patch
52Patch104: bash-2.05a-interpreter.patch
53Patch105: bash-2.05b-debuginfo.patch
54Patch106: bash-2.05b-manso.patch
55Patch107: bash-2.05b-pgrp_sync.patch
56Patch108: bash-2.05b-readline-oom.patch
57Patch109: bash-2.05b-xcc.patch
58Patch110: bash-3.2-audit.patch
59Patch111: bash-3.2-ssh_source_bash.patch
60Patch112: bash-bashbug.patch
61Patch113: bash-infotags.patch
62Patch114: bash-requires.patch
63Patch115: bash-setlocale.patch
64Patch116: bash-tty-tests.patch
65
66# 484809, check if interp section is NOBITS
67Patch117: bash-4.0-nobits.patch
68
69# Do the same CFLAGS in generated Makefile in examples
70Patch118: bash-4.1-examples.patch
71
72# Builtins like echo and printf won't report errors
73# when output does not succeed due to EPIPE
74Patch119: bash-4.1-broken_pipe.patch
75
76# Enable system-wide .bash_logout for login shells
77Patch120: bash-4.2-rc2-logout.patch
78
79# Static analyzis shows some issues in bash-2.05a-interpreter.patch
80Patch121: bash-4.2-coverity.patch
81
82# Don't call malloc in signal handler
83Patch122: bash-4.1-defer-sigchld-trap.patch
84
85# 799958, updated info about trap
86Patch123: bash-4.2-manpage_trap.patch
87
88# https://www.securecoding.cert.org/confluence/display/seccode/INT32-C.+Ensure+that+operations+on+signed+integers+do+not+result+in+overflow
89Patch125: bash-4.2-size_type.patch
90
91Buildroot:    %{_tmppath}/%{name}-%{version}-root
92BuildRequires: texinfo, bison, ncurses-devel, autoconf, gettext
93Obsoletes:    bash <= 1.14.7
94Obsoletes:    bash2
95
96
97%description
98Bash is a GNU project sh-compatible shell or command language
99interpreter. Bash (Bourne Again shell) incorporates useful features
100from the Korn shell (ksh) and the C shell (csh). Most sh scripts
101can be run by bash without modification.
102
103Bash offers several improvements over sh, including command line
104editing, unlimited size command history, job control, shell
105functions and aliases, indexed arrays of unlimited size and
106integer arithmetic in any base from two to 64. Bash is ultimately
107intended to conform to the IEEE POSIX P1003.2/ISO 9945.2 Shell and
108Tools standard.
109
110
111%package doc
112Summary:  Documentation for the GNU Bourne Again shell (bash).
113Summary:  GNU Bourne Again シェル向けドキュメント
114Group:    Applications/Documentation
115Requires: %{name} = %{version}-%{release}
116
117Obsoletes: bash2-doc
118
119%description doc
120This is a separate documentation package for the GNU Bourne
121Again shell.
122
123
124%prep
125%setup -q -n %{name}-%{bashversion}
126
127# Official upstream patches
128%patch1 -p0 -b .001
129%patch2 -p0 -b .002
130%patch3 -p0 -b .003
131%patch4 -p0 -b .004
132%patch5 -p0 -b .005
133%patch6 -p0 -b .006
134%patch7 -p0 -b .007
135%patch8 -p0 -b .008
136%patch9 -p0 -b .009
137%patch10 -p0 -b .010
138%patch11 -p0 -b .011
139%patch12 -p0 -b .012
140%patch13 -p0 -b .013
141%patch14 -p0 -b .014
142%patch15 -p0 -b .015
143%patch16 -p0 -b .016
144%patch17 -p0 -b .017
145%patch18 -p0 -b .018
146%patch19 -p0 -b .019
147%patch20 -p0 -b .020
148%patch21 -p0 -b .021
149%patch22 -p0 -b .022
150%patch23 -p0 -b .023
151%patch24 -p0 -b .024
152%patch25 -p0 -b .025
153
154# Other patches
155%patch101 -p1 -b .security
156%patch102 -p1 -b .paths
157%patch103 -p1 -b .profile
158%patch104 -p1 -b .interpreter
159%patch105 -p1 -b .debuginfo
160%patch106 -p1 -b .manso
161%patch107 -p1 -b .pgrp_sync
162%patch108 -p1 -b .readline_oom
163%patch109 -p1 -b .xcc
164%patch110 -p1 -b .audit
165%patch111 -p1 -b .ssh_source_bash
166%patch112 -p1 -b .bashbug
167%patch113 -p1 -b .infotags
168%patch114 -p1 -b .requires
169%patch115 -p1 -b .setlocale
170%patch116 -p1 -b .tty_tests
171%patch117 -p1 -b .nobits
172%patch118 -p1 -b .examples
173%patch119 -p1 -b .broken_pipe
174%patch120 -p1 -b .logout
175%patch121 -p1 -b .coverity
176%patch122 -p1 -b .defer_sigchld_trap
177%patch123 -p1
178%patch125 -p1 -b .size_type
179
180echo %{version} > _distribution
181echo %{release} |sed 's/vl.*//' > _patchlevel
182
183
184%build
185%configure --with-bash-malloc=no
186make CPPFLAGS="-D_GNU_SOURCE -DRECYCLES_PIDS `getconf LFS_CFLAGS`"
187
188%install
189rm -rf %{buildroot}
190
191# Fix bug #83776
192perl -pi -e 's,bashref\.info,bash.info,' doc/bashref.info
193
194make DESTDIR=$RPM_BUILD_ROOT install
195
196pushd $RPM_BUILD_ROOT
197 mkdir ./bin
198 mv ./usr/bin/bash ./bin/bash
199 ln -s bash ./bin/sh
200 rm -f .%{_infodir}/dir
201popd
202
203ln -s bash.1 %{buildroot}%{_mandir}/man1/sh.1
204
205# make manpages for bash builtins as per suggestion in DOC/README
206pushd doc
207sed -e '
208/^\.SH NAME/, /\\- bash built-in commands, see \\fBbash\\fR(1)$/{
209/^\.SH NAME/d
210s/^bash, //
211s/\\- bash built-in commands, see \\fBbash\\fR(1)$//
212s/,//g
213b
214}
215d
216' builtins.1 > man.pages
217for i in echo pwd test kill; do
218  perl -pi -e "s,$i,,g" man.pages
219  perl -pi -e "s,  , ,g" man.pages
220done
221
222install -c -m 644 builtins.1 %{buildroot}%{_mandir}/man1/builtins.1
223
224for i in `cat man.pages` ; do
225  echo .so man1/builtins.1 > %{buildroot}%{_mandir}/man1/$i.1
226  chmod 0644 ${RPM_BUILD_ROOT}%{_mandir}/man1/$i.1
227done
228
229mkdir -p $RPM_BUILD_ROOT/etc/profile.d/
230install -m 644 %{SOURCE10} $RPM_BUILD_ROOT/etc/bashrc
231
232# Not for printf, false and true (conflict with coreutils)
233rm -f $RPM_BUILD_ROOT%{_mandir}/man1/printf.1
234rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/true.1
235rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/false.1
236
237popd
238
239%find_lang %{name}
240
241rm -rf $RPM_BUILD_ROOT/%{_docdir}/bash
242
243%clean
244rm -rf %{buildroot}
245
246# ***** bash doesn't use install-info. It's always listed in %{_infodir}/dir
247# to prevent prereq loops
248
249# post is in lua so that we can run it without any external deps.  Helps
250# for bootstrapping a new install.
251# Jesse Keating 2009-01-29 (code from Ignacio Vazquez-Abrams)
252%post -p <lua>
253bashfound = false;
254shfound = false;
255 
256f = io.open("/etc/shells", "r");
257if f == nil
258then
259  f = io.open("/etc/shells", "w");
260else
261  repeat
262    t = f:read();
263    if t == "/bin/bash"
264    then
265      bashfound = true;
266    end
267    if t == "/bin/sh"
268    then
269      shfound = true;
270    end
271  until t == nil;
272end
273f:close()
274 
275f = io.open("/etc/shells", "a");
276if not bashfound
277then
278  f:write("/bin/bash\n")
279end
280if not shfound
281then
282  f:write("/bin/sh\n")
283end
284f:close()
285
286%files -f %{name}.lang
287%defattr(-,root,root)
288%doc CHANGES COPYING
289%doc examples
290%config(noreplace) /etc/bashrc
291/bin/bash
292/bin/sh
293%{_infodir}/bash.info*
294%{_mandir}/*/*
295%{_mandir}/*/..1*
296%{_bindir}/bashbug
297
298
299%files doc
300%defattr(-,root,root)
301%doc COMPAT NEWS NOTES POSIX RBASH
302%doc examples/functions/ examples/misc/
303%doc examples/scripts.noah/ examples/scripts.v2/ examples/scripts/
304%doc examples/startup-files/ examples/complete/ examples/loadables/
305%doc doc/*.ps doc/*.0 doc/*.html doc/article.txt
306%doc doc/FAQ doc/INTRO doc/article.ms doc/README
307
308
309%changelog
310* Thu Sep 25 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.25-1
311- updated to 4.3 patch level 25
312
313* Tue Jun 10 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3.18-1
314- update to 4.3 patch level 18
315
316* Wed May 14 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3.11-1
317- update to 4.3 patch level 11
318
319* Mon Mar 18 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.45-1
320- update to 4.2 patch level 45
321- import some patch from fedora package (122-127)
322  - patch122: Don't call malloc in signal handler
323  - patch123: #799958, updated info about trap
324  - patch124: #695656, block the signal and unblock it after the
325    new handler is installed
326  - patch125: Use unsigned type for size
327    https://www.securecoding.cert.org/confluence/display/seccode/INT32-C.+Ensure+that+operations+on+signed+integers+do+not+result+in+overflow
328  - patch126: #903833, Fix missing close(), fixes fd leaks
329
330* Sat Oct  6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.2.37-2
331- remove postun lua script because bash will be never uninstalled
332
333* Mon Sep 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.37-1
334- update to 4.2 patch level 37
335
336* Fri Feb 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.20-1
337- update to 4.2 patch level 20
338
339* Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.8-1
340- update to 4.2 patch level 8
341- use lua script in post/postun
342- update patches from fedora
343
344* Fri Sep 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1-1
345- update to 4.1 patch level 7
346
347* Fri Mar  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-9
348- check if /bin/grep exists on %%post script
349
350* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-8
351- rebuilt with gcc-4.4.3-3 on ppc
352
353* Tue Feb  2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-7
354- rebuilt with new toolchain
355
356* Fri Dec  4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-6
357- revert changes on 3.2-5 (avoid a nasty dependency loop on bootstrapping)
358
359* Fri Dec  4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-5
360- add Requires(post): grep
361
362* Sat Oct 24 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-4
363- remove obsolete /bin/bash2 entry from /etc/shells
364
365* Mon Apr 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-3
366- add Requires(post): ncurses (should be added by find-requires..)
367
368* Sun Mar 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-2
369- add upstream patch (from 040 to 048)
370- build against ncurses-devel (libtinfo)
371- spec in utf-8
372
373* Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2-1vl5
374- added upstream patch (from 026 to 039)
375- added Japanese summary
376- applied new versioning policy
377
378* Fri Jan 18 2008 Shu KONNO <owa@bg.wakwak.com> 3.2-0vl2
379- rebuilt with libtermcap-devel
380
381* Fri Oct 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-0vl1
382- new upstream release
383- add upstream patch (from 001 to 025)
384- remove Provides: bash2
385
386* Wed May 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.05b-0vl4
387- rebuilt with new toolchain
388
389* Mon Sep 11 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.05b-0vl3
390- change doc Group to Applications/Documentation. <BTS:VineLinux:163>
391- quote CPPFLAGS to avoid configure error. <BTS:VineLinux:173>
392
393* Mon Jun 28 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.05b-0vl2
394- Don't read /etc/profile.d/*.sh in /etc/bashrc; done in /etc/profile
395
396* Wed Mar 10 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.05b-0vl1
397- update to 2.05b
398- rebuild with new toolchains
399- add make check
400- add %postun script based on Fedora development
401- README file moved doc package
402- update Patch5 and Patch8 from Fedora development
403- change Patch6
404- remove Patch2 and Patch100 (bash-2.05b supports multibyte string)
405- add Patch11--39 from Fedora development 2.05b-36
406  * Tim Waugh <twaugh@redhat.com>
407  - Fix parameter expansion in multibyte locales (bug #112657).
408  - Speed up UTF-8 command-line redrawing in the common case (bug #102353,
409    bug #110777).
410  - Apply upstream patches (bug #109269 among others).
411  - Fix bash.info (bug #83776).
412  - Add bash205b-007 patch to fix bug #106876.
413  - Avoid crashing on multibyte input when locale is set incorrectly
414    (bug #74266).
415  - LFS support (bug #103627).
416  - Fix completion display when multibyte or control characters are to be
417    shown (bug #90201).
418  - Fix a warning message (bug #79629).
419  - Don't build with AFS support (bug #86514).
420  - Don't explicitly strip binaries (bug #85995).
421  - Really fix bug #83331 for good.
422  - Fix builtins.1.
423  - Actually apply the patch (bug #83331).
424  - Fix history/UTF-8 bug (bug #83331).
425  - More tab-completion fixing (bug #72512).
426  - Force pgrp synchronization (bug #81653).
427  - Prevent prompt overwriting output (bug #74383).
428  - Fix '-rbash' (bug #78455).
429  - Add readline-init patch (bug #74925).
430  - Add the (4) patches from ftp.gnu.org (bug #75888, bug #72512).
431  - Ship '.' man page, which doesn't get picked up by glob.
432  - Locale shell variables fix (bug #74701).
433  * Elliot Lee <sopwith@redhat.com>
434  - (patch26) Don't call 'size' in makefile. Pointless, and interferes with
435    cross compiles.
436
437* Wed Oct  9 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.05-0vl1
438- update to 2.05
439- add README.jpatch to %doc
440- remove patch4 (bash2): revert command name in man pages to "bash"
441  - fix perl command to remove man pages conflict with sh-utils
442- remove section of config.h.in from patch0 to prevent remake of configure
443- change patch9: define in config-top.h to avoid conflict with patch100
444- remove patches 7, 10 & 101
445
446* Mon Apr  8 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.04-1vl14
447- made a link for man sh
448
449* Thu Nov 15 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.04-1vl13
450- added missing %%post and %%triggerpostun section
451
452* Sun Jul 15 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
453- 2.04-1vl12
454- now bash2 is finally bash
455
456* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.04-1vl11
457- build for Playstation2
458
459* Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
460- 2.04-1vl10
461- Provides: bash = %%{version}
462
463* Thu Jun 07 2001 Satoshi MACHINO  <machino@vinelinux.org> 2.04-1vl9
464- added Provides: bash
465
466* Thu Jun 07 2001 Satoshi MACHINO  <machino@vinelinux.org> 2.04-1vl8
467- Obsoletes: bash
468- changed Copyright to License
469
470* Fri Dec 29 2000 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
471- 2.04-1vl7
472- deleted: /etc/profile.d/alias.sh (which we have in /etc/skel/.bashrc)
473- corrected: bashrc-vine -> bashrc
474
475* Sat Dec 16 2000 Satoshi MACHINO  <machino@vinelinux.org> 2.04-1vl6
476- combined bash-1.x and bash-2.x packages
477- added some patches from bash-2.04-13mdk
478
479* Sun Dec 10 2000 Jun Nishii <jun@vinelinux.org> 2.04-1vl5
480- fix spec macros
481- added tests
482
483* Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl5
484- build with gcc-2.95.3
485- partially used rpmmacros
486
487* Fri Sep  8 2000 Jun Nishii <jun@vinelinux.org>
488- minor bug fix in spec file
489
490* Sun Aug 27 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
491- 2.04-1vl3
492- modified %install and %files section to handle compressed man page(s)
493
494* Thu Mar 23 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
495- added pcomplete patch to fix complete if the candidate list is NULL.
496
497* Wed Mar 22 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
498- updated to 2.04
499
500* Tue Sep 14 1999 Dale Lovelace <dale@redhat.com>
501- Remove annoying ^H's from documentation
502
503* Fri Jul 16 1999 Ken Estes <kestes@staff.mail.com>
504- patch to detect what executables are required by a script.
505
506* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
507- auto rebuild in the new build environment (release 4)
508
509* Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
510- strip binaries.
511- include bash-doc correctly.
512
513* Thu Mar 18 1999 Preston Brown <pbrown@redhat.com>
514- fixed post/postun /etc/shells work.
515
516* Thu Mar 18 1999 Cristian Gafton <gafton@redhat.com>
517- updated again text in the spec file
518
519* Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
520- updated text in spec file.
521- update to 2.03.
522
523* Fri Feb 12 1999 Cristian Gafton <gafton@redhat.com>
524- build it as bash2 instead of bash
525
526* Tue Feb  9 1999 Bill Nottingham <notting@redhat.com>
527- set 'NON_INTERACTIVE_LOGIN_SHELLS' so profile gets read
528
529* Thu Jan 14 1999 Jeff Johnson <jbj@redhat.com>
530- rename man pages in bash-doc to avoid packaging conflicts (#606).
531
532* Wed Dec 02 1998 Cristian Gafton <gafton@redhat.com>
533- patch for the arm
534- use $RPM_ARCH-redhat-linux as the build target
535
536* Tue Oct  6 1998 Bill Nottingham <notting@redhat.com>
537- rewrite %pre, axe %postun (to avoid prereq loops)
538
539* Wed Aug 19 1998 Jeff Johnson <jbj@redhat.com>
540- resurrect for RH 6.0.
541
542* Sun Jul 26 1998 Jeff Johnson <jbj@redhat.com>
543- update to 2.02.1
544
545* Thu Jun 11 1998 Jeff Johnson <jbj@redhat.com>
546- Package for 5.2.
547
548* Mon Apr 20 1998 Ian Macdonald <ianmacd@xs4all.nl>
549- added POSIX.NOTES doc file
550- some extraneous doc files removed
551- minor .spec file changes
552
553* Sun Apr 19 1998 Ian Macdonald <ianmacd@xs4all.nl>
554- upgraded to version 2.02
555- Alpha, MIPS & Sparc patches removed due to lack of test platforms
556- glibc & signal patches no longer required
557- added documentation subpackage (doc)
558
559* Fri Nov 07 1997 Donnie Barnes <djb@redhat.com>
560- added signal handling patch from Dean Gaudet <dgaudet@arctic.org> that
561  is based on a change made in bash 2.0.  Should fix some early exit
562  problems with suspends and fg.
563
564* Mon Oct 20 1997 Donnie Barnes <djb@redhat.com>
565- added %clean
566
567* Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
568- added comment explaining why install-info isn't used
569- added mips patch
570
571* Fri Oct 17 1997 Donnie Barnes <djb@redhat.com>
572- added BuildRoot
573
574* Tue Jun 03 1997 Erik Troan <ewt@redhat.com>
575- built against glibc
Note: See TracBrowser for help on using the repository browser.