source: projects/specs/trunk/a/avogadro/avogadro-vl.spec @ 8034

Revision 8034, 8.3 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild with libboost-1.54.0

Line 
1%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.7.2)
2%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt-%{qt4_ver})
3
4%define ENABLE_TESTS -DENABLE_TESTS:BOOL=ON
5
6Name:           avogadro
7Summary:        An advanced molecular editor for chemical purposes
8Version:        1.0.3
9Release:        1%{?_dist_release}
10
11Group:          Applications/Editors
12License:        GPLv2
13URL:            http://avogadro.openmolecules.net/
14
15Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
16
17Patch0:                 avogadro-1.0.3-mkspecs-dir.patch
18
19BuildRequires:  cmake >= 2.6.0
20BuildRequires:  qt4-devel >= 4.5.1
21BuildRequires:  qt4-tools
22BuildRequires:  eigen2-devel >= 2.0.3
23BuildRequires:  openbabel-devel >= 2.2.2
24BuildRequires:  libboost-devel >= 1.35
25BuildRequires:  libboost-python >= 1.35
26BuildRequires:  glew-devel >= 1.5.0
27BuildRequires:  desktop-file-utils
28BuildRequires:  docbook-utils
29BuildRequires:  sip-devel >= 4.11
30BuildRequires:  numpy
31
32Requires: %{name}-libs = %{version}-%{release}
33
34%description
35An advanced molecular editor designed for
36cross-platform use in computational chemistry,
37molecular modeling, bioinformatics, materials science,
38and related areas, which offers flexible rendering and
39a powerful plugin architecture.
40
41
42%package libs
43Summary: Shared libraries for Avogadro
44Summary(ja): Avogadro の共用ライブラリ
45Group: System Environment/Libraries
46Requires: sip
47
48%description libs
49This package contains the shared libraries for the
50molecular editor Avogadro.
51
52
53%package devel
54Summary: Development files for Avogadro
55Summary(ja): Avogadro の開発用ファイル
56Group: Development/Libraries
57Requires: %{name}-libs = %{version}-%{release}
58Requires: qt4-devel = %{_qt4_version}
59Requires: eigen2-devel >= 2.0.3
60Requires: glew-devel >= 1.5.0
61
62%description devel
63This package contains files to develop applications using
64Avogadros libraries.
65
66
67%prep
68%setup -q
69%patch0 -p1 -b .mkspecs-dir
70
71# nuke unpatched copy, use working version included in cmake instead -- Rex
72rm -f cmake/modules/FindPythonLibs.cmake
73
74
75%build
76mkdir -p %{_target_platform}
77pushd %{_target_platform}
78%cmake -Wno-dev \
79    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
80    -DBIN_INSTALL_DIR:PATH=bin \
81    -DLIB_INSTALL_DIR:PATH=%{_lib} \
82    -DENABLE_GLSL:BOOL=ON \
83    -DENABLE_PYTHON:BOOL=ON \
84    %{?ENABLE_TESTS} ..
85popd
86make %{?_smp_mflags} -C %{_target_platform}
87
88
89%install
90rm -rf $RPM_BUILD_ROOT
91make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
92
93
94%check
95desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/avogadro.desktop
96# all of these currently require an active X session, so will fail
97# in mock
98%{?ENABLE_TESTS:make test -C %{_target_platform} ||:}
99
100
101%post libs -p /sbin/ldconfig
102
103%postun libs -p /sbin/ldconfig
104
105%files
106%defattr(-,root,root,-)
107%doc AUTHORS ChangeLog COPYING
108%{_bindir}/avogadro
109%{_bindir}/avopkg
110# TODO: %lang'ify stuff under %%{_datadir}/avogadro/i18n/
111%{_datadir}/avogadro/
112%{_datadir}/pixmaps/avogadro-icon.png
113%{_datadir}/applications/avogadro.desktop
114%{_mandir}/man1/avogadro.1*
115%{_mandir}/man1/avopkg.1*
116
117%files devel
118%defattr(-,root,root,-)
119%{_includedir}/avogadro/
120%{_libdir}/libavogadro.so
121%{_libdir}/avogadro/*.cmake
122%{_libdir}/avogadro/1_0/*.cmake
123# these look like dups of system copies?, take a closer look and/or ask upstream -- Rex
124%{_libdir}/avogadro/1_0/cmake/
125%{_qt4_prefix}/mkspecs/features/avogadro.prf
126
127%files libs
128%defattr(-,root,root,-)
129%{python_sitearch}/Avogadro.so
130%{_datadir}/libavogadro/
131%{_libdir}/libavogadro.so.*
132%dir %{_libdir}/avogadro/
133%dir %{_libdir}/avogadro/1_0/
134%{_libdir}/avogadro/1_0/colors/
135%{_libdir}/avogadro/1_0/extensions/
136%{_libdir}/avogadro/1_0/engines/
137%{_libdir}/avogadro/1_0/tools/
138
139
140%changelog
141* Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.3-1
142- update to 1.0.3
143- remove old patches
144- add Patch0 (avogadro-1.0.3-mkspecs-dir.patch) from fedora
145
146* Sun Jul 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-13
147- rebuild with qt4-4.8.5
148
149* Sun Oct 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-12
150- rebuild with qt4-4.8.3
151
152* Tue Sep 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-11
153- rebuild with qt4-4.8.2
154
155* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-10
156- rebuild with python-2.7.2
157
158* Tue Jan 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-9
159- rebuild with qt4-4.8.0 and glew-1.7.0
160
161* Wed Mar  9 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-8
162- rebuilt with qt4-4.7.2
163- BR: qt4-tools instead of qt4-designer
164
165* Sun Feb 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-7
166- added BR: libboost-python
167- added R: glew-devel, eigen2-devel to devel package
168
169* Wed Feb 23 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-6
170- rebuilt with qt4-4.7.1
171- added Patch0 and 1 from Fedora
172
173* Tue Jan 18 2011 Shu KONNO <owa@bg.wakwak.com> - 1.0.1-5
174- rebuilt with libboost-1.45.0
175
176* Fri Aug 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-4
177- Initial build for Vine Linux
178
179* Wed Aug 04 2010 Rahul Sundaram <sundaram@fedoraproject.org> - 1.0.1-3
180- Rebuild for Boost soname bump
181- Update to match current guidelines
182
183* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 1.0.1-2
184- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
185
186* Mon May 24 2010 Rex Dieter <rdieter@fedoraproject.org> - 1.0.1-1
187- avogadro-1.0.1
188- -devel: move cmake-related files here
189- -devel: Req: qt4-devel
190- %%files: track lib sonames
191- %%check section
192
193* Wed Feb 10 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1.0.0-6
194- reenable plugin builds and libs subpackage
195- fix their build with sip 4.10
196
197* Fri Jan 08 2010 Sebastian Dziallas <sebastian@when.com> - 1.0.0-5
198- disable plugin builds and libs subpackage
199
200* Thu Jan 07 2010 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-4
201- rebuild (sip)
202
203* Mon Nov 23 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-3
204- rebuild (for qt-4.6.0-rc1, f13+)
205
206* Mon Nov 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-2
207- -libs: Requires: sip-api(%%_sip_api_major) >= %%_sip_api (#538124)
208- Requires: %%{name}-libs ...
209
210* Thu Oct 29 2009 Sebastian Dziallas <sebastian@when.com> 1.0.0-1
211- update to new upstream release
212
213* Tue Oct 20 2009 Rex Dieter <rdieter@fedoraproject.org> 0.9.8-3
214- rebuild (eigen2)
215
216* Sat Sep 26 2009 Sebastian Dziallas <sebastian@when.com> 0.9.8-2
217- fix typo in file list
218
219* Sat Sep 26 2009 Sebastian Dziallas <sebastian@when.com> 0.9.8-1
220- update to new upstream release
221- enable python and glsl support again
222
223* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.6-2
224- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
225
226* Sat Jun 06 2009 Sebastian Dziallas <sebastian@when.com> 0.9.6-1
227- new upstream release to fix issue with qt 4.5.0 and earlier
228
229* Wed Jun 03 2009 Sebastian Dziallas <sebastian@when.com> 0.9.5-3
230- remove remaining python parts
231- fix files section finally
232
233* Wed Jun 03 2009 Sebastian Dziallas <sebastian@when.com> 0.9.5-2
234- disable python and glsl for now
235- fix files section
236
237* Wed Jun 03 2009 Sebastian Dziallas <sebastian@when.com> 0.9.5-1
238- update to new release
239
240* Tue May 12 2009 Sebastian Dziallas <sebastian@when.com> 0.9.4-1
241- update to new release
242
243* Fri Apr 10 2009 Sebastian Dziallas <sebastian@when.com> 0.9.3-1
244- update to new release
245
246* Sat Mar 21 2009 Sebastian Dziallas <sebastian@when.com> 0.9.2-2
247- get desktop file properly installed
248
249* Sat Mar 14 2009 Sebastian Dziallas <sebastian@when.com> 0.9.2-1
250- update to new release
251
252* Wed Feb 25 2009 Sebastian Dziallas <sebastian@when.com> 0.9.1-1
253- update to new release
254
255* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.0-2
256- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
257
258* Thu Jan 22 2009 Sebastian Dziallas <sebastian@when.com> 0.9.0-1
259- update to new release
260
261* Sun Sep 14 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-6
262- add handbook to docs
263
264* Sun Sep 14 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-5
265- add build requirements and fix group names
266
267* Wed Aug 13 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-4
268- fix typos
269
270* Sat Aug  9 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-3
271- reorganize spec file
272
273* Sat Aug  9 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-2
274- rename shared library package and structure spec file
275
276* Sun Aug  3 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-1
277- initial pacakging release based on PackMan release
Note: See TracBrowser for help on using the repository browser.