source: projects/specs/trunk/a/avogadro/avogadro-vl.spec @ 9222

Revision 9222, 8.3 KB checked in by Takemikaduchi, 9 years ago (diff)

R: rebuild
openbabel: add BR
k3b: new upstream release
others: KDE-4.14.3

Line 
1%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.7.2)
2%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt-%{qt4_ver})
3
4%define ENABLE_TESTS -DENABLE_TESTS:BOOL=ON
5
6Name:           avogadro
7Summary:        An advanced molecular editor for chemical purposes
8Version:        1.1.1
9Release:        1%{?_dist_release}
10
11Group:          Applications/Editors
12License:        GPLv2
13URL:            http://avogadro.openmolecules.net/
14
15Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
16
17Patch0:                 avogadro-1.0.3-mkspecs-dir.patch
18
19BuildRequires:  cmake >= 2.6.0
20BuildRequires:  qt4-devel >= 4.5.1
21BuildRequires:  qt4-tools
22BuildRequires:  eigen2-devel >= 2.0.3
23BuildRequires:  openbabel-devel >= 2.2.2
24BuildRequires:  libboost-devel >= 1.35
25BuildRequires:  libboost-python >= 1.35
26BuildRequires:  glew-devel >= 1.5.0
27BuildRequires:  desktop-file-utils
28BuildRequires:  docbook-utils
29BuildRequires:  sip-devel >= 4.11
30BuildRequires:  numpy
31
32Requires: %{name}-libs = %{version}-%{release}
33
34%description
35An advanced molecular editor designed for
36cross-platform use in computational chemistry,
37molecular modeling, bioinformatics, materials science,
38and related areas, which offers flexible rendering and
39a powerful plugin architecture.
40
41
42%package libs
43Summary: Shared libraries for Avogadro
44Summary(ja): Avogadro の共用ライブラリ
45Group: System Environment/Libraries
46Requires: sip
47
48%description libs
49This package contains the shared libraries for the
50molecular editor Avogadro.
51
52
53%package devel
54Summary: Development files for Avogadro
55Summary(ja): Avogadro の開発用ファイル
56Group: Development/Libraries
57Requires: %{name}-libs = %{version}-%{release}
58Requires: qt4-devel = %{_qt4_version}
59Requires: eigen2-devel >= 2.0.3
60Requires: glew-devel >= 1.5.0
61Requires: pkgconfig
62
63%description devel
64This package contains files to develop applications using
65Avogadros libraries.
66
67
68%prep
69%setup -q
70%patch0 -p1 -b .mkspecs-dir
71
72
73%build
74mkdir -p %{_target_platform}
75pushd %{_target_platform}
76%cmake -Wno-dev \
77    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
78    -DBIN_INSTALL_DIR:PATH=bin \
79    -DLIB_INSTALL_DIR:PATH=%{_lib} \
80    -DENABLE_GLSL:BOOL=ON \
81    -DENABLE_PYTHON:BOOL=ON \
82    -DENABLE_RPATH:BOOL=OFF \
83    -DENABLE_VERSIONED_PLUGIN_DIR:BOOL=OFF \
84    %{?ENABLE_TESTS} ..
85popd
86make %{?_smp_mflags} -C %{_target_platform}
87
88
89%install
90rm -rf $RPM_BUILD_ROOT
91make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
92
93
94%check
95desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/avogadro.desktop
96# all of these currently require an active X session, so will fail
97# in mock
98%{?ENABLE_TESTS:make test -C %{_target_platform} ||:}
99
100
101%post libs -p /sbin/ldconfig
102
103%postun libs -p /sbin/ldconfig
104
105%files
106%defattr(-,root,root,-)
107%doc AUTHORS ChangeLog COPYING
108%{_bindir}/avogadro
109%{_bindir}/avopkg
110# TODO: %lang'ify stuff under %%{_datadir}/avogadro/i18n/
111%{_datadir}/avogadro/
112%{_datadir}/pixmaps/avogadro-icon.png
113%{_datadir}/applications/avogadro.desktop
114%{_mandir}/man1/avogadro.1*
115%{_mandir}/man1/avopkg.1*
116
117%files devel
118%defattr(-,root,root,-)
119%{_includedir}/avogadro/
120%{_libdir}/libavogadro.so
121%{_libdir}/libavogadro_OpenQube.so
122%{_libdir}/avogadro/*.cmake
123%{_libdir}/avogadro/cmake/
124%{_libdir}/pkgconfig/avogadro.pc
125%{_qt4_prefix}/mkspecs/features/avogadro.prf
126
127%files libs
128%defattr(-,root,root,-)
129%{python_sitearch}/Avogadro.so
130%{_datadir}/libavogadro/
131%{_libdir}/libavogadro.so.*
132%{_libdir}/libavogadro_OpenQube.so.*
133%dir %{_libdir}/avogadro/
134%{_libdir}/avogadro/colors/
135%{_libdir}/avogadro/extensions/
136%{_libdir}/avogadro/engines/
137%{_libdir}/avogadro/tools/
138
139
140%changelog
141* Thu Jan 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.1.1-1
142- update to 1.1.1
143
144* Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.3-1
145- update to 1.0.3
146- remove old patches
147- add Patch0 (avogadro-1.0.3-mkspecs-dir.patch) from fedora
148
149* Sun Jul 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-13
150- rebuild with qt4-4.8.5
151
152* Sun Oct 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-12
153- rebuild with qt4-4.8.3
154
155* Tue Sep 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-11
156- rebuild with qt4-4.8.2
157
158* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-10
159- rebuild with python-2.7.2
160
161* Tue Jan 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-9
162- rebuild with qt4-4.8.0 and glew-1.7.0
163
164* Wed Mar  9 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-8
165- rebuilt with qt4-4.7.2
166- BR: qt4-tools instead of qt4-designer
167
168* Sun Feb 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-7
169- added BR: libboost-python
170- added R: glew-devel, eigen2-devel to devel package
171
172* Wed Feb 23 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-6
173- rebuilt with qt4-4.7.1
174- added Patch0 and 1 from Fedora
175
176* Tue Jan 18 2011 Shu KONNO <owa@bg.wakwak.com> - 1.0.1-5
177- rebuilt with libboost-1.45.0
178
179* Fri Aug 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-4
180- Initial build for Vine Linux
181
182* Wed Aug 04 2010 Rahul Sundaram <sundaram@fedoraproject.org> - 1.0.1-3
183- Rebuild for Boost soname bump
184- Update to match current guidelines
185
186* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 1.0.1-2
187- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
188
189* Mon May 24 2010 Rex Dieter <rdieter@fedoraproject.org> - 1.0.1-1
190- avogadro-1.0.1
191- -devel: move cmake-related files here
192- -devel: Req: qt4-devel
193- %%files: track lib sonames
194- %%check section
195
196* Wed Feb 10 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1.0.0-6
197- reenable plugin builds and libs subpackage
198- fix their build with sip 4.10
199
200* Fri Jan 08 2010 Sebastian Dziallas <sebastian@when.com> - 1.0.0-5
201- disable plugin builds and libs subpackage
202
203* Thu Jan 07 2010 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-4
204- rebuild (sip)
205
206* Mon Nov 23 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-3
207- rebuild (for qt-4.6.0-rc1, f13+)
208
209* Mon Nov 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-2
210- -libs: Requires: sip-api(%%_sip_api_major) >= %%_sip_api (#538124)
211- Requires: %%{name}-libs ...
212
213* Thu Oct 29 2009 Sebastian Dziallas <sebastian@when.com> 1.0.0-1
214- update to new upstream release
215
216* Tue Oct 20 2009 Rex Dieter <rdieter@fedoraproject.org> 0.9.8-3
217- rebuild (eigen2)
218
219* Sat Sep 26 2009 Sebastian Dziallas <sebastian@when.com> 0.9.8-2
220- fix typo in file list
221
222* Sat Sep 26 2009 Sebastian Dziallas <sebastian@when.com> 0.9.8-1
223- update to new upstream release
224- enable python and glsl support again
225
226* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.6-2
227- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
228
229* Sat Jun 06 2009 Sebastian Dziallas <sebastian@when.com> 0.9.6-1
230- new upstream release to fix issue with qt 4.5.0 and earlier
231
232* Wed Jun 03 2009 Sebastian Dziallas <sebastian@when.com> 0.9.5-3
233- remove remaining python parts
234- fix files section finally
235
236* Wed Jun 03 2009 Sebastian Dziallas <sebastian@when.com> 0.9.5-2
237- disable python and glsl for now
238- fix files section
239
240* Wed Jun 03 2009 Sebastian Dziallas <sebastian@when.com> 0.9.5-1
241- update to new release
242
243* Tue May 12 2009 Sebastian Dziallas <sebastian@when.com> 0.9.4-1
244- update to new release
245
246* Fri Apr 10 2009 Sebastian Dziallas <sebastian@when.com> 0.9.3-1
247- update to new release
248
249* Sat Mar 21 2009 Sebastian Dziallas <sebastian@when.com> 0.9.2-2
250- get desktop file properly installed
251
252* Sat Mar 14 2009 Sebastian Dziallas <sebastian@when.com> 0.9.2-1
253- update to new release
254
255* Wed Feb 25 2009 Sebastian Dziallas <sebastian@when.com> 0.9.1-1
256- update to new release
257
258* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.0-2
259- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
260
261* Thu Jan 22 2009 Sebastian Dziallas <sebastian@when.com> 0.9.0-1
262- update to new release
263
264* Sun Sep 14 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-6
265- add handbook to docs
266
267* Sun Sep 14 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-5
268- add build requirements and fix group names
269
270* Wed Aug 13 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-4
271- fix typos
272
273* Sat Aug  9 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-3
274- reorganize spec file
275
276* Sat Aug  9 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-2
277- rename shared library package and structure spec file
278
279* Sun Aug  3 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-1
280- initial pacakging release based on PackMan release
Note: See TracBrowser for help on using the repository browser.