source: projects/specs/trunk/a/avogadro/avogadro-vl.spec @ 11355

Revision 11355, 9.0 KB checked in by ara_t, 6 years ago (diff)

rebuild under libboost-1.66.0

Line 
1%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.7.2)
2%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt-%{qt4_ver})
3
4%define ENABLE_TESTS -DENABLE_TESTS:BOOL=ON
5
6Name:           avogadro
7Summary:        An advanced molecular editor for chemical purposes
8Version:        1.1.1
9Release:        5%{?_dist_release}
10
11Group:          Applications/Editors
12License:        GPLv2
13URL:            http://avogadro.openmolecules.net/
14
15Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
16
17Patch0:                 avogadro-1.0.3-mkspecs-dir.patch
18Patch1:                 avogadro-1.1.1-cmake-3.x.patch
19Patch2:                 avogadro-1.1.1-Q_MOC_RUN.patch
20Patch3:                 avogadro-1.1.1-python_openbabel.patch
21
22BuildRequires:  cmake >= 2.6.0
23BuildRequires:  qt4-devel >= 4.5.1
24BuildRequires:  qt4-tools
25BuildRequires:  eigen2-devel >= 2.0.3
26BuildRequires:  openbabel-devel >= 2.2.2
27BuildRequires:  libboost-devel >= 1.35
28BuildRequires:  libboost-python >= 1.35
29BuildRequires:  glew-devel >= 1.5.0
30BuildRequires:  desktop-file-utils
31BuildRequires:  docbook-utils
32BuildRequires:  sip-devel >= 4.11
33BuildRequires:  numpy
34
35Requires: %{name}-libs = %{version}-%{release}
36
37%description
38An advanced molecular editor designed for
39cross-platform use in computational chemistry,
40molecular modeling, bioinformatics, materials science,
41and related areas, which offers flexible rendering and
42a powerful plugin architecture.
43
44
45%package libs
46Summary: Shared libraries for Avogadro
47Summary(ja): Avogadro の共用ライブラリ
48Group: System Environment/Libraries
49Requires: sip
50
51%description libs
52This package contains the shared libraries for the
53molecular editor Avogadro.
54
55
56%package devel
57Summary: Development files for Avogadro
58Summary(ja): Avogadro の開発用ファイル
59Group: Development/Libraries
60Requires: %{name}-libs = %{version}-%{release}
61Requires: qt4-devel = %{_qt4_version}
62Requires: eigen2-devel >= 2.0.3
63Requires: glew-devel >= 1.5.0
64Requires: pkgconfig
65
66%description devel
67This package contains files to develop applications using
68Avogadros libraries.
69
70
71%prep
72%setup -q
73%patch0 -p1 -b .mkspecs-dir
74%patch1 -p1 -b .cmake3x
75%patch2 -p1 -b .Q_MOC_RUN
76%patch3 -p1 -b .python_openbabel
77
78
79%build
80mkdir -p %{_target_platform}
81pushd %{_target_platform}
82%cmake -Wno-dev \
83    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
84    -DBIN_INSTALL_DIR:PATH=bin \
85    -DLIB_INSTALL_DIR:PATH=%{_lib} \
86    -DENABLE_GLSL:BOOL=ON \
87    -DENABLE_PYTHON:BOOL=ON \
88    -DENABLE_RPATH:BOOL=OFF \
89    -DENABLE_VERSIONED_PLUGIN_DIR:BOOL=OFF \
90    %{?ENABLE_TESTS} ..
91popd
92make %{?_smp_mflags} -C %{_target_platform}
93
94
95%install
96rm -rf $RPM_BUILD_ROOT
97make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
98
99
100%check
101desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/avogadro.desktop
102# all of these currently require an active X session, so will fail
103# in mock
104%{?ENABLE_TESTS:make test -C %{_target_platform} ||:}
105
106
107%post libs -p /sbin/ldconfig
108
109%postun libs -p /sbin/ldconfig
110
111%files
112%defattr(-,root,root,-)
113%doc AUTHORS ChangeLog COPYING
114%{_bindir}/avogadro
115%{_bindir}/avopkg
116# TODO: %lang'ify stuff under %%{_datadir}/avogadro/i18n/
117%{_datadir}/avogadro/
118%{_datadir}/pixmaps/avogadro-icon.png
119%{_datadir}/applications/avogadro.desktop
120%{_mandir}/man1/avogadro.1*
121%{_mandir}/man1/avopkg.1*
122
123%files devel
124%defattr(-,root,root,-)
125%{_includedir}/avogadro/
126%{_libdir}/libavogadro.so
127%{_libdir}/libavogadro_OpenQube.so
128%{_libdir}/avogadro/*.cmake
129%{_libdir}/avogadro/cmake/
130%{_libdir}/pkgconfig/avogadro.pc
131%{_qt4_prefix}/mkspecs/features/avogadro.prf
132
133%files libs
134%defattr(-,root,root,-)
135%{python_sitearch}/Avogadro.so
136%{_datadir}/libavogadro/
137%{_libdir}/libavogadro.so.*
138%{_libdir}/libavogadro_OpenQube.so.*
139%dir %{_libdir}/avogadro/
140%{_libdir}/avogadro/colors/
141%{_libdir}/avogadro/extensions/
142%{_libdir}/avogadro/engines/
143%{_libdir}/avogadro/tools/
144
145
146%changelog
147* Mon Jan 08 2018 Toshiaki Ara <ara_t@384.jp> - 1.1.1-5
148- rebuild with libboost-1.66.0
149
150* Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.1.1-4
151- rebuild with gcc-5.4.0
152- add patches from fc
153  - Patch2 (avogadro-1.1.1-Q_MOC_RUN.patch)
154  - Patch3 (avogadro-1.1.1-python_openbabel.patch)
155
156* Thu May 12 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.1.1-3
157- rebuild with qt4-4.8.7
158- add Patch1 (avogadro-1.1.1-cmake-3.x.patch)
159
160* Thu Oct 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.1.1-2
161- rebuild with glew-1.13.0
162
163* Thu Jan 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.1.1-1
164- update to 1.1.1
165
166* Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.3-1
167- update to 1.0.3
168- remove old patches
169- add Patch0 (avogadro-1.0.3-mkspecs-dir.patch) from fedora
170
171* Sun Jul 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-13
172- rebuild with qt4-4.8.5
173
174* Sun Oct 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-12
175- rebuild with qt4-4.8.3
176
177* Tue Sep 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-11
178- rebuild with qt4-4.8.2
179
180* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-10
181- rebuild with python-2.7.2
182
183* Tue Jan 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-9
184- rebuild with qt4-4.8.0 and glew-1.7.0
185
186* Wed Mar  9 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-8
187- rebuilt with qt4-4.7.2
188- BR: qt4-tools instead of qt4-designer
189
190* Sun Feb 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-7
191- added BR: libboost-python
192- added R: glew-devel, eigen2-devel to devel package
193
194* Wed Feb 23 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-6
195- rebuilt with qt4-4.7.1
196- added Patch0 and 1 from Fedora
197
198* Tue Jan 18 2011 Shu KONNO <owa@bg.wakwak.com> - 1.0.1-5
199- rebuilt with libboost-1.45.0
200
201* Fri Aug 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-4
202- Initial build for Vine Linux
203
204* Wed Aug 04 2010 Rahul Sundaram <sundaram@fedoraproject.org> - 1.0.1-3
205- Rebuild for Boost soname bump
206- Update to match current guidelines
207
208* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 1.0.1-2
209- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
210
211* Mon May 24 2010 Rex Dieter <rdieter@fedoraproject.org> - 1.0.1-1
212- avogadro-1.0.1
213- -devel: move cmake-related files here
214- -devel: Req: qt4-devel
215- %%files: track lib sonames
216- %%check section
217
218* Wed Feb 10 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1.0.0-6
219- reenable plugin builds and libs subpackage
220- fix their build with sip 4.10
221
222* Fri Jan 08 2010 Sebastian Dziallas <sebastian@when.com> - 1.0.0-5
223- disable plugin builds and libs subpackage
224
225* Thu Jan 07 2010 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-4
226- rebuild (sip)
227
228* Mon Nov 23 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-3
229- rebuild (for qt-4.6.0-rc1, f13+)
230
231* Mon Nov 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-2
232- -libs: Requires: sip-api(%%_sip_api_major) >= %%_sip_api (#538124)
233- Requires: %%{name}-libs ...
234
235* Thu Oct 29 2009 Sebastian Dziallas <sebastian@when.com> 1.0.0-1
236- update to new upstream release
237
238* Tue Oct 20 2009 Rex Dieter <rdieter@fedoraproject.org> 0.9.8-3
239- rebuild (eigen2)
240
241* Sat Sep 26 2009 Sebastian Dziallas <sebastian@when.com> 0.9.8-2
242- fix typo in file list
243
244* Sat Sep 26 2009 Sebastian Dziallas <sebastian@when.com> 0.9.8-1
245- update to new upstream release
246- enable python and glsl support again
247
248* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.6-2
249- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
250
251* Sat Jun 06 2009 Sebastian Dziallas <sebastian@when.com> 0.9.6-1
252- new upstream release to fix issue with qt 4.5.0 and earlier
253
254* Wed Jun 03 2009 Sebastian Dziallas <sebastian@when.com> 0.9.5-3
255- remove remaining python parts
256- fix files section finally
257
258* Wed Jun 03 2009 Sebastian Dziallas <sebastian@when.com> 0.9.5-2
259- disable python and glsl for now
260- fix files section
261
262* Wed Jun 03 2009 Sebastian Dziallas <sebastian@when.com> 0.9.5-1
263- update to new release
264
265* Tue May 12 2009 Sebastian Dziallas <sebastian@when.com> 0.9.4-1
266- update to new release
267
268* Fri Apr 10 2009 Sebastian Dziallas <sebastian@when.com> 0.9.3-1
269- update to new release
270
271* Sat Mar 21 2009 Sebastian Dziallas <sebastian@when.com> 0.9.2-2
272- get desktop file properly installed
273
274* Sat Mar 14 2009 Sebastian Dziallas <sebastian@when.com> 0.9.2-1
275- update to new release
276
277* Wed Feb 25 2009 Sebastian Dziallas <sebastian@when.com> 0.9.1-1
278- update to new release
279
280* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.0-2
281- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
282
283* Thu Jan 22 2009 Sebastian Dziallas <sebastian@when.com> 0.9.0-1
284- update to new release
285
286* Sun Sep 14 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-6
287- add handbook to docs
288
289* Sun Sep 14 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-5
290- add build requirements and fix group names
291
292* Wed Aug 13 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-4
293- fix typos
294
295* Sat Aug  9 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-3
296- reorganize spec file
297
298* Sat Aug  9 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-2
299- rename shared library package and structure spec file
300
301* Sun Aug  3 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-1
302- initial pacakging release based on PackMan release
Note: See TracBrowser for help on using the repository browser.