source: projects/specs/trunk/a/avogadro/avogadro-vl.spec @ 2763

Revision 2763, 7.5 KB checked in by inagaki, 13 years ago (diff)

update: avogadro

Line 
1%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.7.1)
2%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt-%{qt4_ver})
3
4%define ENABLE_TESTS -DENABLE_TESTS:BOOL=ON
5
6Name:           avogadro
7Summary:        An advanced molecular editor for chemical purposes
8Version:        1.0.1
9Release:        6%{?_dist_release}
10
11Group:          Applications/Editors
12License:        GPLv2
13URL:            http://avogadro.openmolecules.net/
14
15Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
16# fix FTBFS with SIP 4.11 (Gentoo#335644)
17# patch submitted: http://bugs.gentoo.org/attachment.cgi?id=247308 (upstream is
18# CCed on the Gentoo bug)
19Patch0:         avogadro-1.0.1-sip411.patch
20# fix crash with current SIP and Python 2.7 (#642248)
21Patch1:         avogadro-1.0.1-pycapsule.patch
22
23BuildRequires:  cmake >= 2.6.0
24BuildRequires:  qt4-designer >= 4.5.1
25BuildRequires:  qt4-devel >= 4.5.1
26BuildRequires:  eigen2-devel >= 2.0.3
27BuildRequires:  openbabel-devel >= 2.2.2
28BuildRequires:  libboost-devel >= 1.35
29BuildRequires:  glew-devel >= 1.5.0
30BuildRequires:  desktop-file-utils
31BuildRequires:  docbook-utils
32BuildRequires:  sip-devel
33BuildRequires:  numpy
34
35Requires: %{name}-libs = %{version}-%{release}
36
37%description
38An advanced molecular editor designed for
39cross-platform use in computational chemistry,
40molecular modeling, bioinformatics, materials science,
41and related areas, which offers flexible rendering and
42a powerful plugin architecture.
43
44
45%package libs
46Summary: Shared libraries for Avogadro
47Group: System Environment/Libraries
48Requires: sip
49
50%description libs
51This package contains the shared libraries for the
52molecular editor Avogadro.
53
54
55%package devel
56Summary: Development files for Avogadro
57Group: Development/Libraries
58Requires: %{name}-libs = %{version}-%{release}
59Requires: qt4-devel = %{_qt4_version}
60
61%description devel
62This package contains files to develop applications using
63Avogadros libraries.
64
65
66%prep
67%setup -q
68%patch0 -p1 -b .sip411
69%patch1 -p1 -b .pycapsule
70
71# nuke unpatched copy, use working version included in cmake instead -- Rex
72rm -f cmake/modules/FindPythonLibs.cmake
73
74
75%build
76mkdir -p %{_target_platform}
77pushd %{_target_platform}
78cmake -Wno-dev \
79    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
80    -DBIN_INSTALL_DIR:PATH=bin \
81    -DLIB_INSTALL_DIR:PATH=%{_lib} \
82    -DENABLE_GLSL:BOOL=ON \
83    -DENABLE_PYTHON:BOOL=ON \
84    %{?ENABLE_TESTS} ..
85popd
86make %{?_smp_mflags} -C %{_target_platform}
87
88
89%install
90rm -rf $RPM_BUILD_ROOT
91make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
92
93
94%check
95desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/avogadro.desktop
96# all of these currently require an active X session, so will fail
97# in mock
98%{?ENABLE_TESTS:make test -C %{_target_platform} ||:}
99
100
101%post libs -p /sbin/ldconfig
102
103%postun libs -p /sbin/ldconfig
104
105%files
106%defattr(-,root,root,-)
107%doc AUTHORS ChangeLog COPYING
108%{_bindir}/avogadro
109%{_bindir}/avopkg
110# TODO: %lang'ify stuff under %%{_datadir}/avogadro/i18n/
111%{_datadir}/avogadro/
112%{_datadir}/pixmaps/avogadro-icon.png
113%{_datadir}/applications/avogadro.desktop
114%{_mandir}/man1/avogadro.1*
115%{_mandir}/man1/avopkg.1*
116
117%files devel
118%defattr(-,root,root,-)
119%{_includedir}/avogadro/
120%{_libdir}/libavogadro.so
121%{_libdir}/avogadro/*.cmake
122%{_libdir}/avogadro/1_0/*.cmake
123# these look like dups of system copies?, take a closer look and/or ask upstream -- Rex
124%{_libdir}/avogadro/1_0/cmake/
125%{_qt4_prefix}/mkspecs/features/avogadro.prf
126
127%files libs
128%defattr(-,root,root,-)
129%{python_sitelib}/Avogadro.so
130%{_datadir}/libavogadro/
131%{_libdir}/libavogadro.so.1*
132%dir %{_libdir}/avogadro/
133%dir %{_libdir}/avogadro/1_0/
134%{_libdir}/avogadro/1_0/colors/
135%{_libdir}/avogadro/1_0/extensions/
136%{_libdir}/avogadro/1_0/engines/
137%{_libdir}/avogadro/1_0/tools/
138
139
140%changelog
141* Wed Feb 23 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-6
142- rebuilt with qt4-4.7.1
143- added Patch0 and 1 from Fedora
144
145* Tue Jan 18 2011 Shu KONNO <owa@bg.wakwak.com> - 1.0.1-5
146- rebuilt with libboost-1.45.0
147
148* Fri Aug 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-4
149- Initial build for Vine Linux
150
151* Wed Aug 04 2010 Rahul Sundaram <sundaram@fedoraproject.org> - 1.0.1-3
152- Rebuild for Boost soname bump
153- Update to match current guidelines
154
155* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 1.0.1-2
156- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
157
158* Mon May 24 2010 Rex Dieter <rdieter@fedoraproject.org> - 1.0.1-1
159- avogadro-1.0.1
160- -devel: move cmake-related files here
161- -devel: Req: qt4-devel
162- %%files: track lib sonames
163- %%check section
164
165* Wed Feb 10 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1.0.0-6
166- reenable plugin builds and libs subpackage
167- fix their build with sip 4.10
168
169* Fri Jan 08 2010 Sebastian Dziallas <sebastian@when.com> - 1.0.0-5
170- disable plugin builds and libs subpackage
171
172* Thu Jan 07 2010 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-4
173- rebuild (sip)
174
175* Mon Nov 23 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-3
176- rebuild (for qt-4.6.0-rc1, f13+)
177
178* Mon Nov 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-2
179- -libs: Requires: sip-api(%%_sip_api_major) >= %%_sip_api (#538124)
180- Requires: %%{name}-libs ...
181
182* Thu Oct 29 2009 Sebastian Dziallas <sebastian@when.com> 1.0.0-1
183- update to new upstream release
184
185* Tue Oct 20 2009 Rex Dieter <rdieter@fedoraproject.org> 0.9.8-3
186- rebuild (eigen2)
187
188* Sat Sep 26 2009 Sebastian Dziallas <sebastian@when.com> 0.9.8-2
189- fix typo in file list
190
191* Sat Sep 26 2009 Sebastian Dziallas <sebastian@when.com> 0.9.8-1
192- update to new upstream release
193- enable python and glsl support again
194
195* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.6-2
196- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
197
198* Sat Jun 06 2009 Sebastian Dziallas <sebastian@when.com> 0.9.6-1
199- new upstream release to fix issue with qt 4.5.0 and earlier
200
201* Wed Jun 03 2009 Sebastian Dziallas <sebastian@when.com> 0.9.5-3
202- remove remaining python parts
203- fix files section finally
204
205* Wed Jun 03 2009 Sebastian Dziallas <sebastian@when.com> 0.9.5-2
206- disable python and glsl for now
207- fix files section
208
209* Wed Jun 03 2009 Sebastian Dziallas <sebastian@when.com> 0.9.5-1
210- update to new release
211
212* Tue May 12 2009 Sebastian Dziallas <sebastian@when.com> 0.9.4-1
213- update to new release
214
215* Fri Apr 10 2009 Sebastian Dziallas <sebastian@when.com> 0.9.3-1
216- update to new release
217
218* Sat Mar 21 2009 Sebastian Dziallas <sebastian@when.com> 0.9.2-2
219- get desktop file properly installed
220
221* Sat Mar 14 2009 Sebastian Dziallas <sebastian@when.com> 0.9.2-1
222- update to new release
223
224* Wed Feb 25 2009 Sebastian Dziallas <sebastian@when.com> 0.9.1-1
225- update to new release
226
227* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.0-2
228- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
229
230* Thu Jan 22 2009 Sebastian Dziallas <sebastian@when.com> 0.9.0-1
231- update to new release
232
233* Sun Sep 14 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-6
234- add handbook to docs
235
236* Sun Sep 14 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-5
237- add build requirements and fix group names
238
239* Wed Aug 13 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-4
240- fix typos
241
242* Sat Aug  9 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-3
243- reorganize spec file
244
245* Sat Aug  9 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-2
246- rename shared library package and structure spec file
247
248* Sun Aug  3 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-1
249- initial pacakging release based on PackMan release
Note: See TracBrowser for help on using the repository browser.