source: projects/specs/trunk/a/avogadro/avogadro-vl.spec @ 2529

Revision 2529, 7.0 KB checked in by owa, 13 years ago (diff)

rebuilt with libboost-1.45.0

Line 
1%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.6.3)
2%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt-%{qt4_ver})
3
4%define ENABLE_TESTS -DENABLE_TESTS:BOOL=ON
5
6Name:           avogadro
7Summary:        An advanced molecular editor for chemical purposes
8Version:        1.0.1
9Release:        5%{?_dist_release}
10
11Group:          Applications/Editors
12License:        GPLv2
13URL:            http://avogadro.openmolecules.net/
14Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
15
16BuildRequires:  cmake >= 2.6.0
17BuildRequires:  qt4-designer >= 4.5.1
18BuildRequires:  qt4-devel >= 4.5.1
19BuildRequires:  eigen2-devel >= 2.0.3
20BuildRequires:  openbabel-devel >= 2.2.2
21BuildRequires:  libboost-devel >= 1.35
22BuildRequires:  glew-devel >= 1.5.0
23BuildRequires:  desktop-file-utils
24BuildRequires:  docbook-utils
25BuildRequires:  sip-devel
26BuildRequires:  numpy
27
28Requires: %{name}-libs = %{version}-%{release}
29
30%description
31An advanced molecular editor designed for
32cross-platform use in computational chemistry,
33molecular modeling, bioinformatics, materials science,
34and related areas, which offers flexible rendering and
35a powerful plugin architecture.
36
37
38%package libs
39Summary: Shared libraries for Avogadro
40Group: System Environment/Libraries
41Requires: sip
42
43%description libs
44This package contains the shared libraries for the
45molecular editor Avogadro.
46
47
48%package devel
49Summary: Development files for Avogadro
50Group: Development/Libraries
51Requires: %{name}-libs = %{version}-%{release}
52Requires: qt4-devel
53
54%description devel
55This package contains files to develop applications using
56Avogadros libraries.
57
58
59%prep
60%setup -q
61
62# nuke unpatched copy, use working version included in cmake instead -- Rex
63rm -f cmake/modules/FindPythonLibs.cmake
64
65
66%build
67mkdir -p %{_target_platform}
68pushd %{_target_platform}
69cmake -Wno-dev \
70    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
71    -DBIN_INSTALL_DIR:PATH=bin \
72    -DLIB_INSTALL_DIR:PATH=%{_lib} \
73    -DENABLE_GLSL:BOOL=ON \
74    -DENABLE_PYTHON:BOOL=ON \
75    %{?ENABLE_TESTS} ..
76popd
77make %{?_smp_mflags} -C %{_target_platform}
78
79
80%install
81rm -rf $RPM_BUILD_ROOT
82make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
83
84
85%check
86desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/avogadro.desktop
87# all of these currently require an active X session, so will fail
88# in mock
89%{?ENABLE_TESTS:make test -C %{_target_platform} ||:}
90
91
92%post libs -p /sbin/ldconfig
93
94%postun libs -p /sbin/ldconfig
95
96%files
97%defattr(-,root,root,-)
98%doc AUTHORS ChangeLog COPYING
99%{_bindir}/avogadro
100%{_bindir}/avopkg
101# TODO: %lang'ify stuff under %%{_datadir}/avogadro/i18n/
102%{_datadir}/avogadro/
103%{_datadir}/pixmaps/avogadro-icon.png
104%{_datadir}/applications/avogadro.desktop
105%{_mandir}/man1/avogadro.1*
106%{_mandir}/man1/avopkg.1*
107
108%files devel
109%defattr(-,root,root,-)
110%{_includedir}/avogadro/
111%{_libdir}/libavogadro.so
112%{_libdir}/avogadro/*.cmake
113%{_libdir}/avogadro/1_0/*.cmake
114# these look like dups of system copies?, take a closer look and/or ask upstream -- Rex
115%{_libdir}/avogadro/1_0/cmake/
116%{_qt4_prefix}/mkspecs/features/avogadro.prf
117
118%files libs
119%defattr(-,root,root,-)
120%{python_sitelib}/Avogadro.so
121%{_datadir}/libavogadro/
122%{_libdir}/libavogadro.so.1*
123%dir %{_libdir}/avogadro/
124%dir %{_libdir}/avogadro/1_0/
125%{_libdir}/avogadro/1_0/colors/
126%{_libdir}/avogadro/1_0/extensions/
127%{_libdir}/avogadro/1_0/engines/
128%{_libdir}/avogadro/1_0/tools/
129
130
131%changelog
132* Tue Jan 18 2011 Shu KONNO <owa@bg.wakwak.com> - 1.0.1-5
133- rebuilt with libboost-1.45.0
134
135* Fri Aug 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-4
136- Initial build for Vine Linux
137
138* Wed Aug 04 2010 Rahul Sundaram <sundaram@fedoraproject.org> - 1.0.1-3
139- Rebuild for Boost soname bump
140- Update to match current guidelines
141
142* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 1.0.1-2
143- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
144
145* Mon May 24 2010 Rex Dieter <rdieter@fedoraproject.org> - 1.0.1-1
146- avogadro-1.0.1
147- -devel: move cmake-related files here
148- -devel: Req: qt4-devel
149- %%files: track lib sonames
150- %%check section
151
152* Wed Feb 10 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1.0.0-6
153- reenable plugin builds and libs subpackage
154- fix their build with sip 4.10
155
156* Fri Jan 08 2010 Sebastian Dziallas <sebastian@when.com> - 1.0.0-5
157- disable plugin builds and libs subpackage
158
159* Thu Jan 07 2010 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-4
160- rebuild (sip)
161
162* Mon Nov 23 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-3
163- rebuild (for qt-4.6.0-rc1, f13+)
164
165* Mon Nov 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-2
166- -libs: Requires: sip-api(%%_sip_api_major) >= %%_sip_api (#538124)
167- Requires: %%{name}-libs ...
168
169* Thu Oct 29 2009 Sebastian Dziallas <sebastian@when.com> 1.0.0-1
170- update to new upstream release
171
172* Tue Oct 20 2009 Rex Dieter <rdieter@fedoraproject.org> 0.9.8-3
173- rebuild (eigen2)
174
175* Sat Sep 26 2009 Sebastian Dziallas <sebastian@when.com> 0.9.8-2
176- fix typo in file list
177
178* Sat Sep 26 2009 Sebastian Dziallas <sebastian@when.com> 0.9.8-1
179- update to new upstream release
180- enable python and glsl support again
181
182* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.6-2
183- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
184
185* Sat Jun 06 2009 Sebastian Dziallas <sebastian@when.com> 0.9.6-1
186- new upstream release to fix issue with qt 4.5.0 and earlier
187
188* Wed Jun 03 2009 Sebastian Dziallas <sebastian@when.com> 0.9.5-3
189- remove remaining python parts
190- fix files section finally
191
192* Wed Jun 03 2009 Sebastian Dziallas <sebastian@when.com> 0.9.5-2
193- disable python and glsl for now
194- fix files section
195
196* Wed Jun 03 2009 Sebastian Dziallas <sebastian@when.com> 0.9.5-1
197- update to new release
198
199* Tue May 12 2009 Sebastian Dziallas <sebastian@when.com> 0.9.4-1
200- update to new release
201
202* Fri Apr 10 2009 Sebastian Dziallas <sebastian@when.com> 0.9.3-1
203- update to new release
204
205* Sat Mar 21 2009 Sebastian Dziallas <sebastian@when.com> 0.9.2-2
206- get desktop file properly installed
207
208* Sat Mar 14 2009 Sebastian Dziallas <sebastian@when.com> 0.9.2-1
209- update to new release
210
211* Wed Feb 25 2009 Sebastian Dziallas <sebastian@when.com> 0.9.1-1
212- update to new release
213
214* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.0-2
215- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
216
217* Thu Jan 22 2009 Sebastian Dziallas <sebastian@when.com> 0.9.0-1
218- update to new release
219
220* Sun Sep 14 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-6
221- add handbook to docs
222
223* Sun Sep 14 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-5
224- add build requirements and fix group names
225
226* Wed Aug 13 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-4
227- fix typos
228
229* Sat Aug  9 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-3
230- reorganize spec file
231
232* Sat Aug  9 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-2
233- rename shared library package and structure spec file
234
235* Sun Aug  3 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-1
236- initial pacakging release based on PackMan release
Note: See TracBrowser for help on using the repository browser.