source: projects/specs/trunk/a/avogadro/avogadro-vl.spec @ 1636

Revision 1636, 6.9 KB checked in by inagaki, 14 years ago (diff)

NEW: libktorrent, avogadro, numpy

Line 
1%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.6.3)
2%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt-%{qt4_ver})
3
4%define ENABLE_TESTS -DENABLE_TESTS:BOOL=ON
5
6Name:           avogadro
7Summary:        An advanced molecular editor for chemical purposes
8Version:        1.0.1
9Release:        4%{?_dist_release}
10
11Group:          Applications/Editors
12License:        GPLv2
13URL:            http://avogadro.openmolecules.net/
14Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
15
16BuildRequires:  cmake >= 2.6.0
17BuildRequires:  qt4-designer >= 4.5.1
18BuildRequires:  qt4-devel >= 4.5.1
19BuildRequires:  eigen2-devel >= 2.0.3
20BuildRequires:  openbabel-devel >= 2.2.2
21BuildRequires:  libboost-devel >= 1.35
22BuildRequires:  glew-devel >= 1.5.0
23BuildRequires:  desktop-file-utils
24BuildRequires:  docbook-utils
25BuildRequires:  sip-devel
26BuildRequires:  numpy
27
28Requires: %{name}-libs = %{version}-%{release}
29
30%description
31An advanced molecular editor designed for
32cross-platform use in computational chemistry,
33molecular modeling, bioinformatics, materials science,
34and related areas, which offers flexible rendering and
35a powerful plugin architecture.
36
37
38%package libs
39Summary: Shared libraries for Avogadro
40Group: System Environment/Libraries
41Requires: sip
42
43%description libs
44This package contains the shared libraries for the
45molecular editor Avogadro.
46
47
48%package devel
49Summary: Development files for Avogadro
50Group: Development/Libraries
51Requires: %{name}-libs = %{version}-%{release}
52Requires: qt4-devel
53
54%description devel
55This package contains files to develop applications using
56Avogadros libraries.
57
58
59%prep
60%setup -q
61
62# nuke unpatched copy, use working version included in cmake instead -- Rex
63rm -f cmake/modules/FindPythonLibs.cmake
64
65
66%build
67mkdir -p %{_target_platform}
68pushd %{_target_platform}
69cmake -Wno-dev \
70    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
71    -DBIN_INSTALL_DIR:PATH=bin \
72    -DLIB_INSTALL_DIR:PATH=%{_lib} \
73    -DENABLE_GLSL:BOOL=ON \
74    -DENABLE_PYTHON:BOOL=ON \
75    %{?ENABLE_TESTS} ..
76popd
77make %{?_smp_mflags} -C %{_target_platform}
78
79
80%install
81rm -rf $RPM_BUILD_ROOT
82make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
83
84
85%check
86desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/avogadro.desktop
87# all of these currently require an active X session, so will fail
88# in mock
89%{?ENABLE_TESTS:make test -C %{_target_platform} ||:}
90
91
92%post libs -p /sbin/ldconfig
93
94%postun libs -p /sbin/ldconfig
95
96%files
97%defattr(-,root,root,-)
98%doc AUTHORS ChangeLog COPYING
99%{_bindir}/avogadro
100%{_bindir}/avopkg
101# TODO: %lang'ify stuff under %%{_datadir}/avogadro/i18n/
102%{_datadir}/avogadro/
103%{_datadir}/pixmaps/avogadro-icon.png
104%{_datadir}/applications/avogadro.desktop
105%{_mandir}/man1/avogadro.1*
106%{_mandir}/man1/avopkg.1*
107
108%files devel
109%defattr(-,root,root,-)
110%{_includedir}/avogadro/
111%{_libdir}/libavogadro.so
112%{_libdir}/avogadro/*.cmake
113%{_libdir}/avogadro/1_0/*.cmake
114# these look like dups of system copies?, take a closer look and/or ask upstream -- Rex
115%{_libdir}/avogadro/1_0/cmake/
116%{_qt4_prefix}/mkspecs/features/avogadro.prf
117
118%files libs
119%defattr(-,root,root,-)
120%{python_sitelib}/Avogadro.so
121%{_datadir}/libavogadro/
122%{_libdir}/libavogadro.so.1*
123%dir %{_libdir}/avogadro/
124%dir %{_libdir}/avogadro/1_0/
125%{_libdir}/avogadro/1_0/colors/
126%{_libdir}/avogadro/1_0/extensions/
127%{_libdir}/avogadro/1_0/engines/
128%{_libdir}/avogadro/1_0/tools/
129
130
131%changelog
132* Fri Aug 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-4
133- Initial build for Vine Linux
134
135* Wed Aug 04 2010 Rahul Sundaram <sundaram@fedoraproject.org> - 1.0.1-3
136- Rebuild for Boost soname bump
137- Update to match current guidelines
138
139* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 1.0.1-2
140- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
141
142* Mon May 24 2010 Rex Dieter <rdieter@fedoraproject.org> - 1.0.1-1
143- avogadro-1.0.1
144- -devel: move cmake-related files here
145- -devel: Req: qt4-devel
146- %%files: track lib sonames
147- %%check section
148
149* Wed Feb 10 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1.0.0-6
150- reenable plugin builds and libs subpackage
151- fix their build with sip 4.10
152
153* Fri Jan 08 2010 Sebastian Dziallas <sebastian@when.com> - 1.0.0-5
154- disable plugin builds and libs subpackage
155
156* Thu Jan 07 2010 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-4
157- rebuild (sip)
158
159* Mon Nov 23 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-3
160- rebuild (for qt-4.6.0-rc1, f13+)
161
162* Mon Nov 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-2
163- -libs: Requires: sip-api(%%_sip_api_major) >= %%_sip_api (#538124)
164- Requires: %%{name}-libs ...
165
166* Thu Oct 29 2009 Sebastian Dziallas <sebastian@when.com> 1.0.0-1
167- update to new upstream release
168
169* Tue Oct 20 2009 Rex Dieter <rdieter@fedoraproject.org> 0.9.8-3
170- rebuild (eigen2)
171
172* Sat Sep 26 2009 Sebastian Dziallas <sebastian@when.com> 0.9.8-2
173- fix typo in file list
174
175* Sat Sep 26 2009 Sebastian Dziallas <sebastian@when.com> 0.9.8-1
176- update to new upstream release
177- enable python and glsl support again
178
179* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.6-2
180- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
181
182* Sat Jun 06 2009 Sebastian Dziallas <sebastian@when.com> 0.9.6-1
183- new upstream release to fix issue with qt 4.5.0 and earlier
184
185* Wed Jun 03 2009 Sebastian Dziallas <sebastian@when.com> 0.9.5-3
186- remove remaining python parts
187- fix files section finally
188
189* Wed Jun 03 2009 Sebastian Dziallas <sebastian@when.com> 0.9.5-2
190- disable python and glsl for now
191- fix files section
192
193* Wed Jun 03 2009 Sebastian Dziallas <sebastian@when.com> 0.9.5-1
194- update to new release
195
196* Tue May 12 2009 Sebastian Dziallas <sebastian@when.com> 0.9.4-1
197- update to new release
198
199* Fri Apr 10 2009 Sebastian Dziallas <sebastian@when.com> 0.9.3-1
200- update to new release
201
202* Sat Mar 21 2009 Sebastian Dziallas <sebastian@when.com> 0.9.2-2
203- get desktop file properly installed
204
205* Sat Mar 14 2009 Sebastian Dziallas <sebastian@when.com> 0.9.2-1
206- update to new release
207
208* Wed Feb 25 2009 Sebastian Dziallas <sebastian@when.com> 0.9.1-1
209- update to new release
210
211* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.0-2
212- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
213
214* Thu Jan 22 2009 Sebastian Dziallas <sebastian@when.com> 0.9.0-1
215- update to new release
216
217* Sun Sep 14 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-6
218- add handbook to docs
219
220* Sun Sep 14 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-5
221- add build requirements and fix group names
222
223* Wed Aug 13 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-4
224- fix typos
225
226* Sat Aug  9 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-3
227- reorganize spec file
228
229* Sat Aug  9 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-2
230- rename shared library package and structure spec file
231
232* Sun Aug  3 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-1
233- initial pacakging release based on PackMan release
Note: See TracBrowser for help on using the repository browser.