source: projects/specs/trunk/a/avogadro/avogadro-vl.spec @ 10288

Revision 10288, 8.6 KB checked in by Takemikaduchi, 8 years ago (diff)

task-all-codecs: remove xine-lib-esd
others: new upstream release

Line 
1%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.7.2)
2%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt-%{qt4_ver})
3
4%define ENABLE_TESTS -DENABLE_TESTS:BOOL=ON
5
6Name:           avogadro
7Summary:        An advanced molecular editor for chemical purposes
8Version:        1.1.1
9Release:        3%{?_dist_release}
10
11Group:          Applications/Editors
12License:        GPLv2
13URL:            http://avogadro.openmolecules.net/
14
15Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
16
17Patch0:                 avogadro-1.0.3-mkspecs-dir.patch
18Patch1:                 avogadro-1.1.1-cmake-3.x.patch
19
20BuildRequires:  cmake >= 2.6.0
21BuildRequires:  qt4-devel >= 4.5.1
22BuildRequires:  qt4-tools
23BuildRequires:  eigen2-devel >= 2.0.3
24BuildRequires:  openbabel-devel >= 2.2.2
25BuildRequires:  libboost-devel >= 1.35
26BuildRequires:  libboost-python >= 1.35
27BuildRequires:  glew-devel >= 1.5.0
28BuildRequires:  desktop-file-utils
29BuildRequires:  docbook-utils
30BuildRequires:  sip-devel >= 4.11
31BuildRequires:  numpy
32
33Requires: %{name}-libs = %{version}-%{release}
34
35%description
36An advanced molecular editor designed for
37cross-platform use in computational chemistry,
38molecular modeling, bioinformatics, materials science,
39and related areas, which offers flexible rendering and
40a powerful plugin architecture.
41
42
43%package libs
44Summary: Shared libraries for Avogadro
45Summary(ja): Avogadro の共用ライブラリ
46Group: System Environment/Libraries
47Requires: sip
48
49%description libs
50This package contains the shared libraries for the
51molecular editor Avogadro.
52
53
54%package devel
55Summary: Development files for Avogadro
56Summary(ja): Avogadro の開発用ファイル
57Group: Development/Libraries
58Requires: %{name}-libs = %{version}-%{release}
59Requires: qt4-devel = %{_qt4_version}
60Requires: eigen2-devel >= 2.0.3
61Requires: glew-devel >= 1.5.0
62Requires: pkgconfig
63
64%description devel
65This package contains files to develop applications using
66Avogadros libraries.
67
68
69%prep
70%setup -q
71%patch0 -p1 -b .mkspecs-dir
72%patch1 -p1 -b .cmake3x
73
74
75%build
76mkdir -p %{_target_platform}
77pushd %{_target_platform}
78%cmake -Wno-dev \
79    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
80    -DBIN_INSTALL_DIR:PATH=bin \
81    -DLIB_INSTALL_DIR:PATH=%{_lib} \
82    -DENABLE_GLSL:BOOL=ON \
83    -DENABLE_PYTHON:BOOL=ON \
84    -DENABLE_RPATH:BOOL=OFF \
85    -DENABLE_VERSIONED_PLUGIN_DIR:BOOL=OFF \
86    %{?ENABLE_TESTS} ..
87popd
88make %{?_smp_mflags} -C %{_target_platform}
89
90
91%install
92rm -rf $RPM_BUILD_ROOT
93make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
94
95
96%check
97desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/avogadro.desktop
98# all of these currently require an active X session, so will fail
99# in mock
100%{?ENABLE_TESTS:make test -C %{_target_platform} ||:}
101
102
103%post libs -p /sbin/ldconfig
104
105%postun libs -p /sbin/ldconfig
106
107%files
108%defattr(-,root,root,-)
109%doc AUTHORS ChangeLog COPYING
110%{_bindir}/avogadro
111%{_bindir}/avopkg
112# TODO: %lang'ify stuff under %%{_datadir}/avogadro/i18n/
113%{_datadir}/avogadro/
114%{_datadir}/pixmaps/avogadro-icon.png
115%{_datadir}/applications/avogadro.desktop
116%{_mandir}/man1/avogadro.1*
117%{_mandir}/man1/avopkg.1*
118
119%files devel
120%defattr(-,root,root,-)
121%{_includedir}/avogadro/
122%{_libdir}/libavogadro.so
123%{_libdir}/libavogadro_OpenQube.so
124%{_libdir}/avogadro/*.cmake
125%{_libdir}/avogadro/cmake/
126%{_libdir}/pkgconfig/avogadro.pc
127%{_qt4_prefix}/mkspecs/features/avogadro.prf
128
129%files libs
130%defattr(-,root,root,-)
131%{python_sitearch}/Avogadro.so
132%{_datadir}/libavogadro/
133%{_libdir}/libavogadro.so.*
134%{_libdir}/libavogadro_OpenQube.so.*
135%dir %{_libdir}/avogadro/
136%{_libdir}/avogadro/colors/
137%{_libdir}/avogadro/extensions/
138%{_libdir}/avogadro/engines/
139%{_libdir}/avogadro/tools/
140
141
142%changelog
143* Thu May 12 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.1.1-3
144- rebuild with qt4-4.8.7
145- add Patch1 (avogadro-1.1.1-cmake-3.x.patch)
146
147* Thu Oct 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.1.1-2
148- rebuild with glew-1.13.0
149
150* Thu Jan 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.1.1-1
151- update to 1.1.1
152
153* Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.3-1
154- update to 1.0.3
155- remove old patches
156- add Patch0 (avogadro-1.0.3-mkspecs-dir.patch) from fedora
157
158* Sun Jul 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-13
159- rebuild with qt4-4.8.5
160
161* Sun Oct 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-12
162- rebuild with qt4-4.8.3
163
164* Tue Sep 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-11
165- rebuild with qt4-4.8.2
166
167* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-10
168- rebuild with python-2.7.2
169
170* Tue Jan 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-9
171- rebuild with qt4-4.8.0 and glew-1.7.0
172
173* Wed Mar  9 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-8
174- rebuilt with qt4-4.7.2
175- BR: qt4-tools instead of qt4-designer
176
177* Sun Feb 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-7
178- added BR: libboost-python
179- added R: glew-devel, eigen2-devel to devel package
180
181* Wed Feb 23 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-6
182- rebuilt with qt4-4.7.1
183- added Patch0 and 1 from Fedora
184
185* Tue Jan 18 2011 Shu KONNO <owa@bg.wakwak.com> - 1.0.1-5
186- rebuilt with libboost-1.45.0
187
188* Fri Aug 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-4
189- Initial build for Vine Linux
190
191* Wed Aug 04 2010 Rahul Sundaram <sundaram@fedoraproject.org> - 1.0.1-3
192- Rebuild for Boost soname bump
193- Update to match current guidelines
194
195* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 1.0.1-2
196- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
197
198* Mon May 24 2010 Rex Dieter <rdieter@fedoraproject.org> - 1.0.1-1
199- avogadro-1.0.1
200- -devel: move cmake-related files here
201- -devel: Req: qt4-devel
202- %%files: track lib sonames
203- %%check section
204
205* Wed Feb 10 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1.0.0-6
206- reenable plugin builds and libs subpackage
207- fix their build with sip 4.10
208
209* Fri Jan 08 2010 Sebastian Dziallas <sebastian@when.com> - 1.0.0-5
210- disable plugin builds and libs subpackage
211
212* Thu Jan 07 2010 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-4
213- rebuild (sip)
214
215* Mon Nov 23 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-3
216- rebuild (for qt-4.6.0-rc1, f13+)
217
218* Mon Nov 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-2
219- -libs: Requires: sip-api(%%_sip_api_major) >= %%_sip_api (#538124)
220- Requires: %%{name}-libs ...
221
222* Thu Oct 29 2009 Sebastian Dziallas <sebastian@when.com> 1.0.0-1
223- update to new upstream release
224
225* Tue Oct 20 2009 Rex Dieter <rdieter@fedoraproject.org> 0.9.8-3
226- rebuild (eigen2)
227
228* Sat Sep 26 2009 Sebastian Dziallas <sebastian@when.com> 0.9.8-2
229- fix typo in file list
230
231* Sat Sep 26 2009 Sebastian Dziallas <sebastian@when.com> 0.9.8-1
232- update to new upstream release
233- enable python and glsl support again
234
235* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.6-2
236- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
237
238* Sat Jun 06 2009 Sebastian Dziallas <sebastian@when.com> 0.9.6-1
239- new upstream release to fix issue with qt 4.5.0 and earlier
240
241* Wed Jun 03 2009 Sebastian Dziallas <sebastian@when.com> 0.9.5-3
242- remove remaining python parts
243- fix files section finally
244
245* Wed Jun 03 2009 Sebastian Dziallas <sebastian@when.com> 0.9.5-2
246- disable python and glsl for now
247- fix files section
248
249* Wed Jun 03 2009 Sebastian Dziallas <sebastian@when.com> 0.9.5-1
250- update to new release
251
252* Tue May 12 2009 Sebastian Dziallas <sebastian@when.com> 0.9.4-1
253- update to new release
254
255* Fri Apr 10 2009 Sebastian Dziallas <sebastian@when.com> 0.9.3-1
256- update to new release
257
258* Sat Mar 21 2009 Sebastian Dziallas <sebastian@when.com> 0.9.2-2
259- get desktop file properly installed
260
261* Sat Mar 14 2009 Sebastian Dziallas <sebastian@when.com> 0.9.2-1
262- update to new release
263
264* Wed Feb 25 2009 Sebastian Dziallas <sebastian@when.com> 0.9.1-1
265- update to new release
266
267* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.0-2
268- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
269
270* Thu Jan 22 2009 Sebastian Dziallas <sebastian@when.com> 0.9.0-1
271- update to new release
272
273* Sun Sep 14 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-6
274- add handbook to docs
275
276* Sun Sep 14 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-5
277- add build requirements and fix group names
278
279* Wed Aug 13 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-4
280- fix typos
281
282* Sat Aug  9 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-3
283- reorganize spec file
284
285* Sat Aug  9 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-2
286- rename shared library package and structure spec file
287
288* Sun Aug  3 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-1
289- initial pacakging release based on PackMan release
Note: See TracBrowser for help on using the repository browser.