source: projects/specs/trunk/a/avogadro/avogadro-vl.spec @ 10568

Revision 10568, 9.0 KB checked in by Takemikaduchi, 8 years ago (diff)

grantlee: update to 0.5.1
others: rebuils with gcc-5.4.0

Line 
1%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.7.2)
2%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt-%{qt4_ver})
3
4%define ENABLE_TESTS -DENABLE_TESTS:BOOL=ON
5
6Name:           avogadro
7Summary:        An advanced molecular editor for chemical purposes
8Version:        1.1.1
9Release:        4%{?_dist_release}
10
11Group:          Applications/Editors
12License:        GPLv2
13URL:            http://avogadro.openmolecules.net/
14
15Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
16
17Patch0:                 avogadro-1.0.3-mkspecs-dir.patch
18Patch1:                 avogadro-1.1.1-cmake-3.x.patch
19Patch2:                 avogadro-1.1.1-Q_MOC_RUN.patch
20Patch3:                 avogadro-1.1.1-python_openbabel.patch
21
22BuildRequires:  cmake >= 2.6.0
23BuildRequires:  qt4-devel >= 4.5.1
24BuildRequires:  qt4-tools
25BuildRequires:  eigen2-devel >= 2.0.3
26BuildRequires:  openbabel-devel >= 2.2.2
27BuildRequires:  libboost-devel >= 1.35
28BuildRequires:  libboost-python >= 1.35
29BuildRequires:  glew-devel >= 1.5.0
30BuildRequires:  desktop-file-utils
31BuildRequires:  docbook-utils
32BuildRequires:  sip-devel >= 4.11
33BuildRequires:  numpy
34
35Requires: %{name}-libs = %{version}-%{release}
36
37%description
38An advanced molecular editor designed for
39cross-platform use in computational chemistry,
40molecular modeling, bioinformatics, materials science,
41and related areas, which offers flexible rendering and
42a powerful plugin architecture.
43
44
45%package libs
46Summary: Shared libraries for Avogadro
47Summary(ja): Avogadro の共用ライブラリ
48Group: System Environment/Libraries
49Requires: sip
50
51%description libs
52This package contains the shared libraries for the
53molecular editor Avogadro.
54
55
56%package devel
57Summary: Development files for Avogadro
58Summary(ja): Avogadro の開発用ファイル
59Group: Development/Libraries
60Requires: %{name}-libs = %{version}-%{release}
61Requires: qt4-devel = %{_qt4_version}
62Requires: eigen2-devel >= 2.0.3
63Requires: glew-devel >= 1.5.0
64Requires: pkgconfig
65
66%description devel
67This package contains files to develop applications using
68Avogadros libraries.
69
70
71%prep
72%setup -q
73%patch0 -p1 -b .mkspecs-dir
74%patch1 -p1 -b .cmake3x
75%patch2 -p1 -b .Q_MOC_RUN
76%patch3 -p1 -b .python_openbabel
77
78
79%build
80mkdir -p %{_target_platform}
81pushd %{_target_platform}
82%cmake -Wno-dev \
83    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
84    -DBIN_INSTALL_DIR:PATH=bin \
85    -DLIB_INSTALL_DIR:PATH=%{_lib} \
86    -DENABLE_GLSL:BOOL=ON \
87    -DENABLE_PYTHON:BOOL=ON \
88    -DENABLE_RPATH:BOOL=OFF \
89    -DENABLE_VERSIONED_PLUGIN_DIR:BOOL=OFF \
90    %{?ENABLE_TESTS} ..
91popd
92make %{?_smp_mflags} -C %{_target_platform}
93
94
95%install
96rm -rf $RPM_BUILD_ROOT
97make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
98
99
100%check
101desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/avogadro.desktop
102# all of these currently require an active X session, so will fail
103# in mock
104%{?ENABLE_TESTS:make test -C %{_target_platform} ||:}
105
106
107%post libs -p /sbin/ldconfig
108
109%postun libs -p /sbin/ldconfig
110
111%files
112%defattr(-,root,root,-)
113%doc AUTHORS ChangeLog COPYING
114%{_bindir}/avogadro
115%{_bindir}/avopkg
116# TODO: %lang'ify stuff under %%{_datadir}/avogadro/i18n/
117%{_datadir}/avogadro/
118%{_datadir}/pixmaps/avogadro-icon.png
119%{_datadir}/applications/avogadro.desktop
120%{_mandir}/man1/avogadro.1*
121%{_mandir}/man1/avopkg.1*
122
123%files devel
124%defattr(-,root,root,-)
125%{_includedir}/avogadro/
126%{_libdir}/libavogadro.so
127%{_libdir}/libavogadro_OpenQube.so
128%{_libdir}/avogadro/*.cmake
129%{_libdir}/avogadro/cmake/
130%{_libdir}/pkgconfig/avogadro.pc
131%{_qt4_prefix}/mkspecs/features/avogadro.prf
132
133%files libs
134%defattr(-,root,root,-)
135%{python_sitearch}/Avogadro.so
136%{_datadir}/libavogadro/
137%{_libdir}/libavogadro.so.*
138%{_libdir}/libavogadro_OpenQube.so.*
139%dir %{_libdir}/avogadro/
140%{_libdir}/avogadro/colors/
141%{_libdir}/avogadro/extensions/
142%{_libdir}/avogadro/engines/
143%{_libdir}/avogadro/tools/
144
145
146%changelog
147* Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.1.1-4
148- rebuild with gcc-5.4.0
149- add patches from fc
150  - Patch2 (avogadro-1.1.1-Q_MOC_RUN.patch)
151  - Patch3 (avogadro-1.1.1-python_openbabel.patch)
152
153* Thu May 12 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.1.1-3
154- rebuild with qt4-4.8.7
155- add Patch1 (avogadro-1.1.1-cmake-3.x.patch)
156
157* Thu Oct 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.1.1-2
158- rebuild with glew-1.13.0
159
160* Thu Jan 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.1.1-1
161- update to 1.1.1
162
163* Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.3-1
164- update to 1.0.3
165- remove old patches
166- add Patch0 (avogadro-1.0.3-mkspecs-dir.patch) from fedora
167
168* Sun Jul 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-13
169- rebuild with qt4-4.8.5
170
171* Sun Oct 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-12
172- rebuild with qt4-4.8.3
173
174* Tue Sep 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-11
175- rebuild with qt4-4.8.2
176
177* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-10
178- rebuild with python-2.7.2
179
180* Tue Jan 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-9
181- rebuild with qt4-4.8.0 and glew-1.7.0
182
183* Wed Mar  9 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-8
184- rebuilt with qt4-4.7.2
185- BR: qt4-tools instead of qt4-designer
186
187* Sun Feb 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-7
188- added BR: libboost-python
189- added R: glew-devel, eigen2-devel to devel package
190
191* Wed Feb 23 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-6
192- rebuilt with qt4-4.7.1
193- added Patch0 and 1 from Fedora
194
195* Tue Jan 18 2011 Shu KONNO <owa@bg.wakwak.com> - 1.0.1-5
196- rebuilt with libboost-1.45.0
197
198* Fri Aug 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-4
199- Initial build for Vine Linux
200
201* Wed Aug 04 2010 Rahul Sundaram <sundaram@fedoraproject.org> - 1.0.1-3
202- Rebuild for Boost soname bump
203- Update to match current guidelines
204
205* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 1.0.1-2
206- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
207
208* Mon May 24 2010 Rex Dieter <rdieter@fedoraproject.org> - 1.0.1-1
209- avogadro-1.0.1
210- -devel: move cmake-related files here
211- -devel: Req: qt4-devel
212- %%files: track lib sonames
213- %%check section
214
215* Wed Feb 10 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1.0.0-6
216- reenable plugin builds and libs subpackage
217- fix their build with sip 4.10
218
219* Fri Jan 08 2010 Sebastian Dziallas <sebastian@when.com> - 1.0.0-5
220- disable plugin builds and libs subpackage
221
222* Thu Jan 07 2010 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-4
223- rebuild (sip)
224
225* Mon Nov 23 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-3
226- rebuild (for qt-4.6.0-rc1, f13+)
227
228* Mon Nov 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-2
229- -libs: Requires: sip-api(%%_sip_api_major) >= %%_sip_api (#538124)
230- Requires: %%{name}-libs ...
231
232* Thu Oct 29 2009 Sebastian Dziallas <sebastian@when.com> 1.0.0-1
233- update to new upstream release
234
235* Tue Oct 20 2009 Rex Dieter <rdieter@fedoraproject.org> 0.9.8-3
236- rebuild (eigen2)
237
238* Sat Sep 26 2009 Sebastian Dziallas <sebastian@when.com> 0.9.8-2
239- fix typo in file list
240
241* Sat Sep 26 2009 Sebastian Dziallas <sebastian@when.com> 0.9.8-1
242- update to new upstream release
243- enable python and glsl support again
244
245* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.6-2
246- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
247
248* Sat Jun 06 2009 Sebastian Dziallas <sebastian@when.com> 0.9.6-1
249- new upstream release to fix issue with qt 4.5.0 and earlier
250
251* Wed Jun 03 2009 Sebastian Dziallas <sebastian@when.com> 0.9.5-3
252- remove remaining python parts
253- fix files section finally
254
255* Wed Jun 03 2009 Sebastian Dziallas <sebastian@when.com> 0.9.5-2
256- disable python and glsl for now
257- fix files section
258
259* Wed Jun 03 2009 Sebastian Dziallas <sebastian@when.com> 0.9.5-1
260- update to new release
261
262* Tue May 12 2009 Sebastian Dziallas <sebastian@when.com> 0.9.4-1
263- update to new release
264
265* Fri Apr 10 2009 Sebastian Dziallas <sebastian@when.com> 0.9.3-1
266- update to new release
267
268* Sat Mar 21 2009 Sebastian Dziallas <sebastian@when.com> 0.9.2-2
269- get desktop file properly installed
270
271* Sat Mar 14 2009 Sebastian Dziallas <sebastian@when.com> 0.9.2-1
272- update to new release
273
274* Wed Feb 25 2009 Sebastian Dziallas <sebastian@when.com> 0.9.1-1
275- update to new release
276
277* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.0-2
278- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
279
280* Thu Jan 22 2009 Sebastian Dziallas <sebastian@when.com> 0.9.0-1
281- update to new release
282
283* Sun Sep 14 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-6
284- add handbook to docs
285
286* Sun Sep 14 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-5
287- add build requirements and fix group names
288
289* Wed Aug 13 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-4
290- fix typos
291
292* Sat Aug  9 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-3
293- reorganize spec file
294
295* Sat Aug  9 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-2
296- rename shared library package and structure spec file
297
298* Sun Aug  3 2008 Sebastian Dziallas <sebastian@when.com> 0.8.1-1
299- initial pacakging release based on PackMan release
Note: See TracBrowser for help on using the repository browser.