source: projects/specs/trunk/a/authconfig/authconfig-vl.spec @ 8577

Revision 8577, 28.0 KB checked in by daisuke, 10 years ago (diff)

authconfig: re-add patch to remove selinux feature

Line 
1Summary: Command line tool for setting up authentication from network services
2Summary(ja): ネットワークサービスからの認証を設定するためのコマンドラインツール
3Name: authconfig
4Version: 6.2.8
5Release: 2%{?_dist_release}
6License: GPLv2+
7ExclusiveOS: Linux
8Group: System Environment/Base
9BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
10URL: https://fedorahosted.org/authconfig
11Source: https://fedorahosted.org/releases/a/u/%{name}/%{name}-%{version}.tar.bz2
12
13Patch10: authconfig-6.2.3-fprintd-pam.patch
14Patch11: authconfig-6.2.3-fix-broken-strings.patch
15
16# remove selinux staff
17Patch100: authconfig-6.2.8-noselinux.patch
18
19Requires: pam
20Conflicts: samba-common < 3.0, samba-client < 3.0
21Conflicts: nss_ldap < 254
22BuildRequires: glib2-devel, python >= 2.4.1, python-devel
23BuildRequires: desktop-file-utils, intltool, gettext, perl-XML-Parser
24
25%description
26Authconfig is a command line utility which can configure a workstation
27to use shadow (more secure) passwords.  Authconfig can also configure a
28system to be a client for certain networked user information and
29authentication schemes.
30
31%description -l ja
32authconfig はシャドウ(よりセキュリティーが高い)パスワードの設定をおこなう
33コマンドラインプログラムです。また、ネットワークを介したユーザ情報と認証
34サービスを利用するように設定することもできます。
35
36%package gtk
37Summary: Graphical tool for setting up authentication from network services
38Summary(ja): ネットワークサービスからの認証を設定するためのグラフィカルツール
39Group: System Environment/Base
40Requires: %{name} = %{version}-%{release}, pygtk2-libglade
41Requires: usermode-gtk
42
43%description gtk
44Authconfig-gtk is a GUI program which can configure a workstation
45to use shadow (more secure) passwords.  Authconfig-gtk can also configure
46a system to be a client for certain networked user information and
47authentication schemes.
48
49%prep
50%setup -q -n %{name}-%{version}
51%patch10 -p1
52%patch11 -p1
53%patch100 -p1
54
55%build
56CFLAGS="$RPM_OPT_FLAGS -fPIC"; export CFLAGS
57%configure
58make
59
60%install
61rm -rf $RPM_BUILD_ROOT
62make install DESTDIR=$RPM_BUILD_ROOT
63rm $RPM_BUILD_ROOT/%{_libdir}/python*/site-packages/acutilmodule.a
64rm $RPM_BUILD_ROOT/%{_libdir}/python*/site-packages/acutilmodule.la
65rm $RPM_BUILD_ROOT/%{_datadir}/%{name}/authconfig-tui.py
66ln -s authconfig.py $RPM_BUILD_ROOT/%{_datadir}/%{name}/authconfig-tui.py
67
68%find_lang %{name}
69find $RPM_BUILD_ROOT%{_datadir} -name "*.mo" | xargs ./utf8ify-mo
70
71%clean
72rm -rf $RPM_BUILD_ROOT
73
74%post
75authconfig --updateall --nostart &>/dev/null ||:
76
77%post gtk
78touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
79
80%postun gtk
81if [ $1 -eq 0 ] ; then
82    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
83    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
84fi
85
86%posttrans gtk
87gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
88
89%triggerin -- authconfig <= 6.2.3
90if [ ! -e %{_sysconfdir}/pam.d/postlogin-ac ]; then
91        authconfig --updateall --nostart >/dev/null 2>&1 || :
92fi
93if [ ! -e %{_sysconfdir}/pam.d/postlogin ]; then
94        cd %{_sysconfdir}/pam.d; \
95        ln -s postlogin-ac postlogin > /dev/null 2>&1 || :
96fi
97
98
99%files -f %{name}.lang
100%defattr(-,root,root,-)
101%doc COPYING NOTES TODO README.samba3
102%ghost %config(noreplace) %{_sysconfdir}/sysconfig/authconfig
103%ghost %config(noreplace) %{_sysconfdir}/pam.d/system-auth-ac
104%ghost %config(noreplace) %{_sysconfdir}/pam.d/password-auth-ac
105%ghost %config(noreplace) %{_sysconfdir}/pam.d/fingerprint-auth-ac
106%ghost %config(noreplace) %{_sysconfdir}/pam.d/smartcard-auth-ac
107%ghost %config(noreplace) %{_sysconfdir}/pam.d/postlogin-ac
108%{_bindir}/authconfig
109%{_bindir}/authconfig-tui
110%{_sbindir}/cacertdir_rehash
111%{_sbindir}/authconfig
112%{_sbindir}/authconfig-tui
113%{_mandir}/man8/*
114%{_mandir}/man5/*
115%{python_sitearch}/acutilmodule.so
116%dir %{_datadir}/%{name}
117%{_datadir}/%{name}/authconfig.py*
118%{_datadir}/%{name}/authconfig-tui.py*
119%{_datadir}/%{name}/authinfo.py*
120%{_datadir}/%{name}/shvfile.py*
121%{_datadir}/%{name}/dnsclient.py*
122%{_datadir}/%{name}/msgarea.py*
123%config(noreplace) %{_sysconfdir}/pam.d/authconfig
124%config(noreplace) %{_sysconfdir}/pam.d/authconfig-tui
125%config(noreplace) %{_sysconfdir}/security/console.apps/authconfig
126%config(noreplace) %{_sysconfdir}/security/console.apps/authconfig-tui
127%attr(700,root,root) %dir %{_localstatedir}/lib/%{name}
128
129%files gtk
130%defattr(-,root,root,-)
131%{_bindir}/authconfig-gtk
132%{_bindir}/system-config-authentication
133%{_sbindir}/authconfig-gtk
134%{_sbindir}/system-config-authentication
135%{_datadir}/%{name}/authconfig.glade
136%{_datadir}/%{name}/authconfig-gtk.py*
137%config(noreplace) %{_sysconfdir}/pam.d/authconfig-gtk
138%config(noreplace) %{_sysconfdir}/pam.d/system-config-authentication
139%config(noreplace) %{_sysconfdir}/security/console.apps/authconfig-gtk
140%config(noreplace) %{_sysconfdir}/security/console.apps/system-config-authentication
141%{_datadir}/applications/*
142%{_datadir}/icons/hicolor/*/*/*
143
144%changelog
145* Tue Jun 17 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 6.2.8-2
146- add Patch100 to remove selinux staff (again)
147
148* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.2.8-1
149- update to 6.2.8
150- remove Patch101 (authconfig-6.2.3-authinfo-vine.patch)
151
152* Sat Oct 13 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2.4-1
153- update to 6.2.4
154- run "authconfig --updateall --nostart" on %%post script
155
156* Tue Sep 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.2.3-1
157- update to 6.2.3
158- update Patch10 (authconfig-6.2.3-fprintd-pam.patch)
159- update Patch11 (authconfig-6.2.3-fix-broken-strings.patch)
160- add Patch101 (authconfig-6.2.3-authinfo-vine.patch)
161
162* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.4.10-6
163- rebuild with python-2.7.2
164
165* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 5.4.10-5
166- rebuilt with rpm-4.8.1-3
167
168* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 5.4.10-4
169- rebuilt with python-2.6.4
170
171* Sun Aug 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.10-3
172- update Patch11
173  - old patch does not fix problem on some environment..
174
175* Fri Aug 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.10-2
176- add Patch10
177  - Fingerprint auth requires fprintd-pam package not pam_fprintd
178- add Patch11 to fix broken help messages on some locale.
179
180* Wed May 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.10-1
181- new upstream release
182
183* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.4-1
184- new upstream release
185- historical changelogs are following:
186  * Tue Apr 05 2005 Shu KONNO <owa@bg.wakwak.com> 4.6.1-1vl4
187  - added authconfig-4.6.1-authinfo.patch, by HOTTA Michihide <hotta@net-newbie.com>
188  - added BuildRequires: desktop-file-utils
189  * Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 4.6.1-1vl3
190  - rebuilt with python-2.4.1-0vl1
191  * Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 4.6.1-1vl2
192  - rebuilt with python-2.3.3-0vl1
193  * Mon Apr 12 2004 Shu KONNO <owa@bg.wakwak.com> 4.6.1-1vl1.1
194  - rebuilt with python-2.3.3-0vl0.3 (for TestPkg)
195  * Sun Feb 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-1vl1
196  - updated to 4.6.1
197  - updated Patch0 and Source1
198  - rebuild with new toolchains
199  - Reqyires: glib2, BuildRequires: glib2-devel
200  * Sat Jul 06 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1.19-1vl2
201  - add vinized color palette
202  * Thu Jul 04 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1.19-1vl1
203  - rebuild for Vine Linux
204  - based on Red Hat Linux 7.2, merged with Vine Linux package.
205    * Thu Jun 28 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp>
206    - 3.0.3-1vl5
207    - change checkbox color
208    * Tue Dec 26 2000 Tomoya TAKA <tomoya@olive.plala.or.jp> 3.0.3-1vl4
209    - add %patch1 to fix mandir
210    * Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 3.0.3-1vl3
211    - build with gcc-2.95.3
212    - partially used rpmmacros
213    * Thu Jul 13 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
214    - 3.0.3-1vl2
215    - modified %files section to handle compressed man page
216    * Thu May 11 2000 Jun Nishii <jun@vinelinux.org>
217    - 3.0.3-1vl1
218    - build for Vine
219
220* Tue Aug  5 2008 Tomas Mraz <tmraz@redhat.com> - 5.4.4-1
221- do not call domainname when run with --nostart (#457697)
222
223* Fri Jun  6 2008 Tomas Mraz <tmraz@redhat.com> - 5.4.3-1
224- remove the --enableldapssl alias and add some help to GUI tooltips
225  to clear up some confusion (#220973)
226- add option --enablepreferdns to prefer DNS over NIS or WINS in
227  hostname resolution
228
229* Tue Apr  8 2008 Tomas Mraz <tmraz@redhat.com> - 5.4.2-1
230- read wins setting from nsswitch.conf correctly (#440459)
231- do not ignore --enablemd5/--disablemd5 options
232
233* Tue Mar 11 2008 Tomas Mraz <tmraz@redhat.com> - 5.4.1-1
234- fixed backup directory in Makefile and spec (#437040)
235
236* Mon Mar 10 2008 Tomas Mraz <tmraz@redhat.com> - 5.4.0-1
237- include config-util in console.apps files
238- add support for saving/restoring backups of configuration
239  files affected by authconfig (#433776)
240- improve the authconfig manual page (#432023, #432938)
241
242* Tue Jan 29 2008 Tomas Mraz <tmraz@redhat.com> - 5.3.21-1
243- correct the fix for bug #237956
244
245* Fri Jan 18 2008 Tomas Mraz <tmraz@redhat.com> - 5.3.20-1
246- update translations
247
248* Wed Jan  9 2008 Tomas Mraz <tmraz@redhat.com> - 5.3.19-1
249- support new sha256 and sha512 password hash algorithms
250- add support for pam_mkhomedir (#212790)
251- do not crash in authconfig --help (#237956) - thanks to Andy Shevchenko for
252  the idea how to fix that
253- setup password hash algorithm in /etc/login.defs (#218652)
254- update translations
255
256* Tue Sep 25 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.18-1
257- improve krb5.conf handling (#238766)
258
259* Fri Aug 24 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.17-1
260- remove obsolete pam_krb5afs support (#250704)
261- add support for pam_access (#251360)
262- update translations
263
264* Tue Aug 21 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.16-3
265- license tag fix
266
267* Thu Aug  9 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.16-2
268- require newt-python (#251359)
269
270* Wed Jul 25 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.16-1
271- add support for winbind offline login (#232955)
272
273* Wed Jul 18 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.15-1
274- dnsclient fixes by Simo Sorce
275- add Categories to .desktop file (#245868)
276- fixed traceback when calling joinDomain (#245374)
277- disable smart card action setting when gnome-screensaver
278  not installed (#209643)
279- do not change protocols and services in nsswitch.conf (#236669)
280
281* Tue Jun 12 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.14-1
282- authconfig.8 synopsis fixed (patch by Eric Raymond) (#220574)
283- drop explicit requirement on python version as it is now
284  generated automatically
285- improve writing /etc/samba/smb.conf (based on patch by
286  Simo Sorce)
287- merge changes upstream
288 
289* Fri May  4 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.13-4
290- local nis domain is obtained from sysconfig/network (#235927)
291- set "local authorization is sufficient" on by default
292
293* Thu Apr  5 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.13-3
294- minor changes and cleanups for merge review (#225293)
295
296* Mon Mar 19 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.13-2
297- nss_ldap is now in /usr/lib (#232975)
298
299* Tue Dec 12 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.13-1
300- another traceback in --probe and other fixes (#218874)
301- make smbRealm a default realm when appropriate (#219300)
302- added missing languages in LINGUAS
303
304* Wed Nov 29 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.12-1
305- when pam_krb5 auth fails with smartcard login don't enforce it
306  in the account stack (#214931)
307- updated translations (#216570)
308- winbind should be added only to user tables (#216862)
309
310* Fri Oct 20 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.11-1
311- fixed --smartcardaction command line option (#211552)
312
313* Fri Oct  6 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.10-1
314- fixed passwd PAM stack when PKCS11 enabled (#195960)
315- make authconfig --probe work again (#209676)
316
317* Mon Oct  2 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.9-1
318- updated translations (#207095)
319- correctly write pam_smb.conf with only one server specified (#208365)
320
321* Thu Sep 21 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.8-1
322- move options to another tab to fit on 800x600 screen (#207357)
323
324* Tue Sep 19 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.7-1
325- improve PAM setup for smart card login
326- support smart card login with kerberos (PKINIT)
327- add pam_pkcs11 to password PAM stack
328
329* Mon Sep  4 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.6-1
330- skip pam_unix for session for crond service
331- fixed a bug in saving when smartcard settings changed (#204838)
332- removed allow_ypbind setsebool as it is now handled in ypbind
333
334* Tue Aug 29 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.5-1
335- improve smart card related UI strings
336- removed possibility to set smart card type from authconfig-gtk
337  as only coolkey will be supported for now
338
339* Thu Aug 24 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.4-1
340- pass options given to authconfig-gtk to authconfig (#203955)
341
342* Sun Jul 23 2006 Ray Strode <rstrode@redhat.com> - 5.3.3-2
343- write out new "wait_for_card" config option if we're
344  forcing smart card authentication
345- add "use_uid" option to smart card pam_succeed_if line to
346  work around bug where pam_succeed_if checks user information
347  even in cases where the conditional doesn't depend on it.
348- remove unimplemented "logout" smart card removal action from
349  settings
350- remove unnecessary "card_only" argument
351
352* Fri Jul 21 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.3-1
353- don't start sceventd when smartcard login is enabled
354- improve pam config for smartcard login
355
356* Tue Jul 18 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.2-1
357- don't require pam_pkcs11 to run
358
359* Tue Jul 18 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.1-1
360- screensavers should be authenticated by smartcard too
361- add feature to download a CA certificate for LDAP from
362  an URL (#197103)
363- add pam_keyinit session module to the PAM configuration (#198638)
364
365* Fri Jul  7 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.0-1
366- added support for smartcard authentication
367- fixed parsing kerberos realms
368
369* Thu May 18 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.5-1
370- write ldap servers as URIs and not HOSTs (#191842)
371- fix a typo in --test output
372- updated summary, converted changelog to UTF-8
373
374* Fri May 12 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.4-1
375- added crond to the services restarted after firstboot (#187334)
376- when checking nscd status redirect output to /dev/null (#188555)
377
378* Tue Mar 21 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.3-1
379- make smb.conf and krb5.conf loading more robust (#185766)
380
381* Mon Feb 27 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.2-1
382- add try_first_pass option to pam_unix for better integration
383  with individual service configurations (#182350)
384- updated translations
385
386* Mon Feb 20 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.1-1
387- don't crash in TUI when some options aren't set (#182151)
388
389* Fri Feb  3 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.0-1
390- redesigned GUI (#178112)
391- added man page for system-config-ac (#179584)
392- disable authentication of system accounts by network services
393  by default, added option for changing that (#179009)
394- updated translations, new languages
395
396* Mon Jan  9 2006 Tomas Mraz <tmraz@redhat.com> - 5.1.2-1
397- fixed regression when saving nsswitch.conf
398
399* Fri Jan  6 2006 Tomas Mraz <tmraz@redhat.com> - 5.1.1-1
400- print warning if PAM module is missing when the PAM configuration
401  is saved (#168880)
402
403* Fri Dec 23 2005 Tomas Mraz <tmraz@redhat.com>
404- make child dialog preset code more robust (#176462)
405
406* Sat Dec 17 2005 Tomas Mraz <tmraz@redhat.com> - 5.1.0-1
407- update only configuration files which settings were modified (#72290)
408
409* Mon Dec  5 2005 Tomas Mraz <tmraz@redhat.com> - 5.0.4-1
410- don't ignore krb5realm command line option (#174838)
411- read dns_lookup_realm and dns_lookup_kdc values correctly
412- the PAM configuration is now written in system-auth-ac file
413  which is then symlinked from system-auth, the symlink is not
414  overwritten so local PAM configuration is now possible (#165342)
415
416* Mon Nov  7 2005 Tomas Mraz <tmraz@redhat.com> - 5.0.3-1
417- add symlinks to python scripts in sbindir
418- don't override nullok setting from system-auth (#96996)
419
420* Fri Oct 14 2005 Tomas Mraz <tmraz@redhat.com> - 5.0.2-1
421- authinfo-tui.py is now symlink
422- reword the CA certificate message (#154317)
423- use include instead of pam_stack in pam config
424- don't break yp.conf with multiple domains (#127306)
425
426* Mon Sep  5 2005 Tomas Mraz <tmraz@redhat.com> - 5.0.1-1
427- fixed a few errors catched by pychecker
428
429* Sat Sep  3 2005 Tomas Mraz <tmraz@redhat.com> - 5.0.0-1
430- C code completely rewritten in Python
431- some bugs fixed in the process (and no doubt new introduced)
432- TUI deprecated, opens only when run as authconfig-tui
433
434* Mon Jun 20 2005 Tomas Mraz <tmraz@redhat.com> - 4.6.13-1
435- set domain and ypserver option correctly when multiple servers
436  specified in kickstart (#159214)
437
438* Tue Apr 12 2005 Tomas Mraz <tmraz@redhat.com> - 4.6.12-1
439- replaced deprecated gtk.TRUE/FALSE (#153034)
440- updated translations
441
442* Mon Mar 14 2005 Tomas Mraz <tmraz@redhat.com>
443- propagate the --enablewinbindauth option to the configuration (#151018)
444
445* Fri Mar  4 2005 Tomas Mraz <tmraz@redhat.com> - 4.6.11-1
446- changed version propagation
447
448* Thu Mar  3 2005 Tomas Mraz <tmraz@redhat.com>
449- updated translations
450- fixed build on gcc4
451
452* Wed Feb 23 2005 Tomas Mraz <tmraz@redhat.com> - 4.6.10-1
453- updated translations
454
455* Thu Feb 10 2005 Tomas Mraz <tmraz@redhat.com> - 4.6.9-1
456- improved the code that writes tls_cacertdir to ldap.conf
457
458* Tue Jan 25 2005 Tomas Mraz <tmraz@redhat.com>
459- renamed functions in authconfigmodule to be more clear
460- implemented cacertdir for LDAP with TLS
461
462* Mon Jan 24 2005 Tomas Mraz <tmraz@redhat.com>
463- fixed a bug in authinfo_differs when called from python
464
465* Fri Dec 17 2004 Tomas Mraz <tmraz@redhat.com> - 4.6.8-1
466- add option for making local authorization sufficient for local users
467  this is attempt to 'solve/workaround' the problem with blocking local logins by
468  pulling out network cable (#115181)
469
470* Wed Dec 15 2004 Tomas Mraz <tmraz@redhat.com>
471- remove dependency on nscd
472- don't show warning messages when switching options off
473
474* Mon Dec  6 2004 Tomas Mraz <tmraz@redhat.com> - 4.6.7-1
475- updated translations
476- winbind in authconfig-gtk.py was setting the nsswitch.conf on the auth tab
477- use GtkComboBox instead of deprecated GtkOptionMenu
478- disable options with not installed binaries, remove unnecessary deps of
479  authconfig-gtk
480
481* Thu Nov 18 2004 Tomas Mraz <tmraz@redhat.com> - 4.6.6-1
482- merged patches from dist
483- fix versioning
484
485* Mon Nov  8 2004 Jeremy Katz <katzj@redhat.com> - 4.6.5-6
486- rebuild against python 2.4
487
488* Thu Oct 28 2004 Dan Walsh <dwalsh@redhat.com>
489- Fix setsebool patch to turn off boolean
490
491* Thu Oct 28 2004 Dan Walsh <dwalsh@redhat.com>
492- Add setsebool for NIS
493
494* Fri Oct 15 2004 Tomas Mraz <tmraz@redhat.com>
495- force broken_shadow option on network auth (#136760)
496
497* Fri Oct 15 2004 Tomas Mraz <tmraz@redhat.com>
498- force restart of autofs on firstboot call when using NIS (#133035, #124498)
499
500* Thu Oct 07 2004 Tomas Mraz <tmraz@redhat.com>
501- require python to install (#134654)
502
503* Mon Oct 04 2004 Jindrich Novy <jnovy@redhat.com> 4.6.5-1
504- updated translations from upstream
505- autogeneration of build stripts in prep phase
506
507* Thu Sep 30 2004 Jindrich Novy <jnovy@redhat.com>
508- fixed man page
509- added dependency on nscd
510
511* Wed Sep 29 2004 Jindrich Novy <jnovy@redhat.com> 4.6.4-6
512- regenerated build scripts
513
514* Wed Sep 29 2004 Jindrich Novy <jnovy@redhat.com> 4.6.4-5
515- fixed all po files to translate correctly messages with modified accelerators (#133742)
516- added translations for Arabic, Bulgarian and other languages (#133716, #133158)
517
518* Wed Sep 22 2004 Jindrich Novy <jnovy@redhat.com> 4.6.4-4
519- added "quiet" option to pam_success_if PAM module in sytem-auth (#133179)
520
521* Mon Sep 13 2004 Jindrich Novy <jnovy@redhat.com> 4.6.4-3
522- corrected package dependencies #132411
523- regenerated glade.strings.h #132369
524
525* Wed Aug 25 2004 Jindrich Novy <jnovy@redhat.com> 4.6.4-2
526- modified authconfig-gtk interface to fit lower resolution screens (#127175)
527- modified accelerators in authconfig-gtk (#125797)
528- updated package dependencies (#125306)
529
530* Tue Aug 24 2004 Jindrich Novy <jnovy@redhat.com>
531- updated configure scripts
532- warnfixes and minor hacks
533
534* Mon Jun  7 2004 Nalin Dahyabhai <nalin@redhat.com> 4.6.4-1
535- tweak account management to fix #55193 correctly
536- require anything we might want to run in the gui subpackage because it
537  doesn't warn about missing things and you don't have a terminal to see
538  error messages about missing commands
539- properly display the domain in the GUI join dialog (#124621)
540
541* Tue May 11 2004 Nalin Dahyabhai <nalin@redhat.com> 4.6.3-1
542- omit the "ads" or "rpc" when calling "net join", Samba's smarter now (#122802)
543- properly warn about missing "net" (samba-client) and libnss_winbind and
544  pam_winbind (samba-common) in text mode (#122802)
545
546* Wed Apr 21 2004 Nalin Dahyabhai <nalin@redhat.com> 4.6.2-1
547- learn all about pam_passwdqc
548- preserve arguments to pam_cracklib and pam_passwdqc
549- short-circuit PAM authorization checks for users with UID < 100
550- remove redhat-config-authentication as a way to invoke the GUI tool (#115977)
551
552* Fri Feb  6 2004 Nalin Dahyabhai <nalin@redhat.com> 4.6.1-1
553- fix man page: --enableldapssl should be --enableldaptls
554- make --enableldapssl an alias for --enableldaptls
555
556* Thu Jan  8 2004 Nalin Dahyabhai <nalin@redhat.com> 4.6-1
557- authconfig-gtk.py: require rhpl, which is required by the script (#104209)
558- both: require usermode (authconfig-gtk transitively), else leave a dangling
559  symlink (#104209)
560- the great redhat-config-authentication/system-config-authentication renaming,
561  as was foretold in the fedora-config-list archives
562
563* Wed Jan  7 2004 Nalin Dahyabhai <nalin@redhat.com>
564- preserve "compat" if it's used in /etc/nsswitch.conf
565
566* Tue Nov 18 2003 Nalin Dahyabhai <nalin@redhat.com> 4.4-1
567- add options for toggling krb5's use of DNS
568
569* Mon Nov 17 2003 Nalin Dahyabhai <nalin@redhat.com>
570- rework tui to include winbind options. there wasn't enough room in the old
571  dialog to include the important options, so the whole thing's been reworked
572
573* Thu Nov 13 2003 Nalin Dahyabhai <nalin@redhat.com>
574- conflict with older versions of samba which expect different configuration
575
576* Mon Nov 10 2003 Nalin Dahyabhai <nalin@redhat.com>
577- initial support for configuring winbind
578
579* Tue Oct 28 2003 Nalin Dahyabhai <nalin@redhat.com>
580- make pam_cracklib requisite instead of required in generated PAM configs
581
582* Wed Oct 22 2003 Bill Nottingham <notting@redhat.com> 4.3.8-1
583- rebuild with current translations
584
585* Thu Aug 21 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.7-2
586- make the tarball name include the release number
587
588* Thu Aug 21 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.7-1
589- authconfig-gtk: condrestart certain additional services if invoked with
590  the --firstboot flag (half of #91268, needs cooperating firstboot)
591- translation updates
592
593* Mon Jul  7 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.6-1
594- translation updates
595
596* Mon Jun 30 2003 Nalin Dahyabhai <nalin@redhat.com>
597- add 'redhat-config-authentication' as an alias for authconfig-gtk
598- make authconfig-gtk exec authconfig if gui startup fails and it looks like
599  we're connected to a tty
600
601* Thu Jun 05 2003 Elliot Lee <sopwith@redhat.com>
602- rebuilt
603
604* Mon May  5 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.5-1
605- translation updates
606- close unusable file descriptors if locking fails
607
608* Tue Feb 18 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.4-1
609- learn how to toggle defaults/crypt_style in /etc/libuser.conf (#79337)
610
611* Fri Feb  7 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.3-1
612- look in /lib64 for modules for nsswitch and PAM by default on
613  x86_64, ppc64, and s390x (#83049)
614
615* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
616- rebuilt
617 
618* Mon Nov  4 2002 Nalin Dahyabhai <nalin@redhat.com> 4.3.2-1
619- update translations
620- update copyright strings (only took 10 months!)
621
622* Wed Oct 23 2002 Nalin Dahyabhai <nalin@redhat.com> 4.3.1-1
623- require a version of PAM (0.75-43) which supports $ISA
624- use $ISA in our own PAM config files
625
626* Tue Oct 22 2002 Nalin Dahyabhai <nalin@redhat.com>
627- add $ISA to the name of the directory in which we expect PAMs to be stored
628
629* Fri Sep 20 2002 Nalin Dahyabhai <nalin@redhat.com> 4.3-1
630- build with -fPIC, necessary on some arches
631
632* Tue Sep  3 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.11-3
633- update translations
634
635* Thu Aug 29 2002 Trond Eivind Glomsrød <teg@redhat.com> 4.2.12-2
636- Update translations
637
638* Fri Aug 23 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.11-1
639- modify spacing and layout in authconfig-gtk
640
641* Thu Aug 15 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.10-4
642- translation updates
643- rebuild to pick up dependency changes
644
645* Mon Jul 29 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.10-3
646- include the userhelper configuration file
647- require sufficiently-new pam package in the gui subpackage
648
649* Fri Jul 26 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.10-2
650- actually include the icon in the package
651- translation updates
652
653* Tue Jul 23 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.10-1
654- use desktop-file-install (#69376)
655- include an icon for the menu item (#68577)
656
657* Wed Jul 17 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.9-2
658- own the pkgdatadir
659- pull in translation updates
660
661* Mon Jun  3 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.9-1
662- add --enable-experimental to enable some of that experimental code
663- add --enable-local to enable local policies
664- update translations
665
666* Thu May 30 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-7
667- use the current revision of python by default
668- get the intltool/gettext situation sorted out
669
670* Thu May 23 2002 Tim Powers <timp@redhat.com>
671- automated rebuild
672
673* Fri May  3 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-5
674- remove bogus buildrequires left over from when authconfig-gtk was C code
675- buildrequires python-devel in addition to python (to build the python module,
676  but we still need python to byte-compile the python script)
677
678* Thu Apr 18 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-4
679- add missing translations back in
680- convert .mo files at install-time
681
682* Mon Apr 15 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-3
683- refresh translations
684
685* Wed Apr 10 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-2
686- actually add the .desktop files
687
688* Tue Apr  9 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-1
689- refresh translations
690- destroy the python object correctly
691
692* Tue Mar 26 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.7-2
693- add the .desktop file
694
695* Mon Mar 25 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.7-1
696- rework the auth stack logic to require all applicable auth modules
697
698* Fri Mar  1 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.6-1
699- allow pam_krb5afs to be used for account management, too
700
701* Mon Feb 25 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.5-3
702- refresh translations
703
704* Fri Feb 22 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.5-2
705- refresh translations
706
707* Tue Feb 12 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.5-1
708- actually free authInfo structures when asked to
709- use pam_krb5's account management facilities
710- conflict with versions of pam_krb5 which don't offer account management
711
712* Mon Feb  4 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.4-1
713- add python bindings for the back-end
714- redo the gui so that it exercises the python bindings
715- take a shot at getting authconfig to work in a firstboot container
716
717* Thu Jan 31 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.3-4
718- rebuild again
719
720* Wed Jan 30 2002 Tim Powers <timp@redhat.com> 4.2.3-3
721- rebuilt against new glib
722
723* Wed Jan 23 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.3-2
724- rebuild in new environment
725
726* Thu Jan 10 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.3-1
727- add some more experimental options
728- clean up the glade files a bit
729- don't destroy a garbage pointer on main cancel, destroy the main dialog
730
731* Thu Jan  3 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.2-2
732- bump release and rebuild
733
734* Thu Dec 20 2001 Nalin Dahyabhai <nalin@redhat.com> 4.2.2-1
735- make setting of experimental options only possible through
736  /etc/sysconfig/authconfig, to keep accidents from happening
737- add some more support for experimental stuff
738
739* Tue Dec 11 2001 Nalin Dahyabhai <nalin@redhat.com> 4.2.1-1
740- fix setting of LDAP TLS option in authconfig-gtk
741- change Apply to Ok, Close to Cancel, because that's how they work
742
743* Tue Dec 11 2001 Nalin Dahyabhai <nalin@redhat.com> 4.2-2
744- add the glade XML file to the -gtk subpackage (fix from katzj)
745
746* Mon Dec 10 2001 Nalin Dahyabhai <nalin@redhat.com> 4.2-1
747- port to glib2
748- move post code to the back-end
749- add a libglade GUI in a -gtk subpackage
750- set up to use userhelper
Note: See TracBrowser for help on using the repository browser.