source: projects/specs/trunk/a/authconfig/authconfig-vl.spec @ 8353

Revision 8353, 27.8 KB checked in by Takemikaduchi, 10 years ago (diff)

GNOME-3.12.0

Line 
1Summary: Command line tool for setting up authentication from network services
2Summary(ja): ネットワークサービスからの認証を設定するためのコマンドラインツール
3Name: authconfig
4Version: 6.2.8
5Release: 1%{?_dist_release}
6License: GPLv2+
7ExclusiveOS: Linux
8Group: System Environment/Base
9BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
10URL: https://fedorahosted.org/authconfig
11Source: https://fedorahosted.org/releases/a/u/%{name}/%{name}-%{version}.tar.bz2
12
13Patch10: authconfig-6.2.3-fprintd-pam.patch
14Patch11: authconfig-6.2.3-fix-broken-strings.patch
15
16Requires: pam
17Conflicts: samba-common < 3.0, samba-client < 3.0
18Conflicts: nss_ldap < 254
19BuildRequires: glib2-devel, python >= 2.4.1, python-devel
20BuildRequires: desktop-file-utils, intltool, gettext, perl-XML-Parser
21
22%description
23Authconfig is a command line utility which can configure a workstation
24to use shadow (more secure) passwords.  Authconfig can also configure a
25system to be a client for certain networked user information and
26authentication schemes.
27
28%description -l ja
29authconfig はシャドウ(よりセキュリティーが高い)パスワードの設定をおこなう
30コマンドラインプログラムです。また、ネットワークを介したユーザ情報と認証
31サービスを利用するように設定することもできます。
32
33%package gtk
34Summary: Graphical tool for setting up authentication from network services
35Summary(ja): ネットワークサービスからの認証を設定するためのグラフィカルツール
36Group: System Environment/Base
37Requires: %{name} = %{version}-%{release}, pygtk2-libglade
38Requires: usermode-gtk
39
40%description gtk
41Authconfig-gtk is a GUI program which can configure a workstation
42to use shadow (more secure) passwords.  Authconfig-gtk can also configure
43a system to be a client for certain networked user information and
44authentication schemes.
45
46%prep
47%setup -q -n %{name}-%{version}
48%patch10 -p1
49%patch11 -p1
50
51%build
52CFLAGS="$RPM_OPT_FLAGS -fPIC"; export CFLAGS
53%configure
54make
55
56%install
57rm -rf $RPM_BUILD_ROOT
58make install DESTDIR=$RPM_BUILD_ROOT
59rm $RPM_BUILD_ROOT/%{_libdir}/python*/site-packages/acutilmodule.a
60rm $RPM_BUILD_ROOT/%{_libdir}/python*/site-packages/acutilmodule.la
61rm $RPM_BUILD_ROOT/%{_datadir}/%{name}/authconfig-tui.py
62ln -s authconfig.py $RPM_BUILD_ROOT/%{_datadir}/%{name}/authconfig-tui.py
63
64%find_lang %{name}
65find $RPM_BUILD_ROOT%{_datadir} -name "*.mo" | xargs ./utf8ify-mo
66
67%clean
68rm -rf $RPM_BUILD_ROOT
69
70%post
71authconfig --updateall --nostart &>/dev/null ||:
72
73%post gtk
74touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
75
76%postun gtk
77if [ $1 -eq 0 ] ; then
78    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
79    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
80fi
81
82%posttrans gtk
83gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
84
85%triggerin -- authconfig <= 6.2.3
86if [ ! -e %{_sysconfdir}/pam.d/postlogin-ac ]; then
87        authconfig --updateall --nostart >/dev/null 2>&1 || :
88fi
89if [ ! -e %{_sysconfdir}/pam.d/postlogin ]; then
90        cd %{_sysconfdir}/pam.d; \
91        ln -s postlogin-ac postlogin > /dev/null 2>&1 || :
92fi
93
94
95%files -f %{name}.lang
96%defattr(-,root,root,-)
97%doc COPYING NOTES TODO README.samba3
98%ghost %config(noreplace) %{_sysconfdir}/sysconfig/authconfig
99%ghost %config(noreplace) %{_sysconfdir}/pam.d/system-auth-ac
100%ghost %config(noreplace) %{_sysconfdir}/pam.d/password-auth-ac
101%ghost %config(noreplace) %{_sysconfdir}/pam.d/fingerprint-auth-ac
102%ghost %config(noreplace) %{_sysconfdir}/pam.d/smartcard-auth-ac
103%ghost %config(noreplace) %{_sysconfdir}/pam.d/postlogin-ac
104%{_bindir}/authconfig
105%{_bindir}/authconfig-tui
106%{_sbindir}/cacertdir_rehash
107%{_sbindir}/authconfig
108%{_sbindir}/authconfig-tui
109%{_mandir}/man8/*
110%{_mandir}/man5/*
111%{python_sitearch}/acutilmodule.so
112%dir %{_datadir}/%{name}
113%{_datadir}/%{name}/authconfig.py*
114%{_datadir}/%{name}/authconfig-tui.py*
115%{_datadir}/%{name}/authinfo.py*
116%{_datadir}/%{name}/shvfile.py*
117%{_datadir}/%{name}/dnsclient.py*
118%{_datadir}/%{name}/msgarea.py*
119%config(noreplace) %{_sysconfdir}/pam.d/authconfig
120%config(noreplace) %{_sysconfdir}/pam.d/authconfig-tui
121%config(noreplace) %{_sysconfdir}/security/console.apps/authconfig
122%config(noreplace) %{_sysconfdir}/security/console.apps/authconfig-tui
123%attr(700,root,root) %dir %{_localstatedir}/lib/%{name}
124
125%files gtk
126%defattr(-,root,root,-)
127%{_bindir}/authconfig-gtk
128%{_bindir}/system-config-authentication
129%{_sbindir}/authconfig-gtk
130%{_sbindir}/system-config-authentication
131%{_datadir}/%{name}/authconfig.glade
132%{_datadir}/%{name}/authconfig-gtk.py*
133%config(noreplace) %{_sysconfdir}/pam.d/authconfig-gtk
134%config(noreplace) %{_sysconfdir}/pam.d/system-config-authentication
135%config(noreplace) %{_sysconfdir}/security/console.apps/authconfig-gtk
136%config(noreplace) %{_sysconfdir}/security/console.apps/system-config-authentication
137%{_datadir}/applications/*
138%{_datadir}/icons/hicolor/*/*/*
139
140%changelog
141* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.2.8-1
142- update to 6.2.8
143- remove Patch101 (authconfig-6.2.3-authinfo-vine.patch)
144
145* Sat Oct 13 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2.4-1
146- update to 6.2.4
147- run "authconfig --updateall --nostart" on %%post script
148
149* Tue Sep 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.2.3-1
150- update to 6.2.3
151- update Patch10 (authconfig-6.2.3-fprintd-pam.patch)
152- update Patch11 (authconfig-6.2.3-fix-broken-strings.patch)
153- add Patch101 (authconfig-6.2.3-authinfo-vine.patch)
154
155* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.4.10-6
156- rebuild with python-2.7.2
157
158* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 5.4.10-5
159- rebuilt with rpm-4.8.1-3
160
161* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 5.4.10-4
162- rebuilt with python-2.6.4
163
164* Sun Aug 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.10-3
165- update Patch11
166  - old patch does not fix problem on some environment..
167
168* Fri Aug 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.10-2
169- add Patch10
170  - Fingerprint auth requires fprintd-pam package not pam_fprintd
171- add Patch11 to fix broken help messages on some locale.
172
173* Wed May 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.10-1
174- new upstream release
175
176* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.4-1
177- new upstream release
178- historical changelogs are following:
179  * Tue Apr 05 2005 Shu KONNO <owa@bg.wakwak.com> 4.6.1-1vl4
180  - added authconfig-4.6.1-authinfo.patch, by HOTTA Michihide <hotta@net-newbie.com>
181  - added BuildRequires: desktop-file-utils
182  * Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 4.6.1-1vl3
183  - rebuilt with python-2.4.1-0vl1
184  * Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 4.6.1-1vl2
185  - rebuilt with python-2.3.3-0vl1
186  * Mon Apr 12 2004 Shu KONNO <owa@bg.wakwak.com> 4.6.1-1vl1.1
187  - rebuilt with python-2.3.3-0vl0.3 (for TestPkg)
188  * Sun Feb 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-1vl1
189  - updated to 4.6.1
190  - updated Patch0 and Source1
191  - rebuild with new toolchains
192  - Reqyires: glib2, BuildRequires: glib2-devel
193  * Sat Jul 06 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1.19-1vl2
194  - add vinized color palette
195  * Thu Jul 04 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1.19-1vl1
196  - rebuild for Vine Linux
197  - based on Red Hat Linux 7.2, merged with Vine Linux package.
198    * Thu Jun 28 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp>
199    - 3.0.3-1vl5
200    - change checkbox color
201    * Tue Dec 26 2000 Tomoya TAKA <tomoya@olive.plala.or.jp> 3.0.3-1vl4
202    - add %patch1 to fix mandir
203    * Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 3.0.3-1vl3
204    - build with gcc-2.95.3
205    - partially used rpmmacros
206    * Thu Jul 13 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
207    - 3.0.3-1vl2
208    - modified %files section to handle compressed man page
209    * Thu May 11 2000 Jun Nishii <jun@vinelinux.org>
210    - 3.0.3-1vl1
211    - build for Vine
212
213* Tue Aug  5 2008 Tomas Mraz <tmraz@redhat.com> - 5.4.4-1
214- do not call domainname when run with --nostart (#457697)
215
216* Fri Jun  6 2008 Tomas Mraz <tmraz@redhat.com> - 5.4.3-1
217- remove the --enableldapssl alias and add some help to GUI tooltips
218  to clear up some confusion (#220973)
219- add option --enablepreferdns to prefer DNS over NIS or WINS in
220  hostname resolution
221
222* Tue Apr  8 2008 Tomas Mraz <tmraz@redhat.com> - 5.4.2-1
223- read wins setting from nsswitch.conf correctly (#440459)
224- do not ignore --enablemd5/--disablemd5 options
225
226* Tue Mar 11 2008 Tomas Mraz <tmraz@redhat.com> - 5.4.1-1
227- fixed backup directory in Makefile and spec (#437040)
228
229* Mon Mar 10 2008 Tomas Mraz <tmraz@redhat.com> - 5.4.0-1
230- include config-util in console.apps files
231- add support for saving/restoring backups of configuration
232  files affected by authconfig (#433776)
233- improve the authconfig manual page (#432023, #432938)
234
235* Tue Jan 29 2008 Tomas Mraz <tmraz@redhat.com> - 5.3.21-1
236- correct the fix for bug #237956
237
238* Fri Jan 18 2008 Tomas Mraz <tmraz@redhat.com> - 5.3.20-1
239- update translations
240
241* Wed Jan  9 2008 Tomas Mraz <tmraz@redhat.com> - 5.3.19-1
242- support new sha256 and sha512 password hash algorithms
243- add support for pam_mkhomedir (#212790)
244- do not crash in authconfig --help (#237956) - thanks to Andy Shevchenko for
245  the idea how to fix that
246- setup password hash algorithm in /etc/login.defs (#218652)
247- update translations
248
249* Tue Sep 25 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.18-1
250- improve krb5.conf handling (#238766)
251
252* Fri Aug 24 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.17-1
253- remove obsolete pam_krb5afs support (#250704)
254- add support for pam_access (#251360)
255- update translations
256
257* Tue Aug 21 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.16-3
258- license tag fix
259
260* Thu Aug  9 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.16-2
261- require newt-python (#251359)
262
263* Wed Jul 25 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.16-1
264- add support for winbind offline login (#232955)
265
266* Wed Jul 18 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.15-1
267- dnsclient fixes by Simo Sorce
268- add Categories to .desktop file (#245868)
269- fixed traceback when calling joinDomain (#245374)
270- disable smart card action setting when gnome-screensaver
271  not installed (#209643)
272- do not change protocols and services in nsswitch.conf (#236669)
273
274* Tue Jun 12 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.14-1
275- authconfig.8 synopsis fixed (patch by Eric Raymond) (#220574)
276- drop explicit requirement on python version as it is now
277  generated automatically
278- improve writing /etc/samba/smb.conf (based on patch by
279  Simo Sorce)
280- merge changes upstream
281 
282* Fri May  4 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.13-4
283- local nis domain is obtained from sysconfig/network (#235927)
284- set "local authorization is sufficient" on by default
285
286* Thu Apr  5 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.13-3
287- minor changes and cleanups for merge review (#225293)
288
289* Mon Mar 19 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.13-2
290- nss_ldap is now in /usr/lib (#232975)
291
292* Tue Dec 12 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.13-1
293- another traceback in --probe and other fixes (#218874)
294- make smbRealm a default realm when appropriate (#219300)
295- added missing languages in LINGUAS
296
297* Wed Nov 29 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.12-1
298- when pam_krb5 auth fails with smartcard login don't enforce it
299  in the account stack (#214931)
300- updated translations (#216570)
301- winbind should be added only to user tables (#216862)
302
303* Fri Oct 20 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.11-1
304- fixed --smartcardaction command line option (#211552)
305
306* Fri Oct  6 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.10-1
307- fixed passwd PAM stack when PKCS11 enabled (#195960)
308- make authconfig --probe work again (#209676)
309
310* Mon Oct  2 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.9-1
311- updated translations (#207095)
312- correctly write pam_smb.conf with only one server specified (#208365)
313
314* Thu Sep 21 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.8-1
315- move options to another tab to fit on 800x600 screen (#207357)
316
317* Tue Sep 19 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.7-1
318- improve PAM setup for smart card login
319- support smart card login with kerberos (PKINIT)
320- add pam_pkcs11 to password PAM stack
321
322* Mon Sep  4 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.6-1
323- skip pam_unix for session for crond service
324- fixed a bug in saving when smartcard settings changed (#204838)
325- removed allow_ypbind setsebool as it is now handled in ypbind
326
327* Tue Aug 29 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.5-1
328- improve smart card related UI strings
329- removed possibility to set smart card type from authconfig-gtk
330  as only coolkey will be supported for now
331
332* Thu Aug 24 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.4-1
333- pass options given to authconfig-gtk to authconfig (#203955)
334
335* Sun Jul 23 2006 Ray Strode <rstrode@redhat.com> - 5.3.3-2
336- write out new "wait_for_card" config option if we're
337  forcing smart card authentication
338- add "use_uid" option to smart card pam_succeed_if line to
339  work around bug where pam_succeed_if checks user information
340  even in cases where the conditional doesn't depend on it.
341- remove unimplemented "logout" smart card removal action from
342  settings
343- remove unnecessary "card_only" argument
344
345* Fri Jul 21 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.3-1
346- don't start sceventd when smartcard login is enabled
347- improve pam config for smartcard login
348
349* Tue Jul 18 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.2-1
350- don't require pam_pkcs11 to run
351
352* Tue Jul 18 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.1-1
353- screensavers should be authenticated by smartcard too
354- add feature to download a CA certificate for LDAP from
355  an URL (#197103)
356- add pam_keyinit session module to the PAM configuration (#198638)
357
358* Fri Jul  7 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.0-1
359- added support for smartcard authentication
360- fixed parsing kerberos realms
361
362* Thu May 18 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.5-1
363- write ldap servers as URIs and not HOSTs (#191842)
364- fix a typo in --test output
365- updated summary, converted changelog to UTF-8
366
367* Fri May 12 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.4-1
368- added crond to the services restarted after firstboot (#187334)
369- when checking nscd status redirect output to /dev/null (#188555)
370
371* Tue Mar 21 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.3-1
372- make smb.conf and krb5.conf loading more robust (#185766)
373
374* Mon Feb 27 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.2-1
375- add try_first_pass option to pam_unix for better integration
376  with individual service configurations (#182350)
377- updated translations
378
379* Mon Feb 20 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.1-1
380- don't crash in TUI when some options aren't set (#182151)
381
382* Fri Feb  3 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.0-1
383- redesigned GUI (#178112)
384- added man page for system-config-ac (#179584)
385- disable authentication of system accounts by network services
386  by default, added option for changing that (#179009)
387- updated translations, new languages
388
389* Mon Jan  9 2006 Tomas Mraz <tmraz@redhat.com> - 5.1.2-1
390- fixed regression when saving nsswitch.conf
391
392* Fri Jan  6 2006 Tomas Mraz <tmraz@redhat.com> - 5.1.1-1
393- print warning if PAM module is missing when the PAM configuration
394  is saved (#168880)
395
396* Fri Dec 23 2005 Tomas Mraz <tmraz@redhat.com>
397- make child dialog preset code more robust (#176462)
398
399* Sat Dec 17 2005 Tomas Mraz <tmraz@redhat.com> - 5.1.0-1
400- update only configuration files which settings were modified (#72290)
401
402* Mon Dec  5 2005 Tomas Mraz <tmraz@redhat.com> - 5.0.4-1
403- don't ignore krb5realm command line option (#174838)
404- read dns_lookup_realm and dns_lookup_kdc values correctly
405- the PAM configuration is now written in system-auth-ac file
406  which is then symlinked from system-auth, the symlink is not
407  overwritten so local PAM configuration is now possible (#165342)
408
409* Mon Nov  7 2005 Tomas Mraz <tmraz@redhat.com> - 5.0.3-1
410- add symlinks to python scripts in sbindir
411- don't override nullok setting from system-auth (#96996)
412
413* Fri Oct 14 2005 Tomas Mraz <tmraz@redhat.com> - 5.0.2-1
414- authinfo-tui.py is now symlink
415- reword the CA certificate message (#154317)
416- use include instead of pam_stack in pam config
417- don't break yp.conf with multiple domains (#127306)
418
419* Mon Sep  5 2005 Tomas Mraz <tmraz@redhat.com> - 5.0.1-1
420- fixed a few errors catched by pychecker
421
422* Sat Sep  3 2005 Tomas Mraz <tmraz@redhat.com> - 5.0.0-1
423- C code completely rewritten in Python
424- some bugs fixed in the process (and no doubt new introduced)
425- TUI deprecated, opens only when run as authconfig-tui
426
427* Mon Jun 20 2005 Tomas Mraz <tmraz@redhat.com> - 4.6.13-1
428- set domain and ypserver option correctly when multiple servers
429  specified in kickstart (#159214)
430
431* Tue Apr 12 2005 Tomas Mraz <tmraz@redhat.com> - 4.6.12-1
432- replaced deprecated gtk.TRUE/FALSE (#153034)
433- updated translations
434
435* Mon Mar 14 2005 Tomas Mraz <tmraz@redhat.com>
436- propagate the --enablewinbindauth option to the configuration (#151018)
437
438* Fri Mar  4 2005 Tomas Mraz <tmraz@redhat.com> - 4.6.11-1
439- changed version propagation
440
441* Thu Mar  3 2005 Tomas Mraz <tmraz@redhat.com>
442- updated translations
443- fixed build on gcc4
444
445* Wed Feb 23 2005 Tomas Mraz <tmraz@redhat.com> - 4.6.10-1
446- updated translations
447
448* Thu Feb 10 2005 Tomas Mraz <tmraz@redhat.com> - 4.6.9-1
449- improved the code that writes tls_cacertdir to ldap.conf
450
451* Tue Jan 25 2005 Tomas Mraz <tmraz@redhat.com>
452- renamed functions in authconfigmodule to be more clear
453- implemented cacertdir for LDAP with TLS
454
455* Mon Jan 24 2005 Tomas Mraz <tmraz@redhat.com>
456- fixed a bug in authinfo_differs when called from python
457
458* Fri Dec 17 2004 Tomas Mraz <tmraz@redhat.com> - 4.6.8-1
459- add option for making local authorization sufficient for local users
460  this is attempt to 'solve/workaround' the problem with blocking local logins by
461  pulling out network cable (#115181)
462
463* Wed Dec 15 2004 Tomas Mraz <tmraz@redhat.com>
464- remove dependency on nscd
465- don't show warning messages when switching options off
466
467* Mon Dec  6 2004 Tomas Mraz <tmraz@redhat.com> - 4.6.7-1
468- updated translations
469- winbind in authconfig-gtk.py was setting the nsswitch.conf on the auth tab
470- use GtkComboBox instead of deprecated GtkOptionMenu
471- disable options with not installed binaries, remove unnecessary deps of
472  authconfig-gtk
473
474* Thu Nov 18 2004 Tomas Mraz <tmraz@redhat.com> - 4.6.6-1
475- merged patches from dist
476- fix versioning
477
478* Mon Nov  8 2004 Jeremy Katz <katzj@redhat.com> - 4.6.5-6
479- rebuild against python 2.4
480
481* Thu Oct 28 2004 Dan Walsh <dwalsh@redhat.com>
482- Fix setsebool patch to turn off boolean
483
484* Thu Oct 28 2004 Dan Walsh <dwalsh@redhat.com>
485- Add setsebool for NIS
486
487* Fri Oct 15 2004 Tomas Mraz <tmraz@redhat.com>
488- force broken_shadow option on network auth (#136760)
489
490* Fri Oct 15 2004 Tomas Mraz <tmraz@redhat.com>
491- force restart of autofs on firstboot call when using NIS (#133035, #124498)
492
493* Thu Oct 07 2004 Tomas Mraz <tmraz@redhat.com>
494- require python to install (#134654)
495
496* Mon Oct 04 2004 Jindrich Novy <jnovy@redhat.com> 4.6.5-1
497- updated translations from upstream
498- autogeneration of build stripts in prep phase
499
500* Thu Sep 30 2004 Jindrich Novy <jnovy@redhat.com>
501- fixed man page
502- added dependency on nscd
503
504* Wed Sep 29 2004 Jindrich Novy <jnovy@redhat.com> 4.6.4-6
505- regenerated build scripts
506
507* Wed Sep 29 2004 Jindrich Novy <jnovy@redhat.com> 4.6.4-5
508- fixed all po files to translate correctly messages with modified accelerators (#133742)
509- added translations for Arabic, Bulgarian and other languages (#133716, #133158)
510
511* Wed Sep 22 2004 Jindrich Novy <jnovy@redhat.com> 4.6.4-4
512- added "quiet" option to pam_success_if PAM module in sytem-auth (#133179)
513
514* Mon Sep 13 2004 Jindrich Novy <jnovy@redhat.com> 4.6.4-3
515- corrected package dependencies #132411
516- regenerated glade.strings.h #132369
517
518* Wed Aug 25 2004 Jindrich Novy <jnovy@redhat.com> 4.6.4-2
519- modified authconfig-gtk interface to fit lower resolution screens (#127175)
520- modified accelerators in authconfig-gtk (#125797)
521- updated package dependencies (#125306)
522
523* Tue Aug 24 2004 Jindrich Novy <jnovy@redhat.com>
524- updated configure scripts
525- warnfixes and minor hacks
526
527* Mon Jun  7 2004 Nalin Dahyabhai <nalin@redhat.com> 4.6.4-1
528- tweak account management to fix #55193 correctly
529- require anything we might want to run in the gui subpackage because it
530  doesn't warn about missing things and you don't have a terminal to see
531  error messages about missing commands
532- properly display the domain in the GUI join dialog (#124621)
533
534* Tue May 11 2004 Nalin Dahyabhai <nalin@redhat.com> 4.6.3-1
535- omit the "ads" or "rpc" when calling "net join", Samba's smarter now (#122802)
536- properly warn about missing "net" (samba-client) and libnss_winbind and
537  pam_winbind (samba-common) in text mode (#122802)
538
539* Wed Apr 21 2004 Nalin Dahyabhai <nalin@redhat.com> 4.6.2-1
540- learn all about pam_passwdqc
541- preserve arguments to pam_cracklib and pam_passwdqc
542- short-circuit PAM authorization checks for users with UID < 100
543- remove redhat-config-authentication as a way to invoke the GUI tool (#115977)
544
545* Fri Feb  6 2004 Nalin Dahyabhai <nalin@redhat.com> 4.6.1-1
546- fix man page: --enableldapssl should be --enableldaptls
547- make --enableldapssl an alias for --enableldaptls
548
549* Thu Jan  8 2004 Nalin Dahyabhai <nalin@redhat.com> 4.6-1
550- authconfig-gtk.py: require rhpl, which is required by the script (#104209)
551- both: require usermode (authconfig-gtk transitively), else leave a dangling
552  symlink (#104209)
553- the great redhat-config-authentication/system-config-authentication renaming,
554  as was foretold in the fedora-config-list archives
555
556* Wed Jan  7 2004 Nalin Dahyabhai <nalin@redhat.com>
557- preserve "compat" if it's used in /etc/nsswitch.conf
558
559* Tue Nov 18 2003 Nalin Dahyabhai <nalin@redhat.com> 4.4-1
560- add options for toggling krb5's use of DNS
561
562* Mon Nov 17 2003 Nalin Dahyabhai <nalin@redhat.com>
563- rework tui to include winbind options. there wasn't enough room in the old
564  dialog to include the important options, so the whole thing's been reworked
565
566* Thu Nov 13 2003 Nalin Dahyabhai <nalin@redhat.com>
567- conflict with older versions of samba which expect different configuration
568
569* Mon Nov 10 2003 Nalin Dahyabhai <nalin@redhat.com>
570- initial support for configuring winbind
571
572* Tue Oct 28 2003 Nalin Dahyabhai <nalin@redhat.com>
573- make pam_cracklib requisite instead of required in generated PAM configs
574
575* Wed Oct 22 2003 Bill Nottingham <notting@redhat.com> 4.3.8-1
576- rebuild with current translations
577
578* Thu Aug 21 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.7-2
579- make the tarball name include the release number
580
581* Thu Aug 21 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.7-1
582- authconfig-gtk: condrestart certain additional services if invoked with
583  the --firstboot flag (half of #91268, needs cooperating firstboot)
584- translation updates
585
586* Mon Jul  7 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.6-1
587- translation updates
588
589* Mon Jun 30 2003 Nalin Dahyabhai <nalin@redhat.com>
590- add 'redhat-config-authentication' as an alias for authconfig-gtk
591- make authconfig-gtk exec authconfig if gui startup fails and it looks like
592  we're connected to a tty
593
594* Thu Jun 05 2003 Elliot Lee <sopwith@redhat.com>
595- rebuilt
596
597* Mon May  5 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.5-1
598- translation updates
599- close unusable file descriptors if locking fails
600
601* Tue Feb 18 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.4-1
602- learn how to toggle defaults/crypt_style in /etc/libuser.conf (#79337)
603
604* Fri Feb  7 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.3-1
605- look in /lib64 for modules for nsswitch and PAM by default on
606  x86_64, ppc64, and s390x (#83049)
607
608* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
609- rebuilt
610 
611* Mon Nov  4 2002 Nalin Dahyabhai <nalin@redhat.com> 4.3.2-1
612- update translations
613- update copyright strings (only took 10 months!)
614
615* Wed Oct 23 2002 Nalin Dahyabhai <nalin@redhat.com> 4.3.1-1
616- require a version of PAM (0.75-43) which supports $ISA
617- use $ISA in our own PAM config files
618
619* Tue Oct 22 2002 Nalin Dahyabhai <nalin@redhat.com>
620- add $ISA to the name of the directory in which we expect PAMs to be stored
621
622* Fri Sep 20 2002 Nalin Dahyabhai <nalin@redhat.com> 4.3-1
623- build with -fPIC, necessary on some arches
624
625* Tue Sep  3 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.11-3
626- update translations
627
628* Thu Aug 29 2002 Trond Eivind Glomsrød <teg@redhat.com> 4.2.12-2
629- Update translations
630
631* Fri Aug 23 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.11-1
632- modify spacing and layout in authconfig-gtk
633
634* Thu Aug 15 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.10-4
635- translation updates
636- rebuild to pick up dependency changes
637
638* Mon Jul 29 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.10-3
639- include the userhelper configuration file
640- require sufficiently-new pam package in the gui subpackage
641
642* Fri Jul 26 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.10-2
643- actually include the icon in the package
644- translation updates
645
646* Tue Jul 23 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.10-1
647- use desktop-file-install (#69376)
648- include an icon for the menu item (#68577)
649
650* Wed Jul 17 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.9-2
651- own the pkgdatadir
652- pull in translation updates
653
654* Mon Jun  3 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.9-1
655- add --enable-experimental to enable some of that experimental code
656- add --enable-local to enable local policies
657- update translations
658
659* Thu May 30 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-7
660- use the current revision of python by default
661- get the intltool/gettext situation sorted out
662
663* Thu May 23 2002 Tim Powers <timp@redhat.com>
664- automated rebuild
665
666* Fri May  3 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-5
667- remove bogus buildrequires left over from when authconfig-gtk was C code
668- buildrequires python-devel in addition to python (to build the python module,
669  but we still need python to byte-compile the python script)
670
671* Thu Apr 18 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-4
672- add missing translations back in
673- convert .mo files at install-time
674
675* Mon Apr 15 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-3
676- refresh translations
677
678* Wed Apr 10 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-2
679- actually add the .desktop files
680
681* Tue Apr  9 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-1
682- refresh translations
683- destroy the python object correctly
684
685* Tue Mar 26 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.7-2
686- add the .desktop file
687
688* Mon Mar 25 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.7-1
689- rework the auth stack logic to require all applicable auth modules
690
691* Fri Mar  1 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.6-1
692- allow pam_krb5afs to be used for account management, too
693
694* Mon Feb 25 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.5-3
695- refresh translations
696
697* Fri Feb 22 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.5-2
698- refresh translations
699
700* Tue Feb 12 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.5-1
701- actually free authInfo structures when asked to
702- use pam_krb5's account management facilities
703- conflict with versions of pam_krb5 which don't offer account management
704
705* Mon Feb  4 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.4-1
706- add python bindings for the back-end
707- redo the gui so that it exercises the python bindings
708- take a shot at getting authconfig to work in a firstboot container
709
710* Thu Jan 31 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.3-4
711- rebuild again
712
713* Wed Jan 30 2002 Tim Powers <timp@redhat.com> 4.2.3-3
714- rebuilt against new glib
715
716* Wed Jan 23 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.3-2
717- rebuild in new environment
718
719* Thu Jan 10 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.3-1
720- add some more experimental options
721- clean up the glade files a bit
722- don't destroy a garbage pointer on main cancel, destroy the main dialog
723
724* Thu Jan  3 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.2-2
725- bump release and rebuild
726
727* Thu Dec 20 2001 Nalin Dahyabhai <nalin@redhat.com> 4.2.2-1
728- make setting of experimental options only possible through
729  /etc/sysconfig/authconfig, to keep accidents from happening
730- add some more support for experimental stuff
731
732* Tue Dec 11 2001 Nalin Dahyabhai <nalin@redhat.com> 4.2.1-1
733- fix setting of LDAP TLS option in authconfig-gtk
734- change Apply to Ok, Close to Cancel, because that's how they work
735
736* Tue Dec 11 2001 Nalin Dahyabhai <nalin@redhat.com> 4.2-2
737- add the glade XML file to the -gtk subpackage (fix from katzj)
738
739* Mon Dec 10 2001 Nalin Dahyabhai <nalin@redhat.com> 4.2-1
740- port to glib2
741- move post code to the back-end
742- add a libglade GUI in a -gtk subpackage
743- set up to use userhelper
Note: See TracBrowser for help on using the repository browser.