source: projects/specs/trunk/a/authconfig/authconfig-vl.spec @ 12469

Revision 12469, 26.8 KB checked in by tomop, 4 years ago (diff)

python-3.8.5 and related packages.

Line 
1Summary: Command line tool for setting up authentication from network services
2Summary(ja): ネットワークサービスからの認証を設定するためのコマンドラインツール
3Name: authconfig
4Version: 7.0.1
5Release: 3%{?_dist_release}
6Group: admin-tools
7Vendor: Project Vine
8Distribution: Vine Linux
9
10License: GPLv2+
11URL: https://pagure.io/authconfig
12Source: https://releases.pagure.org/%{name}/%{name}-%{version}.tar.bz2
13
14# fedora patches
15Patch1: authconfig-6.2.6-gdm-nolastlog.patch
16Patch2: authconfig-7.0.1-nss-update.patch
17
18# remove selinux stuff
19Patch100: authconfig-7.0.1-noselinux.patch
20
21# elogind patch
22Patch1000: authconfig-7.0.1-elogind.patch
23
24# stop warning flood by tempfile in python3.5
25Patch1001: authconfig-7.0.1-fix-temp-warning.patch
26
27ExclusiveOS: Linux
28BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
29BuildRequires: glib2-devel
30BuildRequires: python3-devel
31BuildRequires: intltool, gettext
32Requires: pam
33Requires: openssl
34Conflicts: samba-common < 3.0, samba-client < 3.0
35Conflicts: nss_ldap < 254
36Obsoletes: authconfig-gtk < 7.0.0
37
38%description
39Authconfig is a command line utility which can configure a workstation
40to use shadow (more secure) passwords.  Authconfig can also configure a
41system to be a client for certain networked user information and
42authentication schemes.
43
44%description -l ja
45authconfig はシャドウ(よりセキュリティーが高い)パスワードの設定をおこなう
46コマンドラインプログラムです。また、ネットワークを介したユーザ情報と認証
47サービスを利用するように設定することもできます。
48
49%prep
50%setup -q -n %{name}-%{version}
51%patch1 -p1
52%patch2 -p1
53%patch1000 -p1
54%patch1001 -p1
55
56%patch100 -p1
57
58perl -pi -e 's|/usr/lib|/lib|' authinfo.py
59
60%build
61CFLAGS="$RPM_OPT_FLAGS -fPIC"; export CFLAGS
62%configure --with-python-rev=3
63make
64
65%install
66rm -rf $RPM_BUILD_ROOT
67make install DESTDIR=$RPM_BUILD_ROOT
68rm $RPM_BUILD_ROOT/%{_libdir}/python*/site-packages/acutil.a
69rm $RPM_BUILD_ROOT/%{_libdir}/python*/site-packages/acutil.la
70
71%find_lang %{name}
72find $RPM_BUILD_ROOT%{_datadir} -name "*.mo" | xargs ./utf8ify-mo
73
74%clean
75rm -rf $RPM_BUILD_ROOT
76
77%post
78authconfig --updateall --nostart &>/dev/null ||:
79
80%triggerin -- authconfig <= 6.2.3
81if [ ! -e %{_sysconfdir}/pam.d/postlogin-ac ]; then
82        authconfig --updateall --nostart >/dev/null 2>&1 || :
83fi
84if [ ! -e %{_sysconfdir}/pam.d/postlogin ]; then
85        cd %{_sysconfdir}/pam.d; \
86        ln -s postlogin-ac postlogin > /dev/null 2>&1 || :
87fi
88
89
90%files -f %{name}.lang
91%defattr(-,root,root,-)
92%license COPYING
93%doc NOTES TODO HOWTO.AD-client
94%ghost %config(noreplace) %{_sysconfdir}/sysconfig/authconfig
95%ghost %config(noreplace) %{_sysconfdir}/pam.d/system-auth-ac
96%ghost %config(noreplace) %{_sysconfdir}/pam.d/password-auth-ac
97%ghost %config(noreplace) %{_sysconfdir}/pam.d/fingerprint-auth-ac
98%ghost %config(noreplace) %{_sysconfdir}/pam.d/smartcard-auth-ac
99%ghost %config(noreplace) %{_sysconfdir}/pam.d/postlogin-ac
100%{_sbindir}/cacertdir_rehash
101%{_sbindir}/authconfig
102%{_mandir}/man8/*
103%{_mandir}/man5/*
104%{_libdir}/python*/site-packages/acutil.so
105%dir %{_datadir}/%{name}
106%{_datadir}/%{name}/authconfig.py*
107%{_datadir}/%{name}/authinfo.py*
108%{_datadir}/%{name}/shvfile.py*
109%{_datadir}/%{name}/dnsclient.py*
110%attr(700,root,root) %dir %{_localstatedir}/lib/%{name}
111
112%changelog
113* Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.1-3
114- rebuilt with python-3.8.
115
116* Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.1-2
117- updated Patch100.
118
119* Sun Dec 16 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.1-1
120- new upstream release.
121- switched to python3.
122- updated Patch100.
123- added elogind support.
124- dropped Patch10 and 11.
125- dropped a subpackage "gtk": no longer supported in the upstream.
126
127* Tue Jun 17 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 6.2.8-2
128- add Patch100 to remove selinux staff (again)
129
130* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.2.8-1
131- update to 6.2.8
132- remove Patch101 (authconfig-6.2.3-authinfo-vine.patch)
133
134* Sat Oct 13 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2.4-1
135- update to 6.2.4
136- run "authconfig --updateall --nostart" on %%post script
137
138* Tue Sep 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.2.3-1
139- update to 6.2.3
140- update Patch10 (authconfig-6.2.3-fprintd-pam.patch)
141- update Patch11 (authconfig-6.2.3-fix-broken-strings.patch)
142- add Patch101 (authconfig-6.2.3-authinfo-vine.patch)
143
144* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.4.10-6
145- rebuild with python-2.7.2
146
147* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 5.4.10-5
148- rebuilt with rpm-4.8.1-3
149
150* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 5.4.10-4
151- rebuilt with python-2.6.4
152
153* Sun Aug 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.10-3
154- update Patch11
155  - old patch does not fix problem on some environment..
156
157* Fri Aug 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.10-2
158- add Patch10
159  - Fingerprint auth requires fprintd-pam package not pam_fprintd
160- add Patch11 to fix broken help messages on some locale.
161
162* Wed May 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.10-1
163- new upstream release
164
165* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.4-1
166- new upstream release
167- historical changelogs are following:
168  * Tue Apr 05 2005 Shu KONNO <owa@bg.wakwak.com> 4.6.1-1vl4
169  - added authconfig-4.6.1-authinfo.patch, by HOTTA Michihide <hotta@net-newbie.com>
170  - added BuildRequires: desktop-file-utils
171  * Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 4.6.1-1vl3
172  - rebuilt with python-2.4.1-0vl1
173  * Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 4.6.1-1vl2
174  - rebuilt with python-2.3.3-0vl1
175  * Mon Apr 12 2004 Shu KONNO <owa@bg.wakwak.com> 4.6.1-1vl1.1
176  - rebuilt with python-2.3.3-0vl0.3 (for TestPkg)
177  * Sun Feb 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-1vl1
178  - updated to 4.6.1
179  - updated Patch0 and Source1
180  - rebuild with new toolchains
181  - Reqyires: glib2, BuildRequires: glib2-devel
182  * Sat Jul 06 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1.19-1vl2
183  - add vinized color palette
184  * Thu Jul 04 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1.19-1vl1
185  - rebuild for Vine Linux
186  - based on Red Hat Linux 7.2, merged with Vine Linux package.
187    * Thu Jun 28 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp>
188    - 3.0.3-1vl5
189    - change checkbox color
190    * Tue Dec 26 2000 Tomoya TAKA <tomoya@olive.plala.or.jp> 3.0.3-1vl4
191    - add %patch1 to fix mandir
192    * Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 3.0.3-1vl3
193    - build with gcc-2.95.3
194    - partially used rpmmacros
195    * Thu Jul 13 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
196    - 3.0.3-1vl2
197    - modified %files section to handle compressed man page
198    * Thu May 11 2000 Jun Nishii <jun@vinelinux.org>
199    - 3.0.3-1vl1
200    - build for Vine
201
202* Tue Aug  5 2008 Tomas Mraz <tmraz@redhat.com> - 5.4.4-1
203- do not call domainname when run with --nostart (#457697)
204
205* Fri Jun  6 2008 Tomas Mraz <tmraz@redhat.com> - 5.4.3-1
206- remove the --enableldapssl alias and add some help to GUI tooltips
207  to clear up some confusion (#220973)
208- add option --enablepreferdns to prefer DNS over NIS or WINS in
209  hostname resolution
210
211* Tue Apr  8 2008 Tomas Mraz <tmraz@redhat.com> - 5.4.2-1
212- read wins setting from nsswitch.conf correctly (#440459)
213- do not ignore --enablemd5/--disablemd5 options
214
215* Tue Mar 11 2008 Tomas Mraz <tmraz@redhat.com> - 5.4.1-1
216- fixed backup directory in Makefile and spec (#437040)
217
218* Mon Mar 10 2008 Tomas Mraz <tmraz@redhat.com> - 5.4.0-1
219- include config-util in console.apps files
220- add support for saving/restoring backups of configuration
221  files affected by authconfig (#433776)
222- improve the authconfig manual page (#432023, #432938)
223
224* Tue Jan 29 2008 Tomas Mraz <tmraz@redhat.com> - 5.3.21-1
225- correct the fix for bug #237956
226
227* Fri Jan 18 2008 Tomas Mraz <tmraz@redhat.com> - 5.3.20-1
228- update translations
229
230* Wed Jan  9 2008 Tomas Mraz <tmraz@redhat.com> - 5.3.19-1
231- support new sha256 and sha512 password hash algorithms
232- add support for pam_mkhomedir (#212790)
233- do not crash in authconfig --help (#237956) - thanks to Andy Shevchenko for
234  the idea how to fix that
235- setup password hash algorithm in /etc/login.defs (#218652)
236- update translations
237
238* Tue Sep 25 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.18-1
239- improve krb5.conf handling (#238766)
240
241* Fri Aug 24 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.17-1
242- remove obsolete pam_krb5afs support (#250704)
243- add support for pam_access (#251360)
244- update translations
245
246* Tue Aug 21 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.16-3
247- license tag fix
248
249* Thu Aug  9 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.16-2
250- require newt-python (#251359)
251
252* Wed Jul 25 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.16-1
253- add support for winbind offline login (#232955)
254
255* Wed Jul 18 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.15-1
256- dnsclient fixes by Simo Sorce
257- add Categories to .desktop file (#245868)
258- fixed traceback when calling joinDomain (#245374)
259- disable smart card action setting when gnome-screensaver
260  not installed (#209643)
261- do not change protocols and services in nsswitch.conf (#236669)
262
263* Tue Jun 12 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.14-1
264- authconfig.8 synopsis fixed (patch by Eric Raymond) (#220574)
265- drop explicit requirement on python version as it is now
266  generated automatically
267- improve writing /etc/samba/smb.conf (based on patch by
268  Simo Sorce)
269- merge changes upstream
270 
271* Fri May  4 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.13-4
272- local nis domain is obtained from sysconfig/network (#235927)
273- set "local authorization is sufficient" on by default
274
275* Thu Apr  5 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.13-3
276- minor changes and cleanups for merge review (#225293)
277
278* Mon Mar 19 2007 Tomas Mraz <tmraz@redhat.com> - 5.3.13-2
279- nss_ldap is now in /usr/lib (#232975)
280
281* Tue Dec 12 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.13-1
282- another traceback in --probe and other fixes (#218874)
283- make smbRealm a default realm when appropriate (#219300)
284- added missing languages in LINGUAS
285
286* Wed Nov 29 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.12-1
287- when pam_krb5 auth fails with smartcard login don't enforce it
288  in the account stack (#214931)
289- updated translations (#216570)
290- winbind should be added only to user tables (#216862)
291
292* Fri Oct 20 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.11-1
293- fixed --smartcardaction command line option (#211552)
294
295* Fri Oct  6 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.10-1
296- fixed passwd PAM stack when PKCS11 enabled (#195960)
297- make authconfig --probe work again (#209676)
298
299* Mon Oct  2 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.9-1
300- updated translations (#207095)
301- correctly write pam_smb.conf with only one server specified (#208365)
302
303* Thu Sep 21 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.8-1
304- move options to another tab to fit on 800x600 screen (#207357)
305
306* Tue Sep 19 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.7-1
307- improve PAM setup for smart card login
308- support smart card login with kerberos (PKINIT)
309- add pam_pkcs11 to password PAM stack
310
311* Mon Sep  4 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.6-1
312- skip pam_unix for session for crond service
313- fixed a bug in saving when smartcard settings changed (#204838)
314- removed allow_ypbind setsebool as it is now handled in ypbind
315
316* Tue Aug 29 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.5-1
317- improve smart card related UI strings
318- removed possibility to set smart card type from authconfig-gtk
319  as only coolkey will be supported for now
320
321* Thu Aug 24 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.4-1
322- pass options given to authconfig-gtk to authconfig (#203955)
323
324* Sun Jul 23 2006 Ray Strode <rstrode@redhat.com> - 5.3.3-2
325- write out new "wait_for_card" config option if we're
326  forcing smart card authentication
327- add "use_uid" option to smart card pam_succeed_if line to
328  work around bug where pam_succeed_if checks user information
329  even in cases where the conditional doesn't depend on it.
330- remove unimplemented "logout" smart card removal action from
331  settings
332- remove unnecessary "card_only" argument
333
334* Fri Jul 21 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.3-1
335- don't start sceventd when smartcard login is enabled
336- improve pam config for smartcard login
337
338* Tue Jul 18 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.2-1
339- don't require pam_pkcs11 to run
340
341* Tue Jul 18 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.1-1
342- screensavers should be authenticated by smartcard too
343- add feature to download a CA certificate for LDAP from
344  an URL (#197103)
345- add pam_keyinit session module to the PAM configuration (#198638)
346
347* Fri Jul  7 2006 Tomas Mraz <tmraz@redhat.com> - 5.3.0-1
348- added support for smartcard authentication
349- fixed parsing kerberos realms
350
351* Thu May 18 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.5-1
352- write ldap servers as URIs and not HOSTs (#191842)
353- fix a typo in --test output
354- updated summary, converted changelog to UTF-8
355
356* Fri May 12 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.4-1
357- added crond to the services restarted after firstboot (#187334)
358- when checking nscd status redirect output to /dev/null (#188555)
359
360* Tue Mar 21 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.3-1
361- make smb.conf and krb5.conf loading more robust (#185766)
362
363* Mon Feb 27 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.2-1
364- add try_first_pass option to pam_unix for better integration
365  with individual service configurations (#182350)
366- updated translations
367
368* Mon Feb 20 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.1-1
369- don't crash in TUI when some options aren't set (#182151)
370
371* Fri Feb  3 2006 Tomas Mraz <tmraz@redhat.com> - 5.2.0-1
372- redesigned GUI (#178112)
373- added man page for system-config-ac (#179584)
374- disable authentication of system accounts by network services
375  by default, added option for changing that (#179009)
376- updated translations, new languages
377
378* Mon Jan  9 2006 Tomas Mraz <tmraz@redhat.com> - 5.1.2-1
379- fixed regression when saving nsswitch.conf
380
381* Fri Jan  6 2006 Tomas Mraz <tmraz@redhat.com> - 5.1.1-1
382- print warning if PAM module is missing when the PAM configuration
383  is saved (#168880)
384
385* Fri Dec 23 2005 Tomas Mraz <tmraz@redhat.com>
386- make child dialog preset code more robust (#176462)
387
388* Sat Dec 17 2005 Tomas Mraz <tmraz@redhat.com> - 5.1.0-1
389- update only configuration files which settings were modified (#72290)
390
391* Mon Dec  5 2005 Tomas Mraz <tmraz@redhat.com> - 5.0.4-1
392- don't ignore krb5realm command line option (#174838)
393- read dns_lookup_realm and dns_lookup_kdc values correctly
394- the PAM configuration is now written in system-auth-ac file
395  which is then symlinked from system-auth, the symlink is not
396  overwritten so local PAM configuration is now possible (#165342)
397
398* Mon Nov  7 2005 Tomas Mraz <tmraz@redhat.com> - 5.0.3-1
399- add symlinks to python scripts in sbindir
400- don't override nullok setting from system-auth (#96996)
401
402* Fri Oct 14 2005 Tomas Mraz <tmraz@redhat.com> - 5.0.2-1
403- authinfo-tui.py is now symlink
404- reword the CA certificate message (#154317)
405- use include instead of pam_stack in pam config
406- don't break yp.conf with multiple domains (#127306)
407
408* Mon Sep  5 2005 Tomas Mraz <tmraz@redhat.com> - 5.0.1-1
409- fixed a few errors catched by pychecker
410
411* Sat Sep  3 2005 Tomas Mraz <tmraz@redhat.com> - 5.0.0-1
412- C code completely rewritten in Python
413- some bugs fixed in the process (and no doubt new introduced)
414- TUI deprecated, opens only when run as authconfig-tui
415
416* Mon Jun 20 2005 Tomas Mraz <tmraz@redhat.com> - 4.6.13-1
417- set domain and ypserver option correctly when multiple servers
418  specified in kickstart (#159214)
419
420* Tue Apr 12 2005 Tomas Mraz <tmraz@redhat.com> - 4.6.12-1
421- replaced deprecated gtk.TRUE/FALSE (#153034)
422- updated translations
423
424* Mon Mar 14 2005 Tomas Mraz <tmraz@redhat.com>
425- propagate the --enablewinbindauth option to the configuration (#151018)
426
427* Fri Mar  4 2005 Tomas Mraz <tmraz@redhat.com> - 4.6.11-1
428- changed version propagation
429
430* Thu Mar  3 2005 Tomas Mraz <tmraz@redhat.com>
431- updated translations
432- fixed build on gcc4
433
434* Wed Feb 23 2005 Tomas Mraz <tmraz@redhat.com> - 4.6.10-1
435- updated translations
436
437* Thu Feb 10 2005 Tomas Mraz <tmraz@redhat.com> - 4.6.9-1
438- improved the code that writes tls_cacertdir to ldap.conf
439
440* Tue Jan 25 2005 Tomas Mraz <tmraz@redhat.com>
441- renamed functions in authconfigmodule to be more clear
442- implemented cacertdir for LDAP with TLS
443
444* Mon Jan 24 2005 Tomas Mraz <tmraz@redhat.com>
445- fixed a bug in authinfo_differs when called from python
446
447* Fri Dec 17 2004 Tomas Mraz <tmraz@redhat.com> - 4.6.8-1
448- add option for making local authorization sufficient for local users
449  this is attempt to 'solve/workaround' the problem with blocking local logins by
450  pulling out network cable (#115181)
451
452* Wed Dec 15 2004 Tomas Mraz <tmraz@redhat.com>
453- remove dependency on nscd
454- don't show warning messages when switching options off
455
456* Mon Dec  6 2004 Tomas Mraz <tmraz@redhat.com> - 4.6.7-1
457- updated translations
458- winbind in authconfig-gtk.py was setting the nsswitch.conf on the auth tab
459- use GtkComboBox instead of deprecated GtkOptionMenu
460- disable options with not installed binaries, remove unnecessary deps of
461  authconfig-gtk
462
463* Thu Nov 18 2004 Tomas Mraz <tmraz@redhat.com> - 4.6.6-1
464- merged patches from dist
465- fix versioning
466
467* Mon Nov  8 2004 Jeremy Katz <katzj@redhat.com> - 4.6.5-6
468- rebuild against python 2.4
469
470* Thu Oct 28 2004 Dan Walsh <dwalsh@redhat.com>
471- Fix setsebool patch to turn off boolean
472
473* Thu Oct 28 2004 Dan Walsh <dwalsh@redhat.com>
474- Add setsebool for NIS
475
476* Fri Oct 15 2004 Tomas Mraz <tmraz@redhat.com>
477- force broken_shadow option on network auth (#136760)
478
479* Fri Oct 15 2004 Tomas Mraz <tmraz@redhat.com>
480- force restart of autofs on firstboot call when using NIS (#133035, #124498)
481
482* Thu Oct 07 2004 Tomas Mraz <tmraz@redhat.com>
483- require python to install (#134654)
484
485* Mon Oct 04 2004 Jindrich Novy <jnovy@redhat.com> 4.6.5-1
486- updated translations from upstream
487- autogeneration of build stripts in prep phase
488
489* Thu Sep 30 2004 Jindrich Novy <jnovy@redhat.com>
490- fixed man page
491- added dependency on nscd
492
493* Wed Sep 29 2004 Jindrich Novy <jnovy@redhat.com> 4.6.4-6
494- regenerated build scripts
495
496* Wed Sep 29 2004 Jindrich Novy <jnovy@redhat.com> 4.6.4-5
497- fixed all po files to translate correctly messages with modified accelerators (#133742)
498- added translations for Arabic, Bulgarian and other languages (#133716, #133158)
499
500* Wed Sep 22 2004 Jindrich Novy <jnovy@redhat.com> 4.6.4-4
501- added "quiet" option to pam_success_if PAM module in sytem-auth (#133179)
502
503* Mon Sep 13 2004 Jindrich Novy <jnovy@redhat.com> 4.6.4-3
504- corrected package dependencies #132411
505- regenerated glade.strings.h #132369
506
507* Wed Aug 25 2004 Jindrich Novy <jnovy@redhat.com> 4.6.4-2
508- modified authconfig-gtk interface to fit lower resolution screens (#127175)
509- modified accelerators in authconfig-gtk (#125797)
510- updated package dependencies (#125306)
511
512* Tue Aug 24 2004 Jindrich Novy <jnovy@redhat.com>
513- updated configure scripts
514- warnfixes and minor hacks
515
516* Mon Jun  7 2004 Nalin Dahyabhai <nalin@redhat.com> 4.6.4-1
517- tweak account management to fix #55193 correctly
518- require anything we might want to run in the gui subpackage because it
519  doesn't warn about missing things and you don't have a terminal to see
520  error messages about missing commands
521- properly display the domain in the GUI join dialog (#124621)
522
523* Tue May 11 2004 Nalin Dahyabhai <nalin@redhat.com> 4.6.3-1
524- omit the "ads" or "rpc" when calling "net join", Samba's smarter now (#122802)
525- properly warn about missing "net" (samba-client) and libnss_winbind and
526  pam_winbind (samba-common) in text mode (#122802)
527
528* Wed Apr 21 2004 Nalin Dahyabhai <nalin@redhat.com> 4.6.2-1
529- learn all about pam_passwdqc
530- preserve arguments to pam_cracklib and pam_passwdqc
531- short-circuit PAM authorization checks for users with UID < 100
532- remove redhat-config-authentication as a way to invoke the GUI tool (#115977)
533
534* Fri Feb  6 2004 Nalin Dahyabhai <nalin@redhat.com> 4.6.1-1
535- fix man page: --enableldapssl should be --enableldaptls
536- make --enableldapssl an alias for --enableldaptls
537
538* Thu Jan  8 2004 Nalin Dahyabhai <nalin@redhat.com> 4.6-1
539- authconfig-gtk.py: require rhpl, which is required by the script (#104209)
540- both: require usermode (authconfig-gtk transitively), else leave a dangling
541  symlink (#104209)
542- the great redhat-config-authentication/system-config-authentication renaming,
543  as was foretold in the fedora-config-list archives
544
545* Wed Jan  7 2004 Nalin Dahyabhai <nalin@redhat.com>
546- preserve "compat" if it's used in /etc/nsswitch.conf
547
548* Tue Nov 18 2003 Nalin Dahyabhai <nalin@redhat.com> 4.4-1
549- add options for toggling krb5's use of DNS
550
551* Mon Nov 17 2003 Nalin Dahyabhai <nalin@redhat.com>
552- rework tui to include winbind options. there wasn't enough room in the old
553  dialog to include the important options, so the whole thing's been reworked
554
555* Thu Nov 13 2003 Nalin Dahyabhai <nalin@redhat.com>
556- conflict with older versions of samba which expect different configuration
557
558* Mon Nov 10 2003 Nalin Dahyabhai <nalin@redhat.com>
559- initial support for configuring winbind
560
561* Tue Oct 28 2003 Nalin Dahyabhai <nalin@redhat.com>
562- make pam_cracklib requisite instead of required in generated PAM configs
563
564* Wed Oct 22 2003 Bill Nottingham <notting@redhat.com> 4.3.8-1
565- rebuild with current translations
566
567* Thu Aug 21 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.7-2
568- make the tarball name include the release number
569
570* Thu Aug 21 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.7-1
571- authconfig-gtk: condrestart certain additional services if invoked with
572  the --firstboot flag (half of #91268, needs cooperating firstboot)
573- translation updates
574
575* Mon Jul  7 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.6-1
576- translation updates
577
578* Mon Jun 30 2003 Nalin Dahyabhai <nalin@redhat.com>
579- add 'redhat-config-authentication' as an alias for authconfig-gtk
580- make authconfig-gtk exec authconfig if gui startup fails and it looks like
581  we're connected to a tty
582
583* Thu Jun 05 2003 Elliot Lee <sopwith@redhat.com>
584- rebuilt
585
586* Mon May  5 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.5-1
587- translation updates
588- close unusable file descriptors if locking fails
589
590* Tue Feb 18 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.4-1
591- learn how to toggle defaults/crypt_style in /etc/libuser.conf (#79337)
592
593* Fri Feb  7 2003 Nalin Dahyabhai <nalin@redhat.com> 4.3.3-1
594- look in /lib64 for modules for nsswitch and PAM by default on
595  x86_64, ppc64, and s390x (#83049)
596
597* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
598- rebuilt
599 
600* Mon Nov  4 2002 Nalin Dahyabhai <nalin@redhat.com> 4.3.2-1
601- update translations
602- update copyright strings (only took 10 months!)
603
604* Wed Oct 23 2002 Nalin Dahyabhai <nalin@redhat.com> 4.3.1-1
605- require a version of PAM (0.75-43) which supports $ISA
606- use $ISA in our own PAM config files
607
608* Tue Oct 22 2002 Nalin Dahyabhai <nalin@redhat.com>
609- add $ISA to the name of the directory in which we expect PAMs to be stored
610
611* Fri Sep 20 2002 Nalin Dahyabhai <nalin@redhat.com> 4.3-1
612- build with -fPIC, necessary on some arches
613
614* Tue Sep  3 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.11-3
615- update translations
616
617* Thu Aug 29 2002 Trond Eivind Glomsrød <teg@redhat.com> 4.2.12-2
618- Update translations
619
620* Fri Aug 23 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.11-1
621- modify spacing and layout in authconfig-gtk
622
623* Thu Aug 15 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.10-4
624- translation updates
625- rebuild to pick up dependency changes
626
627* Mon Jul 29 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.10-3
628- include the userhelper configuration file
629- require sufficiently-new pam package in the gui subpackage
630
631* Fri Jul 26 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.10-2
632- actually include the icon in the package
633- translation updates
634
635* Tue Jul 23 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.10-1
636- use desktop-file-install (#69376)
637- include an icon for the menu item (#68577)
638
639* Wed Jul 17 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.9-2
640- own the pkgdatadir
641- pull in translation updates
642
643* Mon Jun  3 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.9-1
644- add --enable-experimental to enable some of that experimental code
645- add --enable-local to enable local policies
646- update translations
647
648* Thu May 30 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-7
649- use the current revision of python by default
650- get the intltool/gettext situation sorted out
651
652* Thu May 23 2002 Tim Powers <timp@redhat.com>
653- automated rebuild
654
655* Fri May  3 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-5
656- remove bogus buildrequires left over from when authconfig-gtk was C code
657- buildrequires python-devel in addition to python (to build the python module,
658  but we still need python to byte-compile the python script)
659
660* Thu Apr 18 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-4
661- add missing translations back in
662- convert .mo files at install-time
663
664* Mon Apr 15 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-3
665- refresh translations
666
667* Wed Apr 10 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-2
668- actually add the .desktop files
669
670* Tue Apr  9 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.8-1
671- refresh translations
672- destroy the python object correctly
673
674* Tue Mar 26 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.7-2
675- add the .desktop file
676
677* Mon Mar 25 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.7-1
678- rework the auth stack logic to require all applicable auth modules
679
680* Fri Mar  1 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.6-1
681- allow pam_krb5afs to be used for account management, too
682
683* Mon Feb 25 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.5-3
684- refresh translations
685
686* Fri Feb 22 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.5-2
687- refresh translations
688
689* Tue Feb 12 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.5-1
690- actually free authInfo structures when asked to
691- use pam_krb5's account management facilities
692- conflict with versions of pam_krb5 which don't offer account management
693
694* Mon Feb  4 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.4-1
695- add python bindings for the back-end
696- redo the gui so that it exercises the python bindings
697- take a shot at getting authconfig to work in a firstboot container
698
699* Thu Jan 31 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.3-4
700- rebuild again
701
702* Wed Jan 30 2002 Tim Powers <timp@redhat.com> 4.2.3-3
703- rebuilt against new glib
704
705* Wed Jan 23 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.3-2
706- rebuild in new environment
707
708* Thu Jan 10 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.3-1
709- add some more experimental options
710- clean up the glade files a bit
711- don't destroy a garbage pointer on main cancel, destroy the main dialog
712
713* Thu Jan  3 2002 Nalin Dahyabhai <nalin@redhat.com> 4.2.2-2
714- bump release and rebuild
715
716* Thu Dec 20 2001 Nalin Dahyabhai <nalin@redhat.com> 4.2.2-1
717- make setting of experimental options only possible through
718  /etc/sysconfig/authconfig, to keep accidents from happening
719- add some more support for experimental stuff
720
721* Tue Dec 11 2001 Nalin Dahyabhai <nalin@redhat.com> 4.2.1-1
722- fix setting of LDAP TLS option in authconfig-gtk
723- change Apply to Ok, Close to Cancel, because that's how they work
724
725* Tue Dec 11 2001 Nalin Dahyabhai <nalin@redhat.com> 4.2-2
726- add the glade XML file to the -gtk subpackage (fix from katzj)
727
728* Mon Dec 10 2001 Nalin Dahyabhai <nalin@redhat.com> 4.2-1
729- port to glib2
730- move post code to the back-end
731- add a libglade GUI in a -gtk subpackage
732- set up to use userhelper
Note: See TracBrowser for help on using the repository browser.